Subject: [MMUSIC] RE: [Sip-implementors] SIP and FAX

From: "Manivannan S, TLS-Chennai" <[email-masked]>
Date: Thu, 28 Jun 2007 18:43:02 +0530

Thanks Gaurav,

I get some information from this RFC, but I need call flow involved in
FAX over SIP. I have found a
draft(draft-ietf-sipping-realtimefax-01.txt), but it is expired. Any
latest RFC/draft explaining the call flow of FAX t.38 over SIP.

Thanks,
S. Manivannan

-----Original Message-----
From: Gaurav Kheterpal [mailto:[email-masked]] 
Sent: Thursday, June 28, 2007 4:20 PM
To: Manivannan S, TLS-Chennai; [email-masked];
[email-masked]
Subject: RE: [Sip-implementors] SIP and FAX

You can refer to:-

* RFC 4612 - Real-Time Facsimile (T.38) - audio/t38 MIME Sub-type
Registration

* http://www.iana.org/assignments/sdp-parameters

* ITU-T T.38 Annexure D, Section 9

* draft-andreasen-mmusic-sdp-capability-negotiation-reqts-00 - SDP
Capability Negotiation: Requirements and Review of Existing Work

Regards,
Gaurav

> -----Original Message-----
> From: [email-masked] [mailto:sip- 
> [email-masked]] On Behalf Of Manivannan S,

> TLS-Chennai
> Sent: Thursday, June 28, 2007 2:45 PM
> To: [email-masked]; [email-masked]; Manivannan S, 
> TLS- Chennai
> Subject: [Sip-implementors] SIP and FAX
> 
> 
> Hi all,
> 
> 
> 
> Could anybody tell me which latest RFC/draft is explaining FAX T.38 
> over SIP and SDP? I have googled and found only expired drafts.
> 
> 
> 
> Thanks,
> 
> S. Manivannan
> 
> 
> 
> DISCLAIMER:
> ----------------------------------------------------------------------
> ----
> ---------------------------------------------
> 
> The contents of this e-mail and any attachment(s) are confidential and

> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its 
> affiliates. Any views or opinions presented in this email are solely 
> those of the author and may not necessarily reflect the opinions of 
> HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure, 
> modification, distribution and / or publication of this message 
> without the prior written consent of the author of this e- mail is 
> strictly prohibited. If you have received this email in error please 
> delete it and notify the sender immediately. Before opening any mail 
> and attachments please check them for viruses and defect.
> 
> ----------------------------------------------------------------------
> ----
> ---------------------------------------------
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Fri, 29 Jun 2007 14:02:17 -0600

Hi,

S. Manivannan
> FAX over SIP.
A call flow is only informative.

Meir Leshem
> As far as I know, draft-ietf-sipping-realtimefax-01 (which is expired
> of
> course) is the de-facto standard for negotiation of fax handling (T.38
> and fallback to G.711) in SIP.
draft-ietf-sipping-realtimefax-01 is dead, RIP. As one of the original
authors of the sipping draft, I guess I should chime in. 
This old draft was put together back in 1999 when voip gateways started
to implement t.38 fax and it helped in the first sipit where we tested
fax way back then. The itu specs were also not stable and it helped
debug issues and get some interop going. But this is now over and the
draft should not be used as a reference: it was a work-in-progress.
It was rightly decided by the sipping chairs at the time that the draft
was about SDP attributes for t38 fax and then RFC 3362 was published,
and then rfc4612. 
That said, the old draft is still used by many folks to understand that
you got to start with an audio session, wait for the fax whistling and
some specific triggers to perform tone detection then switch to an
appropriate codec (g711 fallback or switch to another one). Note that
with super G3 fax machines, modem/voice band data, T.38v3 and V.152,
implementers have a couple more options to transport fax/mode calls
reliably and it's gotten a little bit more interesting. Also, in some
networks, g711 just works fine.

Colin wrote:
> RFC 4612?
Yes. This adds mime types for t.38 over rtp; many implementations still
use udptl. It's been a while I moved away from this but the itu
Recommendation should be reference spec (annex D?).

Jean-Francois.

> [email-masked]] On Behalf Of Meir Leshem
> Sent: Thursday, June 28, 2007 8:45 AM
> To: Manivannan S, TLS-Chennai; Gaurav Kheterpal; sip-
> [email-masked]; [email-masked]
> Subject: Re: [Sip-implementors] SIP and FAX
> 
> Hi,
> 
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of
> Manivannan S, TLS-Chennai
> Sent: Thursday, June 28, 2007 4:13 PM
> To: Gaurav Kheterpal; [email-masked];
> [email-masked]
> Subject: Re: [Sip-implementors] SIP and FAX
> 
> Thanks Gaurav,
>

---

From: "Gaurav Kheterpal" <[email-masked]>
Date: Thu, 28 Jun 2007 16:19:34 +0530

You can refer to:-

Regards,
Gaurav

> To: [email-masked]; [email-masked]; Manivannan S, TLS-
> Chennai
> Could anybody tell me which latest RFC/draft is explaining FAX T.38 over
> SIP and SDP? I have googled and found only expired drafts.
> 
> 
> 
> Thanks,
> 
> S. Manivannan
> 
> 
> 
> DISCLAIMER:
> --------------------------------------------------------------------------
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily reflect
> the opinions of HCL or its affiliates.
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this e-
> mail is strictly prohibited. If you have
> received this email in error please delete it and notify the sender
> immediately. Before opening any mail and
> attachments please check them for viruses and defect.
> 
> --------------------------------------------------------------------------
> ____________From [email-masked] Sat Jun 30 08:11:46 2007
From: "Gaurav Kheterpal" <[email-masked]>
To: "'Manivannan S, TLS-Chennai'" <[email-masked]>,
	<[email-masked]>, <[email-masked]>
Date: Thu, 28 Jun 2007 16:19:34 +0530
Cc: 
Subject: [MMUSIC] RE: [Sip-implementors] SIP and FAX

You can refer to:-

Regards,
Gaurav

> To: [email-masked]; [email-masked]; Manivannan S, TLS-
> Chennai
> Could anybody tell me which latest RFC/draft is explaining FAX T.38 over
> SIP and SDP? I have googled and found only expired drafts.
> 
> 
> 
> Thanks,
> 
> S. Manivannan
> 
> 
> 
> DISCLAIMER:
> --------------------------------------------------------------------------
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily reflect
> the opinions of HCL or its affiliates.
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this e-
> mail is strictly prohibited. If you have
> received this email in error please delete it and notify the sender
> immediately. Before opening any mail and
> attachments please check them for viruses and defect.
> 
> --------------------------------------------------------------------------

---

From: "Meir Leshem" <[email-masked]>
Date: Thu, 28 Jun 2007 17:45:14 +0300

Hi,
As far as I know, draft-ietf-sipping-realtimefax-01 (which is expired of
course) is the de-facto standard for negotiation of fax handling (T.38
and fallback to G.711) in SIP. 

Regards
Meir Leshem
Veraz Networks

-----Original Message-----
To: Gaurav Kheterpal; [email-masked]; [email-masked]

Thanks Gaurav,

Thanks,
S. Manivannan

-----Original Message-----
From: Gaurav Kheterpal [mailto:[email-masked]] 
Sent: Thursday, June 28, 2007 4:20 PM
To: Manivannan S, TLS-Chennai; [email-masked];
[email-masked]

You can refer to:-

* draft-andreasen-mmusic-sdp-capability-negotiation-reqts-00 - SDP
Capability Negotiation: Require___________________________________

---

From: "Meir Leshem" <[email-masked]>
Date: Thu, 28 Jun 2007 17:45:14 +0300

Hi,

Regards
Meir Leshem
Veraz Networks

-----Original Message-----

Thanks Gaurav,

Thanks,
S. Manivannan

-----Original Message-----
From: Gaurav Kheterpal [mailto:[email-masked]] 
Sent: Thursday, June 28, 2007 4:20 PM
To: Manivannan S, TLS-Chennai; [email-masked];
[email-masked]

You can refer to:-

Regards,
Gaurav

ments and Review of Existing Work

Regards,
Gaurav