Subject: [MMUSIC] ICE Question: Sharing the same IP between two UAs on different networks

From: "Diego B" <[email-masked]>
Date: Fri, 27 Jul 2007 01:43:11 +0300

Hi;
I apologies if this question is out of scope or
not relevant.

After the tutorial I was thinking about the case
where UA1 and UA2 share the same private IP but in different networks.
lets say UA1 in acme.com and UA2 in foo.com.
What will be the situation here ?
UA1 and UA2 will send media to their own IP ? or
ICE will recognize the problem in one of the protocol steps ?
or may be this situation can not happen at all.

Another similar question is if
UA1 and UA2 are in the same network
and UA3 in a different network but with the same private IP range.

UA1 has the same IP than UA3.
UA2 makes a call to UA3.
In the UA3's SDP UA2 will see the private IP of UA3 that is the same as UA1,
so if UA2 proves that IP there can be a chance that UA1 answers to UA2 requests.

what will be the scenario here ? UA2 will ends up sending media to UA1 ?
or this path will be discarded for some reason ?

Thanks
Diego B

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Gustavo García <[email-masked]>
Date: Fri, 27 Jul 2007 01:03:11 +0200

Hi Diego,

> or may be this situation can not happen at all.

A UA could detect this situation and avoid sending connectivity checks to
its own IP address, but even if the UA send the STUN connectivity checks to
its own IP address, the connectivity checks will not succeed because the
STUN credentials that will use in the checks won't be valid. (i.e. UA1 will
send to itself requests using the STUN password received from UA2).

" STUN connectivity checks between agents are authenticated using the
   short term credential mechanism defined for STUN
   [I-D.ietf-behave-rfc3489bis]."
 
> so if UA2 proves that IP there can be a chance that UA1 answers to UA2

The connectivity checks will not succeed in this scenario either.

> Diego B

BR,
G.