Subject: [MMUSIC] Propose A Non-18x Provisional Response Used for ICE Connectivity Check

From: <[email-masked]>
Date: Thu, 29 Nov 2007 13:50:33 +0800

Hi, there:

In section 12, “Usage with SIP”, ICE-19 suggests the use of rfc3262 (100rel extension) for reliable provisional responses with SDP transmission as well as an ICE optimization by sending 18x with SDP 4 times ‘till receiving an ICE binding request (section. 12.1.1 “Offer in INVITE”). 

Prior to ICE invention, a terminal (such as an SIP IP phone) may locally generate ringback tone to notify its user upon receiving a 180 provisional response; and it will cease playing locally generated ringback tone upon receiving a 183 with SDP (even when a 180 with SDP) because the far-end side may decide to send call-progress tone or an audio announcement in an early media stream.  Generally, a 183 with SDP is reliably or unreliably transmitted by a PSTN gateway to transmit PSTN-side call-progress tone (it may be just a tone or some music) in an early media. 

Therefore, the reliable provisional 1xx responses with SDP transmitted aimed for ICE-connectivity check should not use 180~184 provisional responses; otherwise, the terminals receiving such 18x provisional responses while making outbound calls may wrongly cease playing locally generated ringback tone even such 18x reliable provisional responses are for ICE connectivity check instead of for far-end side call-progress tones. 

I would suggest explicitly nail down or recommend another non-18x provisional response for such ICE usage in the revised ICE-20. 

Albert

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 29 Nov 2007 10:35:00 -0500

The caller in this case is obviously ICE aware. It should know that ICE
will cause an immediate provisional response with SDP and that this is
not to be interpreted as pending arrival of in-band media.

There are known issues with interpreting 183 with SDP as 'pending
in-band media'. See RFC 3960 for a discussion of some of this.

-Jonathan R.

[email-masked] wrote:
> Hi, there:
> 
>  
> 
> In section 12, “Usage with SIP”, ICE-19 suggests the use of rfc3262 
> (100rel extension) for reliable provisional responses with SDP 
> transmission as well as an ICE optimization by sending 18x with SDP 4 
> times ‘till receiving an ICE binding request (section. 12.1.1 “Offer in 
> INVITE”).
> 
> Prior to ICE invention, a terminal (such as an SIP IP phone) may locally 
> generate ringback tone to notify its user upon receiving a 180 
> provisional response; and it will cease playing locally generated 
> ringback tone upon receiving a 183 with SDP (even when a 180 with SDP) 
> because the far-end side may decide to send call-progress tone or an 
> audio announcement in an early media stream.  Generally, a 183 with SDP 
> is reliably or unreliably transmitted by a PSTN gateway to transmit 
> PSTN-side call-progress tone (it may be just a tone or some music) in an 
> early media.
> 
> Therefore, the reliable provisional 1xx responses with SDP transmitted 
> aimed for ICE-connectivity check should not use 180~184 provisional 
> responses; otherwise, the terminals receiving such 18x provisional 
> responses while making outbound calls may wrongly cease playing locally 
> generated ringback tone even such 18x reliable provisional responses are 
> for ICE connectivity check instead of for far-end side call-progress tones.
> 
> I would suggest explicitly nail down or recommend another non-18x 
> provisional response for such ICE usage in the revised ICE-20.
> 
>  
> 
>  
> 
> Albert
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com