Subject: [MMUSIC] Re: [Sip] SIP IPv6 ABNF: Essential correction to RFC3261

From: Colin Perkins <[email-masked]>
Date: Mon, 19 Nov 2007 22:44:02 +0000

Can someone familiar with the issue also check the ABNF in RFC 4566  
(SDP)? From a quick look, it seems that it has a similar problem...

Colin

On 19 Nov 2007, at 19:38, Adam Roach wrote:
> For the record: this seems to be a real problem in the original  
> ABNF, and the proposed fix appears correct to me. I support adding  
> this to the next batch of essential corrections.
>
> /a
>
> Vijay K. Gurbani wrote:
>> Folks: While performing the Gen-ART review of the
>> draft-ietf-sipping-ipv6-torture-test document, an extant bug in
>> the IPv6 ABNF production rules of RFC3261 was discovered.
>>
>> A quick dialog with the chairs resulted in the understanding
>> that this could potentially be fixed as part of the SIP essential
>> corrections process, once it was ratified by the WG.
>>
>> Brian and I have submitted a short draft describing this bug and
>> its resolution to the IETF.  Until it appears in the archives, you
>> can get a copy from
>> https://svn.resiprocate.org/rep/ietf-drafts/gurbani/sip-ipv6-abnf/ 
>> draft-gurbani-sip-ipv6-abnf-fix-00.txt
>> https://svn.resiprocate.org/rep/ietf-drafts/gurbani/sip-ipv6-abnf/ 
>> draft-gurbani-sip-ipv6-abnf-fix-00.html
>>
>> Thanks.
>>
>> - vijay

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Adam Roach <[email-masked]>
Date: Mon, 19 Nov 2007 16:56:28 -0600

> (SDP)? From a quick look, it seems that it has a similar problem...

By my readying, you are correct -- the ABNF rules in 4566 suffer from 
the same flaw. From an ANBF perspective, I would propose that the 
solution is the same as Vijay and Brian detail in their draft. From a 
process perspective, I don't know how to handle it (outside of the 
relatively invisible RFC errata process).

/a

>> For the record: this seems to be a real problem in the original ABNF, 
>> and the proposed fix appears correct to me. I support adding this to 
>> the next batch of essential corrections.
>>
>> /a
>>
>> Vijay K. Gurbani wrote:
>>> https://svn.resiprocate.org/rep/ietf-drafts/gurbani/sip-ipv6-abnf/draft-gurbani-sip-ipv6-abnf-fix-00.txt 
>>>
>>> https://svn.resiprocate.org/rep/ietf-drafts/gurbani/sip-ipv6-abnf/draft-gurbani-sip-ipv6-abnf-fix-00.html 
>>>
>>>
>>> Thanks.
>>>
>>> - vijay
>
>

---

From: Colin Perkins <[email-masked]>
Date: Tue, 20 Nov 2007 11:52:47 +0000

On 19 Nov 2007, at 22:56, Adam Roach wrote:
>> Can someone familiar with the issue also check the ABNF in RFC  
>> 4566 (SDP)? From a quick look, it seems that it has a similar  
>> problem...
>
> By my readying, you are correct -- the ABNF rules in 4566 suffer  
> from the same flaw. From an ANBF perspective, I would propose that  
> the solution is the same as Vijay and Brian detail in their draft.  
> From a process perspective, I don't know how to handle it (outside  
> of the relatively invisible RFC errata process).

If the MMUSIC chairs agree, I could submit draft-ietf-mmusic- 
rfc4566bis-00.txt after the meeting, with just this fix. That can be  
kept alive for a couple of years, collecting any other bug fixes  
found, and eventually be published as an updated RFC.

-- 
Colin Perkins
http://csperkins.org/

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 20 Nov 2007 09:01:19 -0600

> (SDP)? From a quick look, it seems that it has a similar problem...

Colin: Yes, it appears to.  Insofar as the rfc4566 ABNF is based on
rfc2373 Appendix B, it will have similar problems.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs