Subject: [MMUSIC] Abnormal termination

From: <[email-masked]>
Date: Tue, 26 Aug 2008 08:41:47 +0300

Hi All,

If during an active  stream the server wants to terminate the
connection. How should it inform the client?
(TEARDOWN is allowed only from Client to Server.)

Regards,

Amit Yedidia
Elbit System Ltd.

Email: [email-masked]
Tel: 972-4-8318905
----------------------------------------------------------

The information in this e-mail transmission contains proprietary and business 
sensitive information.  Unauthorized interception of this e-mail may constitute 
a violation of law. If you are not the intended recipient, you are hereby 
notified that any review, dissemination, distribution or duplication of this 
communication is strictly prohibited. You are also asked to contact the sender 
by reply email and immediately destroy all copies of the original message.
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Ankit Kumar Jalori <[email-masked]>
Date: Tue, 26 Aug 2008 11:17:28 +0530

Dear Amit,

            In case server wants to terminate the connection it can send RTCP BYE packet to the client

            in response to which client can terminate the connection.

Regards,

Ankit Kumar Jalori
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 26, 2008 11:27 AM
To: [email-masked]
Subject: [MMUSIC] Abnormal termination

Hi All,

If during an active  stream the server wants to terminate the connection. How should it inform the client?

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: <[email-masked]>
Date: Tue, 26 Aug 2008 08:56:25 +0300

Dear Ankit,
 
Thank\ you for your answer,
To be more specific, your proposal is :
 
1.The Server sends RTCP BYE
2. In response the Client sends TEARDOWN
3. The Serevr reply with 200 ok.
 
is that correct?

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

From: Ankit Kumar Jalori [mailto:[email-masked]] 
Sent: Tuesday, August 26, 2008 8:47 AM
To: Yedidia Amit
Cc: [email-masked]
Subject: RE: Abnormal termination

Dear Amit,

            In case server wants to terminate the connection it can send
RTCP BYE packet to the client

Regards,

Ankit Kumar Jalori

From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Tuesday, August 26, 2008 11:27 AM
To: [email-masked]
Subject: [MMUSIC] Abnormal termination

Hi All,

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

sensitive information.  Unauthorized interception of this e-mail may
constitute 
a violation of law. If you are not the intended recipient, you are
hereby 
notified that any review, dissemination, distribution or duplication of
this 
communication is strictly prohibited. You are also asked to contact the
sender 
by reply email and immediately destroy all copies of the original
message.

"DISCLAIMER: This message is proprietary to Aricent and is intended
solely for the use of the individual to whom it is addressed. It may
contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended.
If you have received this message in error,please notify the originator
immediately. If you are not the intended recipient, you are notified
that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. Aricent accepts no
responsibility forloss or damage arising from the use of the information
transmitted by this email including damage from virus."

---

From: Ankit Kumar Jalori <[email-masked]>
Date: Tue, 26 Aug 2008 11:37:09 +0530

Dear Amit,

            That's right,

            Ideally when server wants to gracefully terminate the connection it should inform client by sending RTCP BYE which in turn

should make client send TEARDOWN.

But there are some cases where some servers mistakenly send BYE packets but still keep on sending data in that case

there should be check for this scenario.

Regards,

Ankit Kumar Jalori
________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 26, 2008 11:41 AM
To: Ankit Kumar Jalori
Cc: [email-masked]
Subject: RE: Abnormal termination

Dear Ankit,

is that correct?

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

Regards,

Ankit Kumar Jalori

Hi All,

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

---

From: <[email-masked]>
Date: Tue, 26 Aug 2008 09:36:51 +0300

Dear Ankit,
 
what's happened when the Server wants to terminate session regardless to
the Client response

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

From: Ankit Kumar Jalori [mailto:[email-masked]] 
Sent: Tuesday, August 26, 2008 9:07 AM
To: Yedidia Amit
Cc: [email-masked]
Subject: RE: Abnormal termination

Dear Amit,

            That's right,

            Ideally when server wants to gracefully terminate the
connection it should inform client by sending RTCP BYE which in turn 

But there are some cases where some servers mistakenly send BYE packets
but still keep on sending data in that case

Regards,

Ankit Kumar Jalori

From: [email-masked]
[mailto:[email-masked]] 
Sent: Tuesday, August 26, 2008 11:41 AM
To: Ankit Kumar Jalori
Cc: [email-masked]
Subject: RE: Abnormal termination

Dear Ankit,

is that correct?

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

 

Dear Amit,

Regards,

Ankit Kumar Jalori

Hi All,

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

---

From: Ankit Kumar Jalori <[email-masked]>
Date: Tue, 26 Aug 2008 12:14:28 +0530

Dear Amit,

            Server can simply close the connection if it does not want graceful close.

            When client does not see any data coming from server for a specific period then it can assume the connection has lost.

Regards,

Ankit Kumar Jalori
________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 26, 2008 12:22 PM
To: Ankit Kumar Jalori
Cc: [email-masked]
Subject: RE: Abnormal termination

Dear Ankit,

what's happened when the Server wants to terminate session regardless to the Client response

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

            That's right,

Regards,

Ankit Kumar Jalori

Dear Ankit,

is that correct?

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905

Regards,

Ankit Kumar Jalori

Hi All,

Regards,

Amit Yedidia

Elbit System Ltd.

Tel: 972-4-8318905