Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-media-loopback-19.txt

From: [email-masked]
Date: Thu, 12 Jul 2012 21:48:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title           : An Extension to the Session Description Protocol (SDP) and Real-time Transport Protocol (RTP) for Media Loopback
	Author(s)       : Hadriel Kaplan
                          Kaynam Hedayat
                          Nagarjuna Venna
                          Paul E. Jones
                          Nathan Stratton
	Filename        : draft-ietf-mmusic-media-loopback-19.txt
	Pages           : 33
	Date            : 2012-07-12

Abstract:
    The wide deployment of Voice over IP (VoIP), Text and Video over IP
    services has introduced new challenges in managing and maintaining
    real-time voice/text/video quality, reliability, and overall
    performance.  In particular, media delivery is an area that needs
    attention.  One method of meeting these challenges is monitoring
    the media delivery performance by looping media back to the
    transmitter.  This is typically referred to as "active monitoring"
    of services.   Media loopback is especially popular in ensuring the
    quality of transport to the edge of a given VoIP, Real-time Text or
    Video over IP service.  Today in networks that deliver real-time
    media, short of running 'ping' and 'traceroute' to the edge,
    administrators are left without the necessary tools to actively
    monitor, manage, and diagnose quality issues with their service.
    The extension defined herein adds new SDP media types and
    attributes, which enable establishment of media sessions where the
    media is looped back to the transmitter. Such media sessions will
    serve as monitoring and troubleshooting tools by providing the
    means for measurement of more advanced VoIP, Real-time Text and
    Video over IP performance metrics.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-media-loopback

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-19

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-mmusic-media-loopback-19

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 13 Jul 2012 05:06:50 +0000

Howdy,
Based on the emails/comments from the WGLC, I have posted a revised media-loopback draft.  I believe this addresses all opened issues, and in general covers the following changes:

1) Feedback from media mime types reviewer on section 13 (now section 14).  Changes based on:
http://www.ietf.org/mail-archive/web/ietf-types/current/msg01649.html

2) Many editorial corrections from Flemming, based on:
http://www.ietf.org/mail-archive/web/mmusic/current/msg09295.html

3) Non-contentious comments from Magnus have been addressed, based on:
http://www.ietf.org/mail-archive/web/mmusic/current/msg09300.html

4) Congestion control issue - it appears "let the loopback source do it" was the rough consensus, so it has been changed. (well... clarified)  The thread started here:
http://www.ietf.org/mail-archive/web/mmusic/current/msg09305.html

5) Secretly replaced the fine coffee the IETF usually serves, with Folgers Crystals.

6) SRTP is now covered in a small new section.

7) Author list has been reduced to 5 authors.

If you are not happy with the changes let me know (or rather let this mailing list know).

-hadriel

On Jul 13, 2012, at 12:48 AM, <[email-masked]>
 <[email-masked]> wrote:

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 13 Jul 2012 13:28:35 +0200

Hi Hadriel:

Thanks a lot for getting this new revision. We are almost done!!!

I hereby invite those who made comments during the WGLC to verify that 
they are satisfied with their resolution. If we don't here any feedback 
within a week (July 20th), we will understand everything is correct, and 
we will proceed to request publication of this draft.

/Miguel

On 13/07/2012 7:06, Hadriel Kaplan wrote:
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Kevin Gross <[email-masked]>
Date: Sat, 14 Jul 2012 15:41:39 -0600

I am not happy about the coffee change!

Kevin Gross

On Fri, Jul 13, 2012 at 5:28 AM, Miguel A. Garcia <
[email-masked]> wrote:

> within a week (July 20th), we will understand everything is correct, and we
> will proceed to request publication of this draft.
>
> /Miguel
>
>
>> Based on the emails/comments from the WGLC, I have posted a revised
>> media-loopback draft.  I believe this addresses all opened issues, and in
>> general covers the following changes:
>>
>> http://www.ietf.org/mail-**archive/web/ietf-types/**current/msg01649.html<http://www.ietf.org/mail-archive/web/ietf-types/current/msg01649.html>
>>
>> http://www.ietf.org/mail-**archive/web/mmusic/current/**msg09295.html<http://www.ietf.org/mail-archive/web/mmusic/current/msg09295.html>
>>
>> http://www.ietf.org/mail-**archive/web/mmusic/current/**msg09300.html<http://www.ietf.org/mail-archive/web/mmusic/current/msg09300.html>
>>
>> 4) Congestion control issue - it appears "let the loopback source do it"
>> was the rough consensus, so it has been changed. (well... clarified)  The
>> thread started here:
>> http://www.ietf.org/mail-**archive/web/mmusic/current/**msg09305.html<http://www.ietf.org/mail-archive/web/mmusic/current/msg09305.html>
>>
>>>         Title           : An Extension to the Session Description
>>> Protocol (SDP) and Real-time Transport Protocol (RTP) for Media Loopback
>>>         Filename        : draft-ietf-mmusic-media-**loopback-19.txt
>>>         Pages           : 33
>>>         Date            : 2012-07-12
>>>
>>> Abstract:
>>> https://datatracker.ietf.org/**doc/draft-ietf-mmusic-media-**loopback<https://datatracker.ietf.org/doc/draft-ietf-mmusic-media-loopback>
>>>
>>> http://tools.ietf.org/html/**draft-ietf-mmusic-media-**loopback-19<http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-19>
>>>
>>> http://tools.ietf.org/rfcdiff?**url2=draft-ietf-mmusic-media-**
>>> loopback-19<http://tools.ietf.org/rfcdiff?url2=draft-ietf-mmusic-media-loopback-19>
>>>
>>>
>>> ftp://ftp.ietf.org/internet-**drafts/<ftp://ftp.ietf.org/internet-drafts/>
>>>
>>> ______________________________**_________________
>>> https://www.ietf.org/mailman/**listinfo/i-d-announce<https://www.ietf.org/mailman/listinfo/i-d-announce>
>>> Internet-Draft directories: http://www.ietf.org/shadow.**html<http://www.ietf.org/shadow.html>
>>> or ftp://ftp.ietf.org/ietf/**1shadow-sites.txt<ftp://ftp.ietf.org/ietf/1shadow-sites.txt>
>>>
>>
>> ______________________________**_________________
>> mmusic mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/mmusic<https://www.ietf.org/mailman/listinfo/mmusic>
>>
>>
>>
> --
> Miguel A. Garcia
> +34-91-339-3608
> Ericsson Spain
>
>
>
> ______________________________**_________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/mmusic<https://www.ietf.org/mailman/listinfo/mmusic>
>

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 20 Jul 2012 13:47:51 +0200

We haven't received any comments on this week of review of the changes of 
this last version of the media loopback. We believe the draft is ready 
for publication request now.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Gunnar Hellström <[email-masked]>
Date: Fri, 20 Jul 2012 20:57:15 +0200

I am happy with the resolution and glad to see the progress.

/Gunnar

___________________________________________________
Gunnar Hellström
Omnitor
[email-masked]

On 2012-07-20 13:47, Miguel A. Garcia wrote:
> We haven't received any comments on this week of review of the changes 
> of this last version of the media loopback. We believe the draft is 
> ready for publication request now.
>
> /Miguel
>
>>> media-loopback draft.  I believe this addresses all opened issues, 
>>> and in general covers the following changes:
>>>
>>> 4) Congestion control issue - it appears "let the loopback source do 
>>> it" was the rough consensus, so it has been changed. (well... 
>>> clarified)  The thread started here: