Subject: [MMUSIC] [Technical Errata Reported] RFC4566 (3278)

From: RFC Errata System <[email-masked]>
Date: Tue, 3 Jul 2012 11:01:16 -0700 (PDT)

The following errata report has been submitted for RFC4566,
"SDP: Session Description Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4566&eid=3278

--------------------------------------
Type: Technical
Reported by: Riccardo Bernardini <[email-masked]>

Section: 5

Original Text
-------------
At page 9:

      Media description, if present
         m=  (media name and transport address)

Corrected Text
--------------

      Media description, if present
         m=* (media name and transport address)

Notes
-----
A '*' is added making "m=" lines optional

Rationale: 
The description about media lines in section 5, page 9 is conflicting with the ABNF syntax of media-description in Section 9, page 40

media-descriptions =  *( media-field
                         information-field
                         *connection-field
                         bandwidth-fields
                         key-field
                         attribute-fields )

According to the ABNF grammar, an SDP description can have zero "m=" lines, but according to the description at page 9, at least one line must be present.  Note that the conflict could be solved also by replacing the media-descriptions definition with 

   media-descriptions =  1*( media-field ... )

but at page 8 (still Section 5) it is said

   An SDP session description consists of a session-level section
   followed by zero or more media-level sections. ...
               ^^^^^^^^^^^^^^^^^^^^^^^^

so, I guess that the ABNF grammar is correct.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4566 (draft-ietf-mmusic-sdp-new-26)
--------------------------------------
Title               : SDP: Session Description Protocol
Publication Date    : July 2006
Author(s)           : M. Handley, V. Jacobson, C. Perkins
Category            : PROPOSED STANDARD
Source              : Multiparty Multimedia Session Control
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 4 Jul 2012 11:12:40 +0200

I am adding Ali Begen to the loop, who is the current editor of 4566bis.

Ali, can you please comment on the technical errata?

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 6 Jul 2012 08:01:12 +0000

All,

I think this errata should be rejected.

The text on page 9 is pretty clear and I don't see a conflict with the ABNF.
 
Under "Session description" it is explicitly stated that you can have zero or more media descriptions (as well as time descriptions)
Further down under "Media description, if present" it is elaborated what a media description includes. 
It must at least include exactly one m-line. The a,b,k,i,c-lines are optional.
Adding the asterisk as proposed would remove this subtlety.
The same technique is used for "Time description". The t-line is mandatory, the r-lines are optional. 

BTW: Being able to provide zero media descriptions is crucial for certain implementations. An example is tunneling QSIG in SIP.

Regards
Thomas  

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von RFC Errata System
> Gesendet: Dienstag, 03. Juli 2012 20:01
> An: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Betreff: [MMUSIC] [Technical Errata Reported] RFC4566 (3278)
> 
> 
> The description about media lines in section 5, page 9 is 
> conflicting with the ABNF syntax of media-description in 
> Section 9, page 40
> 
> According to the ABNF grammar, an SDP description can have 
> zero "m=" lines, but according to the description at page 9, 
> at least one line must be present.  Note that the conflict 
> could be solved also by replacing the media-descriptions 
> definition with 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Riccardo Bernardini <[email-masked]>
Date: Fri, 06 Jul 2012 11:39:34 +0200

"Stach, Thomas" <[email-masked]> ha scritto:

> Under "Session description" it is explicitly stated that you can  
> have zero or more media descriptions (as well as time descriptions)

OK, let me try to rephrase it: the media-description BLOCK is OPTIONAL  
and you can have zero media-description blocks; but the "m=" line is  
MANDATORY whenever you have a media-description block. Maybe this was  
the reason of my confusion: I interpreted the missing asterisk as  
``you cannot have SDP descriptions without m= lines,''  while I should  
have read ``m= lines are mandatory within a media block, but an SDP  
without m= lines is OK as long as you have no media blocks.'' I guess  
that "if present" part should clarify this, but it escaped me, sorry.   
Note that this type of subtlety does not happen with t= lines since,  
according to the ABNF, at least one "time-fields" block must be present.

OK, I can see why the text on page 9 is correct.

Regards

Riccardo

>
> BTW: Being able to provide zero media descriptions is crucial for  
> certain implementations. An example is tunneling QSIG in SIP.
>
> Regards
> Thomas
>

-- 
Riccardo Bernardini
DIEGM -- University of Udine
via delle Scienze 208
33100 Udine
Tel: +39-0432-55-8271
Fax: +39-0432-55-8251

----------------------------------------------------------------------
SEMEL (SErvizio di Messaging ELettronico) - AINF, Universita' di Udine

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Sat, 7 Jul 2012 22:55:12 +0000

I agree with Thomas' assessment. I don’t see a problem with the current ABNF.

> -----Original Message-----
> From: Miguel A. Garcia [mailto:[email-masked]]
> Sent: Wednesday, July 04, 2012 5:13 AM
> To: RFC Errata System; Ali C. Begen (abegen)
> Cc: [email-masked]; [email-masked]; [email-masked]; Gonzalo Camarillo; [email-masked];
> Flemming Andreasen (fandreas); [email-masked]; [email-masked]
> Subject: Re: [Technical Errata Reported] RFC4566 (3278)
> 
> > According to the ABNF grammar, an SDP description can have zero "m=" lines, but according to the description at page 9,
> at least one line must be present.  Note that the conflict could be solved also by replacing the media-descriptions definition
> with
> >
> >
> >

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Mon, 9 Jul 2012 09:14:00 +0200

Hi Thomas:

I am also copying Ali, who is currently editing 4566bis.

This comment is as an individual. I see your point, and I believe you are 
right as well. The text needs to be read as a whole: The "Session 
Description" indicates that "Zero or more media descriptions" can follow. 
And the text then says "Media description, if present". So, if there is a 
media description present, the "m=" line is mandatory, thus, there is no 
asterisk close to it.

BR,

         Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain