Subject: [MMUSIC] IETF#89: BUNDLE: Q9: What are the criteria for allowing usage of the same PT value within multiple m- lines? - Episode III

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 18:20:45 +0000

Hi,

Based on some further off-line discussions, I have the following suggestion:

Q1: Identical PT values in initial Offer

We allow an offerer to include identical PT values already in the initial offer.

BUT, we also MANDATE BUNDLE entities to support SOME mechanism (offerer determined) which can be used to distinguish received media. At this point we don't need to decide what "SOME" is. It could be SSRC, "AppId", or something else.

If an BUNDLE endpoint doesn't want to, or for some reason can't use "SOME", it will have to terminate the BUNDLE group and fall back to individual 5-tuple for each m- line.

Does anyone have a problem with this approach?

Q2: Codec configuration

People are ok to allow PT value re-usage for the same "codec configuration", but it means that we need text what that means (Colin sent something). I do NOT want to word smith text during the presentation.

Regards,

Christer

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 3 Mar 2014 18:30:09 +0000

Hello Christer

  Please see inline

Thanks
Suhas

On Mon, Mar 3, 2014 at 6:20 PM, Christer Holmberg <
[email-masked]> wrote:

> *Q1: Identical PT values in initial Offer*
>
>
>
 BUT, we also MANDATE BUNDLE entities to support SOME mechanism (offerer
> determined) which can be used to distinguish received media. At this point
> we don't need to decide what "SOME" is. It could be SSRC, "AppId", or
> something else.
>
>
>
[Suhas] Agree on the SOME need not be decided now and I feel it is out of
scope of the BUNDLE draft

>  If an BUNDLE endpoint doesn't want to, or for some reason can't use
> "SOME", it will have to terminate the BUNDLE group and fall back to
> individual 5-tuple for each m- line.
>
>
>

 [Suhas] Seems alright but the first point seems too conservative as
explained below

 If an BUNDLE endpoint doesn't want to use identical PT values, it can
still use unique PT values and be in the BUNDLE group unless it has
exhausted the PT space.

But I am OK with the proposed solution if everyone agrees.

>
>
>
>
>
> *Q2: Codec configuration*
>
>
>
> People are ok to allow PT value re-usage for the same "codec
> configuration", but it means that we need text what that means (Colin sent
> something). I do NOT want to word smith text during the presentation.
>
>
>
 [Suhas] +1 ..

>  Regards,
>
>
>
> Christer
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 3 Mar 2014 18:37:35 +0000

Hi,

Q1: Identical PT values in initial Offer
We allow an offerer to include identical PT values already in the initial offer.
BUT, we also MANDATE BUNDLE entities to support SOME mechanism (offerer determined) which can be used to distinguish received media. At this point we don't need to decide what "SOME" is. It could be SSRC, "AppId", or something else.
[Suhas] Agree on the SOME need not be decided now and I feel it is out of scope of the BUNDLE draft

I didn't suggest that it is out of scope of the BUNDLE draft (we can for sure discuss that also) - only that we don't need to decide what SOME is at this point.

 [Suhas] Seems alright but the first point seems too conservative as explained below

 If an BUNDLE endpoint doesn't want to use identical PT values, it can still use unique PT values and be in the BUNDLE group unless it has exhausted the PT space.

I should have been more clear. I was referring to an endpoint receiving an offer with identical PT values, but does not want to, or can't, use the SOME mechanism. In such case the endpoint will have to fallback.

Regards,

Christer

Q2: Codec configuration

 [Suhas] +1 ..

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 3 Mar 2014 18:59:21 +0000

Thanks Christer. That makes it clear :)

Cheers
Suhas

On Mon, Mar 3, 2014 at 6:37 PM, Christer Holmberg <
[email-masked]> wrote:

> I didn't suggest that it is out of scope of the BUNDLE draft (we can for
> sure discuss that also) - only that we don't need to decide what SOME is at
> this point.
>
>
>
>
>
> I should have been more clear. I was referring to an endpoint receiving an
> offer with identical PT values, but does not want to, or can't, use the
> SOME mechanism. In such case the endpoint will have to fallback.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>