Subject: [MMUSIC] Comment on the ICE updated offer procedures

From: "Stach, Thomas" <[email-masked]>
Date: Sun, 2 Mar 2014 20:08:23 +0000

Ari,

the slides  for IETF 89 propose that always an updated offer shall be sent.
You also mention the issues with that as listed in draft-elwell-mmusic-ice-updated-offer.
This was also discussed in IETF 80.
Draft-elwell-mmusic-ice-updated-offer acknowledges that there are middle boxes that need such updated offer to work properly.
However, there are also cases and other types of middle boxes that break or show undesirable behavior, just because of the updated offer.
Because of these issues, I think that always sending the updated offer should not be required.
Instead, it should be made configurable if the updated offer is sent or not sent, possibly together with some signaling (ice-options/ice-options-required?) which behavior is to be applied.

Regards
Thomas

---

From: Ari Keränen <[email-masked]>
Date: Sun, 2 Mar 2014 22:22:44 +0000

Hi Thomas,

> Instead, it should be made configurable if the updated offer is sent or not sent, possibly together with some signaling (ice-options/ice-options-required?) which behavior is to be applied.

Having this configurable and defaulting to always doing the updated offer makes sense to me. And perhaps this should be then signaled in an ice-options-optional since it should not affect whether aggressive nomination can be used or not.

Cheers,
Ari

---

From: "Stach, Thomas" <[email-masked]>
Date: Wed, 5 Mar 2014 11:03:35 +0000

> > Draft-elwell-mmusic-ice-updated-offer acknowledges that there are middle
> boxes that need such updated offer to work properly.
> > However, there are also cases and other types of middle boxes that break or
> show undesirable behavior, just because of the updated offer.
> > Instead, it should be made configurable if the updated offer is sent or not
> sent, possibly together with some signaling (ice-options/ice-options-
> required?) which behavior is to be applied.
> 
> Having this configurable and defaulting to always doing the updated offer
> makes sense to me. And perhaps this should be then signaled in an ice-options-
> optional since it should not affect whether aggressive nomination can be used
> or not.

[TS] Yes, defaulting to doing the updated offer seems reasonable since 5245 agents would do it anyhow in most cases.
I agree that aggressive nomination shouldn't be impacted, so using a tag in ice-options-optional is fine.
Thanks
Thomas