Subject: [MMUSIC] Bundle: Q13 receiver-Id

From: "Roni Even" <[email-masked]>
Date: Fri, 7 Mar 2014 12:50:12 +0200

Hi,

In draft-even-mmusic-application-token-02
<http://tools.ietf.org/html/draft-even-mmusic-application-token-02>  there
is a recv-appId token that can be used as the receiver-Id. Based on the
discussion in the meeting it seems that the recv-appId  usage  will be
needed for the case when the offerer receives media before the SDP answer
and can use the recv-appId to identify the correlation to an m-line / RTP
stream   in the SDP.  This will also works for the same PT number.

Roni

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 7 Mar 2014 13:33:47 +0000

Thank you for the input, Roni!

I assume that, for the purpose of associating media with an m- line, an entity would not need to support the OTHER attributes in the draft, right?

Regards,

Christer

Sent from Windows Mail

From: Roni Even<mailto:[email-masked]>
Sent: ‎Friday‎, ‎7‎ ‎March‎ ‎2014 ‎12‎:‎50
To: 'mmusic'<mailto:[email-masked]>

Hi,
In draft-even-mmusic-application-token-02<http://tools.ietf.org/html/draft-even-mmusic-application-token-02> there is a recv-appId token that can be used as the receiver-Id. Based on the discussion in the meeting it seems that the recv-appId  usage  will be needed for the case when the offerer receives media before the SDP answer and can use the recv-appId to identify the correlation to an m-line / RTP stream   in the SDP.  This will also works for the same PT number.

Roni

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Mar 2014 07:56:44 +0000

Hi,

If people are ok with using the mechanism in Roni's draft, please indicate so.

Please also indicate if you are NOT ok to use it, or you think there is another mechanism we should at least verify.

Please also indicate if you don't care what mechanism we use - just to make sure we get community input :)

Note that if the "receiver-id" will require a new draft, the publication of BUNDLE will be dependent of that draft, so I think we should make a decision which way to go asap.

Regards,

Christer

________________________________
From: mmusic [[email-masked]] on behalf of Christer Holmberg [[email-masked]]
Sent: Friday, 07 March 2014 3:33 PM
To: Roni Even; 'mmusic'
Subject: Re: [MMUSIC] Bundle: Q13 receiver-Id

Regards,

Christer

Sent from Windows Mail

Hi,

Roni

---

From: Justin Uberti <[email-masked]>
Date: Tue, 11 Mar 2014 21:45:35 -0700

application-token is currently the only mechanism that has been proposed. I
am OK with using it for BUNDLE.

On Tue, Mar 11, 2014 at 12:56 AM, Christer Holmberg <
[email-masked]> wrote:

> Please also indicate if you are NOT ok to use it, or you think there is
> another mechanism we should at least verify.
>
> Note that if the "receiver-id" will require a new draft, the publication
> of BUNDLE will be dependent of that draft, so I think we should make a
> decision which way to go asap.
>
> Regards,
>
> Christer
>
>
>  ------------------------------
> *From:* mmusic [[email-masked]] on behalf of Christer Holmberg [
> [email-masked]]
> *Sent:* Friday, 07 March 2014 3:33 PM
> *To:* Roni Even; 'mmusic'
> *Subject:* Re: [MMUSIC] Bundle: Q13 receiver-Id
>
>  I assume that, for the purpose of associating media with an m- line, an
> entity would not need to support the OTHER attributes in the draft, right?
>
>  Regards,
>
>  Christer
>
>  Sent from Windows Mail
>
>   *From:* Roni Even <[email-masked]>
> *Sent:* ‎Friday‎, ‎7‎ ‎March‎ ‎2014 ‎12‎:‎50
> *To:* 'mmusic' <[email-masked]>
>
>   Hi,
>
> In draft-even-mmusic-application-token-02<http://tools.ietf.org/html/draft-even-mmusic-application-token-02>there is a recv-appId token that can be used as the receiver-Id. Based on
> the discussion in the meeting it seems that the recv-appId  usage  will be
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 20 Mar 2014 11:55:29 -0400

> If people are ok with using the mechanism in Roni's draft, please

Yes, I'm in favor of this.
Based on the comments, there is work to do on that draft, but it in on 
track to provide the right semantics.

	Thanks,
	Paul

> ------------------------------------------------------------------------
> *From:* mmusic [[email-masked]] on behalf of Christer Holmberg
> [[email-masked]]
> *From:* Roni Even <mailto:[email-masked]>
> *To:* 'mmusic' <mailto:[email-masked]>
>
> Hi,
>
> <http://tools.ietf.org/html/draft-even-mmusic-application-token-02>
> there is a recv-appId token that can be used as the receiver-Id. Based
> on the discussion in the meeting it seems that the recv-appId  usage
>   will be needed for the case when the offerer receives media before the
> SDP answer and can use the recv-appId to identify the correlation to an
> m-line / RTP stream   in the SDP.  This will also works for the same PT
> number.
>
> Roni
>
>
>