Subject: [MMUSIC] m-line recycling

From: Eric Rescorla <[email-masked]>
Date: Sun, 11 May 2014 21:50:18 -0700

The JSEP spec specifies m-line recycling:

 o  If any MediaStreamTracks have been added, and there exist m=
      sections of the appropriate media type with no associated
      MediaStreamTracks (i.e. as described in the preceding paragraph),
      those m= sections MUST be recycled by adding the new
      MediaStreamTrack to the m= section.  This is done by adding the
      necessary "a=msid", "a=ssrc", and "a=ssrc-group" lines to the
      recycled m= section, and removing the "a=recvonly" attribute.

Based on the minutes from IETF 89, we were going to take this to mmusic.

http://etherpad.tools.ietf.org:9000/p/notes-ietf-89-rtcweb?useMonospaceFont=true

Thoughts?

-Ekr

https://github.com/rtcweb-wg/jsep/issues/21

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 12 May 2014 06:54:26 +0000

Hi,

I don’t think it should be a MUST – at least not only based on the media type. Because, there may be other properties than the media type associated with the “m=” line, why one does not want to use it for the specific MST.

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: 12. toukokuuta 2014 7:50
To: mmusic WG; [email-masked]
Subject: [MMUSIC] m-line recycling

Thoughts?

-Ekr

---

From: Martin Thomson <[email-masked]>
Date: Mon, 12 May 2014 07:43:30 -0700

Yes, some words about being compatible and all that entails are required if
we intend to stipulate it being reused. Either that or we can say MAY. The
need for a strong definition diminishes then.
On May 11, 2014 11:54 PM, "Christer Holmberg" <
[email-masked]> wrote:

>  Hi,
>
>
>
> I don’t think it should be a MUST – at least not only based on the media
> type. Because, there may be other properties than the media type associated
> with the “m=” line, why one does not want to use it for the specific MST.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>
>
>
> *From:* mmusic [mailto:[email-masked]] *On Behalf Of *Eric
> Rescorla
> *Sent:* 12. toukokuuta 2014 7:50
> *To:* mmusic WG; [email-masked]
> *Subject:* [MMUSIC] m-line recycling
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Justin Uberti <[email-masked]>
Date: Sun, 18 May 2014 20:37:44 -0700

One option could be to only reuse m= lines that both sides have stopped
using (i.e. port=0, as opposed to a=sendonly/recvonly). This provides most
of the benefits of recycling without having to deal with the notion of
'compatible'.

On Mon, May 12, 2014 at 7:43 AM, Martin Thomson <[email-masked]>wrote:

> Yes, some words about being compatible and all that entails are required
> if we intend to stipulate it being reused. Either that or we can say MAY.
> The need for a strong definition diminishes then.
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 19 May 2014 04:49:49 +0000

Hi,

>One option could be to only reuse m= lines that both sides have stopped using (i.e. port=0, as >opposed to a=sendonly/recvonly). This provides most of the benefits of recycling without >having to deal with the notion of 'compatible'.

Are you suggesting a MUST reuse such m= line, if available?

Regards,

Christer

On Mon, May 12, 2014 at 7:43 AM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

Yes, some words about being compatible and all that entails are required if we intend to stipulate it being reused. Either that or we can say MAY. The need for a strong definition diminishes then.
On May 11, 2014 11:54 PM, "Christer Holmberg" <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: mmusic [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Eric Rescorla
Sent: 12. toukokuuta 2014 7:50
To: mmusic WG; [email-masked]<mailto:[email-masked]>
Subject: [MMUSIC] m-line recycling

Thoughts?

-Ekr

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Justin Uberti <[email-masked]>
Date: Mon, 19 May 2014 05:37:36 -0700

yes

On Sun, May 18, 2014 at 9:49 PM, Christer Holmberg <
[email-masked]> wrote:

> using (i.e. port=0, as >opposed to a=sendonly/recvonly). This provides
> most of the benefits of recycling without >having to deal with the notion
> of 'compatible'.
>
>
>