Subject: Re: [MMUSIC] [rtcweb] ICE-Mismatch and WebRTC

From: "Stach, Thomas" <[email-masked]>
Date: Mon, 14 Jul 2014 13:43:45 +0000

I think this makes sense, but just for clarity some thoughts inline…

From: rtcweb [mailto:[email-masked]] On Behalf Of Roman Shpount
Sent: Freitag, 11. Juli 2014 23:21
To: Emil Ivov
Cc: [email-masked]
Subject: Re: [rtcweb] ICE-Mismatch and WebRTC

I would agree with:

1. Must fail if c=/m= line IP does not match any candidate. Must also fail if rtcp attribute does not match any RTCP candidates.
[TS] What to do if this is only the case for one m-line, but not for others?
2. Must fail if "ice-mismatch" attribute is present same as no ICE
[TS] ICE-mismatch is a media-level attribute. What if you have an ice-mismatch for just one m-line, but not for others?

3. Port 0 in m= line to disable the line must be understood
[TS] Yes. Of course, if the m-line is disabled it should not carry candidates and thus an ice-mismatch should not occur for that m-line.

4. c= line with 0.0.0.0 must fail
[TS] Again, MUST fail in case of all m-lines or already for a single m-line?

Does this make sense?
_____________
Roman Shpount

---

From: Roman Shpount <[email-masked]>
Date: Mon, 14 Jul 2014 13:56:43 -0400

On Mon, Jul 14, 2014 at 9:43 AM, Stach, Thomas <[email-masked]>
wrote:

> *From:* rtcweb [mailto:[email-masked]] *On Behalf Of *Roman
> Shpount
> *Sent:* Freitag, 11. Juli 2014 23:21
> *To:* Emil Ivov
> *Cc:* [email-masked]
> *Subject:* Re: [rtcweb] ICE-Mismatch and WebRTC
>
>
>
> I would agree with:
>
>
>
> 1. Must fail if c=/m= line IP does not match any candidate. Must also fail
> if rtcp attribute does not match any RTCP candidates.
>

It should fail if this is the case for any m= line. Offer/Answer updates
are atomic, so if information for one line is broken, the whole update
should fail.

> [TS] ICE-mismatch is a media-level attribute. What if you have an
> ice-mismatch for just one m-line, but not for others?
>

It should fail if ice-mismatch is present on any m= line. Same reason as
above.

>  [TS] Yes. Of course, if the m-line is disabled it should not carry
> candidates and thus an ice-mismatch should not occur for that m-line.
>
>
>

It should fail if 0.0.0.0 is present on any m-line. Same reason as above.

_____________
Roman Shpount