Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

From: [email-masked]
Date: Thu, 14 Jan 2016 06:32:57 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

        Title           : A Framework for SDP Attributes when Multiplexing
        Author          : Suhas Nandakumar
	Filename        : draft-ietf-mmusic-sdp-mux-attributes-12.txt
	Pages           : 96
	Date            : 2016-01-14

Abstract:
   The Session Description Protocol (SDP) provides mechanisms to
   describe attributes of multimedia sessions and of individual media
   streams (e.g., Real-time Transport Protocol (RTP) sessions) within a
   multimedia session.  Typically media associated with individual media
   descriptions ("m=" lines) represent RTP sessions and are thus carried
   over individual underlying transport layer flows.  For scenarios
   where SDP is used to negotiate the usage of single 5-tuple for
   sending and receiving media associated with multiple media
   descriptions, it is required to understand the semantic implications
   of the SDP attributes associated with the RTP Media Streams
   multiplexed over a single underlying transport layer flow.

   The purpose of this specification is to provide a framework for
   analyzing the multiplexing characteristics of SDP attributes.  This
   specification also categorizes the existing SDP attributes based on
   the framework described herein.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-mmusic-sdp-mux-attributes-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-sdp-mux-attributes-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 14 Jan 2016 06:34:19 -0800

Hello All

This version fixes couple of ID nits and updates the references to the
latest RFCs.

Cheers
suhas

On Thu, Jan 14, 2016 at 6:32 AM, <[email-masked]> wrote:

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Bo Burman <[email-masked]>
Date: Thu, 14 Jan 2016 16:08:34 +0000

Thank you Suhas,

I believe this version addresses all comments provided, has no remaining nits, and I thus intend to use it for the publication request.

Cheers,
/Bo
MMUSIC co-chair

From: mmusic [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: den 14 januari 2016 15:34
To: [email-masked]
Cc: mmusic WG; [email-masked]
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

Hello All

This version fixes couple of ID nits and updates the references to the latest RFCs.

Cheers
suhas

On Thu, Jan 14, 2016 at 6:32 AM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 14 Jan 2016 20:06:30 +0000

Hold on :)

Some time ago there was a question from Taylor Brandstetter. Was that solved? The topic mentioned BUNDLE, but I think the question was also related to the sdp-mux-attribute draft.

http://www.ietf.org/mail-archive/web/mmusic/current/msg15421.html

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Bo Burman
Sent: 14 January 2016 18:09
To: Suhas Nandakumar <[email-masked]>
Cc: mmusic WG <[email-masked]>
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

Thank you Suhas,

Cheers,
/Bo
MMUSIC co-chair

From: mmusic [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: den 14 januari 2016 15:34
To: [email-masked]<mailto:[email-masked]>
Cc: mmusic WG; [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

Hello All

Cheers
suhas

Abstract:

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 14 Jan 2016 12:50:43 -0800

Thanks Christer for bringing this to our notice. I just responded to
Taylor's clarification question and I don't  think the response to his
question changes any of the behavior for BUNDLE or MUX.

Please let me know your thoughts on my response.

Thanks
Suhas

On Thu, Jan 14, 2016 at 12:06 PM, Christer Holmberg <
[email-masked]> wrote:

> Hold on :)
>
>
>
> Some time ago there was a question from Taylor Brandstetter. Was that
> solved? The topic mentioned BUNDLE, but I think the question was also
> related to the sdp-mux-attribute draft.
>
>
>
> *From:* mmusic [mailto:[email-masked]] *On Behalf Of *Bo Burman
> *Sent:* 14 January 2016 18:09
> *To:* Suhas Nandakumar <[email-masked]>
> *Cc:* mmusic WG <[email-masked]>
>
> *Subject:* Re: [MMUSIC] I-D Action:
> draft-ietf-mmusic-sdp-mux-attributes-12.txt
>
>
>
> Thank you Suhas,
>
>
>
> I believe this version addresses all comments provided, has no remaining
> nits, and I thus intend to use it for the publication request.
>
>
>
> Cheers,
>
> /Bo
>
> MMUSIC co-chair
>
>
>
> *From:* mmusic [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Suhas Nandakumar
> *Sent:* den 14 januari 2016 15:34
> *To:* [email-masked]
> *Cc:* mmusic WG; [email-masked]
> *Subject:* Re: [MMUSIC] I-D Action:
> draft-ietf-mmusic-sdp-mux-attributes-12.txt
>
>
>
> Hello All
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 15 Jan 2016 12:29:53 +0000

Hi,

There is also another issue:

Some time ago, Peter Thatcher asked whether it is really needed to include the SDP candidate attributes in all bundled m- lines.

http://www.ietf.org/mail-archive/web/mmusic/current/msg15331.html

Looking at SDP attributes in general, I guess the question is: if an attribute belongs to IDENTICAL, does it need to be included in all m- lines within a BUNDLE group?

Regards,

Christer

From: Suhas Nandakumar [mailto:[email-masked]]
Sent: 14. tammikuuta 2016 22:51
To: Christer Holmberg
Cc: Bo Burman; mmusic WG; Taylor Brandstetter
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

Thanks Christer for bringing this to our notice. I just responded to Taylor's clarification question and I don't  think the response to his question changes any of the behavior for BUNDLE or MUX.

Thanks
Suhas

On Thu, Jan 14, 2016 at 12:06 PM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hold on :)

Regards,

Christer

From: mmusic [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Bo Burman
Sent: 14 January 2016 18:09
To: Suhas Nandakumar <[email-masked]<mailto:[email-masked]>>
Cc: mmusic WG <[email-masked]<mailto:[email-masked]>>

Thank you Suhas,

Cheers,
/Bo
MMUSIC co-chair

Hello All

Cheers
suhas

Abstract:

---

From: Taylor Brandstetter <[email-masked]>
Date: Fri, 15 Jan 2016 08:20:12 -0800

"candidate" is in the TRANSPORT category though, which doesn't prevent it
from being different in different media sections. It's the BUNDLE
negotiation draft that imposes the candidate duplication requirement, with
a combination of these two paragraphs:

   When the answerer selects a BUNDLE address for itself, referred to as
   the answerer BUNDLE address, it MUST associate that address with each
   bundled "m=" line within the created BUNDLE group in the answer.

   When an offerer or answerer associates a shared address (i.e. a
   previously selected BUNDLE address) with one or more bundled "m="
   lines, it MUST associate identical ICE candidates (referred to as
   shared ICE candidates) with each of those "m=" lines.

On Fri, Jan 15, 2016 at 4:29 AM, Christer Holmberg <
[email-masked]> wrote:

> Some time ago, Peter Thatcher asked whether it is really needed to include
> the SDP candidate attributes in all bundled m- lines.
>
>
>
> Looking at SDP attributes in general, I guess the question is: if an
> attribute belongs to IDENTICAL, does it need to be included in all m- lines
> within a BUNDLE group?
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From:* Suhas Nandakumar [mailto:[email-masked]]
> *Sent:* 14. tammikuuta 2016 22:51
> *To:* Christer Holmberg
> *Cc:* Bo Burman; mmusic WG; Taylor Brandstetter
>

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 18 Jan 2016 20:45:56 -0800

I agree with Taylor.

The Mux draft assigns category "TRANSPORT" to the ICE candidates. So the
candidate information from the "m=" line which corresponds to the BUNDLED
m=line shall be considered for the entire group.

As far as implementation is concerned, i think one should be fine just
trickling the candidate information for the m=line selected for a given
BUNDLE group and no need to copy it for the rest unless there is a explicit
need (Initial offer, plan to change the bundle group address, drop a
m=line)  to include different candidates.

 I would recommend we update the BUNDLE draft (if there is any confusion)
to match the MUX draft unless people think otherwise.

Hope this helps.

Tanks
Suhas

On Fri, Jan 15, 2016 at 8:20 AM, Taylor Brandstetter <[email-masked]>
wrote:

>> Some time ago, Peter Thatcher asked whether it is really needed to
>> include the SDP candidate attributes in all bundled m- lines.
>>
>>
>>
>> *From:* mmusic [mailto:[email-masked] <[email-masked]>]
>> *On Behalf Of *Suhas Nandakumar

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 21 Jan 2016 20:33:33 -0800

Hello Christer/Bo/Peter

  Do we think the understanding of dealing with the candidates when muxing
is clear or does either of the drafts needs more explanation on what needs
to be done.

Thanks
Suhas

---

From: Bo Burman <[email-masked]>
Date: Tue, 26 Jan 2016 17:37:51 +0000

Hi,

From what I can understand, there seems to be no reason to change –mux-attributes-12 at this point. I also see no opposition to Suhas’ proposal below that if a clarification is needed, it should go into the BUNDLE draft.

If there are no further comments, I intend to proceed with the publication request of –mux-attributes-12.

/Bo
MMUSIC co-chair

From: Suhas Nandakumar [mailto:[email-masked]]
Sent: den 22 januari 2016 05:34
To: Taylor Brandstetter
Cc: Christer Holmberg; Bo Burman; mmusic WG; Peter Thatcher
Subject: Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-mux-attributes-12.txt

Hello Christer/Bo/Peter

  Do we think the understanding of dealing with the candidates when muxing is clear or does either of the drafts needs more explanation on what needs to be done.

Thanks
Suhas

On Mon, Jan 18, 2016 at 8:45 PM, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:
I agree with Taylor.

The Mux draft assigns category "TRANSPORT" to the ICE candidates. So the candidate information from the "m=" line which corresponds to the BUNDLED m=line shall be considered for the entire group.

As far as implementation is concerned, i think one should be fine just trickling the candidate information for the m=line selected for a given BUNDLE group and no need to copy it for the rest unless there is a explicit need (Initial offer, plan to change the bundle group address, drop a m=line)  to include different candidates.

 I would recommend we update the BUNDLE draft (if there is any confusion) to match the MUX draft unless people think otherwise.

Hope this helps.

Tanks
Suhas

On Fri, Jan 15, 2016 at 8:20 AM, Taylor Brandstetter <[email-masked]<mailto:[email-masked]>> wrote:
"candidate" is in the TRANSPORT category though, which doesn't prevent it from being different in different media sections. It's the BUNDLE negotiation draft that imposes the candidate duplication requirement, with a combination of these two paragraphs:

On Fri, Jan 15, 2016 at 4:29 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: Suhas Nandakumar [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 14. tammikuuta 2016 22:51
To: Christer Holmberg
Cc: Bo Burman; mmusic WG; Taylor Brandstetter

Thanks
Suhas

Regards,

Christer

Thank you Suhas,

Cheers,
/Bo
MMUSIC co-chair

Hello All

Cheers
suhas

Abstract: