Subject: [MMUSIC] Concern with status of draft-ietf-mmusic-4572-update

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 25 Aug 2016 15:21:39 +0000

I do not think that draft-ietf-mmusic-4572-update can should be an "update" to 4572. RFC 4572 is widely deployed and the deployments are not going to be changed to incorporate this update. Having customers tell me equipment is not 4572 compliant because it does not implement this is not good. It will lead to interoperability problems where some people do this and others do not. For example, a 4572 is unlikely to include a SHA-256 fingerprint yet someone reading this update might make there systeme require the SHA-256 since this says it is a MUST. 

Instead I think this should be written as an extension to 4572 and JSEP and WebRTC should normatively reference it. 

For backwards compatibility, I think that  including SHA-1 as wells as SHA-256 should be a MUST

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 25 Aug 2016 15:52:22 +0000

Define "extension". Does that mean we need a way to indicate support of that extension too?

Some people claimed that there are already implementations using multiple fingerprints, and one of the purposes of the draft is to clarify the rules and semantics of that, in order to give people a common understanding of the semantics of multiple fingerprints. 

And, things will still work even if some existing implementations only look at one of the fingerprints.

There were quite extensive list discussions, especially between Roman S and Martin T, in order to get everything right, so I REALLY think we should keep it as it is. Also, WGLC ended 19th June, and the WG that you are co-chairing have asked for this (among others) documents to be finalized :)

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Cullen Jennings (fluffy)
Sent: 25 August 2016 18:22
To: mmusic WG <[email-masked]>
Subject: [MMUSIC] Concern with status of draft-ietf-mmusic-4572-update

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic