Subject: Re: [MMUSIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 - PT reuse

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 Sep 2016 21:01:14 +0000

Hi,

## Interoperable PT reuse 

>Reuse of PT inside a bundle group in an offer needs to only be allow the m= line is >bundle only. Without this, when this if the offer drives at a device that does not support >bundle, it will be invalid SDP. 

Not sure I understand. As all bundled m- lines belong to the same RTP session, BUNDLE is actually more strict than RFC 3264 when it comes to PT values, so what could go wrong if a non-BUNDLE receives the SDP?

Regards,

Christer

---

From: Martin Thomson <[email-masked]>
Date: Sun, 18 Sep 2016 16:42:39 -0700

On 19 Sep 2016 7:01 AM, "Christer Holmberg" <[email-masked]>
wrote:
> >Reuse of PT inside a bundle group in an offer needs to only be allow the
m= line is >bundle only. Without this, when this if the offer drives at a
device that does not support >bundle, it will be invalid SDP.
>
> Not sure I understand. As all bundled m- lines belong to the same RTP
session, BUNDLE is actually more strict than RFC 3264 when it comes to PT
values, so what could go wrong if a non-BUNDLE receives the SDP?

I agree with Christian here. If lines aren't going to be bundled, the value
of PT-based demux is reduced. If anything, we should encourage the use of
unique PT values more for a=bundle-only.