Subject: Re: [MMUSIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 - Cullen's non-major issues

From: Christer Holmberg <[email-masked]>
Date: Sun, 18 Sep 2016 21:36:36 +0000

Hi,

# Medium Issue

>Given the other conversation around “update”, does this needs to update 3264?

I don't know. The draft defines a new meaning of port zero in an offer, so...

I don't think we can stop updating drafts. If it's generally unclear what "update" really means, we can always add some text.

>## Mux only confusions. 
>
>I think we agreed that if and endpoint was sending mux-only, it still had to put in the rtcp-mux attributes, it is just saying that it is never going to negotiate a non muxed >option. A bunch of text reads that you have mux-only or rtcp-mux but I think it needs to be if you have mux-only, then you must also have rtcp-mux. The reasons for this is >that we want stuff that does not implement mux-only but does do rtcp-mux to work in theses cases. 

Without checking archives and minutes, I don't remember what we agreed. However, I have no strong opinion, so I'm happy to hear what others think.

(Your text said "mix" instead of "mux" in a few places, so I fixed that)

# Small Stuff

>In the para in section 1 where we are taking about MID, I think we should introduce the name MID here. 

I can do that.

>Think we should delete first two paragraphs of section 9. Don’t add anything and just confusing.

I have no strong opinion, but as there were quite a bit of discussions about this at one point I'd like to hear what others think.

>14.1 specifies uses of UTF strings that implementation need to compare. Should specify normalization for this. 

I'll look into that.

Regards,

Christer

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 22 Sep 2016 19:13:03 -0400

> I have no strong opinion, but as there were quite a bit of discussions about this at one point I'd like to hear what others think.

I think it's useful and would like to keep it.

Thanks

-- Flemming