Subject: Re: [MMUSIC] Draft new version: draft-ietf-mmusic-sctp-sdp-17

From: Bo Burman <[email-masked]>
Date: Fri, 2 Sep 2016 14:46:00 +0000

MMUSIC,

Please have a look at this and let the chairs and authors know if you have comments, or if it is ready for another WGLC.

Cheers,
Bo
MMUSIC co-chair

From: Christer Holmberg [mailto:[email-masked]]
Sent: den 30 augusti 2016 14:37
To: [email-masked]
Cc: [email-masked]
Subject: Draft new version: draft-ietf-mmusic-sctp-sdp-17

Hi,

The new version (-17) of draft-ietf-mmusic-sctp-sdp has finally been submitted.

-The draft now takes draft-dtls-sdp and draft-4572-update into consideration.
-The procedures associated with SCTP/DTLS (DTLS over SCTP) have been removed, as nobody indicated a need to keep them.

When it comes to the management of SCTP associations, DTLS associations and TCP connections, the previous version of the draft took an approach from an SDP attribute perspective. In the new version, the draft takes an approach from an association/connection perspective, describes how each layer is managed and how/if/which SDP attribute impact the association/connection. The text also clarifies that each association/connection is managed independently of each other. For example, it is possible to re-establish an DTLS association without touching the overlaying SCTP association, etc.

NOTE: The draft now says that, since each SCTP endpoint is always 'active', and both establish the SCTP association, the SDP 'setup' attribute is not used for SCTP. IF someone thinks there is a use-case where a separation of active and passive SCTP endpoint is needed, please bring it to the list. There are no changes to how the SDP setup attribute impact the DTLS roles  (client/server) and the TCP roles (active/passive).

The draft was previously already in WGLC, but due to the changes in the latest version we should probably wait a bit before we continue the WGLC. I encourage everyone to take a look - especially the browser/JSEP folks.

I'd like to give a special Thank You to Roman Shpount, for the input and feedback he has given off-line.

Regards,

Christer

---

From: Roman Shpount <[email-masked]>
Date: Fri, 2 Sep 2016 13:25:00 -0400

Hi All,

I have posted the question regarding SDP attribute setup=holdconn on this
list which is directly related to this draft. It would likely needs to be
resolved before WGLC.

Regards,

_____________
Roman Shpount

On Fri, Sep 2, 2016 at 10:46 AM, Bo Burman <[email-masked]> wrote:

> MMUSIC,
>
>
>
> Please have a look at this and let the chairs and authors know if you have
> comments, or if it is ready for another WGLC.
>
>
>
> Cheers,
>
> Bo
>
> MMUSIC co-chair
>
>
>
> *From:* Christer Holmberg [mailto:[email-masked]]
> *Sent:* den 30 augusti 2016 14:37
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Draft new version: draft-ietf-mmusic-sctp-sdp-17
>
>
>
> Hi,
>
>
>
> -The procedures associated with SCTP/DTLS (DTLS over SCTP) have been
> removed, as nobody indicated a need to keep them.
>
>
>
> When it comes to the management of SCTP associations, DTLS associations
> and TCP connections, the previous version of the draft took an approach
> from an SDP attribute perspective. In the new version, the draft takes an
> approach from an association/connection perspective, describes how each
> layer is managed and how/if/which SDP attribute impact the
> association/connection. The text also clarifies that each
> association/connection is managed independently of each other. For example,
> it is possible to re-establish an DTLS association without touching the
> overlaying SCTP association, etc.
>
>
>
> NOTE: The draft now says that, since each SCTP endpoint is always
> ‘active’, and both establish the SCTP association, the SDP ‘setup’
> attribute is not used for SCTP. IF someone thinks there is a use-case where
> a separation of active and passive SCTP endpoint is needed, please bring it
> to the list. There are no changes to how the SDP setup attribute impact the
> DTLS roles  (client/server) and the TCP roles (active/passive).
>
>
>
> The draft was previously already in WGLC, but due to the changes in the
> latest version we should probably wait a bit before we continue the WGLC. I
> encourage everyone to take a look – especially the browser/JSEP folks.
>
>
>
> I’d like to give a special Thank You to Roman Shpount, for the input and
> feedback he has given off-line.
>
>
>
> Regards,
>
>
>
> Christer
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 6 Sep 2016 16:00:05 +0000

Hi,

If nobody cares about holdconn, or have any other major issues with the draft, I think we should go for WGLC.

Regards,

Christer

From: Roman Shpount [mailto:[email-masked]]
Sent: 02 September 2016 20:25
To: Bo Burman <[email-masked]>
Cc: Christer Holmberg <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [MMUSIC] Draft new version: draft-ietf-mmusic-sctp-sdp-17

Hi All,

I have posted the question regarding SDP attribute setup=holdconn on this list which is directly related to this draft. It would likely needs to be resolved before WGLC.

Regards,

_____________
Roman Shpount

On Fri, Sep 2, 2016 at 10:46 AM, Bo Burman <[email-masked]<mailto:[email-masked]>> wrote:
MMUSIC,

Cheers,
Bo
MMUSIC co-chair

From: Christer Holmberg [mailto:[email-masked]<mailto:[email-masked]>]
Sent: den 30 augusti 2016 14:37
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Draft new version: draft-ietf-mmusic-sctp-sdp-17

Hi,

NOTE: The draft now says that, since each SCTP endpoint is always ‘active’, and both establish the SCTP association, the SDP ‘setup’ attribute is not used for SCTP. IF someone thinks there is a use-case where a separation of active and passive SCTP endpoint is needed, please bring it to the list. There are no changes to how the SDP setup attribute impact the DTLS roles  (client/server) and the TCP roles (active/passive).

The draft was previously already in WGLC, but due to the changes in the latest version we should probably wait a bit before we continue the WGLC. I encourage everyone to take a look – especially the browser/JSEP folks.

I’d like to give a special Thank You to Roman Shpount, for the input and feedback he has given off-line.

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Roman Shpount <[email-masked]>
Date: Tue, 6 Sep 2016 13:45:26 -0400

Hi,

If no one cares about holdconn we should update the draft and specify that
holdconn MUST NOT be used. After this we can go to WGLC.

_____________
Roman Shpount

On Tue, Sep 6, 2016 at 12:00 PM, Christer Holmberg <
[email-masked]> wrote:

> *From:* Roman Shpount [mailto:[email-masked]]
> *Sent:* 02 September 2016 20:25
> *To:* Bo Burman <[email-masked]>
> *Cc:* Christer Holmberg <[email-masked]>; [email-masked];
> [email-masked]
> *Subject:* Re: [MMUSIC] Draft new version: draft-ietf-mmusic-sctp-sdp-17
>
>
>
> Hi All,
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 6 Sep 2016 18:04:19 +0000

Hi,

>If no one cares about holdconn we should update the draft and specify that >holdconn MUST NOT be used. After this we can go to WGLC.

Correct.

Regards,

Christer

On Tue, Sep 6, 2016 at 12:00 PM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

From: Roman Shpount [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 02 September 2016 20:25
To: Bo Burman <[email-masked]<mailto:[email-masked]>>
Cc: Christer Holmberg <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] Draft new version: draft-ietf-mmusic-sctp-sdp-17

Hi All,

Regards,

_____________
Roman Shpount

Cheers,
Bo
MMUSIC co-chair

Hi,

Regards,

Christer