Subject: [MMUSIC] Moving Forward on 4572-update (was Re: Rough concensus: Re: 4572-update: Consensus call on how to move forward)

From: "Ben Campbell" <[email-masked]>
Date: Fri, 21 Oct 2016 15:49:55 -0500

Hi Everyone, please accept my apologies for waiting this long to weigh 
in.

I think it's clear that multiple people are not happy with how we got to 
this point. But assigning blame doesn't help us make progress on the 
draft. I propose that we get over that, and instead focus instead on how 
to move forward. Email discussion doesn't seem to be helping. Maybe a 
call will.

Flemming and/or Bo: Can you set up a Doodle poll to get Christer, 
Cullen, and other demonstratively  interested parties on a conference 
call? I will join if at all possible, but don't let scheduling around me 
stop a call from happening.

Thanks!

Ben.

On 21 Oct 2016, at 11:05, Flemming Andreasen wrote:

> [fixing cc-list]
>
> On 10/21/16 11:59 AM, Flemming Andreasen wrote:
>>
>>
>> On 10/21/16 11:21 AM, Cullen Jennings wrote:
>>> I think that is a bad way to run a WG. All I asked for was a phone 
>>> call to discuss this so we could get the issues on the table and 
>>> discuss what is best. The chairs never even replied to my request 
>>> for a WG call to discuss this.
>> That is simply not true. You (and Christer) were explicitly asked to 
>> setup a phone call on 10/6/16 to discuss this issue; a request that 
>> (like many other others) went unanswered or required extensive 
>> prodding to get any attention.
>>
>>> The list discussions that ensued from this resulted in people other 
>>> than me sugesting possibilities that were much better than any of 
>>> the three below -  none of which were considered in your consensus 
>>> call.
>> I'm not sure what those proposals are, nor were they brought up in 
>> response to the consensus call.
>>
>>> I don’t plan to appeal this but I am considering if it’s worth 
>>> my time to participate in this WG if we are not going to be willing 
>>> to actually spend a short time to discuss possible solutions before 
>>> taking a consensus call.  As input to that decisions, it would be 
>>> really useful to know why you refused to have a phone call on this 
>>> topic and what your policy in general is going to be toward 
>>> discussions of proposed solutions to problems in the future.
>> My position is that we will try our very best to get to not only 
>> consensus but to satisfy as many concerns as we possibly can. It does 
>> however require people to engage in a timely manner, and even when 
>> they don't, we still do what we can, but at some point we need to 
>> move forward. As for the issue at hand, it has been discussed 
>> extensively, and several changes were made to the draft to try and 
>> accommodate your requests.
>>
>> The one major remaining issue I believe you have is around whether 
>> this document updates RFC 4572. This has been discussed extensively 
>> on the wgchairs list; a discussion I initiated to try and help 
>> address your concern. You may disagree with how that discussion 
>> concluded, but again, to try and alleviate your concerns, a note was 
>> added to 4572-update to make it clear that the document does not make 
>> existing 4572 implementations non-compliant with RFC 4572.
>>
>> I believe the chairs, authors, and the WG at large has done 
>> everything that can reasonably be done to try and address your 
>> concerns, and at this point we need to move forward.
>>
>> Thanks
>>
>> -- Flemming (as MMUSIC co-chair)
>>
>>
>>
>>>
>>>> On Oct 19, 2016, at 6:43 AM, Flemming Andreasen 
>>>> <[email-masked]> wrote:
>>>>
>>>> Hi
>>>>
>>>> Following up on the consensus call, we have received 5 responses in 
>>>> favor of option a) below, one neutral, and one objection. Looking 
>>>> at the document we have noted that backwards compatibility is 
>>>> handled by the current text in the document and it also clearly 
>>>> states that it does not make current RFC 4572 implementation 
>>>> non-compliant with RFC 4572. Since we have not heard of any 
>>>> technical problems with proposal a), nor seen any tangible progress 
>>>> on how to address the objection, we are hereby declaring rough 
>>>> consensus on option a). We will proceed with the publication 
>>>> request for the current draft while duly noting the "roughness" of 
>>>> the consensus based on the pending objection as part of this.
>>>>
>>>> Thanks
>>>>
>>>>     Flemming & Bo (MMUSIC chairs)
>>>>
>>>>
>>>> On 10/12/16 6:23 PM, Flemming Andreasen wrote:
>>>>> Greetings
>>>>>
>>>>> There has been quite a bit of discussion on 
>>>>> draft-ietf-mmusic-4572-update (currently -07), which had 
>>>>> previously completed WGLC when a few concerns were raised. The 
>>>>> document currently:
>>>>> 1. Clarifies the usage of multiple SDP 'fingerprint' attributes
>>>>> 2. Updates the preferred cipher-suite with a stronger cipher suite
>>>>> 3. Updates RFC 4572.
>>>>>
>>>>> Item 1 seems to be generally agreeable, whereas items 2 and 3 are 
>>>>> not. The chairs are hereby soliciting WG feedback on how to 
>>>>> proceed based on the following choices:
>>>>>
>>>>> a) Proceed with publication of 4572-update-07 in its current form 
>>>>> (i.e. covering all 3 items above)
>>>>>
>>>>> b) Remove item 2 from 4572-update, i.e. do not update the 
>>>>> preferred cipher-suite
>>>>>
>>>>> c) Remove item 3 from 4572-update, i.e. do not indicate that this 
>>>>> document constitutes an update to RFC 4572.
>>>>>
>>>>>
>>>>> Note that choice a) is mutually exclusive with b) and c), but b) 
>>>>> and c) are not mutually exclusive.
>>>>>
>>>>> Please let us know your preference wrt to the above no later than 
>>>>> Friday October 14th.
>>>>>
>>>>>
>>>>> Thanks
>>>>>
>>>>>        Flemming & Bo (MMUSIC chairs)
>>>>>
>>>>> _______________________________________________
>>>>> mmusic mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/mmusic
>>>>> .
>>>>>
>>>> _______________________________________________
>>>> mmusic mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/mmusic
>>> .
>>>
>>
>> _______________________________________________
>> mmusic mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mmusic
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 22 Oct 2016 06:16:19 -0700

I would be happy to attend such a call.

-Ekr

On Fri, Oct 21, 2016 at 1:49 PM, Ben Campbell <[email-masked]> wrote:

> Hi Everyone, please accept my apologies for waiting this long to weigh in.
>
> this point. But assigning blame doesn't help us make progress on the draft.
> I propose that we get over that, and instead focus instead on how to move
> forward. Email discussion doesn't seem to be helping. Maybe a call will.
>
> Flemming and/or Bo: Can you set up a Doodle poll to get Christer, Cullen,
> and other demonstratively  interested parties on a conference call? I will
> join if at all possible, but don't let scheduling around me stop a call
> from happening.
>
> Thanks!
>
> Ben.
>
>>>> I think that is a bad way to run a WG. All I asked for was a phone call
>>>> to discuss this so we could get the issues on the table and discuss what is
>>>> best. The chairs never even replied to my request for a WG call to discuss
>>>> this.
>>>>
>>> setup a phone call on 10/6/16 to discuss this issue; a request that (like
>>> many other others) went unanswered or required extensive prodding to get
>>> any attention.
>>>
>>> The list discussions that ensued from this resulted in people other than
>>>> me sugesting possibilities that were much better than any of the three
>>>> below -  none of which were considered in your consensus call.
>>>>
>>> I don’t plan to appeal this but I am considering if it’s worth my time
>>>> to participate in this WG if we are not going to be willing to actually
>>>> spend a short time to discuss possible solutions before taking a consensus
>>>> call.  As input to that decisions, it would be really useful to know why
>>>> you refused to have a phone call on this topic and what your policy in
>>>> general is going to be toward discussions of proposed solutions to problems
>>>> in the future.
>>>>
>>> however require people to engage in a timely manner, and even when they
>>> don't, we still do what we can, but at some point we need to move forward.
>>> As for the issue at hand, it has been discussed extensively, and several
>>> changes were made to the draft to try and accommodate your requests.
>>>
>>> The one major remaining issue I believe you have is around whether this
>>> document updates RFC 4572. This has been discussed extensively on the
>>> wgchairs list; a discussion I initiated to try and help address your
>>> concern. You may disagree with how that discussion concluded, but again, to
>>> try and alleviate your concerns, a note was added to 4572-update to make it
>>> clear that the document does not make existing 4572 implementations
>>> non-compliant with RFC 4572.
>>>
>>> I believe the chairs, authors, and the WG at large has done everything
>>> that can reasonably be done to try and address your concerns, and at this
>>> point we need to move forward.
>>>
>>> Thanks
>>>
>>>> On Oct 19, 2016, at 6:43 AM, Flemming Andreasen <[email-masked]>
>>>>> wrote:
>>>>>
>>>>> Hi
>>>>>
>>>>> favor of option a) below, one neutral, and one objection. Looking at the
>>>>> document we have noted that backwards compatibility is handled by the
>>>>> current text in the document and it also clearly states that it does not
>>>>> make current RFC 4572 implementation non-compliant with RFC 4572. Since we
>>>>> have not heard of any technical problems with proposal a), nor seen any
>>>>> tangible progress on how to address the objection, we are hereby declaring
>>>>> rough consensus on option a). We will proceed with the publication request
>>>>> for the current draft while duly noting the "roughness" of the consensus
>>>>> based on the pending objection as part of this.
>>>>>
>>>>> Thanks
>>>>>
>>>>>> draft-ietf-mmusic-4572-update (currently -07), which had previously
>>>>>> completed WGLC when a few concerns were raised. The document currently:
>>>>>> not. The chairs are hereby soliciting WG feedback on how to proceed based
>>>>>> on the following choices:
>>>>>>
>>>>>> b) Remove item 2 from 4572-update, i.e. do not update the preferred
>>>>>> cipher-suite
>>>>>>
>>>>>> Note that choice a) is mutually exclusive with b) and c), but b) and
>>>>>> c) are not mutually exclusive.
>>>>>>

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 25 Oct 2016 00:01:22 -0400

Hi Ben

We will get a poll setup as soon as we understand any major constraints 
from the key participants.

Thanks

-- Flemming

On 10/21/16 4:49 PM, Ben Campbell wrote:
> I think it's clear that multiple people are not happy with how we got 
> to this point. But assigning blame doesn't help us make progress on 
> the draft. I propose that we get over that, and instead focus instead 
> on how to move forward. Email discussion doesn't seem to be helping. 
> Maybe a call will.
>
> call? I will join if at all possible, but don't let scheduling around 
> me stop a call from happening.
>
> Thanks!
>
> Ben.
>
>>>> I don’t plan to appeal this but I am considering if it’s worth my 
>>>> time to participate in this WG if we are not going to be willing to 
>>>> actually spend a short time to discuss possible solutions before 
>>> consensus but to satisfy as many concerns as we possibly can. It 
>>> does however require people to engage in a timely manner, and even 
>>> when they don't, we still do what we can, but at some point we need 
>>> to move forward. As for the issue at hand, it has been discussed 
>>> added to 4572-update to make it clear that the document does not 
>>> make existing 4572 implementations non-compliant with RFC 4572.
>>>
>>>>> Following up on the consensus call, we have received 5 responses 
>>>>> in favor of option a) below, one neutral, and one objection. 
>>>>> Looking at the document we have noted that backwards compatibility 
>>>>> is handled by the current text in the document and it also clearly 
>>>>> technical problems with proposal a), nor seen any tangible 
>>>>> progress on how to address the objection, we are hereby declaring 
>>>>> rough consensus on option a). We will proceed with the publication

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 25 Oct 2016 04:33:04 +0000

Hi Flemming,

Any day but Monday works for me.

Regards,

Christer 

Sent from my iPhone

> On 25 Oct 2016, at 7.01, Flemming Andreasen <[email-masked]> wrote:
> 
> Hi Ben
> 
> We will get a poll setup as soon as we understand any major constraints from the key participants.
> 
> Thanks
> 
> -- Flemming
> 
> 
>> I think it's clear that multiple people are not happy with how we got to this point. But assigning blame doesn't help us make progress on the draft. I propose that we get over that, and instead focus instead on how to move forward. Email discussion doesn't seem to be helping. Maybe a call will.
>> 
>> Flemming and/or Bo: Can you set up a Doodle poll to get Christer, Cullen, and other demonstratively  interested parties on a conference call? I will join if at all possible, but don't let scheduling around me stop a call from happening.
>> 
>> Thanks!
>> 
>> Ben.
>> 
>>>>> I think that is a bad way to run a WG. All I asked for was a phone call to discuss this so we could get the issues on the table and discuss what is best. The chairs never even replied to my request for a WG call to discuss this.
>>>> That is simply not true. You (and Christer) were explicitly asked to setup a phone call on 10/6/16 to discuss this issue; a request that (like many other others) went unanswered or required extensive prodding to get any attention.
>>>> 
>>>>> The list discussions that ensued from this resulted in people other than me sugesting possibilities that were much better than any of the three below -  none of which were considered in your consensus call.
>>>> I'm not sure what those proposals are, nor were they brought up in response to the consensus call.
>>>> 
>>>>> I don’t plan to appeal this but I am considering if it’s worth my time to participate in this WG if we are not going to be willing to actually spend a short time to discuss possible solutions before taking a consensus call.  As input to that decisions, it would be really useful to know why you refused to have a phone call on this topic and what your policy in general is going to be toward discussions of proposed solutions to problems in the future.
>>>> My position is that we will try our very best to get to not only consensus but to satisfy as many concerns as we possibly can. It does however require people to engage in a timely manner, and even when they don't, we still do what we can, but at some point we need to move forward. As for the issue at hand, it has been discussed extensively, and several changes were made to the draft to try and accommodate your requests.
>>>> 
>>>> The one major remaining issue I believe you have is around whether this document updates RFC 4572. This has been discussed extensively on the wgchairs list; a discussion I initiated to try and help address your concern. You may disagree with how that discussion concluded, but again, to try and alleviate your concerns, a note was added to 4572-update to make it clear that the document does not make existing 4572 implementations non-compliant with RFC 4572.
>>>> 
>>>> I believe the chairs, authors, and the WG at large has done everything that can reasonably be done to try and address your concerns, and at this point we need to move forward.
>>>> 
>>>> Thanks
>>>> 
>>>>>> On Oct 19, 2016, at 6:43 AM, Flemming Andreasen <[email-masked]> wrote:
>>>>>> 
>>>>>> Hi
>>>>>> 
>>>>>> Following up on the consensus call, we have received 5 responses in favor of option a) below, one neutral, and one objection. Looking at the document we have noted that backwards compatibility is handled by the current text in the document and it also clearly states that it does not make current RFC 4572 implementation non-compliant with RFC 4572. Since we have not heard of any technical problems with proposal a), nor seen any tangible progress on how to address the objection, we are hereby declaring rough consensus on option a). We will proceed with the publication request for the current draft while duly noting the "roughness" of the consensus based on the pending objection as part of this.
>>>>>> 
>>>>>> Thanks
>>>>>> 
>>>>>>> There has been quite a bit of discussion on draft-ietf-mmusic-4572-update (currently -07), which had previously completed WGLC when a few concerns were raised. The document currently:
>>>>>>> Item 1 seems to be generally agreeable, whereas items 2 and 3 are not. The chairs are hereby soliciting WG feedback on how to proceed based on the following choices:
>>>>>>> 
>>>>>>> a) Proceed with publication of 4572-update-07 in its current form (i.e. covering all 3 items above)
>>>>>>> 
>>>>>>> b) Remove item 2 from 4572-update, i.e. do not update the preferred cipher-suite
>>>>>>> 
>>>>>>> c) Remove item 3 from 4572-update, i.e. do not indicate that this document constitutes an update to RFC 4572.
>>>>>>> 
>>>>>>> 
>>>>>>> Note that choice a) is mutually exclusive with b) and c), but b) and c) are not mutually exclusive.
>>>>>>> 
>>>>>>> Please let us know your preference wrt to the above no later than Friday October 14th.
>>>>>>> 
>>>>>>> 
>>>>>>> Thanks
>>>>>>>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 25 Oct 2016 16:07:56 +1100

I am in Australia this week so next week would be easier. Otherwise, please
make it late Pacific time so that it's not too early.

-Ekr

On Tue, Oct 25, 2016 at 3:33 PM, Christer Holmberg <
[email-masked]> wrote:

> to this point. But assigning blame doesn't help us make progress on the
> draft. I propose that we get over that, and instead focus instead on how to
> move forward. Email discussion doesn't seem to be helping. Maybe a call
> will.
> >>
> Cullen, and other demonstratively  interested parties on a conference call?
> I will join if at all possible, but don't let scheduling around me stop a
> call from happening.
> >>
> >> Thanks!
> >>
> >> Ben.
> >>
> call to discuss this so we could get the issues on the table and discuss
> what is best. The chairs never even replied to my request for a WG call to
> discuss this.
> than me sugesting possibilities that were much better than any of the three
> actually spend a short time to discuss possible solutions before taking a
> consensus call.  As input to that decisions, it would be really useful to
> know why you refused to have a phone call on this topic and what your
> policy in general is going to be toward discussions of proposed solutions
> to problems in the future.
> this document updates RFC 4572. This has been discussed extensively on the
> everything that can reasonably be done to try and address your concerns,
> and at this point we need to move forward.
> >>>>
> >>>> Thanks
> >>>>

---

From: Roman Shpount <[email-masked]>
Date: Tue, 25 Oct 2016 09:02:37 -0400

Hi All,

Any reasonable time US Eastern works for me.

_____________
Roman Shpount

On Tue, Oct 25, 2016 at 1:07 AM, Eric Rescorla <[email-masked]> wrote:

> I am in Australia this week so next week would be easier. Otherwise,
> please make it late Pacific time so that it's not too early.
>
> -Ekr
>
>
>> in favor of option a) below, one neutral, and one objection. Looking at the

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 25 Oct 2016 08:57:20 -0700

Next Thursday is bad for me but any other morning (pacific time) next week would work for me. 

> On Oct 25, 2016, at 6:02 AM, Roman Shpount <[email-masked]> wrote:
> 
> Hi All,
> 
> On Tue, Oct 25, 2016 at 1:07 AM, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
> I am in Australia this week so next week would be easier. Otherwise, please make it late Pacific time so that it's not too early.
> 
> -Ekr
> 
> 
> On Tue, Oct 25, 2016 at 3:33 PM, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Flemming,
> 
> > On 25 Oct 2016, at 7.01, Flemming Andreasen <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi Ben
> >
> >>>>>> On Oct 19, 2016, at 6:43 AM, Flemming Andreasen <[email-masked] <mailto:[email-masked]>> wrote:
> >>>>>>
> >>>>>> Hi
> >>>>>>
> >>>>>>> [email-masked] <mailto:[email-masked]>
> >>>>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> >>>>>>> .
> >>>>>>>
> >>>>>> [email-masked] <mailto:[email-masked]>
> >>>>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> >>>>> .
> >>>>>
> >>>>
> >>>> [email-masked] <mailto:[email-masked]>
> >>>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> >>>
> >>> [email-masked] <mailto:[email-masked]>
> >>> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> >>
> >> .
> >>
> >
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mmusic <https://www.ietf.org/mailman/listinfo/mmusic>
> 
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 26 Oct 2016 00:54:41 -0400

A Doodle poll is now available at

	http://doodle.com/poll/kxw4n9a2v7v3pe2y

We are looking at either Wednesday or Friday next week (November 2 or 
4), so please get your vote in pretty quickly if you are interested.

Thanks

-- Flemming

On 10/25/16 12:01 AM, Flemming Andreasen wrote:
>>>> That is simply not true. You (and Christer) were explicitly asked 
>>>> to setup a phone call on 10/6/16 to discuss this issue; a request 
>>>> that (like many other others) went unanswered or required extensive 
>>>>> The list discussions that ensued from this resulted in people 
>>>>> other than me sugesting possibilities that were much better than 
>>>>> any of the three below -  none of which were considered in your 
>>>>> consensus call.
>>>>> time to participate in this WG if we are not going to be willing 
>>>>> to actually spend a short time to discuss possible solutions 
>>>>> before taking a consensus call.  As input to that decisions, it 
>>>>> would be really useful to know why you refused to have a phone 
>>>>> call on this topic and what your policy in general is going to be 
>>>>> toward discussions of proposed solutions to problems in the future.
>>>> concluded, but again, to try and alleviate your concerns, a note 
>>>> was added to 4572-update to make it clear that the document does 
>>>> not make existing 4572 implementations non-compliant with RFC 4572.
>>>>
>>>>>> Looking at the document we have noted that backwards 
>>>>>> compatibility is handled by the current text in the document and 
>>>>>> it also clearly states that it does not make current RFC 4572 
>>>>>> implementation non-compliant with RFC 4572. Since we have not 
>>>>>> heard of any technical problems with proposal a), nor seen any 
>>>>>> tangible progress on how to address the objection, we are hereby 
>>>>>> declaring rough consensus on option a). We will proceed with the 
>>>>>> publication request for the current draft while duly noting the 
>>>>>> "roughness" of the consensus based on the pending objection as 
>>>>>> part of this.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>>> Item 1 seems to be generally agreeable, whereas items 2 and 3 
>>>>>>> are not. The chairs are hereby soliciting WG feedback on how to 
>>>>>>> c) Remove item 3 from 4572-update, i.e. do not indicate that 
>>>>>>> this document constitutes an update to RFC 4572.
>>>>>>>
>>>>>>>

---

From: Roman Shpount <[email-masked]>
Date: Wed, 26 Oct 2016 01:07:01 -0400

What time zone is this?

Regards,

_____________
Roman Shpount

On Wed, Oct 26, 2016 at 12:54 AM, Flemming Andreasen <[email-masked]>
wrote:

> We are looking at either Wednesday or Friday next week (November 2 or 4),
> so please get your vote in pretty quickly if you are interested.
>
> Thanks
>
> -- Flemming
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 26 Oct 2016 01:33:02 -0400

Eastern (assuming you see 10 AM, 11 AM and 12 PM)

On 10/26/16 1:07 AM, Roman Shpount wrote:
> What time zone is this?
>
> Regards,
>
> _____________
> Roman Shpount
>
> On Wed, Oct 26, 2016 at 12:54 AM, Flemming Andreasen 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     <http://doodle.com/poll/kxw4n9a2v7v3pe2y>
>
>     We are looking at either Wednesday or Friday next week (November 2
>     or 4), so please get your vote in pretty quickly if you are
>     interested.
>
>     Thanks
>
>     -- Flemming
>
>
>             I think it's clear that multiple people are not happy with
>             how we got to this point. But assigning blame doesn't help
>             us make progress on the draft. I propose that we get over
>             that, and instead focus instead on how to move forward.
>             Email discussion doesn't seem to be helping. Maybe a call
>             will.
>
>             Flemming and/or Bo: Can you set up a Doodle poll to get
>             Christer, Cullen, and other demonstratively  interested
>             parties on a conference call? I will join if at all
>             possible, but don't let scheduling around me stop a call
>             from happening.
>
>             Thanks!
>
>             Ben.
>
>                         I think that is a bad way to run a WG. All I
>                         asked for was a phone call to discuss this so
>                         we could get the issues on the table and
>                         discuss what is best. The chairs never even
>                         replied to my request for a WG call to discuss
>                         this.
>
>                     That is simply not true. You (and Christer) were
>                     explicitly asked to setup a phone call on 10/6/16
>                     to discuss this issue; a request that (like many
>                     other others) went unanswered or required
>                     extensive prodding to get any attention.
>
>                         The list discussions that ensued from this
>                         resulted in people other than me sugesting
>                         possibilities that were much better than any
>                         of the three below -  none of which were
>                         considered in your consensus call.
>
>                     I'm not sure what those proposals are, nor were
>                     they brought up in response to the consensus call.
>
>                         I don’t plan to appeal this but I am
>                         considering if it’s worth my time to
>                         participate in this WG if we are not going to
>                         be willing to actually spend a short time to
>                         discuss possible solutions before taking a
>                         consensus call.  As input to that decisions,
>                         it would be really useful to know why you
>                         refused to have a phone call on this topic and
>                         what your policy in general is going to be
>                     My position is that we will try our very best to
>                     get to not only consensus but to satisfy as many
>                     concerns as we possibly can. It does however
>                     require people to engage in a timely manner, and
>                     even when they don't, we still do what we can, but
>                     at some point we need to move forward. As for the
>                     issue at hand, it has been discussed extensively,
>                     and several changes were made to the draft to try
>                     and accommodate your requests.
>
>                     The one major remaining issue I believe you have
>                     is around whether this document updates RFC 4572.
>                     This has been discussed extensively on the
>                     wgchairs list; a discussion I initiated to try and
>                     help address your concern. You may disagree with
>                     how that discussion concluded, but again, to try
>                     and alleviate your concerns, a note was added to
>                     4572-update to make it clear that the document
>                     does not make existing 4572 implementations
>                     I believe the chairs, authors, and the WG at large
>                     has done everything that can reasonably be done to
>                     try and address your concerns, and at this point
>                     we need to move forward.
>
>                     Thanks
>
>                             On Oct 19, 2016, at 6:43 AM, Flemming
>                             Andreasen <[email-masked]
>                             <mailto:[email-masked]>> wrote:
>
>                             Hi
>
>                             Following up on the consensus call, we
>                             have received 5 responses in favor of
>                             option a) below, one neutral, and one
>                             objection. Looking at the document we have
>                             noted that backwards compatibility is
>                             handled by the current text in the
>                             document and it also clearly states that
>                             it does not make current RFC 4572
>                             implementation non-compliant with RFC
>                             4572. Since we have not heard of any
>                             technical problems with proposal a), nor
>                             seen any tangible progress on how to
>                             address the objection, we are hereby
>                             declaring rough consensus on option a). We
>                             will proceed with the publication request
>                             for the current draft while duly noting
>                             the "roughness" of the consensus based on
>                             the pending objection as part of this.
>
>                             Thanks
>
>                                 not. The chairs are hereby soliciting
>                                 WG feedback on how to proceed based on
>                                 the following choices:
>
>                                 Please let us know your preference wrt
>                                 to the above no later than Friday
>                                 October 14th.
>
>
>                                 Thanks
>
>                                 <https://www.ietf.org/mailman/listinfo/mmusic>
>                                 .
>
>                             <https://www.ietf.org/mailman/listinfo/mmusic>
>
>                         .
>
>
>                     <https://www.ietf.org/mailman/listinfo/mmusic>
>
>
>                 <https://www.ietf.org/mailman/listinfo/mmusic>
>
>
>             .
>
>
>         <https://www.ietf.org/mailman/listinfo/mmusic>
>
>
>     <https://www.ietf.org/mailman/listinfo/mmusic>
>
>
>
>

---

From: Martin Thomson <[email-masked]>
Date: Fri, 28 Oct 2016 16:11:41 +1100

On 26 October 2016 at 15:54, Flemming Andreasen <[email-masked]> wrote:
> We are looking at either Wednesday or Friday next week (November 2 or 4), so
> please get your vote in pretty quickly if you are interested.

These are awful times for me, though I would like to be involved.
It's not that long now until we will all be in the same room, is this
somehow urgent enough that we need to have a call?

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 28 Oct 2016 16:18:44 +1100

Dealing with this in Seoul seems like a reasonable suggestion

-Ekr

On Fri, Oct 28, 2016 at 4:11 PM, Martin Thomson <[email-masked]>
wrote:

> 4), so

---

From: Bo Burman <[email-masked]>
Date: Fri, 28 Oct 2016 09:39:48 +0000

This is definitely possible – MMUSIC Seoul agenda is not set in stone, but please be aware that the single MMUSIC session is only an hour in total.
/Bo
MMUSIC co-chair

From: mmusic [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: den 28 oktober 2016 10:49
To: Martin Thomson <[email-masked]>
Cc: Ben Campbell <[email-masked]>; mmusic <[email-masked]>; ART ADs <[email-masked]>; Flemming Andreasen <[email-masked]>; Cullen Jennings <[email-masked]>; Christer Holmberg <[email-masked]>
Subject: Re: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update (was Re: Rough concensus: Re: 4572-update: Consensus call on how to move forward)]

-Ekr

On Fri, Oct 28, 2016 at 4:11 PM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 28 Oct 2016 13:23:16 +0000

Hi,

Keep in mind that this would most likely not be a thing where the presenter (me, I assume) shows a slide that people the comment on. It would mostly be a “behind the microphone argume… eeeh.. discussion” between a few people, so I wonder whether the WG session is the best place to discuss this.

Regards,

Christer

From: Bo Burman <[email-masked]<mailto:[email-masked]>>
Date: Friday 28 October 2016 at 12:39
To: Eric Rescorla <[email-masked]<mailto:[email-masked]>>, Martin Thomson <[email-masked]<mailto:[email-masked]>>
Cc: Ben Campbell <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, ART ADs <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>, Cullen Jennings <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: RE: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update (was Re: Rough concensus: Re: 4572-update: Consensus call on how to move forward)]

From: mmusic [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: den 28 oktober 2016 10:49
To: Martin Thomson <[email-masked]<mailto:[email-masked]>>
Cc: Ben Campbell <[email-masked]<mailto:[email-masked]>>; mmusic <[email-masked]<mailto:[email-masked]>>; ART ADs <[email-masked]<mailto:[email-masked]>>; Flemming Andreasen <[email-masked]<mailto:[email-masked]>>; Cullen Jennings <[email-masked]<mailto:[email-masked]>>; Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update (was Re: Rough concensus: Re: 4572-update: Consensus call on how to move forward)]

-Ekr

---

From: Roman Shpount <[email-masked]>
Date: Fri, 28 Oct 2016 09:43:26 -0400

In general, the two opposing champions are Cullen (asking not to update the
required hash algorithm) and Martin (who asked to make SHA-256 the
requirement in the first place).

Can I suggest two of them to have a call and see if one can convince the
other? The group had its consensus call, but based on my discussion with
Christer, the draft authors do not particularly care either way regarding
mandatory hash function selection issue. If Martin and Cullen can agree on
the way forward regarding this, they can bring the result to the group and
I am sure we will accommodate it. If they cannot reach an agreement, then
we can look at other ways to resolve it.

Please note, that Chirster and I do feel strongly that the new draft should
be considered an update to RFC 4572, since it clarifies the multiple
fingerprint related issues. I do believe any of the 4572 implementations
should be compliant with the new draft in order to avoid interop issues.

Regards,

_____________
Roman Shpount

On Fri, Oct 28, 2016 at 9:23 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> Keep in mind that this would most likely not be a thing where the
> presenter (me, I assume) shows a slide that people the comment on. It would
> mostly be a “behind the microphone argume… eeeh.. discussion” between a few
> people, so I wonder whether the WG session is the best place to discuss
> this.
>
> Regards,
>
> Christer
>
> From: Bo Burman <[email-masked]>
> To: Eric Rescorla <[email-masked]>, Martin Thomson <[email-masked]
> >
> Cc: Ben Campbell <[email-masked]>, "[email-masked]" <[email-masked]>,
> ART ADs <[email-masked]>, Flemming Andreasen <[email-masked]>,
> Cullen Jennings <[email-masked]>, Christer Holmberg <
> [email-masked]>
> Subject: RE: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update (was
> Re: Rough concensus: Re: 4572-update: Consensus call on how to move
> forward)]
>
> This is definitely possible – MMUSIC Seoul agenda is not set in stone, but
> please be aware that the single MMUSIC session is only an hour in total.
>
> /Bo
>
> MMUSIC co-chair
>
>
>
> *From:* mmusic [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Eric Rescorla
> *Sent:* den 28 oktober 2016 10:49
> *To:* Martin Thomson <[email-masked]>
> *Cc:* Ben Campbell <[email-masked]>; mmusic <[email-masked]>; ART ADs <
> [email-masked]>; Flemming Andreasen <[email-masked]>; Cullen
> Jennings <[email-masked]>; Christer Holmberg <christer.holmberg@ericsson.
> com>
> *Subject:* Re: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update
> (was Re: Rough concensus: Re: 4572-update: Consensus call on how to move
> forward)]
>
>
>

---

From: "Ben Campbell" <[email-masked]>
Date: Fri, 28 Oct 2016 09:43:57 -0500

> requirement in the first place).

If Martin is critical to this conversation, then the conversation should 
wait for him. But I agree with Christer that this is likely to be a 
behind-the-mike discussion. I half expect that to end with "interested 
parties please gather for a side meeting."

The point being: If a group call cannot happen prior to Seoul, then I 
strongly suggest interested parties arrange a side meeting there _prior_ 
to the MMUSIC meeting (currently scheduled Wednesday morning).

(I understand the AD is somewhat frustrated over the draft being stuck 
on this point ;-)  )

> we can look at other ways to resolve it.

I highly encourage that in any case.

> should be compliant with the new draft in order to avoid interop 

I take that to mean that if Martin and Cullen go off and decide the 
"updates" tag is not needed, you will be unhappy? If so, please try to 
participate in any such call.

>>> or

---

From: Roman Shpount <[email-masked]>
Date: Fri, 28 Oct 2016 11:07:59 -0400

Essentially there are two issues:

1. Should we mandate the SHA-256
2. Should this be an update to RFC 4572

I do not care about mandating SHA-256. Christer updated the draft to
include this at Martin's request. Then he removed it at Cullen's request. I
would ask two of them to talk and try to come to an agreement.

I do care strongly about this document being an update to RFC 4572 and will
be unhappy if this tag is removed. RFC 4572 is ambiguous in regard to
multiple fingerprints. Two implementations can currently claim compliance
with RFC 4572 but fail to work with each other. I want this resolved and I
think this requires an update.

Regards,
_____________
Roman Shpount

On Fri, Oct 28, 2016 at 10:43 AM, Ben Campbell <[email-masked]> wrote:

> strongly suggest interested parties arrange a side meeting there _prior_ to
> the MMUSIC meeting (currently scheduled Wednesday morning).
>
> (I understand the AD is somewhat frustrated over the draft being stuck on
> this point ;-)  )
>
>
>
>>>> Cc: Ben Campbell <[email-masked]>, "[email-masked]" <[email-masked]
>>> >,

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 28 Oct 2016 15:19:02 +0000

Hi,

Just to clarify: even though I do want the  spec to be an update to 4572, I am happy with the note saying that the spec does not make existing implementations non-compliant with 4572.

Regards,

Christer

Sent from my iPhone

On 28 Oct 2016, at 18.08, Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:

I do not care about mandating SHA-256. Christer updated the draft to include this at Martin's request. Then he removed it at Cullen's request. I would ask two of them to talk and try to come to an agreement.

I do care strongly about this document being an update to RFC 4572 and will be unhappy if this tag is removed. RFC 4572 is ambiguous in regard to multiple fingerprints. Two implementations can currently claim compliance with RFC 4572 but fail to work with each other. I want this resolved and I think this requires an update.

Regards,
_____________
Roman Shpount

On Fri, Oct 28, 2016 at 10:43 AM, Ben Campbell <[email-masked]<mailto:[email-masked]>> wrote:
On 28 Oct 2016, at 8:43, Roman Shpount wrote:

If Martin is critical to this conversation, then the conversation should wait for him. But I agree with Christer that this is likely to be a behind-the-mike discussion. I half expect that to end with "interested parties please gather for a side meeting."

The point being: If a group call cannot happen prior to Seoul, then I strongly suggest interested parties arrange a side meeting there _prior_ to the MMUSIC meeting (currently scheduled Wednesday morning).

(I understand the AD is somewhat frustrated over the draft being stuck on this point ;-)  )

I take that to mean that if Martin and Cullen go off and decide the "updates" tag is not needed, you will be unhappy? If so, please try to participate in any such call.

Regards,

_____________
Roman Shpount

On Fri, Oct 28, 2016 at 9:23 AM, Christer Holmberg <
[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer

From: Bo Burman <[email-masked]<mailto:[email-masked]>>
Date: Friday 28 October 2016 at 12:39
To: Eric Rescorla <[email-masked]<mailto:[email-masked]>>, Martin Thomson <[email-masked]<mailto:[email-masked]>

Cc: Ben Campbell <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
ART ADs <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>,
Cullen Jennings <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <
[email-masked]<mailto:[email-masked]>>
Subject: RE: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update (was
Re: Rough concensus: Re: 4572-update: Consensus call on how to move
forward)]

/Bo

MMUSIC co-chair

*From:* mmusic [mailto:[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>] *On
Behalf Of *Eric Rescorla
*Sent:* den 28 oktober 2016 10:49
*To:* Martin Thomson <[email-masked]<mailto:[email-masked]>>
*Cc:* Ben Campbell <[email-masked]<mailto:[email-masked]>>; mmusic <[email-masked]<mailto:[email-masked]>>; ART ADs <
[email-masked]<mailto:[email-masked]>>; Flemming Andreasen <[email-masked]<mailto:[email-masked]>>; Cullen
Jennings <[email-masked]<mailto:[email-masked]>>; Christer Holmberg <christer.holmberg@ericsson.
com>
*Subject:* Re: [MMUSIC] Doodle poll [Re: Moving Forward on 4572-update

-Ekr

On Fri, Oct 28, 2016 at 4:11 PM, Martin Thomson <[email-masked]<mailto:[email-masked]>>
wrote:

On 26 October 2016 at 15:54, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>
wrote:
A Doodle poll is now available at

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 28 Oct 2016 15:22:03 +0000

Hi,

I was going to suggest a side meeting, but forgot.

When would people be available? Sunday? Monday? 

Tuesday is pretty full with sessions I assume most of the affected parties will attend.

Regards,

Christer 

Sent from my iPhone

> On 28 Oct 2016, at 17.44, Ben Campbell <[email-masked]> wrote:
>

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 28 Oct 2016 09:24:58 -0600

> On Oct 28, 2016, at 9:07 AM, Roman Shpount <[email-masked]> wrote:
> 
> I would ask two of them to talk and try to come to an agreement.

I’m happy to talk to Martin and a time that is more sane for him and we can report back to the WG.

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 28 Oct 2016 12:00:11 -0400

Ok - let's proceed that way as the first step then. When will the two of 
you talk and when will you report back to the WG ?

Assuming that will happen by early next week, I would still like to have 
a call scheduled for later next week to ensure progress, and it seems 
everybody except Martin is available Friday at 10 AM Eastern, so that is 
when we will schedule it.

Best case scenario will be that all is resolved before then and we can 
cancel the call; worst case we will use the call to prep for further 
discussion in Seoul. Since Martin is a major stakeholder and not able to 
participate Friday, there will of course not be any decisions made in 
the Friday meeting (which in any case would be subject to mailing list 
confirmation)

Thanks

-- Flemming (with chair hat on)