Subject: Re: [MMUSIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 - Cullen's non-major issues - normalization

From: Christer Holmberg <[email-masked]>
Date: Thu, 6 Oct 2016 12:22:57 +0000

Hi,

>>14.1 specifies uses of UTF strings that implementation need to compare.
>>Should specify normalization for this.
>
>I'll look into that.

I looked into this. As far as I understand, SDP attribute values are
case-sensitive, so is there a reason why we simply can¹t say that when the
mid is carried in an RTCP MID SDES item, or in a RTP SDES header
extension, endpoints MUST use keep the case?

Regards,

Christer

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 6 Oct 2016 15:53:30 -0600

> On Oct 6, 2016, at 6:22 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
> case-sensitive, so is there a reason why we simply canąt say that when the

Oh, I think comparing UTF is bit more complicated than that if we want to allow for UTF outside the range of the first 128 code points.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 7 Oct 2016 02:55:36 +0000

Hi,

We only need to consider characters that are allowed within the mid attribute, i.e., token.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Cullen Jennings<mailto:[email-masked]>
Sent: ‎07/‎10/‎2016 00:53
To: Christer Holmberg<mailto:[email-masked]>
Cc: mmusic WG<mailto:[email-masked]>
Subject: Re: [MMUSIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 - Cullen's non-major issues - normalization