Subject: Re: [MMUSIC] USIC] Review of draft-ietf-mmusic-sdp-bundle-negotiation-32 - RTP demux - A new text proposal

From: Bernard Aboba <[email-masked]>
Date: Thu, 20 Oct 2016 12:07:51 -0500

I think your proposed text is missing some PT-matching aspects.  Basically,
JSEP matches the MID, then SSRC, then PT.  However, if there are non-unique
PTs, both JSEP as well as ORTC end up routing to one of the RtpReceivers
(though they currently disagree as to which one) rather than dropping the
packet.

   If an offerer and answerer is not able to associate an RTP stream
   with an "m=" line (using the mechanisms described in this section, or
   using other appropriate mechanism), it SHOULD drop the RTP/RTCP
   packets associated with the RTP stream, once non-stream specific
   processing (e.g., related to congestion control) of the packets have
   occurred.  Note that RTCP packets might be associated with multiple
   RTP streams.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Oct 2016 18:08:52 +0000

>I think your proposed text is missing some PT-matching aspects. Basically, JSEP matches the MID, then SSRC, then PT.

I can say “…or using other appropriate mechanisms, e.g, based on the payload type value if it is unique to a single “m=” line)”

> However, if there are non-unique PTs, both JSEP as well as ORTC end up routing to one of the
> RtpReceivers (though they currently disagree as to which one) rather than dropping the packet.

I can say “…MUST either drop the RTP/RTCP packets associated with the RTP stream, or process them in some application specific manner, one non-stream…”

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 20 Oct 2016 15:02:11 -0400

On 10/20/16 1:07 PM, Bernard Aboba wrote:
> I think your proposed text is missing some PT-matching aspects.
> Basically, JSEP matches the MID, then SSRC, then PT.  However, if there
> are non-unique PTs, both JSEP as well as ORTC end up routing to one of
> the RtpReceivers (though they currently disagree as to which one) rather
> than dropping the packet.

IMO this case ought to be considered out of scope and the behavior 
undefined.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Oct 2016 19:49:13 +0000

Hi,

>> Basically, JSEP matches the MID, then SSRC, then PT.  However, if 
>> there are non-unique PTs, both JSEP as well as ORTC end up routing to 
>> one of the RtpReceivers (though they currently disagree as to which 
>> one) rather than dropping the packet.
>
> IMO this case ought to be considered out of scope and the behaviour undefined.

I agree, and I suggest that we say that packets can be dropped, or processed based on whatever application specific behaviour.

Regards,

Christer

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 21 Oct 2016 11:34:36 +0200

>    occurred.  Note that RTCP packets might be associated with multiple

I think that is unnecessary and agree that this is out of scope. Bundle 
requires one to use MIDs as identifiers. So either use MID and BUNDLE, 
else don't bundle. I don't see the need for describing behavior that is 
not the intended when using BUNDLE.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------