Subject: [MMUSIC] Fwd: New Version Notification for draft-ietf-mmusic-rfc4566bis-19.txt

From: "Ali C. Begen" <[email-masked]>
Date: Sat, 17 Jun 2017 01:32:11 +0300

Hi everyone

There have been some comments on and off the list regarding the 4566bis
draft and with this update, I am hoping that I made all the changed asked
for. There were a few errors that were taken care of, some ABNF syntax has
been improved, references have been updated, etc.

https://www.ietf.org/rfcdiff?url1=draft-ietf-mmusic-rfc4566bis-18&url2=draft-ietf-mmusic-rfc4566bis-19

Please check whether you have outstanding issues or not. I saw that the
chairs updated the milestone for this draft, and from my perspective, the
draft is ready to go to WGLC.

-acbegen

PS Van J.'s email is bouncing and I was told his current email was
[email-masked]. I sent an email, but no response. If anybody has more info
on this, let me know. We need a working email for him to go thru the
publication process.

---------- Forwarded message ----------
From: <[email-masked]>
Date: Sat, Jun 17, 2017 at 1:23 AM
Subject: New Version Notification for draft-ietf-mmusic-rfc4566bis-19.txt
To: Colin Perkins <[email-masked]>, Mark Handley <[email-masked]>,
Ali Begen <[email-masked]>, Van Jacobson <[email-masked]>

A new version of I-D, draft-ietf-mmusic-rfc4566bis-19.txt
has been successfully submitted by Ali Begen and posted to the
IETF repository.

Name:           draft-ietf-mmusic-rfc4566bis
Revision:       19
Title:          SDP: Session Description Protocol
Document date:  2017-06-17
Group:          mmusic
Pages:          61
URL:            https://www.ietf.org/internet-drafts/draft-ietf-mmusic-
rfc4566bis-19.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-mmusic-
rfc4566bis/
Htmlized:       https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-19
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-
rfc4566bis-19
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-
rfc4566bis-19

Abstract:
   This memo defines the Session Description Protocol (SDP).  SDP is
   intended for describing multimedia sessions for the purposes of
   session announcement, session invitation, and other forms of
   multimedia session initiation.  This document obsoletes RFC 4566.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 19 Jun 2017 11:02:16 -0400

Hi Ali,

On 6/16/17 6:32 PM, Ali C. Begen wrote:
> draft and with this update, I am hoping that I made all the changed 
> asked for. There were a few errors that were taken care of, some ABNF 
> syntax has been improved, references have been updated, etc.
> 
> chairs updated the milestone for this draft, and from my perspective, 
> the draft is ready to go to WGLC.

I like the change to the grammar that moves the notation for 
optionality/repetition of individual fields from the definition of those 
fields to the overall definition of the session-description:

    session-description = proto-version
                          origin-field
                          session-name-field
                          [information-field]
                          [uri-field]
                          *email-fields
                          *phone-fields
                          [connection-field]
                          *bandwidth-fields
                          1*time-fields
                          [key-field]
                          *attribute-fields
                          *media-descriptions

However, this change induced a bug in the definition of media-descriptions:

    media-descriptions =  media-field
                          information-field
                          *connection-field
                          bandwidth-fields
                          key-field
                          attribute-fields

This needs the same changes made to session-description. So this needs 
to be changed to:

    media-descriptions =  media-field
                          [information-field]
                          *connection-field
                          *bandwidth-fields
                          [key-field]
                          *attribute-fields

Also this change does result in some very odd naming, where the names of 
some fields are plural but now ought to be singular. These ought to be 
fixed. Specifically:

email-fields => email-field
phone-fields => phone-field
bandwidth-fields => bandwidth-field
time-fields => time-field
attribute-fields => attribute-field
media-descriptions => media-description

Otherwise the new version seems good to me.

	Thanks,
	Paul

---

From: "Ali C. Begen" <[email-masked]>
Date: Thu, 22 Jun 2017 02:39:34 +0300

Hi Paul

Thanks for catching the error. It is fixed and submitted now.

-acbegen

On Mon, Jun 19, 2017 at 6:02 PM, Paul Kyzivat <[email-masked]>
wrote:

>> https://www.ietf.org/rfcdiff?url1=draft-ietf-mmusic-rfc4566b
>> is-18&url2=draft-ietf-mmusic-rfc4566bis-19
>>
> This needs the same changes made to session-description. So this needs to
> be changed to:
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 22 Jun 2017 15:16:21 -0400

One thing you missed in the ABNF def of media-description:

s/*attribute-fields/*attribute-field/

Otherwise looks good.

	Thanks,
	Paul

On 6/21/17 7:39 PM, Ali C. Begen wrote:
> On Mon, Jun 19, 2017 at 6:02 PM, Paul Kyzivat <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hi Ali,
> 
>         There have been some comments on and off the list regarding the
>         4566bis draft and with this update, I am hoping that I made all
>         the changed asked for. There were a few errors that were taken
>         care of, some ABNF syntax has been improved, references have
>         been updated, etc.
> 
>         <https://www.ietf.org/rfcdiff?url1=draft-ietf-mmusic-rfc4566bis-18&url2=draft-ietf-mmusic-rfc4566bis-19>
> 
>         Please check whether you have outstanding issues or not. I saw
>         that the chairs updated the milestone for this draft, and from
>         my perspective, the draft is ready to go to WGLC.
> 
> 
>     optionality/repetition of individual fields from the definition of
>     those fields to the overall definition of the session-description:
> 
>     This needs the same changes made to session-description. So this
>     needs to be changed to:
> 
>     Also this change does result in some very odd naming, where the
>     names of some fields are plural but now ought to be singular. These
>     ought to be fixed. Specifically:
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/mmusic>
> 
> 
> 
>