Subject: [MMUSIC] Fwd: New Version Notification for draft-ietf-mmusic-rfc4566bis-21.txt

From: "Ali C. Begen" <[email-masked]>
Date: Thu, 29 Jun 2017 12:02:25 +0300

Hi everyone

This fixes Paul's and Gunnar's comments.

-acbegen

---------- Forwarded message ----------
From: <[email-masked]>
Date: Thu, Jun 29, 2017 at 12:00 PM
Subject: New Version Notification for draft-ietf-mmusic-rfc4566bis-21.txt
To: Colin Perkins <[email-masked]>, Mark Handley <[email-masked]>,
Ali Begen <[email-masked]>, Van Jacobson <[email-masked]>

A new version of I-D, draft-ietf-mmusic-rfc4566bis-21.txt
has been successfully submitted by Ali Begen and posted to the
IETF repository.

Name:           draft-ietf-mmusic-rfc4566bis
Revision:       21
Title:          SDP: Session Description Protocol
Document date:  2017-06-29
Group:          mmusic
Pages:          61
URL:            https://www.ietf.org/internet-drafts/draft-ietf-mmusic-
rfc4566bis-21.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-mmusic-
rfc4566bis/
Htmlized:       https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-21
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-
rfc4566bis-21
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-
rfc4566bis-21

Abstract:
   This memo defines the Session Description Protocol (SDP).  SDP is
   intended for describing multimedia sessions for the purposes of
   session announcement, session invitation, and other forms of
   multimedia session initiation.  This document obsoletes RFC 4566.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Jun 2017 12:54:48 -0400

> This fixes Paul's and Gunnar's comments.

I ran this abnf through bap for a formal check and found a couple of things:

1) The definition of media-description still references bandwidth-fields 
rather than bandwidth-field.

2) The definition of key-type is not right - it seems to have lost a lot 
in the process of adopting the %s notation. To preserve compatibility 
with 4566 it should be:

    key-type =            %s"prompt" /
                          %s"clear:" text  /
                          %s"base64:" base64 /
                          %s"uri:" uri

Otherwise looks good to me.

	Thanks,
	Paul

> From: ** <[email-masked] <mailto:[email-masked]>>
> To: Colin Perkins <[email-masked] <mailto:[email-masked]>>, Mark 
> Handley <[email-masked] <mailto:[email-masked]>>, Ali 
> Begen <[email-masked]>, Van Jacobson <[email-masked] 
> <mailto:[email-masked]>>
> 
> 
> 
> URL: 
> https://www.ietf.org/internet-drafts/draft-ietf-mmusic-rfc4566bis-21.txt 
> <https://www.ietf.org/internet-drafts/draft-ietf-mmusic-rfc4566bis-21.txt>
> Status: https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/ 
> <https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/>
> <https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-21>
> Htmlized: 
> https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-rfc4566bis-21 
> <https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-rfc4566bis-21>
> Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-rfc4566bis-21 
> <https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-rfc4566bis-21>
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org 
> <http://tools.ietf.org>.
> 
> The IETF Secretariat
> 
> 
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: "Ali C. Begen" <[email-masked]>
Date: Fri, 30 Jun 2017 17:34:09 +0300

Thanks Paul, v22 should be all good now.

-acbegen

On Thu, Jun 29, 2017 at 7:54 PM, Paul Kyzivat <[email-masked]>
wrote:

> in the process of adopting the %s notation. To preserve compatibility with
> 4566 it should be:
>
>    key-type =            %s"prompt" /
>                          %s"clear:" text  /
>                          %s"base64:" base64 /
>                          %s"uri:" uri
>
>
>> Begen <[email-masked]>, Van Jacobson <[email-masked] <mailto:
>> [email-masked]>>
>>
>>
>>
>> URL: https://www.ietf.org/internet-drafts/draft-ietf-mmusic-rfc45
>> 66bis-21.txt <https://www.ietf.org/internet-drafts/draft-ietf-mmusic-
>> rfc4566bis-21.txt>
>> Status: https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/ <
>> https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/>
>> Htmlized: https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-21 <
>> https://tools.ietf.org/html/draft-ietf-mmusic-rfc4566bis-21>
>> Htmlized: https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-rfc4
>> 566bis-21 <https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-rfc
>> 4566bis-21>
>> Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-rfc4566bis-21 <
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-rfc4566bis-21>
>>
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <
>> http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>>
>>
>>