Subject: [MMUSIC] Presentation for a call if DTLS Association be started if not requested in the offer

From: Roman Shpount <[email-masked]>
Date: Thu, 28 Sep 2017 01:37:50 -0400

Hi All,

Attached is the presentation for the call tomorrow (or later today)

Once again, conference call information:

*Join the meeting: join.me/112-807-485 <https://join.me/112-807-485>*

Thursday, September 28, 2017 12:00 PM
Eastern Time (US & Canada)
In my time zone? <https://join.me/timezone/1506614400000/1506621600000>
*To dial in by phone:*

United States - Los Angeles, CA
*+1.213.226.1066 <+1.213.226.1066,,112807485#>*

United States - New York, NY
*+1.646.307.1990 <+1.646.307.1990,,112807485#>*

United States - San Francisco, CA
*+1.415.594.5500 <+1.415.594.5500,,112807485#>*

United States - Washington, DC
*+1.202.602.1295 <+1.202.602.1295,,112807485#>*

Australia - Sydney
*+61.2.9191.6319 <+61.2.9191.6319,,112807485#>*

France - Paris
*+33.1.8288.3590 <+33.1.8288.3590,,112807485#>*

Germany - Berlin
*+49.30.2240.3071 <+49.30.2240.3071,,112807485#>*

Singapore - national
*+65.3158.1842 <+65.3158.1842,,112807485#>*

United Kingdom - London
*+44.20.3582.4515 <+44.20.3582.4515,,112807485#>*

More phone numbers <https://join.me/intphone/112807485/0>

Conference ID:
*112-807-485 #*

Need to share screen?  Download the app <https://join.me/app>

Regards,

_____________
Roman Shpount

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Sep 2017 06:22:36 +0000

Thanks Roman!

I would request those that do NOT want to allow an answerer to trigger a new DTLS association to prepare a description (verbally or using slides) on how they suggest handling interoperability with legacy peers that may trigger a new DTLS association in the answer.

Regards,

Christer

From: Roman Shpount <[email-masked]<mailto:[email-masked]>>
Date: Thursday 28 September 2017 at 08:37
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ben Campbell <[email-masked]<mailto:[email-masked]>>, Bernard Aboba <[email-masked]<mailto:[email-masked]>>, Bo Burman <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>, Flemming Andreasen <[email-masked]<mailto:[email-masked]>>, Jonathan Lennox <[email-masked]<mailto:[email-masked]>>, Justin Uberti <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Presentation for a call if DTLS Association be started if not requested in the offer

Hi All,

Join the meeting: join.me/112-807-485<https://join.me/112-807-485>

Thursday, September 28, 2017 12:00 PM
Eastern Time (US & Canada)
In my time zone?<https://join.me/timezone/1506614400000/1506621600000>

To dial in by phone:

United States - Los Angeles, CA
+1.213.226.1066<tel:+1.213.226.1066,,112807485#>

United States - New York, NY
+1.646.307.1990<tel:+1.646.307.1990,,112807485#>

United States - San Francisco, CA
+1.415.594.5500<tel:+1.415.594.5500,,112807485#>

United States - Washington, DC
+1.202.602.1295<tel:+1.202.602.1295,,112807485#>

Australia - Sydney
+61.2.9191.6319<tel:+61.2.9191.6319,,112807485#>

France - Paris
+33.1.8288.3590<tel:+33.1.8288.3590,,112807485#>

Germany - Berlin
+49.30.2240.3071<tel:+49.30.2240.3071,,112807485#>

Singapore - national
+65.3158.1842<tel:+65.3158.1842,,112807485#>

United Kingdom - London
+44.20.3582.4515<tel:+44.20.3582.4515,,112807485#>

More phone numbers<https://join.me/intphone/112807485/0>

Conference ID:
112-807-485 #

Need to share screen?  Download the app<https://join.me/app>

Regards,

_____________

Roman Shpount

---

From: Roman Shpount <[email-masked]>
Date: Thu, 28 Sep 2017 05:14:15 -0400

Hi All,

I would also like to see if and how exactly allowing new DTLS association
when not requested in the offer, contradicts JSEP.

Roman Shpount

On Sep 28, 2017 02:22, "Christer Holmberg" <[email-masked]>
wrote:

Thanks Roman!

I would request those that do NOT want to allow an answerer to trigger a
new DTLS association to prepare a description (verbally or using slides) on
how they suggest handling interoperability with legacy peers that may
trigger a new DTLS association in the answer.

Regards,

Christer

From: Roman Shpount <[email-masked]>
Date: Thursday 28 September 2017 at 08:37
To: Christer Holmberg <[email-masked]>, "[email-masked]" <
[email-masked]>, Ben Campbell <[email-masked]>, Bernard Aboba <
[email-masked]>, Bo Burman <[email-masked]>, Eric
Rescorla <[email-masked]>, Flemming Andreasen <[email-masked]>, Jonathan
Lennox <[email-masked]>, Justin Uberti <[email-masked]>, "
[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>
Subject: Presentation for a call if DTLS Association be started if not
requested in the offer

Hi All,

Australia - Sydney

France - Paris

Germany - Berlin

Singapore - national

United Kingdom - London

Conference ID:
*112-807-485 #*

Regards,

_____________
Roman Shpount

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Sep 2017 11:29:00 +0200

The relevant text is here
https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-23#section-5.8.3

         tls-id value, which MUST be set according to
         [I-D.ietf-mmusic-dtls-sdp], Section 5.  If this is a re-offer
         and the tls-id value is different from that presently in use,
         the DTLS connection is not being continued and the remote
         description MUST be part of an ICE restart, together with new
         ufrag and password values.  If this is an answer, the tls-id
         value, if present, MUST be the same as in the offer.

This is no longer precisely correct because you've made the answerer
provide its own tls-id,
but the clear implication is that the answerer cannot unilaterally restart
DTLS. It's when
we went to update it to handle the newer syntax, we found the conflict.

-Ekr

On Thu, Sep 28, 2017 at 11:14 AM, Roman Shpount <[email-masked]> wrote:

> To: Christer Holmberg <[email-masked]>, "[email-masked]"
> <[email-masked]>, Ben Campbell <[email-masked]>, Bernard Aboba <
> Rescorla <[email-masked]>, Flemming Andreasen <[email-masked]>,
> Jonathan Lennox <[email-masked]>, Justin Uberti <[email-masked]>,
> "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Sep 2017 12:48:17 +0000

Hi,

>The relevant text is here https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-23#section-5.8.3
>
> This is no longer precisely correct because you've made the answerer provide its own tls-id,
> but the clear implication is that the answerer cannot unilaterally restart DTLS. It's when

It’s true that the answerer provides its own tls-id, but I don’t understand why that would imply that it can’t restart DTLS.

Also, I’d like to hear your suggestion on how to handle backward compatibility with endpoints that don’t support tls-id (read: endpoints that may trigger new DTLS association in the answer). Maybe the problem will go away one day, but I don’t think we can just close our eyes and wait for that day to come…

Regards,

Christer

On Thu, Sep 28, 2017 at 11:14 AM, Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

I would also like to see if and how exactly allowing new DTLS association when not requested in the offer, contradicts JSEP.

Roman Shpount

On Sep 28, 2017 02:22, "Christer Holmberg" <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Roman!

Regards,

Christer

Hi All,

To dial in by phone:

Australia - Sydney

France - Paris

Germany - Berlin

Singapore - national

United Kingdom - London

Conference ID:
112-807-485 #

Regards,

_____________

Roman Shpount

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Sep 2017 15:19:17 +0200

On Thu, Sep 28, 2017 at 2:48 PM, Christer Holmberg <
[email-masked]> wrote:

> It’s true that the answerer provides its own tls-id, but I don’t
> understand why that would imply that it can’t restart DTLS.
>

As I said, the original text assumed that the answerer *copied* the TLS-ID
and that is because we assumed that the answerer couldn't, so just because
we've changed the syntax doesn't mean we think the logic should change.

Also, I’d like to hear your suggestion on how to handle backward
> compatibility with endpoints that don’t support tls-id (read: endpoints
> that may trigger new DTLS association in the answer). Maybe the problem
> will go away one day, but I don’t think we can just close our eyes and wait
> for that day to come…
>

Which endpoints do that? Because that's absolutely going to be forbidden by
JSEP.

-Ekr

>> On Sep 28, 2017 02:22, "Christer Holmberg" <[email-masked]
>> m> wrote:
>>
>> Thanks Roman!
>>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Sep 2017 13:36:30 +0000

Hi,

Š

>> Also, I¹d like to hear your suggestion on how to handle backward
>>compatibility with endpoints that don¹t support tls-id
>> (read: endpoints that may trigger new DTLS association in the answer).
>>Maybe the problem will go away one day, but I don¹t think we
>> can just close our eyes and wait for that day to comeŠ
>
> Which endpoints do that? Because that's absolutely going to be forbidden
>by JSEP.

³Legacy² RFC 5763-compliant endpoints that don¹t support tls-id.

Regards,

Christer

On Thu, Sep 28, 2017 at 11:14 AM, Roman Shpount
<[email-masked]> wrote:

Hi All,

Roman Shpount

On Sep 28, 2017 02:22, "Christer Holmberg"
<[email-masked]> wrote:

Thanks Roman!

I would request those that do NOT want to allow an answerer to trigger a
new DTLS association to prepare a description (verbally or using slides)
on how they suggest handling interoperability with legacy peers that may
trigger a new DTLS association in
 the answer. 

Regards,

Christer

From: Roman Shpount <[email-masked]>
Date: Thursday 28 September 2017 at 08:37
To: Christer Holmberg <[email-masked]>, "[email-masked]"
<[email-masked]>,
 Ben Campbell <[email-masked]>, Bernard Aboba
<[email-masked]>, Bo Burman <[email-masked]>,
 Eric Rescorla <[email-masked]>, Flemming Andreasen <[email-masked]>,
Jonathan Lennox <[email-masked]>,
 Justin Uberti <[email-masked]>, "[email-masked]"
<[email-masked]>,
 "[email-masked]" <[email-masked]>
Subject: Presentation for a call if DTLS Association be started if not
requested in the offer

Hi All,

Once again, conference call information:
Join the meeting: join.me/112-807-485 <https://join.me/112-807-485>

Thursday, September
 28, 2017 12:00 PM 
Eastern Time (US & Canada)
In
 my time zone? <https://join.me/timezone/1506614400000/1506621600000>
To dial in by phone:United States - Los Angeles, CA
+1.213.226.1066 <tel:+1.213.226.1066,,112807485#>
United States - New York, NY
+1.646.307.1990 <tel:+1.646.307.1990,,112807485#>
United States - San Francisco, CA
+1.415.594.5500 <tel:+1.415.594.5500,,112807485#>
United States - Washington, DC
+1.202.602.1295 <tel:+1.202.602.1295,,112807485#>
Australia - Sydney 
+61.2.9191.6319 <tel:+61.2.9191.6319,,112807485#>
France - Paris 
+33.1.8288.3590 <tel:+33.1.8288.3590,,112807485#>
Germany - Berlin 
+49.30.2240.3071 <tel:+49.30.2240.3071,,112807485#>
Singapore - national
+65.3158.1842 <tel:+65.3158.1842,,112807485#>
United Kingdom - London
+44.20.3582.4515 <tel:+44.20.3582.4515,,112807485#>
More phone numbers <https://join.me/intphone/112807485/0>
Conference ID: 
112-807-485 #
Need to share screen?  Download
 the app <https://join.me/app>
Regards,
_____________

Roman Shpount

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 28 Sep 2017 15:54:31 +0200

> ³Legacy² RFC 5763-compliant endpoints that don¹t support tls-id.

Sorry, I was asking "which actual implementations do this"?

-Ekr

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 28 Sep 2017 14:29:10 +0000

Hi,

...

>>>>an just close our eyes and wait for that day to comeŠ
>>>
>>‘Legacy' RFC 5763-compliant endpoints that don¹t support tls-id.
>>

I don’t know - perhaps Roman knows?

Regards,

Christer

Hi All,

Roman Shpount

Thanks Roman!

Regards,

Christer

Hi All,

Join the meeting: 
join.me/112-807-485 <http://join.me/112-807-485>
<https://join.me/112-807-485>

Thursday, September
 28, 2017 12:00 PM
Eastern Time (US & Canada)
In
 my time zone? <https://join.me/timezone/1506614400000/1506621600000>
To dial in by phone:United States - Los Angeles, CA
+1.213.226.1066 <tel:%2B1.213.226.1066> <tel:+1.213.226.1066
<tel:%2B1.213.226.1066>,,112807485#>
United States - New York, NY
+1.646.307.1990 <tel:%2B1.646.307.1990> <tel:+1.646.307.1990
<tel:%2B1.646.307.1990>,,112807485#>
United States - San Francisco, CA
+1.415.594.5500 <tel:%2B1.415.594.5500> <tel:+1.415.594.5500
<tel:%2B1.415.594.5500>,,112807485#>
United States - Washington, DC
+1.202.602.1295 <tel:%2B1.202.602.1295> <tel:+1.202.602.1295
<tel:%2B1.202.602.1295>,,112807485#>
Australia - Sydney
+61.2.9191.6319 <tel:%2B61.2.9191.6319> <tel:+61.2.9191.6319
<tel:%2B61.2.9191.6319>,,112807485#>
France - Paris
+33.1.8288.3590 <tel:%2B33.1.8288.3590> <tel:+33.1.8288.3590
<tel:%2B33.1.8288.3590>,,112807485#>
Germany - Berlin
+49.30.2240.3071 <tel:+49.30.2240.3071,,112807485#>
Singapore - national
+65.3158.1842 <tel:+65.3158.1842,,112807485#>
United Kingdom - London
+44.20.3582.4515 <tel:+44.20.3582.4515,,112807485#>
More phone numbers <https://join.me/intphone/112807485/0>
Conference ID:
112-807-485 #
Need to share screen?  Download
 the app <https://join.me/app>
Regards,
_____________

Roman Shpount