Subject: [MMUSIC] 4566bis: media field terminology

From: Thomas Stach <[email-masked]>
Date: Wed, 20 Dec 2017 14:31:16 +0100

Hi,

just a quick observation.

In 5.14 the end of the first para reads:
"A media field has several sub-fields: "

Wouldn't that have to be
"A "m=" line has several sub-fields: "  ?

There are several other occurrences of "media field" in the document,
where sometimes _"m-" line_ and sometimes _media description_ seems to 
be more appropriate.

p.14, 5.6, 3rd para
... before the first media field --> media description
p.21, 1st para
... can also be added before the first media field  --> media description
p.22, 2nd para
  ... defined in the <proto> sub-field of the media field. --> "m-" line

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 20 Dec 2017 13:45:14 +0000

Hi,

There was a previous discussion about this:

https://www.ietf.org/mail-archive/web/mmusic/current/msg18238.html

Regards,

Christer

On 20/12/17 15:31, "mmusic on behalf of Thomas Stach"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mmusic

---

From: Thomas Stach <[email-masked]>
Date: Wed, 20 Dec 2017 17:20:29 +0100

Christer,
while your issue seems to be resolved in -24 my issue is different.

I think -24 is not clear in the usage of  terminology for
"m=" line, media description, media field (Is the <media> thing from the 
first line in 5.14 meant?.
Is this <media> thing a "media field" or a "media sub-field").

In the meantime, I recognized that in the grammar in section 9 there is 
a "media-field" (with dash),
which seems to be the equivalent to a "m-" line(?).
In this "media-field" thing there is a "media" field (or sub-field?).
Is this "media-field" thing (with dash) meant by "media field" (without 
dash ) in 5.14?
If so, the language needs to be made consistent and a cross-ref to the 
grammar section would be worthwhile.

I can guess the answers to the above questions, but believe the usage of 
terminology in  5.14 is at least unfortunate, if not confusing.

BTW: I didn't check the other sections 5.x for similar weirdness.

Regards
Thomas

On 2017-12-20 14:45, Christer Holmberg wrote:
>> "A media field has several sub-fields:"
>>
>> Wouldn't that have to be

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 21 Dec 2017 08:06:25 +0000

Hi,

>grammar section would be worthwhile.

I don¹t think we need ³media field² in the normative text, because I think
it is equivalent to ³m=³ line.

Regards,

Christer

---

From: Thomas Stach <[email-masked]>
Date: Thu, 21 Dec 2017 09:51:13 +0100

inline

> it is equivalent to ³m=³ line.
That's what I'd prefer as well together with the substitutions from my 
initial post (below)
Regards
Thomas