Subject: [MMUSIC] Change of -sdp-mux-attributes needed to align with BUNDLE?

From: Bo Burman <[email-masked]>
Date: Fri, 1 Dec 2017 16:30:11 +0000

WG,

A while ago (in this thread: https://mailarchive.ietf.org/arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U), Taylor concluded that the -sdp-mux-attributes<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/> draft, which is currently in RFC Editor's queue, needs to be updated to align with current BUNDLE<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/> draft.

The -sdp-mux-attributes draft unconditionally requires (in section 4.3) that category IDENTICAL attributes and their values "MUST be repeated across all the media descriptions under multiplexing".

BUNDLE (section 8.1) requires such repetition for IDENTICAL and TRANSPORT only when a BUNDLE group is initially negotiated. When the BUNDLE addresses have been selected, for all "m=" sections but the one carrying the BUNDLE-tag, BUNDLE requires the opposite; MUST NOT include SDP attributes with IDENTICAL or TRANSPORT category.

Does the WG agree that -sdp-mux-attributes has to be changed to align with what is now described by BUNDLE?

Unless anyone objects before EOB Dec 15, we will proceed with such change to -sdp-mux-attributes.

Thanks,

Bo
MMUSIC co-chair

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 1 Dec 2017 23:38:18 +0000

Hi,

As I believe I have said before, we need to separate two things:

1) Whether the attribute value needs to be applied to all m- sections
2) Whether the attribute needs to be explicitly assigned/encoded to all m- sections

In my opinion, draft-mux-attributes shall only cover 1).

2) is BUNDLE specific.

I do agree that it is a little difficult to determine whether “repeat” means 1) or 2).

Regards.

Christer

Sent from my iPhone

On 1 Dec 2017, at 18.30, Bo Burman <[email-masked]<mailto:[email-masked]>> wrote:

WG,

A while ago (in this thread: https://mailarchive.ietf.org/arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U), Taylor concluded that the -sdp-mux-attributes<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/> draft, which is currently in RFC Editor’s queue, needs to be updated to align with current BUNDLE<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/> draft.

The -sdp-mux-attributes draft unconditionally requires (in section 4.3) that category IDENTICAL attributes and their values “MUST be repeated across all the media descriptions under multiplexing”.

BUNDLE (section 8.1) requires such repetition for IDENTICAL and TRANSPORT only when a BUNDLE group is initially negotiated. When the BUNDLE addresses have been selected, for all “m=” sections but the one carrying the BUNDLE-tag, BUNDLE requires the opposite; MUST NOT include SDP attributes with IDENTICAL or TRANSPORT category.

Thanks,

Bo
MMUSIC co-chair

---

From: Suhas Nandakumar <[email-masked]>
Date: Fri, 1 Dec 2017 16:10:15 -0800

> I do agree that it is a little difficult to determine whether “repeat”
Above was my recollection too. I am not sure if we need to change Mux
attributes. Since Mux attributes needs to be read along with the Bundle
spec.
 The Bundle spec may define additional constraints or usage patterns.

> Regards.
>
> Christer
>
> Sent from my iPhone
>
> On 1 Dec 2017, at 18.30, Bo Burman <[email-masked]> wrote:
>
> WG,
>
>
>
> A while ago (in this thread: https://mailarchive.ietf.org/
> arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U), Taylor concluded that the
> -sdp-mux-attributes
> <https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/>
> draft, which is currently in RFC Editor’s queue, needs to be updated to
> align with current BUNDLE
> <https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/>
> draft.
>
>
>
> The -sdp-mux-attributes draft unconditionally requires (in section 4.3)
> that category IDENTICAL attributes and their values “MUST be repeated
> across all the media descriptions under multiplexing”.
>
>
>
> BUNDLE (section 8.1) requires such repetition for IDENTICAL and TRANSPORT
> *only* when a BUNDLE group is initially negotiated. When the BUNDLE
> addresses have been selected, for all “m=” sections but the one carrying
> the BUNDLE-tag, BUNDLE requires the opposite; MUST NOT include SDP
> attributes with IDENTICAL or TRANSPORT category.
>
>
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 5 Dec 2017 09:35:01 +0000

Hi,

>> I do agree that it is a little difficult to determine whether ³repeat²
>>means 1) or 2).
>

I guess a note could have been useful, saying something like:

³NOTE: Eventhough IDENTICAL attributes must be repeated across all media
descriptions under multiplexing, they might not always be explicitly
encoded across all media descriptions. BUNDLE defines rules for when
attributes and their values are implicitly applied to media description.²

Regards.

Christer

Sent from my iPhone

WG,
 
A while ago (in this thread:
https://mailarchive.ietf.org/arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U
<https://mailarchive.ietf.org/arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U>)
, Taylor concluded that the

-sdp-mux-attributes
<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/>
draft, which is currently in RFC Editor¹s queue, needs to be updated to
align with current

BUNDLE 
<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/
 
The -sdp-mux-attributes draft unconditionally requires (in section 4.3)
that category IDENTICAL attributes and their values ³MUST be repeated
across all the media descriptions under multiplexing².
 
BUNDLE (section 8.1) requires such repetition for IDENTICAL and TRANSPORT
only when a BUNDLE group is initially negotiated. When the BUNDLE
addresses have been selected, for all ³m=² sections but the one carrying
the BUNDLE-tag, BUNDLE requires the opposite; MUST NOT include SDP
attributes with IDENTICAL or TRANSPORT category.
 
Does the WG agree that -sdp-mux-attributes has to be changed to align with
what is now described by BUNDLE?
 
Unless anyone objects before EOB Dec 15, we will proceed with such change
to -sdp-mux-attributes.
 
Thanks,
 
Bo
MMUSIC co-chair

---

From: Bo Burman <[email-masked]>
Date: Wed, 20 Dec 2017 13:28:47 +0000

Christer, all,

So, to be clear, you suggest to add such note to the -sdp-mux-attributes draft?
Do the draft authors and the WG agree with that?

/Bo
MMUSIC co-chair

> -----Original Message-----
> From: Christer Holmberg
> Sent: den 5 december 2017 10:35
> To: Suhas Nandakumar <[email-masked]>
> Cc: Bo Burman <[email-masked]>; Ben Campbell <[email-masked]>; draft-ietf-mmusic-sdp-mux-
> [email-masked]; IETF MMUSIC WG <[email-masked]>
> Subject: Re: [MMUSIC] Change of -sdp-mux-attributes needed to align with BUNDLE?
> 
> Hi,
> 
> >> 2) Whether the attribute needs to be explicitly assigned/encoded to
> >>all
> >>m- sections
> >>
> >> I do agree that it is a little difficult to determine whether
> >>³repeat² means 1) or 2).
> >
> ³NOTE: Eventhough IDENTICAL attributes must be repeated across all media descriptions under multiplexing, they might
> not always be explicitly encoded across all media descriptions. BUNDLE defines rules for when attributes and their values
> are implicitly applied to media description.²
> 
> Regards.
> 
> Christer
> 
> 
> 
> 
> Sent from my iPhone
> 
> draft, which is currently in RFC Editor¹s queue, needs to be updated to align with current
> 
> BUNDLE
> The -sdp-mux-attributes draft unconditionally requires (in section 4.3) that category IDENTICAL attributes and their
> values ³MUST be repeated across all the media descriptions under multiplexing².
> 
> BUNDLE (section 8.1) requires such repetition for IDENTICAL and TRANSPORT only when a BUNDLE group is initially
> negotiated. When the BUNDLE addresses have been selected, for all ³m=² sections but the one carrying the BUNDLE-tag,
> BUNDLE requires the opposite; MUST NOT include SDP attributes with IDENTICAL or TRANSPORT category.
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 20 Dec 2017 13:41:58 +0000

Hi,

>So, to be clear, you suggest to add such note to the -sdp-mux-attributes

Yes.

Regards,

Christer

>> ³NOTE: Eventhough IDENTICAL attributes must be repeated across all
>>media descriptions under multiplexing, they might
>> not always be explicitly encoded across all media descriptions. BUNDLE
>>defines rules for when attributes and their values
>><https://mailarchive.ietf.org/arch/msg/mmusic/u__oKBA3GiieVeda8yydyCtuT5U
>>>)
>>that category IDENTICAL attributes and their
>> BUNDLE (section 8.1) requires such repetition for IDENTICAL and
>>TRANSPORT only when a BUNDLE group is initially
>> negotiated. When the BUNDLE addresses have been selected, for all ³m=²
>>sections but the one carrying the BUNDLE-tag,

---

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 20 Dec 2017 08:22:16 -0800

I am fine with the note if it is helping bring clarity. so +1

On Wed, Dec 20, 2017 at 5:41 AM, Christer Holmberg <
[email-masked]> wrote:

> >> <https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-mux-attributes/
> >
> >><https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-
> bundle-negotiatio
> >>n/
> >> > draft.
> >>