Subject: [mobile-ip] Some Analysis

From: James Kempf <[email-masked]>
Date: Thu, 26 Apr 2001 16:01:06 -0700 (PDT)

(second send, first perhaps filtered due to size...)

> Numbers!!!

After having unjustly flamed Erik this morning and being inspired by
his challenge, I went through an analysis comparing signalling
overhead on hierarchical v.s. nonhierarchical designs. The attached
zipped PDF (sorry for the zip, I couldn't get a unzipped through the list size 
filter) and text explain.

Note to H&K: Arguments about the analysis are welcome, but please
don't post "this won't happen in practice" arguments. You may have
your opinion and I may have mine. The math speaks for itself.

		jak

---

From: "Sami Vaarala" <[email-masked]>
Date: Fri, 27 Apr 2001 09:54:12 +0300

James,

> your opinion and I may have mine. The math speaks for itself.

When analysing the non-hierarchical case, you are summing all the
delays to calculate the latency.  Wouldn't the binding updates
(or registration requests) be sent in parallel to both HA, and all
CNs?  Thus the latency would be a maximum of a set of numbers, not
a sum ?

-Sami

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Fri, 27 Apr 2001 09:19:28 +0200

Oh (sigh of relief),
hope that this will make this mailing list discussion
a little bit more fruitful.

No problem with zips, ASCII math formulas etc.
The great thing is that statements are quantifi-ed/-able.

"Thus, the signalling latency in the hierarchical case will always be better."
That's what you can expect from similar questions (effect of divide-and-conquer).
More questions:
How much better is signalling latency?
How is payload affected?
Can the architectural complexities be measured
(which affect program development, maintenance, ...)?
Is there some overall measure which appropriately weights these factors?
And, most importantly, how can answers to these questions convince practicioners?

Wolfgang

James Kempf schrieb:
>   ----------------------------------------------------------------------------------------------------
>                               Name: lmm-analysis.zip
>                               Type: Zip Compressed Data (application/x-zip-compressed)
>    lmm-analysis.zip       Encoding: BASE64
>                        Description: lmm-analysis.zip
>                    Download-Status: Nicht mit der Nachricht heruntergeladen
> 
>                      Name: lmm.zip
>                      Type: Zip Compressed Data (application/x-zip-compressed)
>    lmm.zip       Encoding: BASE64
>               Description: lmm.zip
>           Download-Status: Nicht mit der Nachricht heruntergeladen

-- 
Wolfgang Schoenfeld, GMD-IPSI, Dolivostr. 15, D-64293 Darmstadt
Office: +49-6151-869-865 FAX: -6847 Mobile: +49-174-7093455

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 27 Apr 2001 09:55:06 +0200

oups...
The analysis can actually be found at
http://www.inrialpes.fr/planete/people/ccastel/hmip.ps.gz

sorry about that ...

Claude.

Claude Castelluccia wrote:

> Hello,
>
> Some more analysis can be found in
> http://www.inrialpes.fr/people/ccastel/hmip.ps.gz
>
> This analysis was made 3 years ago when I was working on the design of
> one of the HMIPv6
> ancestor.
>
> Hope this help!
>
> regards,
>
> Claude.
>
> Wolfgang Schoenfeld wrote:
>
>> Oh (sigh of relief),
> ----------------------------------------
> Claude CASTELLUCCIA, INRIA Rhone-Alpes
> ph:  +33 4.76.61.52.15 (fax: 52.52)
> http://www.inrialpes.fr/planete/
>
>

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 27 Apr 2001 09:48:42 +0200

Hello,

Some more analysis can be found in http://www.inrialpes.fr/people/ccastel/hmip.ps.gz

This analysis was made 3 years ago when I was working on the design of one of the HMIPv6
ancestor.

Hope this help!

regards,

Claude.

--