Subject: RE: [mobile-ip] Mobile Netwoks in MIPv6

From: Mohan Parthasarathy <[email-masked]>
Date: Tue, 3 Apr 2001 13:52:29 -0700 (PDT)

> 
> 
> Hello Thierry, 
> 
> One other issue you might want to consider in your draft

Do we really need another draft ? From the discussions we had,
it looked like some clarifications are sufficient. At least
the mail from Mattias explained this clearly i guess.

> is the case where the MR sends a BU that covers the entire
> prefix but another MN (with a Home address on the MR's 
> subnet) sends a BU for its location which may be different 
> from the MR's location. 
> 
> I guess it would be easy enough if the HA does a search 
> on the longest Home address match to avoid the confusion
> in this case. 
> 
This case can be easily covered in the above clarification.

-mohan

> Is that a feasible scenario ? I haven't read your draft for sometime 
> now so maybe it's already covered ?
> 
> Cheers,
> Hesham

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 06 Apr 2001 14:53:58 +0200

> the mail from Mattias explained this clearly i guess.

I questioned if the MR must tell the HA what prefixes are behind the MR
and mentioned that this must be known by the HA (and also the BRs) by
other means (which we haven't figured out yet...).

The MN still needs to tell CNs about the prefixes, so the draft makes
sense.

/Mattias

---

From: Michael Thomas <[email-masked]>
Date: Fri, 6 Apr 2001 09:38:49 -0700 (PDT)

> other means (which we haven't figured out yet...).

Mattias,

Are you talking about prefixes that are not part
of the home subnet prefix the MR subtends? If
so, wouldn't that be handled by a normal routing
protocol like OSPF?

 > The MN still needs to tell CNs about the prefixes, so the draft makes

I think we need to be very careful here. What does
this mean from a security statndpoint? What
authorized this? This may be no different than the
current MIP situation, but I wouldn't count on
that without testing the assumption thoroughly.

Also: does this mean that the MR needs to create
flow based information for the static hosts behind
it? That seems to be the implication. Will this
scale well for large MR's such as on a plane or
aircraft carriers?

		Mike

---

From: Mattias Pettersson <[email-masked]>
Date: Sat, 07 Apr 2001 19:21:00 +0200

> so, wouldn't that be handled by a normal routing

First question - yes.
Second question - yes, normal routing protocols would handle this fine
when the MR is at home (attached to HA's link). But we still need to run
routing protocols between MR and all routers on the home link, including
the HA. The BUs plus "Mobile Network Prefix Sub-Option" in the mobile
networks draft only update the HA, not all the other routers on the home
link.

So should we run routing protocols through a bi-directional tunnel
between the HA and MR? Routing protocols usually assume or reqiure
link-local addresses for the source and destination of the messages.

Or should the HA act as a proxy router on behalf of the MR and send
routing messages to the other routers on the home link in order to
maintain routes to the mobile networks?

Or do we only allow statically configured routes in the routers pointing
out the mobile prefixes?

What do you people prefer?

> that without testing the assumption thoroughly.

The HA must verify the MR requesting forwarding of the mobile prefixes
so it knows it is the same MR as was at home. What kind of authorization
do we use between routers on the home link?

> scale well for large MR's such as on a plane or

I don't follow you here. Can you explain a bit more?

/Mattias