Subject: RE: [mobile-ip] dynamic home addressing as a WG item??

From: James Kempf <[email-masked]>
Date: Thu, 12 Apr 2001 11:25:32 -0700 (PDT)

Hi Sandy,

I've been having problems with my email, which is why the response is
delayed.

>> The options related to IP address configuration
>> and routing (gateway router, subnet mask,
>> and domain name) are not handled by
>> service discovery currently but they could
>> be handled by a mobile IP extension or
>> AAA extension that hides the back end
>> implementation so network operators
>> could use the backend technique of their
>> choosing.
>
>Sure.  But this is precisely the question:
>who should allocate these configuration 
>parameters? Some backend mechanism made
>transparent through Mobile IP extensions?
>AAA extensions? DHCP? I obviously believe
>that DHCP should do it, at least today and in
>the foreseeable future. 
>

I think the question is "how should the mobile node
access these parameters" not "who should allocate
the parameters." Since these have to do with
the HA, they need to be allocated by the
HA on the home subnet. The HA can allocate them
via DHCP or however it chooses. 

I think that it would be better to come up with
a lightweight way of doing this, rather than
requiring DHCP relays and reverse tunnels. 
A simple extension to MIP that allows an
HA to send configuration information in
a registration reply would do the trick.

>> No, but this is something that could easily become
>> a standardized Diameter extension.
>
>I wonder if anyone on this mailing list with
>AAA expertise can shed some more light onto 
>this possibility.
>

To get it to the end node would actually require
something like BURP, but that's not being discussed
for BURP. Diameter is infrastructure only.

>Sure, DHCP was developed for enterprise networks
>but why is this a problem? The point is that DHCP
>IS widely deployed in LANs today and with a 
>relatively simple solution you can use it to
>configure remote mobile nodes *as if* they
>were connected to their home networks, WITHOUT
>the need to change DHCP in any way to make it fit
>the special needs of mobile nodes.
>

One of the problems with mobility is that people
assume it is possible to simply extend enterprise
designs based on always wired hosts. This sometimes
works, but often it doesn't. Mobility has
its own unique aspects, and I think extending
DHCP isn't the right way to go. Just as there
are separate routing protocols for local domain
and wide area, I think we need address and 
basic configuration provisioning to fit
the mobile case. They need to be simple
and lightweight. DHCP is neither in a
mobile deployment scenario (and, btw.,
I did read both drafts).

>Fine.  You could make a Mobile IP client take on
>the responsabilities a DHCP client is used to
>handling but be ready to *change* that Mobile IP
>client.  At the very least, you'd have to change
>the Mobile IP standard to require mobile nodes
>to register even while they're at home so that
>they can maintain soft-state support on their
>assigned home address.  Now, if you happen 
>to also need configuration parameters, you not
>only have to change the client state machine 
>but you also need to extend Mobile IP messages...
>Changing the Mobile IP standard to do this is 
>the key problem you can avoid by letting DHCP 
>handle the dynamic addressing and configuration
>needs of the mobile nodes.  
>

Sure, mobile IP isn't cast in stone at this point.

Maybe the problem here is that we have two different
models in mind. I think there is a distinction between
"nomadic" users and "mobile" users. Nomadic users
set up somewhere, do IP traffic for a while, then shut down.
They do not change their point of attachment. These
types of users are and will continue to be well-served
by DHCP. Mobile users are constantly changing their
point of attachment, and occasionally their hosts may
go into dormant mode in order to save power, while
still maintaining a virtual IP connection. These users
are better served with mobile IP. Currently, there is
no  way to get nonservice related configuration parameters
through mobile IP. This is an oversight that needs fixing.
It does not, IMHO, mean that a protocol designed for
nomadic use should be extended to something it wasn't
designed for, namely mobile users.

		jak

---

From: "Phil Neumiller" <[email-masked]>
Date: Thu, 12 Apr 2001 14:29:56 -0500

Hi James,

I have a comment on your suggestion to Sandy below.
----- Original Message -----
From: "James Kempf" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, April 12, 2001 1:25 PM

> a registration reply would do the trick.

I would say its a "hack" not a trick and it has the negative
effect of putting a routing protocol (MIP) under the yoke
of something that is clearly an application layer duty.
DON'T DO IT!  (That's how I really feel James...)

-pdn

---

From: Luca Salgarelli <[email-masked]>
Date: Thu, 12 Apr 2001 18:04:39 -0400

Hi James.

I think I agree with Phil on this. I am not comfortable with the idea of
coupling a routing protocol with something needed to distribute
configuration information.

I think that a clean separation between the two is needed.

> OK, then what would you suggest? I think extending
> DHCP to the mobile is just as much of a hack.

I don't see why you consider "extending DHCP" to the mobile a hack:
Mobile-IP is designed to transparently hide the movements of the client. So
I don't see why you would see letting DHCP "transparently" run on top of
the Mobile-IP tunnel a hack.

Luca