Subject: [mobile-ip] Question about Registration Replies and RFC2002bis

From: Kory Keith <[email-masked]>
Date: Fri, 6 Apr 2001 07:33:50 -0700 (PDT)

Sorry if this is a repost, but I never saw it on the
board....

In RFC 2002bis, it clearly states that the MN should
send 0.0.0.0 as it source address in the IP field of
the Registration Request when requesting a Dynamic
Home Address. (3.6.1.1).
My question is about 3.7.2.3 where it states the
following:

IP Destination Address
    Copied from the IP Source Address of the
Registration Request.

If I read this correctly, the Foreign Agent is meant
to send the Registration Reply to the MN with a
destination address of 0.0.0.0 in the IP header. How
can this be valid when 0.0.0.0 is a reserved address
in the IP standard and should not be used as a
destination address??

Kory Keith

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 16 Apr 2001 09:29:49 -0700

Hello Kory,

I'm finally catching up, please excuse the delay...

> the Registration Request when requesting a Dynamic

Correct.

> in the IP standard and should not be used as a

That's a good question.  This language is a holdover from 
RFC 2002, by which it was not possible to use 0.0.0.0.
Unfortunately, I think the answer is that there isn't
a good answer.  The choices seem to be:

- 0.0.0.0
- 255.255.255.255
- 224.0.0.1
- subnet-directed broadast, _if_ the Prefix Information
  Option has been included in the Agent Advertisements.

Probably arguments could be made for all of them, but
I would sort-of favor the third one if we were starting
from a clean slate.  For any of the choices, the foreign
agent should deliver the Registration Reply to only one
layer-2 address.

If the document comes back from IESG again with requests
for additional revision, perhaps this is a change that
could be made.  Does anyone else have comments about what
should be changed?  I think at least some clarification
should be added to the specification.

Regards,
Charlie P.