Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem ents

From: Phil Roberts <[email-masked]>
Date: Tue, 10 Apr 2001 10:35:28 -0400

Hi,
 
I'm a little confused about your req 10.  MIP v6 already has route
optimization.  Do you envision req 10 to provide an alternative to that or
to interoperate with that or ... something else?
 
Thanks,
Phil

-----Original Message-----
From: Hongyi Li [mailto:[email-masked]]
Sent: Tuesday, April 10, 2001 10:21 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi Phil, 
  Here are few more requirements I think that are impportant for RR/LMM (I
like 
the term localized mobility management too): 

 10) LMM SHALL provide optimized routing for mobile-to-mobile communication.

 11) LMM SHOULD minimize the number of network nodes affected by handoff
signals. 
 12) LMM SHOULD support auto-configuration capabilities for mobile
agents/FAs, access routers. 
 13) LMM SHOULD simplify the network design and provisioning for enabling
LMM 
capability in a network and allow progressive LMM deployment capabilities. 

Some more comments in lines: 
   
> 1) Regional registration shall be introduced to minimize the signaling 
> traffic to the home agent or correspondent nodes for 
> intra-domain mobility 
> 2) Regional registration shall not introduce new overhead on 
> links between 
> the mobile and the regional registration agents 
> 3) Connectivity to the mobiles shall not be interrupted in 
> the presence of 
> the failure of regional registration agents 
> 4) Regional registration shall scale to support millions of nodes in a 
> visited network 

LMM SHALL be scalable in terms of number of connected users (i.e., active +
dormant =  millions) and the number of users on the move.

> 5) Regional registration shall be secure against malicious 
> behavior from 
> visiting mobiles 
> 6) Regional registration shall allow multiple levels of hierarchy 
> 7) Regional registration shall support fast handoffs 
> 8) Regional registration shall not require changes to the 
> mobile node, the 
> home agent, or correspondent nodes 
> 9) Regional registration shall not introduce host routes in 
> routing tables 

I agree with Theo comments about host route. The LMM SHOULD minimize the
amount of host routes in the routers. 

- Hongyi

---

From: "Hongyi Li" <[email-masked]>
Date: Tue, 10 Apr 2001 15:29:22 -0400

Michael,
  To reduce the number of host routes is a desirable goal
for the routers that have limited number of routing table entries. 
If a LMM protocol can aggregate / de-aggregate the host routes in
the mobile agents (e.g. MAP), the protocol would be more scalable
in term of routing table size. This is only a desirable requirement
not a MUST.

-Hongyi

> From: Michael Thomas [mailto:[email-masked]]
> Sent: Tuesday, April 10, 2001 2:57 PM
> To: [email-masked]
> Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying
> requirem ents
> 
> 
> Hongyi Li writes:
>    I'm sorry but somebody's going to have to explain
>    why this is a requirement. The number of routes
>    in the MAP are the same. The only difference is
>    the routes in the access and/or aggregation
>    routers between the MAP and the MN, but that
>    scales to the order of the subtended hosts at
>    each point in the tree which doesn't seem
>    especially onerous.
> 
> 		Mike
>

---

From: "Hongyi Li" <[email-masked]>
Date: Wed, 11 Apr 2001 09:23:33 -0400

Hi Phil,
  Mobile IPv6 achieves route optimization by using cutting through path that
bypasses the anchor
point (i.e., home agent). If a LMM protocol introduces new type of anchor
points, the path optimization will become
an issue again. Therefore , it is a goal for LMM to achieve the same level
of route optimization as in MIP v6 that
is to use the route selected by native IP routing protocol (i.e., OSPF, RIP,
BGP..).
  The route optimization requirement is applicable for all mobile
communications and shouldn't limited for 
mobile-to-mobile. Therefore, the requirement 10 should be "LMM SHALL provide
optimized routing for mobile
communication"
 
-Hongyi

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Tuesday, April 10, 2001 10:35 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi,

Thanks,
Phil

-----Original Message-----
From: Hongyi Li [mailto:[email-masked]]
Sent: Tuesday, April 10, 2001 10:21 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi Phil, 

   

- Hongyi

---

From: Phil Roberts <[email-masked]>
Date: Wed, 11 Apr 2001 09:49:36 -0400

-----Original Message-----
From: Hongyi Li [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 9:24 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi Phil,
[Phil Roberts] 
Hi,
 
   Understand your revised requirement, but I'm not sure what you're trying
to say in the first paragraph.  If there is a
localized mobility management agent somewhere between the last hop router
and the home agent, do you want the
route optimized path to go through that local mobility agent or not?  And
does it depend on the circumstances of the
communication?  *And* can you write a requirement saying that?  (Not to
imply that it will be an accepted requirement
but one up for discussion).
 
Phil

-Hongyi

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Tuesday, April 10, 2001 10:35 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi,

Thanks,
Phil

-----Original Message-----
From: Hongyi Li [mailto:[email-masked]]
Sent: Tuesday, April 10, 2001 10:21 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi Phil, 

   

- Hongyi

---

From: "Muhammad Jaseemuddin" <[email-masked]>
Date: Wed, 11 Apr 2001 16:20:53 -0400

Phil:

 Route optimization does not fully optimize the route in case of any form of
regional registration. e.g. HMIPv6. For example if the CN is outside the
domain, then the packets will follow the optimized path upto the local
mobility anchor point (MAP), and then follow the optimal path to the mobile.
If the MAP is not co-located with the border routers, then the scheme does
not use optimal route from the border routers to the mobile. This situation
becomes more conspicous if the CN is another mobile within the domain but
necessarily on the same subnet as the the subnet on which the mobile's AR is
connected. One can argue that in that case MN should send BU to CN with its
LCOA if it (somehow) discovers that the CN is actually a mobile in the same
domain. Then, intra-MAP domain signaling will be increased and the benefit
of MAP will be less obvious.

 What I interepreted from Hongyi's requirement 10 is to address the above
issue?

Cheers,
- Muhammad Jaseemuddin
 
> From:	Phil Roberts [SMTP:[email-masked]]
> 	  Here are few more requirements I think that are impportant for
> RR/LMM (I like 
> 	 11) LMM SHOULD minimize the number of network nodes affected by
> handoff signals. 
> 	 13) LMM SHOULD simplify the network design and provisioning for
> enabling LMM 
> 	LMM SHALL be scalable in terms of number of connected users (i.e.,
> active + dormant =  millions) and the number of users on the move.
> 
> 	I agree with Theo comments about host route. The LMM SHOULD minimize
> the amount of host routes in the routers. 
> 
> 	- Hongyi 
>

---

From: Phil Roberts <[email-masked]>
Date: Wed, 11 Apr 2001 16:26:09 -0400

Agreed.   But I can't tell from the requirement what exactly is required.
Is it something like "2 MNs behind the same LMA shall use an optimized route
that doesn't go through the LMA?"

-----Original Message-----
From: Muhammad Jaseemuddin [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:21 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Phil: 

Cheers, 
- Muhammad Jaseemuddin 

	-----Original Message----- 
From:   Phil Roberts [SMTP:[email-masked]] 
Sent:   Tuesday, April 10, 2001 10:35 AM 
To:     [email-masked]' 
Subject:        RE: [mobile-ip] IPv6 Regional Registration - identifying
requirem ents 

	Hi, 

Thanks, 
Phil 

	-----Original Message-----
From: Hongyi Li [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Tuesday, April 10, 2001 10:21 AM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

	Hi Phil,

	 10) LMM SHALL provide optimized routing for mobile-to-mobile
communication.

	- Hongyi

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 12 Apr 2001 17:49:36 +0200

I can't understand the route opt. requirement either.
The MN supports MIPv6 and can decide whether it wants to
use the local anchor point or not when sending BUs to CNs.
There is no need to require anything from the local anchor
point itself. I believe that the HMIPv6 draft has a
note on this. If the MN determines that the CN lies within
its same (MAP) site then it may decide to communicate directly
with the CN.
Regards
/Karim

-----Original Message-----
From: Phil Roberts
To: [email-masked]'
Sent: 2001-04-11 22:26
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem	ents

Agreed.   But I can't tell from the requirement what exactly is
required.  Is it something like "2 MNs behind the same LMA shall use an
optimized route that doesn't go through the LMA?"

-----Original Message-----
From: Muhammad Jaseemuddin [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:21 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying
requirem ents

Phil: 

 Route optimization does not fully optimize the route in case of any
form of regional registration. e.g. HMIPv6. For example if the CN is
outside the domain, then the packets will follow the optimized path upto
the local mobility anchor point (MAP), and then follow the optimal path
to the mobile. If the MAP is not co-located with the border routers,
then the scheme does not use optimal route from the border routers to
the mobile. This situation becomes more conspicous if the CN is another
mobile within the domain but necessarily on the same subnet as the the
subnet on which the mobile's AR is connected. One can argue that in that
case MN should send BU to CN with its LCOA if it (somehow) discovers
that the CN is actually a mobile in the same domain. Then, intra-MAP
domain signaling will be increased and the benefit of MAP will be less
obvious.

 What I interepreted from Hongyi's requirement 10 is to address the
above issue? 

Cheers, 
- Muhammad Jaseemuddin 

	-----Original Message----- 
From:   Phil Roberts [SMTP:[email-masked]] 
Sent:   Tuesday, April 10, 2001 10:35 AM 
To:     [email-masked]' 
Subject:        RE: [mobile-ip] IPv6 Regional Registration - identifying
requirem ents 

	Hi, 
  
I'm a little confused about your req 10.  MIP v6 already has route
optimization.  Do you envision req 10 to provide an alternative to that
or to interoperate with that or ... something else?

Thanks, 
Phil 

	-----Original Message-----

	Hi Phil,
  Here are few more requirements I think that are impportant for RR/LMM
(I like
the term localized mobility management too): 

capability in a network and allow progressive LMM deployment
capabilities. 

> 4) Regional registration shall scale to support millions of nodes in a

	LMM SHALL be scalable in terms of number of connected users
(i.e., active + dormant =  millions) and the number of users on the
move.

> 9) Regional registration shall not introduce host routes in

	I agree with Theo comments about host route. The LMM SHOULD
minimize the amount of host routes in the routers. 

	- Hongyi

---

From: "Hongyi Li" <[email-masked]>
Date: Thu, 12 Apr 2001 16:18:54 -0400

Hi Phil,
 
  Optimize routing is a goal for MIPv6 and it should be the goal for LMM/RR
as well.
This requirement simply requires that the data packets between two
communicating
nodes (regardless of where the two nodes are) take the path selected by the
native
IP routing protocol (e.g., OSPF).
 
  An example of non-optimized path is that if an anchor node is not on the
optimal
path between two communicating nodes and packets still travel through that
anchor
anchor node (triangular routing).
 
  This is just a proposed requirement. I am not arguing whether a particular
protocol
can meet the requirement or not.  
 
-Hongyi

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:26 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

-----Original Message-----
From: Muhammad Jaseemuddin [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:21 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Phil: 

Cheers, 
- Muhammad Jaseemuddin 

	-----Original Message----- 
From:   Phil Roberts [SMTP:[email-masked]] 
Sent:   Tuesday, April 10, 2001 10:35 AM 
To:     [email-masked]' 
Subject:        RE: [mobile-ip] IPv6 Regional Registration - identifying
requirem ents 

	Hi, 

Thanks, 
Phil 

	-----Original Message-----

	Hi Phil,

  

	- Hongyi

---

From: Phil Roberts <[email-masked]>
Date: Thu, 12 Apr 2001 16:40:25 -0400

OK.  I was just trying to get at what you were asking for.  It sounds like
you want some
entity (the mobile) to determine whether the direct path to the CN is more
efficient than
the path to the CN through the LMM agent, and if so, to choose that path.
Is that
correct?

-----Original Message-----
From: Hongyi Li [mailto:[email-masked]]
Sent: Thursday, April 12, 2001 4:19 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Hi Phil,

 
 
-Hongyi

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:26 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

-----Original Message-----
From: Muhammad Jaseemuddin [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 4:21 PM
To: [email-masked]'
Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem
ents

Phil: 

Cheers, 
- Muhammad Jaseemuddin 

	-----Original Message----- 
From:   Phil Roberts [SMTP:[email-masked]] 
Sent:   Tuesday, April 10, 2001 10:35 AM 
To:     [email-masked]' 
Subject:        RE: [mobile-ip] IPv6 Regional Registration - identifying
requirem ents 

	Hi, 

Thanks, 
Phil 

	-----Original Message-----

	Hi Phil,

  

	- Hongyi