Subject: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting Compressor on Mobile IPv6 Handover

From: [email-masked]
Date: Fri, 6 Apr 2001 13:13:11 -0500

> 
> 
> [email-masked] writes:
>  > > From: ext Michael Thomas [mailto:[email-masked]]
> 
>  > > Can somebody explain to me how this has any
>  > > possible applicability if you are using FMIP
>  > > during the transition? FMIP requires a new tunnel
>  > > for which there will be no compression state in
>  > > the old access router.
>  > > 
>  > 
>  > If there is no compression state at the old router, why 
> would you try to
>  > relocate it ? 
> 
>    There's compression state there, but not the 
>    compression state that matters: when I'm 
>    receiving packets from the old AR during the
>    FMIP transition time, there will be a *new*
>    IP header appended toward the MN. This is
>    because those packets will have to be tunneled to the
>    MN. This means that it is a *new* compression
>    context, not an old existing one.
>  
I don't have sufficient details to comment..

>  > > All of these interactions with MIP, FMIP, HMIP
>  > > etc, etc make it look to me like this is a losing
>  > > situation. It may be the better part of valor to
>  > > say that fast/smooth handoffs are inherently more
>  > > bandwidth consumptive and that one of the
>  > > casualties is header compression state in the mean
>  > > time. 
>  > 
>  > Can you justify your claim above ?
> 
>    I can't prove negatives. I'm afraid that it
>    is your place to prove that context transfer
>    of header compression state in the face of all
>    of these extenuating circumstances is still
>    worthwhile.
> 

You can't justify your claims. So, before you raise issues
(related/unrelated), try to make an effort to understand the work done by
others. 

As far as I am concerned, how about all the e-mail discussion during the
last two weeks ? Please take a look!

>  > >Trying to extend a point to point L2
>  > > compression mechanism across an arbitrary internet
>  > > is just *bizzare*. L2TP is bad enough.
>  > > 
>  > 
>  > You are compressing IP and transport headers! This should 
> work on ANY link.
>  > That's why you try to CT header compression state. Get it ?
> 
>    Oh sure, I get it... I "get" VoMPLS too, but
>    that doesn't make it any less bizarre.
> 

If you got it, you would probably re-think! If you were to re-think and
understand the issues, you would probably question yourself what's bizarre,
and then write. 

-Rajeev

> 	    Mike

---

From: Michael Thomas <[email-masked]>
Date: Fri, 6 Apr 2001 13:19:28 -0700 (PDT)

> (related/unrelated), try to make an effort to understand the work done by

   I don't know what you would like me to do. I've
   brought up an issue, and you've brushed it
   aside assumedly as irrelevant. I've been paying
   attention to this thread, and as far I can
   tell, nobody has answered my question. 
   
   Also: you are also telling me that I have to
   prove negatives of the form "tell me why we
   _shouldn't_ do XYZ." That is a logical fallacy.
   You may not like my message, but it does not
   give you free reign to ignore reality. It is
   in nobody's interest to design a protocol 
   that does not work in the areas where it would
   be most useful.

	   Mike