Subject: RE: [mobile-ip] Mobile Prefix Advertisements

From: "Powell, Ken" <[email-masked]>
Date: Thu, 19 Apr 2001 14:56:45 -0400

Hi T.J.,

Just wanted to let you know that I reviewed your proposed
changes, along with doing another complete read-through
of the mobile-ipv6 spec. As always, I have some comments
brewing, particularly for section 9.8. This stuff is
not easy and the details could have a big impact on our
implementation. I asked our development team to sanity
check all my comments, and to also do a detailed review
of section 9.8 to be sure we get it right.

BTW, I noticed you didn't touch Appendix A. I'll be
proposing some changes I think you asked for a long
time ago. Your new Home Prefix Solicitation and Home
Prefix Advertisement changes make my temporary home
address kludge unnecessary.

Ken 

> -----Original Message-----
> From: T.J. Kniveton [mailto:[email-masked]]
> Sent: Saturday, March 31, 2001 8:25 AM
> To: [email-masked]
> Subject: [mobile-ip] Mobile Prefix Advertisements
> 
> 
> Hi,
> 
> At IETF50, I presented some problems with Network Renumbering and
> Tunneled Router Advertisements, and also presented a solution that had
> been discussed on this mailing list -- namely, to create a 
> new ICMP type
> for transporting prefix info from home link router 
> advertisements to the
> mobile node away from home.
> 
> So far, this idea is generally agreed upon as a reasonable 
> solution, so
> I am hoping people are open to trying this out. I have just finished
> writing proposed changes to the Mobile IPv6 draft which..
> 1. incorporate these new ICMP types
> 2. clean up the text in the renumbering section to make it easier to
> understand, and
> 3. simplify and re-evaluate rules and streamline the 
> specified mechanism
> a bit
> 4. keep as much of what was there as possible
> 
> Although there is still more work to get this right, I put these files
> on my web site so people can take a look. Please point out errors, and
> especially glaring problems, or make suggestions, whatever..
> 
> http://www.kniveton.com/tj/specs/
> 
> The resultant file is MIPv6-13tj2.txt -- my suggestion on how 
> to look at
> these changes would be download MIPv6-13.txt (the original draft) and
> MIPv6-13tj2.txt, and run "Compare Two Files" under xemacs's 
> Tools menu.
> 
> --
> T.J. Kniveton
> NOKIA Research
> 
>

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 20 Apr 2001 11:33:05 +0200

> address kludge unnecessary.

I would be happy to let the temporary home address go, too.

/Mattias