Subject: RE: [mobile-ip] Location privacy

From: [email-masked]
Date: Mon, 9 Apr 2001 10:32:29 -0500

Comments below:
 
Glenn:
>Raj, 
>
>Why are you not too worried about it? Right now if someone tries to
>call me on my cell phone they don't get to know where I am and I
>certainly don't want them to necessarily know or have my service
>degraded because I'm half way accross the world. This seems like a
>reasonable and revenue affecting concern to both a service provider
>and to people in general.  
>
 
The scenario you describe is one that I have considered as well. The
reason I mentioned that I was not too worried about it right now was
from the perspective of Mobile IPv6 and getting the MIPv6 spec done in
this WG. I prefer not to let the location privacy issue interfere with
the MIPv6 spec being done and to add to that the issue of location
privacy is being discussed and MAY be dealt with in another WG
altogether (look at Phil's note to the list earlier). 
So for now I am just sticking my head in the sand and ignoring the
problem.  
 
>Please clarify. 
>Thanks, 
>Glenn 
Basavaraj:
>>Location privacy is something that MAY need attention on it's own and 
>>for now, I'm not too worried about it.

---

From: Claude Castelluccia <[email-masked]>
Date: Mon, 09 Apr 2001 18:02:42 +0200

Hello Raj,

Some of the privacy issues are very specific to MIPv6 (as described in
draft-castelluccia-mobileip-privacy-00.txt).
IMO they should be discussed and considered in the MIP WG soon or
later...
regards,
Claude.

[email-masked] wrote:

> problem. >

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Michael Thomas <[email-masked]>
Date: Mon, 9 Apr 2001 09:17:30 -0700 (PDT)

I really don't know what MIP has to do with
location privacy per se. In fact, it provides a
fair veneer of privacy which is completely under
the control of the mobile node: it just doesn't
send binding updates if it wants rudimentary
privacy. Moving the HA farther toward the mobile
node (as does HMIP) reveals more information. The
only way to reveal less information is to decouple
your home agent from your home network; this is
just an operational issue. Of course, the best is
to run things through an ALG which I think is
ultimately what will happen if people want to be
assured privacy (eg battered wife).

	Mike

Claude Castelluccia writes:
 > <!doctype html public "-//w3c//dtd html 4.0 transitional//en">
 > <html>
 > &nbsp;
 > <br>Hello Raj,
 > <p>Some of the privacy issues are very specific to MIPv6 (as described
 > in&nbsp; draft-castelluccia-mobileip-privacy-00.txt).
 > <br>IMO&nbsp;they should be discussed and considered in the MIP WG soon
 > or later...
 > <br>regards,
 > <br>Claude.
 > <p>[email-masked] wrote:
 > <blockquote TYPE=CITE><font face="Arial"><font color="#0000FF"><font size=-1>></font></font></font>
 > <font face="Arial"><font color="#0000FF"><font size=-1>The scenario you
 > describe is one that I have considered as well. The</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>reason I mentioned
 > that I was not too worried about it right now was</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>from the perspective
 > of Mobile IPv6 and getting the MIPv6 spec done in</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>this WG. I prefer
 > not to let the location privacy issue interfere with</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>the MIPv6 spec
 > being done and to add to that the issue of location</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>privacy is being
 > discussed and MAY be dealt with in another WG</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>altogether (look
 > at Phil's note to the list earlier).</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>So for now I
 > am just sticking my head in the sand and ignoring the</font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>problem.</font></font></font>
 > <font face="Arial"><font color="#0000FF"><font size=-1>></font></font></font>
 > <br><font face="Arial"><font color="#0000FF"><font size=-1>>Please clarify.</font></font></font></blockquote>
 > 
 > <pre>--&nbsp;
 > 
 > Claude CASTELLUCCIA, INRIA Rhone-Alpes&nbsp;&nbsp;
 > ph:&nbsp; +33 4.76.61.52.15 (fax: 52.52)
 > <A HREF="http://www.inrialpes.fr/planete/">http://www.inrialpes.fr/planete/</A></pre>
 > &nbsp;</html>

---

From: Michael Thomas <[email-masked]>
Date: Mon, 9 Apr 2001 09:35:23 -0700 (PDT)

Argh. Sorry for following myself up but:

Michael Thomas writes:
 > Moving the HA farther toward the mobile
 > your home agent from your home network; 

   This should read: "decouple your home agent's
   location from your ``home'' location"

		 Mike