Subject: Re: [mobile-ip] Revised Localized Mobility Management Requirements

From: Erik Nordmark <[email-masked]>
Date: Wed, 18 Apr 2001 13:53:25 -0700 (PDT)

> OK.  Let's make another cut through these.  Seems that folks like the title
> Localized Mobility Management.  I didn't retain the original numbers.
> 
> Agreed upon requirements where there was no dissent:
> 1. Regional registration shall be introduced to minimize the signaling
> traffic to the home agent or correspondent nodes for intradomain mobility.

I assume this applies to a "domain" being something larger than one IP subnet
and smaller than the whole Internet, since in the first case L2 does the work
and in the second case the existing HA does the work.
My question is whether it would be useful to constrain the size and other
attributes a bit more.

For instance, is this "domain" within one adminstrative domain or not?
The answer affects what trust models make sense for securing things.

Even within one adminstrative domain there might be cases where you want
to limit this "domain" to less than the whole adminstrative domain - for
instance if the adminstrative domain spans the globe.
This might mean that it might make sense to view this as a "small RTT domain"
(using the exactly defined "small" :-), since in a large RTT domain
the latency of updating the local mobility agent(s) might be as large as 
updating the home agent.

  Erik

---

From: Claude Castelluccia <[email-masked]>
Date: Thu, 19 Apr 2001 09:39:30 +0200

Hello Erik,

> The answer affects what trust models make sense for securing things.

Just as an example in HMIPv6, we refer as "domain" the set of nodes that are
supported by the
same MAP (or set of MAPs)...
I am not sure whether this domain has to be owned by the same administrative
entity (probably not)...

regards,
Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Tom Weckström <[email-masked]>
Date: Thu, 19 Apr 2001 11:44:24 +0300 (EET DST)

Hi.

Small comments to Erik's good notifications:

On Wed, 18 Apr 2001, Erik Nordmark wrote:

Erik.N >> OK.  Let's make another cut through these.  Seems that folks like the title
Erik.N >> Localized Mobility Management.  I didn't retain the original numbers.
Erik.N >> 
Erik.N >> Agreed upon requirements where there was no dissent:
Erik.N >> 1. Regional registration shall be introduced to minimize the signaling
Erik.N >> traffic to the home agent or correspondent nodes for intradomain mobility.
Erik.N >
Erik.N >I assume this applies to a "domain" being something larger than one IP subnet
Erik.N >and smaller than the whole Internet, since in the first case L2 does the work
Erik.N >and in the second case the existing HA does the work.
Erik.N >My question is whether it would be useful to constrain the size and other
Erik.N >attributes a bit more.
Erik.N >
Erik.N >For instance, is this "domain" within one adminstrative domain or not?
Erik.N >The answer affects what trust models make sense for securing things.
Erik.N >
Erik.N >Even within one adminstrative domain there might be cases where you want
Erik.N >to limit this "domain" to less than the whole adminstrative domain - for
Erik.N >instance if the adminstrative domain spans the globe.
Erik.N >This might mean that it might make sense to view this as a "small RTT domain"
Erik.N >(using the exactly defined "small" :-), since in a large RTT domain
Erik.N >the latency of updating the local mobility agent(s) might be as large as 
Erik.N >updating the home agent.
Erik.N >
Erik.N >  Erik

Firstly, a good design principle to limit the size of a "domain" is to
think how fast handoffs this "domain" would be able to provide. In a
humongous hierarchy with slow links between the elements of the hierarchy,
even the localized mobility management may not provide reasonably fast
handoffs. The size of the domain is also linked to the number of MNs the
system must support. By splitting mega-domains, one would also gain some
scalability for the entire system of domains, but that is merely a network
design issue, perhaps not that tightly related to protocol design.

Secondly, the latency of updating the binding in the HA in the MN's home 
network is always at least one hop slower (round trip 2 hops) than
updating only the local mobility agents. Correct me, if you can think of a
scenario that breaks my argument.

Best regards,
		Tom
-- 
	Tom Weckström		Dynamics group
				Helsinki University of Technology
				[email-masked]
				http://www.cs.hut.fi/Research/Dynamics/

---

From: Draznin Sagiv <[email-masked]>
Date: Thu, 19 Apr 2001 17:41:34 +0100

Sorry for the "beginners question",
Someone can explain the main differences between GPRS and Mobile IP?

  At 09:39 AM 4/19/2001 +0200, you wrote:
>Just as an example in HMIPv6, we refer as "domain" the set of nodes that 
>are supported by the
>I am not sure whether this domain has to be owned by the same 
>administrative entity (probably not)...
>
>regards,
>Claude.
>
>
>--
>
><http://www.inrialpes.fr/planete/>http://www.inrialpes.fr/planete/

------------------------------------------------------
Sagiv Draznin
System Engineer ,SP ,Mobile Tech
Cisco Systems Israel
  Herzliya Business Park
  4 Maskit St. P.O.Box 4032
  Herzliya Pituach, 46733, Israel
  Phone:+972-9-9700622
  Mobile:+972-54-972622
  FAX:    +972-9-9700019
  E.mail:[email-masked]
   WEB:www.cisco.com
     ICQ #:93366338
-------------------------------------------------------

---

From: "Yun Won Chung" <[email-masked]>
Date: Thu, 19 Apr 2001 23:46:07 +0900

GPRS uses its specific radio access technologies and mobility management procedures,
but Mobile IP is layer 3 protocol and independent of layer 1 or 2 technologies.
So, Mobile IP can be used in internetworking between different mobile systems,
such as GPRS, IMT-2000, WLAN, etc.
  ----- Original Message ----- 
  From: Draznin Sagiv 
  To: [email-masked] 
  Sent: Friday, April 20, 2001 1:41 AM
  Subject: [mobile-ip] "beginners question"

    Hello Erik, 

       
    Just as an example in HMIPv6, we refer as "domain" the set of nodes that are supported by the 
    same MAP (or set of MAPs)... 
    I am not sure whether this domain has to be owned by the same administrative entity (probably not)... 

    regards, 
    Claude. 

--

---

From: Xiaofeng Xu <[email-masked]>
Date: Thu, 19 Apr 2001 10:12:54 -0500

In Mobip, the mobile node is allocated a fixed home address and only the
traffix destined to the mobile is tunneled. The home agent is fixed.
In GPRS, the mobile node can be allocated a fixed address or dynamic
address, the traffic to and from the mobile are tunneled on both
directions.  The GGSN can be located at home or in visiting network.

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 19 Apr 2001 18:43:16 -0700 (PDT)

> design issue, perhaps not that tightly related to protocol design.

I agree in general.
But I've heard arguments for having a hirarchy of agents within each domain
and I'm struggling trying to understand whether that is a requirement or not.
Basically I see two approaches and I don't know how to resolve them:
1. A domain might be huge (for whatever reason) hence for scaling reasons
   you need to be capable of having a arbirarely deep hirarchy of agents.
2. Simplicity is good idea and a solution without hirarchy is likely to
   be simpler, if not to implement to operate, than one with a hirarchy.

This coupled with the size of the domain being a network design issue
makes this hard to resolve.

  Erik