Subject: [mobile-ip] Location privacy

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 2 Apr 2001 21:58:35 +0200

Mike, 

We're providing location privacy based on the 
routeable address of the MN. 
Granted you can do some other tricks, but eventually
the CN will address the MN. That is the fact 
that you can't hide. Unless of course we start
using ALGs. 
Have I missed something ?

Hesham

> -----Original Message-----
> From:	Michael Thomas [SMTP:[email-masked]]
> Sent:	Tuesday, 3 April 2001 4:56
> To:	[email-masked]
> Subject:	RE: [mobile-ip] Multiple tunnels over unoptimized route packets f	or Extended mode
> 
> Hesham, 
> 
> Location privacy is only as good as the weakest
> link. I'm somewhat doubtful that mobile IP is that
> link; it's much more likely to be the applications
> running on top. For calling privacy, for example,
> we've been through this many times and it all
> really boils down to if you want to do it right,
> you need an application layer anonymizer. For SIP,
> that means doing a back to back UA, for email,
> that mean anonymous remailers, etc, etc. Anything
> less is probably not going to cut it, especially
> if you have to meet legal tests.
> 
> 	    Mike
> 
> Hesham Soliman  (ERA) writes:
>  > Glenn, 
>  > 
>  > > Do you really think that you could convince a customer that you are really providing them location privacy. 
>  > > If I were that customer, I would not be convinced. 
>  > > 
>  > 	=> Well, up until this mail I thought there is some location 
>  > 	privacy support in the draft. However if there is a better
>  > 	way of doing it, we're happy to consider it. I thought 
>  > 	we discussed this before IETF and found that it was difficult 
>  > 	to achieve complete location privacy with optimal routing ? 
>  > 	Could you elaborate on why you're not convinced ?
>  > 
>  > > I think that is everyone's point.
>  > > 
>  > 	=> Everyone ? The only feedback I got until Minneapolis 
>  > 	was that (from the people that talked to me in private)
>  > 	Basic mode provided some nice features for 
>  > 	hiding the LCoA. So I don't know who everyone 
>  > 	is. 
>  > 	It's very difficult when people make general statements
>  > 	like these without explaining reasons and / or alternatives. 
>  > 	I'd appreciate some elaboration.
>  > 
>  > 	Thanks,
>  > 	Hesham
>  > 
>  > 
>  > 
>  >

---

From: "Glenn Morrow" <[email-masked]>
Date: Tue, 3 Apr 2001 10:23:42 -0500

Hesham,

You have correctly identified the issue. You have not missed something. 

Glenn

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Monday, April 02, 2001 2:59 PM
To: [email-masked]'
Subject: [mobile-ip] Location privacy

Mike, 

Hesham

---

From: [email-masked]
Date: Tue, 3 Apr 2001 12:23:57 -0500

Hesham,

> 
> 	Hi Raj, 
> 
> > I do not believe location privacy should be one of the focal points
> > of HMIPv6. I think the key thing to be accomplished with HMIPv6
> > is the ability to reduce signaling to CNs and HA whenever a MN
> > moves (and changes it's COA)
> > 
> 	=> Sounds good. Actually that's what we wanted as well,
> 	but, the solution we came up with gave us location
> 	privacy for free. So I agree that it shouln't be the 
> 	focal point and that HMIPv6 should not be the optimal 
> 	location privacy solution. It would be good if someone 
> 	started looking into a more optimal way of doing it.
> 

Location privacy is something that MAY need attention on it's own and
for now, I'm not too worried about it.

> >  and to some extent (*maybe*) provide
> > a local entity in the serving network to authorize the MN access to
> > the network. 
> > 
> 	=> Can we say that such authorisation is done by virtue
> 	 of the BU to the MAP ? Would that be satisfactory ? 
> 	 I'm just trying to avoid integrating AAA into MIP. 
> 

That's what I meant in my statement. I am not trying to integrate AAA into
MIP
in any way.

> 	Hesham
-Basavaraj

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 3 Apr 2001 20:20:54 +0200

>       Just curious,  cann't you do this  via BURP?
> 
	=> That's exactly what I meant.

	Regards,
	Hesham

---

From: "Glenn Morrow" <[email-masked]>
Date: Mon, 9 Apr 2001 09:45:24 -0500

Resending due to the Thursday server issues.

-----Original Message-----
From: Morrow, Glenn [RICH2:C330:EXCH] 
Sent: Thursday, April 05, 2001 2:03 PM
To: [email-masked]'
Subject: RE: [mobile-ip] Location privacy

Raj,

Why are you not too worried about it? Right now if someone tries to call me
on my cell phone they don't get to know where I am and I certainly don't
want them to necessarily know or have my service degraded because I'm half
way accross the world. This seems like a reasonable and revenue affecting
concern to both a service provider and to people in general. 

I'll also refer to Charlie's hierarchical related mathematics rebutal to any
"light is pretty fast" arguments.

Please clarify.

Thanks,

Glenn

---

From: [email-masked]
Date: Mon, 9 Apr 2001 11:25:07 -0500

Claude:  
>Hello Raj, 
>Some of the privacy issues are very specific to MIPv6 (as described
>in  draft-castelluccia-mobileip-privacy-00.txt).  
>IMO they should be discussed and considered in the MIP WG soon or later... 
>regards, 
>Claude. 
>

No disagreement there Claude. If you look at Phil's note sent out
earlier which said:
"
     we have a charter item to "address location privacy."  We'd like to
gather some information about what the working group thinks the extent of
the work on location privacy in this working group should be.  It MUST in
some serious way be connected with the Mobile IP protocol.  There will be in
the Apps area very soon a location privacy working group so we have to
realize that this working group will not be the place to resolve all issues
relating to location privacy.
"

I am merely saying that in terms of priority, getting the MIPv6 spec
done is relatively more critical than addressing privacy issues
related to MIPv6.

-Basavaraj

>[email-masked] wrote: 
>>
>> The scenario you describe is one that I have considered as well. The 
>>  reason I mentioned that I was not too worried about it right now was 
>>  from the perspective of Mobile IPv6 and getting the MIPv6 spec done in 
>>  this WG. I prefer not to let the location privacy issue interfere with 
>>  the MIPv6 spec being done and to add to that the issue of location 
>>  privacy is being discussed and MAY be dealt with in another WG 
>>  altogether (look at Phil's note to the list earlier). 
>>  So for now I am just sticking my head in the sand and ignoring the 
>>  problem.
>
>-- 
>
>----------------------------------------
>Claude CASTELLUCCIA, INRIA Rhone-Alpes  
>ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: "Glenn Morrow" <[email-masked]>
Date: Mon, 9 Apr 2001 08:57:07 -0500

Phil,

It seems to me that MIP currently solves location privacy at the expense of
route optimization. 

I believe that the MIP WG should work on a method of providing route
optimized location privacy. 

The domain of the MIP WG should be focused on the network-layer addressing
issues i.e. COA and home addresses.

The application group should work on the user address issues.

Thanks,

Glenn

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Friday, April 06, 2001 7:35 AM
To: [email-masked]'
Subject: [mobile-ip] location privacy

This and the next post I sent the last couple of days and never saw show up
on the list.  If you saw them, sorry for the duplicates.

Hi,

Phil

---

From: [email-masked]
Date: Mon, 9 Apr 2001 12:11:58 -0500

>Michael Thomas:
> 
> I really don't know what MIP has to do with
> location privacy per se. In fact, it provides a
> fair veneer of privacy which is completely under
> the control of the mobile node: it just doesn't
> send binding updates if it wants rudimentary
> privacy. 

Sending BUs to CNs causes route optimization. But
irrespective of whether a MN decides to send a BU or not
to a CN, the SRC address of packets from the MN to the
CN is the COA. So the privacy factor (from a COA/location
of the MN) perspective is gone.

-Basavaraj

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 9 Apr 2001 23:50:58 +0200

Mike, 

> send binding updates if it wants rudimentary
	=> At the expense of route optimisation.

> Moving the HA farther toward the mobile
> node (as does HMIP) reveals more information. The
> only way to reveal less information is to decouple
> your home agent from your home network; this is
> just an operational issue. Of course, the best is
> to run things through an ALG which I think is
> ultimately what will happen if people want to be
> assured privacy (eg battered wife).
> 
	=> I really hope we don't have to resort to ALG's
	to get location privacy. I can see the next step 
	being reintroducing NATs for the same purpose !
	This would be a disaster IMO, especially for IPv6.

	Hesham

---

From: James Kempf <[email-masked]>
Date: Mon, 9 Apr 2001 09:56:07 -0700 (PDT)

I'm having a bit of difficulty seeing where this issue is coming from
at the IP layer. Is this a pseudonym for NATs? Routers need to see
the IP address in order to route. What is driving this requirement?

		jak

---

From: Phil Roberts <[email-masked]>
Date: Tue, 10 Apr 2001 09:36:52 -0400

Hi,

    what do you mean by "this?"  That mobile-ip has location privacy in its
charter, that there is a working group forming to take up the overall issue
of location privacy, or the concept of location privacy itself?

Phil

> From: James Kempf [mailto:[email-masked]]
> Sent: Friday, April 06, 2001 8:04 PM
> To: [email-masked]; [email-masked]'
> Subject: Re: [mobile-ip] location privacy
> 
> 
> I'm having a difficult time understanding what this means. Is this a 
> euphonisum
> for NATs? I have an even more difficult time seeing how to 
> implement it.
> The routers need to see an address to route the packet. What are the
> requirements driving this topic?
> 
>                  jak
> 
> At 08:34 AM 4/6/01 -0400, Phil Roberts wrote: