Subject: [mobile-ip] Hierarchy and Low Latency Handoff

From: James Kempf <[email-masked]>
Date: Tue, 24 Apr 2001 15:55:02 -0700 (PDT)

Hi H&K,

The design for low latency MIPv6 handoff proposes using bicasting to smooth 
handover.  I know it has been taken out of the draft, but Hesham
in particular has been a major proponent of bicasting, and I belive
there are plans afoot to do a separate draft or otherwise record
in some fashion bicasting as a viable handoff smoothing technique.

Now, if bicasting is used, then the new AR or the mobile node (depending on 
whether mobile assisted or network assisted handoff is used) needs to signal 
back to the LMM agent in order to get a new packet stream to the new AR. If the 
signalling line between the new AR and the LMM agent gets stretched enough, 
though, the latency in signalling may be enough to cause  packet loss and an 
.... urption in the conversation :-).

Thus it seems to me that in order to fufill the requirement that
the hiearchical scheme work well with with low latency handoff, we
really must have a requirement for multiple levels of hierarchy, *if*
bicasting is to remain a viable alternative for smoothing low latency
handoff.

The other possibility is that we drop bicasting as a candidate for
handoff smoothing. 

		jak

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 25 Apr 2001 01:37:33 +0200

Hi Theo, 
> >         Could someone help me out and explain why this is
> >         such a MIPv6 specific requirement ?
> 
> which one are you referring to?
> 
	=> The multi-level hierarchy.

	Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 25 Apr 2001 01:53:48 +0200

Hi James, 

	>	Either way, the main point here is that delays on the 
	>	wire are completely insignificant compared to the 
	>	delays over the air. This is a _proven_fact.
	>

	Not quite. I did a little experiment at IETF50 to see what signalling
	delays would be for an intercontinental BU - about 160 ms RTT to Japan
	and Europe. That is over half the RTT delay recommended by the ITU
	before human perception notices a gap. I think transcontinental
	 would be maybe half of this. 

	If the network operator cannot deploy a hierarchy of LMM agents,
	they may not be able to counter.

	=> James, I'm sorry but you completely misuse the 
	proposal here. Do you expect a MN to be located 
	in Europe and send a BU t an LMM agent / MAP 
	in the US ? Of course not. 
	We're not building a global mobility management 
	solution, it's _local_. LMM.
	We're not suggesting  that MNs BUs traverse the globe 
	in underwater cables.

	But I think you've missed my point. You maintain, as I understand it, that we 
	shouldn't include hierarchy because there is no demonstrated need for it
	at this time. We've been discussing this issue for some time, and I've
	just come up with an interaction between low latency handoff and
	hierarchy that could cause an interruption in real time traffic
	in certain deployments. Arguable, but possible.

	=> I thought I just showed one way of doing this in my 
	response. The delays over the wire are _insignificant_.
	Unless of course you start sending BUs across continents. 
	We can very happily say that our proposal does not 
	support this scenario where a MN is located in one 
	continent and the MAP is located in another. 
	What's the point of building such a network ?

	You still haven't answered my question on why 
	this is a v6 specific requirement.

	Hesham

---

From: James Kempf <[email-masked]>
Date: Thu, 26 Apr 2001 09:27:20 -0700 (PDT)

Erik,

>> times would be maybe half of this. 
>> 
>Why not. Each operator could solve the above by having an LMM agent
>per continent. Or they could be more fine grain and have one per metropolitan
>area.
>I don't see what benefits you could derive (and what the numbers would be
>in terms of signalling traffic volume and signalling delay) by an
>operator having e.g. both continent level LMMs as well as metro-area LMMs.
> 

Please see my previous post (third time!) about a deployment situation/network
topology that would result in significant increase in handover latency
(and thus probability of dropped calls).

		jak