Subject: [mobile-ip] a doubt about MIP

From: "pieracarlo venditti" <[email-masked]>
Date: Thu, 22 Apr 2021 20:24:47 +0200

Hello,
I'm an italian student, I studied RFC2002 but I've a doubt about Mobile IP protocol: if Mobile Node assumes that it has lost contact with its agent and it recives two new Advertisements, I don't understand if it attempts registration with the two Foreign Agents  sending the two new Advertisements or it attempts registration with only one of them and if it is so with which of them?
Thanks in advance
Carlo

---

From: "cny" <[email-masked]>
Date: Sat, 21 Apr 2001 20:47:14 +0200

Hi 

It really depend on implementations.
That is movement detection methods.

1) Lazy Cell Switching
if the mobile node loses 3 advertisements, it will then use the first advertisment it receives.
2.5 sec delay if each advertisment is sent once per seconds.

2) Eager Cell Switching
Every advertisment the mobile node receives, it will used the advertisment under that mobile agent.
0.5 sec delay if each advertisment is sent once per seconds.

3) Prefixed Matching
Handoffs depending upon a different prefix advertisment the mobile node receives.
0.5 sec delay if each advertisment is sent once per seconds.

May i know what are you doing for your project then???? :)

Cheers
Chern Nam Yap

  ----- Original Message ----- 
  From: pieracarlo venditti 
  To: [email-masked] 
  Sent: Thursday, April 22, 2021 8:24 PM
  Subject: [mobile-ip] a doubt about MIP

  Hello,

---

From: Tom Weckström <[email-masked]>
Date: Sat, 21 Apr 2001 22:01:02 +0300 (EET DST)

Hello.

On Thu, 22 Apr 2021, pieracarlo venditti wrote:

pieven >Hello,
pieven >I'm an italian student, I studied RFC2002 but I've a doubt about Mobile IP protocol: if Mobile Node assumes that it has lost contact with its agent and it recives two new Advertisements, I don't understand if it attempts registration with the two Foreign Agents  sending the two new Advertisements or it attempts registration with only one of them and if it is so with which of them?
pieven >Thanks in advance
pieven >Carlo
pieven >

The previously presented three possible methods are one way to explain
what could happen.

Another way to make sure the connection is maintained and the handofver is
as smooth as possible is to combine WLAN link layer information such as
link quality to the MNs registration decision.

For example, Dynamics HUT Mobile IP has different policies that affect the
way the MN makes registration decisions according to received agent
advertisements and WLAN link quality. More info from Dyanmics web site and
our publications.

	Tom

-- 
	Tom Weckström		Dynamics group
				Helsinki University of Technology
				[email-masked]
				http://www.cs.hut.fi/Research/Dynamics/

---

From: "Pugini Fabio" <[email-masked]>
Date: Sun, 22 Apr 2001 10:25:52 +0200

Hi
To be sincere, I think Piercarlo meant something different (I know that since we discussed about this topic few days ago). Our doubt is: what happens if a mobile node, which detects that it has just moved into a new Visited Network (by means of LCS or ECS or Pre-Matching indiferently), receives two or more advertisement in a very small time-interval (I mean before the registration), because it moved in a overlapping coverage areas of many BS? We thought that two possibility are available:
1) It keeps on sending registartion requests until it registers with a new Foreign Agent, that is until the first confirmation is received (not necessarily the one relevant to the first advertisement sent). In this case: What happens to the following confirmations that will soon arrive? Will they be ignored or will they be considered (than the node will switch to new foreign agents and finally register with the "last" one)?
2) It sends the first registration request and starts waiting for the relevant confirmation without sending any other registr. requests. (this seems to me to be  a very strange, and nowhere explained, approach).

Any help in understanding this operation will be highily appriciated.

In order to answer to last Chern Nam Yap's question, I can say that Piercarlo and I (we are students) are trying to analize the Mobile IP advertisement/registration way of operation. In the abovementioned first option (when  the mobile node considers all the registration confirmation it receives), we envision some delay/loss issues.
Best Regards
  ----- Original Message ----- 
  From: cny 
  To: [email-masked] 
  Sent: Saturday, April 21, 2001 8:47 PM
  Subject: Re: [mobile-ip] a doubt about MIP

  Hi 

  1) Lazy Cell Switching

  2) Eager Cell Switching

  3) Prefixed Matching

  Cheers
  Chern Nam Yap

    ----- Original Message ----- 
    From: pieracarlo venditti 
    To: [email-masked] 
    Sent: Thursday, April 22, 2021 8:24 PM
    Subject: [mobile-ip] a doubt about MIP

    Hello,

---

From: "cny" <[email-masked]>
Date: Mon, 23 Apr 2001 18:54:02 +0200

Hi 

Yes this is a interesting case, but normally the second way is assume.

Chern Nam Yap

  ----- Original Message ----- 
  From: Pugini Fabio 
  To: [email-masked] 
  Sent: Sunday, April 22, 2001 10:25 AM
  Subject: Re: [mobile-ip] a doubt about MIP

  Hi

    ----- Original Message ----- 
    From: cny 
    To: [email-masked] 
    Sent: Saturday, April 21, 2001 8:47 PM
    Subject: Re: [mobile-ip] a doubt about MIP

    Hi 

    1) Lazy Cell Switching

    2) Eager Cell Switching

    3) Prefixed Matching

    Cheers
    Chern Nam Yap

      ----- Original Message ----- 
      From: pieracarlo venditti 
      To: [email-masked] 
      Sent: Thursday, April 22, 2021 8:24 PM
      Subject: [mobile-ip] a doubt about MIP

      Hello,