Subject: RE: [mobile-ip] Multiple tunnels over unoptimized route packets f or Extended mode

From: "Glenn Morrow" <[email-masked]>
Date: Sun, 1 Apr 2001 20:43:27 -0500

Hesham,

Do you really think that you could convince a customer that you are really
providing them location privacy. If I were that customer, I would not be
convinced. I think that is everyone's point.

Thanks,

Glenn

> > Basic mode provides some features that Extended mode
> >         doesn't. For example location privacy is one of the major
advantages.

---

From: "Glenn Morrow" <[email-masked]>
Date: Mon, 2 Apr 2001 08:21:14 -0500

Hesham,

You probably did not get any feedback publicly at the WG meeting because
people at the MICs were quite plentiful and focused more on other issues of
the draft - time ran out. As I recall, you have received numerous comments
on the mailing list about it. This constitutes feedback. As for
alternatives, I suggest you look to what could be done at a router close to
the CN. People seem to trust routers to route their packets, perhaps they
should also trust them to hide their location.

Hope this helps,

Glenn

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Monday, April 02, 2001 2:26 AM
To: [email-masked]'
Subject: RE: [mobile-ip] Multiple tunnels over unoptimized route packets
f or Extended mode

Glenn, 

> Do you really think that you could convince a customer that you are really
providing them location privacy. 
> If I were that customer, I would not be convinced. 
> 
	=> Well, up until this mail I thought there is some location 
	privacy support in the draft. However if there is a better
	way of doing it, we're happy to consider it. I thought 
	we discussed this before IETF and found that it was difficult 
	to achieve complete location privacy with optimal routing ? 
	Could you elaborate on why you're not convinced ?

> I think that is everyone's point.
> 
	=> Everyone ? The only feedback I got until Minneapolis 
	was that (from the people that talked to me in private)
	Basic mode provided some nice features for 
	hiding the LCoA. So I don't know who everyone 
	is. 
	It's very difficult when people make general statements
	like these without explaining reasons and / or alternatives. 
	I'd appreciate some elaboration.

	Thanks,
	Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 2 Apr 2001 16:51:05 +0200

Glenn, 

> As I recall, you have received numerous comments on the mailing list about it. 
> 
	=> The only one I remember was from you. Another from James saying 
	that he liked Basic mode because of this feature. That's all I know 
	of on the location privacy comments. 

> This constitutes feedback. As for alternatives, I suggest you look to what could be done at a router close to the CN. People seem to trust routers to route their packets, perhaps they should also trust them to hide their location.
> 
	=> I'd love to get more cycles, but if people think it's interesting 
	then I guess it'll come naturally. We've done the best 
	we could given the requirements (min changes to MIPv6). 
	If something better comes out, then people will vote for it.

	Thanks,
	Hesham
> From: Hesham Soliman (ERA) [ <mailto:[email-masked]>] 
> > Do you really think that you could convince a customer that you are really providing them location privacy.

---

From: [email-masked]
Date: Tue, 3 Apr 2001 09:49:23 -0500

Hesham,

I do not believe location privacy should be one of the focal points
of HMIPv6. I think the key thing to be accomplished with HMIPv6
is the ability to reduce signaling to CNs and HA whenever a MN
moves (and changes it's COA) and to some extent (*maybe*) provide
a local entity in the serving network to authorize the MN access to
the network. 

-Basavaraj

> From: ext Michael Thomas [mailto:[email-masked]]
> Sent: Monday, April 02, 2001 1:56 PM
> To: [email-masked]
> Location privacy is only as good as the weakest
> link. I'm somewhat doubtful that mobile IP is that
> link; it's much more likely to be the applications
> running on top. For calling privacy, for example,
> we've been through this many times and it all
> really boils down to if you want to do it right,
> you need an application layer anonymizer. For SIP,
> that means doing a back to back UA, for email,
> that mean anonymous remailers, etc, etc. Anything
> less is probably not going to cut it, especially
> if you have to meet legal tests.
> 
> 	    Mike
> 
> Hesham Soliman  (ERA) writes:
>  > Glenn, 
>  > 
>  > > Do you really think that you could convince a customer 
> that you are really providing them location privacy.