Subject: RE: [mobile-ip] Hierarchy and Low Latency Handoff

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 25 Apr 2001 01:20:31 +0200

Hi James, 

Very good and timely point. There is a misunderstanding 
though and I'll try to clarify it below.

> The design for low latency MIPv6 handoff proposes using bicasting to smooth 
> handover.  I know it has been taken out of the draft, but Hesham
> in particular has been a major proponent of bicasting, and I belive
> there are plans afoot to do a separate draft or otherwise record
> in some fashion bicasting as a viable handoff smoothing technique.
> 
	=> Correct. Karim and I are writing a draft (or copying parts 
	of the old draft !) on this. We don't believe the Fast Handoff 
	solution for v6 is complete without it (unlike the v4 low latency draft). 
	In fact the design team has agreed that this will be highlighted 
	in the draft. I haven't had a chance to review the last revision yet though.

> Now, if bicasting is used, then the new AR or the mobile node (depending on 
> whether mobile assisted or network assisted handoff is used) needs to signal 
> back to the LMM agent in order to get a new packet stream to the new AR. If the 
> signalling line between the new AR and the LMM agent gets stretched enough, 
> though, the latency in signalling may be enough to cause  packet loss and an 
> .... urption in the conversation :-).
> 
	=> Ok so there are two cases, in the first case the MN sends a BU
	to the old AR (or LMM agent in case if HMIP is used). If bicasting 
	is used then this BU will request it. The forwarding delay on to
	the LMM agent is almost the same as the delay to the AR. 
	This is due to the fact that the bottle neck here is the 
	air interface. Delays on te wire are insignificant compared 
	to the massive delays over the air. 

	In the second case(no BU from the MN to the old AR) the MN
	can simply send the BU to the LMM agent (MAP in HMIPv6)
	some time after moving. The aim here would be to get 
	a more optimal route and reduce signalling outside 
	the domain. Bicasting can still be done from the 
	old AR. This is only one way of doing it and there 
	are more that we will discuss in the draft. 

	Personally I think there are still some open issues for the 
	second scenario (no BU from the MN) that need 
	to be explained in the draft but as I said I haven't had the 
	time to detail these issues. 

	Either way, the main point here is that delays on the 
	wire are completely insignificant compared to the 
	delays over the air. This is a _proven_fact.

> Thus it seems to me that in order to fufill the requirement that
> the hiearchical scheme work well with with low latency handoff, we
> really must have a requirement for multiple levels of hierarchy, *if*
> bicasting is to remain a viable alternative for smoothing low latency
> handoff.
> 
	=> I hope my explanation above clears this misunderstanding.

> The other possibility is that we drop bicasting as a candidate for
> handoff smoothing. 
> 
	=> Hmmm .. we did agree to keep it didn't we ? :)

	Could someone help me out and explain why this is 
	such a MIPv6 specific requirement ? 
	Please don't tell me that V6 is new and exciting :)
	That doesn't answer my question.

	Just trying to understand.

	Hesham

---

From: Theo Pagtzis <[email-masked]>
Date: Tue, 24 Apr 2001 16:28:28 -0700

Hi Hesham,

>         such a MIPv6 specific requirement ?

which one are you referring to?

>         Just trying to understand.

Theo

UCL/ Mobile Systems

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 25 Apr 2001 15:02:25 -0400

Hi Hesham,
  Bicasting is a special case of multicasting. Why not use multicasting from the MAP on
the downlink? In fact we have a draft on some thing like this for fast handoff.

--
Behcet

---

From: "tang" <[email-masked]>
Date: Sat, 28 Apr 2001 15:39:30 +0800

hi,everyone

I'm interesting in MOBILE IP,but some terms are strange to me,such as AR ,MAP,BU...etc. Please tell me about these or tell me where I can find these terms' explanation .

thanks.

tang