Subject: Re: [mobile-ip] Question about Registration Replies and RFC2002bis

From: James Kempf <[email-masked]>
Date: Mon, 16 Apr 2001 13:01:48 -0700 (PDT)

Hi Charlie,

Another issue that came up here in the discussion about DHCP is that
RFC 2002bis currently does not require the mobile node to periodically
reregister when it is on the home network. If the mobile node gets a dynamic 
home address and the HA is maintaining it by DHCP, then the HA
will periodically need to reregister.

Does it make sense to also require the mobile node to reregister, or
do you think this should be completely handled by the HA?

		jak
>X-mProtect: Mon, 16 Apr 2001 09:29:56 -0700 Nokia Silicon Valley Messaging 
Protection
>Date: Mon, 16 Apr 2001 09:29:49 -0700
>From: "Charles E. Perkins" <[email-masked]>
>To: Kory Keith <[email-masked]>
>CC: [email-masked]
>Subject: Re: [mobile-ip] Question about Registration Replies and RFC2002bis
>
>Hello Kory,
>
>I'm finally catching up, please excuse the delay...
>
>> In RFC 2002bis, it clearly states that the MN should
>> send 0.0.0.0 as it source address in the IP field of
>> the Registration Request when requesting a Dynamic
>> Home Address. (3.6.1.1).
>
>Correct.
>
>> My question is about 3.7.2.3 where it states the
>> following:
>> 
>> IP Destination Address
>>     Copied from the IP Source Address of the
>> Registration Request.
>> 
>> If I read this correctly, the Foreign Agent is meant
>> to send the Registration Reply to the MN with a
>> destination address of 0.0.0.0 in the IP header. How
>> can this be valid when 0.0.0.0 is a reserved address
>> in the IP standard and should not be used as a
>> destination address??
>
>That's a good question.  This language is a holdover from 
>RFC 2002, by which it was not possible to use 0.0.0.0.
>Unfortunately, I think the answer is that there isn't
>a good answer.  The choices seem to be:
>
>- 0.0.0.0
>- 255.255.255.255
>- 224.0.0.1
>- subnet-directed broadast, _if_ the Prefix Information
>  Option has been included in the Agent Advertisements.
>
>Probably arguments could be made for all of them, but
>I would sort-of favor the third one if we were starting
>from a clean slate.  For any of the choices, the foreign
>agent should deliver the Registration Reply to only one
>layer-2 address.
>
>If the document comes back from IESG again with requests
>for additional revision, perhaps this is a change that
>could be made.  Does anyone else have comments about what
>should be changed?  I think at least some clarification
>should be added to the specification.
>
>Regards,
>Charlie P.
>
>
>
>> 
>> Kory Keith
>> 
>> __________________________________________________
>> Do You Yahoo!?
>> Get email at your own domain with Yahoo! Mail.
>> http://personal.mail.yahoo.com/

---

From: Patrice Calhoun <[email-masked]>
Date: Mon, 23 Apr 2001 08:34:49 -0700 (PDT)

> home address and the HA is maintaining it by DHCP, then the HA will
> periodically need to reregister.

Well, it sure makes sense to have the registration lifetime set to (DHCP
leasetime + fudgefactor).

PatC