Subject: RE: [mobile-ip] Multiple tunnels over unoptimized route packets f or Extended mode

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 2 Apr 2001 22:00:02 +0200

------------------   RCoA = 3ffe:11:7:1::2 /128
	                             |      MAP   |-------------------------------
	                             |----------------|

	                             -------------------
	                             |    AR        |
	                             |----------------|
	                                   |
	                                   |
	                                   |     LCoA = 3ffe:11:7:3::1 /128
	                             -------------------
	                             | MR(MAP) |
	                             |----------------|
	                                   |    Home prefix = 2ff1:1:7:9:/64
	                                   |
	                                   |     MN LCoA = 2ff1:1:7:9::2 /128
	                             ------------------
	                             |     MN      |
	                             |----------------|

	The MR's LCoA in the visited domain is  3ffe:11:7:3::1 /128 .
	This is what the MR/MAP advertises to the MN. 

	HA_BU     (MN's Home_ADDR, 3ffe:11:7:3::1)
	MAP_BU  (RCoA, 3ffe:11:7:3::1)

	1. If there is no "further" MAP (for the sake of simplicity)
	    then the MN's HA will tunnel to the MR _directly_.

	2. If the MR is actually at home, then it will _not_ advertise
	    its MAP option with the T flag set since the address 
	    given to the MN will be topologically correct and the MN
	    will be reachable through normal routing. Is that the scenario
	    you were thinking of ?

	3. If the MR was at home (as in 2) and then moved
	   somewhere else (with the MN) then it will advertise
	   the LCoA which is NOT the Home address. The MN
	   will send a BU to the HA ( if outside the MAP domain) 
	   or further MAP (if still inside the MAP domain) and update
	   the MAP/HA Binding Cache. 

	If you've been following the discussions on Mobile Networks
	then you'd know that there is no clear definition today
	on how the MR updates the HA with an entire prefix.

	To summarise, if there is a further MAP then packets
	will be routed directly to the MN (if the MR is at home)
	or to the MR (if it is in a visited network). 
	If it was at home then moved, the packets will be routed
	to the MR's LCoA based on a BU from the MN which
	is triggered by the MR's MAP option informing the MN
	that it moved.

	I can't explain it in any more detail. 

	Hesham

---

From: Theo Pagtzis <[email-masked]>
Date: Mon, 02 Apr 2001 14:37:18 -0700

>                                      |      MAP   |-------------------------------

ok...

so the MR needs to do:

0)  MR gets an LCoA
1) MAP registration (MAP_BU)

2) MR_HA_BU to its own HA   this is

        MR_HA_BU (MR Home Addr, 3ffe:11:7:1::2)

now let us wonder what happens if the MR_HA_BU arrives __before__ the HA_BU....??  I
think this is a very possible case....

This is the case that I have been talking about... and that can get worse if the MR
(vehicle) changes too often is MAP point...

I cannot imagine that the fixed MAP works in extended mode for the MR...simply because
the MR is just another HMIPv6 node.

The spec does not explicitly state how a fixed MAP is to react if the MN that registers
with its is an MR.

Also the distance metric is not specified so that the selection criterion for an MR and
the MN (which to me behave the same) is concretely effected. At the moment the
"FURTHER MAP" means nothing to me as an implementor...it could be any of them in the
next 3-4 MAPs available. What would the distance metric be for that particular case?

Also if you (the spec) opts for extended mode for fixed MAP then the spec needs to
differentiate what are the cases that the Basic mode is needed...

>             then the MN's HA will tunnel to the MR _directly_.

If there is no further MAP then we have base mobility for the MR case and that will be
the end of the discussion.

>             will be reachable through normal routing. Is that the scenario

nope.. if the MR is at home then the thing is solved ages ago..

>            the LCoA which is NOT the Home address.

yes I agree 101% on that..

> The MN

yes the question is who will arrive first the HA_BU or the MR_HA_BU. when you are out
of the MAP domain..you want to registrer with the domain first before you want to send
anything back home. And to register with the domain, the latter needs to register
first.....

>         on how the MR updates the HA with an entire prefix.

Well if the MR is away from home I expect it to act as an HMIPv6 MN when it comes to
registering with its own HA.

>         is triggered by the MR's MAP option informing the MN

yes but until that MR's MAP gets sorted with a domain and a MAP registration I cannot
see how are you going to send packets upstream..from the MN that is..

Theo

UCL/ Mobile Systems