Subject: [mobile-ip] some issues with IPv6 mobility draft (sharif)

From: "Shahrier, Sharif M." <[email-masked]>
Date: Mon, 9 Apr 2001 16:43:31 -0400

> I have some issues to discuss with the document:
> 
> "Mobility Support in IPv6"
> <draft-ietf-mobileip-ipv6-13.txt>
> 
> I would be grateful if people can take a look and make any contructive
> comments. Thanks.
> 
> 
> 1.	Consider A, B where A is the mobile and B is the correpondent node.
> A is currently 
> 	away from its  home agent. B is also a mobile node. Suppose A send a
> BU(A) and moves 
> 	to its new location. The network is heavily loaded, and B has not
> yet received the 
> 	binding update. B also was to move. Thus, similarly, it sends a
> BU(B) to A, and moves 
> 	to its new location. The binding updates BU(A) and BU(B) eventually
> arrives at A's 
> 	and B's previous locations, respectively. But A and B have already
> moved. This means 
> 	that nodes neither A or B will are aware of each other new
> respective locations. 
> 	
> 	Thus, I believe this is be an erronous condition wrt A and B not
> knowing each others
> 	final destination addresses.
> 
> 2.	In light of the potential problem in (1), I propose that we
> eliminate all signaling 
> 	between mobile-to-mobile with respect to Binding Update and Binding
> Request messages.
> 	Instead, after a mobile has moved to a new location:
> 
> 		- It only sends a Binding Update to its home agent. 
> 		- Home agent updates the binding for the mobile.
> 		- The home agent maintains a Binding Update List containing
> all the 
> 		  correspondent nodes that are currently communicating with
> the mobile. 
> 		- The home agent (uni)multicasts a Binding Update to all the
> nodes in 
> 		  that Binding Update List. 
> 		- The correspondent nodes send back Binding Acknowledgement
> to the 
> 		  home agent.
> 		- Home agent, in turn, sends back Binding Acknowlegement to
> the mobile.
> 
> 	Under this scheme, we eliminate the need for mobile-to-mobile
> signaling. Only
> 	signaling between home agent and the mobile and correspondent(s)
> nodes are 
> 	neccessary. Also, something like the scheme above may slove the
> problem 
> 	described in (1). 
> 
> 3.	If the home agent has failed/reconfigured, I believe that "dynamic
> home agent 
> 	discovery" is used to locate a new home agent on the home link.
> However, it
> 	does not guard against failure to the home link itself. For this
> pupose we
> 	need to add fault tolerent capability to guard against link failure.
> 
> 
> 	Designate a "primary" home link and a "secondary" home link. Under
> non failure
> 	conditions, primary link is used as the home link. If the primary
> link fails,
> 	then the secondary link is used. New home agent is located. Of
> course, the 
> 	number of links can be increased to an arbitrary number.
> 
> 	These three points are not intended as final solutions, but as 
> 	a framework from which a formal solution can be drafted.
> 
> 
> 	Best Regards,
> 
> 	Sharif Shahrier
> 	InterDigital
> 
> 	
>

---

From: Mohan Parthasarathy <[email-masked]>
Date: Mon, 9 Apr 2001 15:10:27 -0700 (PDT)

> 	final destination addresses.

If the binding is wrong, you will get ICMP errors and if this
persists you should delete your binding cache entry if you
are a correspondent node. Now the packets go through the
home agent which has the right binding.

-mohan

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 10 Apr 2001 00:26:57 +0200

Im not sure if this situation will happen. When you 
move you would have an anchor point in the visited
network. This is either your previous default router 
in the basic MIPv6 case or your MAP in HMIPv6. 

This anchor point will have a tunnel to the MN. 
The lifetime of that tunnel should certainly be 
longer than a RTT on the Internet. 

If this didn't happen for some reason, then ICMP 
unreachables will be sent as others mentioned.

So I don't think we have a problem, do we ?

Hesham

> -----Original Message-----
> From:	Phil Neumiller [SMTP:[email-masked]]
> Sent:	Tuesday, 10 April 2001 8:15
> To:	[email-masked]
> Cc:	Kiernan, Brian G.
> Subject:	Re: [mobile-ip] some issues with IPv6 mobility draft (sharif)
> 
> It would seem that perhaps an optimization is possible here then?
> I wonder "how long" it would take for the fall back to occur and
> how frequently this particular pathological race condition could
> occur.
> 
> -pdn
> ----- Original Message -----
> From: "Vijay Devarapalli" <[email-masked]>
> To: <[email-masked]>
> Cc: "Kiernan, Brian G." <[email-masked]>
> Sent: Monday, April 09, 2001 4:39 PM
> Subject: Re: [mobile-ip] some issues with IPv6 mobility draft (sharif)
> 
> 
> > Okay, they wont. A keeps sending BUs to B's old CoA. It
> > would keep getting ICMP unreachable messages for B's old
> > CoA. then A would delete the binding cache entry it has
> > for B. A would then send the next BU to B's home address,
> > which is forwarded to B by B's home agent. so B eventually
> > knows where A is.
> >
> > this works because you fall back to the home address when
> > you cant reach someone at a particular CoA.
> >
> > it doesnt make sense for the Home Agent to maintain binding
> > update lists for each mobile that it seves as the home agent.
> >
> > vijay
> >
>