Subject: RE: [mobile-ip] Mobile Netwoks in MIPv6

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 3 Apr 2001 22:34:45 +0200

> Isn't it always the case that a mobile node behind a 
> mobile router, that the mobile router must be the
> mobile host's home agent?
> 
	=> Well, don't think so. It may be the case but there is no
	need to require it.

>  If the mobile router moves,
> wouldn't that cause the mobile host's BU to the
> other home agent to become stale?
> 
	=> Not if the other mobile updates its HA with a 
	new location. I mean if you just rely on the MR
	updating its HA, that would still work but 
	doesn't really give you route optmisation. 
	Plus the MN may go somewhere else,
	ie. leave the MR's subnet. 

	Hesham

> Hesham Soliman  (ERA) writes:
>  > 
>  > Hello Thierry, 
>  > 
>  > One other issue you might want to consider in your draft
>  > is the case where the MR sends a BU that covers the entire
>  > prefix but another MN (with a Home address on the MR's 
>  > subnet) sends a BU for its location which may be different 
>  > from the MR's location. 
>  > 
>  > I guess it would be easy enough if the HA does a search 
>  > on the longest Home address match to avoid the confusion
>  > in this case. 
>  > 
>  > Is that a feasible scenario ? I haven't read your draft for sometime 
>  > now so maybe it's already covered ?
>  > 
>  > Cheers,
>  > Hesham

---

From: Michael Thomas <[email-masked]>
Date: Tue, 3 Apr 2001 14:18:23 -0700 (PDT)

Hesham Soliman  (ERA) writes:
 > 	new location. 

   Yes, I knew I should have drawn this out first.

   But how does the mobile node know that the
   mobile router moved?

 > I mean if you just rely on the MR

   Isn't the real implication here that route
   optimization is the responsibility of that
   which actually moves? Ie, if the MR moves,
   it needs to send BU's to CN's. If the MN
   moves, it too needs send route optimizations?
   Ie, that this entire problem is recursive?
   That's sure what my drawing looked like unless
   we do something really different.

	 Mike

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 06 Apr 2001 14:55:20 +0200

[Manual resend...]

>         => Well, don't think so. It may be the case but there is no

Sorry Hesham, but why will the MN use HA as its home agent? In the old
figure, HA was on link P1, and MN is only on link P2. I can't see that
HA could act as a home agent for any MN execpt MR on link P2.

Ok, I assume that we have the two independent routing entries in the HA
as I was talking about earlier.

/Mattias