Subject: RE: [mobile-ip] Some Analysis

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Sat, 28 Apr 2001 02:04:30 +0200

James, 

	Please see my comments below.

> > Numbers!!!
> >
> 
> After having unjustly flamed Erik this morning and being inspired by
> his challenge, I went through an analysis comparing signalling
> overhead on hierarchical v.s. nonhierarchical designs. The attached
> zipped PDF (sorry for the zip, I couldn't get a unzipped through the list size 
> filter) and text explain.
> 
	=. No probs. As a side not, I believe Erik said "Numbers". 
	This is a nice detailed analysis, but it's missing "Numbers". 
	I do agree that updating a node 2 hops away is faster
	than updating a node 3 hops away. That's just common
	sense. However, the point is: is there any _significant_
	improvement ? I don't think so.
	Why ? because the numbers for delays over the air interface
	are so much higher than forwarding on the wire, 
	which makes forwarding delays on the wire (within a local 
	domain) insignificant. 

	I hope you can see that I didn't say "it will never happen".
	I said that there is no significant improvement .
	To use Eriks's words from an earlier mail, we need to
	see an order of magntude reduction in delays for any of 
	this to be significant. 

> Note to H&K: Arguments about the analysis are welcome, but please
> don't post "this won't happen in practice" arguments. You may have
> your opinion and I may have mine. The math speaks for itself.
> 
	=> I guess I'm "H", your math is fine, but this academic 
	argument needs to be placed in the right context. 
	I'm sure you're already aware of these delays I'm referring
	to, since you're heavily involved in MWIF. 

	Hesham

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 27 Apr 2001 19:28:25 -0500

Numbers?
----- Original Message -----
From: "Hesham Soliman (ERA)" <[email-masked]>
To: <[email-masked]>
Sent: Friday, April 27, 2001 7:04 PM
Subject: RE: [mobile-ip] Some Analysis

> which makes forwarding delays on the wire (within a local

Please quantify your response.  You are complaining about the lack
of numbers yet provide none.  At least we have a delay model with
what James has provided.

> I said that there is no significant improvement .

What is the quantitative or qualitative basis for the significant
improvement you seek?

---

From: Jim Bound <[email-masked]>
Date: Sat, 28 Apr 2001 00:47:02 -0400 (EDT)

Hesham,

But your or Erik have not proven there is no significant benefit either.
I feel your response is using a logic model that states one cannot deduce
anything from mathematical properties and James also did the inequalities
too. So I would argue his logic table was duplicate with an addition
discrete logical component.

And as another comment do you know how many I told you so cards I am
holding where Ipv6 made choices to defer a minimum performance gain with
the argument that "no significant gain is made".  A lot.  Know what.  I
built an IPv6 stack.  And we had to make up for all those decisions as
implementors in our production IPv4/v6 stack.

So at this point with your comment I will say now I am digging my heels in
to the chairs and saying arguments of this sort are simply not fair in
this case.  The distribtution of hierarchy in this case will also cause
ease of management at each level and with LDAP, Agentx, or a host of other
user level protocols can be managed quite easily and maintained at the top
of the hiearchy.

Not picking on you or Erik but the argument OK.  I am as sick of this one
as I am of being liberal in what I receive and conservative in what I
send.  It is simply not logical or scientific.

Also I see a mege of RegRe and HMIPv6 with minimum alteration to either.
But give and take would be required.

respectfully to you as author too,

/jim