Subject: Re: [mobile-ip] Mobile Netwoks in MIPv6

From: Thierry Ernst <[email-masked]>
Date: Fri, 06 Apr 2001 15:06:27 +0200

[Sorry if you received this twice - mailing list was apparently broken
Thursday]

Hi Hesham, all,

> Hesham:
> Hello Thierry,
> 
> One other issue you might want to consider in your draft
> is the case where the MR sends a BU that covers the entire
> prefix but another MN (with a Home address on the MR's
> subnet) sends a BU for its location which may be different
> from the MR's location.

I have already been thinking about this but I did not include it in my
draft.   My draft does cover the case where the MR moves without its
attached nodes, neither when a MN attaches to the mobile network.  
Sounds like it's time for the new revision to cover it.
 
> I guess it would be easy enough if the HA does a search
> on the longest Home address match to avoid the confusion
> in this case.

It depends where is the HA and what is the MN's care-of address.
 
> Is that a feasible scenario ? I haven't read your draft for sometime
> now so maybe it's already covered ?

I will add a section in my draft, then we could discuss about it.  
Unfortunately, I do not have the time to write a new version right now,
but this will be done by July and will address other issues.

Cheers,
Thierry

--
* mailto:[email-masked]  Tel +33 (0) 4 76 61 52 69 
* INRIA Rhone-Alpes Projet PLANETE       (fax 52 52) 
* and MOTOROLA Labs Paris
* http://www.inrialpes.fr/planete/

---

From: Thierry Ernst <[email-masked]>
Date: Fri, 06 Apr 2001 15:10:03 +0200

[yet another repost - not the same ...]

> Do we really need another draft ? 
What do you mean by another draft ?  There is already one 
(http://www.inrialpes.fr/planete/people/ernst/Documents/draft-ernst-mobileip-v6-network.txt),
my guess it that you may say that there is no need for a draft dealing
with mobile_networks issues other than the MIPv6 draft (?)

> From the discussions we had,
> it looked like some clarifications are sufficient. At least
> the mail from Mattias explained this clearly i guess.

I think we need a draft dealing about mobile networks independently of
the MIPv6 draft.   MIPv6 addresses general issues, mobile routers and
networks have their own.

---

From: Thierry Ernst <[email-masked]>
Date: Fri, 06 Apr 2001 15:11:07 +0200

[last repost !]

Mohan Parthasarathy wrote:

> I never said anything about prefixes appearing out of thin air.
> I think the spec is not clear enough. So, just having the
> routing information for all the prefixes behind MR is not
> sufficient.

> Look at the steps involved :
> 
> 1) MR moves to the foreign link and asks HA to defend for its home
>    address.
> 
> 2) Packet from some CN goes toward HA. Reading 9.5 and 9.6 sections
>    of the draft says that it will encapsulate only for packets
>    destined to the MR's home address. Any packet for which MR
>    is the router, it will try to send it to MR. Hhmm MR itself is
>    not home. So should it encapsualte ? But it is not defending
>    for those addresses.
> 
> I agree that we can clarify the existing draft rather than having
> another draft.

I would agree if encapsulation by HA to the MR would be the sole
issue.   But I guess the most recent emails have clarified that there
(many) other issues to address, and this deserves an indepent draft
IMHO.

Thierry.

---

From: Thierry Ernst <[email-masked]>
Date: Fri, 06 Apr 2001 15:04:36 +0200

Hi,

What I see in this thread is a lot of questions raised by some people
("how does ...", "why ...", "could you ..."), and other people trying to
answer whereas the problem is not stated.  How could one reply to a
question if it's not based on some technical solution ?

How would a MN knows that the MR it is attached to has moved ?
=> I don't know - this depends of the solution we propose to handle MR

Is the MR the Home Agent of the MN that attaches the MR ?
=> I don't know - this depends of the solution we propose to handle MR

Do nodes behind the MR need to get a COA ?
=> I don't know - this depends of the solution we propose to handle MR

and so on.

We don't have the solution to those questions now.   It's therefore
useless to answer those questions if it's not based on some concrete
propositions.   My draft is trying to answer some of the questions, not
all (for sure I can add new sections in the draft, but I voluntary kept
the things as simple as possible in order to raise the issue - now that
the issue is raised and that people seem to agree that there are issues
to address, I might consider to extend my draft to address the other
issues I have been thinking of for quite a few months now), then I would
only reply to concerns about my proposition.  I will submit a revision
of my draft by July.

BTW, my proposition does not only says how to redirect packets from the
HA to the MR (some people might argue this is not issue - well, at least
we need clarifications in the MIPv6 draft), it also says how to perform
route optimization between the CN and the MR.

Thierry.

---

From: Mohan Parthasarathy <[email-masked]>
Date: Fri, 6 Apr 2001 09:59:43 -0700 (PDT)

> 
> Thierry Ernst writes:
>  > > >  If the mobile router moves,
>  > > > wouldn't that cause the mobile host's BU to the
>  > > > other home agent to become stale?
>  > > >
>  > >         => Not if the other mobile updates its HA with a
>  > >         new location. I mean if you just rely on the MR
>  > >         updating its HA, that would still work but
>  > >         doesn't really give you route optmisation.
>  > 
>  > Right.
> 
>   Yes, but how does the MN behind the MR *know* that
>   MR changed its CoA?
> 
>   A related question: if it's just a non-mobile host
>   behind a mobile router, what causes those hosts
>   to change their home address destination option?
>   In fact, how did they know that they needed to
>   use it in the first place?
> 
Doesn't this imply that MR should get a new prefix everytime it
moves so that the MNs can configure a new care of address ?

-mohan

>   There are some pretty deep and fundamental questions
>   lurking here. Namely, is mobility transparent to 
>   non-mobile hosts and if so, why? We also need to
>   consider what this means in the face of
>   renumbering which in many respects is mobility 
>   (flattening) in disguise.
> 
> 	 Mike

---

From: "Stuart W. Card" <[email-masked]>
Date: Tue, 03 Apr 2001 17:43:44 -0400

At 02:14 AM 2001-03-30 +0200,
<[email-masked]> wrote:

>Thierry Ernst has brought up a valid scenario in which the MIPv6
>spec does not work. This is reagrding the support of Mobile
>Networks in MIPv6.
>
>The scenario and solution are explained in :
>http://search.ietf.org/internet-drafts/draft-ernst-mobileip-v6-network-01.txt
>
>This draft was presented in Pittsburgh (00) and San Diego (01).
>Personally I think this is a good solution and it deserves the
>WG support...
>
>So do you think the draft or at least the problem should
>be considered as part of the charter ?

Much discussion followed.  Several points:

(1) Leaving behavior of implementations to interpretations
made by implementors is a bad idea.  The fact that the WG
members themselves have different interpretations is sufficient
evidence that interpretation of the current language by future
implementors will lead to divergent behaviors.

(2) The HA is not necessarily the _last_ router, going from
the Internet core towards the prefixes for which the MR routes;
it may not even be in the normal path for such packets.
Further, the MR does not necessarily advertise; the routes
may have been otherwise configured.  Therefore, the HA does
not necessarily have routing table entries that could be used
to route traffic intended for prefixes behind the MR via the tunnel.

(3) Solutions based upon making all the 'fixed' nodes on
the mobile network act as if they were themselves (independently)
mobile are not efficiently scalable.

Therefore, the issue of Mobile Networks must be explicitly addressed,
preferably in the Mobile IP WG rather than elsewhere.  I think it is in
the scope of the current charter, but if/when the charter is revised,
this topic should explicitly be identified therein as within scope.
I think Thierry Ernst's draft is a good thing, at least to kick off discussion.
The ultimate requirements for Mobile Networks support should be
integrated into the mainstream Mobile IP documents rather than
addressed in separate RFCs.

Several more points:

(1) Mobile Routers may raise new authentication issues,
relating to ensuring that the MR is truly the router properly
authorized to route for the prefixes on which it sends BUs.

(2) Mobile Routers may route for multiple prefixes of different sizes
in arbitrary disconnected regions of the address space.

(3) Mobile Routers may be multi-homed.

The last point above is particularly important for me.
I am building wireless mobile routers that concurrently
use multiple wireless links to access multiple points
of access into the wireline infrastructure.  Except for
this last point, everything is just IMO, and I'm not an
expert on Mobile IP.  Thanks all!

Stuart W. Card, Chief Scientist & Vice-Pres., Critical Technologies Inc.
Suite 400 Technology Center, 4th Floor 1001 Broad Street, Utica NY 13501
315-793-0248 x141  FAX -9710  <[email-masked]>  http://www.critical.com