Subject: Re: Multiple Levels of LMM agents (was: RE: [mobile-ip] Revised L ocalized Mobility Management Requirement s)

From: James Kempf <[email-masked]>
Date: Tue, 24 Apr 2001 15:08:59 -0700 (PDT)

Hi Phil,

An interesting idea.

So can you explain how this will reduce the length of the signalling leg between
the LMM agent and mobile node when the mobile node changes subnet? The 
primary argument for hierarchy is that you can have a lower level LMM
agent that is close to the mobile node with which the mobile node does
a short leg BU when changing CoA, but the global CoA remains the 
same. 

		jak

>X-Sent: 24 Apr 2001 21:52:13 GMT
>From: "Phil Neumiller" <[email-masked]>
>To: <[email-masked]>
>Subject: Re: Multiple Levels of LMM agents (was: RE: [mobile-ip] Revised L 
ocalized Mobility Management Requirement s)
>Date: Tue, 24 Apr 2001 16:51:17 -0500
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
>
>Charlie, Hesham,
>
>With SeaMoby context transfer, the HA can be virtualized.  The HA could also
>be replicated for multi-home agent-ing.  One of the beauties of the SeaMoby
>context transfer is that the the "essence" of the MN or AR hosting the MN can
>be transported seamlessly to where it makes the most sense at that current
>time, i.e. the network can evolve by having the HA follow the mobile or
>by going to the optimal location for service (i.e. load balancing, QoS, and
>other factors can be part of the decision process).
>
>Thanks,
>
>Phil
>----- Original Message -----
>From: "Hesham Soliman (ERA)" <[email-masked]>
>To: <[email-masked]>
>Sent: Tuesday, April 24, 2001 4:41 PM
>Subject: RE: Multiple Levels of LMM agents (was: RE: [mobile-ip] Revised L 
ocalized Mobility Management Requirement s)
>
>
>> Hello Charlie,
>>
>> > The point of hierarchy is to localize the signaling.  That's a good
>> > feature.  It also has the advantage of reducing signaling across
>> > administrative boundaries.
>> >
>> => I don't understand how multi-level hierarchy can reduce
>> signalling across administrative domains. If by "administrative
>> domains" you refer to the top Anchor's domain then signalling
>> to the HA is required regardless of how many levels you have..
>>
>> > Both of these are valuable for scalability.
>> >
>> => IMHO a real scalability benefit from hierarchy would be
>> if we can have less state in the "further" agents than
>> he "closer" ones. This is not the case in single level
>> or multi-level hierarchy so I'm not sure I see a significant
>> scalability benefit.
>>
>> Regards,
>> Hesham
>>
>>
>
>

---

From: "Phil Neumiller" <[email-masked]>
Date: Tue, 24 Apr 2001 17:20:02 -0500

Hi James,

My answer is below.
----- Original Message -----
From: "James Kempf" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, April 24, 2001 5:08 PM
Subject: Re: Multiple Levels of LMM agents (was: RE: [mobile-ip] Revised L ocalized Mobility Management Requirement s)

> the LMM agent and mobile node when the mobile node changes subnet?

Oh, yes.  We had talked about this on the CT list just today.  Lets say I am a
LMM pool hosting router.  We know that due to just the physics of proximity with
other LMM pool hosting routers that any given host will almost always hand off
exclusively with a certain set of "regular neighbors".  A security association (sort
of a security web) is formed apriori with the regular neighbors so that secure
tunnels are in place between all regular neighbors.  This makes the context
transfer very fast, i.e. no dependency on building a secure tunnel before transfering
it.  This allows the virtual LMM to simply walk through the pre-approved
web of routers that it is authorized for.  If make-before-break is desired that
can be added for seamlessness.

---

From: "Phil Neumiller" <[email-masked]>
Date: Tue, 24 Apr 2001 17:28:44 -0500

Also, you can pre-flood neighbors with the "notion" of a MN "may"
becoming your way shortly, which can be used for optimization
purposes and QoS equations and handofff decisions.