Subject: RE: Multiple Levels of LMM agents (was: RE: [mobile-ip] Revised L ocalized Mobility Management Requirement s)

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 25 Apr 2001 00:55:16 +0200

>  The 
> primary argument for hierarchy is that you can have a lower level LMM
> agent that is close to the mobile node with which the mobile node does
> a short leg BU when changing CoA, but the global CoA remains the 
> same. 
> 
	=> So the main gain here if I understand you correctly is that
	you get a "quicker" update of the routing tables. 
	In a wireless system where forwarding delays on the wire are 
	completely insgnificant compared to the delays over the air,,
	I don't see a significant value adding here. We can easily illustrate
	this with some well known numbers. 
	Unless you see other gains that I couldn't interpret..

	Hesham

---

From: Tom Weckström <[email-masked]>
Date: Thu, 26 Apr 2001 10:36:50 +0300 (EET DST)

On Wed, 25 Apr 2001, Hesham Soliman  (ERA) wrote:

Hesham >>  The 
Hesham >> primary argument for hierarchy is that you can have a lower level LMM
Hesham >> agent that is close to the mobile node with which the mobile node does
Hesham >> a short leg BU when changing CoA, but the global CoA remains the 
Hesham >> same. 
Hesham >> 
Hesham >	=> So the main gain here if I understand you correctly is that
Hesham >	you get a "quicker" update of the routing tables. 
Hesham >	In a wireless system where forwarding delays on the wire are 
Hesham >	completely insgnificant compared to the delays over the air,,
Hesham >	I don't see a significant value adding here. We can easily illustrate
Hesham >	this with some well known numbers. 
Hesham >	Unless you see other gains that I couldn't interpret..
Hesham >
Hesham >	Hesham 
Hesham >

Hesham, you just admitted that we get a faster routing table update with
multilevel hierarchy. There is little to argue against this clear benefit.
This benefit, in the end, results in *better scalability* as Theo and
others have already said.

Regards,
-- 
	Tom Weckström		Dynamics group
				Helsinki University of Technology
				[email-masked]
				http://www.cs.hut.fi/Research/Dynamics/