Subject: RE: [mobile-ip] IPv6 Regional Registration - identifying requirem ents

From: "Hongyi Li" <[email-masked]>
Date: Tue, 10 Apr 2001 10:20:55 -0400

Hi Phil,
  Here are few more requirements I think that are impportant for RR/LMM (I
like
the term localized mobility management too):

 10) LMM SHALL provide optimized routing for mobile-to-mobile communication.
 11) LMM SHOULD minimize the number of network nodes affected by handoff
signals.
 12) LMM SHOULD support auto-configuration capabilities for mobile
agents/FAs, access routers.
 13) LMM SHOULD simplify the network design and provisioning for enabling
LMM
capability in a network and allow progressive LMM deployment capabilities.

Some more comments in lines:
   
> 1) Regional registration shall be introduced to minimize the signaling
> traffic to the home agent or correspondent nodes for 
> intra-domain mobility
> 2) Regional registration shall not introduce new overhead on 
> links between
> the mobile and the regional registration agents
> 3) Connectivity to the mobiles shall not be interrupted in 
> the presence of
> the failure of regional registration agents
> 4) Regional registration shall scale to support millions of nodes in a
> visited network

LMM SHALL be scalable in terms of number of connected users (i.e., active +
dormant =  millions) and the number of users on the move.

> 5) Regional registration shall be secure against malicious 
> behavior from
> visiting mobiles
> 6) Regional registration shall allow multiple levels of hierarchy
> 7) Regional registration shall support fast handoffs
> 8) Regional registration shall not require changes to the 
> mobile node, the
> home agent, or correspondent nodes
> 9) Regional registration shall not introduce host routes in 
> routing tables

I agree with Theo comments about host route. The LMM SHOULD minimize the
amount of host routes in the routers.

- Hongyi

---

From: Michael Thomas <[email-masked]>
Date: Tue, 10 Apr 2001 11:57:15 -0700 (PDT)

> amount of host routes in the routers.

   I'm sorry but somebody's going to have to explain
   why this is a requirement. The number of routes
   in the MAP are the same. The only difference is
   the routes in the access and/or aggregation
   routers between the MAP and the MN, but that
   scales to the order of the subtended hosts at
   each point in the tree which doesn't seem
   especially onerous.

		Mike