Subject: [mobile-ip] draft 15

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Thu, 22 Nov 2001 15:47:14 +0100

A few comments/questions to 
http://www.ietf.org/internet-drafts/draft-ietf-mobileip-ipv6-15.txt
downloaded this morning (CET).

The date is 2 July 2001 as in draft-14.

typo: page 17: "int" should be "char"

Page 20: Deleting the preference stuff?
I guess this is the only object pointing towards some load-sharing/balancing
HA's.
Maybe too simple, but I should like to see some other proposals on this problem
before removing the field.

Section 5.1: What happened to:
>> Agree, but why not whenever it is possible/easy write it explicitly, i.e.
>> change 5.1 to "D-bit is ignored if the H-bit is not set."
>
>I don't see any problem with this.  Unless someone else can say
>why not to do this, I will make the change.
>
>Regards,
>Charlie P.

Section 8.3:
Some HA (also being a CN) receives a BU without H-bit from a node already
registered _with_ the H-bit set.
What would be a sensible reaction?
1) Stop intercepting packets and just work as a usual CN
2) Ignore the missing H-bit in the BU
3) ?

/Peter
-- 
Peter Grimstrup          Systems Developer
Ericsson Telebit A/S     tel: +45 89 38 52 75
Skanderborgvej 232       fax: +45 89 38 51 01
DK 8260 Viby J, Denmark  e-mail: [email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Thu, 22 Nov 2001 16:14:44 +0100

Section 8.3:

=> I agree this should be specified (and we'll test this ASAP
at the ETSI IPv6 plug-tests)

=> I vote for 1) because this can happen when the MN reboots
and forgets its previous HA for instance (I am trying to find
a meaning).

Thanks

[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Thu, 22 Nov 2001 16:38:27 +0100

Section 8.3:
   
=> after a short discussion, the consensus is to raise an error
(with a new code). Of course if acknowlegments are not requested
an easy solution is to drop the BU (:-).

Thanks

PS: the test is near ready, we don't expect good behaviors because
the test is far faster to write than a fix...

---

From: Mattias Pettersson <[email-masked]>
Date: Fri, 23 Nov 2001 09:37:52 +0100

Hi,

> an easy solution is to drop the BU (:-).

I agree that an error is the only solution. A well-functioning MN would
not send a BU to HA without H-bit, simply because the MN must consult
its BUL before sending it and would get a hit on destination address =
HA and know that H must be set. If MN has no BUL (due to crash) it will
have to get in sync with the HA, thus both DAD issues and sequence
numbers could stop this before it becomes an issue at all as already
mentioned.

From the HA's point of view, receiving a BU with H = 0 is not a proper
way of telling it to remove a home registration. Home registrations must
not be removed unless explicitly stated by the MN. So, since the MN
behaves badly, it should be informed about this (by error code) and the
HA should keep its state.

/Mattias