Subject: RE: [mobile-ip] LMM for IPv6 requirements draft (new revision .01 )

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 15 Nov 2001 18:19:42 +0100

Hi James, 

>
> 3.9 Support for MIPv6 Handover.
>
>    An LMM solution MUST be available for all standardized MIPv6
handover
> algorithms. The signaling interactions
>    between the handover algorithms and LMM MUST maintain
compatibility.
> This requirement SHOULD NOT be interpreted
>    as ruling out useful optimizations of LMM and MIPv6 handoff that
> simplify the implementation or deployment of LMM or
>    MIPv6 handover.
>
> => This is a bit confusing, especially the last sentence.
>    I don't get the advantage between this one and the one
>    in the doc.
>

For one thing, the original requirement says nothing about standard
MIPv6 handover. I think the requirements must cover all handover
possibilities, not just fast handover.

=> Sure, I kind of assumed that. But saying it explicitly
  is a good thing.

For another, as you mention, I would like to allow a solution in which
the fast handover and LMM solutions are deployable together. For
example, suppose there is a possibility of optimizing HMIPv6 to take
advantage of BETH tunnels. The current requirement would not allow this,
because it would mean that HMIPv6 and BETH would have to be deployed
together. That is the purpose of the last sentence.

=> OK, my interpretation of the requirement was 
 that it would allow for the scenario that you
 mention above, but I must have interpreted it 
 differently. 

Cheers,
Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 21 Nov 2001 18:04:43 +0100

> >   I thought that any mention w.r.t. a handover and 
  > compatibility of a
  > > handover mechanism w.r.t to an LMM scheme was only to imply
  > > compatibility with handoff optimisations. That is to say, 
  > it assumes
  > > existence of base MIPv6 handoffs at the very least..i.e. we assume
  > base
  > > MIPv6 and only care about compatibility of LMM schemes 
  > with handoff
  > > mechanisms _beyond_ base mobility (a.k.a MIPv6).
  > >
  > 
  > If a service provider wants to deploy standard MIPv6 
  > handover, then it
  > should be possible to obtain LMM support for it. This is 
  > not to imply
  > that the same LMM solution is required for both standard 
  > MIPv6 handover
  > and the optimizations, they could be different.
 
  => Not to elongate this thread any more, but we're
     talking about ONE LMM solution. We can optimise
     it for different scenarios, but the aim is 
     to get one LMM solution. 
Hesham