Subject: RE: [mobile-ip] I-D ACTION:draft-ietf-mobileip-hmipv6-05.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 30 Nov 2001 10:48:56 +0100

Hi, 

Thanks for the comments. Some answers below.

  > Thank you for the new version of the draft.
  > 
  > I understand that MAP discovery is still used like in -04, 
  > namely MAP
  > options are re-transmitted from one interface to another.  

=> Yes that's one option. The other one involves RR. 

I still
  > wonder if routers should re-transmit on other links what 
  > they receive
  > via RA's on one link.  I see this as the job of routing 
  > protocols and
  > not of RA's.

=> As far as I know it doesn't break anything. Also the 
RAs SHOULD be authenticated when using this mechanism. 
Or do you think it should be a MUST ? 

  > 
  > Also, I still think HMIPv6 should specify a way to delete 
  > MAP-options
  > from an advertising interface.(RR means to do that is to put 0 in
  > use-prefix of a CHANGE).

=> yes or a delete. But you're right we should make it 
more explicit for both mechanisms. It doesn't actually 
involve more protocol work. I'll add some text for that
and let you know before the next revision comes out. 

Cheers,
Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 30 Nov 2001 15:18:41 +0100

Greg, 

  > 	It is easy to delete map options by setting the
  > 	Preference value to 255 (do not use).

=> '15' in the new (properly aligned) option :)

  > 
  > 	This will not necessarily make the MAP invisible
  > 	immediately, but if you advertise at 255 for
  > 	the elapsed lifetime of the MAP option, then
  > 	after that stage, no one will be bound to
  > 	the MAP, and it can be removed from all
  > 	advertisements
  > 
  > 	This will work for RA and RR.

=> I think the intention (which will be explicitly
stated in the next version) was that 255 (or 15 
currently) means: The MAP will not accept new BUs.
For deletion we have to stop the advertisement. This 
can be done by sendin an option with the lifetime set
to zero.

Hesham