Subject: Re: [mobile-ip] AAA keys design comment

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 11 Nov 2001 17:29:14 -0800

Hello Fredrik,

While reading through the AAA keys discussion, I found this text:

>>   It appears that I've been thinking of this too
>>   much like the v6 model which _does_ require the
>>   round trip to the HA at all times since there's
>>   no FA.
> 
> it's not only the roundtrip over the air that can be
> more expensive, it's also between the home and foreign
> network (when the HA is allocated in the home network).

I don't see why we can't use the same AAA/Mobile IP model
for IPv6 as for IPv4, since some sort of local attendant
function looks pretty likely.  For Mobile IPv4, the foreign
agent is the logical place to put the additional attendant
functionality, but it also has to be somewhere local
in IPv6.  We have the AAAv6 draft for this purpose, and
eventually we hope that AAA will pick it up as a work
item since the IPv6 working group has essentially
validated the usefulness of having some sort of AAA
model for authorizing network access for IPv6.  I have to
be careful to avoid giving the impression that IPv6 has
validated our AAAv6 draft, because that isn't the case.
There seem to be many interacting features, and lately
I have not had time to push forward on this particular
draft.

Regards,
Charlie P.

---

From: "James Kempf" <[email-masked]>
Date: Mon, 12 Nov 2001 09:41:26 -0800

Charlie,

What about having the access router perform this function?

Also, isn't the new User Network AAA Protocol (UNAP) working group the right
place to discuss this issue?

        jak

---

From: Michael Thomas <[email-masked]>
Date: Wed, 14 Nov 2001 07:57:15 -0800 (PST)

> I have not had time to push forward on this particular

   If you read the article that Fredrik responded
   to, you will find that for mipv6 there is an
   additional round trip required since there's 
   no such thing as proxied binding updates in 
   mipv6. There's also the same fate sharing
   problem as in mipv4 with the HA and AAAh. 
   Thirdly, there's no such thing as a foreign 
   agent in mipv6. Positing one for AAA is a 
   major deviation of the design, and one that
   the wg has been trying to steadfastly avoid.

	  Mike

---

From: "Fredrik Johansson" <[email-masked]>
Date: Thu, 15 Nov 2001 08:42:01 +0100

Hi Charlie

I agree with James, although I havn't given it much thought, the access
router seems like a good place to place the AAA functionality in the foreign
network.

Regards
/fredrik

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Charles E.
>Perkins
>Sent: den 12 november 2001 02:29
>To: Fredrik Johansson
>Cc: [email-masked]