Subject: RE: [mobile-ip] LMM for IPv6 requirements draft (new revision .01 )

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 21 Nov 2001 12:32:41 +0100

Carl, 

Looks fine. So did the last one !
The requirement said that the two (LMM and FMIP)
MUST BE _able_ to get deployed separately.
If you remove "able to get" from that statement
then I think you would think that the requirement
is mandating that they get deployed separately, which
is not the way I interepret it. 

BTW, I assume that you'll also remove the other 2 
reqts as agreed by Cedric, Theo, James, me ....etc
earlier on the list ?
The two are: 
1. The movement detection based on domain
   identification.
2. The L2 stuff !

Thanks, 
Hesham

-----Original Message-----
From: Carl Williams [mailto:[email-masked]]
Sent: Wednesday, November 21, 2001 3:56 AM
To: [email-masked]; Cedric Westphal;
[email-masked]; [email-masked]
Subject: Re: [mobile-ip] LMM for IPv6 requirements draft (new revision
.01)

> 
> Here is what the second paragraph says:
> 
>     LMM and any standardized Mobile IPv6
>     handover algorithm  MUST BE able to be deployed independently
>     of each other.
> 
> So please explain to me how an LMM solution that leverages
> a handover protocol could be separately deployed from
> the handover protocol?
> 
>                 jak
> 
> 

Hello James,  

Initially the requirement was written from the perspective
of an "optimized" MIPv6 handover scheme that was *optional*.

So with your proposal we are now not making any assumptions
about the nature of the handover scheme.  Indeed, it could just simply
be MIPv6.  I will use the suggested text and include:

3.9 Support for Mobile IPv6 Handover

Since one of the primary goals of LMM is to minimize
signaling during handover, an LMM solution MUST
be available for the standardized Mobile IPv6 handover
algorithms. LMM and the Mobile IPv6 handover algorithms
MUST maintain compatibility in their signaling interactions for
fulfilling complementary roles with respect to each other.

If anyone has any comments on this requirement, please
make your concerns known.

Thanks to all those who read the draft:) and provided feedback.

Carl

---

From: Theo Pagtzis <[email-masked]>
Date: Wed, 21 Nov 2001 12:04:58 +0000

True

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 21 Nov 2001 10:36:07 -0800

----- Original Message -----
From: "Hesham Soliman (ERA)" <[email-masked]>
To: "'Carl Williams'" <[email-masked]>;
<[email-masked]>; "Cedric Westphal" <[email-masked]>;
"Hesham Soliman (ERA)" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, November 21, 2001 3:32 AM
Subject: RE: [mobile-ip] LMM for IPv6 requirements draft (new revision .01)

> 1. The movement detection based on domain

Hi Hesham,

I removed (1) above.  But (2) was never in the draft :-)
It was in a version that was sent to the LMM design
team and I assume Cedric somehow got a copy of it.

Carl

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 21 Nov 2001 13:07:47 -0800

Carl,

I did get two versions of the draft, but I commented only on the
one I got from docomo-labs:-). Mystery paragraph's gone anyway...
Thanks for considering the comments and for updating the document,

Cedric.

---

From: "Jari T. Malinen" <[email-masked]>
Date: Wed, 21 Nov 2001 13:17:02 -0800

Hello,

On movement detection: it is strange if we have no words at all
on the requirement to detect when a LMM domain has changed. I
feel there should be a version of the movement detection text
included. If it were just an option for the protocol I would
not mind dropping it altogether but for a LMM protocol to operate
at all one needs to know when a LMM domain is crossed to do an initial
registration. The domain need not be the same as an administrative
domain, but like in base Mobile IP, movement detection clearly
is a part of the overall operation. I do not see a problem
if some other mechanism or protocol provides the actual
mechanism but it needs to be noted such mechanism is
needed for the LMM to work.

BR,

-Jari

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 21 Nov 2001 13:18:28 -0800

> Thanks for considering the comments and for updating the document,

Cedric,

   You are correct. there was a small (brief) period that the old draft
   was on the website.  So you most likely downloaded quickly (after
   the announcement).  So thanks for your great interest in reading
   and providing feedback on LMM requirements.

Carl

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 21 Nov 2001 13:35:35 -0800

Jari,

> needed for the LMM to work.

now I understand. My original comments was that the requirement was not
clear as to who is detecting the movement, and I suggested either to clarify,
or to drop it. I agree that registration issues into a new LMM domain, and
the ability for the MN to know the LM domain ability are important issues.
In the following words, I am trying to capture the intent of the requirement,
let me know if I am close:

3.5.4 Movement detection

Any LMM mechanism MUST contain or make use of a mechanism that provides
movement detection between separate visited domains. Movement detection
allows a MN to identify that it has moved to a new LM domain, and to perform
registration in the new LM domain. LMM mechanism SHOULD interwork with
a default movement detection mechanism, such as AAA.

Take care,

Cedric.

---

From: Michael Thomas <[email-masked]>
Date: Wed, 21 Nov 2001 13:53:36 -0800 (PST)

> a default movement detection mechanism, such as AAA.

   AAA?!?

   AAA isn't a movement detection mechanism, nor should it be
   used as one. That's a *very* bell shaped view of the world.

	   Mike

---

From: "Jari T. Malinen" <[email-masked]>
Date: Wed, 21 Nov 2001 13:54:15 -0800

All,

> > 2. The L2 stuff !

To repeat a bit the design team discussion, I agree, as long as it is
well understood that a basic design principle calls for a solution to
work over multiple L2s. It can be considered an implementation detail
how L2 optimizations are done as long as it does not mean we require
some currently not common L2 features for the solution to work.

In summary:
- L2 independence can be considered a basic enough design principle
  for L3 protocols not worth mentioning in this spec
- L2 implementation issue: agreed, as long as it does not mean a need
  to implement something specific on L2 for the L3 design to work at all
  (possible L2 additions used by the design can be optimizations but
  they MUST NOT be mandatory).

BR,

-Jari

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 21 Nov 2001 14:28:40 -0800

Mike,

> Cedric Westphal writes:

something that conveniently got omitted to make a point. Please do
not use the so-called 'projector' technique, where you point at one
detail to cast doubts on the validity of the whole. The professional
attitude, as well as the common etiquette on IETF mailing lists, is to
at least mention (with a *snip* or equivalent) that you cut something
from the exchange.

>    used as one. That's a *very* bell shaped view of the world.

You can blame me as much as you care, the mention of AAA comes from the
original 3.5.4 Movement detection paragraph in the draft. By the way, Mike,
if you have some better wording to offer, please do so.

Cedric.

---

From: Michael Thomas <[email-masked]>
Date: Wed, 21 Nov 2001 14:38:17 -0800 (PST)

I'm making no point whatsoever on the whole draft,
nor can I see how my comment would be taken as
such. Nor have I ascribed blame on you or anybody
else, as I have no idea who wrote the paragraph
that was quoted. I'm simply pointing out that AAA
seems like a very weird example of what
could/should be used as a movement detection
mechanism. As for better wording, I'd suggest that
any mention of AAA in that capacity should just be
deleted from the text of the requirements.

	     Mike

---

From: "Jari T. Malinen" <[email-masked]>
Date: Wed, 21 Nov 2001 14:59:04 -0800

Mike,

I agree with you, AAA is not a movement detection
mechanism. Instead of "such as AAA" one could
say "such as one provided by protocols indicating
network capabilities. Such protocols could include
Neighbor Discovery, Candidate Access Router protocol,
or AAA".

Or maybe you can come up with some suitable
examples since there are opinions LMM itself should
not contain movement detection?

BR,

-Jari

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 21 Nov 2001 17:01:56 -0600

Mike,
  Carl's draft  at
http://ietf.org/internet-drafts/draft-ietf-mobileip-lmm-requirements-00.txt
talks about DOMAIN movement, in this context AAA makes sense I think.

Regards,

--
Behcet

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 21 Nov 2001 15:04:48 -0800

Mike,

nor do I say you are making a point on the whole draft.
By mentioning the _whole_ draft, you are making a general
comment out of a particular comment. If you tweak the
premisse of a particular point into a general point, of course
the conclusions won't hold.

> such.

See, how could it be taken as such, as no one said it would?

> Nor have I ascribed blame on you or anybody
> that was quoted.

Authorship of said paragraph (mine) was in the line _before_ said paragraph.
Please add a disclaimer in your comments in the future saying that
your comment focuses on what you kept, and what you cut out you
disregarded. People in this list might assume you comment on the whole email,
and might not understand where you are coming from.

Cedric.

> I'm simply pointing out that AAA

---

From: Michael Thomas <[email-masked]>
Date: Wed, 21 Nov 2001 15:24:28 -0800 (PST)

> not contain movement detection?

   I've always assumed that how the mobile node
   decides it needs to move, cross realm or not,
   was strictly out of scope of LMM. Does it make
   any difference from the requirements standpoint
   whether the movement detection was the result of
   a hint from AAA, or an instinct to fly south for
   the winter?

   :-)

		Mike

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 21 Nov 2001 15:36:07 -0800

Mike,

Michael Thomas wrote:

>    was strictly out of scope of LMM.

This thread, as illustrated by the subject line, is about movement
detection,
not movement decision. As a consequence...

> Does it make

> ....you are not asking a rhetorical question relevant to this thread.

...you are not asking a rhetorical question relevant to this thread.

Cedric.

---

From: "Jari T. Malinen" <[email-masked]>
Date: Wed, 21 Nov 2001 15:48:05 -0800

>    a hint from AAA, or an instinct to fly south for

The issue is rather what the LMM mobile node needs to do when
it detects it has e.g. arrived to an area supporting LMM
or exited from it as opposed to not doing that. Or crossing
domain boundaries vs. not. If there is any difference in these
in terms of operation, it's an issue.

-Jari

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 21 Nov 2001 16:01:08 -0800

For the benefit of the working group:

Those on  the LMM team (Theo, Jari, Erik Nordmark, Hesham,
James Kempf, myself) discussed a L2 related requirement. We
decided to not to include the requirement in the draft that I
posted (and submitted).

Since it has been brought up in a number of emails I feel the need to
list it below so that others on the alias can have context to some
of the email discussions.  Jari did a good job of summarizing it in his
recent
email (which I attached below as well).

3.4.8 Scalable to any link-layer

   A LMM mechanism MUST be fully functional for any link layer.
   This requirement doesn't disallow some L2 specific usage.
   The requirement is only saying that if an LMM solution used,
   for example, L2 MTU in order to perform packet sizing, the
   solution MUST continue to work with no L2 MTU usage.  Any
   LMM mechanism MUST be able to operate on any link layer
   suitable for general-purpose IP traffic.  Also, a LMM
   mechanism SHOULD be able to make use of or coexist with
   optimizations provided by link-layers.

In short, the consensus is to not have such a requirement in
the LMM requirement draft.

Carl  (Jari's email is below)

----- Original Message -----
From: "Jari T. Malinen" <[email-masked]>
To: <[email-masked]>
Cc: "Hesham Soliman (ERA)" <[email-masked]>; "Cedric
Westphal" <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 21, 2001 1:54 PM
Subject: Re: [mobile-ip] LMM for IPv6 requirements draft (new revision .01)

---

From: Michael Thomas <[email-masked]>
Date: Wed, 21 Nov 2001 16:11:40 -0800 (PST)

> in terms of operation, it's an issue.

   Is this really an issue of LMM, or is it tied up
   with the access control at the AR's? Ie, is
   there a need to separate out the AR domain from
   the LMM domain? Also: even if you did decouple
   them, is there a need for a separate next LMM
   discovery mechanism than that which you'd
   employ for AR discovery?
   
		Mike