Subject: Re: [mobile-ip] RFC3012 interpretation yet again

From: "Charles E. Perkins" <[email-masked]>
Date: Sun, 11 Nov 2001 15:32:31 -0800

Hello Mike,

[email-masked] wrote:

> Well, since you asked...  This is not a purely technical issue, but
> I think it would help a lot if RFC3012bis included a ladder diagram
> of a canonical call flow.  Right now each element's processing
> is discussed in isolation and I believe that an appendix showing the
> order in which events typically occur would help.

How's this:

        MN                  FA              Verification Infrastructure
         |                   |                        |
         |<-- Adv+Challenge--|                        |
         |    (if needed)    |                        |
         |                   |                        |
         |-- RReq+Challenge->|                        |
         |    + Auth.Ext.    |                        |
         |                   |--- RReq + Challenge -->|
         |                   |      + Auth.Ext        |
         |                   |                        |
         |                   |<-- RRep + Auth.Ext.----|
         |                   |                        |
         |<-- RRep+Auth.Ext--|                        |
         |     + Challenge   |                        |
         |                   |                        |

... along with an explanatory paragraph...

Regards,
Charlie P.

---

From: [email-masked]
Date: Tue, 13 Nov 2001 08:01:47 -0600

Understood, though the RRQ and RRP imply Mobile IP.

Mike

Pat Calhoun <[email-masked]>@sunroof.eng.sun.com on 11/12/2001
06:46:44 PM

Please respond to [email-masked]

Sent by:  [email-masked]

To:   [email-masked]
cc:   "Charles E. Perkins" <[email-masked]>
Subject:  Re: [mobile-ip] RFC3012 interpretation yet again

> - Wouldn't the message to/from the verification infrastructure
> be something other than RRQ and RRP?

It could be anything. This draft tries to introduce the verification
infrastructure to satisfy review comments, but we also don't want to
copy text from another spec that defines the actual protocol.

PatC