Subject: RE: [mobile-ip] LMM for IPv6 requirements-Movement detection

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Nov 2001 15:14:37 +0100

Theo, 

  > Perhaps I did not explain clearly. 
  > 
  > In your schematic you assume that the LMM is in fact an AR! 
  > This is fine
  > but not what Mike had in mind. Mike talked about _not_ 
  > co-locating the

=> I didn't think it looked like an AR at all. Here it 
is again with more explanation:

                    CN
                     |
                     |     Domain A
                    AR
                     |
                    some routers (Backbone)

                     |
                     |      Domain B
                     LMM 
                      |  ----------+
                      |            |
                     AR1           |
                      |            AR2
                     MN

As you can see the LMM is clearly separated from the 2
ARs. It is also 'on the way' to either AR. So any
packet addressed to the MN would traverse it 
anyway. _In_this_topology_ .

If I was building a network I would want to make sure
that the LMM agent is on the 'aggregate router' level
rather than the AR. 

  > LMM with an AR. However, an LMM has to be behind a link if not an AR
  > itself. Thus, the LMM in such case MUST be behind some AR. 
  > The schematic
  > becomes:
  > 
  > 
  > 
  >             CN
  >              |
  >              |
  >              AR
  >               |
  >               .
  >               .
  >               .
  >             Internet
  >               .
  >               .      1
  >               |      ->
  >    (domain)   ARb --------           <-------- decoupling 
  > of AR and LMM
  > such that LMM is behind
  >       |       |    <-    | | 2                 that AR (since not
  > co-located)            
  >       |       |     3   ^| v                   Routing suboptimality
  > goes for steps 1,2 and 3
  >       |       .          |                     as packets have to go
  > through that path
  >       v       .         LMM                    since they 
  > are forwarded
  > by the LMM to the MN !
  >               .
  >               |
  >               AR
  >               |
  >               |   
  >               MN 
  > 
  > 
  > Now take ARb and augment it to be ARb/LMM in one single 
  > box. At the same
  > time get rid of the individual LMM box; thus you get rid of 1,2,3.
  > Wouldn't that reason for colocation offering optimality in 
  > the routing
  > of packets sent by the LMM to the MN?

=> You've assumed a certain architecture and based on
that assumption you're showing that placing the LMM
agent outside the AR does not work ! You're assuming 
that traffic will arive at ARb first. 
So the point is, suboptimality will depend on:

- Where the CN is ? inside the same domain or a different one ?
- Network topology
- Placement of the LMM in the network. 

None of the above implies that one way is ALWAYS better. 
I can show you several pictures with two ARs that
are topologically 'far' as I said in the previous mail. 

Hesham

  > 
  > 
  > Theo 
  > UCL/Mobile Systems Group
  > 
  > 
  > "Hesham Soliman (ERA)" wrote:
  > > 
  > >   >
  > >   > I believe that if you place the LMM agent anywhere else
  > >   > than the AR you
  > >   > will eventually have suboptimal routing since it will 
  > need to go to
  > >   >
  > >   >   that AR ------> LMM -----> that AR ------> MN
  > >   >
  > > 
  > > => I don't really get that logic, it greatly depends on
  > > where the CN is and the network topology.
  > > 
  > > E.g :
  > > 
  > >                     CN
  > >                      |
  > >                      |
  > >                     AR
  > >                      |
  > >                     some routers
  > > 
  > >                      |
  > >                      |
  > >                      LMM
  > >                       |
  > >                       |
  > >                      AR
  > >                       |
  > >                      MN
  > > 
  > > Where is the suboptimality here ? The packets
  > > will traverse the LMM router anyway to get
  > > to the AR.
  > > 
  > > You can play around with the topology to get
  > > one that will add one hop or maybe two, to the
  > > "optimal route" but I don't think that is a major
  > > concern. You can also add 10 hops to the optimal
  > > route but that would be strange network design
  > > for someone trying to use an LMM agent.
  > > 
  > > Similarily I can make the LMM in the AR look like
  > > a very suboptimal solution if the two ARs
  > > (between which the MN is moving) are not physically
  > > connected and are topologically 'far'.
  > > 
  > > So it's not as simple as saying that the LMM
  > > in the AR is more optimal. Operators will have
  > > to be careful how they place these agents. This
  > > will largely depend on their type of access network,
  > > mobility patterns ...etc.
  > > 
  > > Hesham
  >

---

From: Theo Pagtzis <[email-masked]>
Date: Wed, 28 Nov 2001 17:25:47 +0000

Hi Hesham,

another misinterpretation largely due to misuse of the term on my part.
What I mean is that you assume the LMM to be co-located with a router,
in this case seems to be more accurate to say Access Network Router
(ANR).

What I was trying to say is that Mike suggested not co-locating the LMM
with a router but behind one if I understood correctly. I felt that
looked sub-optimal. That's all.

Other than that we are in agreement.

Cheers

Theo
UCL/Mobile Systems

 but on my side this one though..When I

---

From: "James Kempf" <[email-masked]>
Date: Wed, 28 Nov 2001 12:37:49 -0800

Hesham,

The diagram Theo originally sent had the border router to the Internet
marked as the second AR vertically,
you seemed to have combined it here with the LMM agent in your
diagram below. The problem is that if you locate the LMM agent anywhere
in the
domain except at the border router or the access router, you may end up
getting an additional dog
leg between the LMM agent and the other router. Here is an example
(if I can get the ASCII text to work right);

                         CN
                           |
                           |
                          BR

               { The Internet }

                        BR
                           \
                            \
                             \
                             LMM
                           /
                         /
                       /
                    AR
                      |
                    MN

If the number of hops between the AR, LMM agent, and BR is low, this
might not be such a problem,
but it is adding a "triangle route" which is what route optimization was
originally designed to eliminate.
The triangle route in this case is much smaller than without LMM because
it does not extend over the Internet,
but it is still there.

If you put the LMM agent at a border router, as you've done below, or an
access router, you still end up with
occasions when the  leg to the MN gets long, but there is only one leg,
and you can optimize by having the MN
switch LMM agents when the leg gets too long. This minimizes the
triangle route.

 If the LMM agent is at the AR, the dog leg can be kept very small,
which is the point I think Theo was trying to make. But you can also put
the LMM agent at the BR, and have multiple BRs, which the MN can switch
between if the dog leg gets too
long. In general, I think the dog leg will be longer if the LMM agent is
at the BR, but it is still easier optimizing than if the
LMM agent is somewhere inside the domain.

But I think this is mostly a matter of network engineering and not
really a requirements issue. The requirements already state that the LMM
agent must be placable in order to minimize triangle routing.

        jak

---

From: Theo Pagtzis <[email-masked]>
Date: Wed, 28 Nov 2001 22:21:32 +0000

correct..