Subject: Re: [mobile-ip] LMM for IPv6 requirements-Movement detection

From: "John V. Duran" <[email-masked]>
Date: Wed, 21 Nov 2001 16:38:40 -0700

I will be out of the office until November 28th.  Please contact the HSC
Helpdesk at 272-1694 or [email-masked] for any helpdesk related
issues.

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 29 Nov 2001 14:30:29 +0100

James,

  > The diagram Theo originally sent had the border router to 
  > the Internet
  > marked as the second AR vertically,
  > you seemed to have combined it here with the LMM agent in your
  > diagram below. 

=> Not intentionally, but it doesn't make a difference, 
I can use the same arguments for your diagram below.

The problem is that if you locate the LMM 
  > agent anywhere
  > in the
  > domain except at the border router or the access router, 
  > you may end up
  > getting an additional dog
  > leg between the LMM agent and the other router. Here is an example
  > (if I can get the ASCII text to work right);
  > 
  >                          CN
  >                            |
  >                            |
  >                           BR
  > 
  >                { The Internet }
  > 
  >                         BR
  >                            \
  >                             \
  >                              \
  >                              LMM
  >                            /
  >                          /
  >                        /
  >                     AR
  >                       |
  >                     MN
  > 
  > If the number of hops between the AR, LMM agent, and BR is low, this
  > might not be such a problem,
  > but it is adding a "triangle route" which is what route 
  > optimization was
  > originally designed to eliminate.
  > The triangle route in this case is much smaller than 
  > without LMM because
  > it does not extend over the Internet,
  > but it is still there.
  > 
  > If you put the LMM agent at a border router, as you've done 
  > below, or an
  > access router, you still end up with
  > occasions when the  leg to the MN gets long, but there is 
  > only one leg,
  > and you can optimize by having the MN
  > switch LMM agents when the leg gets too long. This minimizes the
  > triangle route.

=> I think you've missed my point in my reply to Theo.
The suboptimality of routing depends on:
- CN location (same domain or not )
- Network topology, combined with LMM agent placement. 

In you diagram above, there is no suboptimality
between the CN and MN. 
If I put the CN on the same subnet as the MN
there will be a few more hops, _if_the_MN
updates it with the LMM location. 

All these suboptimalities can take place regardless
of whethere the LMM is in the AR or not. 
Just because the MN is moving between 2 ARs, it 
doesn't mean that those ARs are one hop away (topologically)
from each other. I don't know why people assume that. 

  > 
  >  If the LMM agent is at the AR, the dog leg can be kept very small,
  > which is the point I think Theo was trying to make. But you 
  > can also put
  > the LMM agent at the BR, and have multiple BRs, which the 
  > MN can switch
  > between if the dog leg gets too
  > long. In general, I think the dog leg will be longer if the 
  > LMM agent is
  > at the BR, but it is still easier optimizing than if the
  > LMM agent is somewhere inside the domain.

=> OK let me illustrate again:

                                 CN

                                   Internet
                                 | 
                                BR
                                 |
                               Router 1
                                 |
                       ----------+---------+
                      AR1                  AR2
The MN is moving from AR1 to AR2.
                      
Having the LMM in Router1 makes a more optimal
route than if it were in AR1, in_this_case. In other cases it may not be so.
E.g. If we move the CN, change the topology, change the
location of the LMM agent. 

  > But I think this is mostly a matter of network engineering and not
  > really a requirements issue. The requirements already state 
  > that the LMM
  > agent must be placable in order to minimize triangle routing.
  > 

=> Exactly. Agreed 100 %.