Subject: Re: [mobile-ip] rfc3012 interpretation question

From: "Charles E. Perkins" <[email-masked]>
Date: Sat, 10 Nov 2001 13:01:40 -0800

> The question is - if the challenge has less than 237 bytes - should the high
> order byte which was already used in the MD5 calculation  be included again as
> part of the  "least-order 237 bytes from Challenge"?

After all the discussion, I think it is clear that the answer should
be yes.  I have included the following sentence in the revised draft:

   If the challenge has fewer than 238 bytes, this algorithm includes
   the high-order byte in the computation twice.

Regards,
Charlie P.

---

From: "Lipford, Mark" <[email-masked]>
Date: Mon, 12 Nov 2001 10:27:26 -0600

Charlie,

As far as this section is concerned I believe that sentence does clarify the
requirement.

Thanks

		-----Original Message-----
		From:	Charles E. Perkins [mailto:[email-masked]]
		Sent:	Saturday, November 10, 2001 3:02 PM
		To:	Nish Abrol
		Cc:	[email-masked]; [email-masked]
		Subject:	Re: [mobile-ip] rfc3012 interpretation
question

		> part of the  "least-order 237 bytes from Challenge"?

		After all the discussion, I think it is clear that the
answer should
		be yes.  I have included the following sentence in the
revised draft:

		   If the challenge has fewer than 238 bytes, this algorithm
includes
		   the high-order byte in the computation twice.

		Regards,
		Charlie P.