Subject: RE: [mobile-ip] draft 15

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 22 Nov 2001 17:12:48 +0100

>   >registered _with_ the H-bit set.
  >   >What would be a sensible reaction?
  >   >1) Stop intercepting packets and just work as a usual CN
  >   >2) Ignore the missing H-bit in the BU
  >   >3) ?
  > 
  >    => Why don't we go for 2) ? 
  >    The effect would be that the HA will continue to intercept
  >    packets and if corresponding with the MN, the applications
  >    will still work. 
  > 
  > => to send back an error won't flush the binding cache entry.
  > 
  >    The issue here is how to avoid the tunnel interface. 
  >    
  > => it seems the MN has to cleanly delete its home registration first
  > (i.e. 1) is hard to implement (according to HA implementers here)
  > and this MN behavior is not natural: something is wrong and this
  > has to be signaled back to the MN).

=> I thought the assumption was that the MN has 
a TCP connection ...etc with the HA. 
The MN will either need to remember that the CN
is also the HA and not send a BU (and accept 
the tunnelled packets). Or somehow the HA
would figure out a way of sending packets 
with a routing header (if that still exists 
after SLC !) for traffic that was initiated at 
the HA. 

Have I missed your point ?

Hesham

---

From: Francis Dupont <[email-masked]>
Date: Thu, 22 Nov 2001 17:43:10 +0100

=> at least I've missed yours because:
 - the HA has to send all packets from him with the HA address as source
   with a routing header (this is the HA as CN stuff).
 - the HA has to tunnel other packets, forwarded and from him with
   another addresses (a side effect of the binding cache per address
   requirement).
The last case is arguable but not others (HA is a CN, a router must not
insert routing headers in packets forwarded though it).

Regards

[email-masked]

---

From: "Peter Grimstrup (TED)" <[email-masked]>
Date: Fri, 23 Nov 2001 08:52:07 +0100

Comments inline

/Peter

> a TCP connection ...etc with the HA.

Maybe you're right, but as a side remark, when we consider how much
used ping is as the first testing/probing tool, I could imagine ping's
with or without BU's to be used also in the mobile world. In this case
an understandable reaction from the HA is the best.
... I know, this is not real traffic...