Subject: Assumption not made! Re: [mobile-ip] I-D ACTION:draft-aura-mipv6-bu-attacks-00.txt

From: Charlie Perkins <[email-masked]>
Date: Mon, 10 Dec 2001 14:20:01 -0800

Hello folks,

While reading the abovementioned document, I came across the
following passage:

   The assumption in Mobile IPv6, as in many other systems, seems to
   have been that generic security mechanism such as IPSec, IKE, and a
   public-key infrastructure (PKI) will eventually solve all
   authentication issues.

But as co-author of the specification, I can assure you that no
such assumption was ever made.  In fact, the best way to express
it, is that _no_ assumption about security infrastructure was made.
I think this is quite appropriate, and is still a viable perspective.
For one thing, since we didn't know what security infrastructure
to use, it makes a lot of sense to me to avoid making assumptions
about it.  Any assumptions that we might have made would directly
have had the effect of excluding some possible solutions.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 10 Dec 2001 14:25:53 -0800

Hello again folks,

Isn't it true that much of this document deals with reasons
why it's bad to accept unauthenticated Binding Updates?

I don't see exactly why we have to keep solving that
same problem, since as I have noted quite a few times
we have already solved it by mandating authentication in
every single revision of Mobile IPv6.  I'm reminded that
one can prove any theorem if one starts with a false
assumption.  But the goal should not be to refute every
such theorem -- it's better to avoid making false assumptions
in the first place...

I'll try to take a closer look at the threats that do not involve
failure to authenticate Binding Updates.

Regards,
Charlie P.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 11 Dec 2001 05:20:02 +0200

> every single revision of Mobile IPv6.

Charlie,

We certainly didn't mean to imply anything about past
versions of Mobile IPv6. Even if we are now putting
infrastructureless authentication (used to be called weak
authentication) to the protocol we realize well that this
isn't the first time someone's come up with the idea that
perhaps the BUs should be protected somehow.

However, we are trying to design the infrastructureless
authentication mechanisms and in doing so we *need* to
understand what the problems are, what kinds of attacks
are possible. Draft-aura-mipv6-bu-attacks-00.txt is an
attempt at that. It does tell you about the dangers of
unauthenticated binding updates. But it also tells you
about some perhaps not so obvious dangers, such as what
could happen to third parties, or what could happen to
an authentication protocol if it didn't take in account
denial of service issues. It boils down to understanding
what "authentication" means for MIPv6.

Please don't take any described problems as claims that
this is the first time they are being considered. This
isn't implied.

I'm looking forward to your comments on e.g. whether
you think all relevant authentication DoS dangers are
listed, whether we have listed all "tools" we have at
hand for infrastructureless authentication, and so on.
We'd very much appreciate feedback on those issues.

Jari