Subject: Re: [mobile-ip] 0.0.0.0 src address

From: Peter Lei <[email-masked]>
Date: Fri, 07 Dec 2001 19:16:03 -0600

trying again... seems my first one went to /dev/null...

"Alper E. YEGIN" wrote:
> 
> Matt,
> 
> > > > > For example, what if any MN configures itself with a
> > > temporary address
> > > > > to send the reg-req with home-addr=0, to get it's
> > > > > newly-assigned homeaddr?
> > > > >
> > > > > >    -  If the mobile node does not have a home address,
> > > the IP source
> > > > >        address MUST be 0.0.0.0.
> > > > >
> > > >
> > > > I also question why this is a MUST.  It is entirely
> > > possible that the MN's
> > > > interface over which it is going to send the RREQ has an IP address
> > > > (established via DHCP), while the mobile does not yet have
> > > a MIP home
> > > > address.  In this case, shouldn't it be able to send the
> > > RREQ with the
> > > > interface's address as the IP source address, but with a
> > > zero home address
> > > > in the RREQ??
> > >
> > > You cannot make this assumption. This works only if we are using
> > > co-located care-of address. In case of FA-located care-of
> > > address, mobile node has only home address.
> >
> > I was not making the assumption that this was always the case.  I was
> merely
> > asking: when this is the case, shouldn't the mobile be able to set the
> 
> oh, ok. I thought you were suggesting this as a solution.
> 
> > source IP address on its RREQ equal to the interface's address over which
> > the RREQ is going out??
> 
> that should be ok.
> 
> > Currently this is not allowed by the MIP draft, as
> > the mobile MUST set the source address of its RREQs to 0.0.0.0 if it has
> no
> > home address.
> 
> I don't know why it has to be like that. I cannot think of any reason.
> 
> I think the mobile node should be able to send the registration request
> with the care-of address as the source address. After all, the reg. req. can
> carry home address in a separate field.
> 
> In the case of co-located care-of address and dynamic home address
> allocation, how can the mobile node send the registration request with
> an unspecified source address (and receive a response)?
> 
> I think this is an important problem.

So, wouldn't this solve this issue in 3.6.1.1 in 2002bis-08 (Note, this
merely "moves" the added requirement in -08):

    -  When registering on a foreign network with a co-located care-of
       address, the IP source address MUST be the care-of address.

    -  In all other circumstances, the IP source address MUST be the
       mobile node's home address.  If the mobile node does not have a
       home address, the IP source address MUST be 0.0.0.0.

Was this not the original intent of adding the 0.0.0.0 "homeless" text
in the first place; i.e. clarifying behavior for the homeless MN
registering through a FA, yet still allowing the homeless MN using
a colocated COA.

--peter

[rest snipped]

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Sat, 8 Dec 2001 20:25:47 -0800

Peter,

>        home address, the IP source address MUST be 0.0.0.0.

Yes, this should solve the problem.

> registering through a FA, yet still allowing the homeless MN using

Maybe. Like Siva's interpretation. Probably (?) after a careful reading and
little bit of thinking, implementor would do the right thing. But I still
think the draft could benefit a clearer text, like yours.

alper