Subject: [mobile-ip] IPv4 Fast Handover Support for 802.11

From: "James Kempf" <[email-masked]>
Date: Sun, 2 Dec 2001 15:56:32 -0800

Folks,

As some of you may have noticed,
draft-ietf-mobileip-lowlatency-handoffs-ipv4.txt does not support fast
handoff for the current 802.11 MAC. While the 802.11 spec is always
subject to change, it may take awhile and the IPv4 fast handoff work is
supposted to be immediately deployable. We've done a short proposal for
how to support fast handoff for 802.11 as it currently exists, it's at
http://geocities.com/kempf42/draft-kempf-mobileip-postmit-handover-00.tx
t, it fits into the existing
low latency framework fairly smoothly. Sorry we couldn't get this in on
time, but we just figured it out in the last couple days. This proposal
also has some other uses, re the low latency draft, and it is just to
get the conversation started about how to fix low latency for 802.11
(that is, we don't necessary expect the WG to accept it as is, but we do
want to get the problem solved).

            jak

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Tue, 4 Dec 2001 14:22:25 +0100

It is an implementation issue and the document Ajoy tried to send out
explained how Windows NDIS can provide these triggers.

In 802.11 the MN can scan for beacons and these could contain the
corresponding FA identifiers (IP/MAC) in the SSID field. Signal
strengths and error rates can also be provided. So 802.11 can supply
trigger information to the MN's upper layers.

The point I was trying to make is that low latency already supports
802.11 and no change needs to be made to that spec to support it.
I was not saying that we should add anything.

/Karim

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Tue, 4 Dec 2001 10:11:38 -0600

Hello James,
I sent you the paper in the separate email. Due to oversize, 
the email with attachment did not go though the list. 
BTW, if any body needs to look at the attachment I can send
personal copy to them.
regards,
ajoy

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Tuesday, December 04, 2001 5:16 AM
To: [email-masked]; Singh Ajoy-ASINGH1
Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11

Hi Ajoy,

Well, perhaps I am wrong then and it would supplying a pre-Layer 2
trigger is simply an implementation issue. I think the
draft still has some value for Postreg, as Karim mentioned.

BTW, the paper you mentioned wasn't attached.

            jak

----- Original Message -----
From: "Singh Ajoy-ASINGH1" <[email-masked]>
To: "Singh Ajoy-ASINGH1" <[email-masked]>;
<[email-masked]>
Sent: Monday, December 03, 2001 8:49 AM
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

> Here I am talking about MN trigger for pre-registration.
>
> -----Original Message-----
> From: Singh Ajoy-ASINGH1
> Sent: Monday, December 03, 2001 10:44 AM
> To: [email-masked]'
> Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11
>
>
> Hello James,
> I am  not sure if I completely agree with this draft. I am
> attaching some paper from Microsoft which is not
> confidential. Based upon the work defined in
> the document, I do not sure why it is not possible to
> get trigger in case of 802.11. I believe we do not
> really need to define anything special for
> 802.11. I think getting L2 tigger for 802.11 looks like
> some implementation issues not standard issue. Any
> comments ?
> regards,
> ajoy
>
>
>
> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Sunday, December 02, 2001 5:57 PM
> To: [email-masked]
> Subject: [mobile-ip] IPv4 Fast Handover Support for 802.11
>
>
> Folks,
>

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Tue, 4 Dec 2001 12:16:17 -0600

Sharif,
Low latency  handoff will work on all the technologies you have 
mentioned. Just they have to provide appropriate triggers. 
regards,
ajoy 

-----Original Message-----
From: Shahrier, Sharif M. [mailto:[email-masked]]
Sent: Tuesday, December 04, 2001 11:14 AM
To: [email-masked]
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

802.11 is just one of the technologies that the low latency handover
protocol should support, but what about HYPERLAN, GPRS
and other technologies?

-Sharif.

 -----Original Message-----
From: 	James Kempf [mailto:[email-masked]] 
Sent:	Sunday, December 02, 2001 6:57 PM
To:	[email-masked]
Subject:	[mobile-ip] IPv4 Fast Handover Support for 802.11

Folks,

            jak