Subject: RE: [mobile-ip] question on L2 triggers draft

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Thu, 6 Dec 2001 14:57:24 -0600

Hi james (C/o Alper :) )

Ok, Understand. That sounds reasonable.

Thanks,
Madjid 

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Wednesday, December 05, 2001 11:41 PM
To: [email-masked]
Subject: Re: [mobile-ip] question on L2 triggers draft

Hi Madjid,

This is James Kempf, Alper is lending me his machine.

I think I wrote that. What I had in mind was the following situation.
Suppose I've got a subnet with 802.11 and Bluetooth access points. Having a
way that the access points could report movement to the access router would
faciliatate intra-subnet movement, for example, ARP cache flushing.

                    jak

----- Original Message -----
From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, December 05, 2001 2:08 PM
Subject: [mobile-ip] question on L2 triggers draft

> Alper,
>
> Nice informative draft. I have one question on the L2 handover section
(4.1)
> You say
>
> "When APs supporting multiple radio technologies on a single subnet,
> interoperability suffers if there is no L2-independent way of reporting
> on link movement."
>
> Would you care to elaborate?
> Say a WLAN AP-cellular AP case, do you mean the movement has to be
reported
> at L3 even if the two APs belong to the same subnet?
>
> Regards,
> Madjid
>
>
> -----Original Message-----
> From: Alper E. YEGIN [mailto:[email-masked]]
> Sent: Sunday, December 02, 2001 2:14 AM
> To: [email-masked]
> Subject: [mobile-ip] L2 triggers draft
>
>
> Folks,
>
> New version of L2 triggers draft is available:
>
> http://www.ietf.org/internet-drafts/draft-manyfolks-l2-mobilereq-01.txt
>
> Supporting Optimized Handover for IP Mobility -
> Requirements for Underlying Systems
>
>    Abstract
>
>    A critical factor in achieving good performance for IP mobility
>    protocols is the design of L2 handover. Handover occurs when a
>    Mobile Node moves from one radio Access Point to another. If the new
>    radio Access Point is associated with a new subnet, a change in
>    routing reachability may occur and require L3 protocol action on the
>    part of the Mobile Node or Access Routers. If no change in subnet
>    occurs, the Access Point may still need to take some action to
>    inform the Access Router about a change in on-link reachability. In
>    either case, prompt and timely information from L2 to the parties
>    involved about the sequencing of handover can help optimize handover
>    at the IP level. This draft discusses requirements for an L2
>    handover protocol or API to support optimized handover.
>
>
> Enjoy.
>
> alper
>

---

From: "Subrata Goswami" <[email-masked]>
Date: Thu, 6 Dec 2001 18:49:09 -0800

The ref [7](802.11 IAPP ) in the draft  handles all the roaming
issues in a L2 connected 802.11 environment.  Here roaming is transparent
to IP, IAPP takes care (or would take care) of that.

However , it seems  that MIP is forwarded as the solution in a situation
where a MN roams from  a 802.11 AP to another 802.11 AP situated in another
L2 network (e.g. there is no L2 connectivity between the AP's). Or the MN
might roam into a 3GPPx network. In both of these situations, only the MN
would be able tell that it has roamed out of this AP and roamed into that
AP.
Furthermore context parameters would have to be generic enough to handle
very
different types of networks. If the trigger is network initiated then the
FA's
in two potentially autonomous networks would have to exchange contexts,
which
might take longer than going through HA's.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Nakhjiri
Madjid-MNAKHJI1
Sent: Thursday, December 06, 2001 12:57 PM
To: [email-masked]'
Subject: RE: [mobile-ip] question on L2 triggers draft

Hi james (C/o Alper :) )

Thanks,
Madjid

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]]
Sent: Wednesday, December 05, 2001 11:41 PM
To: [email-masked]
Subject: Re: [mobile-ip] question on L2 triggers draft

Hi Madjid,

                    jak

----- Original Message -----
From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, December 05, 2001 2:08 PM
Subject: [mobile-ip] question on L2 triggers draft

(4.1)
reported

---

From: "James Kempf" <[email-masked]>
Date: Fri, 7 Dec 2001 14:12:20 -0800

> L2 network (e.g. there is no L2 connectivity between the AP's).

IAPP works cross subnet, if that is what you meant by "no L2
connectivity between AP's".

>Or the MN

I don't quite understand your point here. If the MN is capable of
handling 802.11 and 3GPP traffic,
then it will have two interfaces. The interfaces will have their own
respective L2 triggers as
will the access points in the network.

> might take longer than going through HA's.

I don't believe the intent is to propose L2 triggers for intertechnology
handover. The triggers are proposed for
handover between access points of the same technology.

            jak