Subject: RE: [mobile-ip] MN-to-MN communications in MIPv4

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Mon, 3 Dec 2001 19:14:49 +0100

I remember we discussed this a long time ago and it was left
open as an option for the implementation. IMO it could be a
useful optimisation. Not sure that the text you're referring to
relates to this however and can't find it mentioned. Scenarios
which were brought up where this shouldn't be done is if reverse
tunneling is used or where the HA does the accounting and all the
MN traffic must go through it.
Rgds
/Karim 

 > -----Original Message-----
 > From: Lewis Adam-CAL022 [mailto:[email-masked]]
 > Sent: den 3 december 2001 18:45
 > To: Mobile-IP working group
 > Subject: [mobile-ip] MN-to-MN communications in MIPv4
 > 
 > 
 > I thought I read the answer to this in RFC2002, but after 
 > going back to confirm it I was unable to find it again.  It 
 > is my assumption that two mobile nodes connected to the same 
 > FA should be able to by-pass normal IP routing (e.g. the 
 > need to tunnel through a HA) and route directly through the 
 > FA.  I make this assumption since it would be a logical 
 > optimization since the FA has all the necessary information 
 > needed to do so (e.g. home IP address, link layer address, 
 > etc.).  The only supporting text I was able to find on this 
 > in the RFC was on page 10.
 > 
 > "Similarly, a mobile node and a prospective or current 
 > foreign agent MUST be able to exchange datagrams without 
 > relying on standard IP routing mechanisms; that is, those 
 > mechanisms which make forwarding decisions based upon the 
 > network-prefix of the destination address in the IP header. 
 > This requirement can be satisfied if the foreign agent and 
 > the visiting mobile node have an interface on the same link. 
 > In this case, the mobile node and foreign agent simply 
 > bypass their normal IP routing mechanism when sending 
 > datagrams to each other, addressing the underlying 
 > link-layer packets to their respective link-layer addresses. 
 > Other placements of the foreign agent relative to the mobile 
 > node MAY also be possible using other mechanisms to exchange 
 > datagrams between these nodes, but such placements are 
 > beyond the scope of this document."
 > 
 > Adam
 > 
 > Adam C. Lewis 
 > Senior Engineer 
 > Advanced Technology & Strategy 
 > Global Technology Development Group 
 > Commercial, Government, and Industrial Solutions Sector 
 > 
 > 1301 E. Algonquin Road 
 > IL02/Rm. 509 
 > Schaumburg, IL 60196 
 > Email: [email-masked] 
 > Phone: (847) 576-8489 Fax: (847) 576-9018 
 > 
 >

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 3 Dec 2001 21:25:34 +0100 (CET)

> MN traffic must go through it.

So if it is optional for FAs to implement such a short-cut, how
can a HA that wants to see all packets sent to the MN (e.g. for
accounting reasons) turn off such optional behavior in the FA?

I would see to me that if the WG wants to allow both FA short-cuts
and MNs seeing all packets that there would have to be a way to
indicate the desire to enable or disable the shortcut in the registration
message(s).

The reverse tunneling case is more obvious - if the FA is doing reverse
tunneling it shouldn't do short cuts to or from that MN.
(The MN might have a private home address in which case it can't let those
packets "escape" the bidirectional tunnel.)

   Erik