Subject: RE: [mobile-ip] MN-to-MN communications in MIPv4

From: KASSI-LAHLOU Mohammed FTRD/DMI/CAE <[email-masked]>
Date: Wed, 5 Dec 2001 11:41:01 +0100

Hi,

I had understood that the routing process in the FA had already changed. The
FA delivers the packets with mobile node's home address as a destination
address to the MN on the foreign network; otherwise it will be a loop.

Or may be the FA delivers the packets to the mobile node on the foreign
network only if they were encapsulated and routes them towards the HA if
they weren't.

Maybe some clarifications are needed in the draft.

Kassi

-----Message d'origine-----
De : Erik Nordmark [mailto:[email-masked]]
Envoye : mardi 4 decembre 2001 14:42
A : Karim El-Malki (ERA)
Cc : 'Erik Nordmark'; [email-masked]'
Objet : RE: [mobile-ip] MN-to-MN communications in MIPv4

> What I should have written is that it wasn't clear what scenario would
> require all packets to go through the HA, while reverse tunneling was
> more obvious. The accounting can be done in the FA. Is there any other
> scenario where all traffic must go through the HA? If not then this
> shortcut may be done by the FA if bidirectional tunneling is not used.
> Otherwise I agree with what you're saying.

I don't know if folks have built or are building MIPv4 FAs that collect
accounting information. In such a case, from reading the RFCs, they
would presumably expect all packets to go through the HA.
Thus having FAs implement shortcuts might be an unpleasant surprise in
that case.

Having the accounting be done in the FA (without the ability for the HA
to verify it) is a quite different model. THus I'm not debating that a
system can't be built to work that way - I'm just pointing out that allowing
FA shortcuts is a change to the RFCs as I understand them.
 
  Erik

---

From: KASSI-LAHLOU Mohammed FTRD/DMI/CAE <[email-masked]>
Date: Wed, 5 Dec 2001 12:01:21 +0100

I think that the access points make the accounting and the information is
delivered to the accounting centre.

Kassi

-----Message d'origine-----
De : Karim El-Malki (ERA) [mailto:[email-masked]]
Envoyé : mercredi 5 décembre 2001 11:41
À : 'Erik Nordmark'
Cc : [email-masked]'
Objet : RE: [mobile-ip] MN-to-MN communications in MIPv4

I believe there are FAs which collect accounting data (e.g. CDMA2000 PDSNs).
Would it actually be a problem for accounting? I'm not an expert in
this but why should the HA want to do accounting only for one
direction of MN traffic and not both? If you want to do accounting in the
HA then you reverse tunnel. If there's no reverse tunneling then only
the FA can collect accounting information for traffic to/from the MN.
Do you think HA verification of accounting only for traffic towards
the MN is something people want to do?

 > FA shortcuts is a change to the RFCs as I understand them.

Do you mean RFC2002 or others? I'm not sure this is disallowed in 2002
but I may have misunderstood something. Also, as above, I don't think that
the ability for the HA to verify the FA's accounting only for one direction
of the traffic is useful.

/Karim

---

From: "Qiang Zhang" <[email-masked]>
Date: Wed, 5 Dec 2001 10:58:31 -0500

In addition, for those MNs that may operate at the colocated mode and
use optimized routing, the problem becomes more obvious. Though per the
RFC2977, a visiting network access entity needs to take the
responsibility to perform AAA record collecting and DHCP server was used
as a sample in this RFC... , it is still not clearly defined. 
Qiang

	-----Original Message----- 
	From: KASSI-LAHLOU Mohammed FTRD/DMI/CAE 
	Sent: Wed 12/5/2001 5:41 AM 
	To: [email-masked]'; Karim El-Malki (ERA) 
	Cc: 
	Subject: RE: [mobile-ip] MN-to-MN communications in MIPv4

	Hi,
	
	I had understood that the routing process in the FA had already
changed. The
	FA delivers the packets with mobile node's home address as a
destination
	address to the MN on the foreign network; otherwise it will be a
loop.
	
	Or may be the FA delivers the packets to the mobile node on the
foreign
	network only if they were encapsulated and routes them towards
the HA if
	they weren't.

	Kassi
	
	-----Message d'origine-----
	De : Erik Nordmark [mailto:[email-masked]]
	Envoye : mardi 4 decembre 2001 14:42
	A : Karim El-Malki (ERA)
	Cc : 'Erik Nordmark'; [email-masked]'
	Objet : RE: [mobile-ip] MN-to-MN communications in MIPv4

	> Otherwise I agree with what you're saying.
	
	I don't know if folks have built or are building MIPv4 FAs that
collect
	accounting information. In such a case, from reading the RFCs,
they
	would presumably expect all packets to go through the HA.
	Thus having FAs implement shortcuts might be an unpleasant
surprise in
	that case.
	
	Having the accounting be done in the FA (without the ability for
the HA
	to verify it) is a quite different model. THus I'm not debating
that a
	system can't be built to work that way - I'm just pointing out
that allowing
	FA shortcuts is a change to the RFCs as I understand them.
	
	  Erik

---

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Wed, 05 Dec 2001 18:05:59 +0100

> I think there is potential routing problem here. Suppose MN1 
 > and MN2 are
 > visitors on an FA (FA1).  Now suppose MN2 does FA handoff 
 > and moves to FA2.
 > FA1 will have a visiting entry for MN2 till the lifetime 
 > expiration. Now if
 > FA1 tries to by-pass traffic to MN2 through it's visiting 
 > interface, packets
 > won't reach MN2. This problem won't exist if HA send BU's to 
 > previous FA.
 > But, I don't think many people would implement Route 
 > Optimizations on HA.
 
The previous FA extension to the Registration message can be used
where the BU is sent from new FA to old FA. Not everyone will
implement this, but it should be made clear if and when this
shortcut can be done.

/Karim