Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11

From: "Alper E. YEGIN" <[email-masked]>
Date: Tue, 19 Mar 2002 19:00:07 -0800

Ajoy,

> Hello James,
> I am  not sure if I completely agree with this draft. I am 
> attaching some paper from Microsoft which is not 
> confidential. Based upon the work defined in 
> the document, I do not sure why it is not possible to 
> get trigger in case of 802.11. I believe we do not 
> really need to define anything special for 
> 802.11. I think getting L2 tigger for 802.11 looks like 
> some implementation issues not standard issue. Any 
> comments ? 

Yes, I agree. Getting L2 triggers on the mobile node side
for WLAN is an implementation issue. 

Getting L2 triggers on the AR/FA side requires a protocol,
IMO. Access point is what is aware of clients associating 
(link up) and disassociating (link down). Getting this information
from access point to the router behind it would require a transport.

> regards,
> ajoy 

alper

> 
> 
> 
> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Sunday, December 02, 2001 5:57 PM
> To: [email-masked]
> Subject: [mobile-ip] IPv4 Fast Handover Support for 802.11
> 
> 
> Folks,
> 
> As some of you may have noticed,
> draft-ietf-mobileip-lowlatency-handoffs-ipv4.txt does not support fast
> handoff for the current 802.11 MAC. While the 802.11 spec is always
> subject to change, it may take awhile and the IPv4 fast handoff work is
> supposted to be immediately deployable. We've done a short proposal for
> how to support fast handoff for 802.11 as it currently exists, it's at
> http://geocities.com/kempf42/draft-kempf-mobileip-postmit-handover-00.tx
> t, it fits into the existing
> low latency framework fairly smoothly. Sorry we couldn't get this in on
> time, but we just figured it out in the last couple days. This proposal
> also has some other uses, re the low latency draft, and it is just to
> get the conversation started about how to fix low latency for 802.11
> (that is, we don't necessary expect the WG to accept it as is, but we do
> want to get the problem solved).
> 
>             jak
>

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 22 Mar 2002 11:14:53 -0600

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Friday, March 22, 2002 9:35 AM
To: [email-masked]; Singh Ajoy-ASINGH1
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

  > Sent: Wednesday, March 20, 2002 4:50 AM
  > To: [email-masked]; Singh Ajoy-ASINGH1
  > Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > 
  > 
  > Gentlemen,
  > 
  > > => Agreed. So a network initiation in WLAN is
  > > currently not possible as far as I know.
  > > I read the paper that Ajoy sent and I think
  > > it's more thant enough for WLANs.
  > >
  > 
  > Not so fast.
  > 
  > There is a problem on the mobile side as well in that the 802.11
  > standard *protocol* doesn't provide any signal prior to handover, it
  > just reassociates. Now, it is possible, depending on the 
  > 802.11 card and
  > driver, to force handover to a particular access point, 
  > note power level
  > and indicate when handover is likely and where, etc., but 
  > this is not
  > the same as getting a definitive L2 trigger saying when handover is
  > going to occur and where the MN will go, and it is *most 
  > definitively*
  > not portable. Some NIC cards/drivers support it, others don't.

=> Sure, but we never assumed that 802.11 was connection-oriented.
The assumption was that this is an implementation issue.
The paper Ajoy referred to, shows that windows already
supports this.

Ajoy-> The paper seems to indicate that it is possible to support 
this in some WLAN driver. But frankly we have not been able to 
realize this in our lab setup. I would still think having IEEE to provide 
some standard mechanism to support L2 triggers will be really helpful. 

  > As an example of a problem that could occur, suppose the 
  > driver makes an
  > assumption, based on power levels, that the MN is going to handover
  > somewhere and the IP level starts performing prehandover 
  > care of address
  > change. The standard has no commitment that the handover 
  > will, in fact,
  > occur, and it could equally well be aborted and the MN 
  > could handover to
  > another access point.

=> The handover is decided by the MN. So if the MN decided
in the last minute (so to speak) to change AP, then 
maybe there will be no time for anticipation. But 
I think Handover failures are possible in any scenario, there
is not much we can do about this on the IP layer.

Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 14:46:13 +0100

=> This *is* why you need the API. L2 can simply 
send a trigger saying a handover is about 
to take place. No need to transfer power levels. 
The trigger will be sent based on the implementors'
assumptions of when the handover should take place. 

Hesham

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 27 Mar 2002 12:12:20 -0600

Hesham,
I think even in case of Mobile initiated trigger, 
providing L2 trigger information (Link UP and Link Down) 
at AR will definitely make the handover better. Probably 
this is what Alper is referring to. I think this should 
be doable by extending the existing IAPP protocol or defining
a new protocol. Am I missing anything ?
regards,
ajoy

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Wednesday, March 27, 2002 7:46 AM
To: [email-masked]
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

Alper, 

  > Also AP will have to tell this information to the Access Router.
  > This is where a "protocol" for L2 triggers is needed.
  > 

=> In this case the handover can be MN
initiated. A 'protocol' thaty transfers 
L2 triggers is really going down the path
of the L7 L2! Let's not go there

Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 19:16:39 +0100

> a new protocol. Am I missing anything ?

=> But I didn't think 802.11 allowed the AP to
know whether a MN has 'left' its coverage area.
So I always assume that link up or down
is only relevant to the MN itself. 
I see no reason to send this info to the AR. 
I get the feeling we're talking about different
things :) are we?

Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 19:43:46 +0100

> -> If I remember correctly, new AP does send IAPP(?) message 
  > to old AP after MN is re-associated with new AP. Can't 
  > we extend IAPP to inform AR about the Mobile node's
  > re-association with new AP ? Can some one comment
  > about this ? 

=> But this works within the same subnet. 
We're dealing with inter-subnet handovers. 
Of course one could argue that it can be used 
across subnets, but I'm not sure I agree with
that. 

Hesham

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 27 Mar 2002 14:19:38 -0600

James,
I like the idea of extending IAPP to provide 
L2 trigger to oAR and nAR. 
regards,
ajoy

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Wednesday, March 27, 2002 2:12 PM
To: [email-masked]
Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11

Ajoy,

You are right, it doesn't

What we would like to do is modify the 802.11 standard, perhaps via
IAPP, so that this information is made available to the AR.

        jak

----- Original Message -----
From: "Singh Ajoy-ASINGH1" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 27, 2002 10:33 AM
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

> But I didn't think 802.11 allowed the AP to
> Sent: Wednesday, March 27, 2002 12:17 PM

---

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Thu, 28 Mar 2002 14:54:10 -0600

Hesham,
I am not talking about pre-trigger here.
But I do not see any thing wrong in providing 
link up and link down trigger at AR after L2 handover.
regards,
ajoy
 
-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Thursday, March 28, 2002 6:27 AM
To: [email-masked]
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

Just a question, are you guys aware that
this trigger happens _after_ the handover?

I can't see how this helps fast handoffs.

Hesham

  > From: Singh Ajoy-ASINGH1 [mailto:[email-masked]]
  > Sent: Wednesday, March 27, 2002 9:20 PM
  > To: [email-masked]'