Subject: [mobile-ip] A question on QoS over Mobile IP

From: "Comp" <[email-masked]>
Date: Thu, 21 Mar 2002 22:26:56 +0800

Hi all,

I have a question on QoS over Mobile IP using RSVP. If a corresponding node has multiple flows to a mobile node and the flows have different QoS requirements, how can intermediate routers and mobility agents distinguish the flows? It seems intermediate routers and mobility agents classify packet flows based on the source address or home address.  But in this case, the source address or home address are same. I am confused. 

pengbin

---

From: Michael Thomas <[email-masked]>
Date: Thu, 21 Mar 2002 07:05:10 -0800 (PST)

> I have a question on QoS over Mobile IP using RSVP. If a corresponding =
> node has multiple flows to a mobile node and the flows have different =
>QoS requirements, how can intermediate routers and mobility agents =
>distinguish the flows? It seems intermediate routers and mobility agents =
>classify packet flows based on the source address or home address.  But =
>in this case, the source address or home address are same. I am =
> confused.=20

Pengbin,

I think you're confused, but it's perfectly
understandable because this is a pretty murky
subject :-) An RSVP router would definitely use
the CoA to classify packets, not the home address.
This is irrespective of whether this is a good or
bad thing for MIP: it's simply an artifact of RSVP
not having any notion of a home address option,
or, say, a prefix invariant flow selector. This
mainly leads to the necessesity of reestablishing
the reservation along the entire path to the CN
when you change CoA's.

That said, I don't really understand your issue
with multiple reservations. Normal RSVP handles
them just fine by setting up different flow
selectors bound to different tspecs. Clearly a
stationary node isn't ordinarily changing its
source address, so I guess I don't see what you're
finding problematic.

	 Mike

---

From: Wang Hui <[email-masked]>
Date: Thu, 21 Mar 2002 23:20:00 +0800 (CST)

I think the key issue of QoS over MIP, which is different from the
traditional IP network framework, is how to guarantee the QoS of a
specific flow when the mobile node roams among diffrent networks.

The QoS parameters have to be 'roam' around different networks due to the
mobile node's moving.

Any idea on this issue?

On Thu, 21 Mar 2002, Michael Thomas wrote:

>
> > I have a question on QoS over Mobile IP using RSVP. If a corresponding > > node has multiple flows to a mobile node and the flows have different > >QoS requirements, how can intermediate routers and mobility agents > >distinguish the flows? It seems intermediate routers and mobility agents > >classify packet flows based on the source address or home address.  But > >in this case, the source address or home address are same. I am > > confused. 
>
> Pengbin,
>

--
 Wang Hui
 Next Generation Internet Research Team,
 InfoNet Lab, USTC
 http://mail.ustc.edu.cn/~whui
 Tel: +86-551-3603634

---

From: Michael Thomas <[email-masked]>
Date: Thu, 21 Mar 2002 07:43:08 -0800 (PST)

> The QoS parameters have to be 'roam' around different networks due to the

   Well, I have some ideas about these issue, but there
   isn't anything that's standard. I wrote a draft a while
   back which is now expired going over many of the issues
   with MIP/RSVP interactions. It's still available at
 
   http://www.mtcc.com/standards/draft-thomas-seamoby-rsvp-analysis-00.txt

   Ultimately, I believe that the general intent was to
   resolve these issues in NSIS. A QoS requirements from
   mobile IP has also been written; Hemant Chasker was the
   editor.

		Mike