Subject: RE: [mobile-ip] Consensus to include recent piggybacking proposal ?

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 15 Mar 2002 21:11:19 +0100

Charlie,

  > > Karen Nielsen sent two emails to highlight
  > > the inability to piggyback some RR messages
  > > since they are placed in IPsec tunnels
  > > by the HA. You can generalise the same
  > > problem for Security Gateways, in those cases
  > > the MN might not be aware of security policies by
  > > intermediate routers (SGs).
  > 
  > This is not an issue with the current proposal,
  > as Vijay has pointed out.

=> As Vijay pointed out in his most recent email,
there could be issues with piggybacking 1a and 
2a. Karen can speak for herself, but reading the
last email, it said something like 'strongly 
stress ....that piggybaking 1a and 2a is not possible'.

Also the other point was SGWs which the MN is 
not aware of.

  > 
  > > Also the note was only relevant to IPsec and
  > > didn't address the QoS issues (e.g. when using
  > > Diffserv e2e or when having the Diffserv bits
  > > set by intermediate routers). These comments
  > > were explicitly made by David Oran and to some
  > > extent in my earlier emails.
  > 
  > I responded at length to those e-mails.  There is no
  > issue with respect to piggybacking and QoS,
  > _unless_ you are trying to have some sort of
  > "implicit" QoS without asking for it.  In any
  > other case, the QoS signalling would trivially
  > be able to handle any setup required for
  > deciding whether or not to use piggybacking.

=> First of all, no one is using e2e QoS signalling
today, please correct me if I'm wrong. 
Second, I might have missed on of your emails
but I'd appreciate a pointer on how 
Diffserv can be used here if there is a conflict
between the BU DSCPs and the payload's. 
Obviously Diffserv is not always used e2e and 
can be set by intermediate routers. 

Hesham

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 15 Mar 2002 13:56:50 -0800

> stress ....that piggybaking 1a and 2a is not possible'.

Hesham, 

I said either way is fine. That is *NOT* the issue here....

Vijay