Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 22 Mar 2002 16:35:28 +0100

> -----Original Message-----
  > From: James Kempf [mailto:[email-masked]]
  > Sent: Wednesday, March 20, 2002 4:50 AM
  > To: [email-masked]; Singh Ajoy-ASINGH1
  > Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > 
  > 
  > Gentlemen,
  > 
  > > => Agreed. So a network initiation in WLAN is
  > > currently not possible as far as I know.
  > > I read the paper that Ajoy sent and I think
  > > it's more thant enough for WLANs.
  > >
  > 
  > Not so fast.
  > 
  > There is a problem on the mobile side as well in that the 802.11
  > standard *protocol* doesn't provide any signal prior to handover, it
  > just reassociates. Now, it is possible, depending on the 
  > 802.11 card and
  > driver, to force handover to a particular access point, 
  > note power level
  > and indicate when handover is likely and where, etc., but 
  > this is not
  > the same as getting a definitive L2 trigger saying when handover is
  > going to occur and where the MN will go, and it is *most 
  > definitively*
  > not portable. Some NIC cards/drivers support it, others don't.

=> Sure, but we never assumed that 802.11 was connection-oriented.
The assumption was that this is an implementation issue.
The paper Ajoy referred to, shows that windows already
supports this.

  > As an example of a problem that could occur, suppose the 
  > driver makes an
  > assumption, based on power levels, that the MN is going to handover
  > somewhere and the IP level starts performing prehandover 
  > care of address
  > change. The standard has no commitment that the handover 
  > will, in fact,
  > occur, and it could equally well be aborted and the MN 
  > could handover to
  > another access point.

=> The handover is decided by the MN. So if the MN decided
in the last minute (so to speak) to change AP, then 
maybe there will be no time for anticipation. But 
I think Handover failures are possible in any scenario, there
is not much we can do about this on the IP layer.

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Fri, 22 Mar 2002 07:59:03 -0800

> is not much we can do about this on the IP layer.

Well, there is an issue in FMIPv6 about when to start forwarding packets
through the tunnel to the MN on the new link. If there is no signal on
the router at Link Down, then the tunnel must start when the F-BU is
received by the old access router. This results in termination of packet
delivery prior to the actual Layer 2 handover, and thus more lost
packets than if a Link Down trigger is available.

So I think having a Link Down trigger in 802.11 would be helpful for
this.

            jak

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Sat, 23 Mar 2002 16:37:05 -0800

> So I think having a Link Down trigger in 802.11 would be helpful for

Also AP will have to tell this information to the Access Router.
This is where a "protocol" for L2 triggers is needed.

alper