Subject: RE: [mobile-ip] Comments on Draft 16

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 19:38:32 +0100

BTW, I haven't been keeping up with
email so sorry if this was already discussed. 

Glenn Morrow brought up the issue (ipv6 list) of reverse 
tunnelling to the HA when the HoA is a Site-local
address. He suggested that tunnel must be authenticated.
I don't remember if this was in the draft already, but
I think it has to be added. The draft (15) said that 
the HA SHOULD tunnel Site-local (unicast and mcast)
packets to the CoA, so we can expect reverse tunnelling
to take place if the MN was communicating to another
node within the home site. 

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Sat, 30 Mar 2002 19:21:11 +0200

> node within the home site. 

I must have missed that e-mail, can someone send a copy to
me?

Anyway, there seems to be a few different issues:

1. Now that reverse tunneling is mandatory if there's no
    RO, part of the problem goes away.
2. When RO is used, a CoA is not site-local, so this isn't
    a problem either.
3. Authentication of the tunnel. Is there some difference
    in the security impacts whether or note link/site-local
    addresses or global addresses are used? If not, would
    the current text on MAY use authenticated tunnels be
    sufficient?

Jari