Subject: RE: [mobile-ip] Reverse tunneling issues

From: George Tsirtsis <[email-masked]>
Date: Thu, 28 Mar 2002 07:59:38 -0500

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Thursday, March 28, 2002 12:47 PM
To: [email-masked]'
Cc: [email-masked]'; [email-masked]'
Subject: RE: [mobile-ip] Reverse tunneling issues

George,

Haven't read the draft, but do the problems
disappear with triangular routing? 
Or would you still have the same problem for inbound
traffic?

GT> Inbound traffic is ok because of PFANE in MIPv4 and BU to oldAR in MIPv6
so, yes this is only when you do reverse tunneling. Actually the packet loss
is mostly at the HA side. For example if the HA has a reverse tunnel entry
from CoAx it can accept packets coming from that CoA. If now the MN moves,
it will send a new reverse registration for CoAy. If this reaches the HA
while packets from the oldCoAx are still on their way to the HA, these
packets will thrown on the floor (because the HA replaces old binding with
new one). And there is a bit more loss if the CoAy registration is
immediately followed by data packets because of difference between fast and
slow paths in the HA...

Another question, for MIPv4, is it more due to the fact
that reverse tunnelling is done by the FA? Because 
this doesn't exist in v6.

GT> As I said this is mostly a problem at the HA side...

Sorry I don't mean to hammer you with questions but
I'm just curious about the main reasons. 

GT> No problem...have a look at the draft and do not let the too many
options of how to solve the problem confuse you ...this is not complex...it
is just that it has to be dealt with.

George

  > -----Original Message-----
  > From: George Tsirtsis [mailto:[email-masked]]
  > Sent: Thursday, March 28, 2002 1:33 PM
  > To: [email-masked]'
  > Cc: [email-masked]'; [email-masked]'
  > Subject: [mobile-ip] Reverse tunneling issues
  > 
  > 
  > There is a general problem with reverse tunneling and 
  > packet loss, which
  > applies to MIPv4 and I think MIPv6 also. 
  > Draft-oneill-mip-revtun-ho-00.txt
  > exposed the problem that we faced while trying to implement reverse
  > tunneling in MIPv4.
  > 
  > It boils down to the fact that there is no "smooth" handoff 
  > equivalent when
  > the MN operates in reverse tunneling mode. The above draft 
  > talks about how
  > packets can be lost during handoff and lists a number of 
  > different ways of
  > solving the problem from simple configuration changes in 
  > the HA, to possible
  > extensions to Mobile IP signaling.
  > 
  > As I said, the above work has been done in the context of 
  > MIPv4 but similar
  > issues may apply to MIPv6, I am still trying to determine this...
  > 
  > Is the WG interested in working on this issue? Has anyone 
  > else faced or
  > thought of similar problems with packet loss in reverse tunneling?
  > 
  > I would appreciate your feedback/thoughts.
  > 
  > Ragards
  > George
  >

---

From: "James Kempf" <[email-masked]>
Date: Thu, 28 Mar 2002 09:34:56 -0800

George,

> new one).

I think with FMIPv6 you can defer the BU to the HA until the traffic
slows down.

Also, what about registering CoAy as an alt-CoA initially?

> And there is a bit more loss if the CoAy registration is

I'm not sure I understand this, maybe I need to read Alan's draft.

            jak

---

From: Jari Arkko <[email-masked]>
Date: Sat, 30 Mar 2002 16:08:48 +0200

> is just that it has to be dealt with.

Assuming something has to be done, is this something that has to go to
the base RFC, or something that can be done in an extension separately?

Jari