Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 28 Mar 2002 13:26:32 +0100

Just a question, are you guys aware that
this trigger happens _after_ the handover?

I can't see how this helps fast handoffs.

Hesham

  > -----Original Message-----
  > From: Singh Ajoy-ASINGH1 [mailto:[email-masked]]
  > Sent: Wednesday, March 27, 2002 9:20 PM
  > To: [email-masked]'
  > Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > 
  > 
  > James,
  > I like the idea of extending IAPP to provide 
  > L2 trigger to oAR and nAR. 
  > regards,
  > ajoy
  > 
  > -----Original Message-----
  > From: James Kempf [mailto:[email-masked]]
  > Sent: Wednesday, March 27, 2002 2:12 PM
  > To: [email-masked]
  > Subject: Re: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > 
  > 
  > Ajoy,
  > 
  > You are right, it doesn't
  > 
  > What we would like to do is modify the 802.11 standard, perhaps via
  > IAPP, so that this information is made available to the AR.
  > 
  >         jak
  > 
  > ----- Original Message -----
  > From: "Singh Ajoy-ASINGH1" <[email-masked]>
  > To: <[email-masked]>
  > Sent: Wednesday, March 27, 2002 10:33 AM
  > Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > 
  > 
  > > But I didn't think 802.11 allowed the AP to
  > > know whether a MN has 'left' its coverage area.
  > > So I always assume that link up or down
  > > is only relevant to the MN itself.
  > > I see no reason to send this info to the AR.
  > > I get the feeling we're talking about different
  > > things :) are we?
  > >
  > > -> If I remember correctly, new AP does send IAPP(?) message
  > > to old AP after MN is re-associated with new AP. Can't
  > > we extend IAPP to inform AR about the Mobile node's
  > > re-association with new AP ? Can some one comment
  > > about this ?
  > >
  > > regards,
  > > ajoy
  > >
  > >
  > > -----Original Message-----
  > > From: Hesham Soliman (ERA) [mailto:[email-masked]]
  > > Sent: Wednesday, March 27, 2002 12:17 PM
  > > To: [email-masked]
  > > Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11
  > >
  > >
  > >   > I think even in case of Mobile initiated trigger,
  > >   > providing L2 trigger information (Link UP and Link Down)
  > >   > at AR will definitely make the handover better. Probably
  > >   > this is what Alper is referring to. I think this should
  > >   > be doable by extending the existing IAPP protocol or defining
  > >   > a new protocol. Am I missing anything ?
  > >
  > > => But I didn't think 802.11 allowed the AP to
  > > know whether a MN has 'left' its coverage area.
  > > So I always assume that link up or down
  > > is only relevant to the MN itself.
  > > I see no reason to send this info to the AR.
  > > I get the feeling we're talking about different
  > > things :) are we?
  > >
  > > Hesham
  > >
  >

---

From: "James Kempf" <[email-masked]>
Date: Thu, 28 Mar 2002 09:07:24 -0800

Hesham,

The problem is more complex than just using IAPP as a trigger for fast
handover. The current working assumption of 802.11f is that fast
handovers for voice can be supported using reactive handover. That is,
the new access point does the IAPP transaction with the old after the MN
has moved rather than the other way around. We've measured L2 handover
times at from 90-200 ms with existing products, the IAPP transaction +
reactive MIP handover would need to be added to that, and they are
additionally proposing adding security to IAPP. Since total (L2 + L3)
handover time must be under 40 ms for voice (if you want to support it),
their current model of reactive handover is probably not going to get
anywhere near supporting voice.

In fact, I think it unlikely that 802.11 could really benefit in any
significant way from the fast handover work in the MIP group, given the
L2 performance of existing products and the current 802.11f efforts to
have the APs use IAPP posthandover, regardless of whether it is possible
to implement a nonstandard mobile-based trigger.

So, we are trying to convince the 802.11f WG to change from a reactive
to a proactive model. This would defined a standardized way for the AP
to issue a prehandover trigger to the router or MN to get a prehandover
trigger based on power levels, and for the AP to initiate the IAPP
transaction with the new AP prior to the MN moving. There is some work
going on at U. Maryland to measure 802.11 L2 handover times and
hopefully this will give the 802.11 group some data to base modifying
the basic L2 handover protocol if needed, and for vendors to get some
baseline to improve their products.

As to how likely they are to accept this model, I think it is probably
no more difficult than trying to persuade an IETF WG to accept
something, and they are certainly motivated since they want to support
voice. At the worst, we will be able to convince them they either need
to provide some standardized support for fast handover or give up the
goal of supporting voice.

            jak

From: "Hesham Soliman (ERA)" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 28, 2002 4:26 AM
Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 28 Mar 2002 10:23:16 -0800

The trigger (at least I am talking about) is
LINK DOWN. So it's OK if it happens
after the handover. As long as it happens
shortly (how short?) after the handover, it's fine.
This is not pre-trigger.

alper