Subject: [mobile-ip] about proxy DAD

From: Yukiyo Akisada <[email-masked]>
Date: Fri, 8 Mar 2002 04:28:35 +0900

Hi, all.

I have some quiestions about proxy DAD.

When the MN sends BU (S bit is 0),
should HA execute DAD for only MN's link-local home address?
or both of link-local and global addess?

And when the MN sends BU (S bit is 1),
should HA execute DAD for only global address?
or not?

ID-15 chapter 9.1 says that

    -  Finally, if the Duplicate Address Detection (D) bit is set in
       the Binding Update, this home agent MUST perform Duplicate
       Address Detection [27] on the mobile node's home link for the
       home address in this binding (before returning the Binding
       Acknowledgement).  The address used for Duplicate Address
       Detection SHOULD be the mobile node's link-local address.

and

   If the `S' bit field in the Binding Update is zero, The Home Agent
   creates or updates Binding Cache entries for each of possible
   several home addresses.  The set of such home addresses is formed
   by replacing the routing prefix for the given home address with
   all other routing prefixes that are supported by the home agent
   processing the Binding Update.  The Home Agent creates such a
   separate primary care-of address registration for each such home
   address.  Note that the same considerations for Duplicate Address
   Detection apply for each affected home address.

I'm little confusing about this.

Regards.

----
Yukiyo Akisada @ TAHI Project

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 14 Mar 2002 13:23:41 -0800

hi Yukiyo,

Whatever the 'S' bit is set to, the conservative approach 
for the home agent would be to perform DAD for both the 
home address and link local address of the mobile node.

But as RFC 2462 says, DAD can be skipped for the home
address if stateless configuration is used and the 
interface id is going to be the same for the home address 
and the link local address. And when you chose to skip, 
it can be skipped for both cases ('S' bit set to 0/1).

Vijay

---

From: Suvidh Mathur <[email-masked]>
Date: Thu, 14 Mar 2002 16:02:54 -0800 (PST)

Hi,

In continuation of Yukio's mail, I also have a small
doubt regarding the scenario when S bit is set to
zero. The draft says "The set of such home
> addresses is formed by replacing the routing prefix
for the given home address with all other routing
prefixes that are supported by the home agent  
processing the Binding Update".
What does supported by HA mean? Does it mean for all
prefixes advertised by the HA, or does it mean for all
addresses advertised on the home link (including
prefixes advertised by other routers on the home link)

regards,
suvidh

> > Yukiyo Akisada @ TAHI Project

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 14 Mar 2002 16:09:44 -0800

hi,

> prefixes advertised by other routers on the home link)

By all routers on the home link. The important part here 
is the 'home link'. It *does not* mean all the routers in 
the home domain/network/whatever.

Vijay

---

From: Yukiyo Akisada <[email-masked]>
Date: Fri, 15 Mar 2002 11:00:05 +0900

Hi, Vijay.

On Thu, 14 Mar 2002 13:23:41 -0800

> it can be skipped for both cases ('S' bit set to 0/1).

I can find this sentence in RFC2462.
Now, I'm clear.

Thanks.

----------------------------------------
Yokogawa Electric Corporation
----------------------------------------
Yukiyo AKisada @ TAHI Project
e-mail: [email-masked]
----------------------------------------

---

From: Yukiyo Akisada <[email-masked]>
Date: Fri, 15 Mar 2002 10:50:19 +0900

Hi, Vijay.

Thanks.