Subject: RE: [mobile-ip] IPv4 Fast Handover Support for 802.11

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 28 Mar 2002 09:42:26 +0100

> Even when this is a mobile-initiated/controlled
  > handover, the access point might know the
  > mobile is gone (through disassociation, etc.).

=> I don't think this can be done in a 
real-time-like manner. 

  > 
  > Passing this piece of information to the access
  > router is useful in many aspects. One is, as
  > mentioned in the FMIPv6 draft, this can be used
  > as a signal to oldAR to start forwarding traffic
  > through tunnel to newCoA. We can think
  > of this as "delayed binding update". F-BU
  > doesn't change the forwarding immediately.

=> Here we go again :). So do we need to go around
fixing every link layer to get FMIPv6 to work
over all L2s? 
I think it is much cleaner to have a generic L3
solution that works.

  > oldAR waits until it receives a positive confirmation
  > that MN is gone (when this feature is available).
  > (and so that you don't need to bi-cast ;)

=> Yeah, at what cost! I mean you want to 
change IEEE 802.11, or alternatively design
a new protocol to transfer non-existent L2
information between the AP and the AR, why?
to avoid bicasting!
What can I say, if you succeed in doing all
this then you've earnt it :)

Hesham

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Thu, 28 Mar 2002 10:30:49 -0800

> => I don't think this can be done in a 

Well, we have to look at numbers... (and definition
of "real-time" :)

> fixing every link layer to get FMIPv6 to work

No.. Whereever this is available, it shall be used.
If the network can detect disassociation (a L2 feature)
and can pass this information to AR (sometimes implementation,
sometimes a new protocol issue depending on whether L2 and
L3 are co-located or not), this can be used.

> I think it is much cleaner to have a generic L3

Depends on the "L3 solution". 

> this then you've earnt it :)

Bi-casting is used to compensate for uncertainity
on the network as to when the mobile leaves. 
If we can solve the root of the problem, we don't need
bi-casting. So, this is worth looking at.

alper