Subject: RE: [mobile-ip] Comments on Draft 16

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 27 Mar 2002 19:34:49 +0100

Jari,

  > By the way, the use of Alt-CoA is still an open issue. But 
  > perhaps you
  > could help me in understanding it. If Alt-CoA is used from a new CoA
  > to refer to the old-CoA, this kind of use seems fine. However, if it
  > is used from the old CoA to refer to some activity that 
  > should be done
  > towards a new, yet untested CoA then there may bombing 
  > attack concerns.
  > Which kind of use is the Alt-CoA designed for?

=> Does it matter? I mean if the COTI is always 
done on the intended CoA then wouldn't it always 
work? So if a BU is sent with an Alt-CoA then 
the COTI is done on the Alt-CoA. 

As for the use, well a multihomed MN may choose 
(for whatever reason) to send a BU from one interface
to forward traffic to another interface. 
I can't think of a good case right now (apart from
HMIPv6 :) ). 

Hesham

---

From: Jari Arkko <[email-masked]>
Date: Wed, 27 Mar 2002 22:04:24 +0200

> the COTI is done on the Alt-CoA. 

Ah, if this is done then it does indeed work.

(But see also below.)

> I can't think of a good case right now (apart from

So, in the multihomed case you'd still have to send
the COT/COTI from the real interface, even if the BU
could be sent from elsewhere. Ok for everybody?

Jari

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 28 Mar 2002 11:46:21 +0100 (CET)

> the COTI is done on the Alt-CoA. 

The question is really if alt-coa is still useful for
its intended purpose, which is something that the design team
doesn't understand.

So let me spell things out in detail to see if something jumps out.
Assume a MN has two CoAs: C1 and C2.
It wants to create the binding to C2 but (for whatever
reason) it wants to send the actual BU packet with C1 as a source.

It would then do HoTI/HoT as normal.
Send a CoTI with C2 as the source, and receive the CoT with C2 as
the destination.
Then it has the cookies necessary to send a BU for CoA=C2
and it can use any source address for that BU by including the alt-coa
option.
Thus the MN needs to be able to both send and receive packets
on the alt-coa address in order to get the right Care-of cookie.

As long as this is still useful things are fine.
But if folks where intending to use alt-coa for cases when the MN can't
(yet) send and/or receive on that address there is a problem to combine
this with RR.

  Erik