Subject: RE: [mobile-ip] Return Routability

From: [email-masked]
Date: Wed, 6 Mar 2002 12:24:34 +0200

Well,

> "Jari Arkko" <[email-masked]> writes:
> > 1a = HoA Test Init (HTI)
> > 1b = CoA Test Init (CTI)
> > 2a = HoA Test (HT)
> > 2b = CoA Test (CT)
> > 3 = BU
> 
> I think I've already seen somewhere HTI short for Handoff Transfer
> Initiate and CTI short for Context Transfer Initiate...

Which means we could have:

1a = HoA Test Init (HoTI)
1b = CoA Test Init (CoTI)
2a = HoA Test (HoT)
2b = CoA Test (CoT)
3 = BU

Don't know if these are any better ;)

John

---

From: Alexandru Petrescu<[email-masked]>
Date: 06 Mar 2002 12:25:37 +0100

[email-masked] writes:
> 1a = HoA Test Init (HoTI)  MN(HoA)--->HA--->CN     
> 1b = CoA Test Init (CoTI)  MN(CoA)--------->CN     
> 2a = HoA Test (HoT)        CN-------->HA--->MN(HoA)
> 2b = CoA Test (CoT)        CN-------------->MN(CoA)
> 3 = BU                     MN(CoA)--------->CN     
> 

I can use them, even if they're a bit long :-)

One can notice that CoT is very close in meaning to a BR.  Thus, we
can consider that a normal packet that has a BR option will have an
additional CoT option.  This, of course, modulo the piggybacking
discussion.

Also, a HoT can be considered as a BR whose destination address is the
HA address with the Home Address option of the MN.  Again, modulo the
piggybacking discussion.

Thus only HoTI and CoTI are new messages to be defined.

Alex