Subject: Re: [Mobopts] Re: [Mip6] [Fwd: FW:resubmit draft-irtf-mobopts-locat ion-privacy-ps-00.txtwith revised boilerplate]

From: Qiu Ying <[email-masked]>
Date: Wed, 03 Aug 2005 15:44:03 +0800

Hi,
Yes, RFC3775 only mentions that the SQN should be larger than the previous one. The new issue is how to let the receiver know the increment if we does not use a fixed one..
-- Qiu Ying

----- Original Message -----
From: Rajeev Koodli <[email-masked]>
Date: Wednesday, August 3, 2005 1:30 am
Subject: Re: [Mobopts] Re: [Mip6] [Fwd: FW:resubmit	draft-irtf-mobopts-locat ion-privacy-ps-00.txtwith revised	boilerplate]

> 
> 
> Ryuji Wakikawa wrote:
> 
> > Hi Wassim
> > 
> > I agree most of implementation today just increment one for 
> sequence  
> > number.
> > Is there any description in RFC3775  saying that MN must 
> increment  
> > sequentially for Seq number?
> 
> I was looking for that. I could not find text that says the Sequence
> Number must be incremented by one. The only requirement is that it is
> greater than the previous one.
> 
> -Rajeev
> 
> 
> 
> 
> > 
> > ryuji
> > 
> > 
> > On 2005/07/12, at 12:50, Wassim Haddad wrote:
> > 
> >> Hi Rajeev,
> >>
> >> Thanks for writing this draft.
> >>
> >> I just want to add that tracing the BU messages via the sequence 
> number
> >> can also reveal in real time to an eavesdropper the path taken 
> by an
> >> unknown mobile node, i.e., by linking the BU messages and 
> consequently>> the pseudo-IP addresses.
> >> However, the ability to follow the movements in real time, 
> combined  with
> >> some prior infos about one particular target can lead to break 
> the  
> >> user's
> >> anonymity.
> >>
> >> IMHO, it makes sense to add such scenario in the problem statement.
> >>
> >> We have addressed this particular issue in our "anonymity and  
> >> unlinkability
> >> solution for omipv6" (draft-haddad-privacy-omipv6-anonymity-00).
> >>
> >>
> >> Regards,
> >>
> >> Wassim H.
> >>
> >>
> >> On Mon, 11 Jul 2005, Rajeev Koodli wrote:
> >>
> >>
> >>>
> >>> Hello folks,
> >>>
> >>> I submitted the draft on Friday, I believe with the correct  
> boilerplate>>> (see attached draft). I still got an error message.
> >>>
> >>> Anyway, please find the Location Privacy Problem Statement draft.
> >>>
> >>> Regards,
> >>>
> >>> -Rajeev
> >>>
> >>>
> >>>
> >>>> -----Original Message-----
> >>>>
> >>>
> >>>
> >>>> From:     Koodli Rajeev (Nokia-NRC/MtView)
> >>>> Sent:    Friday, July 08, 2005 7:42 PM
> >>>> To:    [email-masked]'
> >>>> Subject:    resubmit draft-irtf-mobopts-location-privacy- ps-
> 00.txt 
> >>>> with revised boilerplate
> >>>>
> >>>>
> >>>> Here it is..
> >>>>
> >>>> Thanks,
> >>>>
> >>>> -Rajeev Koodli
> >>>>
> >>>>
> >>>>>  <<draft-irtf-mobopts-location-privacy-ps-00.txt>>
> >>>>>
> >>>>
> >>>> http://people.nokia.net/~rajeev
> >>>>
> >>>>
> >>>
> >>>
> >>>
> >>>
> >>
> >> _______________________________________________
> >> Mobopts mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/mobopts
> >>
> >>
> > 
> > 
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> 
> 
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
> 

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Wassim Haddad <[email-masked]>
Date: Wed, 3 Aug 2005 12:04:22 +0300 (EEST)

On Wed, 3 Aug 2005, Qiu Ying wrote:

> Hi,
> Yes, RFC3775 only mentions that the SQN should be larger than the previous one. The new issue is how to let
> the receiver know the increment if we does not use a fixed one..

=> IMHO, the CN can compute the "next", i.e., expected SQN, in the same way as the MN. In this case, if the
new BU message sent by the MN does not carry the expected SQN, then it will be rejected.

Regards,

Wassim H.

---

From: Wassim Haddad <[email-masked]>
Date: Wed, 3 Aug 2005 12:18:20 +0300 (EEST)

On Wed, 3 Aug 2005, Jianying Zhou wrote:

> Is the algorithm confidential (only known to MN and CN)?
>
> - If yes, how to share the secret?

=> Yes it is confidential. Please check draft-haddad-privacy-omipv6-anonymity-00

Regards,

Wassim H.

> Wassim Haddad wrote:
> >>>>I agree most of implementation today just increment one for sequence number.
> >>>>Is there any description in RFC3775  saying that MN must increment
> >>>>
> >>>>
> >>>>>I just want to add that tracing the BU messages via the sequence number
> >>>>>
> >>>>>
> >>>>>can also reveal in real time to an eavesdropper the path taken by an
> >>>>>
> >>>>>
> >>>>>However, the ability to follow the movements in real time, combined  with
> >>>>>
> >>>>>
> >>>>>some prior infos about one particular target can lead to break the
> >>>>>
> >>>>>
> >>>>>user's anonymity.
> >>>>>