Subject: RE: [Mobopts] Dallas minutes and presentations

From: "Kilian Weniger" <[email-masked]>
Date: Fri, 21 Apr 2006 10:37:08 +0200

Hi Rajeev,

I have some corrections to the minutes about MIP6 location privacy
discussion. From my notes it was more as follows:

---
5. MIP6 Location Privacy
...

Discussion:

Kilian:  The draft seems to focus on the case of hiding the HoA from
eavesdroppers. For the case of hiding the CoA from CN, the draft
proposes bidirectional tunnling. This is a really simple solution, but
it is not very efficient in many scenarios. Optimized routing should be
considered also for the case of hiding the location from CN. There are
drafts out providing solutions for this.
Rajeev:  This draft is about adding location privacy support to MIPv6
without changing MIPv6 much. The approach you are proposing (ROTA)
introduces a new entity.
Kilian:  There are multiple solutions for this problem, some of them
require more changes, some of them less changes. 
---

Regards,

Kilian

> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]] 
> Sent: Donnerstag, 20. April 2006 20:29
> To: [email-masked]
> Subject: [Mobopts] Dallas minutes and presentations
> 
> 
> at..
> 
> people.nokia.net/~rajeev/mobopts
> 
> Regards,
> 
> -Rajeev
> 
> 
> 
> 
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
> 
> 

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: QIU Ying <[email-masked]>
Date: Fri, 21 Apr 2006 23:59:48 +0800

Hi, Kilian

Thanks for your comments. Please refer to my response inline.

----- Original Message ----- 
From: "Kilian Weniger" <[email-masked]>
To: <[email-masked]>
Sent: Friday, April 21, 2006 4:37 PM
Subject: RE: [Mobopts] Dallas minutes and presentations

>eavesdroppers.

Not exactly. If the CN does not care MN's identity, such as CN is a public 
webserver, MN can negotiate with CN through a fake HoA. The main idea of the 
solutions is to break the relationship among HoA, CoA, HA and CN.

>For the case of hiding the CoA from CN, the draft
>it is not very efficient in many scenarios.

It is ture that tnnling mode is not very efficient, but it is tradeoff. In 
order to hide the CoA from CN, you must use a 3rd-party to hand over.

>Optimized routing should be
>considered also for the case of hiding the location from CN.

The purpose of Optimized Routing is to let the packets transfer from CN to 
MN directly. Therefore, CN must know the CoA. If a packet is handed over by 
a third-party, it hardly say it were still a Optimized Routing mode.

In order to hide the location from CN, a fake HoA could be employed if the 
CN accepts.

>There are drafts out providing solutions for this.
>

Yes. This draft combines 3 of them:
draft-koodli-mip6-location-privacy-solutions-
draft-qiu-mip6-mnprivacy-
draft-zhao-mip6-rr-ext-

Regards
Qiu Ying

------------ Institute For Infocomm Research - Disclaimer -------------
This email is confidential and may be privileged.  If you are not the intended recipient, please delete it and notify us immediately. Please do not copy or use it for any purpose, or disclose its contents to any other person. Thank you.
--------------------------------------------------------

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 26 Apr 2006 20:44:30 -0700

Hi Killian,

I agree with your recollection of the discussion.
I have updated the minutes and put them on the URL below.

Regards,

-Rajeev