Subject: [Model-t] draft-arkko-farrell-arch-model-t-00

From: Dominique Lazanski <[email-masked]>
Date: Tue, 5 Nov 2019 11:56:13 +0000

Many thanks for the new Internet draft  https://datatracker.ietf.org/doc/draft-arkko-farrell-arch-model-t/ <https://datatracker.ietf.org/doc/draft-arkko-farrell-arch-model-t/>. It starts to address many of the issues and challenges occurring at endpoints as in my first draft https://datatracker.ietf.org/doc/draft-lazanski-smart-users-internet/ <https://datatracker.ietf.org/doc/draft-lazanski-smart-users-internet/> and subsequent draft which will be posted shortly.

I am wondering if this is an IAB project only? That would clear up some misunderstanding on my part. Consistently, acknowledgement of my draft has been ignored, first in Montreal and now, though I see content from it has been incorporated. I wasn’t asked to combine or contribute to this draft. I propose in my draft that the best way forward to combine all three and evolve one document.

I work in several other SDOs and being a woman is quite challenging in all SDO work. If this isn’t an IAB project only, I’d be happy to discuss the issues that you have with my work with the ombudsman in Singapore.

Thank you and well done on a good draft.

Dominique

---

From: Bret Jordan <[email-masked]>
Date: Tue, 5 Nov 2019 07:45:40 -0700

I think Dominique’s draft is great and a much better place to start from.  Taking her ideas and words and refactoring them in to a new draft is just wrong.  If anything, we should work with her to add to and enhance her draft. 

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

> On Nov 5, 2019, at 4:56 AM, Dominique Lazanski <[email-masked]> wrote:
> 
> -- 
> Model-t mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/model-t

---

From: S Moonesamy <[email-masked]>
Date: Wed, 06 Nov 2019 00:29:35 -0800

Dear Ms Lazanski,
At 03:56 AM 05-11-2019, Dominique Lazanski wrote:
>I am wondering if this is an IAB project only? That would clear up 
>some misunderstanding on my part. Consistently, acknowledgement of 
>my draft has been ignored, first in Montreal and now, though I see 
>content from it has been incorporated. I wasn't asked to combine or 
>contribute to this draft. I propose in my draft that the best way 
>forward to combine all three and evolve one document.

I don't have any information about what happened in Montreal.  It is 
not clear to me which content has been incorporated.  Would it be 
possible to provide some information about that?

The contact information for the Ombudspersons is at 
https://www.ietf.org/contact/ombudsteam/

Regards,
S. Moonesamy

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Nov 2019 16:33:43 +0000

On 05/11/2019 14:45, Bret Jordan wrote:
> Taking her ideas and words and refactoring them in to a new
> draft is just wrong.  

I have no idea what you're on about. The draft Jari posted
is just a merge of the separate drafts he and I posted for
the DEDR workshop some months ago.

If there is some accusation in your text above, then I
think it's be stylish to retract it and a bit naff to fail
to do so.

Thanks,
S.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Nov 2019 16:35:54 +0000

Hiya,

On 05/11/2019 11:56, Dominique Lazanski wrote:
> I am wondering if this is an IAB project only? 

No, this is an IAB list. There's no formal "project" so far
really, IMO we're still at the point of figuring out if we
can do something useful.

> That would clear up
> some misunderstanding on my part. Consistently, acknowledgement of my
> draft has been ignored, first in Montreal and now, though I see
> content from it has been incorporated. 

Huh? What and where? The draft in the subject line is just
a merge of the drafts Jari and I separately posted to the
DEDR workshop.

S.

> I wasn’t asked to combine or
> I work in several other SDOs and being a woman is quite challenging
> in all SDO work. If this isn’t an IAB project only, I’d be happy to
> discuss the issues that you have with my work with the ombudsman in
> Singapore.
>

---

From: Dominique Lazanski <[email-masked]>
Date: Wed, 6 Nov 2019 18:06:31 +0000

Hiya,

There is a third draft on this topic which you neglected to include in your presentation from Montreal. That is the draft that I submitted and second version of which will be posted shortly. Please see the attached screenshot of drafts which does not include the one I wrote and the attached email as well as the video from minute 44 where I mention my draft and my willingness to collaborate with you. https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275 <https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275>

The logical thing to do would be work together and combine all three - now two - drafts into one with all three of us as authors.

Thanks,
Dominique

> On 6 Nov 2019, at 16:33, Stephen Farrell <[email-masked]> wrote:
> 
> 
> 
> <0x5AB2FAF17B172BEA.asc>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Nov 2019 18:15:46 +0000

Hiya,

On 06/11/2019 18:06, Dominique Lazanski wrote:
> Hiya,
> 
> There is a third draft on this topic which you neglected to include
> in your presentation from Montreal. 

Are you complaining that a presentation to introduce a
discussion did not comprehensively refer to every single
mention of the topic or something? If so, I guess that
seems a bit odd to me.

> That is the draft that I
> submitted and second version of which will be posted shortly. Please
> see the attached screenshot of drafts which does not include the one
> I wrote and the attached email as well as the video from minute 44
> where I mention my draft and my willingness to collaborate with you.
> https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275
> <https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275>
>
>  The logical thing to do would be work together and combine all three
> - now two - drafts into one with all three of us as authors.

Perhaps or perhaps not. I think it's entirely valid for
Jari and I to choose the content of an individual draft
that we co-authored. If you disagree perhaps that's a
topic you might be better taking elsewhere, e.g. to
[email-masked] perhaps, as I'm sure other authors of
individual drafts would like to know that such (new to
me) expectations exist for some people.

Meanwhile, can you or Bret please clarify how you got to
"I see content from it has been incorporated" (where "it"
is your draft I assune).

What exact content do you mean?

If we did inadvertently include some text without reference
I'd be keen to correct that. If we did not (which I think
is the case) then I'd like that accusation (more the case
for Bret's mail than yours) cleared up please.

Thanks,
S.

> Thanks, Dominique
>>> Taking her ideas and words and refactoring them in to a new draft
>>> is just wrong.
>> 
>> I have no idea what you're on about. The draft Jari posted is just
>> a merge of the separate drafts he and I posted for the DEDR
>> workshop some months ago.
>> 
>> If there is some accusation in your text above, then I think it's
>> be stylish to retract it and a bit naff to fail to do so.
>> 
>> Thanks, S.
>> 
>> 
>> <0x5AB2FAF17B172BEA.asc>
> 
> 
>

---

From: Dominique Lazanski <[email-masked]>
Date: Wed, 6 Nov 2019 21:21:26 +0000

It is fine. I get it. You value being confrontational over collaborative. You value being insular over working with the wider community. There were three drafts - not 100 - so leaving one out seems ridiculous. I think it would be reasonable to include all three going forward in one draft. Don’t you?

I am not taking my work elsewhere so you won’t be getting rid of me any time soon. I have experience at start ups during the 1990s called Yahoo! and eBay and also about 20 years experience in mobile operator device security including work on IMEI security so if you don’t think that is relevant that is clearly your problem, not mine.

I look forward to working with you and our community in Singapore on this topic.

Dominique

> On 6 Nov 2019, at 18:15, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
>> https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275 <https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275>
>> <https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275 <https://www.youtube.com/watch?v=FkoGWtdZZAw&feature=youtu.be&t=2275>>
>> 
> [email-masked] <mailto:[email-masked]> perhaps, as I'm sure other authors of

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Nov 2019 22:35:59 +0000

On 06/11/2019 21:21, Dominique Lazanski wrote:
> It is fine. I get it. You value being confrontational over
> collaborative. You value being insular over working with the wider
> community. 

More accusations? And this time personal rather than the
repeated (but unsupported) one of plagiarism. I'm puzzled
that you think that might be productive.

Neither you nor Bret have actually pointed to any text in
our draft that's supposedly taken from yours despite me
asking three times.

If you retract the accusation of plagiarism or point at
some problematic text in our draft then I'll be happy to
discuss more.

S.

PS: Frankly, I'm wondering if there's any point in this
group meeting at IETF106 - if unsupported accusations are
going to be bandied about like this, I don't see much
point in that at all. Perhaps it was a mistake to try be
inclusive in how we had this discussion.

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 07 Nov 2019 10:39:19 +1100

It's probably time for some cooling off.  Attacking other participants is completely inappropriate.

Please try to show some respect for your fellow human.  Spending a moment to moderate the tone of emails can go a long way to avoid misunderstanding.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 7 Nov 2019 00:45:21 +0000

Hiya,

On 06/11/2019 23:39, Martin Thomson wrote:
>  misunderstanding.

As you know, for an academic, allegations of plagiarism are
not something to treat as just a possible misunderstanding.

I've had a couple of students over the last 15+ years who
failed their courses solely because I or a colleague
spotted exactly that kind of mis-behaviour - it wouldn't be
credible for me to check for that if I didn't react to
similar accusations against me as being serious.

In this case, Jari and I have been accused of plagiarism:
"I see content from it has been incorporated" is a quote
from [1], referring to a -00 draft published by the author
of [1] on July 8th 2019. [2]

Our recent draft [3] is substantially the merge of drafts
first pubslished in April 2019 [4,5], the latest versions
of which (pre-merge) were dated July 6th 2019 and July 9th
2019.

I have requested three times that that accusation be
withdrawn or justified. That request has not been
acknowledged nor answered, but was met by additional
irrelevant and incorrect pejoratives.

No text has been quoted to demonstrate any issue, never
mind such a serious issue as plagiarism.

I hope it is clear that this accusation is both serious
and unfounded and therefore needs to be withdrawn.

It may be the case that the someone didn't understand
that they made a serious accusation. If so, I hope this
mail should have fully explained that.

S.

[1]
https://mailarchive.ietf.org/arch/msg/model-t/1oU-aP-aA70j3nl_6aYNssmfjaI
[2] https://datatracker.ietf.org/doc/draft-lazanski-smart-users-internet/
[3] https://datatracker.ietf.org/doc/draft-arkko-farrell-arch-model-t/
[4] https://datatracker.ietf.org/doc/draft-farrell-etm/
[5] https://datatracker.ietf.org/doc/draft-arkko-arch-internet-threat-model/

---

From: Bret Jordan <[email-masked]>
Date: Thu, 7 Nov 2019 08:20:19 -0700

Withdrawn.  

I felt when you presented, a lot of the ideas were similar to what Dominique had published. Then when you did not acknowledge her draft even though there were only three drafts published, I felt like you were purposefully shunning her. That was the basis of my concern.

However, after re-reviewing, I see that you published your document first. So I formally apologize for claiming that you incorporated her ideas.   

Thanks,
Bret

> On Nov 6, 2019, at 5:45 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> <0x5AB2FAF17B172BEA.asc>-- 
> Model-t mailing list
> [email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 7 Nov 2019 15:31:34 +0000

Hiya,

> Withdrawn.

Thank you. I appreciate that saying that can sometimes
be hard to do.

> I felt when you presented, a lot of the ideas were similar to what
> Dominique had published. 

Yep, there're a lot of similarities. That's likely a
good sign though.

> Then when you did not acknowledge her draft
> even though there were only three drafts published, I felt like you
> were purposefully shunning her. That was the basis of my concern.

That was definitely not our intent.

In fact, I'm not sure if we do want to fully merge all
the various drafts now or even soon - it may be better to
see what emerges from a few different efforts for a while,
and it's not clear to me that all of anyone's text needs
to end up in an RFC - in some sense the ideal outcome
would be a 1-pager that we could offer to IETFers to see
if they'd like that to update BCP72. We might or might
not decide that there's value in publishing the 20-40
page justification/analysis that lead to that 1-pager in
an RFC, but equally, it might be ok to just leave that
hanging about in Internet-drafts. (Not sure TBH, and too
early yet to tell.)

> However, after re-reviewing, I see that you published your document
> first. So I formally apologize for claiming that you incorporated her
> ideas.

Again, thanks.

Cheers,
S.

> 
> 
> Thanks, Bret PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8
> ACAE 7415 0050 "Without cryptography vihv vivc ce xhrnrw, however,
> the only thing that can not be unscrambled is an egg."
> 
>> As you know, for an academic, allegations of plagiarism are not
>> something to treat as just a possible misunderstanding.
>> 
>> I've had a couple of students over the last 15+ years who failed
>> their courses solely because I or a colleague spotted exactly that
>> kind of mis-behaviour - it wouldn't be credible for me to check for
>> that if I didn't react to similar accusations against me as being
>> serious.
>> 
>> In this case, Jari and I have been accused of plagiarism: "I see
>> content from it has been incorporated" is a quote from [1],
>> referring to a -00 draft published by the author of [1] on July 8th
>> 2019. [2]
>> 
>> Our recent draft [3] is substantially the merge of drafts first
>> pubslished in April 2019 [4,5], the latest versions of which
>> (pre-merge) were dated July 6th 2019 and July 9th 2019.
>> 
>> I have requested three times that that accusation be withdrawn or
>> justified. That request has not been acknowledged nor answered, but
>> was met by additional irrelevant and incorrect pejoratives.
>> 
>> No text has been quoted to demonstrate any issue, never mind such a
>> serious issue as plagiarism.
>> 
>> I hope it is clear that this accusation is both serious and
>> unfounded and therefore needs to be withdrawn.
>> 
>> It may be the case that the someone didn't understand that they
>> made a serious accusation. If so, I hope this mail should have
>> fully explained that.
>> 
>> S.
>> 
>> [1] 
>> [3]
>> https://datatracker.ietf.org/doc/draft-arkko-farrell-arch-model-t/ 
>> [4] https://datatracker.ietf.org/doc/draft-farrell-etm/ [5]
>> https://datatracker.ietf.org/doc/draft-arkko-arch-internet-threat-model/
>>
>>
>>
>>
>> 
>> Model-t mailing list [email-masked]

---

From: Christian Huitema <[email-masked]>
Date: Wed, 13 Nov 2019 12:56:59 -0800

Doing my prep work for the meeting in Singapore, I have been reviewing
draft-arkko-farrell-arch-model-t-00. I think this is a very good
framework for the discussion, which does reflect the discussions in the
IAB prior to launching the "model T" effort. I have a couple of nits
that I would like to see fixed, and I will list them later. But first, I
would like to point the differences with
draft-lazanski-smart-users-internet-00.

Draft-arkko-farrell-arch-model-t-00 addresses much of the threats
discussed in draft-lazanski-smart-users-internet-00, including efforts
to delineate what we should really mean by end-to-end. There are
differences in tone, as Lazanski's draft reads more like an advocacy for
different classes of defense, but beyond the difference in tone there is
an important difference in focus on threats against businesses, botnets,
and persistent actors.

I think the threat model should try integrate some of these threat
descriptions. Botnets are so common that they probably deserve their own
section in the next version of draft-arkko-farrell-arch-model-t, looking
at how these things are built, what they are use for, and how better
security could if not prevent their formation at least make them easier
to detect and demolish. Similarly, attacks against enterprise networks
probably deserve their own section, including how they are used for
ransomware, DDOS or spying, how they progress over time, and how the
enterprise can detect and mitigate attacks in progress -- probably with
a mention of the "kill chain".

Some of the enterprise attacks are facilitated by poor security postures
inherited from the early Internet development. The worse offender is
probably the classic domain-based defense, "soft on the inside, crunchy
on the outside". Draft-arkko-farrell-arch-model-t addresses some of
that, but could be more forceful.

I understand that there is a tension between describing the attacks and
securing the Internet. Combating botnets or persistent threat requires
monitoring system behavior and flagging anomalies. Some of the current
tools do that by monitoring clear text parts of the traffic. These tools
are threatened by advances in end-to-end security that also contribute
to hide the bad actors. There is a natural tendency by some
practitioners to block the end-to-end security advances in order to
preserve their existing tools. We don't want to reinforce that line of
argument, but we need to discuss it and delineate the alternatives.

As for the nits in draft-arkko-farrell-arch-model-t-00, I noted that in
the basic guidelines section (4.1), the draft says:

 3.  Perform end-to-end protection via other parties:...

The paragraph actually explains the dangers of involving third parties
when performing end-to-end protection. I think it would be clearer to
state that in the headline, as in "Minimize reliance on third parties
for end to end protection".

The additional guidelines section has a paragraph about greasing. I
wonder whether greasing really is a security function, or something
else. I don' see the case for greasing made in the observations section
(2). You should either make it, or not mention greasing.

-- Christian Huitema

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 13 Nov 2019 21:41:47 +0000

Hi Christian,

Thanks for the comments, I'll process 'em more thoroughly
later but just wanted to comment on one thing for now, so
folks who'll be in Singapore next week can think about it
en-route...

On 13/11/2019 20:56, Christian Huitema wrote:
> descriptions. 

ISTM your comment above assumes a modus-operandi where we
try to integrate various folks' efforts now(ish), which is
indeed something we will want to eventually do, but I'm
not sure if doing that now, versus a bit later, is the
better plan.

I think there may be value in trying to see where these
different starting points lead people for a while; not
in a competitive sense but rather to see what common
outcomes or conclusions might emerge. There are as you
note already lots of things in common in the two drafts
you mention, and I'd love to see if others who also worked
independently ended up in similar places (or not).

I've a few reasons why I think doing more work before
trying to integrate might be a good plan:

- we won't need to argue about motivating text near so
  much:-)
- we're not in that much of a rush that we need to get
  done in a few months
- we may get more viewpoints and broader input if there
  isn't just one document on which we're working
- but mostly, I think the interesting output here has
  to be concise to be useful- much moreso than the draft
  Jari and I posted, so we'll in any case have to extract
  the important bits that can make sense IETF-wide (as
  a possible BCP72 update) and therefore may never need a
  perfect 30 page document (and/or if we might find it
  easier to post-facto justify the concise text compared
  to aiming for something like rough consensus on the
  all the motivating text).

That's something I think may be worth chatting about in
Singapore.

Cheers,
S.