Subject: [Modern] I-D Action: draft-ietf-modern-problem-framework-01.txt

From: [email-masked]
Date: Fri, 08 Jul 2016 14:30:53 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Managing, Ordering, Distributing, Exposing, & Registering telephone Numbers of the IETF.

        Title           : Modern Problem Statement, Use Cases, and Framework
        Authors         : Jon Peterson
                          Tom McGarry
	Filename        : draft-ietf-modern-problem-framework-01.txt
	Pages           : 22
	Date            : 2016-07-08

Abstract:
   The functions of the public switched telephone network (PSTN) are
   rapidly migrating to the Internet.  This is generating new
   requirements for many traditional elements of the PSTN, including
   telephone numbers (TNs).  TNs no longer serve simply as telephone
   routing addresses, they are now identifiers which may be used by
   Internet-based services for a variety of purposes including session
   establishment, identity verification, and service enablement.  This
   problem statement examines how the existing tools for allocating and
   managing telephone numbers do not align with the use cases of the
   Internet environment, and proposes a framework for Internet-based
   services relying on TNs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-modern-problem-framework/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-modern-problem-framework-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-modern-problem-framework-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chris Wendt <[email-masked]>
Date: Fri, 8 Jul 2016 19:53:55 -0400

Hi All,

I have submitted a new version of the DRiP draft.

This includes updates to the Heartbeat API, a JWT based Authorization header for transaction security and a few more notes on security.

Comments are welcome.

Thanks.

-Chris

A new version of I-D, draft-wendt-modern-drip-01.txt
has been successfully submitted by Chris Wendt and posted to the
IETF repository.

Name:		draft-wendt-modern-drip
Revision:	01
Title:		Distributed Registry Protocol
Document date:	2016-07-08
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/internet-drafts/draft-wendt-modern-drip-01.txt <https://www.ietf.org/internet-drafts/draft-wendt-modern-drip-01.txt>
Status:         https://datatracker.ietf.org/doc/draft-wendt-modern-drip/ <https://datatracker.ietf.org/doc/draft-wendt-modern-drip/>
Htmlized:       https://tools.ietf.org/html/draft-wendt-modern-drip-01 <https://tools.ietf.org/html/draft-wendt-modern-drip-01>
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wendt-modern-drip-01 <https://www.ietf.org/rfcdiff?url2=draft-wendt-modern-drip-01>

Abstract:
  This document describes a protocol for allowing a distributed set of
  nodes to synchronize a set of information in real-time with minimal
  amount of delay.  This is useful for registry types of information
  like identity and telephone numbers with associated routing and
  ownership information and could be extended to support other
  distributed real-time information updates as well.