Subject: RE: [Monami6] Flow Bindings and destination addressindraft-soliman-monami6-flow-binding-00.txt

From: Nicolas Montavont <[email-masked]>
Date: Thu, 01 Jun 2006 20:28:59 +0200

Hi,

On Tue, 2006-05-30 at 07:39 -0700, Soliman, Hesham wrote:
> 
>  > > Is the Flow Binding(s) created always between the Binding 
>  > indicated by
>  > > the BU and the Flow Identification option(s) carried in 
>  > the same BU?
> 
> => I'm not sure I understand the question here. The flow id option
> identifies a flow and is carried in the BU. The flow has to use 
> authorised addresses for the mobile. Please clarify.
> 
>  > >
>  > > Is it correct if I say "A Flow Binding is an association between
>  > > a MIPv6 Binding (e.g. BC entry or BUL entry) and a Flow 
>  > Identifier"?
> 
> => I don't think that's the right wording. I'd say it's a binding
> of a flow to a particular care-of address.
> 
>  > >
>  > > Let's have an existing (HoA-1, CoA-1) default binding for 
>  > MN at the HA.
>  > > Now, MN sends a BU with a Flow Identification option in a BU to HA
>  > > like the following:
>  > > o the CoA in the BU is CoA-1
>  > > o the HoA in the BU is HoA-1
>  > > o the dst addr in the Flow ID option is IP-X and the E flag set.
>  > > IP-X != HoA-1 and IP-X != CoA-1.
>  > > What kind of MIPv6 Binding and Flow Binding will it result?
> 
> => We could debate whether the ownership of HoA-1 authorises the MN
> to bind another address, say IP-X. I think it's easy to do that.
> However,
> the general rule is that the address in the flow id option must be
> authorised. 
> I think this is worth clarifying in the next rev of the draft

As it is written now in the draft, the Destination address must be the
home address (HoA1 in your example) for a CN. We didn't specify anything
to bind another address.

Nicolas

> 
> Hesham
> 
>  > >
>  > > Regards,
>  > > Gabor
>  > >
>  > > _______________________________________________
>  > > Monami6 mailing list
>  > > [email-masked]
>  > > https://www1.ietf.org/mailman/listinfo/monami6 
>  > 
>  > 
>  > 
>  > 
>  > _______________________________________________
>  > Monami6 mailing list
>  > [email-masked]
>  > https://www1.ietf.org/mailman/listinfo/monami6
>  > 
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Gábor Fekete <[email-masked]>
Date: Thu, 1 Jun 2006 23:33:43 +0300

Hi Hesham,

> authorised addresses for the mobile. Please clarify.
First, Section 2 says:
  "....  Multiple options may exist within a binding
   update message."
Second, a Destination IP Address filed is present in the Flow identifier
option.
These two facts make me ask my original question above.
Plus these:
1. Can a single BC entry have multiple FIDs (or Flow Identifiers)?
   The draft does not say anything about this but the above quote
   of Section 2 suggests this.
2. If no then why can there be multiple Flow Identifiers in a BU?

> of a flow to a particular care-of address.
OK. I meant the same, i was just looking for a cleaner definition for
myself. My problem was, it is not clear what the definition of
a "Flow Binding" is.

> to bind another address, say IP-X. I think it's easy to do that.

What do you mean by "easy to do that"? Modifying the draft?
If no then my question in the top of this email comes back here again.
But now I put it this way:
Can the Flow Identifier option have different authorized IP address
(e.g. a second HoA) in its Destination Address field than the HoA
(e.g. in the HoA destination option) in the BU itself?

> I think this is worth clarifying in the next rev of the draft

One thing I am going after with this thread is that I think that
including a destination address field in the Flow
Identifier option is not justified. Even in the HMIP case.

Thanks for your reply,
Gabor Fekete

---

From: Gábor Fekete <[email-masked]>
Date: Fri, 2 Jun 2006 00:04:22 +0300

Hi Nicolas,

See my little comment in the end!

> home address (HoA1 in your example) for a CN. We didn't specify anything
From the definition of "Destination Address":
      "...  For a
      correspondent node, the destination is the home address of the
      mobile node. ..."
Maybe "is the" should be changed to "MUST be a".

Gabor