Subject: Re: [MEXT] Fwd: I-D Action:draft-zhao-mext-mnp-ikev2-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 9 Jul 2008 14:31:41 -0700 (PDT)

Hi Vijay,
    I also think that BU/BA exchange is a better solution as the second solution Pascal mentioned. There are a few problems like the one below to be resolved. We are going to work out an I-D on this soon.

Regards,

Behcet

----- Original Message ----
From: fan zhao <[email-masked]>
To: Vijay Devarapalli <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, July 9, 2008 2:30:54 PM
Subject: Re: [MEXT] Fwd: I-D Action:draft-zhao-mext-mnp-ikev2-00.txt

Hi Vijay,

My understanding is that the MR does not perform the BU/BA
exchange with the HA over the home link.

Sincerely,
fan

On Wed, Jul 9, 2008 at 11:58 AM, Vijay Devarapalli <[email-masked]> wrote:
> Hello Fan,
>
> I prefer using the Binding Update/Binding Ack exchange for assigning a
> mobile network prefix to the mobile router instead of defining an IKEv2
> configuration payload for this, unless there are some significant
> advantages to use IKEv2. Are there any?
>
> draft-zhao-mext-mnp-ikev2-00.txt does not talk about the advantages of
> using IKEv2 configuration payloads over BU/BAck exchange.
>
> Vijay
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of fan zhao
>> Sent: Tuesday, July 08, 2008 11:24 AM
>> To: [email-masked]
>> Subject: [MEXT] Fwd: I-D Action:draft-zhao-mext-mnp-ikev2-00.txt
>>
>> Hi,
>>
>> We have submitted a draft on using IKEv2 to assign a Mobile Network
>> Prefix to the Mobile Router. Comments, questions and suggestions
>> are highly appreciated.
>> Thanks.
>>
>> BR,
>> Fan
>>
>>
>> ---------- Forwarded message ----------
>> From:  <[email-masked]>
>> Date: 2008/7/6
>> Subject: I-D Action:draft-zhao-mext-mnp-ikev2-00.txt
>> To: [email-masked]
>>
>>
>> A New Internet-Draft is available from the on-line
>> Internet-Drafts directories.
>>
>>        Title           : IKEv2 based Mobile Network Prefix Assignment
>>        Author(s)       : F. Zhao, et al.
>>        Filename        : draft-zhao-mext-mnp-ikev2-00.txt
>>        Pages           : 13
>>        Date            : 2008-07-06
>>
>> This document proposes a mechanism for the Mobile Router to
>> dynamically obtain the Mobile Network Prefix through IKEv2.  The
>> mechanisms to renew, release and update the allocated Mobile Network
>> Prefixes are also described.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-zhao-mext-mnp-ikev2-00.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>>
>>
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>> _______________________________________________
>> MEXT mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mext
>>
>
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 9 Jul 2008 20:04:13 -0400

Hi Behcet,

> Hi Vijay,
>    I also think that BU/BA exchange is a better solution as 
> the second solution Pascal mentioned. There are a few 
> problems like the one below to be resolved. We are going to 
> work out an I-D on this soon.

The document already exists.
http://tools.ietf.org/id/draft-ietf-nemo-prefix-delegation-02.txt

I guess we don't need yet another draft on this.

Vijay