Subject: [MEXT] Home Agent Switch Message (RFC 5142) and DSMIP

From: <[email-masked]>
Date: Thu, 30 Oct 2008 09:06:37 +0100

The home agent switch message allows a home agent to inform the 
mobile node, that the mobile node should deregister from the home 
agent, and register with some other home agent.  The address of this 
other home agent is supplied in the home agent switch message.  
The address in an IPv6 address.  If the home agent supports DSMIP, 
the home agent should also provide an IPv4 address.  Isn't there a 
need for an extention, such that the home agent's IPv4 address 
can be given to the mobile node?

Christian
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Thu, 30 Oct 2008 13:38:50 -0400

Hi Christian,

RFC 5142 was done a while ago. To able to re-direct the mobile node to
an IPv4 address of the home agent, we need to revise RFC 5142. I can do
that, if there is interest.

Vijay

---

From: Brian Haley <[email-masked]>
Date: Thu, 30 Oct 2008 16:02:49 -0400

Vijay,

Wouldn't a new DSMIP companion document just define a new mobility 
option to use with HA Switch and how it should be used?  I wouldn't 
think we'd revise 5142 to add DSMIP-specific content to it.

-Brian

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Thu, 30 Oct 2008 16:44:27 -0400

> think we'd revise 5142 to add DSMIP-specific content to it.

That will result in two documents for the same purpose. We should avoid
that. I don't see any issue with 5142bis talking about the IPv4 home
agent address.

Vijay

> 
> -Brian
> 
> Vijay Devarapalli wrote:
>> Hi Christian,
>> 
>> RFC 5142 was done a while ago. To able to re-direct the mobile node
>> to an IPv4 address of the home agent, we need to revise RFC 5142. I
>> can do that, if there is interest. 
>> 
>> Vijay
>>

---

From: <[email-masked]>
Date: Fri, 31 Oct 2008 08:17:07 +0100

Vijay

Yes, please suggest a mobility option and please prepare
a document (RFC5142bis or separate document).  I have the
3GPP release 8 in mind and should like to have a solution.

Christian 

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: 30. oktober 2008 18:39
> To: Kaas-Petersen Christian; [email-masked]
> Cc: Julien Laganier; marcelo bagnulo braun
> Subject: RE: [MEXT] Home Agent Switch Message (RFC 5142) and DSMIP
> 
> Hi Christian,
> 
> RFC 5142 was done a while ago. To able to re-direct the 
> mobile node to an IPv4 address of the home agent, we need to 
> revise RFC 5142. I can do that, if there is interest.
> 
> Vijay
> 
> > The home agent switch message allows a home agent to inform 
> the mobile 
> > node, that the mobile node should deregister from the home 
> agent, and 
> > register with some other home agent.  The address of this 
> other home 
> > agent is supplied in the home agent switch message.
> > The address in an IPv6 address.  If the home agent supports 
> DSMIP, the 
> > home agent should also provide an IPv4 address.  Isn't there a need 
> > for an extention, such that the home agent's IPv4 address 
> can be given 
> > to the mobile node?
> > 
> > Christian

---

From: Julien Laganier <[email-masked]>
Date: Fri, 31 Oct 2008 09:30:20 +0100

On Thursday 30 October 2008, Vijay Devarapalli wrote:
> That will result in two documents for the same purpose. We should
> avoid that. I don't see any issue with 5142bis talking about the IPv4
> home agent address.

I see a possible issue with having both plain-MIPv6 and DSMIPv6 support 
in the same RFC, e.g. 5142bis.

There will be MIPv6 only systems with HA switch functionality but 
without DSMIP capability. Can such systems claim conformance to 
5142bis?

--julien

---

From: Brian Haley <[email-masked]>
Date: Fri, 31 Oct 2008 10:09:34 -0400

> that. I don't see any issue with 5142bis talking about the IPv4 home

But with that logic we'd update 3775 every time we had a new mobility 
option, and we don't do that.  I'd prefer a separate document.

-Brian

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 31 Oct 2008 07:45:50 -0700

> without DSMIP capability. Can such systems claim conformance to

We can add a mobility option for the carrying the HA IPv4 address, not
modify the message itself. Existing implementations would become conformant
to 5142bis when they get updated to support the new mobility option. This is
normal, though.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 31 Oct 2008 07:52:15 -0700

> option, and we don't do that.  I'd prefer a separate document.

In general, if it is a new feature, we should standardize it in a separate
document. In this case, we just want the ability to carry the HA IPv4
address in an existing message. 5142 is already a very simple short spec,
revising it wouldn't take much effort. Since we are adding a mobility
option, it would be backward compatible with implementations that are out
today that implement 5142.

Vijay