Subject: [Mops] Milestone updates

From: Leslie Daigle (ThinkingCat) <[email-masked]>
Date: Fri, 18 Mar 2022 18:47:59 -0400

Hi,

In advance of next week’s meeting/discussion of milestones, we wanted 
to flag the proposed changes.

Feel free to start the discussion here, and we’ll take it up on 
Monday’s meeting.

This is what we have, with comments:

> Jul 2022 	Last-call document on Society of Motion Picture and 
> Television Engineers (SMPTE) protocol reliance on IETF protocols 
> (including explicit outreach to SMPTE)

That doesn’t seem to be shaping up — perhaps we can revisit when 
there are more in person meetings (IETF and SMPTE) and it’s clearer 
what the relationship is.  Propose striking it.

> Jul 2022 	Last-call document on Streaming Video Alliance (SVA)
> reliance on IETF protocols (including explicit outreach to SVA)

We may have an updated plan of who might volunteer for this.
Propose moving this to November 2022.

> Nov 2021 	IESG to decide whether continue, re-charter or close MOPS WG

Done.

> Nov 2021 	Last-call document on operational considerations for low 
> latency streaming video applications

Done.

> Nov 2021 	Draft documenting Society of Motion Picture and Television 
> Engineers (SMPTE) protocol reliance on IETF protocols

Strike, as above.

> Jul 2021 	Last-call document on edge network considerations for 
> streaming media

This seems to be a bogon from a previous edit.  Suggest moving it to Nov 
2022 as a Last Call for the operational considerations for low latency 
streaming video applications document, date TBD.

> Jul 2021 	Revised draft operational considerations for low latency 
> streaming video applications
> draft-ietf-mops-ar-use-case

Done (Mar 2022)

> Jul 2021 	Draft documenting Streaming Video Alliance (SVA) reliance on 
> IETF protocols

Per note above — make this July 2022.

Altogether, that would make our new milestones:

Jul 2022 	Draft documenting Streaming Video Alliance (SVA) reliance on 
IETF protocols

Nov 2022 	Last-call document on Streaming Video Alliance (SVA) reliance 
on IETF protocols (including explicit outreach to SVA)

TBD	Last-call operational considerations for low latency streaming video 
applications
draft-ietf-mops-ar-use-case

Leslie.

> -- 
>
> -------------------------------------------------------------------
-----------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 21 Mar 2022 12:00:49 +0100

Hi, Leslie,

One thing below ...

On Fri, Mar 18, 2022 at 11:48 PM Leslie Daigle <[email-masked]>
wrote:

> Hi,
>
> In advance of next week’s meeting/discussion of milestones, we wanted to
> flag the proposed changes.
>
> Feel free to start the discussion here, and we’ll take it up on Monday’s
> meeting.
>
> Jul 2022 Last-call document on Society of Motion Picture and Television
> Engineers (SMPTE) protocol reliance on IETF protocols (including explicit
> outreach to SMPTE)
>
> That doesn’t seem to be shaping up — perhaps we can revisit when there are
> more in person meetings (IETF and SMPTE) and it’s clearer what the
> relationship is. Propose striking it.
>
> Nov 2021 Last-call document on operational considerations for low latency
> Jul 2021 Last-call document on edge network considerations for streaming
> media
>
It's unfortunate that MOPS happens before the MOQ BOF, but the language
that the MOQ proponents have been talking about is
"lower-than-ultra-low-latency" use cases. ISTM that it's worth asking, on
the mailing list, and after the MOQ BOF, whether we think we know enough
about "low-latency" applications, which seem to be *really *low-latency, to
give advice to operators about them.

Even AR, the focus of our adopted draft, isn't quite streaming, and I'd
hate to think 10-second latency AR (the definition for low latency we have
in
https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations_),
I think.

But I'm sure that we'll talk. 😉

Best,

Spencer

> Jul 2021 Draft documenting Streaming Video Alliance (SVA) reliance on IETF
> protocols
>
> Jul 2022 Draft documenting Streaming Video Alliance (SVA) reliance on IETF
> protocols
>
> Nov 2022 Last-call document on Streaming Video Alliance (SVA) reliance on
> IETF protocols (including explicit outreach to SVA)
>
> ------------------------------
>
> ------------------------------
> Leslie Daigle
> Mops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mops
>

---

From: "Ali C. Begen" <[email-masked]>
Date: Mon, 21 Mar 2022 14:23:56 +0300

> On Mar 21, 2022, at 2:00 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> It's unfortunate that MOPS happens before the MOQ BOF, but the language that the MOQ proponents have been talking about is "lower-than-ultra-low-latency" use cases.

I know you are pressing my button Spencer on this :), but I don’t like beating these terminologies to death. Simply call it “real-time” video 

> ISTM that it's worth asking, on the mailing list, and after the MOQ BOF, whether we think we know enough about "low-latency" applications, which seem to be really low-latency, to give advice to operators about them.

With my author hat on, the current draft is done. If we reboot these latency discussions again, not only it will be utterly useless, but also we will have no tangible improvements on the document. 

> Even AR, the focus of our adopted draft, isn't quite streaming, and I'd hate to think 10-second latency AR (the definition for low latency we have in https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations_), I think.

Streaming VR content is different than doing metaverse stuff. But again, please lets avoid opening this discussion again in the context of the opcons draft.

-acbegen

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 21 Mar 2022 13:47:56 +0100

Ali,

Push your button? I would never. 😉

On Mon, Mar 21, 2022 at 12:23 PM Ali C. Begen <[email-masked]>
wrote:

> "lower-than-ultra-low-latency" use cases.
>
> I know you are pressing my button Spencer on this :), but I don’t like
> beating these terminologies to death. Simply call it “real-time” video
>
> > ISTM that it's worth asking, on the mailing list, and after the MOQ BOF,
> whether we think we know enough about "low-latency" applications, which
> seem to be really low-latency, to give advice to operators about them.
>
> With my author hat on, the current draft is done. If we reboot these
> latency discussions again, not only it will be utterly useless, but also we
> will have no tangible improvements on the document.
>
> Streaming VR content is different than doing metaverse stuff. But again,
> please lets avoid opening this discussion again in the context of the
> opcons draft.
>

That would all be fine with me. I wish the categories that we agreed on in
the working group had survived AD Evaluation, but Eric's comment was
non-blocking. We may get the same comment again from IETF Last Call and
from IESG Evaluation, but if we do, we'll Do The Right Thing when we come
to that bridge.

And I do take your point that "having this discussion in the context of the
opcons draft" isn't the same thing as "having this discussion", so I'm fine
with shipping that section unchanged.

Best,

Spencer

---

From: "Holland, Jake" <[email-masked]>
Date: Mon, 21 Mar 2022 13:43:02 +0000

Hi,

The latency categories seem like a moving target, I think the industry practice has changed materially while this doc has been under construction.

Should we make it 5s instead of 10 for low latency?  I mean, I guess that’s maybe a reasonable choice, but I’m not sure it matters.  We called it “rough” categories, so order of magnitude boundaries where there’s relevant operational differences seems reasonable to me, and the difference between 5 and 10s isn’t really a major factor.  (And by way of comparison, I think the tv production delays often still are in the 10s range—those newscasters talking to each other over satellite often will pause for a solid 18s to respond...)

I tend to agree we shouldn’t keep editing it every time we notice it has changed.  The plan all along was to make this a snapshot of currently known practices, understanding that this is an active area of development that’s undergoing changes.  So for my opinion, I think it’s ok.

(If we’re overridden by the wg, I guess my ask is to determine a consensus number for the boundaries with the decision during the meeting, so I’d ask any proponents for changing to please propose one.)

Just my 2c :)

-Jake

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon,2022-03-21 at 5:48 AM
To: "Ali C. Begen" <[email-masked]>
Cc: Leslie Daigle <[email-masked]>, Kyle Rose <[email-masked]>, MOPS Working Group <[email-masked]>
Subject: Re: [Mops] Milestone updates

Ali,

On Mon, Mar 21, 2022 at 12:23 PM Ali C. Begen <[email-masked]> wrote:

> On Mar 21, 2022, at 2:00 PM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:
>

> Even AR, the focus of our adopted draft, isn't quite streaming, and I'd hate to think 10-second latency AR (the definition for low latency we have in https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations_<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html*name-latency-considerations___;Iw!!GjvTz_vk!AO0zGJyx2DfOiuRJBMPkUYBMNhmz6WfoN8FrALD2BOFp0_NZPscX9L2dd5Q20Eg$>), I think.

That would all be fine with me. I wish the categories that we agreed on in the working group had survived AD Evaluation, but Eric's comment was non-blocking. We may get the same comment again from IETF Last Call and from IESG Evaluation, but if we do, we'll Do The Right Thing when we come to that bridge.

And I do take your point that "having this discussion in the context of the opcons draft" isn't the same thing as "having this discussion", so I'm fine with shipping that section unchanged.

Best,

Spencer

-acbegen

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 22 Mar 2022 09:52:43 +0100

Hi, Jake,

On Mon, Mar 21, 2022 at 2:43 PM Holland, Jake <[email-masked]> wrote:

> Hi,
>
>
>
> The latency categories seem like a moving target, I think the industry
> practice has changed materially while this doc has been under construction.
>

I agree. I know that's why I'm reacting now. Erik and I are reacting
specifically about the 1 second for videoconferencing, which is clearly
wrong, because we've known that people accidentally talk over other people
when latencies are more than 200 ms for decades, but it's probably not
wrong enough to be worth talking about changing it.

Honestly, if this document is about Operational Considerations for
Streaming Media, anyone reading it for guidance about videoconferencing
probably has bigger problems than the latency categories. 😉

> Should we make it 5s instead of 10 for low latency?  I mean, I guess
> that’s maybe a reasonable choice, but I’m not sure it matters.  We called
> it “rough” categories, so order of magnitude boundaries where there’s
> relevant operational differences seems reasonable to me, and the difference
> between 5 and 10s isn’t really a major factor.  (And by way of comparison,
> I think the tv production delays often still are in the 10s range—those
> newscasters talking to each other over satellite often will pause for a
> solid 18s to respond...)
>
>
>
> I tend to agree we shouldn’t keep editing it every time we notice it has
> changed.  The plan all along was to make this a snapshot of currently known
> practices, understanding that this is an active area of development that’s
> undergoing changes.  So for my opinion, I think it’s ok.
>

You have convinced me even after Ali convinced me.

I think we're through discussing that part, at least for now.

Best,

Spencer

> (If we’re overridden by the wg, I guess my ask is to determine a consensus
> number for the boundaries with the decision during the meeting, so I’d ask
> any proponents for changing to please propose one.)
>
>
>
> Just my 2c :)
>
>
>
> -Jake
>
>
>
> *From: *Spencer Dawkins at IETF <[email-masked]>
> *Date: *Mon,2022-03-21 at 5:48 AM
> *To: *"Ali C. Begen" <[email-masked]>
> *Cc: *Leslie Daigle <[email-masked]>, Kyle Rose <[email-masked]>,
> MOPS Working Group <[email-masked]>
> *Subject: *Re: [Mops] Milestone updates
>
>
>
> Ali,
>
>
>
> https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations_
> <https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html*name-latency-considerations___;Iw!!GjvTz_vk!AO0zGJyx2DfOiuRJBMPkUYBMNhmz6WfoN8FrALD2BOFp0_NZPscX9L2dd5Q20Eg$>),
> I think.
>
> And I do take your point that "having this discussion in the context of
> the opcons draft" isn't the same thing as "having this discussion", so I'm
> fine with shipping that section unchanged.
>
>
>
> Best,
>
>
>
> Spencer
>
>
>
> -acbegen
>
>

---

From: "Ali C. Begen" <[email-masked]>
Date: Tue, 22 Mar 2022 12:36:36 +0300

> On Mar 22, 2022, at 11:52 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Honestly, if this document is about Operational Considerations for Streaming Media, anyone reading it for guidance about videoconferencing probably has bigger problems than the latency categories.

Indeed. We are not saying anything related to interactive video stuff. Not sure how more clear we can make it.