Subject: Re: [Mops] Comments on draft-ietf-mops-streaming-opscons-08

From: "Holland, Jake" <[email-masked]>
Date: Tue, 1 Mar 2022 15:57:28 +0000

Hi,

I don’t know of any IPR disclosures to make for this doc.

Thanks Sanjay for the comments.  I made a comment in the repo, thanks for already addressing it, Spencer. :)

Best,
Jake

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon,2022-02-28 at 7:21 PM
To: "Mishra, Sanjay" <[email-masked]>
Cc: "Ali C. Begen" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Mops] Comments on draft-ietf-mops-streaming-opscons-08

Hi, Sanjay,

On Mon, Feb 28, 2022 at 6:03 PM Mishra, Sanjay <[email-masked]<mailto:[email-masked]>> wrote:
Opscon authors - I have submitted a shepherd write up for the document earlier today. I have two follow up questions.

1. I am reconfirming that there are no IPR disclosures that should be made but have not been made. But, please confirm once again.

2. I have some minor knits in the document. See below:

Please take a look at https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/pull/96<https://urldefense.com/v3/__https:/github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/pull/96__;!!GjvTz_vk!CstG6JyhWlECQF-PmvLdo9iMkCbZSV1nS3lLV5213aX4XWU3lcg5hdsHR8Fm30Y$>, and let me know what you think.

I made most of these changes as suggested, and rephrased two or three. My thoughts follow.

Best,

Spencer

Comments:

Pg 6: remove "." between TCP and which.
Much of the focus of this document is on reliable media using HTTP
over TCP. which is widely used..."

Awkward transition between comma and start of another example.

"wide range of operating systems, is also used in a
wide variety of other applications, has been demonstrated to provide
acceptable performance over the open Internet, includes state of the
art standardized security mechanisms, and can make use of already deployed
caching infrastructure"

I split this into a list of bullets. I don't know how anyone could have parsed the sentence on first reading :-)

Consider rephrasing the start of the sentence, such as "This document also briefly discusses..." (or the document also briefly touches on...)
"Some mentions of unreliable media delivery using RTP and other UDPbased
protocols appear in..."

it's -> it is (other places in the document)

sec 3.4 -> re-use of "popular" twice in a sentence
"One popular example is when popular streaming content..."
May be re-state -> "one relevant example is when popular streaming content..."

sec 3.5 ->  "users consume more video and videos at
higher bitrates" reword?
"users consume more videos and at a higher bit rate"?

sec 3.6 -> '"throttle" these transfers, to mitigate the load..." Comma not needed

sec 4.2 -> Reference to draft-pantos-hls-rfc8216bis will need update as this is not an RFC yet

The RFC Editor will verify all of the references just before publication, and makes sure they all exist, etc. They'll make that change automatically, so I didn't do anything here.

"While an LL-HLS client retrieves each chunk with a separate HTTP GET
request, an LL-DASH client ..." replace "an" -> "a"

I wouldn't have caught this ^^^ in a million years.

sec 5.4 -> "Ads" -> prior to use of acronym suggest defining it when first referencing the word advertisements.

sec 6.3 -> missing "an" before increasing -> "As noted in Section 6.2, there is increasing interest...."

sec 7 -> comma at the end of the sentence can be removed -> "when senders and receivers store it,"

Thank you
Sanjay

---

From: "Ali C. Begen" <[email-masked]>
Date: Tue, 1 Mar 2022 10:49:02 -0700

On Mon, Feb 28, 2022 at 5:03 PM Mishra, Sanjay <[email-masked]>
wrote:

> Opscon authors - I have submitted a shepherd write up for the document
> earlier today. I have two follow up questions.
>
> 1. I am reconfirming that there are no IPR disclosures that should be made
> but have not been made. But, please confirm once again.
>

No IPR from my side.

---

From: "Mishra, Sanjay" <[email-masked]>
Date: Tue, 1 Mar 2022 12:59:26 -0500

Hi Ali, Jake and Spencer - Thank you for confirming there are no IPR
disclosures and even better for promptly updating the draft. The Diff looks
good to me. I will give one more quick read to the draft for my own sanity
but I don't think that holds up anything at this point from my end.

Good luck and I am on stand-by for any questions that might come up from
the chairs, or the AD and the IESG.

Thanks
Sanjay

On Tue, Mar 1, 2022 at 12:49 PM Ali C. Begen <[email-masked]>
wrote:

>> 1. I am reconfirming that there are no IPR disclosures that should be
>> made but have not been made. But, please confirm once again.
>>
>
> No IPR from my side.
>

---

From: "Leslie Daigle" <[email-masked]>
Date: Tue, 01 Mar 2022 13:15:55 -0500

That’s great — thanks, Sanjay!  And, thanks Spencer, Jake and Ali, 
for the quick turn around.

Leslie.

> -- 
> Mops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mops

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------