Subject: Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09

From: Kyle Rose <[email-masked]>
Date: Fri, 8 Apr 2022 10:40:37 -0400

Spencer, Jake, Ali: have you guys had a chance to address Éric's coments?
The document is still in the "revised I-D needed" state on the data
tracker. If there has been activity in the GitHub repo but no new draft
pushed, that would also be useful information to share.

Thanks,
Kyle

---

From: "Holland, Jake" <[email-masked]>
Date: Fri, 8 Apr 2022 15:18:20 +0000

Hi Kyle,

Yes, there’s been some activity in the repo and we haven’t yet published a new draft.

Spencer has split each of Eric’s comments into an issue, and in our 2 sessions in the last 2 weeks we’ve discussed I think most of them so far with text for many, and we have another session scheduled for next week.

Please do feel free to review and comment:
https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/issues

I will highlight #98 in particular as a wordsmithing complaint that has us stumped.  I think we’ll happily take text suggestions that have any buy-in that they successfully clarify the use of “simultaneous” to more closely describe “at the same time, but with a latency-driven time gap between sender and receiver” without getting more verbose and hard to follow, else the default plan is to mark it ‘wontfix’:
https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/issues/98

-Jake

From: Kyle Rose <[email-masked]>
Date: Fri,2022-04-08 at 7:41 AM
To: Spencer Dawkins at IETF <[email-masked]>, "Ali C. Begen" <[email-masked]>, Jake Holland <[email-masked]>
Cc: "Eric Vyncke (evyncke)" <evyncke=[email-masked]>, "[email-masked]" <[email-masked]>, MOPS Working Group <[email-masked]>
Subject: Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09

Spencer, Jake, Ali: have you guys had a chance to address Éric's coments? The document is still in the "revised I-D needed" state on the data tracker. If there has been activity in the GitHub repo but no new draft pushed, that would also be useful information to share.

Thanks,
Kyle

---

From: "Ali C. Begen" <[email-masked]>
Date: Fri, 8 Apr 2022 18:23:58 +0300

Then obviously the living document process needs to be finalized.

On Fri, Apr 8, 2022 at 6:18 PM Holland, Jake <[email-masked]> wrote:

> Spencer has split each of Eric’s comments into an issue, and in our 2
> sessions in the last 2 weeks we’ve discussed I think most of them so far
> with text for many, and we have another session scheduled for next week.
>
>
>
> I will highlight #98 in particular as a wordsmithing complaint that has us
> stumped.  I think we’ll happily take text suggestions that have any buy-in
> that they successfully clarify the use of “simultaneous” to more closely
> describe “at the same time, but with a latency-driven time gap between
> sender and receiver” without getting more verbose and hard to follow, else
> the default plan is to mark it ‘wontfix’:
>
> *From: *Kyle Rose <[email-masked]>
> *Date: *Fri,2022-04-08 at 7:41 AM
> *To: *Spencer Dawkins at IETF <[email-masked]>, "Ali C.
> Begen" <[email-masked]>, Jake Holland <
> [email-masked]>
> *Cc: *"Eric Vyncke (evyncke)" <evyncke=[email-masked]>, "
> [email-masked]" <[email-masked]>, MOPS Working Group <
> [email-masked]>
> *Subject: *Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09
>
>
>
-- 
-acbegen
Using iThumbs

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 8 Apr 2022 16:21:34 +0000

Indeed,

Finalized or at least decided ;-) As I said during the MOPS meeting in Vienna, github is one way, having -bis document is another way, and may be other ways may exist.

Finally, all my comments are just like a WGLC comment, authors are free to ignore (and sorry if I was not clear).

Regards

-éric

From: "Ali C. Begen" <ali.begen=[email-masked]>
Date: Friday, 8 April 2022 at 17:24
To: "Holland, Jake" <[email-masked]>
Cc: Eric Vyncke <[email-masked]>, Jake Holland <[email-masked]>, Kyle Rose <[email-masked]>, MOPS Working Group <[email-masked]>, Spencer Dawkins at IETF <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09

On Fri, Apr 8, 2022 at 6:18 PM Holland, Jake <[email-masked]<mailto:[email-masked]>> wrote:
Hi Kyle,

-Jake

From: Kyle Rose <[email-masked]<mailto:[email-masked]>>
Date: Fri,2022-04-08 at 7:41 AM
To: Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>>, "Ali C. Begen" <[email-masked]>, Jake Holland <[email-masked]<mailto:[email-masked]>>
Cc: "Eric Vyncke (evyncke)" <evyncke=[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, MOPS Working Group <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09

Thanks,
Kyle

--
-acbegen
Using iThumbs

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 8 Apr 2022 16:26:42 -0500

Hi, Eric,

Please see below ...

On Fri, Apr 8, 2022 at 11:21 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> Indeed,
>
>
>
> Finalized or at least decided ;-) As I said during the MOPS meeting in
> Vienna, github is one way, having -bis document is another way, and may be
> other ways may exist.
>
>
>
> *From: *"Ali C. Begen" <ali.begen=[email-masked]>
> *Date: *Friday, 8 April 2022 at 17:24
> *To: *"Holland, Jake" <[email-masked]>
> *Cc: *Eric Vyncke <[email-masked]>, Jake Holland <
> [email-masked]>, Kyle Rose <[email-masked]>, MOPS Working
> Group <[email-masked]>, Spencer Dawkins at IETF <
> [email-masked]>, "[email-masked]" <
> [email-masked]>
I told Jake and Ali that I think one problem we're struggling with is that
something can be "simultaneous" on one timescale, and not on another
timescale. In addition to your AD review comment, this is a thing we're
trying to describe in MOQ as well - in the situation where live media is
ingested, syndicated, and distributed to users, that's not actually
"simultaneous", in the sense that someone in a sporting event would be
seeing the same thing at the same time on a phone as they would be seeing
on the field in front of them, but it's not stored-and-forwarded, either.

So I appreciate the nudge to think about this further.

Best,

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 15 Apr 2022 08:16:31 -0500

Hi, Eric,

I'm working my way through the nits from your review, and had questions on
one point. Could you clue me in on the following?

On Sat, Mar 19, 2022 at 3:23 PM Eric Vyncke (evyncke) <evyncke=
[email-masked]> wrote:

> # Section 3.7
>
> In " it was observed that port utilization increased" port is ambiguous:
> is it IXP physical interface ? UDP/TCP ports ? or something else ?
>
We have a PR on this ^^^, but I'm not sure what to do with your next
comment, and I'd love to Do The Right Thing.

>  In the same paragraph, an explanation to the explanation would be
> welcome.
>
I'm pretty sure we're talking about this paragraph in -09

   *  At the IXP-level, it was observed that port utilization increased.
      This phenomenon is mostly explained by a higher traffic demand
      from residential users.

which is unchanged (so far) in the Editor's Copy

Am I digging in the right place?

Does this paragraph need to mention the reasons provided for higher traffic
demand from residential users, in the three references quoted in this
section, or were you thinking of something else?

Best,

Spencer

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 15 Apr 2022 14:23:34 +0000

Hello Spencer,

Thank you for all the hard work done on github !

Indeed, my last non-blocking comment on section 3.7 was on the last paragraph:

               "At the IXP-level, it was observed that port utilization increased.
      This phenomenon is mostly explained by a higher traffic demand
      from residential users"

Suggestion replace:  "is mostly explained" by "could probably be explained" as it is a (educated) guess + add why residential traffic has increased (i.e., I would assumed that all streaming traffic goes with CDN caches in the access provider, hence bypassing IXP, so this traffic may be VPN traffic ?)

Regards

-éric

From: Spencer Dawkins at IETF <[email-masked]>
Date: Friday, 15 April 2022 at 15:17
To: Eric Vyncke <[email-masked]>
Cc: MOPS Working Group <[email-masked]>
Subject: Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09 - nits

Hi, Eric,

I'm working my way through the nits from your review, and had questions on one point. Could you clue me in on the following?

On Sat, Mar 19, 2022 at 3:23 PM Eric Vyncke (evyncke) <evyncke=[email-masked]<mailto:[email-masked]>> wrote:

# Section 3.7

In " it was observed that port utilization increased" port is ambiguous: is it IXP physical interface ? UDP/TCP ports ? or something else ?
We have a PR on this ^^^, but I'm not sure what to do with your next comment, and I'd love to Do The Right Thing.

 In the same paragraph, an explanation to the explanation would be welcome.
I'm pretty sure we're talking about this paragraph in -09

Does this paragraph need to mention the reasons provided for higher traffic demand from residential users, in the three references quoted in this section, or were you thinking of something else?

Best,

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 15 Apr 2022 11:58:47 -0500

Hi, Eric,

On Fri, Apr 15, 2022 at 9:23 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> Suggestion replace:  "is mostly explained" by "could probably be
> explained" as it is a (educated) guess + add why residential traffic has
> increased (i.e., I would assumed that all streaming traffic goes with CDN
> caches in the access provider, hence bypassing IXP, so this traffic may be
> VPN traffic ?)
>

Ah - that makes perfect sense ...

Thank you for the clue!

Best,

Spencer

> Regards
>
>
>
> -éric
>
>
>
>
>
> *From: *Spencer Dawkins at IETF <[email-masked]>
> *Date: *Friday, 15 April 2022 at 15:17
> *To: *Eric Vyncke <[email-masked]>
> *Cc: *MOPS Working Group <[email-masked]>
> *Subject: *Re: [Mops] AD review of draft-ietf-mops-streaming-opcons-09 -
> nits
>
>
>
> Hi, Eric,
>
>
>
> Does this paragraph need to mention the reasons provided for higher
> traffic demand from residential users, in the three references quoted in
> this section, or were you thinking of something else?
>
>
>
> Best,
>
>
>
> Spencer
>