Subject: [Moq] What (on earth?) happened at the side meeting on "Media Over QUIC" on November 9

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 10 Nov 2021 17:13:14 -0600

Dear MOQ fans,

Now that I've had a chance to nap, I'd like to start listing my impressions
about where we ended up yesterday (my time). And I can't stress enough that
these are my opinions,

If I might make a suggestion - please feel free to reply in this thread,
and please focus on "what YOU thought happened", rather than explaining why
someone was confused. If you try to explain why someone else was confused,
just explaining why Spencer is confused would fill the rest of your week!!

High-order impressions.

   - Justin Uberti said it well in a pre-session email: "So I'm still
   bullish here. But before we jump into things it would be good to make sure
   we're aligned on goals, since I'm not sure we all mean the same thing when
   we say media-over-QUIC".
      - We certainly *didn't *all mean the same thing! (which is fine,
      that's why we have side meetings)
      - We spent more time on real-time video and streaming video than on
      most other types of media, but we also talked about captions,
cuepoints, or
      any arbitrary media or non-media type.
      - We did note that gaming has considerable overlap with video, and we
      shouldn't lose sight of that
   - I expected to talk about "media over QUIC", *somewhat *broadly
   defined, but some people had pain points that I wasn't expecting.
      - Some people came to talk about stream multiplexing (especially as
      the QUIC datagram specification matures).
      - Some people are interested in tightly coupling transport and codecs
      (perhaps similar to Salsify(*))
      - As Martin Duke said on Wednesday in TSVAREA, "multipath is
      everywhere". That will matter more in the future than it has in the past.
   - Some people came to talk about a lot of what I thought of as
   system-level considerations
      - Some people came to talk about their applications as a whole - for
      instance, including application-level data with media, as in WebRTC
      - Some people came to talk about synchronization between different
      devices in the same house watching the same program
      - Some people came to talk about mismatches between ingress,
      distributiion within a system, and egress, recognizing that
using different
      protocols at every stage can have impacts on latency and jitter
   - There really are people who are willing to consider new protocols as
   part of using QUIC for their applications
      - The desired attributes included things like starting with
      scalability/ability to fan-out/ability to cache from the beginning of the
      protocol design
   -
   - Peeling off "real-time interactive audio and video", which already has
   a home in AVTCORE, will help a lot.
   - Given that draft-engelbart-rtp-over-quic is already on the agenda for
      AVTCORE on Friday, that ship has already sailed.
      - I heard media ingest mentioned as a problem area several times

If we continue to discuss "Media Over QUIC", I have some suggestions for
anyone who is participating in that discussion. Do the right thing, of
course.

   - Agree on a set of things that are "what I'm trying to do", that are at
   the same level of abstraction. This, alone, would help a lot.
      - Spend more time on that, on the MOQ mailing list, before trying to
      have another meeting about what's necessary for elements in that set
   - Orthogonally with the "what I'm trying to do" set, it would be useful
   to agree on the characteristics I need for "what I'm trying to do" - for
   instance, requirements such as latency, jitter, one-way versus interactive
   applications, etc.
      - Again, this is a conversation that can happen on the MOQ mailing
      list.
   - Once we understand the various things people are trying to do, then
   focus on problems with QUIC
      - (unattributed quote: "identify what sucks in QUIC, and fix what
      sucks")
   - Asking for more help would have helped. Having James Gruessing jump in
   to assist me was great, but even between the two of us, we couldn't track
   what was being said at a mike, and what was being said in the chat, who had
   their hand up, what was being typed in the notes, and what was being typed
   in the spreadsheet (which really was a starting point).

Thank you, again, for your contributions to the conversation.

Best,

Spencer

(*) “Salsify: low-latency network video through tighter integration between
a video codec and a transport protocol
<https://www.usenix.org/conference/nsdi18/presentation/fouladi>”, ANRP
Talk, IETF 111 <https://irtf.org/anrp/IETF111-ANRP-Fouladi.m4v>.

---

From: "Deen, Glenn" <[email-masked]>
Date: Thu, 11 Nov 2021 03:32:58 +0000

I remain supportive of exploring this work.

An observation and suggestion:

When we were putting together MOPS charter we ran into the “this is a really big space with many intersecting, but different use cases” challenge.  I’ll suggest that perhaps some of this should be moved over to MOPS to discuss and coalesce, while the pieces that are more developed and specific to QUIC be what MOQ would ultimately build its charter around?   It’s an established group that some of this could fit into nicely.

So for some of the things talked about are new use-cases, but will in time could become very common – things like multiplexed media delivery.    It’s very cool, but it may not be something that is not ready to build a published RFC specification around until more work is done and more parties have a chance to explore the use-cases and how it would be done.

A mature use-case set…

On the other hand, there are areas like Media Ingest which have both QUIC specific approaches that people are trying out, and has established reliable transports for it that are exploring running over QUIC.  That seems like a topic space where use-cases are mature and could lead to specifications being developed – and they are something that could likely form a nicely focused group charter.

-glenn

On 11/10/21, 3:13 PM, "Moq on behalf of Spencer Dawkins at IETF" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear MOQ fans,

Now that I've had a chance to nap, I'd like to start listing my impressions about where we ended up yesterday (my time). And I can't stress enough that these are my opinions,

If I might make a suggestion - please feel free to reply in this thread, and please focus on "what YOU thought happened", rather than explaining why someone was confused. If you try to explain why someone else was confused, just explaining why Spencer is confused would fill the rest of your week!!

High-order impressions.
·         Justin Uberti said it well in a pre-session email: "So I'm still bullish here. But before we jump into things it would be good to make sure we're aligned on goals, since I'm not sure we all mean the same thing when we say media-over-QUIC".
o    We certainly didn't all mean the same thing! (which is fine, that's why we have side meetings)
o    We spent more time on real-time video and streaming video than on most other types of media, but we also talked about captions, cuepoints, or any arbitrary media or non-media type.
o    We did note that gaming has considerable overlap with video, and we shouldn't lose sight of that
·         I expected to talk about "media over QUIC", somewhat broadly defined, but some people had pain points that I wasn't expecting.
o    Some people came to talk about stream multiplexing (especially as the QUIC datagram specification matures).
o    Some people are interested in tightly coupling transport and codecs (perhaps similar to Salsify(*))
o    As Martin Duke said on Wednesday in TSVAREA, "multipath is everywhere". That will matter more in the future than it has in the past.
·         Some people came to talk about a lot of what I thought of as system-level considerations
o    Some people came to talk about their applications as a whole - for instance, including application-level data with media, as in WebRTC
o    Some people came to talk about synchronization between different devices in the same house watching the same program
o    Some people came to talk about mismatches between ingress, distributiion within a system, and egress, recognizing that using different protocols at every stage can have impacts on latency and jitter
·         There really are people who are willing to consider new protocols as part of using QUIC for their applications
o    The desired attributes included things like starting with scalability/ability to fan-out/ability to cache from the beginning of the protocol design
·
·         Peeling off "real-time interactive audio and video", which already has a home in AVTCORE, will help a lot.
o    Given that draft-engelbart-rtp-over-quic is already on the agenda for AVTCORE on Friday, that ship has already sailed.
·         I heard media ingest mentioned as a problem area several times
If we continue to discuss "Media Over QUIC", I have some suggestions for anyone who is participating in that discussion. Do the right thing, of course.
·         Agree on a set of things that are "what I'm trying to do", that are at the same level of abstraction. This, alone, would help a lot.
o    Spend more time on that, on the MOQ mailing list, before trying to have another meeting about what's necessary for elements in that set
·         Orthogonally with the "what I'm trying to do" set, it would be useful to agree on the characteristics I need for "what I'm trying to do" - for instance, requirements such as latency, jitter, one-way versus interactive applications, etc.
o    Again, this is a conversation that can happen on the MOQ mailing list.
·         Once we understand the various things people are trying to do, then focus on problems with QUIC
o    (unattributed quote: "identify what sucks in QUIC, and fix what sucks")
·         Asking for more help would have helped. Having James Gruessing jump in to assist me was great, but even between the two of us, we couldn't track what was being said at a mike, and what was being said in the chat, who had their hand up, what was being typed in the notes, and what was being typed in the spreadsheet (which really was a starting point).
Thank you, again, for your contributions to the conversation.

Best,

Spencer

(*) “Salsify: low-latency network video through tighter integration between a video codec and a transport protocol<https://urldefense.com/v3/__https:/www.usenix.org/conference/nsdi18/presentation/fouladi__;!!CQl3mcHX2A!VEHRR75iLquX5ZY4iUuG9NH6AYLuKUVw1pGmVTxddmGRTqGrT6fFzM8WwgsZ09d0YQ$>”, ANRP Talk, IETF 111<https://urldefense.com/v3/__https:/irtf.org/anrp/IETF111-ANRP-Fouladi.m4v__;!!CQl3mcHX2A!VEHRR75iLquX5ZY4iUuG9NH6AYLuKUVw1pGmVTxddmGRTqGrT6fFzM8WwgvJkNOTyQ$>.