Subject: Re: [MORG] SEARCH=INTHREAD

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 21 Oct 2008 16:11:26 +0200

Timo Sirainen writes:
> I can think of a couple of use cases for THREADROOT, but is THREADLEAF 
> actually useful for something?

I included it because Dave argued that it was a natural part of the 
parcel, which I think is a desirable property and sufficient 
justification as long as it's easy to implement.

Later I've found an example use case: Suppose you want to make sure 
threads aren't forgotten. So you do "THREADLEAF NOT FROM <me> UNKEYWORD 
considered" to find all unconsidered leaf messages, and for each of 
result, you either answer it or do "STORE +FLAGS considered".

Arnt
_______________________________________________
MORG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/morg
Note Well: http://www.ietf.org/maillist.html

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 21 Oct 2008 16:53:36 +0200

Dave Cridland writes:
> On Tue Oct 21 15:11:26 2008, Arnt Gulbrandsen wrote:
>> Timo Sirainen writes:
>>> I can think of a couple of use cases for THREADROOT, but is  
>>> THREADLEAF actually useful for something?
>>
> My thought was that if you find THREADROOTs, then logically you must  
> be able to find THREADLEAFs. This might be bogus thinking, of course.

I think it was good thinking, because it naturally led to support a use 
case we weren't aware of at the time.

>> threads aren't forgotten. So you do "THREADLEAF NOT FROM <me>  
>> UNKEYWORD considered" to find all unconsidered leaf messages, and  
>> for each of result, you either answer it or do "STORE +FLAGS  
>> considered".
>
> Oh, indeed, although I think you mean:
>
> THREADLEAF NOT FROM <me> UNKEYWORD considered UNANSWERED

No... if I reply the message will stop being a leaf, but it won't 
necessarily acquire an \answered flag.

Arnt

---

From: Dave Cridland <[email-masked]>
Date: Tue, 21 Oct 2008 15:49:45 +0100

You might do the reverse, too:

THREADLEAF FROM <me> TO <minion> UNKEYWORD done

might find all requests to your minion that your minion hadn't yet  
done.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade
_______________________________________________
MORG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/morg
Note Well: http://www.ietf.org/maillist.html