Subject: [MORG] Review of draft-ietf-morg-fuzzy-search-02.txt

From: Alexey Melnikov <[email-masked]>
Date: Wed, 28 Jul 2010 14:26:24 +0200

I think the document is basically fine, but I have a couple of minor 
comments:

In Section 4:
>    If server advertises the ESEARCH capability as defined by [ESEARCH <http://tools.ietf.org/html/draft-ietf-morg-fuzzy-search-02#ref-ESEARCH>],
>   
This is probably minor, but I would say "If server *also* advertises 
....". Because this is in addition to SEARCH=FUZZY.
>    the relevancy scores can be retrieved using the new RELEVANCY return
>    option for SEARCH:
In Section 8 (Security Considerations):
>    This document is believed not to have any security implications.
>   
This is not a proper text for this section, as I don't think this is 
true. It would be better to say that this document doesn't add 
additional security considerations not already present in 
implementations of ESEARCH, SORT, etc.

But maybe we should think harder about this in the case of this document.

---

From: Barry Leiba <[email-masked]>
Date: Wed, 28 Jul 2010 10:45:00 -0400

> This is not a proper text for this section, as I don't think this is true.
> It would be better to say that this document doesn't add additional security
> considerations not already present in implementations of ESEARCH, SORT, etc.

I agree.

> But maybe we should think harder about this in the case of this document.

We did think about it, and we think it's correct that it doesn't add
additional ones.

Did you have anything specific in mind?

Barry