Subject: [MORG] Support for PARTIAL return option when FUZZY+ESORT are advertised, but not CONTEXT=*

From: Alexey Melnikov <[email-masked]>
Date: Sun, 19 Dec 2010 12:31:29 +0000

Hi,
During discussion of the document with IESG the following question came up:

Should the PARTIAL return option be support when the server supports both FUZZY and ESORT extensions, but not CONTEXT=*? Currently PARTIAL is defined as a part of CONTEXT=SEARCH/CONTEXT=SORT. The argument for allowing PARTIAL with fuzzy searches is that fuzzy searches can return many results, so clients should be encouraged to use PARTIAL return option. However it is much easier for servers to just implement PARTIAL without implementing the rest of CONTEXT=SEARCH/CONTEXT=SORT.

Thoughts?

Alexey

---

From: Dave Cridland <[email-masked]>
Date: Mon, 20 Dec 2010 11:41:20 +0000

On Sun Dec 19 12:31:29 2010, Alexey Melnikov wrote:
> Should the PARTIAL return option be support when the server  
> supports both FUZZY and ESORT extensions, but not CONTEXT=*?  
> Currently PARTIAL is defined as a part of  
> CONTEXT=SEARCH/CONTEXT=SORT. The argument for allowing PARTIAL with  
> fuzzy searches is that fuzzy searches can return many results, so  
> clients should be encouraged to use PARTIAL return option. However  
> it is much easier for servers to just implement PARTIAL without  
> implementing the rest of CONTEXT=SEARCH/CONTEXT=SORT.
> 
> Thoughts?

It's a chunk of syntax, I've no particular feelings on how best to  
signal it's supported, so this would be fine by me.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade