Subject: [Mpls-interop] Tandem Connection

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 2 Oct 2008 20:32:52 +0200

Hi Loa,

In all documents (basically in OAM, survivability, etc.) we refer to
Tandem Connection (LSP segment or one or more PW segments)...

It is true that an LSP segment uses the MPLS construct of hierarchical,
nested LSP and an MS-PW segment uses the construct defined in PWE3 (MPLS
PW switching). Still don't we need to describe how to have 1:1 mapping
between an LSP and its TC, how to define a TC on an existing LSP without
disruption to the service, etc. 

Which document is supposed to define all TC related topics? Where is it
covered?

Best regards,

Nurit

----------------------------------------- 
Best regards, 

Nurit Sprecher

Nokia Siemens Networks GmbH & Co. KG 
Industry Environment

Senior Specialist, Carrier Ethernet Transport

3 Hanagar St. Neve Ne'eman B

45241 Hod Hasharon, Israel

Tel. +972 9 7751229

Mobile +972 54 2200954 
Email: [email-masked] <BLOCKED::mailto:[email-masked]> 

_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Fri, 3 Oct 2008 13:19:23 +0200

Hi,

Thinking more about this, I think we need to define TC as a new
architectural element in the MPLS-TP architecture document. Note that it
makes use of LSP hierarchies but this is a specific case of 1:1
relationship between TC and LSP/PW. 

MPLS-TP OAM framework should refer to it and extend it with TCME.
MPLS-TP survivability should refer to it as well (especially for the
case of Peer State Coordination (PSC) /  APS)  messages.  Maybe we'll
find some other uses for TC. 

In addition, I think that MPLS-TP OAM requirements should not refer to
TC. It should provide a requirement to manage and monitor the network in
different nested levels. TC is the architectural element that is used to
address this requirement. This should be described in the OAM framework
document. 

Best regards,

Nurit

________________________________

From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Sprecher, Nurit
(NSN - IL/Hod HaSharon)
Sent: Thursday, October 02, 2008 21:33
To: ext Loa Andersson
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: [Mpls-interop] Tandem Connection

Hi Loa,

Best regards,

Nurit

Nurit Sprecher

Tel. +972 9 7751229

Mobile +972 54 2200954

---

From: Martin Vigoureux <[email-masked]>
Date: Sun, 05 Oct 2008 18:09:19 +0200

Dear Nurit,

if you have in mind control (plane) procedures for the set-up and
maintenance of TCMEs then I guess this will fit in the control plane
docs and derivatives.
For the general definition, it will go into the framework doc, as
agreed with editors/authors.

regards,
martin

Sprecher, Nurit (NSN - IL/Hod HaSharon) a écrit :
> Tandem Connection (LSP segment or one or more PW segments)…
> 
> ------------------------------------------------------------------------
>

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Sun, 5 Oct 2008 18:47:36 +0200

Hi,
I think my proposal was to define it in the MPLS-TP architecture document......not in any other of the documents. Isn't it?
Can I see you second this?
Best regards,
Nurit

-----Original Message-----
From: ext Martin Vigoureux [mailto:[email-masked]] 
Sent: Sunday, October 05, 2008 18:09
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: Re: [Mpls-interop] Tandem Connection

Dear Nurit,

regards,
martin

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Sun, 5 Oct 2008 19:05:09 +0200

Hi Martin,
I am sorry but I was referring to the other e-mail I sent where I proposed to define it in the framework. Please see my other mail.
I am glad we share the same view.
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: Sunday, October 05, 2008 18:48
To: ext Martin Vigoureux
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: Re: [Mpls-interop] Tandem Connection

Hi,

-----Original Message-----
From: ext Martin Vigoureux [mailto:[email-masked]] 
Sent: Sunday, October 05, 2008 18:09
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: Re: [Mpls-interop] Tandem Connection

Dear Nurit,

regards,
martin

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 6 Oct 2008 14:05:16 +0100

Hi,

In my brief review of draft-busi-mpls-tp-oam-framework I complained about 
hte use of the term "Tandem Connection".

It seems that the definition we are now using in MPLS-TP allows an "LSP 
segment" to be monitored using OAM, and it appears that this definition is 
very different to the concept of a tandem connection in G.707.

Fundamental to this discussion is whether a hierarchical LSP must be used in 
order to monitor a piece of the end-to-end LSP between two MEPs. It appears 
that we are *not* requiring such a containment relationship and that we want 
to allow simple monitoring of LSP and PW segments without forcing additional 
label stacking.

If this is the case, I suggest that it would be really helpful to drop the 
use of the term "tandem connection" and just use "segment". This will avoid 
any further confusion.

Thanks,
Adrian
----- Original Message ----- 
From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
To: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>; "ext 
Martin Vigoureux" <[email-masked]>
Cc: "MEAD team" <[email-masked]>; "Weingarten,Yaacov (NSN - IL/Hod 
HaSharon)" <[email-masked]>
Sent: Sunday, October 05, 2008 6:05 PM
Subject: Re: [Mpls-interop] Tandem Connection

Hi Martin,
I am sorry but I was referring to the other e-mail I sent where I proposed 
to define it in the framework. Please see my other mail.
I am glad we share the same view.
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
On Behalf Of ext Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: Sunday, October 05, 2008 18:48
To: ext Martin Vigoureux
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: Re: [Mpls-interop] Tandem Connection

Hi,
I think my proposal was to define it in the MPLS-TP architecture 
document......not in any other of the documents. Isn't it?
Can I see you second this?
Best regards,
Nurit

-----Original Message-----
From: ext Martin Vigoureux [mailto:[email-masked]]
Sent: Sunday, October 05, 2008 18:09
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: MEAD team; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Subject: Re: [Mpls-interop] Tandem Connection

Dear Nurit,

regards,
martin

---

From: "BUSI ITALO" <[email-masked]>
Date: Mon, 13 Oct 2008 14:11:32 +0200

Adrian,

Could you clarify what is the difference between an "LSP segment to be monitored using OAM" and the tandem connection as defined in G.805 (G.707 describes mechanisms to implement TC in SDH networks)?

I might have missed something but my understanding, aligned with the outcome of the JWT activity, is that the only way to meet the requirements of tandem connection is to rely on LSP nesting with 1:1 relationship.

Have I missed something?

Thanks, Italo

> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Monday, October 06, 2008 3:05 PM
> To: Sprecher, Nurit (NSN - IL/Hod HaSharon); VIGOUREUX MARTIN
> Cc: MEAD team; Weingarten,Yaacov (NSN - IL/Hod HaSharon)
> [mailto:[email-masked]]

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 15 Oct 2008 05:01:44 +0200

Hi Adrian,

(I am on line again :-)

You wrote:

> In my brief review of draft-busi-mpls-tp-oam-framework I complained 
> about hte use of the term "Tandem Connection".
> 
> segment" to be monitored using OAM, and it appears that this definition 
> is very different to the concept of a tandem connection in G.707.

Are you refering the the definition of "segment" and "tandem
connection" or to the way the monitoring is performed?

> Fundamental to this discussion is whether a hierarchical LSP must be 
> used in order to monitor a piece of the end-to-end LSP between two MEPs. 
> It appears that we are *not* requiring such a containment relationship 
> and that we want to allow simple monitoring of LSP and PW segments 
> without forcing additional label stacking.

I agree. Label stacking has the disadvantage that in case TCM is
added to an existing LSP, the path is interupted.
Monitoring is easier to turn on (and off) in an existing LSP.

> If this is the case, I suggest that it would be really helpful to drop 
> the use of the term "tandem connection" and just use "segment". This 
> will avoid any further confusion.

I agree. Let's try to find a definition this week.

Cheers, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...
_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop