Subject: Re: [Mpls-interop] management interface for MPLS-TP

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 16 Oct 2008 17:31:41 +0100

OK

There is no "application level" management interface. LSPs are seen as the 
component building blocks from which such things as protected services can 
be constructed.

A
----- Original Message ----- 
From: "Lou Berger" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; "David Ward" <[email-masked]>; 
"Dan (Dan) Romascanu" <[email-masked]>; "Ron Bonica" 
<[email-masked]>; "Eric Gray" <[email-masked]>; "Lam, Hing-Kam 
((Kam))" <[email-masked]>; "MEAD team" <[email-masked]>; 
"Lou Berger" <[email-masked]>
Sent: Thursday, October 16, 2008 5:19 PM
Subject: Re: [Mpls-interop] management interface for MPLS-TP

> My fault - In discussion I  was refering to end-to-end provisioning 
> requests (e.g., including protection) not simple cross-connects...
>
> Lou
> ------Original Message------
> From: Adrian Farrel
> To: David Ward
> To: Dan \(Dan\) Romascanu
> To: Ron Bonica
> To: Eric Gray
> To: Lam, Hing-Kam \(\(Kam\)\)
> To: MEAD team
> To: Lou Berger
> ReplyTo: Adrian Farrel
> Sent: Oct 16, 2008 12:07 PM
> Subject: Re: [Mpls-interop] management interface for MPLS-TP
>
> Hi guys,
>
>> There are examples where a MIB is only used for operational data  (e.g.
>> GMPLS) vs configuration.
>
> Where did you get that idea?
>
> The GMPLS MIBs are suitable for use without a control plane.
>
> They are read/write and allow the configuration of cross-connects (i.e.
> LFIB) without requiring the use of a signaling protocol.
>
> Thanks,
> Adrian
>
>
>
> 

_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: David Ward <[email-masked]>
Date: Thu, 16 Oct 2008 11:45:31 -0500

This is a very interesting conversation but, I'd really like to hear  
from the Ops ADs on what is required from the IETF process.  
Protection schemes could be quite difficult to establish and we are  
traversing a razors edge between the ITU-T requirements of the  
information model and IETF.

-DWard

On Oct 16, 2008, at 11:31 AM, Adrian Farrel wrote:

> OK
>
> There is no "application level" management interface. LSPs are seen  
> as the component building blocks from which such things as  
> protected services can be constructed.
>
> A
> ----- Original Message ----- From: "Lou Berger" <[email-masked]>
> To: "Adrian Farrel" <[email-masked]>; "David Ward"  
> <[email-masked]>; "Dan (Dan) Romascanu" <[email-masked]>; "Ron  
> Bonica" <[email-masked]>; "Eric Gray"  
> <[email-masked]>; "Lam, Hing-Kam ((Kam))" <hklam@alcatel- 
> lucent.com>; "MEAD team" <[email-masked]>; "Lou Berger"  
> <[email-masked]>
>> My fault - In discussion I  was refering to end-to-end  
>> provisioning requests (e.g., including protection) not simple  
>> cross-connects...
>>
>> Lou

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 16 Oct 2008 12:48:13 -0400

Aren't the existing G/MPLS MIBs sufficient to handle this requirement?
And if not, can we not modify them?

    --Tom

---

From: Lou Berger <[email-masked]>
Date: Thu, 16 Oct 2008 13:00:03 -0400

>And if not, can we not modify them?

The discussion relates to if we need to define a *service* 
provisioning interface in the context of MPLS-TP (which we expect to 
be signaling using GMPLS).  The existing GMPLS MIBs act only on a 
single node/cross-connect level rather than as end-to-end LSP 
triggers.  (Service level provisioning has typically been done in a 
proprietary fashion, e.g., MIB/TL1/XML etc.)

The question comes down to: is the existing GMPLS management (and 
provisioning) support sufficient for MPLS-TP or do we also need an 
(end-to-end) service level provisioning interface?

Lou

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 16 Oct 2008 18:11:56 +0100

John asked me to number the control plane reqs to help him with his homework
assignment and Andy thought it might be useful to work from that copy too so
see attached for it.

Ben

---

From: "Drake, John E" <[email-masked]>
Date: Thu, 16 Oct 2008 10:19:53 -0700

Dave,

The counter example is that we have been doing ITU related work (ASON)
for more than five years and we have never before been asked to provide
an information model for network management.  As Adrian points out,
everything has been done with MIBs.

So, in yesterday's discussion, the requirement for an information model
may have been one person's opinion rather than an ITU policy.

Thanks,

John 

>-----Original Message-----
>From: David Ward [mailto:[email-masked]] 
>Sent: Thursday, October 16, 2008 9:46 AM
>To: Adrian Farrel
>Cc: Dan (Dan) Romascanu; MEAD team
>This is a very interesting conversation but, I'd really like 
>to hear from the Ops ADs on what is required from the IETF process.  
>Protection schemes could be quite difficult to establish and 
>we are traversing a razors edge between the ITU-T requirements 
>of the information model and IETF.
>
>-DWard
>
>
>> There is no "application level" management interface. LSPs 
>are seen as 
>> the component building blocks from which such things as protected 
>> services can be constructed.
>>
>> A

---

From: David Ward <[email-masked]>
Date: Thu, 16 Oct 2008 12:28:04 -0500

John, Dan -

The point of the question is this:

Do we have to use a MIB for both operations and configuration or, can  
we use netconf for configuration/provisioning and still make it to  
PS? Manageability technology at the IETF is changing and I am trying  
to find out if we have any more or new options available.

Thanks

-DWard

---

From: "Drake, John E" <[email-masked]>
Date: Thu, 16 Oct 2008 10:34:14 -0700

Dave,

That was your original question.  I was responding to your follow-up
statement about the razor's edge and ITU information model.

Thanks,

John 

>Sent: Thursday, October 16, 2008 10:28 AM
>To: Drake, John E
>Cc: David Ward; Adrian Farrel; Dan (Dan) Romascanu; MEAD team; 
>Lou Berger; Ron Bonica
>Do we have to use a MIB for both operations and configuration 
>or, can we use netconf for configuration/provisioning and 
>still make it to PS? Manageability technology at the IETF is 
>changing and I am trying to find out if we have any more or 
>new options available.
>
>Thanks
>
>
>
>-DWard
>
>> for more than five years and we have never before been asked to 
>> provide an information model for network management.  As 
>Adrian points 
>> out, everything has been done with MIBs.
>>
>> So, in yesterday's discussion, the requirement for an information 
>> model may have been one person's opinion rather than an ITU policy.
>>
>> Thanks,
>>
>> John
>>
>provisioning

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 16 Oct 2008 19:15:50 +0100

Thanks Ben,

These all look pretty achievable with what we already have.

A couple of questions embedded.

Cheers,
Adrian
----- Original Message ----- 
From: "Ben Niven-Jenkins" <[email-masked]>
To: "MEAD team" <[email-masked]>
Sent: Thursday, October 16, 2008 6:11 PM
Subject: [Mpls-interop] Draft-jenkins with numbered CP requirements

> assignment and Andy thought it might be useful to work from that copy too 

--------------------------------------------------------------------------------