Subject: [Mpls-interop] MPLS-TP OAM requirements - AIS/LockNotif - Can MIPs send "usolicited" OAM messages ?

From: Martin Vigoureux <[email-masked]>
Date: Sun, 03 May 2009 20:24:52 +0200

All,

as part of the discussion on AIS/Lock Notification,
the server layer MEPs, detecting a fault/lock condition, should
inform (the MEPs of) the client layers relying on that
server layer and which are affected by the condition.

However as I understand it is not the MEP (sMEP) of the
server layer that sends a notification to the client layers
MEPs (cMEP) but the MIP (cMIP) of the client layer which
is hosted on the same node than the MEP (sMEP).
See the figure below (where the double dashed line is
an LSP, and the ~ line represents an LSP nested in the
other LSP.

+------+      +------+      +------+      +------+
|      |      |      |      | cMIP |~~~~~~| cMEP |
|      |------|      |------|  ^   |      |      |
|      |      |      |      |  |   |      |      |
|      |------|      |------|  |   |      |      |
|      |      |      |      | sMEP |      |      |
+------+      +------+      +------+      +------+

Therefore can MIPs send OAM messages without having priorly received one
or did I miss something?

regards,
-m

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 04 May 2009 01:14:06 +0200

Bonsoir Martin,

You wrote:

> |      |------|      |------| cMIP |~~~~~~| cMEP |
> |      |      |      |      |  ^   |      |      |
> |      |      |      |      |  |   |      |      |
> |      |      |      |      |  |   |      |      |
> |      |======|      |======| sMEP |      |      |

I modified the figure to align with what you wrote.

> Therefore can MIPs send OAM messages without having priorly received one

No, a MIP can only respond to messages it receives from a MEP
that has the same MEG level, i.e. exists in the same path.

In your figure the cMIP ignores messages sent by sMEP.

Cheers, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Martin Vigoureux <[email-masked]>
Date: Mon, 04 May 2009 11:41:21 +0200

Huub,

please see in-line.
regards,
-m

> I modified the figure to align with what you wrote.

[mvx] thx. In fact the double dashed line was already there
       but with quite some spacing between the top and bottom.
> In your figure the cMIP ignores messages sent by sMEP.

but then, how does a Lock condition of the lower LSP
is notified to cMEP?

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 04 May 2009 15:00:10 +0200

Hi Martin,

> please see in-line.

me too [hvh]

>       but with quite some spacing between the top and bottom.

[hvh] OK, tI had the impression that the upper line indicated
the client path/trail, and the lower the server path/trail

> but then, how does a Lock condition of the lower LSP

This is a consequent action performed in the normal
adaptation function between server and client layer.

Best reagrds, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: Martin Vigoureux <[email-masked]>
Date: Mon, 04 May 2009 15:43:06 +0200

Huub,

I am merging the two threads as they talk about the same point.
Please see below.

regards,
-m

> adaptation function between server and client layer.

and you also say (in the other thread):
[hvh] The definition used in ITU-T is:
MEG Intermediate Point (MIP) is an intermediate point in a MEG which
is capable of reacting to some OAM frames. A MIP does not initiate
OAM frames. A MIP takes no action on the transit packet flows.

and:
[hvh] the sink MEP of the server layer should inform the sink MEPs
of the client layer.

How can sMEP send any message to cMEP, they do not belong to the same
Maintenance Entity?
The only way I see for cMEP to be informed is that cMIP sends the
message and if so this contradicts the ITU definition because it does
this, as you say, as a consequent action performed in the normal 
adaptation function between server and client layer (which I read
as something different from receiving an OAM message).

---

From: George Swallow <[email-masked]>
Date: Mon, 04 May 2009 14:36:45 -0400

Huub -

I very much agree with Martin here.

In MPLS-TP the MEG level is not explicit.  It is inferred from the LSP the
OAM is received on.  In typical LSRs, a Server layer down event, e.g. The
failure of a link results in an "Interface Down Event".  When this occurs
all clients of that interface that have registered for the event would be
notified.  Further notification of peer entities is the responsibility of
those clients.

So to me it makes a great deal of sense to have the MEP serving the link
declare that the IF is down, and have the client MIPs be responsible for
sending any needed OAM messages regarding that event.

...George

On 5/4/09 9:43 AM, "Martin Vigoureux" <[email-masked]>
wrote:

> _______________________________________________
> Mpls-interop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 05 May 2009 00:03:02 +0200

Hello George,

> notified.  Further notification of peer entities is the responsibility of

I agree with this as well.

> sending any needed OAM messages regarding that event.

The notification of the "interface down event" should be
accomplished by inserting the OAM message (server failed)
in the adaptation function of the server layer MEP.

Regards, Huub.

---

From: "Malcolm Betts" <[email-masked]>
Date: Tue, 5 May 2009 09:46:02 -0400

Agree, see in line. 

Malcolm Betts
Nortel Networks
Phone: +1 613 763 7860 (ESN 393)
email: [email-masked]

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Monday, May 04, 2009 6:03 PM
To: George Swallow
Cc: [email-masked]
Subject: Re: [Mpls-interop] MPLS-TP OAM requirements - AIS/LockNotif -
Can MIPs send "usolicited" OAM messages ?

Hello George,

You wrote:

> In MPLS-TP the MEG level is not explicit.  It is inferred from the LSP

> the OAM is received on.  In typical LSRs, a Server layer down event, 
> e.g. The failure of a link results in an "Interface Down Event".  When

> this occurs all clients of that interface that have registered for the

> event would be notified.  Further notification of peer entities is the

> responsibility of those clients.

> So to me it makes a great deal of sense to have the MEP serving the 
> link declare that the IF is down, and have the client MIPs be 
> responsible for sending any needed OAM messages regarding that event.

The notification of the "interface down event" should be accomplished by
inserting the OAM message (server failed) in the adaptation function of
the server layer MEP.

MB> Not convinced that we need an OAM message, we do need a local
notification.

Regards, Huub.