Subject: [Mpls-interop] Reaction to a CV defect

From: "Malcolm Betts" <[email-masked]>
Date: Fri, 1 May 2009 15:32:58 -0400

To capture this requirement I suggest that: 
As proposed by Adrian, text for this requirement to section 2.2.3.  My
proposed text is:
"When a continuity verification defect is detected the capability to
shut down the defective PW, LSP or Section MUST be provided; that is the
capability to, stop user traffic being sent from the defective PW, LSP
or Section." 
Note that the section 2.2.1 includes requirements for the notification
of defects therefore they should not be repeated in the section.

Malcolm Betts
Nortel Networks
Phone: +1 613 763 7860 (ESN 393)
email: [email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 2 May 2009 18:08:07 +0100

Malcolm,

Not quite sure about the proposition:

> As proposed by Adrian, text for this requirement to section 2.2.3.
> My proposed text is:

"sent from" or "sent on"?

Pondering the passive voice again :-(
"is detected" by whom?
"MUST be provided by what"?

Try...
When a node detects a continuity verification defect, the protocol 
mechanisms MUST provide a way for the detecting node to shut down the 
defective PW, LSP, or Section; that is, the capability to stop user traffic 
being sent on the defective PW, LSP or Section.

A

---

From: Martin Vigoureux <[email-masked]>
Date: Sun, 03 May 2009 21:27:01 +0200

Malcolm,

I do not quite understand this.
By this requirement we are making some assumptions on what the
operator does in reaction to a CV defect and I do not believe
the document should make such assumptions.
We discussed during the call that we should not take any assumption
on the consequent actions taken.
Finally, the Lock function requirement is listed.
Therefore I believe we do not need that text in the draft.

regards,
-m

Malcolm Betts a écrit :
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Mpls-interop mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: "Malcolm Betts" <[email-masked]>
Date: Mon, 4 May 2009 08:31:26 -0400

Adrian,  

A small point, CV defects are only detected by the node at the receiving
end of the LSP.  Hence I suggested sent from vs sent on.

Apart from that small change I like your new text. So how about:

When a node detects a continuity verification defect, the protocol
mechanisms MUST provide a way for the detecting node to shut down the
defective PW, LSP, or Section; that is, the capability to stop user
traffic being sent from the defective PW, LSP or Section.

Malcolm Betts
Nortel Networks

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Saturday, May 02, 2009 1:08 PM
To: Betts, Malcolm (CAR:X632); [email-masked]
Subject: Re: [Mpls-interop] Reaction to a CV defect

Malcolm,

Not quite sure about the proposition:

> shut down the defective PW, LSP or Section MUST be provided; that is 
> the capability to, stop user traffic being sent from the defective PW,

> LSP or Section."

Try...
When a node detects a continuity verification defect, the protocol
mechanisms MUST provide a way for the detecting node to shut down the
defective PW, LSP, or Section; that is, the capability to stop user
traffic being sent on the defective PW, LSP or Section.

A

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 4 May 2009 13:41:38 +0100

I love prepositions.

I was trying
s/from/on/

I thought it was your intention to coordinate between the detector 
(receiver) and the data sender (hence "sent on")

"Sent from" may be what you intended, but if this is the case:
- the CV defect is detected at the receiver
- the "sent from" restriction is provided at the receiver
Therefore, there is no protocol requirement and we should delete this entire 
section.
That is, this is an implementation requirement talking about actions between 
internal components of an NE.

Thanks,
Adrian
----- Original Message ----- 
From: "Malcolm Betts" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>
Sent: Monday, May 04, 2009 1:31 PM
Subject: RE: [Mpls-interop] Reaction to a CV defect

Adrian,

Malcolm Betts
Nortel Networks

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Saturday, May 02, 2009 1:08 PM
To: Betts, Malcolm (CAR:X632); [email-masked]
Subject: Re: [Mpls-interop] Reaction to a CV defect

Malcolm,

Try...

A