Subject: [mpls-tp] R: discussion on ring protection in MPLS-TP

From: "Diego Caviglia" <[email-masked]>
Date: Fri, 29 Aug 2008 15:38:28 +0200

Ciao Alessandro,
   	                   I think you made a good point.

If, as stated in sveral documents, mpls-tp is going to replace sdh we
have to consider that most of the metro and metro core topology are ring
based.

Br 

Diego
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 29 Aug 2008 16:10:40 +0100

Hi Diego and Alessandro,

> have to consider that most of the metro and metro core topology are ring

I think that what Diego is saying is that we need to be able to deploy 
MPLS-TP in topologies that are ring shaped. That is where there is a set of 
routers with line-side order of two (and presumably the ability to add and 
drop data!) arranged in a ring.

No problem with that as it is just a special case of a mesh of routers.

I think that both Diego and Alessandro are implying that rapid recovery is 
needed in any MPLS-TP deployment. We can argue about how rapid, but there is 
clearly some desired upper bound for a particular grade of service.

But I am still struggling to understand why "ring protection" is a 
requirement. Surely that is one of a set of possible solutions. We can come 
on to discuss the benefits and costs of different solutions as a separate 
thread. Such a discussion will include the relative complexity of 
implementation and operation of various solutions.

So, just for now, can someone explain to me whether "ring protection" is a 
real requirement.

Cheers,
Adrian

---

From: "Eric Gray" <[email-masked]>
Date: Fri, 29 Aug 2008 10:43:11 -0500

Adrian,

	Possibly as a tangential observation, does it make any 
difference in your argument if it turns out to be the case 
that routers in a ring do not actually reduce to a special
case of a partial mesh of routers?

--
Eric Gray
Principal Engineer
Ericsson  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Friday, August 29, 2008 11:11 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] R: discussion on ring protection in MPLS-TP
> 
> Hi Diego and Alessandro,
> 
> > Ciao Alessandro,

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 29 Aug 2008 16:53:40 +0100

Yes, I think it might.

If there is special hardware out there for which add/drop packet technology 
makes sense then that would certainly make a difference.

But I suspect that these devices should not be called "routers."

A
----- Original Message ----- 
From: "Eric Gray" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Friday, August 29, 2008 4:43 PM
Subject: RE: [mpls-tp] R: discussion on ring protection in MPLS-TP

Adrian,

--
Eric Gray
Principal Engineer
Ericsson