Subject: Re: [mpls-tp] [mpls] poll to make draft-andersson-mpls-tp-process-03.txt a working group document

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 1 Jul 2009 07:09:05 -0400

I support this proposal, to record the process for posterity and serve as an
example for future joint projects.

Cheers,
Andy

On Tue, Jun 30, 2009 at 10:19 AM, Loa Andersson <[email-masked]> wrote:

> All,
>
> we have an individual draft, draft-andersson-mpls-tp-process-03.txt,
> that describes additions to the mpls working group process to allow
> ITU-T to give input on MPLS-TP Internet Drafts.
>
> It pretty much captures current practice, and from the start we had no
> intention to ever progress, but recently there has been comments that
> it would have a better and clearer sttus if it were a working group
> document.
>
> We have had no plans to ever make it an RFC, but it has been pointed
> out that it would be possible to publish as an Historical RFC. Whether
> we execute on that or not is not yet decided.
>
> Therefore, is is to start at two week poll on making
> draft-andersson-mpls-tp-process-03.txt an MPLS working group document.
>
> The poll ends on July 14.
>
> Please send your comments to the mpls-tp list.
>
>
> Loa Andersson
>
>
>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 01 Jul 2009 21:03:17 +0100

Support. Ben

On 30/06/2009 15:19, "Loa Andersson" <[email-masked]> wrote:

> Please

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 1 Jul 2009 17:16:08 -0400

Support.

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: "BRUNGARD, DEBORAH A, ATTLABS" <[email-masked]>
Date: Thu, 2 Jul 2009 09:21:45 -0400

Support-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Loa Andersson
Sent: Tuesday, June 30, 2009 10:20 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [CCAMP] poll to make draft-andersson-mpls-tp-process-03.txt a
working group document

All,

Please

-- 

Loa Andersson

Sr Strategy and Standards Manager    phone:  +46 10 717 52 13
Ericsson ///                                 +46 767 72 92 13

                                      email:  [email-masked]
                                              [email-masked]
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 2 Jul 2009 11:57:28 -0400

Support

Thanks,
Greg

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 2 Jul 2009 10:12:57 -0700

Support.

> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: Malcolm Betts <[email-masked]>
Date: Mon, 06 Jul 2009 09:18:04 -0400

Support

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Loa Andersson
> Subject: [mpls-tp] poll to make draft-andersson-mpls-tp-process-03.txt
> a working group document
> 
> All,
>

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 7 Jul 2009 17:55:04 +0200

I support this draft to become a WG draft.

I have the following comment I would like to see addressed in the next
version of the draft on Section 2.2.1, point 15.

If I understand correctly the added text, it is clarifying that the I-D
that is approved by ITU-T will be sent to IESG processing without any
technical change.

What is still not clear is what happens during the IESG processing and
before the I-D enters the RFC Editor Queue. AFAIK changes can be done in
this phase.

I think we need to ensure that any technical change done at this stage
is not impacting the acknoledgement given byt ITU-T in point (14a).

Thanks, Italo

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Loa Andersson
> Sent: Tuesday, June 30, 2009 4:20 PM
> Subject: [CCAMP] poll to make 
> draft-andersson-mpls-tp-process-03.txt a working group document
> 
> All,
>

---

From: Loa Andersson <[email-masked]>
Date: Tue, 07 Jul 2009 20:18:40 +0200

Italo,

the simple answer here is that this draft only covers the part of the
IETF document process.

We have done adaptations to allow proper ITU-T review of IETF documents.

I've no intention to do any adaptations to the IESG part of the process,
nor do I think this is necessary. The IESG process works such that if
there are technical changes these are referred back to the working
group.

/Loa

PS

Please note that this is a poll for making the document a working group
document, if one send comments on the content of the draft there is
always a risk that such comments fall between the chairs (no pun
intended).

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: David Sinicrope <[email-masked]>
Date: Mon, 13 Jul 2009 08:16:32 -0700

Support

On 6/30/09 10:19 AM, "Loa Andersson" <[email-masked]> wrote:

All,

Please

--

Loa Andersson

                                      email:  [email-masked]
                                              [email-masked]
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Eric Gray" <[email-masked]>
Date: Mon, 13 Jul 2009 12:45:47 -0500

Support. 

-----Original Message-----

All,

Please

-- 

Loa Andersson

---

From: "Eric Gray" <[email-masked]>
Date: Mon, 13 Jul 2009 12:47:49 -0500

+1

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Andrew G. Malis
Sent: Wednesday, July 01, 2009 7:09 AM
To: [email-masked]
Subject: Re: [mpls-tp] [mpls] poll to
makedraft-andersson-mpls-tp-process-03.txt a working group document

I support this proposal, to record the process for posterity and serve
as an example for future joint projects.

Cheers,
Andy

	All,
	
	we have an individual draft,
draft-andersson-mpls-tp-process-03.txt,
	that describes additions to the mpls working group process to
allow
	ITU-T to give input on MPLS-TP Internet Drafts.
	
	It pretty much captures current practice, and from the start we
had no
	intention to ever progress, but recently there has been comments
that
	it would have a better and clearer sttus if it were a working
group
	document.
	
	We have had no plans to ever make it an RFC, but it has been
pointed
	out that it would be possible to publish as an Historical RFC.
Whether
	we execute on that or not is not yet decided.
	
	Therefore, is is to start at two week poll on making
	draft-andersson-mpls-tp-process-03.txt an MPLS working group
document.

	Loa Andersson

---

From: "tom.petch" <[email-masked]>
Date: Tue, 14 Jul 2009 14:20:53 +0200

----- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: "BUSI ITALO" <[email-masked]>
Sent: Tuesday, July 07, 2009 8:18 PM

> there are technical changes these are referred back to the working

Although I now understand the intentions of this draft better, which renders
some of my earlier comments inappropriate, I still find it falling some way
short of what is needed.

After Working Group Last Call, in most IETF Working Groups, a document is
produced by a Document Shepherd, which may provoke further WG discussion and
perhaps another WG Last Call, an AD review, which may provoke further discussion
etc, an IETF Last Call, which may provoke further discussion etc and only then
does it go to the IESG, which may provoke further discussion etc.

I cannot understand from this draft where in this potential chain of events
' a request  for publication will be sent to the IESG (15).'
is meant to lie.

Furthermore, whereever this request is meant to lie, the I-D can still return to
the WG for a further WG Last Call which, as this process I-D stands, will NOT be
passed to the ITU-T no matter how substantive the changes now made.

With this in mind, I do not think this ready to be a WG I-D.

Tom Petch.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 14 Jul 2009 09:57:04 -0400

Tom,
The point of making this a WG draft isn't to endorse it as being perfect as
is, but rather to say that it should represent WG consensus rather than just
reflecting Loa's, Dave's, and Malcolm's individual opinions. As it stands,
if they don't like your suggestions for improvement, theydon't need to
incorporate them.  However, if it becomes a WG draft, it becomes easier to
get your suggestions in, assuming the WG agrees with them. And of course, it
doesn't become an RFC until it passes WG last call. So you should be in
favor of it becoming a WG draft!
BTW, I agree with you that the document would be improved by adding a
section 3.5 that documents that non-editorial changes could possibly occur
as a result of IESG review following the WG last call, and if that occurs,
there will be a second WG last call, and the document procedures will loop
back to section 3.4.
Cheers,
Andy

---

From: Malcolm Betts <[email-masked]>
Date: Tue, 14 Jul 2009 10:23:49 -0400

Andy,

I agree with your first point.  

On the second point - adding text.  This draft is only documenting the
enhancements/modifications to the normal IETF process that are applied
in the case of MPLS-TP documents.  My understanding is that what you
have described below (technical changes as a result of IESG review) and
returning it to the WG for a further last call is part of the "normal"
process.  Therefore it is not within the scope of this draft.  However,
if the majority agree I would have no objections to adding a note
describing this (important) part of the standard process for
completeness/clarity.

Malcolm 

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Andrew G. Malis
Sent: Tuesday, July 14, 2009 9:57 AM
To: tom.petch
Cc: BUSI ITALO; [email-masked]
Subject: Re: [mpls-tp] [CCAMP] poll to make
draft-andersson-mpls-tp-process-03.txt a working group document

Tom,

The point of making this a WG draft isn't to endorse it as being perfect
as is, but rather to say that it should represent WG consensus rather
than just reflecting Loa's, Dave's, and Malcolm's individual opinions.
As it stands, if they don't like your suggestions for improvement,
theydon't need to incorporate them.  However, if it becomes a WG draft,
it becomes easier to get your suggestions in, assuming the WG agrees
with them. And of course, it doesn't become an RFC until it passes WG
last call. So you should be in favor of it becoming a WG draft! 

BTW, I agree with you that the document would be improved by adding a
section 3.5 that documents that non-editorial changes could possibly
occur as a result of IESG review following the WG last call, and if that
occurs, there will be a second WG last call, and the document procedures
will loop back to section 3.4.

Cheers,

Andy

On Tue, Jul 14, 2009 at 8:20 AM, tom.petch <[email-masked]>
wrote:

----- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: "BUSI ITALO" <[email-masked]>
Sent: Tuesday, July 07, 2009 8:18 PM

> there are technical changes these are referred back to the working

Although I now understand the intentions of this draft better, which
renders
some of my earlier comments inappropriate, I still find it falling some
way
short of what is needed.

After Working Group Last Call, in most IETF Working Groups, a document
is
produced by a Document Shepherd, which may provoke further WG discussion
and
perhaps another WG Last Call, an AD review, which may provoke further
discussion
etc, an IETF Last Call, which may provoke further discussion etc and
only then
does it go to the IESG, which may provoke further discussion etc.

I cannot understand from this draft where in this potential chain of
events
' a request  for publication will be sent to the IESG (15).'
is meant to lie.

Furthermore, whereever this request is meant to lie, the I-D can still
return to
the WG for a further WG Last Call which, as this process I-D stands,
will NOT be
passed to the ITU-T no matter how substantive the changes now made.

Tom Petch.

---

From: Loa Andersson <[email-masked]>
Date: Tue, 14 Jul 2009 16:15:20 +0200

Andy and Tom,

the section 3.5 would be part of the process when the IESG has revision
control.

My take has been (and still is) that we (as a working group or group of
working groups) could document additions to the working process as long
as we don't break the existing working group process. I've tried to
limit the draft to that scope. An agreement within the working group
how we run our process with the new conditions that arises from the
cooperation with ITU-T.

Now if we start document process outside the scope of the working group,
then we would need to have either a IESG approval for that process or
even process the document to become an RFC.

I'd prefer to keep this a documentation of the working group process.

/Loa

Andrew G. Malis wrote:
> On Tue, Jul 14, 2009 at 8:20 AM, tom.petch <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     From: "Loa Andersson" <[email-masked] <mailto:[email-masked]>>
>     To: "BUSI ITALO" <[email-masked]
>     <mailto:[email-masked]>>
>     [email-masked] <mailto:[email-masked]>

--

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 14 Jul 2009 10:31:45 -0400

Loa,
As Malcolm pointed out (I think your two emails crossed in the mail) this is
part of the normal process. Tom's point is that it's unclear at present in
the draft whether or not a second WG last call and/or the changes made by
the IESG would be liaised to ITU-T for their review and comments. No changes
in the existing IETF process are being requested.
Cheers,
Andy

On Tue, Jul 14, 2009 at 10:15 AM, Loa Andersson <[email-masked]> wrote:

>> as is, but rather to say that it should represent WG consensus rather than
>> just reflecting Loa's, Dave's, and Malcolm's individual opinions. As it
>> stands, if they don't like your suggestions for improvement, theydon't need
>> to incorporate them.  However, if it becomes a WG draft, it becomes easier
>> to get your suggestions in, assuming the WG agrees with them. And of course,
>> it doesn't become an RFC until it passes WG last call. So you should be in
>> favor of it becoming a WG draft! BTW, I agree with you that the document
>> would be improved by adding a section 3.5 that documents that non-editorial
>> changes could possibly occur as a result of IESG review following the WG
>> last call, and if that occurs, there will be a second WG last call, and the
>> document procedures will loop back to section 3.4.
>> Cheers,
>> Andy
>>
>> On Tue, Jul 14, 2009 at 8:20 AM, tom.petch <[email-masked]<mailto:
>> [email-masked]>> wrote:
>>

---

From: "tom.petch" <[email-masked]>
Date: Tue, 14 Jul 2009 16:44:15 +0200

----- Original Message -----
From: "Andrew G. Malis" <[email-masked]>
To: "Loa Andersson" <[email-masked]>
Cc: "tom.petch" <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 14, 2009 4:31 PM

> in the existing IETF process are being requested.

Yes, and I would also include further WG Last Calls which result from an IETF
Last Call, or from comments from Security, GenArt and Transport Directorates.
These can result in substantial changes; do they get passed to ITU-T for
approval?

Tom Petch

ps I am assuming the IETF Last Calls happen for these I-Ds.

><snip>

---

From: "tom.petch" <[email-masked]>
Date: Tue, 14 Jul 2009 17:26:17 +0200

----- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: "Andrew G. Malis" <[email-masked]>
Cc: "tom.petch" <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 14, 2009 4:15 PM

> working groups)

Um.  mpls-tp has a mailing list for discussion but is not a Working Group, of
the IETF or anything else; yes?

I had thought that mpls-tp was a Working Group, looked for a Charter, found
there wasn't one, looked for a slot in an IETF agenda, no joy and have now
worked out that it is not a Working Group per se.

This does make a difference to the interpretation of this process draft, which
makes many references to Working Groups so I think that this point needs
spelling out in it.

Tom Petch
<snip>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 18 Jul 2009 21:59:20 +0100

Hi,

Since the thread appears to have died down (with the consensus call for 
adoption) I just wanted to chime in on a couple of matters of process.

Tom responded to Loa...

> makes many references to Working Groups so I think that this point needs

So, what is happening is that it has been recognised that MPLS-TP is a topic 
that spans multiple working groups. It was decided to not charter a separate 
working group because the overlap was considerable. However, a separate 
mailing list was created because:
- It meant that all of the work could be followed in one place
  without having to monitor three mailing lists.
- It allows people in the relevant WGs who are not
  interested in MPLS-TP to avoind being swamped.

We (the ADs and chairs) agreed that consensus calls should be made across 
all of the relevant working groups, but judged only on the MPLS-TP mailing 
list.

When an I-D is adtoped as a working group document, it is adopted by a 
specific working group (in this case by the MPLS working group).

Tom also wrote:

> is produced by a Document Shepherd, which may provoke further WG
> discussion and perhaps another WG Last Call, an AD review, which may
> provoke further discussion etc, an IETF Last Call, which may provoke 
> further
> discussion etc and only then does it go to the IESG, which may provoke
> further discussion etc.

I think you are slightly out with this.
After WG last call, the I-D is updated to address the WG comments.The WG 
chiars then make a judgement on whether a further WG last call is needed. 
Only once this cycle has completed does the Document Shepherd get involved. 
Her job is simply to perform the write-up for the AD.

Cheers,
Adrian

---

From: "tom.petch" <[email-masked]>
Date: Wed, 22 Jul 2009 18:22:33 +0200

----- Original Message -----
From: "Adrian Farrel" <[email-masked]>
To: "tom.petch" <[email-masked]>; "Loa Andersson" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, July 18, 2009 10:59 PM
Subject: Re: poll to makedraft-andersson-mpls-tp-process-03.txt a working group
document

> specific working group (in this case by the MPLS working group).

I think that more of this needs spelling out in the process document (once the
process allows updates to occur:-).

I had gathered most of it but only at the time of IETF74, despite
having joined this list at the start (and being already on, eg, MPLS and CCAMP
lists). I had failed to understand parts of the process document - as some of my
comments showed - through ignorance of the nature of 'mpls-tp' within the IETF.

And ...

> Her job is simply to perform the write-up for the AD.

... yes; and I have seen the write-up by a Document Shepherd posted to a list
and cause a discussion that questioned whether or not the I-D should proceed to
become an RFC at all: these things happen:-)

The generic issue, which the process I-D does not seem to be clear on, is
whether, when an I-D is returned to a WG for further revision, perhaps further
Working Last Calls, the ITU-T still receives the same liaisons and opportunities
to accept or reject the changes.

Again, something to raise when the I-D re-appears.

Tom Petch

---

From: "BUSI ITALO" <[email-masked]>
Date: Wed, 22 Jul 2009 23:48:52 +0200

Adrian,

Thanks for the clarification.

I think that the issue went "dormant" because of other discussions ...

I apologize if the question appears naïve from a newcomers, but the process seems quite clear to me up to the step 15 (as numbered in the draft).
Your mail has clarified it further up to the point the Document Shepherd gets involved.

What is still not clear, is what happens to the technical content of the draft after that point until the RFC is published.

>From the mail discussion, I understood that if any technical change is done during this phase, the document is sent back to the WG and another WG LC is initiated.

If my understanding is correct, I think that a note clarifying this point would achieve two goals:

1) improve the clarity of the document

2) justify why there is no need to update the IETF process after step 15 to allow ITU-T review of the MPLS-TP drafts

Italo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> To: tom.petch; Loa Andersson
> Cc: [email-masked]
> Subject: Re: [mpls-tp] poll to 
> makedraft-andersson-mpls-tp-process-03.txt aworking group document
> 
> Hi,
> 
> > Um.  mpls-tp has a mailing list for discussion but is not a 
> Working Group, 
> > of
> > I had thought that mpls-tp was a Working Group, looked for 
> a Charter, 
> > found
> > This does make a difference to the interpretation of this 
> process draft, 
> > which

---

From: "Rolf Winter" <[email-masked]>
Date: Thu, 23 Jul 2009 09:15:59 +0200

Hi,

There is an alternative for this draft I believe, at least for its content. The IAB seems to be in love with how the whole MPLS-TP process is working (http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful). Good for them but they fail to mention how the overall process is working in practice. I'd propose to merge the two. I fail to see why we need a document that praises the process and another one describing it.

Best,

	Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> Behalf Of tom.petch
> Sent: Mittwoch, 22. Juli 2009 18:23
> To: Adrian Farrel; Loa Andersson
> Cc: [email-masked]
> Subject: Re: [mpls-tp] poll to makedraft-andersson-mpls-tp-process-
> 03.txt aworking group document
> 
> > > Um.  mpls-tp has a mailing list for discussion but is not a Working
> Group,
> > > of
> > > I had thought that mpls-tp was a Working Group, looked for a
> Charter,
> > > found
> > > This does make a difference to the interpretation of this process
> draft,
> > > which

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 23 Jul 2009 09:39:59 +0200

Hi,
As I see it, the intention of the two documents is totally different and
I can see NO reason to merge them.
The IAB document, discusses the necessity in coordination in general.
They use a case study as an important example for the harm that could be
created because of miss-coordination. I think this document is extremely
important and can serve the Industry the best. 
The intention of the second document is to present the particular
development process of the MPLS-TP documents. This is required because
the work of the MPLS-TP documents is a joint IETF/ITU-T effort. 
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Rolf Winter
Sent: Thursday, July 23, 2009 10:16 AM
To: tom.petch; Adrian Farrel; Loa Andersson
Cc: [email-masked]
Subject: Re: [mpls-tp] poll to
makedraft-andersson-mpls-tp-process-03.txtaworking group document

Hi,

There is an alternative for this draft I believe, at least for its
content. The IAB seems to be in love with how the whole MPLS-TP process
is working
(http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful). Good for
them but they fail to mention how the overall process is working in
practice. I'd propose to merge the two. I fail to see why we need a
document that praises the process and another one describing it.

Best,

	Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
London W3 6BL | Registered in England 2832014 

> > > Um.  mpls-tp has a mailing list for discussion but is not a
Working
> > After WG last call, the I-D is updated to address the WG
comments.The
> WG

---

From: "Rolf Winter" <[email-masked]>
Date: Thu, 23 Jul 2009 10:24:02 +0200

But you have seen that it might directly become a historical RFC, right :) Ok, I see both your and Nurit's point. But then the IAB draft seems to me to really have a trivial message which is: "If you work on the same thing talk to each other". Which is probably fine. I concur.

	Rolf

> From: Huub van Helvoort [mailto:[email-masked]]
> Sent: Donnerstag, 23. Juli 2009 10:04
> To: Rolf Winter
> Cc: [email-masked]
> Hi Rolf,
> You wrote:
> > content. The IAB seems to be in love with how the whole MPLS-TP
> > process is working
> > (http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful). Good
> > for them but they fail to mention how the overall process is working
> > in practice. I'd propose to merge the two. I fail to see why we need
> > a document that praises the process and another one describing it.
> 
> I do not agree with you, the draft above is a hysterical document
> describing what happened before the JWT was created, and
> draft-andersson-mpls-tp-process describes the current process as
> agreed by the JWT.
> We should concentrate on current mode of operation and not waste
> precious time on history.
> 
> Regards, Huub.
> 
> --
> ================================================================
> Always remember that you are unique...just like everyone else...

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 23 Jul 2009 10:50:06 +0200

Hi,
Surprisingly, although it should be trivial, it was not trivial for the
case study, T-MPLS. This is a fact. That is why it is extremely
important to have such a document and indicates the harm that may be
created. 
And I agree with Huub, now we should focus on a good conceptual work.
Best regards,
Nurit

-----Original Message-----
Sent: Thursday, July 23, 2009 11:24 AM
To: [email-masked]

But you have seen that it might directly become a historical RFC, right
:) Ok, I see both your and Nurit's point. But then the IAB draft seems
to me to really have a trivial message which is: "If you work on the
same thing talk to each other". Which is probably fine. I concur.

	Rolf

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 23 Jul 2009 10:03:46 +0200

Hi Rolf,

Regards, Huub.

---

From: "BUSI ITALO" <[email-masked]>
Date: Thu, 23 Jul 2009 11:14:25 +0200

The analysis of the T-MPLS case study in
http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful is
technically weak and incorrect.

I think this draft is a waste of time for the whole community.

Italo 

> [mailto:[email-masked]] On Behalf Of Sprecher, 
> Nurit (NSN - IL/Hod HaSharon)
> Sent: Thursday, July 23, 2009 10:50 AM
> To: ext Rolf Winter; [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls-tp] poll 
> tomakedraft-andersson-mpls-tp-process-03.txtaworking group document
> 
> Hi,

---

From: "BUSI ITALO" <[email-masked]>
Date: Thu, 23 Jul 2009 11:30:40 +0200

Nurit,

I have no time allocated for T-MPLS standardization.

Italo

> From: Sprecher, Nurit (NSN - IL/Hod HaSharon) 
> [mailto:[email-masked]] 
> Sent: Thursday, July 23, 2009 11:28 AM
> To: BUSI ITALO; ext Rolf Winter; [email-masked]
> Cc: [email-masked]
> Subject: RE: [mpls-tp] poll 
> If this is really the case, then I would recommend you to come with
> answers/resolution to the arguments described in the 
> document. This will
> serve the Industry as well. 
> Best regards,
> Nurit
> 
> From: ext BUSI ITALO [mailto:[email-masked]] 
> Sent: Thursday, July 23, 2009 12:14 PM
> To: Sprecher, Nurit (NSN - IL/Hod HaSharon); ext Rolf Winter;
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [mpls-tp] poll

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 23 Jul 2009 11:28:24 +0200

Italo, 
If this is really the case, then I would recommend you to come with
answers/resolution to the arguments described in the document. This will
serve the Industry as well. 
Best regards,
Nurit

-----Original Message-----
From: ext BUSI ITALO [mailto:[email-masked]] 
Sent: Thursday, July 23, 2009 12:14 PM
To: Sprecher, Nurit (NSN - IL/Hod HaSharon); ext Rolf Winter;
[email-masked]
Cc: [email-masked]

Italo

---

From: Loa Andersson <[email-masked]>
Date: Thu, 23 Jul 2009 12:49:57 +0200

All,

I don't if this is the right venue for this discussion, but if you want
to continue please change subject line when you changed subject!

/Loa

--

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 23 Jul 2009 12:53:54 +0100

Hi,

The correct place for this discussion is not here.

draft-iab-mpls-tp-uncoord-harmful is an IAB document and if you want to 
change what it says you need to discuss it with the IAB. Discussions on this 
list will have zero impact on the document.

I believe (having discussed this work with the IAB) that the issue they are 
trying to address is about the future. They want to ensure that future 
protocol development of overlapping or identical protocol families is 
coordinated between SDOs. Part of ensuring that is to show what might go 
wrong. Another part is to show how the issue can be avoided.

Adrian
----- Original Message ----- 
From: "Rolf Winter" <[email-masked]>
To: "tom.petch" <[email-masked]>; "Adrian Farrel" 
<[email-masked]>; "Loa Andersson" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 23, 2009 8:15 AM
Subject: RE: [mpls-tp] poll to makedraft-andersson-mpls-tp-process-03.txt 
aworking group document

Hi,

There is an alternative for this draft I believe, at least for its content. 
The IAB seems to be in love with how the whole MPLS-TP process is working 
(http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful). Good for 
them but they fail to mention how the overall process is working in 
practice. I'd propose to merge the two. I fail to see why we need a document 
that praises the process and another one describing it.

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London 
W3 6BL | Registered in England 2832014

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 23 Jul 2009 09:14:39 -0400

[email-masked] is the proper list for open discussion of
draft-iab-mpls-tp-uncoord-harmful (but please also cc: the iab list).
[email-masked] is the proper place for private comments to the IAB on
this draft (or any other topic, for that matter).

Thanks,
Andy

On Thu, Jul 23, 2009 at 7:53 AM, Adrian Farrel <[email-masked]> wrote:
> draft-iab-mpls-tp-uncoord-harmful is an IAB document and if you want to change what it says you need to discuss it with the IAB. Discussions on this list will have zero impact on the document.
>
> I believe (having discussed this work with the IAB) that the issue they are trying to address is about the future. They want to ensure that future protocol development of overlapping or identical protocol families is coordinated between SDOs. Part of ensuring that is to show what might go wrong. Another part is to show how the issue can be avoided.
>
> Adrian

---

From: "tom.petch" <[email-masked]>
Date: Thu, 23 Jul 2009 18:23:48 +0200

----- Original Message -----
From: "BUSI ITALO" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; "tom.petch" <[email-masked]>;
"Loa Andersson" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, July 22, 2009 11:48 PM

Adrian,

I apologize if the question appears naïve from a newcomers, but the process
seems quite clear to me up to the step 15 (as numbered in the draft).
Your mail has clarified it further up to the point the Document Shepherd gets
involved.

What is still not clear, is what happens to the technical content of the draft
after that point until the RFC is published.

>From the mail discussion, I understood that if any technical change is done
during this phase, the document is sent back to the WG and another WG LC is
initiated.

<tp>
Italo

I am afraid that this is not that well defined within the IETF.  I have seen
substantial/substantive changes made at
- Document Shepherd stage
- AD review
- IETF Last Call
- IESG Review
in each case after a Working Group Last Call that resolved all outstanding
issues prior to a request for publication.  Changes also happen at the Author48
stage but these tend not to be substantive, rather clarity, layout, editorial.

I have seen these because they have then been brought back to a Working Group
list for review, sometimes as a further WG Last Call, sometimes as a Last Call
on one specific point only (eg we now have an IPR claim; do we abandon the
document or proceed?:-(, sometimes as a less formal process with a rough
consensus declared, sometimes not even that.

It all depends on the chairs of the WG and on input from ADs and IESG.  So you
might see different behaviour for, say, a CCAMP document as opposed to
PWE3 one.

This I-D allows us to nail this down more precisely for mpls-tp documents, or
not to do so, as we will, and to leave it up to the WG chairs and ADs to do as
they will.

Because liaisons to and approval of the ITU-T may be involved, stages 13/14 ,
I think that it should be nailed down. But hey, this is the IETF, so rough
consensus, as declared by the Working Group Chairs, will prevail.

Tom Petch
</tp>

If my understanding is correct, I think that a note clarifying this point would
achieve two goals:

2) justify why there is no need to update the IETF process after step 15 to
allow ITU-T review of the MPLS-TP drafts

Italo

<snip>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 23 Jul 2009 22:37:30 +0100

Agreed.

Wording discussed with Italo and agreed. Passed on to Loa for suggested 
inclusion at the end of step 15.

A
----- Original Message ----- 
From: "tom.petch" <[email-masked]>
To: "BUSI ITALO" <[email-masked]>; "Adrian Farrel" 
<[email-masked]>; "Loa Andersson" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 23, 2009 5:23 PM
Subject: Re: [mpls-tp] poll to makedraft-andersson-mpls-tp-process-03.txt 
aworking group document

---

From: Ross Callon <[email-masked]>
Date: Fri, 24 Jul 2009 13:59:30 -0400

I think that this draft is absolutely essential.  However, I do agree that discussing it in long email threads would likely be a waste of time. 

I doubt that you want to hear my opinion about the amount of time and effort that the T-MPLS work in ITU forced on various IESG/IETF folks. 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of BUSI ITALO
Sent: 23 July 2009 05:14
To: Sprecher, Nurit (NSN - IL/Hod HaSharon); ext Rolf Winter; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls-tp] poll tomakedraft-andersson-mpls-tp-process-03.txtaworking group document

Italo

---

From: Huub van Helvoort <[email-masked]>
Date: Sat, 25 Jul 2009 07:24:57 +0200

(changed subject as asked for by Loa)

Hi Ross,

> I doubt that you want to hear my opinion about the amount of time and effort that the T-MPLS work in ITU forced on various IESG/IETF folks. 

You may want to add that to the draft, but then continue discussion
on [email-masked] and [email-masked] as Andy suggested.

Regards, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...