Subject: [mpls-tp] Questions on the MPLS-TP CV drafts

From: Masahiko Mizutani <[email-masked]>
Date: Tue, 07 Jul 2009 22:24:42 +0900

Dear All,

I'm looking at CV definition for MPLS-TP in both two individual drafts
(Internet Draft within MEAD team purview) and have questions on these docs.
- draft-fhbs-mpls-tp-cv-proactive-00
- draft-boutros-mpls-tp-cv-01
**
These documents specify different functionality and different frame
structure for MPLS-TP CV.
I think we need to have common understandings and need to discuss how to
specify this particular function.

Firstly, I have two questions.

Why we need two different CV functions that are used proactively and
used in normal operation? In my understanding, CV must be configured
proactively if we need to use it.
Is there any reasons for the separation?

I’d like to know the difference between CC and CV. Also, I don’t
understand well what MPLS-OAM is. I think we don’t have any consensus on
using these terms. In my opinion, “MPLS-TP OAM” might be better since we
focus on MPLS-Transport Profile.

Best Regards,
Masahiko

Masahiko Mizutani
Hitachi, Ltd., Telecommunication & Network Systems Division
Tel: +81 45 865 7003
+81 80 6575 7704
email: [email-masked]
<mailto:[email-masked]>

---

From: "Annamaria Fulignoli" <[email-masked]>
Date: Wed, 8 Jul 2009 08:41:12 +0200

Hi Masahiko,

for better understanding  MPLS-TP OAM required functionalities , you have to  refer to  http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-requirements-02; 
this document is in last call.

For better understanding  MPLS-TP OAM procedures that  satisfy  the MPLS-TP OAM requirements please refer to http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-00; 

If you wish more clarification or disagree with some  MPLS-TP  OAM requirements  and/or procedures,  you  should  address your comments to these documents respectively.
  
About the MPLS-TP OAM solutions at the moment there  are several drafts  as individual contribution. 

I can answer for the  draft-fhbs-mpls-tp-cv-proactive-00 that you mentioned;  the editors of this draft  has  analysed and proposed possible solutions ( Not the solution !)  for the tool that satisfies  the CC-CV proactive functionality ; the  procedure and behaviour of the proactive cc-cv functionality  is described in the draft-ietf-mpls-tp-oam-framework-00 as even clearly  reported  in the draft draft-fhbs-mpls-tp-cv-proactive-00 itself.  

The difference between CC and CV:  
- Continuity Check  monitors the integrity of the continuity of the path; Loss of Continuity is the triggered defect.

- Connectivity Verification monitors the integrity of the routing of the path between sink and source. The connectivity is supervised by attaching a unique identifier at the source. If the received identifier does not match this expected identifier, a connectivity defect occurs.  

Best Regards,
Annamaria

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Masahiko Mizutani
Sent: martedì 7 luglio 2009 15.25
To: [email-masked]
Subject: [mpls-tp] Questions on the MPLS-TP CV drafts

Dear All,

I'm looking at CV definition for MPLS-TP in both two individual drafts (Internet Draft within MEAD team purview) and have questions on these docs.
- draft-fhbs-mpls-tp-cv-proactive-00
- draft-boutros-mpls-tp-cv-01
**
These documents specify different functionality and different frame structure for MPLS-TP CV.
I think we need to have common understandings and need to discuss how to specify this particular function.

Why we need two different CV functions that are used proactively and used in normal operation? In my understanding, CV must be configured proactively if we need to use it.
Is there any reasons for the separation?

I'd like to know the difference between CC and CV. Also, I don't understand well what MPLS-OAM is. I think we don't have any consensus on using these terms. In my opinion, "MPLS-TP OAM" might be better since we focus on MPLS-Transport Profile.

Best Regards,
Masahiko

Masahiko Mizutani

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Masahiko Mizutani <[email-masked]>
Date: Mon, 13 Jul 2009 10:22:46 +0900

Dear Annamaria

Thank you very much for your answer and clarification.
On this topic I would like to have some more information for my 
understanding.

You said;
 > - Continuity Check monitors the integrity of the continuity of the 
path; Loss of Continuity is the triggered defect.

 > - Connectivity Verification monitors the integrity of the routing of 
the path between sink and source. The connectivity is supervised by 
attaching a unique identifier at the source. If the received identifier 
does not match this expected identifier, a connectivity defect occurs.

CC doesn’t care whether the LSP it traveled is correct or not. Therefore 
the reason we need to have CV for MPLS-TP is to check whether the LSP is 
configured correctly or not.
And for CV, we need some functionality at MIP for the inspection and (if 
necessary) label processing, whereas a MIP doesn’t respond to CC. Is it 
correct?

Additionally I would like to know the following. I’m happy if I could 
have your experts’ help.
- Why we need both tour tracing and CV? It seems to me those two are 
quite similar to each other.
- What do you mean by diagnostic test? It seems that this includes 
performance monitoring (PM). I think PM includes delay measurement and 
packet loss counting.. What is the reason you have picked up these 
functionalities as separate requirements?
- I think the Alarm reporting means Lock reporting, Remote Defect 
reporting, Packet Loss and Delay measurement as well. I don’t disagree 
with these requirement, but I would like to understand the difference of 
these functionalities.
- In section 1.1, LER, LSR, T-PE and S-PE mentioned here don’t appear 
after Section 2. Do we need to mention them?

Best Regards,
Masahiko

> .