Subject: [mpls-tp] wg last call on draft-ietf-mpls-tp-fault-03

From: Loa Andersson <[email-masked]>
Date: Thu, 03 Feb 2011 12:36:47 +0100

Working Group,

this is to start a four week working group last call
on "MPLS Fault Management OAM" (draft-ietf-mpls-tp-fault-03).

Please send comments to the [email-masked] mailing list.

This working group last call ends on February 28, 2011.

Loa, George and Ross

MPLS wg co-chairs

--

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: g67564 <[email-masked]>
Date: Thu, 10 Feb 2011 17:51:40 +0800

Dear authors

After read the document, I have a question about the FM massage procedure.

In the section 5.1, the third paragraph, it said "The message is then sent.
The message MUST be refreshed two more times at an interval of one second.
Further refreshes are sent according to the value of the refresh timer."  I
don't know why the refreshing massage must be first sent two more times in
one second and then sent as the refresh timer interval.  Is it ok if the
refreshing massage is sent only according to the value of the refresh timer?
If it is not, what problem may be introduced? Hope authors could explain it
for me.

In addition, figure 2 is about the fault management massage format, so I
think naming the figure" MPLS-TP fault Management Message Format " other
than" MPLS-TP OAM Message Format " is more suitable.

Best Regards
Xinchun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa
Andersson
Sent: Thursday, February 03, 2011 7:37 PM
To: [email-masked]; [email-masked]
Cc: Ross Callon; [email-masked]
Subject: [mpls] wg last call on draft-ietf-mpls-tp-fault-03

Working Group,

Loa, George and Ross

MPLS wg co-chairs

--

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Xinchun Guo <[email-masked]>
Date: Fri, 11 Feb 2011 09:39:22 +0800

Dear authors

Best Regards
Xinchun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Loa Andersson
Sent: Thursday, February 03, 2011 7:37 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [mpls-tp] wg last call on draft-ietf-mpls-tp-fault-03

Working Group,

Loa, George and Ross

MPLS wg co-chairs

--

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Xinchun Guo <[email-masked]>
Date: Fri, 11 Feb 2011 17:52:08 +0800

Other 3 edit comments, see below.

1.section 2.2, there is overlapping between the last sentence of the first
paragraph and the first sentence of the second paragraph about " The purpose
of the LKR message is to suppress alarms in the MPLS-TP layer network above
the level at which the defect occurs" . Simplify it will be more smart.

2.section 4.1.2, the first sentence" This TLV carries the Interface
Identifier as defined ......", "the Interface Identifier" should be "the
Global Identifier". right?

3. section 5.3, there are two "that" in the first sentence, one is
redundancy.

Regards
Xinchun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Xinchun Guo
Sent: Friday, February 11, 2011 9:39 AM
To: 'Loa Andersson'; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls-tp] wg last call on draft-ietf-mpls-tp-fault-03

Dear authors

Best Regards
Xinchun

-----Original Message-----

Working Group,

Loa, George and Ross

MPLS wg co-chairs

--

---

From: Xinchun Guo <[email-masked]>
Date: Mon, 14 Feb 2011 11:09:56 +0800

Hi authors and all

About this document, I have another question expect to be clarification. I
am not very clear about the specific application of Fault management
message.

In section 2 of this document, it said " Fault OAM messages are generated by
intermediate nodes where an LSP is switched".  Does it mean that the fault
message can only be used for alarm suppress of LSP layer?  Could not this
fault management function be used for PW layer, especially for the MS-PW
conditions.  Take the following hiberarchy scenario for example, PW1 and PW2
are two segments of the MS-PW which is client of the LSP layer.  if the
server layer of LSP fails, such as Link1, node2 will initiate AIS message
and sent it to LSP1 end point node3.  As MS-PW is client of LSP1, for this
condition, whether Node3 will further initiate Fault management message to
MS-PW end point Node4 to notify the failure of LSP1 to suppress alarm of the
end to end pw service.  IMO, Fault management function should cover these PW
conditions.

-                        MS-PW                   -
-                           +---------AIS/LKR-------------->>-
-<-----------------PW1-------------------->|-----------------PW2------------
>-
-              +----AIS/LKR---->>                     -
-<-------LSP1---------+-------------------><--------------LSP2--------------
->-
-              |AIS/LKR                            -
-<--- Link1---------->|<---
Link2------><--------Link3--------------------->-
Node1       Node2       Node3                Node4

Hope authors could clarify this point and detail the Fault function process
about PW scenarios in this document.

Best Regards
Xinchun

-----Original Message-----
Sent: Friday, February 11, 2011 5:52 PM

Regards
Xinchun

-----Original Message-----

Dear authors

Best Regards
Xinchun

-----Original Message-----

Working Group,

Loa, George and Ross

MPLS wg co-chairs

--

---

From: Yuji Tochio <[email-masked]>
Date: Mon, 28 Feb 2011 19:59:28 +0900

Hi,

Some comments

* Section 2.1 (, 2.1.1)
There are some use of fatal. Please clarify what fatal means.
And it is better to have the definition of this both for AIS
and for LDI

* Section 2.1.1
Use of protection seems to relate to the usage for LDI, differentiated
from AIS.
And "The setting of the LDI flag can be predetermined based
on the protection state If the Server Layer is protected...."means
that there is server layer protection scheme and this prederminnes
the usage of LDI.
This server layer protection scheme should be more clarified.
Is the server layer supposed to have 1:1?
How about 1+1?

And active MEP should be active Server MEP

This had been already pointed out in general by
http://www.ietf.org/mail-archive/web/mpls-tp/current/msg02793.html
(last part in that mail)

* Section 4
Please clarify the reception behavior when
- Msg type= reserved
- Msg type = LCK & L-flag set
(should be ignored and this should be described in 5.3)

* Section 5.1
Following sentence is unclear
"The message MUST be refreshed two more times at an interval
of one second."
I guess this implies that messages should be more than specified
at first second. Is this right? Does this apply to refresh timer is 1?

And in early review from ITU-T, it is proposed to remove the refresh timer
but it still remains. It is better to have the clear reason why it is needed.

Section 5.3
It says:
A message is considered a refresh if the message type and IF_ID match
an existing condition and the R-Flag is set to zero.

How about this case?
A-->B-->C-->D
D is receiving AIS or LDI with IF_ID = B. But another failure at C
happens D starts to receive LDI with IF_ID = C.
In this case, does D have to have two timers for B and C

...And it is confused that is "refresh(ed)"
It seems that following cases are used in common, but different places
- the receiver, MEP that refresh timer is in for reception process
- the transmitter (as fault detection by refresh timer)
- the transmitter (as message generation makes format refresh by over-written)

Regards,
Yuji

---

From: Maarten vissers <[email-masked]>
Date: Mon, 28 Feb 2011 12:48:55 +0000

Comment on LDI operation:

LSPs can be nested, and it is possible to have an LSP stack with e.g. five LSPs (A,B,C,D,E) as follows:

MEP1-----------------------(A)--------------------------MEP2
       MEP3----------(B)----------MEP4   MEP5--(C)---MEP6
             W.MEP7--(D)--W.MEP8
             P.MEP9--(E)--P.MEP10

When LSP(D) fails, LSP(B) and LSP(A) fail as well. 
W.MEP8, MEP4 and MEP2 will detect this failure and will insert AIS.
  - W.MEP8 can send AIS(L-flag=0).
  - MEP4 and MEP2 have no immediate knowledge of the 
    server layer/sublayer protection, and send AIS(L-flag=1). 

As there is protection present at a server (sub)layer and both working and protection paths are available before the fault occurs, MEP4 and MEP2 should have send AIS(L-flag=0) instead of AIS(L-flag=1).

How to control that MEP4 and MEP2 set the LDI flag to "clear" when working and protection paths are both available in this case?

Regards,
Maarten

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Mon, 28 Feb 2011 16:24:08 -0600

Hi Maarten-

  It's not my draft, so I can only respond as a possible implementor.
But what you ask seems like it is entirely an implementation issue, and
a pretty straightforward one at that.  A node (say, MEP3) could send
L=1, then send L=0 when it receieves L=0.  Or MEP3 could have been
configured with a priori knowledge that the failure of SPME B should be
L=0.  The draft alludes to this latter approach in section 2.1.1.  The
way I read the draft, the important thing is that a MEP advertises what
it knows; how it determines that is out of scope, IMO.

eric

> Of Maarten vissers
> Sent: Monday, February 28, 2011 7:49 AM
> To: [email-masked]
> LSPs can be nested, and it is possible to have an LSP stack with e.g.
five
> LSPs (A,B,C,D,E) as follows:
> 
> As there is protection present at a server (sub)layer and both working
and
> protection paths are available before the fault occurs, MEP4 and MEP2
> should have send AIS(L-flag=0) instead of AIS(L-flag=1).
> 
> How to control that MEP4 and MEP2 set the LDI flag to "clear" when
working
> and protection paths are both available in this case?
> 
> Regards,
> Maarten
> 
> 
> > this is to start a four week working group last call on "MPLS Fault
> > Management OAM" (draft-ietf-mpls-tp-fault-03).
> >
> > Loa Andersson email: [email-masked] Sr Strategy and
> > Standards Manager [email-masked] Ericsson Inc phone: +46 10 717 52 13
> > +46 767 72 92 13