Subject: [mpls-tp] MPLS-ACH-IP and MPLS-IP encapsulations for BFD in MPLS-TP

From: Mukund Mani <[email-masked]>
Date: Wed, 9 Feb 2011 11:57:12 +0530

Hello all

Had some questions on the usage of MPLS-ACH-IP and MPLS-IP encapsulations
for BFD in MPLS-TP

1.

MPLS-IP encapsulation is valid for MPLS-TP when IP addressing is being used.

(i.e in this case ACH will not be used).  If we follow the procedures
defined in BFD-base
drafts or BFD-MPLS, how exactly is it expected to achieve CV (connectivity
verification)
when ACH is not used in MPLS-TP? Is it acheived using Source IP comparison?

**

*Reference: *
**“*draft-ietf-mpls-tp-lsp-ping-bfd-procedures-01” mentions the following in
Section 3*

**

   [RFC5884] describes how BFD can be used for Continuity Check of MPLS

   LSPs.  The procedures described in [RFC5884] MUST be used when IP

   encapsulation is in use.  This section clarifies the usage of BFD in

   the context of MPLS-TP LSPs when it is not desirable to use IP

   encapsulation.  When using BFD over MPLS-TP LSPs, the BFD

   discriminator MUST either be signaled via LSP-Ping or be statically

   configured.  The BFD packets MUST be sent over ACH when IP

   encapsulation is not used.

2.
Is the usage of ACH TLV’s allowed when MPLS-ACH-IP encapsulation is used in
MPLS-TP?
Question arises from the fact that to do CV in MPLS-TP, MEP identification
(carrying MEP TLV)
is required and thus ACH needs to be included even if IP addressing is
available.
Else there should be a mechanism to do CV with IP (Ref: Question 1)

With Regards
Mukund

---

From: David Allan I <[email-masked]>
Date: Wed, 9 Feb 2011 02:55:46 -0500

HI Mikund:

    You asked

          MPLS-IP encapsulation is valid for MPLS-TP when IP addressing is being used.
          (i.e in this case ACH will not be used).  If we follow the procedures defined in BFD-base
          drafts or BFD-MPLS, how exactly is it expected to achieve CV (connectivity verification)
          when ACH is not used in MPLS-TP? Is it acheived using Source IP comparison?

    Yes,.see cc-cv-rdi draft 03 version section 3
A further artifact of IP encapsulation is that CV mis-connectivity defect detection can be performed by inferring MEP_ID on the basis of the combination of the source IP address and "my discriminator" fields.

2.
Is the usage of ACH TLV's allowed when MPLS-ACH-IP encapsulation is used in MPLS-TP?
Question arises from the fact that to do CV in MPLS-TP, MEP identification (carrying MEP TLV)
is required and thus ACH needs to be included even if IP addressing is available.
Else there should be a mechanism to do CV with IP (Ref: Question 1)

The CC-CV-RDI draft deprecated the use of the ACH TLV in favor of a trailing TLV for MEP ID, and we do not mandate the use of the trailing TLV when MPLS-ACH-IP encapsulation would be used (different code points).

I hope this helps
Dave

---

From: Mukund Mani <[email-masked]>
Date: Thu, 10 Feb 2011 18:39:36 +0530

Hi Dave

Not really clear on the first one.. Here we are not including trailing MEP
TLV. How do we do CV for the first BFD packet with MPLS-IP encap ?

With Regards
Mukund
On Wed, Feb 9, 2011 at 1:25 PM, David Allan I <[email-masked]>wrote:

>  *HI Mikund:*
> *    You asked*
> *    Yes,.see cc-cv-rdi draft 03 version section 3 *
>
> A further artifact of IP encapsulation is that CV mis-connectivity defect
> detection can be performed by inferring MEP_ID on the basis of the
> combination of the source IP address and "my discriminator" fields.
>
> **
>
> 2.
> *The CC-CV-RDI draft deprecated the use of the ACH TLV in favor of a
> trailing TLV for MEP ID, and we do not mandate the use of the trailing TLV
> when MPLS-ACH-IP encapsulation would be used (different code points).*
> **
> *I hope this helps*
> *Dave *
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>

---

From: David Allan I <[email-masked]>
Date: Thu, 10 Feb 2011 10:36:28 -0500

Hi Mikund:

If I understand your question correctly, you would need knowledge of the IP address of the source of the BFD packets.

cheers
Dave

________________________________
From: Mukund Mani [mailto:[email-masked]]
Sent: Thursday, February 10, 2011 5:10 AM
To: David Allan I
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] MPLS-ACH-IP and MPLS-IP encapsulations for BFD in MPLS-TP

Hi Dave

Not really clear on the first one.. Here we are not including trailing MEP TLV. How do we do CV for the first BFD packet with MPLS-IP encap ?

With Regards
Mukund
On Wed, Feb 9, 2011 at 1:25 PM, David Allan I <[email-masked]<mailto:[email-masked]>> wrote:
HI Mikund:

    You asked

2.

I hope this helps
Dave

---

From: Mukund Mani <[email-masked]>
Date: Thu, 17 Feb 2011 19:38:18 +0530

Hi Dave

Thanks for your response..

Just want to touch upon further on this: "knowledge of the IP address of the
source of the BFD packets".

We could ideally have the knowledge of source IP from the source IP address
of the established path over which BFD runs. But then should BFD (data
plane) actually depend on the source IP address of a control plane
established path, to do CV?

For instance, a tunnel (four tuple - Tunnel id, instance, ingress and egress
id) could have the ingress id as the router id.

BFD control packets on the other hand could have the source IP as the
interface IP address.

How do we actually achieve CV in such a case ?

OR is it expected (by say a configuration mechanism) that each peer knows
the source IP of BFD packets for every session?

With Regards
Mukund

On Thu, Feb 10, 2011 at 9:06 PM, David Allan I
<[email-masked]>wrote:

>  Hi Mikund:
>
> If I understand your question correctly, you would need knowledge of the IP
> address of the source of the BFD packets.
>
> cheers
> Dave
>
>  ------------------------------
> *From:* Mukund Mani [mailto:[email-masked]]
> *Sent:* Thursday, February 10, 2011 5:10 AM
> *To:* David Allan I
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [mpls-tp] MPLS-ACH-IP and MPLS-IP encapsulations for BFD in
> MPLS-TP
>
>   Hi Dave
>
>> Is the usage of ACH TLV’s allowed when MPLS-ACH-IP encapsulation is used
>> in MPLS-TP?