Subject: Re : --> Re: Label Space Partitioning

From: "Makarand Kulkarni (98307005) " <[email-masked]>
Date: Wed, 25 Aug 1999 12:03:15 +0530 (IST)

Hi Eric & all,
	I am restating the problem here :

 		     B
  		    / 144.16.100.23 / 12
		   /
 		  /
	   ---->A
		  \
		   \
		    \
		     C 144.16.100.21 / 12

	Here A has 2 peers. Let C initially do the address binding on a 
Label_Request made by A. Later A again makes a requests B for binding and 
B decides to bind same label (here 12), then what should A do  ? Eric, 
you pointed out that A and B keep each other informed about their free 
labels. But the problem is what happens if the non-overlapping label 
spaces are only the free ones ? Doesn't the situation sound like blocking 
in 2 - stage switching N/W's ? We can't bind a label even when we have 
lots of them free ! 

Regards
Makarand

---

From: Eric Gray <[email-masked]>
Date: Wed, 25 Aug 1999 07:41:13 -0400

Makarand, 

	Hmmm.  Thought I had answered this already.

	The scenario you describe is possibly very
likely if - for example - B and C are identical
implementations.  It also should not be important.

	When we talk about a 'per platform' label
space, we mean that the labels we 'bind' (in Label
Mappings we send) apply to any interface we have
in common with the peer to whom we have given the
label.  'Per platform' label space has nothing to
do with the labels that may be given to us.

	For one thing, by saying (during session
establishment) that we will use a 'per platform'
label space, we do not preclude the peer from
having an 'interface specific' label space.  See
the thread "Re: [Fwd: Doubt on Sessions]" started
on 7/13 by "pratima patil <[email-masked]>"
- in particular, note the example given on 7/14
(his time - Thu, 15 Jul 1999 08:55:39 +0900 - by
"Yoshihiro Ohba <[email-masked]>"):

> One example is:
>             Ether         
>     <A:0>------------<B:1>
>     <A:0>------------<B:2>
>              PPP

	Hence, 'per platform' label space is a
one-way concept - referring exclusively to the
labels that will be assigned by the LSR that is
using a 'per platform' label space.

	Is there a switch architecture that is
not able to - for example - use the same VPCI
on more than one output interface?  This should
NOT be the case.  Certainly in non ATM and non
Frame Relay cases, the 'generic' label should be
re-usable at different output interfaces...

---

From: Prasanna Mohanty <[email-masked]>
Date: Wed, 25 Aug 1999 10:04:12 -0700

Hi Mak,

This is a concept that already used in protocols like Q.931, if you have a
chance you can see the recommendation from CCITT. In there the call reference
value is also used the same way. But the value will be directional.

Hope it is a relevant pointer.

Thanks
Prasanna