Subject: question about processing the unknown TLV

From: "Myunghee Son" <[email-masked]>
Date: Fri, 6 Aug 1999 20:16:09 +0900

Hello, Bob Thomas.

On page 31 of the ldp-05, I have a question about TLV's U and F bit.
In this draft the F bit applies only when the U bit is set.
If U bit is set, the unknown TLV is silently ignored. => I'm confused this operation.

Let's consider following condition.
If U bit is set and F bit is set, the unknown TLV is forwarded according to this draft.
But how is processed the unknown TLV that is ignored?

Do you have other meaning of the word 'ignore'?

Regards,
myunghee.

---

From: Bob Thomas <[email-masked]>
Date: Sat, 07 Aug 1999 17:39:24 -0400

myunghee,

> In this draft the F bit applies only when the U bit is set.  If U
> bit is set, the unknown TLV is silently ignored. => I'm confused
> this operation.
>  
> Let's consider following condition.  If U bit is set and F bit is
> set, the unknown TLV is forwarded according to this draft.  But how
> is processed the unknown TLV that is ignored?
>  

There are 2 potential actions an LSR can take with respect to a 
TLV it receives in a message that it will forward to another LSR
as part of processing the messages:

  1.  It can can some local action as specified by the TLV.

  2.  It can forward the TLV to the next LSR.

When the U and F bits are set and the TLV is unknown to the LSR, the actions
it should take with respect to the TLV are:

  1.  No local action (= ignore, = local noop ) since the TLV is unknown.

  2.  Include the TLV in the forwarded message.

Bob