Subject: LSR vs. LER

From: "Aijaz Pathan" <[email-masked]>
Date: Thu, 12 Aug 1999 11:07:45 -0700

Hello,

Does anyone know if there are separate guidelines for implementing LDP State
machines for an LSR (Label Switched Router)  vs. an LER (Label Edge Router -
which has IP on one side and MPLS on the other). Would LER be a subset of
LSR ?

Thanks

- Aijaz

---

From: Eric Gray <[email-masked]>
Date: Thu, 12 Aug 1999 13:52:12 -0400

Aijaz,

	LER was a term coined (by Loa Andersson, if I 
remember correctly) to refer to an LSR that is capable 
of ingressing packets to an LSP (by pushing on a first
Label) and egressing packets from an LSP (by popping
off the last Label).

	In the Framework ID, this is similar to what is 
referred to as an MPLS edge node (a combination of 'MPLS 
ingress node' and 'MPLS egress node') - except that an
'MPLS edge node' may be unable to accept or produce L3
packets in an unlabeled form (if, for instance, it is 
an 'MPLS edge node' between ATM MPLS and Frame-Relay 
MPLS domains).  

	In that same ID, an LSR is an 'MPLS node' with 
L3 forwarding ability.

	So - according to the Framework ID - a device
can be an 'LSR' without being an 'MPLS edge node' if 
it can forward either using labels or using L3 but is 
unable to ingress or egress packets for an LSP (this 
might be an interior or 'core' LSR with some default
forwarding capability).

	An 'LER', as I understand the term, may be 
unable to forward L3 packets between an L3 interface
and an MPLS enabled interface if it does not have a
valid label to push onto the packet.

	Hence an 'LSR' and an 'LER' are not the same
thing necessarily and neither is precisely a subset
of the other.

	In my mind, these terms are primarily helpful 
in understanding specific device configurations.  Many
useful implementations will probably be configurable 
to play in any of these roles based on what cards (for 
example, interface cards) are installed.

	Hope this helps...