Subject: Re: Re : --> Re: Label Space Partitioning

From: Vibhavasu Vuppala <[email-masked]>
Date: Wed, 25 Aug 1999 08:36:08 -0400 (EDT)

Makarand,

There is NO problem if B and C bind the same label for
a FEC, it is perfectly fine. what problem do you see ?  
A and B do not keep each other informed of their
free labels. you seem to be assuming something that is 
misplaced. so can you give an elaborate example showing
the problem.

- vasu

% From [email-masked]  Wed Aug 25 02:30:10 1999
% 
% Hi Eric & all,
% 	I am restating the problem here :
% 
%                     
%  		     B
%   		    / 144.16.100.23 / 12
% 		   /
%  		  /
% 	   ---->A
% 		  \
% 		   \
% 		    \
% 		     C 144.16.100.21 / 12
% 
% 	Here A has 2 peers. Let C initially do the address binding on a 
% Label_Request made by A. Later A again makes a requests B for binding and 
% B decides to bind same label (here 12), then what should A do  ? Eric, 
% you pointed out that A and B keep each other informed about their free 
% labels. But the problem is what happens if the non-overlapping label 
% spaces are only the free ones ? Doesn't the situation sound like blocking 
% in 2 - stage switching N/W's ? We can't bind a label even when we have 
% lots of them free ! 
% 
% Regards
% Makarand
%

---

From: Shahram Davari <[email-masked]>
Date: Wed, 25 Aug 1999 09:23:03 -0700

Hi Mak,

"Per-Platform" Label binding is a one-way operation, which only applies to
the labels bound and distributed by the LSR that supports "Per-Platform"
label space. In your example (assuming A supports per-platform label space)
it only applies to the labels bound and distributed by A and therefore
applies to packets coming to A. While labeled packets leaving A are not part
of A's label space, they belong to either B or C label space.

I hope that helps.

Shahram Davari
PMC-Sierra Inc.

-----Original Message-----
From: Makarand Kulkarni (98307005) [mailto:[email-masked]]
Sent: August 24, 1999 11:33 PM
To: [email-masked]
Subject: Re : --> Re: Label Space Partitioning 

Hi Eric & all,
	I am restating the problem here :

 		     B
  		    / 144.16.100.23 / 12
		   /
 		  /
	   ---->A
		  \
		   \
		    \
		     C 144.16.100.21 / 12

	Here A has 2 peers. Let C initially do the address binding on a 
Label_Request made by A. Later A again makes a requests B for binding and 
B decides to bind same label (here 12), then what should A do  ? Eric, 
you pointed out that A and B keep each other informed about their free 
labels. But the problem is what happens if the non-overlapping label 
spaces are only the free ones ? Doesn't the situation sound like blocking 
in 2 - stage switching N/W's ? We can't bind a label even when we have 
lots of them free ! 

Regards
Makarand