Subject: RE: Partitioning of Label Space

From: [email-masked]
Date: Tue, 24 Aug 1999 09:20:17 +0200

A and B can use the same labels; they have only local (and unidirectional)
significance.
so, if I correctily understand your question, there is no clash.

Regards,
Juerg

> ----------
> From: 	Makarand Kulkarni (98307005)
> [SMTP:[email-masked]]
> Sent: 	Tuesday, August 24, 1999 8:04 AM
> To: 	[email-masked]
> Subject: 	Partitioning of Label Space
> 
> 
> I faced this problem when deciding label allocation -- >
> 
> 	Suppose you have 2 LDP peers A (down) and B (up). Both use per 
> platform label space. B has those labels unused which are in use by A 
> (assuming all the available labels are included in space). Now, if A asks 
> B to bind a label for some FEC, the label will clash with existing 
> bindings. What happens in such cases ? Is the connection refused ? If yes 
> then the connection is being refused inspite of labels being free. 
> 
> 	I don't know much about ATM but similar problem must exist even 
> there. How is it tacklef therw ? 
> 
> Regards
> Makarand
>

---

From: Eric Gray <[email-masked]>
Date: Tue, 24 Aug 1999 09:08:39 -0400

Juerg,

	There can be a clash if labels are 'depleted' in 
both directions when issued.  This can be the case with 
certain types of hardware, and is signaled in LDP during
session establishment.