Subject: regarding LDP notifications

From: Jhilmil Kochar <[email-masked]>
Date: Fri, 20 Aug 1999 12:23:44 +0530

Hi,
    I have a query regarding status codes in notification messages. I
cannot find a notification status code to suit these requirements
1. mandatory parameter missing in protocol message.
2. session FSM error (shutdown)
3. tcp related errors while receiving/ sending.
4. any other internal error which means that the session mesages cannot
be handled any more (shutdown).

    Shutdown seems ok in 2 and 4. But for 1 there should be a status
code of type malformed message. For 3 there can be a status code of type
tcp error.

Thanks in advance
Jhilmil

--

------------------------------
Jhilmil Kochar
Ficon Technology
E-mail:[email-masked]
Web: www.ficon-tech.com

---

From: Eric Gray <[email-masked]>
Date: Fri, 20 Aug 1999 09:56:09 -0400

Jhilmil,

	If a mandatory TLV is missing in a message, a
status code to this effect should be included.  I can
not find one that would be perfect among the present
set - though, if we had to use the current set, I'd
be inclined to use the 'fatal' status 'Bad Protocol
Version'.  Including a status code provides twice the
opportunities to inform the network administrator that 
there is a problem (I wouldn't expect implementations
which neglect to include a mandatory TLV in one message 
to turn it around and include the TLV in the next - 
that would be weird).

	I'm not sure what use a TCP error status code
is since most TCP errors I can think of at the moment
would result in the connection being dropped (so a 
status code would not be useful).