Subject: Resource Class in CR-LDP

From: Snigdho Bardalai <[email-masked]>
Date: Wed, 11 Aug 1999 13:31:10 -0500

Hi,

    Could someone please clarify what a "Resouce
    class" is with an example of its application.

    Can a resource class effect the path selection process,
    i.e to avoid a certain administrative group or keep
    the path within a certain administrative group.

    Thanks,
    Snigdho

--
Snigdho C. Bardalai
Phone - (972) 479-2951
Fax   - (972) 479-6070
Email - [email-masked]

---

From: "Don Fedyk" <[email-masked]>
Date: Wed, 11 Aug 1999 16:05:56 -0500

Snigdho 

I think you have the idea.

Resource Class is a general term for the attribute of a connection. There
are 
two sets of attributes one associated with the link the other associated
with 
the LSP setup. 

The simplest example is alluded to in the text of the CR-LPD draft. If you 
have a link that is you define as "blue" say RsCls[0] = 1.  Then if you have

a CR-LSP setup you can define it as "use blue" or "don't use blue".  Blue 
could have any agreed upon meaning. (e.g. Blue could mean Satellite link). 
We might choose to standardize some meanings and leave others open.

There are other things that can be accomplished by grouping bits together 
and having a group meaning. Three bits might represent a "rank" of a link 
with respect to other links. Then the rank of the LSP might have to be 
lower than or equal to the rank of the link.

Regards,
Don

		-----Original Message-----
		From:	Snigdho Bardalai
[mailto:[email-masked]]
		Sent:	Wednesday, August 11, 1999 2:31 PM
		To:	[email-masked]
		Subject:	Resource Class in CR-LDP

		Hi,

		    Thanks,
		    Snigdho