Subject: Partitioning of Label Space

From: "Makarand Kulkarni (98307005) " <[email-masked]>
Date: Tue, 24 Aug 1999 11:34:43 +0530 (IST)

I faced this problem when deciding label allocation -- >

	Suppose you have 2 LDP peers A (down) and B (up). Both use per 
platform label space. B has those labels unused which are in use by A 
(assuming all the available labels are included in space). Now, if A asks 
B to bind a label for some FEC, the label will clash with existing 
bindings. What happens in such cases ? Is the connection refused ? If yes 
then the connection is being refused inspite of labels being free. 

	I don't know much about ATM but similar problem must exist even 
there. How is it tacklef therw ? 

Regards
Makarand

---

From: Eric Gray <[email-masked]>
Date: Tue, 24 Aug 1999 09:30:45 -0400

Makarand,

	In every case, peers A and B both have been
given the information needed to be aware of each
other's in-use labels.  Whether they have elected to
keep this information is another issue.

	In the PPP, ATM and (I believe) FR case, the
interfaces connecting A and B are not also connected
to anything else.  This means the A cannot have in-use
Labels that B is not directly aware of, and vice versa.

	In the Ethernet case, labeled packets are L2
(real L2, not just MPLS Shim) encapsulated such that 
they are (meant to be) handled only by the LSR that
issued the Labels - thus it is irrelevant that B may
be using a Label issued by some other downstream LSR
that A would like to issue as well.

	Note that 'per platform label space' refers to
the labels that an LSR issues - NOT to the labels which
may be issued to it.  In other words, if -

    o   an LSR is using a per platform label space,
    o   has multiple interfaces as common links with a 
        peer LSR,
    o   issues a label to that peer and
    o   receives labeled packets using this label on
        any of the common link interfaces -

it must be prepared to forward these labeled packets in 
the same way, regardless of which of these common links
it receives the label on.

	The labels that an LSR is issued by different
downstream peers can and will have different meanings
irrespective of the specificity of the label spaces
in use.