Subject: RE: Last call on MPLS TE MIB

From: "Cucchiara, Joan" <[email-masked]>
Date: Wed, 17 Jan 2001 18:59:10 -0500

Hi Mani,

> Hello
> 
> It would help, as suggested in the mail to include 
> the CRLDP-Specific MIB objects in the TE MIB.
> 
> Currently we have them as Enterprise MIB objects 
> in our implementation and we can move to the 
> standard MIB if they are available there.
> 
> I have the following question/doubt for Joan.
> 
> 1) We have a field "flags" in the CRLDP Traffic
> Parameters TLV. This helps in conveying the
> set of negotiable parameters. The value of "Flags"
> being added as a configurable object will provide
> added flexibility. what do you suggest?

I agree with you that an ActiveFlags object would
be useful for CR-LDP.  If possible, would you 
be able to email what this object looked like in
your enterprise MIB?

Having actual implementation feedback is very useful
for MIB objects.  

> 
> 2) Do we need to use the value of the MIB object
> "mplsTunnelIncludeAnyAffinity" for the 
> "RsCls" field in Resource Class TLV?

This seems like a reasonable approach.  Are you
suggesting that the wording of the "mplsTunnelIncludeAnyAffinity"
object be enhanced to include CR-LDP's Resource Class TLV?

   Thanks, Joan

> 
> 
> thanks and best regards
> mani
> -----------------------------------------
> S.Manikantan
> Future Software Limited
> 480-481, Anna Salai, 
> Nandanam, Chennai, India.
> Zip (PIN CODE) : 600 035
> Phone          : 91-44-4330550
> Fax            : 91-44-4344157
> email          : [email-masked]
> -----------------------------------------
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Cucchiara, Joan
> Sent: Wednesday, 17 January 2001 4:30 AM
> To: [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]
> Cc: Cucchiara, Joan; [email-masked]'
> Subject: RE: Last call on MPLS TE MIB
> 
> 
> 
> Tom, Arun and Cheenu,
> 
> Shobhan Lakkapragada was involved in an implementation of
> CR-LDP and found that the following objects are needed 
> to fully support the CR-LDP protocol using the 
> MPLS TE MIB (draft-ietf-mpls-te-mib-05.txt).
> 
> Also, I have reviewed these objects and would like to
> see these added to MPLS TE MIB.  That way, the MPLS TE
> MIB could be used for both MPLS-RSVP and CR-LDP which
> is, we believe, the intent of the MIB, i.e. one MIB for
> both of the TE MPLS protocols, namely, MPLS-RSVP and
> CR-LDP.
> 
> We think that the addition of these objects to 
> the MPLS TE MIB would obviate the need for a 
> separate CR-LDP specific MIB since most of the objects
> in the MPLS TE MIB can be used for both protocols.
> 
> Please note, we have suggested where these objects be
> placed but this is certainly open for discussion.
> 
> Thanks.
> 
> - Joan and Shobhan
> 
> --------------
>  
> The following objects would fit in the mplsTunnelResourceEntry.
> These objects are important in order to fully utilize the 
> Traffic Parameters offered by CR-LDP.
> 
>         mplsTunnelResourceMeanBurstSize        MplsBurstSize,
>         mplsTunnelResourceExcessBurstSize      MplsBurstSize,
>         mplsTunnelResourceFrequency            Integer32,
>         mplsTunnelResourceWeight               Unsigned32
> 
>         mplsTunnelResourceMeanBurstSize OBJECT-TYPE
>              SYNTAX        MplsBurstSize
>              UNITS         "bytes"
>              MAX-ACCESS    read-create
>              STATUS        current
>              DESCRIPTION
>                  "The mean burst size in bytes."
> 
>         mplsTunnelResourceExcessBurstSize OBJECT-TYPE
>              SYNTAX        MplsBurstSize
>              UNITS         "bytes"
>              MAX-ACCESS    read-create
>              STATUS        current
>              DESCRIPTION
>                  "The Excess burst size in bytes."
>              REFERENCE
>                  "CR-LDP Specification, Section 4.3."
> 
>         mplsTunnelResourceFrequency  OBJECT-TYPE
>              SYNTAX        INTEGER {
>                                unspecified(0),
>                                frequent(1),
>                                veryFrequent(2),
>                            }
>              MAX-ACCESS    read-create
>              STATUS        current
>              DESCRIPTION
>                  "The granularity of the availability of 
> committed rate. "
>              REFERENCE
>                  "CR-LDP Specification, Section 4.3."
> 
>         mplsTunnelResourceWeight    OBJECT-TYPE
>              SYNTAX        Unsigned32(0..255)
>              MAX-ACCESS    read-create
>              STATUS        current
>              DESCRIPTION
>                  "The relative weight for using excess bandwidth
>                    above its committed rate.  The value of 0 means
>                    that weight is not applicable for the CR-LSP."
>              REFERENCE
>                  "CR-LDP Specification, Section 4.3."
> 
> 
>    
> 
> > -----Original Message-----
> > From: George Swallow [mailto:[email-masked]]
> > Sent: Friday, January 05, 2001 5:18 PM
> > To: [email-masked]
> > Subject: Last call on MPLS TE MIB
> > 
> > 
> > 
> > This message begins a workgroup last call on
> > draft-ietf-mpls-te-mib-05.txt, "MPLS Traffic Engineering Management
> > Information Base Using SMIv2".
> > 
> > The last call ends Jan 19, 5pm est.
> >                                
> > ...George
> > 
> > 
> ======================================================================
> > George Swallow       Cisco Systems                   (978) 244-8143
> >                      250 Apollo Drive
> >                      Chelmsford, Ma 01824
> > 
> > 
> > 
>

---

From: "Manikantan S" <[email-masked]>
Date: Thu, 18 Jan 2001 10:02:39 +0530

Hello Joan

#> Hello
#>
#> It would help, as suggested in the mail to include
#> the CRLDP-Specific MIB objects in the TE MIB.
#>
#> Currently we have them as Enterprise MIB objects
#> in our implementation and we can move to the
#> standard MIB if they are available there.
#>
#> I have the following question/doubt for Joan.
#>
#> 1) We have a field "flags" in the CRLDP Traffic
#> Parameters TLV. This helps in conveying the
#> set of negotiable parameters. The value of "Flags"
#> being added as a configurable object will provide
#> added flexibility. what do you suggest?
#
#I agree with you that an ActiveFlags object would
#be useful for CR-LDP.  If possible, would you
#be able to email what this object looked like in
#your enterprise MIB?
#
#Having actual implementation feedback is very useful
#for MIB objects.

I currently have the following definition in
the Enterprises MIB.

     fsMplsLdpCrlspTnlFlags INTEGER

     fsMplsLdpCrlspTnlFlags OBJECT-TYPE
        SYNTAX        INTEGER (0..63)
        MAX-ACCESS    read-create
        STATUS        current
        DESCRIPTION
            "The value of Flags conveyed as part of the Traffic Parameters
             during the establishment of the CRLSP. The Bit value
             indicates the set of Traffic parameters that are
             negotiable during the CRLSP setup."
        REFERENCE
            "Section 4.3, Constraint-Based LSP Setup using LDP, Jamoussi,
et.
             al, <draft-ietf-mpls-crldp-04.txt>, July 2000."
        DEFVAL        { 0 } -- Parameters not negotiable.

#>
#> 2) Do we need to use the value of the MIB object
#> "mplsTunnelIncludeAnyAffinity" for the
#> "RsCls" field in Resource Class TLV?
#
#This seems like a reasonable approach.  Are you
#suggesting that the wording of the "mplsTunnelIncludeAnyAffinity"
#object be enhanced to include CR-LDP's Resource Class TLV?

Yes. I feel it will be clear and very helpful.

Thanks and best regards
mani