Subject: RE: ERO and strict/loose subobject

From: John Sparr <[email-masked]>
Date: Wed, 3 Jan 2001 08:28:23 -0800 (PST)

Hi Bill,

Thanks for the comments.

I was still a little bit confused about the first
subobject in the ERO. Lets say the following example.

    A--A1--A2--A3--B--C

Assuming A is the sender node and B is the receiver
node, A1-A3 are the intermediate nodes. A creates an
ERO with the first subobj A's addr (loose) and second
subobj B's addr. When A sends Path msg with the ERO
towards B, what should A do to the ERO, it should
delete the first subobj (itself addr)? or send both
subobjs to B? I think A should delet the first subobj,
but if it is, it's no use to add the first subobj(
itself addr) at the beginning of creating ERO.

Please correct me.

Thanks in advance

Regards,

John

--- "Sanford, Bill" <[email-masked]> wrote:
> John, see the comments below:
> 
> > -----Original Message-----
> > From: John Sparr [mailto:[email-masked]]
> > Sent: Tuesday, January 02, 2001 3:43 PM
> > To: [email-masked]
> > Subject: ERO and strict/loose subobject
> > 
> > 
> > Hi all,
> > 
> > One question about the ERO object in RSVP:
> > 
> > Assuming there is a sender node and it creates an
> ERO.
> > Should the ERO include the ip address of sender
> > itself? If yes, why?
> 
> Lets say the ERO is not set with the sender node and
> is started on the next
> hop.  How does the LSP you want to set up know that
> there are no other hops
> in between the sender and next hop?  If you don't
> have the senders ip
> address as the first subobject, there isn't any way
> to set the properties of
> the link to the next hop to loose or strict.
> 
> In the implementation in
> draft-ietf-mpls-rsvp-lsp-tunnel-07.txt, if you
> didn't have the sender address in the ERO, it would
> immediately error with
> "Bad EXPLICIT_ROUTE object" error.
> 
> In 4.3.4.1. Selection of the Next Hop, it explains:
> 
> 1) The node receiving the RSVP message MUST first
> evaluate the first
>    subobject.  If the node is not part of the
> abstract node described by
>    the first subobject, it has received the message
> in error and SHOULD
>    return a "Bad initial subobject" error.  If there
> is no first
>    subobject, the message is also in error and the
> system SHOULD return
>    a "Bad EXPLICIT_ROUTE object" error.
> 
> > 
> > Another question is about strict/loose object:
> > 
> > The draft of RSVP-TE says "The path between a
> strict
> > node and its preceding node MUST include only
> network
> > nodes from the strict node and its preceding
> abstract
> > node."
> > 
> > Does it mean if there is strict subobject in ERO,
> then
> > ther is no loose subobject and if there is loose
> > subobject, then there is no strict subobject?
> 
> Not at all.  You can have both strict hops and loose
> hops as part of the
> same ERO.  On a "strict" hop link, there isn't any
> other route it can take
> except for the next hop in the ERO list.  On a
> "loose" hop link, there can
> be additional hops between the nodes provided that
> it ends up on the next
> hop.
> 
> Bill

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

---

From: Eric Gray <[email-masked]>
Date: Wed, 03 Jan 2001 11:53:58 -0500

John,

    I believe part of the issue is your use of terms.
In the example you give, I believe that either the
"address" A must be that of an abstract node that
includes addresses A1, A2 and A3 OR B needs
to have the L bit set to indicate that it does not
have to be the very next (adjacent) peer. I am
sure that A cannot forward the Path message
to A1, let alone to B, otherwise.

    I think if you recast your question in terms of
"loose hops" and "abstract nodes" and re-read
the applicable sections of the specification, your
answer will emerge.

--
Eric Gray

---

From: "Michael H. O'Meara" <[email-masked]>
Date: Thu, 4 Jan 2001 16:38:13 -0500

Hello all,
     While there's a thread on the subject, I was hoping that someone
might help clarify some of my confusion in regards to the processing of an
ERO. In particular, I'm having some difficulty understanding the selection
of a next hop for a node in the interior of an abstract node. According to
draft-ietf-mpls-rsvp-lsp-tunnel-07.txt, section 4.3.4.1:

5) Interior of the Abstract Node Case: Otherwise, the node selects a
   next hop within the abstract node of the first subobject (which the
   node belongs to) that is along the path to the abstract node of the
   second subobject (which is the next abstract node).  
...
6) Finally, the node replaces the first subobject with any subobject
   that denotes an abstract node containing the next hop.  This is
   necessary so that when the explicit route is received by the next
   hop, it will be accepted.

    What, exactly, is meant by "any subobject that denotes an abstract
node containing the next hop?" For example, given the following topology:

    A--B1--B2--B3--C

    Say that A sends an ERO={B,C}, where B describes an abstract node that
contains B1, B2, and B3, and B and C are strict hops. According to the
steps for making the selection of a next hop, B1 could send an ERO={B2,C}
to B2. Since C is listed as a strict hop, B2 would return a "Bad strict
node error." I may be missing something, but it would seem that nothing in
the steps for the selection of a next hop, nor in section 4.3.4.2 on the
addition of subobjects to the ERO, would preclude this from happening. I
would certainly appreciate any help in clarifying this matter.
			Thanks in advance,
				Mike    

***************************
Michael O'Meara
Technician
MPLS Consortium	
InterOperability Lab
University of New Hampshire
***************************