Subject: RE: ERO and strict/loose subobject

From: "Sanford, Bill" <[email-masked]>
Date: Thu, 4 Jan 2001 13:11:34 -0500

So if we go back to John's original question,

John> One question about the ERO object in RSVP:

John> Assuming there is a sender node and it creates an ERO. Should the ERO
include the ip address of sender itself? If yes, why?

Doesn't the ERO list have to include the sender as the first hop so it can
evaluate the next hop it has to go to?

-----Original Message-----
From: Antonela Paraschiv [mailto:[email-masked]]
Sent: Thursday, January 04, 2001 10:34 AM
To: John Sparr
Cc: [email-masked]; Bill Sanford; MPLS Mailing List
Subject: Re: ERO and strict/loose subobject

Hi John, 

According to the draft-ietf-mpls-rsvp-lsp-tunnel-07.txt, when the path
message leaves node A (in your example with A, A1, A2, B nodes), the ERO
should have 

   ERO = {A1, B}. 

The following paragraphs from the spec (from 4.3.4.1. Selection of the Next
Hop) state that if a node receives a path message in which the first ERO
subobject does not belong to it, it has to reply with Bad initial object. 

   "1) The node receiving the RSVP message MUST first evaluate the first 
   subobject.  If the node is not part of the abstract node described by 
   the first subobject, it has received the message in error and SHOULD 
   return a "Bad initial subobject" error.  If there is no first 
   subobject, the message is also in error and the system SHOULD return 
    a "Bad EXPLICIT_ROUTE object" error." 
and 
   "6) Finally, the node replaces the first subobject with any subobject 
   that denotes an abstract node containing the next hop.  This is 
   necessary so that when the explicit route is received by the next 
   hop, it will be accepted." 

Note please that step 1) above does not mention ANYTHING about first ERO
subobject being strict or loose. 

Can any of the authors please confirm/infirm the above? 

Best regards, 
Antonela 

John Sparr wrote: 

Hi Eric, 

You are right. I made a mistake. In the example, A is 
not the abstract node and B should set the L bit. 

My question is how node A handle the ERO. Does the ERO 
created by A contains only B's addr or both A's addr 
and B's addr, when A sent out path msg with ERO? 
Assuming A want to send ERO to B and regardless the 
intermediate nodes. 

Thanks. 

Regards, 

John 

--- Eric Gray <[email-masked]> wrote: 
> John, 
> 
>     I believe part of the issue is your use of 
> terms. 
> In the example you give, I believe that either the 
> "address" A must be that of an abstract node that 
> includes addresses A1, A2 and A3 OR B needs 
> to have the L bit set to indicate that it does not 
> have to be the very next (adjacent) peer. I am 
> sure that A cannot forward the Path message 
> to A1, let alone to B, otherwise. 
> 
>     I think if you recast your question in terms of 
> "loose hops" and "abstract nodes" and re-read 
> the applicable sections of the specification, your 
> answer will emerge. 
> 
> -- 
> Eric Gray 
> 
> John Sparr wrote: 
> 
> > Hi Bill, 
> > 
> > Thanks for the comments. 
> > 
> > I was still a little bit confused about the first 
> > subobject in the ERO. Lets say the following 
> example. 
> > 
> >     A--A1--A2--A3--B--C 
> > 
> > Assuming A is the sender node and B is the 
> receiver 
> > node, A1-A3 are the intermediate nodes. A creates 
> an 
> > ERO with the first subobj A's addr (loose) and 
> second 
> > subobj B's addr. When A sends Path msg with the 
> ERO 
> > towards B, what should A do to the ERO, it should 
> > delete the first subobj (itself addr)? or send 
> both 
> > subobjs to B? I think A should delet the first 
> subobj, 
> > but if it is, it's no use to add the first subobj( 
> > itself addr) at the beginning of creating ERO. 
> > 
> > Please correct me. 
> > 
> > Thanks in advance 
> > 
> > Regards, 
> > 
> > John 
> > 
> > --- "Sanford, Bill" <[email-masked]> wrote: 
> > > John, see the comments below: 
> > > 
> > > > -----Original Message----- 
> > > > From: John Sparr [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > > > Sent: Tuesday, January 02, 2001 3:43 PM 
> > > > To: [email-masked] 
> > > > Subject: ERO and strict/loose subobject 
> > > > 
> > > > 
> > > > Hi all, 
> > > > 
> > > > One question about the ERO object in RSVP: 
> > > > 
> > > > Assuming there is a sender node and it creates 
> an 
> > > ERO. 
> > > > Should the ERO include the ip address of 
> sender 
> > > > itself? If yes, why? 
> > > 
> > > Lets say the ERO is not set with the sender node 
> and 
> > > is started on the next 
> > > hop.  How does the LSP you want to set up know 
> that 
> > > there are no other hops 
> > > in between the sender and next hop?  If you 
> don't 
> > > have the senders ip 
> > > address as the first subobject, there isn't any 
> way 
> > > to set the properties of 
> > > the link to the next hop to loose or strict. 
> > > 
> > > In the implementation in 
> > > draft-ietf-mpls-rsvp-lsp-tunnel-07.txt, if you 
> > > didn't have the sender address in the ERO, it 
> would 
> > > immediately error with 
> > > "Bad EXPLICIT_ROUTE object" error. 
> > > 
> > > In 4.3.4.1. Selection of the Next Hop, it 
> explains: 
> > > 
> > > 1) The node receiving the RSVP message MUST 
> first 
> > > evaluate the first 
> > >    subobject.  If the node is not part of the 
> > > abstract node described by 
> > >    the first subobject, it has received the 
> message 
> > > in error and SHOULD 
> > >    return a "Bad initial subobject" error.  If 
> there 
> > > is no first 
> > >    subobject, the message is also in error and 
> the 
> > > system SHOULD return 
> > >    a "Bad EXPLICIT_ROUTE object" error. 
> > > 
> > > > 
> > > > Another question is about strict/loose object: 
> > > > 
> > > > The draft of RSVP-TE says "The path between a 
> > > strict 
> > > > node and its preceding node MUST include only 
> > > network 
> > > > nodes from the strict node and its preceding 
> > > abstract 
> > > > node." 
> > > > 
> > > > Does it mean if there is strict subobject in 
> ERO, 
> > > then 
> > > > ther is no loose subobject and if there is 
> loose 
> > > > subobject, then there is no strict subobject? 
> > > 
> > > Not at all.  You can have both strict hops and 
> loose 
> > > hops as part of the 
> > > same ERO.  On a "strict" hop link, there isn't 
> any 
> > > other route it can take 
> > > except for the next hop in the ERO list.  On a 
> > > "loose" hop link, there can 
> > > be additional hops between the nodes provided 
> that 
> > > it ends up on the next 
> > > hop. 
> > > 
> > > Bill 
> > 
> > __________________________________________________ 
> > Do You Yahoo!? 
> > Yahoo! Photos - Share your holiday photos online! 
> > http://photos.yahoo.com/ <http://photos.yahoo.com/>  
> 

__________________________________________________ 
Do You Yahoo!? 
Yahoo! Photos - Share your holiday photos online! 
http://photos.yahoo.com/ <http://photos.yahoo.com/> 

-- 

Antonela Paraschiv 

Passport MPLS, Carrier Data Networks, Nortel Networks

Tel: (978)288-6136 (Esn : 248-6136)

E-mail: [email-masked]

---

From: "Antonela Paraschiv" <[email-masked]>
Date: Thu, 04 Jan 2001 14:35:09 -0500

Thanks a lot Bill for taking the time to reply.
I hoped you could stress the answer and not the question. I had the
feeling that John needed a confirmation or maybe a clearer answer.

Best regards,
Antonela

"Sanford, Bill" wrote:

> So if we go back to John's original question,John> One question about
> the ERO object in RSVP:
>
> John> Assuming there is a sender node and it creates an ERO.Should the
> ERO include the ip address of senderitself? If yes, why?
>
> Doesn't the ERO list have to include the sender as the first hop so it
> can evaluate the next hop it has to go to?
>
>      According to the draft-ietf-mpls-rsvp-lsp-tunnel-07.txt,
>      when the path message leaves node A (in your example with A,
>      A1, A2, B nodes), the ERO should have
>
>         ERO = {A1, B}.
>
>      The following paragraphs from the spec (from 4.3.4.1.
>      Selection of the Next Hop) state that if a node receives a
>      path message in which the first ERO subobject does not
>      belong to it, it has to reply with Bad initial object.
>
>      Note please that step 1) above does not mention ANYTHING
>      about first ERO subobject being strict or loose.
>
>     > > > > > From: John Sparr [mailto:[email-masked]]
>     > > > http://photos.yahoo.com/
>     > http://photos.yahoo.com/