Subject: Re: Routing

From: Curtis Villamizar <[email-masked]>
Date: Thu, 04 Jan 2001 11:36:57 -0500

In message <[email-masked]>, jie yang ee stnt writes:
> 
> } From [email-masked] Wed Dec 13 12:07 EST 2000
> } To: "Faisal S. Naik" <[email-masked]>
> } cc: mpls uunet <[email-masked]>
> } Subject: Re: Routing
> } MIME-Version: 1.0
> } 
> } 
> } > Hello friends,
> } > Forgive me if i am off topic, but i wanted to confirm one thing,
> } > are todays IGPs dynamic in nature? Also are they capable of selecting an 
> alternate route (if available) on their own? and how far do traffic engineeri
> ng technologies help IGPs in this scenario.
> } > Regards,
> } 
> } Yes they are, and yes they can. However with a more complex network
> } loadbalancing and TE becomes incresingly complex.
> } 
> } - kurtis -

> we believe that multipath routing and traffic dispersion have some benefit 
> in network security, reliability and, perhaps, performance.  But I am not
> quite sure whether today's IGPs are able to find several possilble
> paths at a time and how difficult it is to be implemented, including
> balance loading algorithms. would someone 
> draw a light on the trade-offs of such a scenario? 
> thank you.
> Jie

[ I'm not sure who "we" is.  In the IETF "we" speak as individuals
unless there has been consensus established in a WG or among some set
of people, such as a set of coauthors. ]

ECMP is defined for OSPF.  It is implemented for ISIS and BGP as well.

You can create two or more LSP to the same egress and load split and
if one goes down get a fast partial restoration with full restoration
when the one that went down reroutes.

There is also something called OMP (http://www.fictitious.org/omp)
that has yet to be implemented in a core router.

Curtis

---

From: Ramesh Bhandari <[email-masked]>
Date: Thu, 04 Jan 2001 12:05:26 -0500

You can also look up my book "Survivable Networks:Algorithms for Diverse Routing",
Kluwer (1999) for concepts on traffic splitting over a number of disjoint paths
(inclduing algorithms for their determinations within a given network)), and full
restoration, when a link or node fails.

Ramesh Bhandari