Subject: RE: Last call on MPLS TE MIB

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 25 Jan 2001 07:59:10 -0500

Let me be a little more precise with my last statement
regarding this proposed addition. Why don't we just re-use
the mplsTunnelHopIpv4Addr, and if the value is set to
lspid, modify the description of the hopAddrType slightly
to allow the mplsTunnelHopIpv4Addr or mplsTunnelHopIpv6Addr
to be set as well in this case?

         --Tom

>I have an another observation/suggestion with respect to the
>CRLSP support.
>
>This is with respect to the ER Hop that is configured to be of
>type LSPID. Currently we have support to configure the LSPID
>value via the MIB object "mplsTunnelHopLspId" and the
>have the MIB object "mplsTunnelHopAddrType" set to value "lspid".
>
>For a ER Hop Type of LSPID, the Ingress LSR Router ID value is
>also required.
>
>Can we add an object to facilitate this configuration?
>(We have added this to our enterprises MIB to support LSPID ER hop
>types).
>
>The SMI for the object can be as follows.
>
>mplsTunnelHopIngressRouterId MplsLsrId
>
>mplsTunnelHopIngressRouterId OBJECT-TYPE
>    SYNTAX        MplsLsrId
>    MAX-ACCESS    read-create
>    STATUS        current
>    DESCRIPTION
>           "If mplsTunnelHopAddrType is set to lspid(4), then
>            this value will contain the IPv4 address of the
>            Ingress Router ID of the Tunnel. This object is
>            otherwise insignificant and should contain a
>            value of 0."
>
>NOTE: The suggestion made is for IPv4 Address alone here, since
>the LSPID TLV currently supports IPv4 address type only.
>
>Thanks in advance
>with best regards
>mani
>-----------------------------------------
>S.Manikantan
>Future Software Limited
>480-481, Anna Salai,
>Nandanam, Chennai, India.
>Zip (PIN CODE) : 600 035
>Phone          : 91-44-4330550
>Fax            : 91-44-4344157
>email          : [email-masked]
>-----------------------------------------

---

From: "Manikantan S" <[email-masked]>
Date: Thu, 25 Jan 2001 19:00:05 +0530

Hello Thomas

I accept your suggestion to use the mplsTunnelHopIpv4Addr for
the required need of LSPID ER Hop with the needed modification
in the description. 

thanks and best regards
mani

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Thomas D.
Nadeau
Sent: Thursday, 25 January 2001 6:29 PM
To: [email-masked]; 'Cucchiara, Joan'
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: Last call on MPLS TE MIB

         --Tom

---

From: "Manikantan S" <[email-masked]>
Date: Thu, 25 Jan 2001 20:23:19 +0530

Hello Tom

My suggested change to the description clause for mplsTunnelHopIpv4Addr
is as follows

mplsTunnelHopIpv4Addr OBJECT-TYPE
   SYNTAX        InetAddressIPv4
   MAX-ACCESS    read-create
   STATUS        current
   DESCRIPTION
          "If mplsTunnelHopAddrType is set to ipV4(1), then
           this value will contain the IPv4 address of this
           hop. 

           If mplsTunnelHopAddrType is set to lspid(4), then
           this value will contain the Ingress LSR Router ID
           of the Tunnel.    

           This object is otherwise insignificant and
           should contain a value of 0."
   ::= { mplsTunnelHopEntry 5 }

regards
mani

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Thursday, 25 January 2001 7:26 PM
To: [email-masked]
Subject: RE: Last call on MPLS TE MIB

         Can you please provide us with a specific
change to the DESCRIPTION clause for this object?
We are all quite busy right now, and don't have
the time to sort this out to your satisfaction,
so it is probably easier if you just tell us
exactly what you want.

         --Tom

-----Original Message-----

         --Tom