Subject: RE: LDP - question about partially setup LSPs

From: Olle Pers <[email-masked]>
Date: Tue, 30 Jan 2001 11:11:09 +0100

*  
*  I would agree with you on this one.
* 
Well, here is one that would not agree, without more convincing arguments. 

*  Your second point is key.  How can you know that the 
*  destination address in the packet is an IGP prefix?  
*  I suspect that many networks will want to run BGP 
*  edge-to-edge, but to have only IGP routes in the core. 
*
The IGP knew the prefix, and B had sent out a label mapping 
for it. That was the scenario in David's question. 
So the router B knows how to forward unlabeled packets with this prefix. And
it did send out a label mapping for exactly the same prefix, knowing that it
didn't have any corresponding downstream label yet. Why? I don't want to
think B did that just in order to drop these packets.   

*  In addition to this you have the issue of MPLS VPN and Layer 
*  2 over MPLS traffic.  Either one of these will generate a 
*  label stack in which the innermost label is assigned edge-to-
*  edge and is not visible to the intermediate devices.
*  
These applications require that there exists an edge-to-edge LSP which can
be used as a tunnel. We cannot assume them to work, before the setup of this
LSP is completed. And with unordered control, the ingress will not know when
this has happened. 

But why use unordered control at all, if it leads to problems? What's the
application? 

* 
*  Giles
*  

Olle Pers
Telia, Sweden

---

From: Giles Heron <[email-masked]>
Date: Tue, 30 Jan 2001 13:20:57 +0000

Olle Pers wrote:
[snip]
> think B did that just in order to drop these packets.

Yes, that is the situation in David's question.

However, as I see it the problem with allowing the router to attempt to
forward the packet unlabelled is that it will work in some situations
and not in others - so it is difficult to debug.  I have already seen
one situation where a router was forwarding traceroutes happily along a
"broken" LSP (and forwarding the packet as IP from the point where the
LSP broke onwards) but was unable to forward MPLS VPN traffic.  A
similar result would have occurred with Internet traffic being forwarded
over a BGP-less MPLS core.

> But why use unordered control at all, if it leads to problems? What's the

My understanding of ordered control is that it leads to longer
convergence times than unordered/independent control?  If the
application is layer 2 circuit emulation one would hope to have
convergence times which are similar to those that can be achieved with
native layer 2 techniques (such as PNNI.)

Giles

-- 
===================================================
Giles Heron - IP Architect - Level 3 Communications
phone: +44 20 7864 0719     mobile: +44 7880 506185
===================================================

---

From: "Alexander Marhold" <[email-masked]>
Date: Tue, 30 Jan 2001 14:34:19 +0100

to add my points into the discussion:

Let us assume that the middle router does aggregation !

Now the packet enters the middle router labelled and he cannot have a direct
outgoing labelled path as he has not got labels for the summary but only for
the specific destinations for forwarding the packet.

Therefore whenever he receives a labelled packet and does not have any
outgoing label for that he has to remove the label and do a normal layer-3
lookup in his routing table.

If that lookup fails he drops the packet and tries sending back an ICMP
destination unrechable.

Assuming ordered LSP control it would be nearly impossible to detect such
situation and if the path is now complete or not. Therefore in normal
MPLS-frame based routing environments  it is not implemented.

-----------------
I agree that for MPLS/VPN where the middle routers have no knowledge about
the detsinations this is not optimal, and an "ordered LSP control" could
prevent that, but it is up to the implementer of the MPLS code to decide on
this.

with best regards

Alexander Marhold
Senior Consultant
PRO IN

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
> Of Olle Pers
> Sent: Tuesday, January 30, 2001 11:11 AM
> To: 'Giles Heron'
> Cc: [email-masked]; David Charlap
> Subject: RE: LDP - question about partially setup LSPs
>
>
>
> *