Subject: Questions on creation of p2mp connection using LSR-MIB

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Wed, 3 Jan 2001 14:04:02 -0500

Hi! I have few questions related to establishment of
point-to-multipoint
	connections using LSR-MIB. Your comments / suggestions will be
	appreciated.

	Thanks,
	sanjay

	Consider the following example:
	-------------------------------------
	In mplsInSegmentTable :
	{
		mplsInSegmentIfIndex	= 10
		mplsInSegmentLabel	= 100
		...
	}
	In mplsOutSegmentTable:
	{
		mplsOutSegmentIndex	= 1
		mplsOutSegmentIfIndex	= 11
		...
		----------------------------------
		mplsOutSegmentIndex	= 2
		mplsOutSegmentIfIndex	= 12
		...
	}

	As per the current indexing scheme, I have to create the following
	two rows in the mplsXCTable:
	{
		(create a row in this table using the index: 1.10.100.1)
		mplsXCIndex		= 1
		mplsXCLSPId		= 999
		....

		(create a row in this table using the index: 1.10.100.2)
		mplsXCIndex		= 2
		mplsXCLSPId		= 999
		....
	}
	
	Creation of the above mentioned row in the XC table will
automatically 
	populate the mplsInSegmentXCIndex and mplsOutSegmentXCIndex.

	Now the questions:
	-----------------------
	(a) mplsXCTable.1.10.100.2.mplsXCAdminStatus == down(2)
	=>The desired operational status of this segment (outgoing) is
	down and no packets should be forwarded on this segment.

	Is my assumption correct ?
		
	(b) Assume that mplsXCTable.1.10.100.1.mplsXCAdminStatus == down(2)

	What does this mean ? Is this the adminStatus of the incoming
segment
	or the outgoing segment ? or Does it represent the overall admin
Status of the 
	point-to-multipoint connection ?

	(c) Do you think, the XC model will be simpler, if we create only
ONE XC 
	entry for each connection and make the mplsInSegmentXCIndex &
	mplsOutSegmentXCIndex read-write (for SNMP initiated p2mp & mp2p 
	connections) ? The mplsInSegmentXCIndex & mplsOutSegmentXCIndex
	can still be automatically created for control protocol initiated
connections.
	[May also need to move the mplsXCLabelStackIndex to
outSegmentTable.]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 03 Jan 2001 14:31:45 -0500

Sanjaya,

         Answers are in-line.

>         Consider the following example:

         If you are referring to the operational status of the in/OutSegments,
remember that we no longer have operational status in the MPLS-LSR-MIB
for in/out segments as they do not make sense. Your assumption is correct
if you are assuming that the XCoperStatus = down(2) if the connection will
not forward traffic. The details of why it is not forwarding traffic
are not important in this context.

>Status of the point-to-multipoint connection ?

         It is meant to denote the overall status of the connection.
The specifics of whether or not the actual in/out label is "enabled"
are up to your implementation.

         --Tom

---

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Wed, 3 Jan 2001 19:40:36 -0500

Hi Tom! Thanks for your reply. I am still a little
	confused. I will appreciate, if you can clarify my
	understanding of your response.

	(A) Meaning of the mplsXCAdminStatus field

	Based on your response, 

	When a user sets 
	(i)mplsXCTable.1.10.100.2.mplsXCAdminStatus to down(2),
		=>user wants the switch to stop forwarding 
		on the out segment with mplsOutSegmentIndex =2
	where as, if the user sets 
	(ii) mplsXCTable.1.10.100.1.mplsXCAdminStatus to down(2)
		=> "overall" connection has been administrated to down
		and switch should not forward on ANY of the out 
		segments

	How do you know which of the two mplsXCAdminStatus fields
	represents the "overall" connection's admin status??
	
	[Similar questions arises for mp2p connections because
	of multiple AdminStatus fields in XC table]

	(B) This is a follow up question: Why didn't we use a 
	single XC entry in the mplsXCTable for each connection 
	(p2p/p2mp/mp2p)?

	Thanks,
	sanjay

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Wednesday, January 03, 2001 2:32 PM
To: Choudhury, Sanjaya; [email-masked]
Cc: cheenu Srinivasan; Arun Viswanathan
Subject: Re: Questions on creation of p2mp connection using LSR-MIB

         Sanjaya,

         Answers are in-line.

>         Consider the following example:
(corrected a typo)
>         populate the mplsInSegmentXCIndex and mplsOutSegmentXCIndex.

         If you are referring to the operational status of the
in/OutSegments,

         --Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 03 Jan 2001 20:00:17 -0500

Sanjay,

>         represents the "overall" connection's admin status??

         It depends on how you have implemented this. You can implement
this in two different ways: a) you can use a single XC entry and have
a single inSegment map to multiple outSegments using the same XC or b)
you can have two different XC entries, one for each outSegment and
the same inSegment. In the first case, a single XC would have to be
disabled. In the second case, you would have two XC entries which
would have to both be disabled.

>         single XC entry in the mplsXCTable for each connection

         This is certainly a valid way of implementing this, as
I pointed out above.

         --Tom