Subject: LSP path setup time

From: Greg Richardson <[email-masked]>
Date: Thu, 11 Jan 2001 11:04:06 -0800 (PST)

Hello,

I have a question about establishing explicit LSPs
within an AS.

Lets assume an ingress would like to setup a fixed
bandwidth LSP between itself and a destination node.

Suppose we define the establishment phase as two step
process:

1) Routing Decision - The ingress typically uses an
iteration of dijkstra's algorithm to compute the
shortest path (based on hop-count or other
constraints).

2) Resource Reservation - The ingress uses an
appropriate signaling protocol (such as RSVP-TE)to
explicitly establish the LSP.  This includes any
admission control at intermediate nodes, and perhaps
label distribution between peers.

Although vendor implementation is a huge factor in
determining the relative times to complete either
phase, is it safe to say that the time to complete 2nd
phase almost always dominates the first for a network
consisting of 100's of nodes.  

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

---

From: Bora Akyol <[email-masked]>
Date: Thu, 11 Jan 2001 13:01:03 -0800

It depends on how many hops the LSP is tracing.

t_setup= t_comp + N*(t_prop+t_proc) where t_comp is the computation time at the
head end, t_prop is the propagation time and t_proc is the per hop processing
time and N is the number of hops.

t_comp should be in the 10s of milisecond range (if not less, depending on the
complexity of the query).

Note that after the LSP is setup and the tunnel is declared to be UP, you still
have to wait for traffic get redirected into the tunnel either via configuration
or via routing protocols.

Bora