Subject: RE: Implications of cell-based or frame-based MPLS

From: Vishal Sharma <[email-masked]>
Date: Fri, 19 Jan 2001 10:42:06 -0800

Richard,

One thing that wasn't clear from your question was whether in the
cell-based network you were planning to run only MPLS or were
you thinking of, as Eduard has pointed out, mixing ATM and cell-based
MPLS?

If the former, then why can you not have a two level
label stack, comprised of switching on both VPI and VCI?
(Of course, if you are thinking of somehow mixing services, you'd probably
have
to keep the VPI for switching native ATM services.)

Also, on the subject of mixing services. Are you then thinking of running
a "ships-in-the-night" mode on the cell-based, ATM devices ?

-Vishal

> -----Original Message-----
> From: Metz, E.T. [mailto:[email-masked]]
> Sent: Friday, January 19, 2001 7:35 AM
> To: [email-masked]'
> Cc: [email-masked]
> Subject: RE: Implications of cell-based or frame-based MPLS
> 
> 
> 
> 
> > 
> > (1) What are the other major differences in 
> > performance/capabilities as a
> > consequence of these two different implementations of MPLS 
> > (cell versus
> > packet-based) ?
> > 
> 
> One is segmentation and reassembly. Even in the cell-based 
> network you will
> have a boundary (typically the PE) where you transform the IP 
> packets into
> cells and vice-versa. As far as I know this is not a function 
> that performs
> really well at high-speeds.
> 
> > (2) In the area of MPLS applications such as MPLS-VPNs, MPLS
> > traffic-engineering and fast-reroute, what impacts are caused by the
> > inability of an ATM-LSR to pop/push labels in the label stack 
> > compared to a
> > "frame/packet-based" LSR (which can pop/push labels in the 
> > label stack) ?
> > 
> 
> The inability of ATM-LSR to deal with stack depths > 1 
> requires you to use
> packet-based PEs with a cell-interface towards the core 
> (introducing the SAR
> issue). Alternatively, you could make an ATM switch perform packet
> operations (having the SAR issue twice), however, I doubt if 
> this would
> perform really well.
> 
> > In a most crude form, I am asking the question "what's better 
> > : cell-mode or
> > frame/packet-mode MPLS"
> 
> It is not a matter of good and bad, but rather a matter of needs.
> 
> If you only use the network for IP traffic only, I do not see 
> a particular
> need to introduce cell-based platforms. On the other hand 
> they may prove to
> be very useful if a significant part of your traffic is e.g. 
> due to (native)
> ATM services. In that case you could mix IP and ATM in the same core
> platform (although there are sufficient people that would 
> argue this is a
> bad idea as well)
> 
> Hope this helped a bit ...
> 
> cheers,
> 	Eduard
> > 
> > Richard Crouch (CND-T - Vodafone Ltd.)
> > 
>

---

From: "Yi Chu" <[email-masked]>
Date: Mon, 22 Jan 2001 10:43:56 -0500

I am not clear as to how 'ships-in-the-night' works on an ATM device.  Can
someone explain the concept or point me to an archive if it has been
discussed before?

Thanks.

yi

-----Original Message-----
From:	[email-masked] [mailto:[email-masked]] On Behalf Of Vishal
Sharma
Sent:	Friday, January 19, 2001 1:42 PM
To:	'Metz, E.T.'; [email-masked]'
Cc:	[email-masked]
Subject:	RE: Implications of cell-based or frame-based MPLS

Richard,

-Vishal