Subject: RE: ERO and strict/loose subobject

From: "Sanford, Bill" <[email-masked]>
Date: Wed, 3 Jan 2001 10:31:03 -0500

> -----Original Message-----
> From: Yangguang Xu [mailto:[email-masked]]
> Sent: Tuesday, January 02, 2001 4:56 PM
> To: Sanford, Bill
> Subject: Re: ERO and strict/loose subobject
> 
> Bill,
> 
> The "L" bit for a node doesn't mean the node is loose. 

That is exactly what it means.

> Indeed, the node is
> strict but the path from preceding node to this node is 
> loose. Am I right?
> 
> Thanks,
> 
> Yangguang
> 

Yangguang, in draft-ietf-mpls-rsvp-lsp-tunnel-07.txt:

4.3.3.1. Strict and Loose Subobjects

   The L bit in the subobject is a one-bit attribute.  If the L bit is
   set, then the value of the attribute is 'loose.'  Otherwise, the
   value of the attribute is 'strict.'  For brevity, we say that if the
   value of the subobject attribute is 'loose' then it is a 'loose
   subobject.'  Otherwise, it's a 'strict subobject.'  Further, we say
   that the abstract node of a strict or loose subobject is a strict or
   a loose node, respectively.  Loose and strict nodes are always
   interpreted relative to their prior abstract nodes.

If you have a "loose prior abstract node," the address *may* be the previous
hop in the ERO list.  If you have a "strict prior abstract node," the
address *must* be the previous hop in the ERO list.

Bill

---

From: Yangguang Xu <[email-masked]>
Date: Wed, 03 Jan 2001 10:52:30 -0500

Bill,

Because node marked as "loose" can also be interpreted as that the node itself
is not necessary in the ERO. What I am saying is that no matter the abstract
node is marked as loose or strict, it has to be in the ERO, however somewhere
depending on its being loose or strict. 

Thanks,

Yangguang

---

From: Eric Gray <[email-masked]>
Date: Wed, 03 Jan 2001 11:20:49 -0500

Bill,

    Yangguang is exactly correct.  What the L bit
means is that the next listed hop in the ER does not
have to be an adjacent peer.  It still must be in the
eventual ER.  Some people have been known to
refer to an "abstract node" as a "loose node", and
- in that sense - the L bit indicates a "loose hop"
rather than a "loose node".

--
Eric Gray