Subject: Query

From: Sachin Doshi <[email-masked]>
Date: Fri, 05 Jan 2001 14:49:48 +0530

Hi,
   Could anyone clarify me on these

1. When is MPLS label of 0 (implicit IP is used)?

2. How is the TTL field update in MPLS packets. Suppose there is a
egress router which can pop the MPLS label and then can switch/route the
packet on IP address. By how much should it decrement the TTL (1 or 2).

regards,
   sachin doshi

---

From: Wojciech Dec <[email-masked]>
Date: Fri, 05 Jan 2001 18:22:20 +0100

>1. When is MPLS label of 0 (implicit IP is used)?

It's typically used in penultimate-hop popping scenarios, however the use 
of explicit null or implicit null in such scenarios is something that would 
be typically preconfigured.

>packet on IP address. By how much should it decrement the TTL (1 or 2).

If TTL is to retain the meaning and use of TTL, then the decrement must be 1.

Regards,
Woj.

>    sachin doshi

_________________________________________________________
Wojciech Dec   CCIE# 5563      Phone:  +31 (0)20 342 3034
Network Consulting Engineer    Mobile: +31 (0)622 466 802
Cisco Systems,                 E-Mail: [email-masked]
PO Box 22514,
1100 DA Amsterdam
The Netherlands