Subject: MPLS Label Space

From: "Wayne" <[email-masked]>
Date: Sun, 11 Feb 2001 22:08:05 +0800

Hi all,

Sorry for asking simple question.

Why is there 2 label spaces for a LSR? Isn't the per interface label space cover most of the cases? Why do we need the per platform space? Could someone illustrate it with an example?

Would a Ru and a Rd connect by several links one of the examples?

Thanks very much.

Wayne

---

From: "Nagabhushana Ramaswamy Nadig" <[email-masked]>
Date: Sun, 11 Feb 2001 20:23:20 +0530 (IST)

> Why is there 2 label spaces for a LSR? 
>Isn't the per interface label space cover most of the cases? 

correct.

>Why do we need the per platform space? 

Per platform is nothing but a generalised case of Per Interface where you
will have a single LIB (Label Information Base) for all the
interafces. To differentiate this we need a special value. It is the
capability of your forwarding module that decides this behaviour of LDP.