Subject: RE: signaling in draft-kompella-mpls-bundle-04.txt

From: Adrian Farrel <[email-masked]>
Date: Tue, 20 Feb 2001 18:39:23 -0000

Fong,

The point with LIH in RSVP_HOP is that it identifies the link from the
sender perspective.  (NB, it is not really GMPLS, it is base RSVP).

What Kireeti has described in the bundling draft is the ability to have
multiple component links of a single link.  Clearly when the Path message is
sent (e.g. on a control channel) the downstream node must be able to work
out which component link is going to be used for the data.  The LIH cannot
be used since it provides the sender's identifier for the link and may have
no meaning to the receiver.  Hence a new object is introduced.

Now turning to bi-directional LSPs.  The component links in a bundle are
quite possibly uni-directional.  If they are, they may be paired so that you
could consider one component link to be built from one forward and one
reverse link, but there is no reason why this should be the case.

So you need to identify the component links that will be used for each
direction on the LSP.  Hence the two objects in the bundling draft.

Hope this helps.
Adrian

--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.dataconnection.com/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

>-----Original Message-----
>From: Zaffire - Fong Liaw 
>Sent: Saturday, February 17, 2001 3:05 AM
>To: [email-masked]'
>Cc: [email-masked]'
>Subject: signaling in draft-kompella-mpls-bundle-04.txt
>
>
>Hi Lou, 
>
>I have a question regarding why the bundled draft
>specifies both upstream and downstream component link
>while GMPLS draft assumes the same link is used for
>both upstream and downstream LSP. I believe the GMPLS
>model make more sense.
>
>If we are going to assume the same link should be
>used for both upstream and downstream LSP, we really
>do not need the new component link identifier object 
>since the RSVP HOP object already has the ability to 
>identify a local (component) index along with an 
>IP address.
>
>Thanks.
>-Fong
>

---

From: Yangguang Xu <[email-masked]>
Date: Tue, 20 Feb 2001 14:14:24 -0500

Adrian,

> no meaning to the receiver.  Hence a new object is introduced.

I don't think this is the reason. For RSVP in GMPLS case, LIH should be used to
identify the signaling control interface, not for logical links (or component
links) in data plane. Remember, in transport network, signaling are typically
out-of-band and non-associated.

Yangguang