Subject: Question on MPLS over native ATM

From: shen jing <[email-masked]>
Date: Wed, 28 Feb 2001 11:17:42 +0800

Hi :

I met some problem with my work, would you please give me some hints?

I'm thinking about connect IP host through ATM by using MPLS, which
provide both fast transmission and QoS support to multimedia streams.

I can not modify the control plane software installed in
ATM switch, so I have to use MPLS on end host while native ATM
in that switch. Is there any possiblity to integrate MPLS and ATM
in a layered model ?

     IP --- MPLS -- ATM---------ATM --- MPLS--IP
                                ^                     ^
         ^
                                |                      |
           |
                            MPLS over      Native           MPLS over
                                ATM             ATM                ATM

Is there any draft on this topic ? or any person has implement
a solution?

Thanks a lot.

Shen

---

From: [email-masked]
Date: Wed, 28 Feb 2001 08:39:04 -0500

Shen,

It looks like your IP end host/router needs to change the IP packet into
IP/MPLS/ATM (say AAL5) cells.  Transport the ATM cells across the native
ATM network.  Then at the other end, transform the ATM cells back into IP
packet.  Would you think your IP end host/router has the ability to do
that?

See whether RFC3035 can give you any help.

Regards,
Jane D. Jiang

shen jing <[email-masked]>@UU.NET on 02/27/2001 10:17:42 PM

Please respond to [email-masked]

Sent by:  [email-masked]

To:   Guang Xiaoming <[email-masked]>, "[email-masked]"
      <[email-masked]>
cc:
Subject:  Question on MPLS over native ATM

Hi :

Thanks a lot.

Shen