Subject: Question to draft-ietf-mpls-diff-te-ext-00.txt

From: "Daniel N. Bauer" <[email-masked]>
Date: Mon, 19 Feb 2001 17:20:02 +0100

Hello,

draft-ietf-mpls-diff-te-ext-00.txt describes the
handling of the RSVP CLASSTYPE Object.
Is it correct to say that for E-LSPs, the CLASSTYPE
object should be omitted, since a single E-LSP might
be associated with multiple class types? But then,
omitting a CLASTYPE object automatically associates the
LSP with CLASTYPE 0?!?
Is omitting the correct behaviour?

Thanks,

-Daniel

---

From: Vadim Suraev <[email-masked]>
Date: Tue, 20 Feb 2001 12:18:40 +0200

Daniel,
I think, if I'm not mistaken, draft-ietf-mpls-diff-te-ext-00.txt does not
imply
PathErr with code `Diff-Serv TE Error' is to be sent in this case since
this draft does not define (should not define?):
  1. How PHBs are mapped into Class Type;
  2. Which PHBs exist in Class Type;
  3. A way to check, if PHBs which are carried by E-LSP, match the signaled
Class Type;

However IMHO, you have to avoid signaling EXP<-->PHB mappings
(draft-ietf-mpls-diff-ext-07.txt) 
in such a way that will cause the same PHB to be associated with different
Class Types
or you have to avoid signaling the different Class Types for E-LSP if
EXP<-->PHB mapping is preconfigured.
Otherwise, one class, say EF, may allocate BW from each Class Type's (0,1,2)
pool , for example.

-----Original Message-----
From: Daniel N. Bauer [mailto:[email-masked]]
Sent: Tuesday, February 20, 2001 9:21 AM
To: Shahram Davari
Cc: [email-masked]; Francois Le Faucheur
Subject: Re: Question to draft-ietf-mpls-diff-te-ext-00.txt

Shahram,

thanks for your reply.

From your answer, it follows that if the PHBs
of an E-LSP span multiple class types, then
a PathErr with code `Diff-Serv TE Error' and
some value indicating the error condition
should be sent towards the sender. Otherwise,
unexpected results may occur.

-Daniel

Shahram Davari wrote:
> 
> Hi,
> 
> > -----Original Message-----
> > From: Daniel N. Bauer [mailto:[email-masked]]
> > Sent: Monday, February 19, 2001 11:20 AM
> > To: Francois Le Faucheur; [email-masked]
> > Subject: Question to draft-ietf-mpls-diff-te-ext-00.txt
> >
> >
> > Hello,
> >
> > be associated with multiple class types?
> 
> Any operator who wants to take advantage of Diffserv TE extension, should
configure its E-LSPs to support a set of PHBs that belong to a single
ClassType. So in summary to support Diffserv TE extension, a single E-LSP
MUST not be associated with more than one ClassType. And in case ClassType
is not "0" you MUST include it in the signaling.
> Yours,
> -Shahram
>  But then,

---

From: Shahram Davari <[email-masked]>
Date: Tue, 20 Feb 2001 04:17:29 -0800

Hi,

I also think that dealing with this scenario is not addressed in the draft, and is probably left to the operator.

Yours,
-Shahram

> From: Vadim Suraev [mailto:[email-masked]]
> Sent: Tuesday, February 20, 2001 5:19 AM
> To: 'Daniel N. Bauer'
> Subject: RE: Question to draft-ietf-mpls-diff-te-ext-00.txt
> 
> 
> Daniel,
> I think, if I'm not mistaken, 
> draft-ietf-mpls-diff-te-ext-00.txt does not
> imply