Subject: Question on Generic Label Range Table in LDP MIB

From: Edward Harrison <[email-masked]>
Date: Tue, 6 Feb 2001 09:50:34 -0000

Hi Joan,

I have a question regarding the use of the
mplsLdpEntityConfGenericIfIndexOrZero object within the LDP MIB
(draft-ietf-mpls-ldp-mib-07.txt).

My understanding is that it is possible to have multiple interfaces using
the generic label space and that, typically, each of these interfaces would
advertise the same label ranges.

Furthermore, I thought that it was possible to have a single (non-targeted)
LDP Entity for the generic label range - this entity being associated with
all the interfaces using the generic label range.

If this is correct then I believe one ends up with a single row in the
Generic Label Range Table which corresponds to more than one interface - for
each interface the LDP ID, Entity Index and Label Range will all be the same
as each interface uses the same LDP entity and shares the same label range.

In this scenario what should the value of
mplsLdpEntityConfGenericIfIndexOrZero be (as there are multiple possible
interface indices that are appropriate)? Should it be zero, meaning the
index is unknown, or should it correspond to one of the interfaces for the
Entity?

Thanks very much for your help,

Ed

----------------

Ed Harrison
Network Convergence Group
Data Connection Ltd
Tel:   +44 20 8366 1177       Fax: +44 20 8363 1468
Email: [email-masked] Web:http://www.dataconnection.com

---

From: Mohan Varma K <[email-masked]>
Date: Wed, 7 Feb 2001 19:56:39 +1100

Hi,      
     Yes, creation of row will be a problem if we go with the
 assumption of the earlier ldp-mibs.
 
      As per ldp-mib 7 they have defined a generic label range 
 on a per Interface level. 
      If we ensure a slight different label range in configuration(
 for eg   16-10000 (mplsLdpEntityConfGenericIfIndexOrZero 1),
            17-10000 (mplsLdpEntityConfGenericIfIndexOrZero 2)
 we have almost same labels available on each interface,which 
 we don't have earlier.
        
      However if we want to create a row wth the similar label range 
  we can have additional index to this table.

with regards
Mohan Varma

Hi Joan,

Ed

----------------

Ed Harrison

---

From: Edward Harrison <[email-masked]>
Date: Thu, 15 Feb 2001 18:38:45 -0000

Hi,

I'd forgotten that the generic label range table was only added in one of
the more recent versions of the MIB. I guess this means that this problem in
the MIB has only been around since then.

Joan, have you any comments on this? Is there any chance of adding an
additional index field to the mplsLdpEntityConfGenericTable to cover
scenarios where two interfaces advertise the same label range for the same
LDP entity?

Regards,

Ed

--------------
Ed Harrison
Network Convergence Group
Data Connection Ltd
Tel:   +44 20 8366 1177       Fax: +44 20 8366 5084
Email: [email-masked] Web:http://www.dataconnection.com

-----Original Message-----
From: Mohan Varma K [mailto:[email-masked]]
Sent: 07 February 2001 08:57
To: Edward Harrison
Cc: [email-masked]'
Subject: RE: Question on Generic Label Range Table in LDP MIB

Hi,      

with regards
Mohan Varma

Hi Joan,

Ed

----------------

Ed Harrison

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 15 Feb 2001 14:34:20 -0500

>scenarios where two interfaces advertise the same label range for the same

         I would vote for leaving the MIB as it is an
forcing the user to create a second entry in the table.
Additional indexes are expensive to implement, and in
this case, I don't think that effort would buy you much.

         --Tom

---

From: "Cucchiara, Joan" <[email-masked]>
Date: Tue, 20 Feb 2001 11:28:16 -0500

Hi,

The way we envisioned the generic label range table
would work is along with the interface stack, such
that there is a single (perPlatform) ifIndex at some point in the
stack, which represents a generic label range.  What you
are suggesting is a finer break down of this (I think).

The ifIndex which corresponds to a generic label range
would be used in the generic label range
table.  The ifStack would then lead to a physical port
for a specific generic label (which was actually one of
the earlier tables, but was subsequently removed from
the mib since the feedback we received was that reserving
a group of generic labels was what was important.)

If you want a break down (or mapping) of a specific generic
labels to a specific ifIndex (say an ifIndex which corresponds
to the shim layer), that does not appear in the MIB, because our
understanding of the generic label range was that it applies
to a perPlatform scenario. 

  -Joan

> From: Edward Harrison [mailto:[email-masked]]
> Sent: Thursday, February 15, 2001 1:39 PM
> To: [email-masked]'; [email-masked]'
> Cc: [email-masked]'