Subject: RE: Question to draft-ietf-mpls-diff-te-ext-00.txt

From: Shahram Davari <[email-masked]>
Date: Mon, 19 Feb 2001 10:08:29 -0800

Hi,

> -----Original Message-----
> From: Daniel N. Bauer [mailto:[email-masked]]
> Sent: Monday, February 19, 2001 11:20 AM
> To: Francois Le Faucheur; [email-masked]
> Subject: Question to draft-ietf-mpls-diff-te-ext-00.txt
> 
> 
> Hello,
> 
> draft-ietf-mpls-diff-te-ext-00.txt describes the
> handling of the RSVP CLASSTYPE Object.
> Is it correct to say that for E-LSPs, the CLASSTYPE
> object should be omitted, since a single E-LSP might
> be associated with multiple class types?

Any operator who wants to take advantage of Diffserv TE extension, should configure its E-LSPs to support a set of PHBs that belong to a single ClassType. So in summary to support Diffserv TE extension, a single E-LSP MUST not be associated with more than one ClassType. And in case ClassType is not "0" you MUST include it in the signaling.

Yours,
-Shahram

 But then,
> omitting a CLASTYPE object automatically associates the
> LSP with CLASTYPE 0?!?
> Is omitting the correct behaviour?
> 
> Thanks,
> 
> -Daniel
>

---

From: "Daniel N. Bauer" <[email-masked]>
Date: Tue, 20 Feb 2001 08:20:32 +0100

Shahram,

thanks for your reply.

From your answer, it follows that if the PHBs
of an E-LSP span multiple class types, then
a PathErr with code `Diff-Serv TE Error' and
some value indicating the error condition
should be sent towards the sender. Otherwise,
unexpected results may occur.

-Daniel