Subject: How the merged traffic to be splitted?

From: [email-masked]
Date: Tue, 20 Feb 2001 17:28:18 +0000

Hello:

It seems to me that the MPLS drafts related to the Label 
Merging have not shown how the Label Merge feature can 
be used in  a practical application.

I would appreciate your pointers on the following two 
questions:

1) in the following configuration, how the merged label 
traffic can be split to two different destination LERs E 
and F?
    and how the x and y signaled?

    Ingress A \ 
label:1                                      / LER E
	         
\                                            /?x
		LSR C ----Label 3-------LSR D
	         /                                       
    \?y
    Ingress B /    label 
2                                  \LER F

Note: with label merge, we should not push the label 1 
or or label 2 at LSR C and pop them at LSR D.Right?

2) or the label merge only valid for the following 
configuration for IP traffic (not ATM/FR!)?

   Ingress A \ 
label:1                                      
	         
\                                            
		LSR C ----Label 3-------LER D
	         /                                       
    
    Ingress B /    label 2

Regards,

THomas

---

From: Jeremy Lawrence <[email-masked]>
Date: Wed, 21 Feb 2001 14:15:11 +1100

Thomas,

The ASCII diagrams seem not to have survived intact, but:

>                LSR C ----Label 3-------LSR D

That is a situation which will not happen by label merging.

>                LSR C ----Label 3-------LER D

#2 is true. Only labels of the same FEC (e.g. the same CoS
and destination) may be merged. Merged traffic is split only
at the destination eLSR. Label merge can be done by ATM-LSRs
which support VC-merge, by the way. 

Jeremy Lawrence