Subject: Query

From: Sachin Doshi <[email-masked]>
Date: Wed, 28 Feb 2001 21:27:38 +0530

Can someone answer these:

1. Is it possible that on a LAN where R1 (router/switch) is connected to
R3 (router/switch) through R2(router/switch), there is a LSP which has
only R1 and R3 as LSR's  not R2 (assuming that R1,R2 and R3 all are
MPLS capable).

2. If a LSR receives a MPLS packet which was not directed to him (mac DA
was not this LSR's address), what should it do with the packet? Should
it switch the packet based on the L2 address or is it allowed to switch
it based on the MPLS label?

regards,
   sachin

---

From: Eric Gray <[email-masked]>
Date: Wed, 28 Feb 2001 11:16:27 -0500

Sachin,

    I'm not sure what the difference is between the first
question and the second, but the second seems like a
good question.

    A router may be configured to "bridge" certain packets
(e.g. - based on the MAC header).  This used to be called
a "BRouter" in the days before the invention of the term
"L3 Switch".  There are several examples of when this may
need to be done, but a currently applicable one would be in
the VLAN case.  Of course, when a router is configured
this way, it appears like a transparent bridge to frames it
"bridges".  Hence, from the MPLS perspective, it is not
visible to the LSRs between which it may be "bridging"
<L3 packets>-<in MPLS shim>-<in L2 frames>.

    Does this answer your question?

--
Eric Gray