Subject: RE: MPLS LSPs and ATM PVCs

From: Jeremy Lawrence <[email-masked]>
Date: Tue, 27 Feb 2001 19:19:28 +1100

Dmitry is quite correct, but a comment on applicability:
Bi-directional ATM LSPs might be useful for traffic engineering
(for example). However scaling ATM VC-based MPLS to any-to-any
connectivity amongst more than a couple of hundred or so eLSRs
will typically require VC-merge capability. VC merging is an
inherently unidirectional concept, so the applicability of
bi-directional VCs in ATM VC-based MPLS is somewhat limited.

Regards,

Jeremy Lawrence

At 09:12 02/26/2001 -0500, Dmitry Ryumkin wrote:
>Paul,
>
>Generalized MPLS defines procedures for bi-directional LSP setup.
>
>Regards,
>Dmitry Ryumkin
>
> -----Original Message-----
>From:   [email-masked] [mailto:[email-masked]] 
>Sent:   Monday, February 26, 2001 8:52 AM
>To:     Paul Moore
>Cc:     [email-masked]
>Subject:        Re: MPLS LSPs and ATM PVCs
>
>
>HI Paul,
>
>I believe RSVP is never intended to set up two LSPs using one single
>operation.  We will have to use two RSVP signalling operations to set up
>the two LSPs, one for each direction, even if the PVC may be used
>bidirectionally.
>
>Regards,
>Jane D. Jiang
>
>
>
>
>Paul Moore <[email-masked]>@UU.NET on 02/26/2001 08:11:29 AM
>
>Sent by:  [email-masked]
>
>
>To:   [email-masked]
>cc:
>Subject:  MPLS LSPs and ATM PVCs
>
>
>Hello,
>
>I have a question about MPLS and ATM. ATM point-to-point PVCs can be
>either uni-directional or bi-directional. MPLS LSPs are only
>uni-directional. Is there any work being done concerning bi-directional
>LSPs, for example, to allow two LSPs to be established by a single RSVP
>signalling operation?
>
>I've just joined the list, so apologies if this has already been
>discussed.
>
>Thanks,
>Paul
>
>--
>Paul Moore
>Alcatel Bell
>+32 3 450 3536
>[email-masked]

---

From: Eric Gray <[email-masked]>
Date: Tue, 27 Feb 2001 10:48:36 -0500

Jeremy,

    An observation: the ATM model of bi-directionality is being
assumed (at least apparently) in you comment.  It is not impossible
to establish link-by-link bi-directionality - though it is probably
more difficult than it is worth.

Consider this scenario:

   --- R1 --- R2 ---

    All that would be required would be for R1 and R2 to associate
a given pair of labels with a pair of FECs in a label negotiation
exchange - i.e. (R1, Label-1:FEC-A); (R2, Label-2:FEC-B)
where Label-1 is associated with FEC-A at R1 and distributed
to R2 while Label-2 is associated with FEC-B at R2 and the
association is distributed to R1.  Label-1 and Label-2 could be
numerically identical and FEC-A unrelated to FEC-B.

    In fact, the way that LDP is right now, this can be done in
2 PDUs (if not 2 messages): the first one (say from R1) has
two mesaages in it: a label request message for FEC-B and
an unsolicited label mapping message (with Label-1) for
FEC-A.  R2 then returns an LDP PDU with a label mapping
message (with Label-2 - possibly the same as Label-1) for
FEC-A.  If the intention is to associate the same label bi-
directionally with different FECs, it's almost a shame that
two messages are required in the first LDP PDU.

    But this is not the meaning of bi-directional that you are
discussing, is it? :-)

--
Eric Gray