Subject: RE: per interface lable space validity

From: Shahram Davari <[email-masked]>
Date: Mon, 26 Feb 2001 06:41:49 -0800

Hi,

In your scenario, if the signaling (CR-LDP/RSVP-TE) is tunneled through that tunnel then you can use per-interface label space, otherwise you should use per-platform label space, because you don't know from which interface the packet will arrive.

Yours,
-Shahram 

> -----Original Message-----
> From: shen jing [mailto:[email-masked]]
> Sent: Monday, February 26, 2001 5:56 AM
> To: [email-masked]
> Subject: per interface lable space validity
> 
> 
> I'm reading rfc3036 - "LDP specification", at section 2.2.1 
> Lable spaces
> , it is said a per interface
> lable space only makes sense when the LDP peers are "directly
> connected".
> what is "directly connected" ?   If two LSRs are connected by a tunnel
> which generate
> another layer on Label stack , a per interface label is not 
> meaningful ?
> 
> thanks a lot.
> 
> James Shen
>

---

From: "Abdul Malick" <[email-masked]>
Date: Tue, 27 Feb 2001 10:12:20 +0530

Hi
I feel that even if you tunnel the signalling b/w a LSR and its remote peer,
and if this tunnel may be rerouted (for TE purpose) , then again using
per-interface label space could be a problem. Only if the tunnel is
permanent we can use per-interface label space, otherwise only per-platform
label space should be used.

Please correct me if i am wrong

Cheers
Malick
----- Original Message -----
From: "Shahram Davari" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Monday, February 26, 2001 8:11 PM
Subject: RE: per interface lable space validity

> Hi,
>
> In your scenario, if the signaling (CR-LDP/RSVP-TE) is tunneled through
that tunnel then you can use per-interface label space, otherwise you should
use per-platform label space, because you don't know from which interface
the packet will arrive.

---

From: Bora Akyol <[email-masked]>
Date: Mon, 26 Feb 2001 20:54:29 -0800 (PST)

When you set up the fast reroute LSP, you use a shared explicit style
reservation and set up the ERO for the fast reroute to join the original
path as soon as possible. If you do it this way, then you don't need the
per platform wide label space.

If you do it as described in George Swallow's internet draft on bypass
LSPs then you need the per platform wide label space. That method however
only protects against link failures and not router failures.

Bora