Subject: RE: Multiple label spaces per link??

From: Shahram Davari <[email-masked]>
Date: Fri, 23 Feb 2001 07:29:02 -0800

Hi Vinay,
 
You can have multiple label  sapces per interface (or link) if you could differentiate between them, for example, using the virtual channel number.
 
Yours,
-Shahram

-----Original Message-----
From: Vinay Vernekar [mailto:[email-masked]]
Sent: Thursday, February 22, 2001 3:22 AM
To: [email-masked]'
Subject: Multiple label spaces per link??

Hello, 
I have a question on the following from rfc3036 "LDP Specification".
Under 2.5.3. Session Initialization page 15, para 4 it is given that -
"In general when there are multiple links between LSR1 and LSR2 and multiple label spaces to be advertised by each...."
Does this mean that each link will advertise multiple spaces. In other words is it possible for a single link to advertise more than one label space??
 
Regards
Vinay
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Yesterday is history. Tomorrow is mystery.
Today is a gift. That's why it's called the Present!!
*****************************************************************************
Vinay H. Vernekar
Sr. Software Engineer - Global R&D Solutions
Wipro Technologies
No.26, Hosur Main Road, Bommanahalli,
Bangalore-560 068, India.
Tel: 91-80-5722293/5722296 Extn. 4019
Fax: 91-80-5722696
Email: [email-masked] <mailto:[email-masked]> 
The World's First SEI CMM Level 5 Software Services Company
*****************************************************************************

---

From: Shahram Davari <[email-masked]>
Date: Fri, 23 Feb 2001 07:33:11 -0800

Hi Vijay,
 
I can understand the muticast case, becasue we could differentiate unicast and multicast labels using different link layer ID (such as PPP protocol ID). But I can't understand the L-LSP case! Could you please explain?
 
Yours,
_Shahram 

-----Original Message-----
From: Vijayanand Chandrasekar [mailto:[email-masked]]
Sent: Thursday, February 22, 2001 4:08 AM
To: Vinay Vernekar
Cc: Balasubramanian Mandakolathur B; [email-masked]
Subject: RE: Multiple label spaces per link??

Vinay,
Yes. A single link can advertise more than one label space. This will happen in multicasting and in the case of diffserv/QoS when we create L-LSPs.

Regards,
Vijay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Vinay Vernekar
Sent: Thursday, February 22, 2001 1:52 PM
To: [email-masked]'
Subject: Multiple label spaces per link??

Hello, 
 
Regards
Vinay