Subject: Label Request Event

From: "Heqing Zhu" <[email-masked]>
Date: Thu, 22 Feb 2001 08:57:57 +0800

Hi,I have one basic question regarding "receive label request" in RFC3036.
There is an algorithm in page 96. It describe like this:

"LRq.2     Is there a Next Hop for FEC?
                  If not ,goto LRq.5.
  ...........................
 LRq.5    Execute procedure Send_Notification(MsgSource,No Route)."  

I think maybe the FEC has been to the destination address,
Why not check this ?

Thanks for your help

Heqing Zhu

---

From: "Murali Krishna Policharla" <[email-masked]>
Date: Thu, 22 Feb 2001 11:10:06 +0530

Hi Hequing,
                   the LSR  first checks whether the packet is meant for a
destination that is reachable on the local interface (ethernet) , if it is
reachable,  then it will not say that no next hop is available it will assign
a label and replies backs with the label mapping. 
                 Only if it cannot find an entry in the routing table and
also the destination is not reachable via the local interface (ethernet) then
it will say there is no  Next Hop for this destination address . So then it
is valid to send the following notifcation of no route.

 
Thanks for your help
 
Heqing Zhu
           
-------->some one correct me if i am wrong
 
murali krishna P.
[Murali Krishna Policharla]