Subject: RE: mplsLdpEntityIndex

From: "Cucchiara, Joan" <[email-masked]>
Date: Mon, 12 Mar 2001 12:51:50 -0500

> -----Original Message-----
> From: Anil Gunturu [mailto:[email-masked]]
> Sent: Monday, March 12, 2001 5:05 AM
> To: [email-masked]
> Subject: mplsLdpEntityIndex
> 

Hi Anil,

> 
> I know that this issue has a been addressed before. But, I am 
> still unclear
> on the concept of mplsLdpEntityIndex.

This is a secondary index which is needed for ppp.  
It may not be needed for your specific implementation,but would have to
be supported (e.g. it would have to have a valid value as specified
in the MIB).

> 
> 1. If I have an LSR (A) communicating with two peers (P1 & 
> P2) on the same
> ethernet and A is using platform-wide adressing, will I have 
> two entries in
> the mplsLdpEntityTable?
> 
>             |------- P1
>  A:0--------|
>             |------- P2
> 
> Section 3.1 in the draft-mib seem to indicate that there will be two
> entries.
> 

I don't quite understand the picture above, but there would be
two entries in the mplsLdpEntity Table based on your description.  

An entry in the mplsLdpEntityTable represents a
potential session (prior to session initialization).  The
mplsLdpSessionTable
represents sesssions which are setup or are in the process
of being setup. So if you expect 2 sessions then
you would have two entries in the mpldLdpEntityTable.  

If the LSR A is communicating to two peers then this would imply
two sessions.

> Also, is it possible for A to use different label spaces for 
> p1 and P2?

yes.

> 
> 2. What about in the case where A and B are connected over an 
> Ethernet link
> and a PPP link. B is using interface specific space and A is 
> using platform
> wide space?
>         Ether
>  <A:0>-------------<B:1>
>  <A:0>-------------<B:2>
>         PPP
> My guess is there are two entries in the mplsLdpEntityTable.

yes, again, if you anticipate two sessions, then there would
be two entries in the EntityTable.

> 
> 3. A abd B are connected over Ethernet and PPP links, but 
> both of them are
> using platform-wide label space.
>         Ether
>  <A:0>-------------<B:0>
>  <A:0>-------------<B:0>
>         PPP
> 
> Is there only one entry in this case?

This is 2 sessions, so would be two 
Entities.  Each would have some labels (non-overlapping from
the platform-wide label space) and this would be indicated
in the mplsLdpEntityConfGenericLabelRangeTable.  Please note,
the mplsLdpEntityConfGenericLabelRangeTable allows any number
of label ranges per Entity, as long as these ranges don't overlap.

  -Joan

> 
> Thanks,
> -Anil
> 
> 
> 
> 
> 
> Anil Gunturu, Software Engineer
> Ericsson, Inc                           phone: (805) 562 6431
> Datacom & IP Services                   email: 
> [email-masked]
> 70 Castilian Dr, Santa Barbara, CA-93117
>

---

From: "Anil Gunturu" <[email-masked]>
Date: Mon, 12 Mar 2001 11:15:45 -0800

Hi Joan,
Thanks for your response. It clears a lot of mud. But, can you explain why
mplsLdpEntityIndex is needed for PPP? Draft-mib also mentions this, but I am
not clear on why this is the case.
Thanks for your help,
-Anil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Cucchiara, Joan
Sent: Monday, March 12, 2001 9:52 AM
To: [email-masked]'; [email-masked]
Subject: RE: mplsLdpEntityIndex

Hi Anil,

yes.

  -Joan