Subject: help for ldp state machine

From: "zhang" <[email-masked]>
Date: Thu, 1 Mar 2001 09:50:24 +0800

Dear Mr(Mrs),
  would you please answer my questions?
 First,the ldp state machine is same as cr-ldp state machine, isn't it?
 Second, in 'LDP State Machine'(draft-ietf-mpls-ldp-state-03.txt),
Trigger Control Block contains what information?
 
Third,3.1.5.1 State -- "IDLE"
 
 State:          IDLE
 
 Event:          LDP Request
 
 New State:      Depends upon the action routine.
 
 Actions:
 
   If this LSR is the LSP Egress or Proxy Egress [2]
 
   Then:
     Choose an upstream label, connect this upstream label to the local
     IP forwarding module, allocate the resources, send the LDP-MAPPING
     upstream with the upstream label, and go to the new state
     `ESTABLISHED'.
 
   else
     Obtain a next hop (or interface) with the FEC specified in the
     LDP-REQUEST, propagate the LDP-REQUEST, with newly assigned Message
     ID by this LSR, towards the obtained next hop, and go to the new
     state `RESPONSE_AWAITED'.
 
     If the LSR uses the independent control mode [2], choose an
     upstream label, connect this upstream label to the local IP
     forwarding module, go to the ESTABLISHED state and send an LDP-
     MAPPING upstream with the upstream label.
 
   If unable to process the request for any reason, issue an LDP-NAK to
   the sender with the appropriate error code, go to IDLE and delete the
   LSP Control Block.
I think ESTABLISHED  should be RESPONSE_AWAITED, is it true?
 
Thank you very much.
 
regards,
Zhang Huachen

---

From: Eric Gray <[email-masked]>
Date: Thu, 01 Mar 2001 10:36:14 -0500

Zhang,

    Zeroeth question: Sure, be glad to.  :-)

    First question: Yes.

    Second question: The contents of the trigger control block
are implementation dependent.  The basic idea is that some
event caused the sending of a label request message and the
trigger control block is used to asynchronously tie the causal
event to the eventual response.

    Third question: No. Whenever the local LSR sends a label
mapping. the LSP is established from its perspective.

--
Eric Gray

You wrote:

>  Dear Mr(Mrs),  would you please answer my questions? First,the ldp
> state machine is same as cr-ldp state machine, isn't it? Second, in
> 'LDP State Machine'(draft-ietf-mpls-ldp-state-03.txt),Trigger Control
> Block contains what information? Third,3.1.5.1 State --
> "IDLE"  State:          IDLE  Event:          LDP Request  New
> State:      Depends upon the action routine.  Actions:    If this LSR
> is the LSP Egress or Proxy Egress [2]    Then:
>      `ESTABLISHED'.    else
>      state `RESPONSE_AWAITED'.      If the LSR uses the independent
> control mode [2], choose an
>      MAPPING upstream with the upstream label.    If unable to process
> the request for any reason, issue an LDP-NAK to
> I think ESTABLISHED  should be RESPONSE_AWAITED, is it true? Thank you
> very much. regards,Zhang Huachen