Subject: RE: New TTL Draft

From: [email-masked]
Date: Tue, 6 Mar 2001 09:44:39 -0000

Satoru/Shahram.....trying catch up on the mail backlog I have just got round
to reading this.  My take:

1	I agree with the '1-hop' concept in here since it is architecturally
correct.  That is, if one creates a trail at layer N say, then each link
connection in that trail (ie between 2 adjacent nodes at layer N) is created
by a server trail at layer N-1.  This process recurses for the layer N-1
trail and so on to the duct.  In other words, a trail at layer N has no
visibiluty, and indeed should not have visibility, of all the constituent
server layers (which may also be different technologies) that lie underneath
it.  Hence, from a client layer perspective a link connection can never be
anything but a single hop, and the TTL setting of each trail should be an
independent consideration.

2	Wrt to detecting defects that can affect LSPs please check out the
ID that was just posted (by Shahram) on MPLS OAM.  Note that this is aimed
at explicitly routed pt-pt LSPs and not plain LDP LSPs.  
http://www.ietf.org/internet-drafts/draft-harrison-mpls-oam-00.txt
I hope you find this of some value.

regards, neil
> -----Original Message-----
> From: S.Matsushima [mailto:[email-masked]]
> Sent: 28 February 2001 12:56
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: RE: New TTL Draft
> 
> 
> Shahram,
> 
> This is Satoru Matsushima.
> 
> > Hi All,
> > 
> > Interestingly a similar draft was posted today:
> > 
> > 
> http://www.ietf.org/internet-drafts/draft-satoru-mpls-1hop-lsp-00.txt
> 
> Thanks,:-)
> Actually, this draft consist of three elements:
> 
>   - TTL Processing expansion.
>   - Label distribution method for 1-hop LSP.
>   - The possible to "LSP KeepAlive" using 1-hop LSP.
> 
> So, this draft was not only TTL processing, and it was stated about
> for using 1-hop LSP. Because, I had to describe these elements when I
> tried to write about realizing 1-hop LSP in this draft.
> 
> I think Puneet's draft(and after discussion in ML) described very well
> TTL procesing for hierarchical LSP, but the 1-hop LSP(Pipe model LSP)
> is not a thing only for Diff-Serv. It is very usefull for MPLS/VPN
> operators. (I'm a MPLS/VPN operator.;-)
> Therefore, I think TTL processing expansion should be described more
> generally and be careful in label distribution mode; DU or DoD.
> (we call "Cloud model" and "Per LSP model")
> 
> "LSP KeepAlive" ability is extremely important for the applications
> which use LSP but cannnot know the state of LSP itself(for instance,
> BGP/MPLS VPNs).
> I described a method of "LSP KeepAlive" using 1-hop LSP in this draft.
> How do you think about this?
> 
> 
> regards,
> 
> --
> Satoru Matsushima
<snipped to end NH>

---

From: "S.Matsushima" <[email-masked]>
Date: Wed, 07 Mar 2001 13:44:24 +0900

Neil,

Thanks for your comments, and please see my comments in line.

From: [email-masked]
Subject: RE: New TTL Draft
Date: Tue, 6 Mar 2001 09:44:39 -0000 

> independent consideration.

Thanks, I agree too.
I think we need to more carefully describe TTL processing on
layerd(hierarchical) environment.

> I hope you find this of some value.

I have just read your draft. I think this OAM method should be have
each LSR to detect LSP defect. Is it right?
Our "KeepAlive" does not depend on particular method. It  depend
on "1-hop" method and IP as compared with OAM.(Is it CCAMP charter?)
And OAM has some useful function.(FDI,BDI,P)

But I think all of the MPLS signalling depend on IP, so "KeepAlive"
does not cause more problem(ie interoperability issue).

Regards,

--
Satoru Matsushima