Subject: RE: Expanded ERO draft

From: Bala Rajagopalan <[email-masked]>
Date: Thu, 1 Mar 2001 09:53:35 -0500

Vijay:

This weighting system is a good idea. In fact, I think
the weighting should be applied to votes on all contentious
proposals. I would also add the following weights
to your suggestion:

- People who are writing code (developers): 10x
- People who really aren't writing code, but claiming to 
  do so:  0x
- People who vaguely claim that some "customers" want
  the feature: 0x
- People who aren't aware of the issue, but simply support
  one proposal or another to please somebody:  0x
- People who are the protocol architects: 2x
- Other people: 1x

The only trouble with this scheme is, you may not have 
any votes left to count. But then, who cares? (as 
witnessed by lack of response to this voting call).

BR

- 

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked] 

> -----Original Message-----
> From: Vijay Gill [mailto:[email-masked]]
> Sent: Thursday, March 01, 2001 1:21 AM
> To: Kireeti Kompella
> Cc: [email-masked]
> Subject: Re: Expanded ERO draft
> 
> 
> On Tue, 27 Feb 2001, Kireeti Kompella wrote:
> 
> > As Yakov said, no concrete reason for adding the router ID has been
> > given.  However, we've wasted enough time and bandwidth.  Let's put
> > this to vote:
> >
> > Who all think that adding a router ID to the unnumbered ERO 
> subobject
> > would be beneficial?  A simple yes, no or don't care, please.
> 
> I would listen to what the people who are implementing this 
> have to say on
> the subject. I particularly don't care about the bandwidth/extra bytes
> argument, but as a service provider, I do care that the people who are
> implementing this do this in the simplest way possible. It makes for
> robust code and I like robust code because getting up in the AM really
> really annoys me.
> 
> So my vote ranking system would go like this ;)
> 
> People who are writing this code (developers): 10x
> People who are the protocol architects: 2x
> Other people: 1x
> 
> Lets hear it from the implementors:
> 
> thank you
> 
> /vijay
>

---

From: "Punj, Arun" <[email-masked]>
Date: Fri, 2 Mar 2001 12:10:53 -0500

> My vote (I didn't see dev. manager, but I run the group 
> that's implementing
> it, so I speak on their behalf) would be to throw the router 
> ID in there.  I
> think it's great for debugging, too.  You can look at an 
> inflight ERO and
> know exactly what it is supposed to do, without reference to 
> a TED or an
> LSDB.

I entirely concur with the views above. I think it helps in
debugging if you can just capture an *inflight* ERO and deduce
its path. Also to me simplicitly is a more important virtue than
conciseness. 

Hey by the way, I have not implemented any code for close to
a year. So my vote is 1x - Yes.

> 
> However, I would rather see a single ERO rather than both an 
> ERO and an
> EERO, and the mess of having to deal with interoperability, backwards
> compatibility.

Not too sure about merging EERO and ERO - for the very reason mentioned 
above.

Arun

> -Vach