Subject: RE: Two TE MIBs

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 25 Mar 2001 22:18:06 +0200

Inline

> ----------
> From: 	Thomas D. Nadeau[SMTP:[email-masked]]
> Sent: 	Sunday, March 25, 2001 3:07 PM
> To: 	Rao Vadlamani; [email-masked]; [email-masked]
> Cc: 	cheenu Srinivasan; Arun Viswanathan
> Subject: 	Re: Two TE MIBs
> 
> 
>          Hi,
> 
> >Could someone clarify as to why there are 2 draft TE MIB's
> >draft-ietf-mpls-te-mib-06.txt of Thomas D. Nadeu etal and
> >draft-ietf-tewg-mib-00.txt of Kireeti ? If I understand, both are going
> >for a IESG approval, too. If my understanding is correct both the MIBs
> >are giving more or less the same information. except in the second MIB
> >of kireeti, all the objects are only read-only and operator can't
My understanding is that Kireeti was going to change MAX-ACCESS to
read-create or read-write
> >exercise control over them ? What's the motivation behind this ?
> >Thanks in advance for the clarification and I am sorry to pose this
> >question if this is already raised and discussed.
> 
>          Beats me why there are two, but I am not going to beat
> a dead horse and argue about it any longer though. This was discussed
> at length late last summer, and I suggest you go back and re-read
> the archive so that you can come to your own informed conclusion.
> The outcome of the discussion at that time was that IESG agreed to
> have two.
> 
But we prefer to have no (or as few as possible) overlaps.
Maybe we need to check how this can be achieved.

My understanding at the time of a quick briefing was that they do different
things. Specifically the MIB(s) developed in MPLS WG have lots of stuff
to be able to "debug" MPLS. Also... the message I got was that the MIB
from MPLS WG was to be run at each node, while the TE-WG MIB
does not need to run at each node.

I will look into these MIBs in more detail over the next weeks.

Bert

>          --Tom

---

From: Bora Akyol <[email-masked]>
Date: Sun, 25 Mar 2001 13:26:45 -0800

Of course some of the vendors may be implementing a MIB that combines 
the best parts of both of these.

Bora
Who thinks having one MIB would have been easier.

---

From: "Rao Vadlamani" <[email-masked]>
Date: Wed, 28 Mar 2001 19:16:27 -0500

Bert,

Pl. see my comments inlined.

Thanks
Rao

> read-create or read-write

That's indeed good.

> does not need to run at each node.

A single MIB can still do both the above said functionality, I guess.

> I will look into these MIBs in more detail over the next weeks.

I look forward to your comments.