Subject: CE or PE initiated VPN connectivity

From: "Christophe Bouhier (ETM)" <[email-masked]>
Date: Thu, 8 Mar 2001 13:04:37 +0100

Hi All, 

Is there any work being done on CE or PE initiated VPN connectivity? 

Currently connections are solved using network provisioning tools (running the CLI 
or XML) to provision a PE-CE link in a VRF. I can imagine, that the VPN connection can be signalled 
by the CE using e.g. RSVP/or CR-LDP. This could be used to setup LSP's between the CE and PE for
multiple VPN subscriptions. This would also solve e.g. simulteanous use of a VPN service and 
internet access (without NAT) on the PE. LSP end-point on the CE would have different IP addresses 
(private & public) solving multiple connections on the CE and not on the PE. 

Thanks , Christophe Bouhier

---

From: Hummel Heinrich <[email-masked]>
Date: Thu, 8 Mar 2001 14:44:29 +0100

VPNs: 
provider provisioned versus customer-based, 
PE-to-PE LSPs established by the SP,
CE-to-CE LSPs established by the customer without informing the SP about its purpose,
CE-to-CE LSPs initiated/ordered by the customer but done by involving the SP (i.e. its PEs)

There are all kind of flavors and there should be a market for all of them and even for mixes of them:
E.g. some CEs are capable to install an LSP towards the right remote CE all by themselves, while others are not but need the help of the PE (as a proxy ?).

Some tunnels are MPLS while others are not.
Some are ordered at this SP, while others are ordered at another SP, but altogether should form a contiguous tunnel system.

Furthermore:  IPSEC tunnel over MPLS tunnel.

There are certainly even more aspects and combinations.

I like this discussion. It unveils the wide range of issues. IMHO, so far we all have been focussed too much on whether there should be a "VRF" or a"VR".

Heinrich

> -----Urspr> üngliche Nachricht-----
> Von:	Christophe Bouhier (ETM) [SMTP:[email-masked]]
> Gesendet am:	Donnerstag, 8. März 2001 13:05
> An:	[email-masked]; [email-masked]'
> Betreff:	CE or PE initiated VPN connectivity
> 
> Hi All, 
> 
>  << Datei: Christophe Bouhier (ETM).vcf >>