Subject: Re: RSVP & OSPF-TE ...

From: Narakasura Dumbo <[email-masked]>
Date: Thu, 1 Mar 2001 06:32:07 -0800 (PST)

Hi Tatsuya,

Thanks for the reply.

My question is where is this "color" constraint
carried in the RSVP PATH message ?

Thanks
  Pappai

--- Tatsuya Yanagibashi <[email-masked]>
wrote:
> Pappai,
> 
> narakasura Dumbo wrote:
> > 
> > I have a couple of questions
> > 
> > 1. How do we signal the "color" (32 colors that
> >    can be assigned to a link, Katz OSPF-TE draft)
> >    using RSVP-TE ?    Is this addressed somewhere
> ?
> 
> Conceptually the information of TE such like a
> "color" is used for 
> calculating the PATH under administrative
> constraints in MPLS cloud. 
> Currently CSPF is able to handle its calculation.
> After its computation 
> and calculation, Ingress LSR is going to SIGNAL by
> using RSVP-TE or 
> CR-LDP with ER(O) along the path by CSPF
> calculation.
> 
> Rgds,
> Tatsuya
> 
> -- 
>
/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
> 
>  +----+----+                  Tatsuya Yanagibashi   
>  
>  |.. .|    |
>  |_~__|    |                   Network Consultant
>  | .. |~~_~|               CoSine Communications
> Inc.
>  | .  |    |
>  +----+----+            e-mail:
> [email-masked]
>  C o S i n e                 Phone # +81-3-5219-1292
> Communications               Fax   # +81-3-5219-1201
>    
>
/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: Tatsuya Yanagibashi <[email-masked]>
Date: Sun, 04 Mar 2001 23:48:17 +0900

Pappai,

What I am understanding is "color" is not carried in RSVP PATH message.

As I menthioned you before, it is used for establishment of traffic 
engineering LSP. 

By using OSPF-TE, for example, netowrk administrator can gether some 
traffic engineering information in addition to normal link state 
database. "Color" is one of object of traffic engineering information.

I think that this "color" is designed for categorize each link between 
LSR for traffic engineering purpose. Generally TE LSP is able to 
established manually(explicitly) or dynamically(CSPF). If dynamic TE LSP 
setup is prefered by configration, you can specify that "color" as 
administrative constraint for TE LSP. I am not sure which vendor has 
implemented this feature, though.

Appreciate any comments. Thanks.

Regards,
Tatsuya Yanagibashi

 +----+----+                  Tatsuya Yanagibashi     
 |.. .|    |
 |_~__|    |                   Network Consultant
 | .. |~~_~|               CoSine Communications Inc.
 | .  |    |
 +----+----+            e-mail: [email-masked]
 C o S i n e                 Phone # +81-3-5219-1292
Communications               Fax   # +81-3-5219-1201

---

From: "Alexander Marhold" <[email-masked]>
Date: Mon, 5 Mar 2001 07:03:11 +0100

The "Colour" is implemented in Cisco IOS Traffic Engineering

on a link you can specify:
xxx (config-if)# mpls traffic-eng attribute-flags 0x00000012

and on the tunnel-interface:
yyy (config-if)# tunnel mpls traffic-eng affinity 0x00000012 mask 0x000000ff

the affinity longword (32bit) on the tunnel must match the attribute-flags
on each link for the bits which are set to 1 in the mask

The CSPF checks each link for this match before considering that link for
TE-SPF calculation.

As was already said correctly, this "Colour" is not transported ( as it has
no use) via RSVP
but the link "Colour(s)" are transported via ISIS or OSPF together with the
bandwidth information

with best regards

Alexander Marhold
Senior Consultant
PRO IN

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tatsuya
Yanagibashi
Sent: Sunday, March 04, 2001 3:48 PM
Cc: Narakasura Dumbo; [email-masked]
Subject: Re: RSVP & OSPF-TE ...

Pappai,

Regards,
Tatsuya Yanagibashi