Subject: RE: Explicit null label ?

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 26 Mar 2001 13:21:21 -0800

Is there any reason why would you even consider the second 
option?

-Anoop

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Monday, March 26, 2001 11:43 AM
> To: [email-masked]'
> Subject: Explicit null label ?
> Importance: Low
> 
> 
> Hi All,
> 
> In an MPLS network that supports TE, the constraint-based 
> routing is done via CR-LDP or RSVP-TE signaling. My question 
> is which one of the following methods have people adapted or 
> is envisioned to be superior:
> 
> 1) CR-LDP/RSV-TE signaling be done using unlabeled IP packets.
> 2) CR-LDP/RSVP-TE signaling be done using MPLS labeled packet 
> with label=0 (explicit null label).
> 
> 
> 
> Thanks,
> Shahram Davari
> Systems Engineer
> Product Research Group
> PMC-Sierra, Inc. (Ottawa)
> Phone: (613) 271-4018
> Fax:    (613) 271-7007
>  <<Shahram Davari.vcf>> 
>

---

From: Eric Gray <[email-masked]>
Date: Mon, 26 Mar 2001 16:51:52 -0500

Anoop,

    There are two cases.  The first is when LSP signaling
is used hierarchically (in which case, the explicit null may
be used by the penultimate hop for the LSP being used).
It would only be used at the last hop of an LSP hierarchy.
This does not appear to be the case that Shahram is asking
about.  The other is illustrated below.

    You have these two implementations - call them Butch
Cassidy and Sundance Kid.  Both are technically LSRs,
but Butch Cassidy signals the implicit null whenever it can
(possibly because it doesn't have a clue what to do with a
real label) and the explicit null in ALL other cases - while
Sundance Kid can't send anything but labeled packets.

    Since the explicit null label is well defined in RFC 3032,
there's theoretically no reason why Sundance Kid cannot
use explicit null labeled packets to talk to Butch Cassidy.

    Understand that I am not advocating this behavior.  In fact
far from it.  I think Butch Cassidy and Sundance Kid should
be shot.  But, that is another story...

--
Eric Gray