Subject: »Ø¸´: help for CR-LDP

From: "zhang" <[email-masked]>
Date: Wed, 21 Mar 2001 15:44:51 +0800

Eric Gray
please give me a example"This node is not the end of the LSP.", and according what
  the node adds new explicit route?
    -----Original Message-----
    ·¢¼þÈË: Eric Gray <[email-masked]>
    ÊÕ¼þÈË: zhang <[email-masked]>
    ³ËÍ: [email-masked] <[email-masked]>
    ÈÕÆÚ: 2001Äê3ÔÂ8ÈÕ 22:32
    Ö÷Ìâ: Re: help for CR-LDP

    Zhang, 
        You use an Explicit Route to designate nodes you want 
    included in an LSP.  That's all.  Practical uses of the ERO 
    currently tend to include the egress from an MPLS domain, 
    but there may be TE applications (for example) that benefit 
    from the increased dynamism of having an ERO that only 
    specifies some hop toward the middle of the MPLS cloud. 

    -- 
    Eric Gray 

    You wrote: 

         Dear Mr.(Mrs),  Please help me for a question about algorithem ofselection of the next hop.  In 4.8.1 selection of the next hop       2. If there is no second ER-HOP, this indicates the end of   the explicit route. The explicit route TLV should be removed   from the Label Request Message. This node may or may not   be the end of the LSP. Processing continues with section   4.8.2, where a new explicit route TLV may be added to the   Label Request Message. But why "This node may or may not be the end of the LSP."? RegardsZhang.

---

From: ietf <[email-masked]>
Date: Wed, 21 Mar 2001 11:40:47 -0700

Zhang,

    A simple example (like I said, no one may do this
in practice).  I could simply decide to releave a node
that is congested by deliberately routing traffic toward
another node that is not.  There may be lots of ways
to ensure that the redirected traffic does not still end
up traversing the congested node without explicitly
excluding it (by explicitly listing all included nodes) in
any ERO.  To do this, I should be able to specify an
explicit route that only contains the desired alternate
node as a loose hop.  In practice, this is not noticeably
different from simply terminating the TE LSP at that
node.

--
Eric Gray

zhang wrote:

>  Eric Grayplease give me a example"This node is not the end of the
> LSP.", and according what  the node adds new explicit route?
>
>     >  Dear Mr.(Mrs),  Please help me for a question about
>     > algorithem ofselection of the next hop.  In 4.8.1
>     > selection of the next hop       2. If there is no second
>     > ER-HOP, this indicates the end of   the explicit route.
>     > The explicit route TLV should be removed   from the Label
>     > Request Message. This node may or may not   be the end of
>     > the LSP. Processing continues with section   4.8.2, where
>     > a new explicit route TLV may be added to the   Label
>     > Request Message. But why "This node may or may not be the
>     > end of the LSP."? RegardsZhang.
>

---

From: gopinathg <[email-masked]>
Date: Thu, 22 Mar 2001 15:03:20 +0530

Eric Gray

    In your example I just want to conform & clarify
the following from u..

 I think CR-LDP packet will have both ER-HOP and
FEC (ie similar to FEC in LDP but not CR-LSP FEC
element). If its is true ,at the last ER-HOP we need to
get the next hop as per the LDP specifications..

Thanks In Advance

gopinathg

>>      > end of the LSP."?RegardsZhang.
>>