Subject: Preconfigured EXP<-->PHB mapping for E-LSPs

From: Jayaram Beladakere <[email-masked]>
Date: Tue, 27 Mar 2001 11:06:29 -0800

The following is from "MPLS Support of Differentiated Services"
(draft-ietf-mpls-diff-ext-08.txt).

3.2.1 Preconfigured EXP<-->PHB mapping
....
In case, the preconfigured EXP<-->PHB mapping has not actually been
configured by the Network Administrator, the LSR should use a
default preconfigured EXP<-->PHB mapping which maps all EXP values
to the Default PHB.

In the above case, the LSR provides Default PHB treatment to all labeled
packets (belonging to LSPs with preconfigured EXP<-->PHB mapping).  What
shall be the value of the outgoing EXP field for such labeled packets, both
with label-swap and label-push operations at the LSR?  In particular, shall
the outgoing EXP match incoming EXP, or shall it be '000'?  Is there a
difference if the label operation is swap rather than push?

Regards,
Jayaram Beladakere
Mahi Networks, Inc.

---

From: Shahram Davari <[email-masked]>
Date: Wed, 28 Mar 2001 08:21:23 -0800

Hi Jayaram,

The intention of configured E-LSPs is to have the MPLS+Diffserv network behave the same as a Diffserv-only network. Since RFC-2474 section 3 says:

"
   Packets received with an unrecognized codepoint SHOULD be forwarded
   as if they were marked for the Default behavior (see Sec. 4), and
   their codepoints should not be changed.  Such packets MUST NOT cause
   the network node to malfunction. "

So the answer to you question is that the EXP should be left unchanged in the normal swap operation. 

It is however, possible to push another label and have either non-configured, configured or even signaled E-LSP for the new LSP (which we call tunnel-LSP). In that case depending on the type of the tunnel (Uniform or pipe), the top label could have its EXP set to the same EXP, or to the  Default EXP or something else.

In case the tunnel-LSP is a uniform tunnel that is a non-configured (and non-signaled) E-LSP, then the same behavior as explained in the above quote from RFC-2474 is the correct behavior (i.e., setting the EXP of the pushed label to the same EXP as the incoming label). 

Yours,
-Shahram

> -----Original Message-----
> From: Jayaram Beladakere [mailto:[email-masked]]
> Sent: Tuesday, March 27, 2001 2:06 PM
> To: [email-masked]'
> Subject: Preconfigured EXP<-->PHB mapping for E-LSPs
> 
>