Subject: AW: new draft on multicast traffic engineering with mpls

From: Hummel Heinrich <[email-masked]>
Date: Wed, 7 Mar 2001 10:34:20 +0100

Dirk,

in my draft-hummel-ppvpn-tunnel systems-00.txt I provide an algorithm for computing a minimal tree between n given nodes.
It selects from the n*(n-1)/2 candidate routes between any two of the n nodes those n-1 routes which are shortest but which
assure that all nodes are contiguously interconnected.

A comparison with normal Dijkstra: 
Given: Network with 300 nodes and 550 links. 
1 Root node and 99 leaf nodes.
The Dijkstra tree (shortest path between root and any leaf ) uses 204 links.
The minimal tree uses 160 links. 

I could imagine a multicast model, whereby a minimal skeleton tree is formed based on the early subscribers (rather than to have
a "single point skeleton tree called RP" ) and where further JOIN requests build subtrees rooted at the (closest) leaf node of the initial skeleton tree.

Heinrich

> -----Urspr> üngliche Nachricht-----
> Von:	Dirk Ooms [SMTP:[email-masked]]
> Gesendet am:	Montag, 5. März 2001 16:05
> An:	[email-masked]; [email-masked]
> Betreff:	new draft on multicast traffic engineering with mpls
> 
> FYI
> 
> http://search.ietf.org/internet-drafts/draft-ooms-mpls-multicast-te-00.txt
> 
> Abstract
> 
>    There are several reasons for operators to construct multicast trees
>    by another means than multicast routing protocols.  This document
>    lists these reasons and describes 2 ways of building a multicast
>    traffic-engineered tree: root-initiated tree and leaf-initiated tree.
>    Finally it defines extensions to CR-LDP to support MPLS multicast
>    traffic engineering.
> 
> 
> -- 
> Dirk Ooms                       mailto:[email-masked]
>                                 tel:+32 3 2404732
> Network Strategy Group (NSG)    http://aww.alcatel.com/nsg
> Alcatel                         http://www.alcatel.com

---

From: Dirk Ooms <[email-masked]>
Date: Wed, 07 Mar 2001 10:56:18 +0100

Heinrich,

Indeed, plenty of bandwidth can be saved by constructing other than
shortest-path trees.  In my view the algorithm itself is not subject to
standardization (as long as it is not executed in a distributed
fashion), only the signaling to establish the trees is.  Anyway I'll
wait for the announcement of your draft to further comment.

dirk