Subject: doubt regarding transport address advertisement (LDP/RFC-3036)

From: "Ashish Vyas" <[email-masked]>
Date: Tue, 13 Mar 2001 13:34:04

The following sections are picked up from RFC 3036.

------------section 1-------------------

"An LSR MUST advertise the same transport address in all Hellos that advertise the same label space. This requirement ensures that two LSRs linked by multiple Hello adjacencies using the same label spaces play the same connection establishment role for each adjacency."

----------section 2--------------------------

LSR1 determines the transport addresses to be used at its end (A1) and LSR2's end (A2) of the LDP TCP connection. Address A1 is determined as follows:

a. If LSR1 uses the Transport Address optional object (TLV) in Hello's it sends to LSR2 to advertise an address, A1 is the address LSR1 advertises via the optional object;

b. If LSR1 does not use the Transport Address optional object, A1 is the source address used in Hellos it sends to LSR2.

---------------------end-of-section2-------

Suppose there are multiple links between LSR1 and LSR2. IF LSR1 does not use the Transport Address optional object, the Transport address will be the source address used in HELLOs it sends to LSR2 (as specified in section-2) and HELLOs sent on multiple links will be having different source addresses.

BUT RFC-3036 clearly says: "An LSR MUST advertise the same transport address in all Hellos that advertise the same label space". (Refer section-1 given above). How can it be done?

I hope my interpretation of given sctions are correct.

Regards

-Ashish

Get your FREE download of MSN Explorer at http://explorer.msn.com

---

From: Bob Thomas <[email-masked]>
Date: Tue, 13 Mar 2001 08:53:40 -0500

Ashish,

> <html><DIV>
> <P>The following&nbsp;sections are&nbsp;picked up from RFC 3036.</P>
> <P>------------section 1-------------------</P>
> <P><FONT color=#3300cc>"An LSR MUST advertise the same transport address in all Hellos that advertise the same label space. This requirement ensures that two LSRs linked by multiple Hello adjacencies using the same label spaces play the same connection establishment role for each adjacency."</FONT></P>
> <P><FONT face="Courier New" size=2>&nbsp;----------section 2--------------------------</FONT></P>
> <P><FONT face="Courier New" size=2><FONT color=#330099>LSR1 determines the transport addresses to be used at its end (A1) and LSR2's end (A2) of the LDP TCP connection. Address A1 is determined as follows:</FONT></P>
> <P><FONT color=#330099>a. If LSR1 uses the Transport Address optional object (TLV) in Hello's it sends to LSR2 to advertise an address, A1 is the address LSR1 advertises via the optional object;</FONT></P>
> <P><FONT color=#330099>b. If LSR1 does not use the Transport Address optional object, A1 is the source address used in Hellos it sends to LSR2.</FONT></P>
> <P>---------------------end-of-section2-------</P>
> <P>Suppose there are multiple links between LSR1 and LSR2. IF LSR1 does not use the Transport Address optional object, the Transport address will be the source address used in HELLOs it sends to LSR2 (as specified in section-2) and&nbsp;HELLOs sent on multiple links will be having different source addresses.</P>
> <P>BUT&nbsp;RFC-3036 clearly says: "An LSR MUST advertise the same transport address in all Hellos that advertise the same label space". (Refer section-1 given above). How can it be done?</P>

In this case, LSR1 is violating the protocol.

Suppose links 1, 2, and 3 connect LSR1 and LSR2, and suppose LSR1 wants to
advertise the same label space in the Hellos it sends on these links.

If LSR1 omits the Transport Address TLV for Hellos on link 1, then it
must use the Transport Address TLV for Hellos on links 2 and 3 to
specify the source address used in its link 1 Hellos.

Bob

> <P>I hope my interpretation of given sctions are correct.</P>
> <P>Regards</P>
> <P>-Ashish</P>
> <P></FONT><BR></P></DIV>
> <DIV></DIV>
> <DIV></DIV>
> <DIV>&nbsp;</DIV><br clear=all><hr>Get your FREE download of MSN Explorer at <a href="http://explorer.msn.com">http://explorer.msn.com</a><br></p></html>

---

From: Eric Gray <[email-masked]>
Date: Tue, 13 Mar 2001 11:45:47 -0500

Alternatively, for implementations that can do so, the
implementer can set the IP address which will be used
in sending the hello messages on a set of interfaces
such that the resulting transport address is the same.
There are more difficulties to overcome in using this
approach, however, than there are in Bob's suggested
approach.

--
Eric Gray

---

From: Bob Thomas <[email-masked]>
Date: Tue, 13 Mar 2001 12:23:17 -0500

> such that the resulting transport address is the same.

Agreed.

Bob