Subject: Explicit null label ?

From: Shahram Davari <[email-masked]>
Date: Mon, 26 Mar 2001 11:42:36 -0800

Hi All,

In an MPLS network that supports TE, the constraint-based routing is done via CR-LDP or RSVP-TE signaling. My question is which one of the following methods have people adapted or is envisioned to be superior:

1) CR-LDP/RSV-TE signaling be done using unlabeled IP packets.
2) CR-LDP/RSVP-TE signaling be done using MPLS labeled packet with label=0 (explicit null label).

Thanks,
Shahram Davari
Systems Engineer
Product Research Group
PMC-Sierra, Inc. (Ottawa)
Phone: (613) 271-4018
Fax:    (613) 271-7007
 <<Shahram Davari.vcf>>

---

From: Shahram Davari <[email-masked]>
Date: Mon, 26 Mar 2001 13:35:32 -0800

Hi Anoop,

In the second option, the LSRs recieve only labeled packets. This could potentially reduce hardware requirement.

Yours,
-Shahram

> -----Original Message-----
> From: Anoop Ghanwani [mailto:[email-masked]]
> Sent: Monday, March 26, 2001 4:21 PM
> To: Shahram Davari; [email-masked]'
> Subject: RE: Explicit null label ?
> 
> 
> 
> Is there any reason why would you even consider the second 
> option?
> 
> -Anoop
> 
> > -----Original Message-----
> > From: Shahram Davari [mailto:[email-masked]]
> > Sent: Monday, March 26, 2001 11:43 AM
> > To: [email-masked]'
> > Subject: Explicit null label ?
> > Importance: Low
> > 
> > 
> > Hi All,
> > 
> > In an MPLS network that supports TE, the constraint-based 
> > routing is done via CR-LDP or RSVP-TE signaling. My question 
> > is which one of the following methods have people adapted or 
> > is envisioned to be superior:
> >

---

From: [email-masked]
Date: Mon, 26 Mar 2001 15:51:02 -0700

Eric,

You gave yourself away...I agree...implementation is the step before revenue and
deep into the cost cycle...an achillies heel.

Your;
"In protocol implementation and deployment,
surprises are seldom good."
an axion to live by!

Patrick Diamond