Subject: RE: LDP MIB

From: "Vijayanand Chandrasekar" <[email-masked]>
Date: Wed, 28 Feb 2001 11:30:28 +0530

Hello,

Is it always true that for per platform label space there is a one to many
relationship between Entity and Session. If so, what is the significance of
Entity Index.Why is given in LDP MIB that entity Index is optional for
implementations.

Thanks in advance,
Regards,
Vijay

-----Original Message-----
From: Mohan Varma K [mailto:[email-masked]]
Sent: Friday, March 23, 2001 3:02 PM
To: 'Vijayanand Chandrasekar'
Subject: RE: LDP MIB

Hi,
     The Entity and the session will be one -one in per interface(ATM/FR)
scenario
but not in per platform.
      The Entities configuration will never get changed and  the negotiated
information will be in the session table like the intersected label
range(etc..).
Mohan

I have asked this question twice before but have'nt been able to get a
reply.Can anyone please reply.

IF there is a one to one correspondence between Entity and Session how will
the entity be initialised. Should'nt each entity be configured initially
with Label range, Label space, Targetted peer address etc, so that this info
will be used for peer discovery and session establishment.The LdpId used in
the PDU is that of the entity which should have been configured.If this is
so then how can the number of sessions(hence entities) be known apriori,
since this is as a result of peer discovery.
 Also, in the Entity Table the Enity Index is given as optional for
implementations, what is the reason for this?

Does it mean that we start of with an Enity configuration intially and for
each new peer discovered and sesssion established the Entity Table is
updated.

Thanks in advance,
Regards,
Vijay

---

From: Hans Sjöstrand <[email-masked]>
Date: Thu, 29 Mar 2001 10:06:43 +0200

Vijay,

I don't understand where you've read that the entity Index is
optional. An index can never be optional, it has to have a legel
value (in this case 1..4294967295) and should be obtained from the
'mplsLdpEntityIndexNext' object as written in the mib.

Joan earlier replied to Anil on the subject some week agoe.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Cucchiara, Joan
> Sent: den 12 mars 2001 18:52
> To: [email-masked]'; [email-masked]
> Subject: RE: mplsLdpEntityIndex
>
> > From: Anil Gunturu [mailto:[email-masked]]
> > Sent: Monday, March 12, 2001 5:05 AM
> > To: [email-masked]
> > Subject: mplsLdpEntityIndex
> >
>
> Hi Anil,
>
> >
> > I know that this issue has a been addressed before. But, I am
> > still unclear
> > on the concept of mplsLdpEntityIndex.
>
> This is a secondary index which is needed for ppp.
> It may not be needed for your specific implementation,but would have to
> be supported (e.g. it would have to have a valid value as specified
> in the MIB).
>

Regards
/// Hasse

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Vijayanand Chandrasekar
> Sent: den 28 februari 2001 07:00
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: LDP MIB
>
>
> Hello,
>