Subject: doubt related to draft-ietf-mpls-cr-ldp-05.txt

From: "George Thomas" <[email-masked]>
Date: 16 Jul 2001 13:35:47 -0000

Hi,

I just started reading the CR-LDP draft.
Its mentioned in the CR-LDP Label-request message
that the ER-TLV is optional. Without ER-Hops how explicit
tunnels will be established? Is should be a mandatory object right. Could you please tell me, in which scenario it can be an optional object. 

Thanks and Regards,
George

____________________________________________________
http://www.monsterindia.com - The Best Jobs. For the Best Minds.

---

From: "Mohan Verma" <[email-masked]>
Date: Mon, 16 Jul 2001 21:42:08 +1000

Hi,
   There is egressId in the te-mib as index
 through which I hope you can still get the
 tunnel??
mohan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of George
Thomas
Sent: Monday, July 16, 2001 11:36 PM
To: [email-masked]
Subject: doubt related to draft-ietf-mpls-cr-ldp-05.txt

Hi,

I just started reading the CR-LDP draft.
Its mentioned in the CR-LDP Label-request message
that the ER-TLV is optional. Without ER-Hops how explicit
tunnels will be established? Is should be a mandatory object right. Could
you please tell me, in which scenario it can be an optional object.

Thanks and Regards,
George

---

From: Eric Gray <[email-masked]>
Date: Mon, 16 Jul 2001 14:50:35 -0400

George,

    If you look at the format for CR-LDP Label Request and Label Mapping
messages, you will see that there are several TLVs that are optional.  If
you further compare these with the TLVs defined in CR-LDP and not in
LDP, you will see that either of these standard messages formats can be
a CR-LDP message if they contain any of these CR-LDP defined TLVs.

    Also, there are specific restrictions on the use of LDP specified behavior
in CR-LDP - i.e. - only DoD label distribution and ordered control mode
are used (further implying conservative label retention).

    Hence it might make sense to send a CR-LDP Label Request without an
explicit route object.  For certain, it does no harm to allow an implementation
to do so, since such a message (in the simplest case) is the same as an LDP
specified message.  Since it does not add to the protocol complexity to allow
omission of the TLV and there may be a reason to do so, then there is little
point in making it mandatory.

--
Eric Gray