Subject: Question about FTN MIB

From: Roberto Guglielmi <[email-masked]>
Date: Tue, 24 Jul 2001 17:38:09 +0200

Hi all,

draft-ietf-mpls-ftn-mib-00 staes that the object "mplsFTNActionPointer"
in table "mplsFTNEntry", if "mplsFTNActionType" is redirectLsp(2),
indicates the instance of mplsXCEntry for the LSP to redirect matching
packets to. What's the format of such an object? Is the value
"1.3.6.1.3.96.1.9.1.mplsXCIndex", where mplsXCIndex is in the range
1..2147483647, correct?

Thanks in advance,
Roberto

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 24 Jul 2001 13:59:43 -0400

>"1.3.6.1.3.96.1.9.1.mplsXCIndex", where mplsXCIndex is in the range

         First, I believe that the MIB is up to revision -01,
so make sure that you are looking at the most recent
version. Second, since the action pointer is a RowPointer,
it should contain the OID of the first column of the XCEntry
in the appropriate row: ...mplsXcIndex.<x>.<y>.<z>.<p>
where x, y, z, p are the indexes of the XcEntry.
The NMS can then do successive gets on the remainder
of the columns in this table to get the appropriate
values.

         --Tom