Subject: TC_Prempt in RSVP_TE

From: Manoj Agiwal <[email-masked]>
Date: Tue, 24 Jul 2001 10:58:49 +0530

Hi ,
         Draft says ,

   "If the requested bandwidth is available, but
   is in use by lower priority sessions, then lower priority sessions
   (beginning with the lowest priority) MAY be pre-empted to free the
   necessary bandwidth"

   What will happen to the label allocated for this LSP  ?

   What will happen to the reservations for this LSP at other nodes ?

    Will  preemption priority be used while Label allocation in case if
    the Label pool is exhausted .
    Or it is going to work only for bandwidth ?

Regards ,
Manoj

---

From: "Feng, Mark" <[email-masked]>
Date: Tue, 24 Jul 2001 10:37:06 -0700

> -----Original Message-----
> From: Manoj Agiwal [mailto:[email-masked]]
> Sent: Monday, July 23, 2001 10:29 PM
> To: [email-masked]'
> Subject: TC_Prempt in RSVP_TE
> 
> 
> Hi ,
>          Draft says ,
> 

Implementation dependent.
 
>    What will happen to the reservations for this LSP at other nodes ?

IMO, nothing. The node where the pre-emption occurs sends out
PathErr/ResvErr. Other nodes either forward the message, or process it; but
the reservation should still be intact. In other words, no action is taken
until the point the edge router receives the error.
 
>     Or it is going to work only for bandwidth ?

IMO, it is implementation dependent.