Subject: LDP mib question

From: "Ju, Yu" <[email-masked]>
Date: Thu, 19 Jul 2001 12:11:37 -0400

Hi,

I have several questions regarding draft-ietf-mpls-ldp-mib-07.txt.

1) When mplsLdpEntityIndex is needed to identify an LDP entity? It looks to
me that mplsLdpEntityLdpId itself is good enough.

2) mplsLdpEntityConfGenericIfIndexOrZero represents either the
InterfaceIndex of the 'ifLayer" where there Generic Label would be created.
What if there are multiple interfaces that use the same label range?
mplsLdpEntityConfGenericIfIndexOrZero  can only hold one interfaceIndex
value.

3) Isn't mplsLdpPeerId itself good enough to identify a LDP peer? Why
mplsLdpEntityLdpId and mplsLDPEntityIndex are also part of the index of
mplsLdpPeerEntry?

Thanks,

Yu

---

From: "HariKishan" <[email-masked]>
Date: Thu, 19 Jul 2001 09:52:38 -0700

Yu,
	Here are some reasons for this !!

1) The tables are designed so that Multiple LDP entities exist
   on a single interface.( e.g. Ethernet ). One would want to
   configure the label distribution mode per LSR reachable on
   an interface (e.g. Ethernet using per plat form label space).

2) Multiple LDP entities can exist with the same label space(LDP ID);
  Each entity refers to exactly one label space(LDP ID), but several
  entities may refer to the same LDP ID

3) Multiple LDP entities can exist on a single interface ( typically
   a multi-access interface such as Ethernet);

The case 2 in your e-mail :-
	I think there will be 2 different entities with same label
space id (may/may not be with same label range) and each one
pointing to it's own interface index.

thanks,
Kishan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
> Of Ju, Yu
> Sent: Thursday, July 19, 2001 9:12 AM
> To: [email-masked]'
> Subject: LDP mib question
>
>
> Hi,
>

---

From: Joan Cucchiara <[email-masked]>
Date: Thu, 19 Jul 2001 17:19:27 -0400

> Hi,

Hi Yu,

> me that mplsLdpEntityLdpId itself is good enough.

At one point we had only one index and were asked to 
add a second index (particularly for PPP).   In order to
allow the LDP MIB to be supported by the different implementations (such
as PPP)
a second index was added.  If your implementation doesn't make use
of this second index, it does still need to be supported for SNMP.

> mplsLdpEntityConfGenericIfIndexOrZero  can only hold one interfaceIndex

Yes, and this ifIndex value should appear in the ifStack such that
the layers under this ifIndex will lead to ifIndices for the
physical ports (Ethernet or whatever).  That is what is meant by the
InterfaceIndex of
the "ifLayer" where these generic labels are created (iftype of 166).  
The generic labels need to be maintained and co-ordinated across more
than one
physical port in the perPlatform case.

> mplsLdpEntityLdpId and mplsLDPEntityIndex are also part of the index of

Peer information is learned by a specific 
LDP entity during session initialization so that is
why it is indexed as it is.  The indexes enforce
this relationship of between a given entity and 
peer.

  -Joan