Subject: Re: When to create label bindings

From: Robert Raszuk <[email-masked]>
Date: Mon, 09 Jul 2001 04:56:24 -0700

Bryan,

> It seems that LSRs do not automatically create labels

Extremely wrong !!! MPSL is control driven not data driven.

> for all flows since it
> is not economical to do so for very short flows.

MPLS in your definition is extremely not economical as it creates all
possible bindings even before any packet arrives. In addition some of
those bindings will be maintained by all LSRs as long as there is route
to their dst in IGP table and may never even be used. 

I would suggest to read MPLS related RFCs or available books as a
starter.

R.

> Bryan W wrote:
> 
> I am trying to learn MPLS and have the following question:
> 
> It seems that LSRs do not automatically create labels for all flows since it
> is not economical to do so for very short flows.  However, what triggers the
> label creation?  is it a simple rule that specifies, for example, to create
> a label when 5 packets arrive from the same FEC?  if so, would there be a
> time limit to the frequency of the packets such that if no packets arrive
> after a certain time the flow and the label will expire? if a label is
> created, in the above example, after 5 packets arrive, would that imply that
> the label is a waste if the flow/FEC only has 5 packets?
> 
> Thanks,
> 
> BW
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com
> 
> -------
> The MPLS-OPS Mailing List
> Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
> Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Eric Gray <[email-masked]>
Date: Mon, 09 Jul 2001 10:47:54 -0400

Robert,

    I did not see the original posting on this.  Another place to look for some
ideas on this issue is at http://www.mindspring.com/~ewgray/faq.htm#FLOW.
Naturally, I think the idea of reading a book on MPLS is a good idea as well.

--
Eric Gray

---

From: "Larry Khirallah" <[email-masked]>
Date: Mon, 9 Jul 2001 11:13:52 -0400

> -----Original Message-----
> From: Bryan W [mailto:[email-masked]]
> Sent: Monday, July 09, 2001 11:05 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: When to create label bindings
>
>
> a label when 5 packets arrive from the same FEC?

   this would be an example of 'data-driven' label bindings, and the 'simple
rule'
 is configurable..

> if so, would there be a
    i guess it depends upon your definition of 'waste'...  in most reallife
 situations, you would select to configure a 'threshold' number which
defines
 a high degree of likelihood that a 'flow' would continue once the
'threshold'
 is reached...    you could 'age' the binding if you like, and configure it
 to 'unbind' after a certain expiration period...    once again, alot is
left
 to the designer:)

  larry k