Subject: RE: [MPLS] Popping Multiple Labels

From: "Jiang, Donghua (Donghua)" <[email-masked]>
Date: Tue, 17 Jul 2001 16:30:53 -0400

Manish,

I could not see why it is not possible.

Regards,
Jane
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 12:06 PM
To: [email-masked]
Subject: [MPLS] Popping Multiple Labels

Hi,

I was wondering if there are any possible scenarios in which
a node might pop multiple labels from the stack.  One case
I was thinking of is : a node is endpoint of a tunnel (T1) and
is also a penultimate hop for another tunnel (T2) and T2 is
tunneled over T1!  Maybe this is not a valid scenario but I
would like to check.

I appreciate any help.

thanks,
manish

PS: Scenario

  +-----+         +-------+               +-------+         +------+
  |     | ===~==  |       |  ====~~===    |       +---------+      |
  | L1  |         | L21   |               | L2n   |         | L3   |
  +-----+         +-------+               +-------+         +------+

                  <------------  T1 -------------->
         <--------------------------T2---------------------->

---

From: Manish Godara <[email-masked]>
Date: Tue, 17 Jul 2001 15:58:47 -0700 (PDT)

Thanks Jane.  Also, I think the BGP/MPLS VPNs may need to
pop two labels at the PE router if the penultimate hop is not popping
the top label, right?

thanks,
manish