Subject: draft-pan-lsp-ping-00.txt

From: Shahram Davari <[email-masked]>
Date: Mon, 9 Jul 2001 14:02:22 -0700

Hi,

An observations/question:

The draft says that the LSP ping packets are sent to the egress LSR with UDP encapsulation. I assume the IP address of the Ping packets are set to the IP address of the desired egress LSR. What happens if a ping packet is delivered to an undesired egress LSR? From the MPLS architecture point of view, it seems that the undesired egress LSR will probably try to forward the Ping packet to the desired LSR using the IP address in the Ping packet, which eventually could send echo-reply back to source. Therefore although the LSP has a wrong path the source will never find out. 

Yours,
Shahram Davari

 <<Shahram Davari.vcf>>

---

From: Yangguang Xu <[email-masked]>
Date: Mon, 09 Jul 2001 19:35:51 -0400

Hello,

It's good question. One possible solution is that the penultimate hop should
make sure the LSP ping is from its IP fast data path and the egress LSR should
make sure the LSP ping is from the penultimate hop directly. Right?

Yangguang

---

From: Yangguang Xu <[email-masked]>
Date: Mon, 09 Jul 2001 19:39:22 -0400

Hello,

It's good question. One possible solution is that the penultimate hop should
make sure the LSP ping is from its IP fast data path (there seems to be some
extra work here) and the egress LSR control plane should make sure the LSP ping
is from its penultimate hop directly. Right?

Yangguang

---

From: Sanjay Wadhwa <[email-masked]>
Date: Tue, 10 Jul 2001 08:37:05 -0700 (PDT)

The ingress could send this packet with IP ttl of 1 since the intention
is to never ip forward this packet. The wrong egress in this case would
drop it which is the desired behaviour.

-Sanjay

--- Shahram Davari <[email-masked]> wrote:
> The draft says that the LSP ping packets are sent to the egress LSR
> with UDP encapsulation. I assume the IP address of the Ping packets
> are set to the IP address of the desired egress LSR. What happens if
> a ping packet is delivered to an undesired egress LSR? From the MPLS
> architecture point of view, it seems that the undesired egress LSR
> will probably try to forward the Ping packet to the desired LSR using
> the IP address in the Ping packet, which eventually could send
> echo-reply back to source. Therefore although the LSP has a wrong
> path the source will never find out. 
> 
> Yours,
> Shahram Davari
> 
>  <<Shahram Davari.vcf>> 
> 

> ATTACHMENT part 2 application/octet-stream name=Shahram Davari.vcf

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/