Subject: RE: Diffserv or Intserv with rsvp-te?

From: "Roberto Mameli (ERI)" <[email-masked]>
Date: Fri, 27 Jul 2001 11:44:48 +0200

Hi Khuzema,

in <draft-ietf-mpls-rsvp-lsp-tunnel-08.txt> section 2.3 states:

"This document does not restrict the type of Integrated Service requests for reservations.  However, an implementation SHOULD support the Controlled-Load service [4] and the Class-of-Service service, see Section 4.8.".

Therefore it seems that there is a new service class for RSVP-TE extension, i.e. the Class-of-Service service. So, not a new TSpec type, but simply a new class of service defined within the IntServ TSpec. However, there is no section 4.8 that explains it, and unfortunately I've not been able to find references anywhere. By the way, is there anyone that knows something about it?

Moreover section 5.6 of <draft-ietf-mpls-diff-ext-09.txt> states that:

"Both E-LSPs and L-LSPs can be established with bandwidth reservation or without bandwidth reservation. As specified in [RSVP_MPLS_TE], to establish an E-LSP or an L-LSP with bandwidth reservation, Int-Serv's Controlled Load service (or possibly Guaranteed Service) is used and the bandwidth is signaled in the SENDER_TSPEC (respectively FLOWSPEC) of the path(respectively Resv) message. As specified in [RSVP_MPLS_TE],to establish an E-LSP or an L-LSP without bandwidth reservation, the Null Service specified in [NULL] is used.".

So no Class-of-Service here is cited. Instead Controlled Load or Null Service type are suggested, and mapping between CoS and LSP is signaled through the DiffServ Object in the Path Message. Any clarification about that?

Regards
Roberto

> -----Original Message-----
> From: Khuzema Pithewan [mailto:[email-masked]]
> Sent: Friday, July 27, 2001 8:18 AM
> To: [email-masked]'
> Subject: Diffserv or Intserv with rsvp-te?
> 
> 
> Hi,
> 
> As rsvp-te carries IntServ Tspecs, is it necessary to be 
> intserv mechanism
> in place for rsvp-te to work, or there can be diffserv? 
> 
> If diffserv can be use then how does intserv Tspec maps to 
> diffserv PHBs.?
> 
> Regards,
> Khuzema.
> ------------------------------------------------
> Net Brahma Technologies Private Limited
> Internext Networking Software
> A Microland Group Company
> 777, 3rd 'a' cross, 18th Main 
> Koramangala VI th block
> Bangalore-95
> Phone no.s - (080) 5521451 / 5525011 / 5525012  Ext. 232
> Fax no        - (080) 5537233 
> email : [email-masked]
> www.netbrahma.com
>

---

From: David Charlap <[email-masked]>
Date: Fri, 27 Jul 2001 10:45:53 -0400

"Roberto Mameli (ERI)" wrote:
> "This document does not restrict the type of Integrated Service
> requests for reservations.  However, an implementation SHOULD
> support the Controlled-Load service [4] and the Class-of-Service
> service, see Section 4.8.".

This is vestigial from a previous revision.

The CoS C-Type was deleted in revision -08 of the RSVP-TE draft. 
Instead, IntServ Null-Service should be used when signaling those kinds
of LSPs.

This has been answered many times in the past.  See the mailing list
archives for more discussion.

-- David

---

From: Eric Gray <[email-masked]>
Date: Fri, 27 Jul 2001 10:50:32 -0400

Roberto,

    The dangling reference has been previously pointed out on the list
and George Swallow has previously promised to fix it in the final
editing of the draft.  Last I heard (a small number of weeks ago),
George was really close to having that final editing version done.

    How about it George?

--
Eric Gray

---

From: George Swallow <[email-masked]>
Date: Fri, 27 Jul 2001 11:29:06 -0400

> This is vestigial from a previous revision.

Yes.  In fact the dangling reference has been corrected in draft-09.
But I was asked to hold up publication of that while the IANA did a
final pass.  That ball seems to have been dropped and I've been
pinging folks to get it moving again.

> archives for more discussion.

...George

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824