Subject: TE-MIB and RSVP

From: "Manasa M" <[email-masked]>
Date: Tue, 03 Jul 2001 03:14:05 +0800

Hi,

1)Can we have a parallel tunnels with same tunnel id but, with a different tunnel instances running and
loading sharing traffic with different paths altogether from ingress to egress, not just for 
make before break or rerouting a part of the path.
for example in the case of SONET/SDH ring, can we use it as one instance is for working path and 2nd instance is for protection path?

2) why is the restrction of tunnel id to be just 16 bit in RSVP-TE, is there any technical reason behind it?  as it may be problem if we have lots of unnumbered interfaces expecially in packet router with lots of ppp/vpn links?

rgds
manasa

-- 

_______________________________________________
FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

FREE PC-to-Phone calls with Net2Phone
http://www.net2phone.com/cgi-bin/link.cgi?121

---

From: Suresh Katukam <[email-masked]>
Date: Mon, 02 Jul 2001 16:52:58 -0700

Manasa,

> for example in the case of SONET/SDH ring, can we use it as one instance is for working path and 2nd instance is for protection path?

For Load Sharing, It does not have to be a same tunnel ID as long as
Source and Destination know that there are two LSPs for Load Sharing.

Anyways, Yes, You can have same Tunnel ID with different LSP ids. This
is possible and it is upto Source and Destination to use these LSPs the
way they want. If you do not use SE bit, then these are for all practical
purposes, are two different LSPs. You could use SE bit to avoid setting up
bandwidth twice on a common set of links. 

For example, in SONET BLSR, I do not think that you need to set up
two instances of LSPs since standard BLSR mechanism takes care of protection.
Ofcourse, this results in adjacent nodes time out RSVP states etc. I
think you are not supposed to delete the LSP except indicate to Source
or Destination of the LSP that you lost connection with your neighbor. 
Source or Destination can look into the health of LSP data traffic and
also realize that BLSR link went down, it could keep the LSP alive 
until it sees the data on LSP is affected.

For Standard UPSR, similar mechanism applies.

For Virtual UPSR (Or 1+1 path Protection), you would set up two
LSPs with same Tunnel ID, but different LSP ids.

Thanks,
Suresh