Subject: [MPLS] Popping Multiple Labels

From: <[email-masked]>
Date: Tue, 17 Jul 2001 12:05:34 -0700 (PDT)

Hi,

I was wondering if there are any possible scenarios in which
a node might pop multiple labels from the stack.  One case
I was thinking of is : a node is endpoint of a tunnel (T1) and
is also a penultimate hop for another tunnel (T2) and T2 is
tunneled over T1!  Maybe this is not a valid scenario but I
would like to check.

I appreciate any help.

thanks,
manish

PS: Scenario

  +-----+         +-------+               +-------+         +------+
  |     | ===~==  |       |  ====~~===    |       +---------+      |
  | L1  |         | L21   |               | L2n   |         | L3   |
  +-----+         +-------+               +-------+         +------+

                  <------------  T1 -------------->
         <--------------------------T2---------------------->

---

From: "Jiang, Donghua (Donghua)" <[email-masked]>
Date: Wed, 18 Jul 2001 09:49:10 -0400

Manish,

When you say "T2 is tunneled over T1", do you mean T1 is tunneled inside T2
or T2 is tunneled inside T1? 

After I sent out the email yesterday, I was getting suspicious about what I
said.  If T1 is tunneled inside T2, then the packets are traveling from L1
to L3, the MPLS label used for T2 will always be the top label and
forwarding will be based on the top label, we would not care about the
existence of T1.  So, T1 will not be involved when packets travels from L1
to L3.  If T2 is tunneled inside T1, then from L1 to L21, packets will be
forwarded based on the MPLS labels for T2.  When packets get to L21, one
more layer of label will be pushed on and packet forwarding will be based on
the newly added label layer.  When packets get to L22, the top layer will be
popped as it is the end of the tunnel T1.  Also, due to the negotiation
between L22 and L3, the current top label should also be popped before the
packets are forwarded to L3.

Hope you did not mean to play the trick :-)

Regards,
Jane

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 12:06 PM
To: [email-masked]
Subject: [MPLS] Popping Multiple Labels

Hi,

I appreciate any help.

thanks,
manish

PS: Scenario

---

From: Manish Godara <[email-masked]>
Date: Wed, 18 Jul 2001 09:21:36 -0700 (PDT)

Hi Jane,

Apologies for the confusion.  I meant T2 is tunneled
inside T2.  Thanks for the clarification.  So it is
possible to pop two labels at one LSR.  Now I wonder
if it is efficient to implement this in hardware.

thanks,
manish

------------- your mail ----------------

Manish,

When you say "T2 is tunneled over T1", do you mean T1
is tunneled inside T2
or T2 is tunneled inside T1? 

After I sent out the email yesterday, I was getting
suspicious about what I
said.  If T1 is tunneled inside T2, then the packets
are traveling from L1
to L3, the MPLS label used for T2 will always be the
top label and
forwarding will be based on the top label, we would
not care about the
existence of T1.  So, T1 will not be involved when
packets travels from L1
to L3.  If T2 is tunneled inside T1, then from L1 to
L21, packets will be
forwarded based on the MPLS labels for T2.  When
packets get to L21, one
more layer of label will be pushed on and packet
forwarding will be based on
the newly added label layer.  When packets get to L22,
the top layer will be
popped as it is the end of the tunnel T1.  Also, due
to the negotiation
between L22 and L3, the current top label should also
be popped before the
packets are forwarded to L3.

Regards,
Jane

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Tuesday, July 17, 2001 12:06 PM
To: [email-masked]
Subject: [MPLS] Popping Multiple Labels

Hi,

I was wondering if there are any possible scenarios in
which
a node might pop multiple labels from the stack.  One
case
I was thinking of is : a node is endpoint of a tunnel
(T1) and
is also a penultimate hop for another tunnel (T2) and
T2 is
tunneled over T1!  Maybe this is not a valid scenario
but I
would like to check.

I appreciate any help.

thanks,
manish

PS: Scenario

  +-----+         +-------+               +-------+   
     +------+
  |     | ===~==  |       |  ====~~===    |      
+---------+      |
  | L1  |         | L21   |               | L2n   |   
     | L3   |
  +-----+         +-------+               +-------+   
     +------+

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: [email-masked]
Date: Thu, 19 Jul 2001 09:54:24 +0500

Hi,
I am not sure if this will help you but this is what I once thought to avoid
multiple lookup in the table. If the problem in multi-level pop is looking
up the table after each pop the algorithm below might help you. (In this
multi-level pop I am not talking about the penultimate popping)

This is the algorithm, I thought:
The labels that are popped have the following nature:
The label terminates a LSP at the router assigning them. The action
associated with the top label, is to pop the label and examine the inner
header. 
The inner header may be an MPLS label which might be of the same type i.e.
pop the label and examine the inner header for next action. This may go on,
until we reach a label which need to be swapped or need to be popped and
forwarded or we end up with an IP header.
All such labels which are being popped this way have few things in common:
--They are assigned by the router popping them.
-- The LSP terminates at the router that is popping them.
-- Action associated with the label is to examine the inner header.
(If you are not concerned about debugability, indeed you can use just one
label value for all such labels.)
Since the router is assigning the label, it can reserve a range say
10000-20000 for all such labels. 
When Router receives an MPLS packet with label between 10000-20000, it can
just pop it and examine if the inner label. If the inner label is again in
the range 10000-20000 it can again pop it. This way Router can avoid a table
lookup for popping multiple labels and can just examine the range which I
assumed would be faster.

Note: This will interoperate even if some other router is assigning label
from the same range i.e. say there is another router which assigns a label
10001. This should not concern the router as it is only going to decide
things based on the labels assigned by it and not by some other router. 

Vijay
-----Original Message-----
From: Manish Godara [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 9:22 PM
To: Jiang, Donghua (Donghua)
Cc: [email-masked]'
Subject: RE: [MPLS] Popping Multiple Labels

Hi Jane,

thanks,
manish

------------- your mail ----------------

Manish,

Regards,
Jane

-----Original Message-----

Hi,

I appreciate any help.

thanks,
manish

PS: Scenario