Subject: [MPLS] Implicit Peering/Stack Attributes

From: Manish Godara <[email-masked]>
Date: Fri, 20 Jul 2001 16:03:16 -0700 (PDT)

Hi,

The Architecture document talks about implicit peering
in Sections 3.27.5 and 4.3.  I understand the concept
of implicit peering and that the "implicit peers"
would distribute labels via "Stack Attributes".  But I
don't find any reference in other documents to "Stack
Attributes".  

Can someone please clarify how the Stack Attributes
are distributed and where can I find more information?

thanks in advance,
manish

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Eric Gray <[email-masked]>
Date: Mon, 23 Jul 2001 10:47:35 -0400

Manish,

    Please see below.

You wrote:

> would distribute labels via "Stack Attributes".

Understanding this concept is quite a feat, since it is not
very well explained.

In essence, the 'stack attribute' referred to is a second
label in the stack.  Therefore, a 'stack attribute' would be
distributed using a 'label distribution protocol'. At this
time, the only label distribution protocol that appears to
allow distribution of label stacks (which is required if you
want to directly bind more than one label to a single FEC)
is that which is described in RFC 3107.  I do not know that
any implementation does this, however.

In order to accomplish the same thing using any other
label distribution protocol, you would need to distribute
'to me' labels and then distribute the labels corresponding
to 'stack attributes' by explicitly peering with a remote
LSR signaling entity.

As for the term 'implicit peering', I do not believe this is
intuitive to very many, or explicitly described anywhere.
In either the BGP MPLS (RFC 3107) case, or in any other
case, you have to have an explicit peering relationship in
order to obtain labels corresponding to 'stack attributes'.
Perhaps the authors meant that some type of peering is
implied by the existence of 'stack attribute' labels - thus
implicit peering.  Who knows?

--
Eric Gray

>
>
>
> But I don't find any reference in other documents to
> "Stack Attributes".
>