Subject: question on draft-ietf-mpls-diff-09.txt

From: [email-masked]
Date: Tue, 31 Jul 2001 14:57:49 EDT

Francois et-all,

I have a couple of questions on 
draft-ietf-mpls-diff-09.txt and would appreciate
if you can clarify for me.

1. The DIFFSERV Object (say in RSVP) has EXP-PHB
   mappings. So I can see that populating the
   'Encaps-->PHB mapping' for E-LSP in Sec 3.2
   is straightforward. But I am not sure how  to
   create the 'Set of PHB-->Encaps mapping' in
   the Diffserv Context (sec 3.4.1) from the signalled
   EXP-PHB map. Is this just a simple reverse mapping ?

2. According to Sec 5.3, each intermediate LSR just
   records the DIFFSERV Object. So for a given E-LSP,
   the incomming and outgoung mappingd are the same ?
   If that is so, how can the outgoing EXP on a given 
   LSR be different from the incomming EXP on the 
   same LSR.  Is this because we may have changed
   the drop precedence,  so the PHB used
   to compute the outgoing EXP is is different from
   the PHB we got when we mapped the incomming EXP
   to PHB.

3. It looks to me that in case of RSVP, the EXP-PHB
   mapping is selected by the box initiating the 
   PATH message (which will be the upstream node
   w.r.t data flow). Whereas in case of LDP 
   (downstream unsolicited) this mapping is selected
   by the downstream node. Is my understanding corect ?

thank you very much

- satinder

---

From: Shahram Davari <[email-masked]>
Date: Tue, 31 Jul 2001 13:31:13 -0700

Hi,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 2:58 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: question on draft-ietf-mpls-diff-09.txt
> 
> 
> Francois et-all,
> 

Yes.

>    the incomming and outgoung mappingd are the same ?

Yes.

>    the PHB we got when we mapped the incomming EXP

Yes. This is the case for example when you do policing.

>    by the downstream node. Is my understanding corect ?

Yes.

-Shahram