Subject: RE: mplsTunnelHopTableIndex and mplsTunnelPathInUse

From: Abhishek Choudhary <[email-masked]>
Date: Mon, 30 Jul 2001 12:54:41 +0530

Apratim
	if u look at the mplstunnelHopTable it's triply indexed.
mplsTunnelHopTableIndex is the first and mpldTunnelPathInUse is the second
index to that table. using these two indexes u get a list of hops which is
being used by this tunnel instance.

-----Original Message-----
From: Apratim Mukherjee [mailto:[email-masked]]
Sent: Saturday, July 28, 2001 7:02 PM
To: [email-masked]
Subject: mplsTunnelHopTableIndex and mplsTunnelPathInUse

Hi,

Could someone explain as to what is the difference between the
mplsTunnelHopTableIndex and mplsTunnelPathInUse objects in the
mplsTunnelTable . Dont they both point to an Explicit Route for the tunnel ?

Thanks,
Apratim

---

From: Apratim Mukherjee <[email-masked]>
Date: Mon, 30 Jul 2001 14:35:23 +0530

Hi Abhishek,

>mplsTunnelHopTableIndex is the first and mpldTunnelPathInUse is the >second
index to that table. using these two indexes u get a list of hops >which is
being used by this tunnel instance.

Ya , you are right . But would not the values of the two indexes be the same
for any tunnel instance , as Abhay also pointed out . If two indexes have
the same value , wouldn't that mean a duplication ? Or is that the Hop Table
could look like this :

HopListLindex  PathOptionIndex HopIndex [ Hop Details ]
	1			1              1		ERO1
	1			1              2                   ERO1
	1			1	    3                   ERO1
	1			2              4                   ERO2
	1			2              5                   ERO2
	1			2              6                   ERO2
	1			2              7                   ERO2

	where the ERO1's denote the subobjects of the primary ERO
	and ERO2's denote the subobjects of the secondary ERO ?

	In the normal case then HopListIndex = PathOptionIndex always and
also HopListIndex is a misleading name as it is the index to TWO hop lists
and is not an unique identifier of a Hop List .

	Thanks 
	Apratim

> From: Apratim Mukherjee [ mailto:[email-masked]]

---

From: Abhishek Choudhary <[email-masked]>
Date: Mon, 30 Jul 2001 15:02:19 +0530

Apratim
	see it this way. normally every tunnel will have one corresponding
HopListIndex(mplsTunnelHopTableIndex), which will have multiple
PathOptionIndex corresponding to each instance of the
tunnel(mplsTunnelPathInUse), each consisting of multiple HopIndex(es). 

so two tunnel instances will have the same HopListIndex but different
PathOptionIndex.

abhishek

-----Original Message-----
From: Apratim Mukherjee [mailto:[email-masked]]
Sent: Monday, July 30, 2001 2:35 PM
To: 'Abhishek Choudhary'
Cc: [email-masked]'
Subject: RE: mplsTunnelHopTableIndex and mplsTunnelPathInUse

Hi Abhishek,

	Thanks 
	Apratim

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 30 Jul 2001 08:52:45 -0400

>and is not an unique identifier of a Hop List .

         If you have the same first two indexes, you
are indicating hops that are part of the SAME
path option. Any of the hops denoted by the third
index in this case are all considered to be part
of the same path option. What might be confusing is that
the description clause in the mplsTunnelHopTable has
not been updated to reflect the tertiary indexing.
We will update this as part of the IESG review of
the document.

         Incidentally, the purpose of having the indexes the
way that we do is to allow one to configure a tunnel
instance to have multiple paths (i.e.: what you were
referring to as path options before). For example, the
following demonstrates how one would configure two
paths for a particular tunnel:

         (mplsTunnelHopListIndex,
         mplsTunnelHopPathOptionIndex,
          mplsTunnelHopIndex ):          hop address

         -- first path option
         (1,1,1):        1.2.3.1
         (1,1,2):        2.3.4.1
         (1,1,3):        4.5.6.1

         -- second path option
         (1,2,1):        1.2.4.1
         (1,2,2):        5.6.5.1
         (1,2,3):        7.8.1.1

         ...

         --Tom