Subject: FastReRoute & OSPF LER

From: Zappacosta Rolando Jorge <[email-masked]>
Date: Fri, 20 Jul 2001 15:50:23 -0300

Hello everybody.

 I'm searching for complete and updated info regarding FastRerouing; does
anyone know some good links?

Another question, suppose you have an MPLS routers based backbone and you
use as a LER a router that does *not* run BGP and receives from the outside
interfaces pure IP to be inserted into the core. Why must it not, if it
mustn't, label the packets prior to their insertion in the core? In other
words, may be it possible that the LER labels packets to go through an LSP
created taking into account OSPF information? Or must it label packets if
the LSP's were created thanks to BGP only?

Thanks in advance,

Rolando J. Zappacosta
Gerencia Laboratorios - DER
Reconquista 179
Ciudadela (B1702FCC)
Pcia. de Buenos Aires - ARGENTINA
Tel: +54-11-4332-8360
Fax: +54-11-4303-5586 Ext: 6005

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 20 Jul 2001 13:22:47 -0700

Hi Zappacosta,

> the LSP's were created thanks to BGP only?

Of course you don't need BGP to use LSPs for forwarding traffic. I think
your question maybe triggered by one implementation which in the past by
default was inserting into the TE-LSPs destinations comming via bgp but
now even they have a knob to relax it (it's called "igp shortcuts" if I
remember correctly :).

R.

---

From: abhay <[email-masked]>
Date: Mon, 23 Jul 2001 10:14:49 +0530

Hi Zappa,

         Cisco's Document authored by Robert,describes thier way of fast re-route

         using the Label Stack Model with Global Label Space Implementation.

         However their earlier releases has fast re-route appilcable only to POS

         interfaces and the back up path is statically configured and does not offer

         completed LSP protection.

        However,Junpier Networks implementation has FRR for both Node and Link failure(so does Cisco)

        and complete path protection(not Cisco).

        Both can be found at the Cisco and Juniper websites respectively.

        1) Haskins draft on Fast Re-route and Path protection

        2)Hellstrand's draft on fast re-route.

        3)Shew's draft on fast re-route.

        All these schemes have only ideas with RNT (Reverse Notification Tree) implementations

        fault propogation and type of LSP failures with respective required actions.

        As for your second question,read the mpls extensions drafts for inter area

        LSP's

        Hope this helps.

        Regards,

        Abhay