Subject: LDP question

From: chaos is <[email-masked]>
Date: Wed, 18 Jul 2001 11:41:22 -0700 (PDT)

Greetings WG. I have a question that needs your
enlightened opinion. Let's assume some core device (or
P device) implements (or just activates) IS-IS TE and
RSVP-TE. 

Now let's assume a network provider wants to provide
RFC 2547-based VPNs or some other similar application
requiring LDP utilizing the above core (or P) device. 

Does the core (or P) device need to implement (or
activate) LDP? Lets assume the provider network
consists of typical PE devices and perhaps another
layer of P devices that support full functionality. 

If my question is not clear, I can restate.

Cheers!

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Wushao Wen <[email-masked]>
Date: Wed, 18 Jul 2001 11:48:51 -0700 (PDT)

Chaos,

I think for the VPN, it only rely on the mpls switching table. LDP is not
a requirement as long as we have some mechanism to distribute and setup
label mapping table. In light of this, LDP is not a requirement because
you have the RSVP-TE. 

Thanks!

Wushao

---

From: chaos is <[email-masked]>
Date: Wed, 18 Jul 2001 12:38:53 -0700 (PDT)

I understand your point and feel my question was not
clear. Lets assume the servive provider MUST implement
an LDP application PE to PE. Now lets assume there are
two layers of P devices, core and distribution.
Naturally the distribution P devices support LDP. So
my question is this:

Does the core P device need to support LDP? Or can
this device function as a pure layer-2.5 switch
without LDP enabled or implemented. 

Anyone?

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 19 Jul 2001 10:18:21 +0200

Theoretically the VPN will work as long as you do not uncover the VPN label 
anywhere but the destination PE. Now in your scheme the source PE will 
impose a VPN label + a label (distributed by LDP) corresponding to the 
destination PE. This will get sent out.
 From hereon I'm still not clear about your question. The only reasonable 
possibility that come to my mind is:
The LDP capable P devices are doing TE (across the non LDP enabled 
network), and have LDP sessions running between TE head and tail ends. The 
TE head-end should thus be able to add a 3rd label to the stack (the TE label).

Regards,
Woj.

> > > If my question is not clear, I can restate.

_________________________________________________________
Wojciech Dec   CCIE# 5563      Phone:  +31 (0)20 342 3034
Network Consulting Engineer    Mobile: +31 (0)622 466 802
Cisco Systems,                 E-Mail: [email-masked]
PO Box 22514,
1100 DA Amsterdam
The Netherlands