Subject: RE: draft-ietf-mpls-rsvp-lsp-tunnel-08.txt

From: "Feng, Mark" <[email-masked]>
Date: Fri, 13 Jul 2001 11:12:20 -0700

Hi, I have some doubts regarding the usage of SE style within MPLS.

My question is, with SE style, besides doing make-before-break, is it used
for other purpose?

Consider the following LSP setups (with each sender potentially having
different traffic requirements) using SE style, by using explicit routing.

                    ______             
                   |      |              
               +---|      |---+        
               |   |______|   |        
               |              |
               |s1,s3         |s1,s3
 s1,s2 ______  |              |  ______ 
 -----|      |-+              +-|      | s1,s2,s3,s4
 -----|      |-+              +-|      |------
 s3,s4|______| |              | |______|
               |s2,s4_____    |s2,s4        
               |   |      |   |       
               +---|      |---+       
                   |______|           

Is this possible in RSVP-TE?

Thanks in advance.

Mark

---

From: David Charlap <[email-masked]>
Date: Tue, 17 Jul 2001 14:32:42 -0400

"Feng, Mark" wrote:
> My question is, with SE style, besides doing make-before-break, is
> it used for other purpose?
> 
> Consider the following LSP setups (with each sender potentially
> having different traffic requirements) using SE style, by using
> explicit routing.
> 
>                     ______
>                    |      |
>                +---|      |---+
>                |   |______|   |
>                |              |
>                |s1,s3         |s1,s3
>  s1,s2 ______  |              |  ______

SE style only shares resources among LSPs that share a single session.

If two LSPs must not share resources, then they should be in separate
sessions.  The easiest way to ensure this is to make sure that they use
different tunnel IDs.

Putting them in the same session and requesting FF style might work, but
I would not recommend it because:
	1: The egress router may ignore the request and reserve SE
	   style anyway.
	2: If one of those LSPs must be rerouted, make-before-break
	   may fail.  If it doesn't fail, it may temporarily waste
	   resources.

-- David