Subject: RE: LSP in transit LSR MIBs

From: "Leonid Dubinsky" <[email-masked]>
Date: Sun, 1 Jul 2001 17:35:38 +0300

Hello Tom, 
Thanks for your response.
That's clear you'll have to store cross-connects to mantain the LSP
itself.
Storing LSP information in the TE MIB is possibly the most logical
possibility, but still there are things which should be split in
transit, and the MIB does not support such splitting (e.g., it would be
nice to divide RRO to "upstream" and "downstream" parts, show both
"requested traffic parameters" from RSVP-TE PATH and "allocated
parameters" from RSVP-TE RESV, etc.)
What do you think is the most logical placement of this stuff in the LSR
MIB tables?
Best Regards,
    Leonid Dubinsky.

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Sunday, July 01, 2001 4:56 PM
To: Leonid Dubinsky; [email-masked]
Subject: Re: LSP in transit LSR MIBs

         Transit LSPs should be stored in the LSR-MIB as
Insegment(s)-XC-Outsegment(s) entries. Thus, if you
start at the ingress, you can follow the LSP
across the network to the egress. If the
transit LSP is used to carry traffic for a particular
TE tunnel, then the MPLS-TE-MIB *may* contain that
information at transit LSRs. This is not mandatory,
but most implementations I know of are doing it since
the information is available (via RRO/ERO).

         --Tom

>I've read the drafts LSR MIB and TE-MIB, but I was unable to figure out
>from them where transit LSR should store information about LSPs passing
>through it. Should it be placed in mplsTunnelTable?
>Anyone has any thoughts on this?
>Best Regards,
>     Leonid Dubinsky.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 02 Jul 2001 09:02:45 -0400

>What do you think is the most logical placement of this stuff in the LSR

         RRO/ERO separation on a per-tunnel basis is already
done in the MPLS-TE-MIB. Take a look at the different
HOP tables in the MPLS-TE-MIB. RRO/ERO is not used for
non-TE LSPs (i.e.: they are set up using LDP), so it is
not available in the LSR MIB.

         --Tom