Subject: RE: draft-ietf-mpls-rsvp-lsp-tunnel-08.txt

From: "Feng, Mark" <[email-masked]>
Date: Tue, 17 Jul 2001 12:02:41 -0700

Thanks for the response. Please see the comments below.

> -----Original Message-----
> From: David Charlap [mailto:[email-masked]]
> Sent: Tuesday, July 17, 2001 11:33 AM
> To: [email-masked]
> Subject: Re: draft-ietf-mpls-rsvp-lsp-tunnel-08.txt
> 
> 
> "Feng, Mark" wrote:
> > 
> > Hi, I have some doubts regarding the usage of SE style within MPLS.
> > 
> > My question is, with SE style, besides doing make-before-break, is
> > it used for other purpose?
> > 
> > Consider the following LSP setups (with each sender potentially
> > having different traffic requirements) using SE style, by using
> > explicit routing.
> > 
> >                     ______
> >                    |      |
> >                +---|      |---+
> >                |   |______|   |
> >                |              |
> >                |s1,s3         |s1,s3
> >  s1,s2 ______  |              |  ______
> >  -----|      |-+              +-|      | s1,s2,s3,s4
> >  -----|      |-+              +-|      |------
> >  s3,s4|______| |              | |______|
> >                |s2,s4_____    |s2,s4
> >                |   |      |   |
> >                +---|      |---+
> >                    |______|
> > 
> > Is this possible in RSVP-TE?
> 
> SE style only shares resources among LSPs that share a single session.
> 

Sorry I didn't make it clear. All the senders in the diagram belong to the
same session. 

Considering the first node on the diagram, S1, S2 come in at one interface,
and S3, S4 come in at a different interface. Even though they belong to the
same session, the Path messages travel a different path. This is somewhat
different from RSVP/RFC 2205, where, in unicast, Path messages for the same
session take the same path. 

In this case, because Path messages take different routes, Resv messages
will arrive at different interfaces, with potentially different resource
requirements. The process of handling the resource allocation at various
interfaces, as a result, is somewhat different from RSVP/RFC 2205.

I just want to make sure this is a valid scenario.

> If two LSPs must not share resources, then they should be in separate
> sessions.  The easiest way to ensure this is to make sure 
> that they use
> different tunnel IDs.
> 
> Putting them in the same session and requesting FF style 
> might work, but
> I would not recommend it because:
> 	1: The egress router may ignore the request and reserve SE
> 	   style anyway.
> 	2: If one of those LSPs must be rerouted, make-before-break
> 	   may fail.  If it doesn't fail, it may temporarily waste
> 	   resources.
> 

I agree. Or they could put their own IP address in the extended tunnle ID.

> -- David

- Mark

---

From: David Charlap <[email-masked]>
Date: Tue, 17 Jul 2001 15:14:48 -0400

"Feng, Mark" wrote:
> Sorry I didn't make it clear. All the senders in the diagram belong
> to the same session.

Then all senders will get the same reservation.

> Considering the first node on the diagram, S1, S2 come in at one
> interface, and S3, S4 come in at a different interface. Even though
> they belong to the same session, the Path messages travel a
> different path. This is somewhat different from RSVP/RFC 2205,
> where, in unicast, Path messages for the same session take the
> same path.
> 
> In this case, because Path messages take different routes, Resv
> messages will arrive at different interfaces, with potentially
> different resource requirements. The process of handling the
> resource allocation at various interfaces, as a result, is
> somewhat different from RSVP/RFC 2205.

Not really.  Reservations all come from the egress.  All LSPs share a
common egress router.  Whatever reservation it chooses for one sender
must be used for all of them.  This Resv message may split up (with
different filterspecs in the flow descriptor) as it follows to the
different PHOP routers, but they all reserve the same resources.  When
they come back together at the ingress router, they are still the same.

If the egress router tries to send different flowspecs for each sender,
then it is in error.

> I just want to make sure this is a valid scenario.

It is.

>> If two LSPs must not share resources, then they should be in
>> separate sessions.  The easiest way to ensure this is to make sure
>> that they use different tunnel IDs.
>>
>> might work, but I would not recommend it because:

If all the LSPs originate from the same router, then it may not be
possible to give them different extended tunnel IDs.  But yes, that
would also be possible.

-- David