Subject: RE: LSP-ping

From: Shahram Davari <[email-masked]>
Date: Tue, 17 Jul 2001 12:30:36 -0700

Ping,

> -----Original Message-----
> From: Ping Pan [mailto:[email-masked]]
> Sent: Tuesday, July 17, 2001 3:16 PM
> To: Shahram Davari
> Cc: [email-masked]'
> Subject: Re: LSP-ping
> 
> 
> Shahram Davari wrote:
> > 
> > Hi,
> > 
> > Could anybody explain to me what is wrong with running  
> ICMP-ping over the both the forward and reverse LSP?
> > 
> 
> If the reserve path has multiple LSP's and one of them is 
> down, how can
> you tell if the forwarding LSP (the one operators are 
> interested in) is
> up or down?
> 

The ingress LSR should know which LSP is the reverse LSP.

-Shahram

---

From: George Swallow <[email-masked]>
Date: Tue, 17 Jul 2001 15:38:08 -0400

> The ingress LSR should know which LSP is the reverse LSP.

Huh???  There may be no LSP directly from the egress LSR back to the
ingress.  

Suppose we have a tunnel from A to D  A->B->C->D

D may have no tunnel to A but one to either B or C.  or D could have
no tunnels but C has one to either B or A.  Or B could have a tunnel
back to A.  Or the IP routed path in the reverse direction is not
symmetric and the reply could be lost going down a tunnel from G to Q.

...George

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824

---

From: Ping Pan <[email-masked]>
Date: Tue, 17 Jul 2001 12:38:30 -0700

> The ingress LSR should know which LSP is the reverse LSP.

One more time, the reverse path can go through *many* LSP's. One of them
is dead in the middle of somewhere. How can the ingress know if the
forwarding LSP is up or down base on ICMP ping's? The answer is it
doesn't, and your scheme does not work!