Subject: I-D ACTION:draft-pan-lsp-ping-00.txt

From: Shahram Davari <[email-masked]>
Date: Thu, 12 Jul 2001 09:26:43 -0700

Hi All,

How can the LSP-Ping work if the LSP is setup to carry non-IP traffic?

In an egress LSR there is a binding between an LSP and the L3 protocol that it is supposed to carry. If anything other than IP is carried in an LSP, and we inject ping packets in to that LSP, the egress LSR has no means of parsing that packet. How is this addressed in this draft?

Yours,
-Shahram

---

From: Eric Gray <[email-masked]>
Date: Fri, 13 Jul 2001 10:40:28 -0400

Shahram,

    A non-IP LSP would presumably use a non-IP/ICMP based
path integrity check, wouldn't it?  Also, such an LSP would be
established (most likely) using an explicit route mechanism -
which would tend to ensure that the end-points would know of
the path integrity (or lack thereof) via signaling behavior.

--
Eric Gray

---

From: Ping Pan <[email-masked]>
Date: Fri, 13 Jul 2001 17:04:31 -0700

Shahram Davari wrote:
> In an egress LSR there is a binding between an LSP and the L3 protocol that it is supposed to carry.
> If anything other than IP is carried in an LSP, and we inject ping packets in to that LSP, the egress 
> LSR has no means of parsing that packet. How is this addressed in this draft?
> 

Shahram,

If the LSP (IP or non-IP) is initiated via RSVP-TE, then
draft-pan-lsp-ping-00.txt can be used to check the LSP. In this case,
the egress can parse the echo-requests. You are right, it won't work in
a non-IP network.

- Ping