Subject: LSP in transit LSR MIBs

From: "Leonid Dubinsky" <[email-masked]>
Date: Sun, 1 Jul 2001 08:07:06 +0300

Hi,
I've read the drafts LSR MIB and TE-MIB, but I was unable to figure out
from them where transit LSR should store information about LSPs passing
through it. Should it be placed in mplsTunnelTable?
Anyone has any thoughts on this?
Best Regards,
    Leonid Dubinsky.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Sun, 01 Jul 2001 09:56:26 -0400

Transit LSPs should be stored in the LSR-MIB as
Insegment(s)-XC-Outsegment(s) entries. Thus, if you
start at the ingress, you can follow the LSP
across the network to the egress. If the
transit LSP is used to carry traffic for a particular
TE tunnel, then the MPLS-TE-MIB *may* contain that
information at transit LSRs. This is not mandatory,
but most implementations I know of are doing it since
the information is available (via RRO/ERO).

         --Tom

---

From: abhay <[email-masked]>
Date: Mon, 02 Jul 2001 10:47:14 +0800

Lenoid,

       The TE-MIB at the head end which originates contains the configuration for the tunnel.

       At the transit and the tail ends it contains entries made by the signaling protocol,

       which may be RSVP/CR-LDP.

       Additionally each LSP can be identified by the XC Groups in the LSR MIB and there is a one

       to many XC Group relation from the tunnel entry in the TE-MIB to the LSP in the LSR MIB.

       Transit routers may contain entries made by the signaling protocol in the mplsTunnel Table

       ,if they have the ability to do so..as RSVP and CR-LDP have their own capabilities and pitfalls.

       But we can have an effective LSP control if we have entires in the transit routers,if you are interested

       in complete traffic engineering.

       Regards,

       Abhay