Subject: Some queries about MPLS implementation

From: "N.Suresh" <[email-masked]>
Date: Fri, 27 Jul 2001 21:02:53 +0530

Hi all,
    I am implementing the LDP on linux..
    i have some queries.

   (1)   The Hello Message send on as multicast on a Multicast socket.
Suppose
  that after adjacency discvery a connection is established between the
  two machines. Furthor LDP message transmission is going on the TCP
  socket. To identify the link usage we want again tranceive Hello
  message. I have the doubt that which socket we want to be use for the
  Hello message, whether the multicasted socket or the TCP socket.

(2)  If the  next hop has changed, and I have sent Label Abort msg to
that
  hop. Will it be reach at there?. Then what is the significance of the
  Label Aborted message?

(3)  The Address message is used to send the Interface message to the
next
  hop. But the Address Family field of the Address message tells the
  address types are either IPv4 or IPv6. What is it .

  (3.1) Is it a string value?. Actually interface address is a 48 bit
address of the
   interface.
  (3.2) So how it can be either IPv4 or IPv6?.
  (3.3) The interface address are taken care by the Link Level Layers.
   So what is the need for the LDP to care by the interface address.
   One of the ans. is to identify the link through which the Hello
   msg. is comming.

    anybody has any idea?

    thanx in advance
    regards

--
!============================================================================!
= Suresh N., Research Engineer, C-DoT, Bangalore.                            =
= Call me at : OFF: 2383951(Dir) / 2263399 (268)                             =
=              RES: 3334248  MOBILE: 98441 77782                             =
= Alternate email :  [email-masked]                                      =
= QOT: For fast-acting relief, try slowing down.
!============================================================================!

---

From: "James R. Leu" <[email-masked]>
Date: Fri, 27 Jul 2001 10:46:09 -0500

Hello,

If you are referring to the ldp-portable package that is part of the
"MPLS for Linux" project, please post questions to the appropriate mailing
list:

http://lists.sourceforge.net/lists/listinfo/mpls-linux-general

Thanks,
Jim

-- 
James R. Leu

---

From: Eric Gray <[email-masked]>
Date: Fri, 27 Jul 2001 12:09:08 -0400

"N.Suresh" wrote:

>    (1)   The Hello Message send on as multicast on a Multicast socket. Suppose
>

Hello messages continue to be sent using UDP.

>
>
> (2)  If the  next hop has changed, and I have sent Label Abort msg to that

Two issues here: lost contact with next hop LDP peer and simple change
in routing resulting in a next hop change relative to a FEC.  In the first case
- where the Label Abort message would not be able to reach the peer - the
Label Abort is not indicated; you would instead purge all state relative to
this LDP peer, including any state relative to Label Requests.  In the latter
case, the Label Request Abort accelerates the process of making labels
and other LSP resources available in downstream LSRs when it is found
that this particular portion of the LSP is not needed.

>
>
> (3)  The Address message is used to send the Interface message to the next
>   address types are either IPv4 or IPv6. What is it.

Correct.

>
>
>   (3.1) Is it a string value?. Actually interface address is a 48 bit address
> of the
>    interface.

Formats for these are explicitly defined in the specification (RFC 3036).

>    One of the ans. is to identify the link through which the Hello

LDP needs to know what next hop addresses it may know an LDP peer
by through other means.  This is needed in order to allow the LSR to
bind labels received on an upstream interface to corresponding labels
distributed for a FEC from an LDP peer that is the routing next hop.