Subject: RE: Label Spaces and Uniqueness

From: "Naidu, Venkata" <[email-masked]>
Date: Tue, 10 Jul 2001 13:44:40 -0400

David, Shahram, Eric:

   Please look at my inline comments:

-> Shahram Davari wrote:
-> > 
-> > 
-> >         B-----C--------E-------F
-> > A-------B----------------------F-------G
-> > 
-> > LSP1: ABFG
-> > LSP2: BCEF
-> > 
-> A more important question is what happens at router F.
-> 
-> Router F must not send the same label to E and to B.  When a packet
-> arrives from E, the outer label will indicate a pop.  Then 
-> the remaining
-> label will indicate a swap.  (Let's pretend there are more routers
-> beyond G, so PHP won't come into play here.)

   Why not? As long as I use labels from different label space.
   And I think this is a very importance feature in Fast-Reroute
   in LSP protection. 

   LSP1: ABFG uses labels from global label space, so, even
   after reroute of LSP2 (because of some failure) F receives
   data in that on a different interface and can interpret
   data correctly because the inner label is from global 
   label space.

   LSP2: BCEF uses per interface label space. As far as I know
   both of these label spaces can coincide and more over
   F can allocate the "same" local significance label to B as
   well as to E. (as long as it distinguishes which LSP the
   data is flowing) 

   Is this possible. If not why not?

-> This is what the RFC is talking about.  The only way for F 
-> to determine
-> whether a packet is from LSP1 or LSP2 is using the label.  

   And of course the receive interface too!!!

-> If the label
-> values for the two are identical, then some other means, beyond the
-> scope of MPLS, must be used to determine the LSP that the 
-> packet belongs
-> to.  The easiest way to ensure that the same label is not 
-> used for the
-> two LSPs is to use the same label space for the two.

--Venkata Naidu

---

From: David Charlap <[email-masked]>
Date: Tue, 10 Jul 2001 14:03:58 -0400

"Naidu, Venkata" wrote:
>> Shahram Davari wrote:
>>>         B-----C--------E-------F
>>> A-------B----------------------F-------G
>>>
>>> LSP1: ABFG
>>> LSP2: BCEF
>>
>> A more important question is what happens at router F.
>>
>> Router F must not send the same label to E and to B.  When a packet
>> arrives from E, the outer label will indicate a pop.  Then the
>> remaining label will indicate a swap.  (Let's pretend there are
>> more routers beyond G, so PHP won't come into play here.)
> 

When the labeled packet arrives, how will you be able to determine which
label space to use?  This isn't part of any header.  All you've got is a
label stack and the opaque payload.

If you can determine the label space, then sure, go right ahead.  But I
think the only factors that you can use are either layer-2 information
or physical port information.

>> This is what the RFC is talking about.  The only way for F
>> to determine whether a packet is from LSP1 or LSP2 is using the
>> label.
> 

In the above example, F only has one interface - connected to E.  The
line from B-F is not a separate link.  It is representing a tunnel
through LSP2.

-- David