Subject: MPLS frames over Ethernet

From: Maciek Arkuszewski <[email-masked]>
Date: Thu, 23 Aug 2001 10:56:34 -0700

Hello.

How exactly is a proper MAC address picked for outgoing frame? Is there an
additional mapping maintained between labels and ARP table on LSR? 

Maciek Arkuszewski
Senior Software Engineer
Ixia
<mailto:[email-masked]>
Tel: (818)444-2305

      Ixia...
             When the test really counts.

---

From: Ajay Sahai <[email-masked]>
Date: Fri, 24 Aug 2001 10:17:43 -0400

Maciek

You could maintain the mapping you are referring to. However in most
scenarios
that I can think of, the MAC address needed by an outgoing frame on a given
interface
will be that of the next node.  So I would guess that an interface to
MAC mapping would suffice.

-Ajay

--
Ajay Sahai, Fujitsu Network Communication Inc.,
Two Blue Hill Plaza, P.O. Box 1609, Pearl River, NY 10965
Tel: +845-731-2023 (W) Fax: +845-731-2011
E-Mail: [email-masked]

---

From: David Charlap <[email-masked]>
Date: Fri, 24 Aug 2001 13:52:23 -0400

Maciek Arkuszewski wrote:
> 
> How exactly is a proper MAC address picked for outgoing frame? Is
> there an additional mapping maintained between labels and ARP table
> on LSR?

Obviously, the MAC address chosen would have to be the address of the
next-hop router.  The IP address of this router should already be known
(learned as a part of signaling), so an ARP should easily be doable if
the address is unknown.

-- David