Subject: RE: Time to live

From: [email-masked]
Date: Tue, 21 Aug 2001 12:05:07 -0500

The ingress router copies the TTL field from IP  header. After that the
intermediate label
switch routers decrement TTL in label field. If TTL is zero packet is dropped.

Satish Amara

[email-masked] on 08/21/2001 11:22:28 AM

Sent by:  [email-masked]

To:   [email-masked]
cc:   [email-masked] (Satish Amara/MW/US/3Com)
Subject:  RE: Time to live

It stays the same. The routers only look at the label value not the IP
header. When the packet leaves MPLS domain then the normal operation would
apply.

Asim

-----Original Message-----
From: David Escobar [mailto:[email-masked]]
Sent: 21 August 2001 17:19
To: [email-masked]
Subject: Time to live

Hi;
What happens to the TTL field in the IP header when a labeled packet goes
through an LSP? Is it decreased at each router or stay the same?

---

From: Shahram Davari <[email-masked]>
Date: Tue, 21 Aug 2001 11:42:03 -0700

Hi,

A new draft by Bora Akyol and Puneet Agarwal will be published soon that covers this.

-Shahram

> From: Eric W Gray [mailto:[email-masked]]
> Sent: Tuesday, August 21, 2001 1:56 PM
> To: Ray Qiu
> Cc: MultiProtocol Label Switching Mailing List
> Subject: Re: Time to live
> 
> 
> Yes, that has been suggested as a logical extension of the 'Pipe'
> model in DiffServ.  I don't recall where that effort is at right now
> but I don't think the work has been adopted by either the MPLS
> or CCAMP working groups.  Do you know?
> 
> --
> Eric Gray
> 
> Ray Qiu wrote:
> 
> > There is also an option that we don't copy the MPLS TTL 
> back to IP TTL.
> > It makes IP think the MPLS LSP is only one hop.
> >
> > Thanks,
> > Ray
> >
> > On Tue, 21 Aug 2001, Eric W Gray wrote:
> >
> > > Date: Tue, 21 Aug 2001 13:10:17 -0400
> > > From: Eric W Gray <[email-masked]>
> > > To: Alexander Marhold <[email-masked]>,
> > >      MultiProtocol Label Switching Mailing List <[email-masked]>
> > > Subject: Re: Time to live
> > >
> > > Below, the last sentence was supposed to be "Note that Frame
> > > Relay ..."
> > >
> > > --
> > > Eric Gray
> > >
> > > Eric W Gray wrote:
> > >
> > > > Alexander,
> > > >
> > > >     No cigar.  The distinction is not cell verses 
> frame, but rather
> > > > whether or not it is possible to incorporate the label in the L2
> > > > encapsulation.  Where this is possible, ATM and FR, there is
> > > > no TTL capability in the L2 encapsulation.  Not that Frame
> > > > Relay is Frame based...
> > > >
> > > > --
> > > > Eric Gray
> > > >
> > > > You wrote:
> > > >
> > > > > Hello
> > > > > I want to explain the mechanism a little bit more in detail
> > > > >
> > > > > FRAME based general:
> > > > > 1. normally at the ingress LSR the IP-TTL is copied 
> into the TTL-field of
> > > > > the label header.
> > > > > 2. the label-TTL is decremented at each hop by 1
> > > > > 3. when it reaches 0 the labelled packet will be dropped and a
> > > > > TTL-exceeded-ICMP message will be sent if possible
> > > > > 4. at the egress the label-TTL is copied back into the IP-TTL
> > > > >
> > > > > CELL based general:
> > > > > 1. normally at the ingress LSR the IP-TTL is copied 
> into the TTL-field of
> > > > > the label header.
> > > > > 1a. the ingress LSR to the ATM-MPLS cloud either 
> decrements the TTL by 1
> > > > > 1b              or by the amount of ATM_MPLS hops of 
> the LSP ( this he knows from the
> > > > > LSP-setup using downstream on demand label allocation 
> and ordered
> > > > > lsp-control label setup)
> > > > > 2. then the packet is chopped into cells
> > > > > 3. the egress reassembles the packet and copies the 
> label ttl back into the
> > > > > IP-TTL
> > > > >
> > > > > if 1a is used then the ATM-MPLS cloud looks like a 
> 1-hop network
> > > > >
> > > > > special features:
> > > > > a) on cisco LSRs there is the possibility to disable 
> the copying of the
> > > > > IP-TTL to the label-TTL and the label-TTL again starts at 255.
> > > > > on the egress the smaller of the 2 TTL-values ( label 
> and IP-header) will be
> > > > > used for the IP-TTL
> > > > > then for traceroute the MPLS cloud looks like a 1-hop 
> (2-hop with PHP)
> > > > > network
> > > > >
> > > > > with best regards
> > > > >
> > > > > Alexander
> > > > >
> > > > > 
> __/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/
> > > > >      __/
> > > > >     __/   Dipl.Ing. Alexander Marhold MBA
> > > > >    __/   CCIE #3324, CCNP, CCDP, CCSI #20642
> > > > >   __/   Core & IP Services <Senior Consultant>
> > > > >  __/   Mobile: ++43-(0)664-16 28 234
> > > > > __/   PRO IN http://www.proin.com
> > > > >
> > > > > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > > > > [email-masked]
> > > > > Sent: Tuesday, August 21, 2001 6:22 PM
> > > > > Cc: [email-masked]