Subject: A question on mpls-te-mib: mplsTunnelHopEntryPathComp

From: Ling Li <[email-masked]>
Date: Tue, 28 Aug 2001 11:08:27 -0400

I was confused by the description of mplsTunnelHopEntryPathComp as bellow:

mplsTunnelHopEntryPathComp OBJECT-TYPE
SYNTAX INTEGER {
	dynamic(1), -- CSPF computed
	explicit(2) -- strict hop
}
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"If this value is set to dynamic, then the user
should only specify the source and destination of
the path and expect that the CSPF will calculate
the remainder of the path. If this value is set to
explicit, the user should specify the entire path
for the tunnel to take. This path may contain
strict or loose hops. Each hop along a specific
path should have this object set to the same value"
::= { mplsTunnelHopEntry 14 }

My question is: what if a user want to use CSPF to find a route from Boston
to San Francisco, but specifically he/she wants the route to go through
Chicago.

The description seems suggesting that this operation is not allowed, because
1. The user specified not only the source and destination, but an extra
loose hop (Chicago). Therefore mplsTunnelHopEntryPathComp  cannot be dynamic
2. The user wanted to enable CSPF to calculate the path, so explicit is not
appropriate for mplsTunnelHopEntryPathComp.

Could anyone clarify on this doubt?

Thanks, 

Ling Li 

Axiowave Networks, Inc. 
Email: [email-masked] 
========================

---

From: abhay <[email-masked]>
Date: Wed, 29 Aug 2001 12:27:54 +0530

Hello Ling Li,

             What we have on our hands here is:

             1)A dynamic CSPF path can be requested from the source(Boston) to San Francisco

             Also,

             2)An Offline CSPF path can be requested on the source router

             In both the above cases one can request one router(Chicago) to be included as a rule.

             Altough the user has requested deliberate inclusion,the path is still dynamic

             with the INCLUDED router as a Constraint.

             In such cases,the constraint may not be satisfied.

             Only,when the user has requested a complete explicit path,then we can consider it to

             be a explicit hop

             else

             The hops are all dynamic.

             Hope this helps,

             Regards,

             Abhay