Subject: e-lsp & l - lsp

From: Srinivas T M <[email-masked]>
Date: Wed, 22 Aug 2001 14:45:45 -0700 (PDT)

Hi,
    Can anybody explain what is e-lsp ,l-lsp and
difference between them.

Thanks,
Srini

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: "Kota, Ravikumar" <[email-masked]>
Date: Wed, 22 Aug 2001 18:40:22 -0400

Hi Mark

Thanks for ur correction.
That is mistake in hurry typing.
Thanks alot
Regards
Ravikumar Kota
978  263 0094 (extn  8157 )(work)
978 869 3314(cell)
 
-----Original Message-----
From: Mark Seery [mailto:[email-masked]]
Sent: Wednesday, August 22, 2001 6:33 PM
To: Kota, Ravikumar; 'Srinivas T M'; [email-masked]
Subject: RE: e-lsp & l - lsp

>>  e-lsp intended for carrying single OA for single LSP. l-lsp is intended
for carrying multiple OA s for LSP.

I believe it is the other way.

From the below mentioned draft:

"1.2 EXP-Inferred-PSC LSPs (E-LSP)

   A single LSP can be used to support one or more OAs. Such LSPs can
   support up to eight BAs of a given FEC, regardless of how many OAs
   these BAs span. With such LSPs, the EXP field of the MPLS Shim
   Header is used by the LSR to determine the PHB to be applied to the
   packet. This includes both the PSC and the drop preference......."

"1.3 Label-Only-Inferred-PSC LSPs (L-LSP)

   A separate LSP can be established for a single <FEC, OA> pair.
   With such LSPs, the PSC is explicitly signaled at label
   establishment time so that, after label establishment, the LSR can
   infer exclusively from the label value the PSC to be applied to a
   labeled packet. When the Shim Header is used, the Drop Precedence to
   be applied by the LSR to the labeled packet, is conveyed inside the
   labeled packet MPLS Shim Header using the EXP field. When the Shim
   Header is not used (e.g. MPLS Over ATM), the Drop Precedence to be
   applied by the LSR to the labeled packet is conveyed inside the link
   layer header encapsulation using link layer specific drop precedence
   fields (e.g. ATM CLP)....."

Additional comments:

A number of existing layer 2 technologies (e.g. ATM) can only support L-LSP
because of their inability to carry the equivalent of a full EXP field (drop
precedence can be indicated).

Some people have argued that in the context of diffserv/traffic engineering
support only L-LSPs would be used - I leave this argument as an exercise for
the reader.

E-LSPs represent an approach most similar to diffserv TOS treatment.

-mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Kota,
Ravikumar
Sent: Wednesday, August 22, 2001 3:02 PM
To: 'Srinivas T M'; [email-masked]
Subject: RE: e-lsp & l - lsp

Hi srinivas ,
These are two techiniques to implement packet treatment in  MPLS cloud ,
with diffserv inferred information.
The diffserv information from the packet can be encapsulated into label/exp
field of  "MPLS labelled packet "(this will be happened between
diffservcloud and mpls cloud ),
so that we will be making sure that diffserv information will be used in
MPLS cloud to treat the packets according to that information.
Cisco is implementing this concept with the name : MPLS  DIFFSERV AWARE TE
 e-lsp intended for carrying single OA for single LSP.
l-lsp is intended for carrying multiple OA s for LSP.

 OA  :      Ordered Aggregate. The set of Behavior Aggregates which
               share an ordering constraint.

Any comments are welcome.

Reference draft : draft-ietf-mpls-diff-ext-09.txt

Regards
Ravikumar Kota
978  263 0094 (extn  8157 )(work)
978 869 3314(cell)

-----Original Message-----
From: Srinivas T M [mailto:[email-masked]]
Sent: Wednesday, August 22, 2001 5:46 PM
To: [email-masked]
Subject: e-lsp & l - lsp

Hi,

Thanks,
Srini

---

From: Fabris Sergio <[email-masked]>
Date: Thu, 23 Aug 2001 09:24:35 -0300

Correction:

You can have DiffServ over MPLS without implementing DF-TE.

MPLS DiffServ Aware TE or DF-TE adds:

-Constraint Based Routing per Class with different bandwidth constraints.
-Admision Control per Class over different bandwith pools (ie bandwith
allocated to class queue)

E-LSP intented for carring multiple OA for single LSP
L-LSP is intented por carrying single OA for LSP

For more details see:

http://www.cisco.com/warp/public/732/Tech/mpls/mpls_presentations.shtml

regards,

Sergio Fabris

> -----Mensaje original-----
> De:	Kota, Ravikumar [SMTP:[email-masked]]
> Enviado el:	Miércoles 22 de Agosto de 2001 7:02 PM
> Para:	'Srinivas T M'; [email-masked]
> Asunto:	RE: e-lsp & l - lsp
> 
> Hi srinivas ,

---

From: Sasha Vainshtein <[email-masked]>
Date: Sun, 26 Aug 2001 09:02:27 +0200

IMHO, a very good justification for E-LSPs and L-LSPs is provided
in Appendix A "Example Deployment Scenarios" of the said draft.

Specifically, consider the use case when a SP upgrades a Diffserv-enabled IP
network to an MPLS-enabled one. Such a process should guarantee
at least backwards compatibility with minimal effort. Appendix A
sugests the following approach: 
* As far as connectivity is concerned, vanilla LDP (RFC 3036) guarantees
that
the upgraded network possesses at least the same connectivity as the
original one
* If a small (<= 8) number of OAs has been originally deployed, then
preconfigured EXP<-->PHB mapping would be sufficient to guarantee
complete backwards compatibility with the Diffserv behavior of the
original network by converting each hop-by-hop routed LSP into
an E-LSP for the specified OAs. While such a convertion is limited,
it may be quite practical for a network originally supporting only a
small number of OAs (including BE, at least one more class for separating
 CS-based OAs into two different groups and a small number of other PHBs)

Once the upgrade has been successfully completed, the SP can enhance
the network in two ways:
* Deploy MPLS-specific features (traffic engineering, fast reroute etc.)
while preserving its Diffserv behavior
* Deploy new OAs (e.g. miltiple AF instances with different markers,
thresholds etc.). This will be done by explicit engineering of L-LSPs
as the number of OAS supported by the network hrows.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> Sent: Thursday, August 23, 2001 12:33 AM