Subject: MPLS over FR.

From: Binita Jha <[email-masked]>
Date: Fri, 31 Aug 2001 18:56:08 +0530

I have a doubt regarding MPLS over FR.
1) RFC 3034 says that the top label (DLCI) carries implicitly information
about the network protocol type. but how does it indicate about if the shim
header is present or not?

2) Also if the shim header is present then how do we know abt what network
protocol is present?

Kindly send me the answer if anyone has.
Regards
Binita

---

From: Shahram Davari <[email-masked]>
Date: Fri, 31 Aug 2001 07:07:42 -0700

Hi,

Comments in-line:

> -----Original Message-----
> From: Binita Jha [mailto:[email-masked]]
> Sent: Friday, August 31, 2001 9:26 AM
> To: [email-masked]'
> Subject: MPLS over FR.
> 
> 

The shim header MUST always be present, even if the packet has one label. Only the S, EXP and TTL values of the top label of the shim header are used. The top label's 20-bit label value is not used at all, rather the DLCI is used instead.

> 2) Also if the shim header is present then how do we know abt 

A DLCI value is bound to a specific network protocol (could be done by partitioning of DLCI space). If the S=1 in the top label, then it means that the payload has the same network protocol. If the S=0, then it means that another label is present and the payload is MPLS.

Yours,
-Shahram

---

From: "Hemant P. Kelkar" <[email-masked]>
Date: Fri, 31 Aug 2001 13:49:07 -0400 (EDT)

Hi, 
2 small doubts:
#1. A particular value of a DLCI is bound with a particular protocol to be
carried in FR.
Is that conveyed in Q.933(PVC)/FRF4.1(SVC) ? Or they are administratively
known for a given network ?
#2. In the point (2)of the mail below, with S=1 there may still be MPLS
payload present with only "1" label.How to determine the Payload type in
that case ?

Regards,
Hemant Kelkar

Date: Fri, 31 Aug 2001 07:07:42 -0700
From: Shahram Davari <[email-masked]>
To: 'Binita Jha' <[email-masked]>, "[email-masked]'" <[email-masked]>
Subject: RE: MPLS over FR.

Hi,

> header is present or not?

The shim header MUST always be present, even if the packet has one label.
Only the S, EXP and TTL values of the top label of
the shim header are used. The top label's 20-bit label value is not used
at all, rather the DLCI is used instead.

> 2) Also if the shim header is present then how do we know abt

A DLCI value is bound to a specific network protocol (could be done by
partitioning of DLCI space). If the S=1 in the top
label, then it means that the payload has the same network protocol. If
the S=0, then it means that another label is present
and the payload is MPLS.

Yours,
-Shahram