Subject: Hello Message Extension

From: Jia Hong <[email-masked]>
Date: Wed, 15 Aug 2001 21:49:57 -0700 (PDT)

Hi All,
        I have one more doubt related to hello
message. If there are say 3 interfaces between two
nodes then the hellos should be transmitted on all the
3 interfaces. This means the hello message are used to
detect the interface failures and not the node failure
in case there are multiple parallel point to point
links between two nodes.

Thanks in advance,
Jia.

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: David Charlap <[email-masked]>
Date: Thu, 16 Aug 2001 11:19:49 -0400

Jia Hong wrote:
> 
>         I have one more doubt related to hello message. If there are
> say 3 interfaces between two nodes then the hellos should be
> transmitted on all the 3 interfaces. This means the hello message
> are used to detect the interface failures and not the node failure
> in case there are multiple parallel point to point links between two
> nodes.

What protocol are you talking about?

In LDP, Hellos are transmitted on every interface, and work as you
describe - detecting link failures.

In RSVP, if all the interfaces are numbered, Hellos will be sent on each
interface.  If there are unnumbered interfaces, however, Hellos will
only be sent on one interface (per neighbor, of course).  The RSVP-TE
document describes the details of how this is supposed to work.

-- David

---

From: "Hongwei" <[email-masked]>
Date: Thu, 16 Aug 2001 17:39:53 +0100

hi David,

Could you please hang on a second here? I have no a concrete concept about
"interface" in LDP specification. Is it a physical link or something else?

Another question is: how to know a router is a LDP egress router? is it the
responsibility of network administrator to configure, or the router itself
can automatically detect that it is on the boundary between MPLS domain and
non-MPLS domain by sending discovery hello message? if the router discovers
in this way , what if the routers in the non-mpls domain don't understand
the hello message?

Thanks a lot!

--henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of David Charlap
Sent: 16 August 2001 16:20
To: [email-masked]
Subject: Re: Hello Message Extension

-- David