Subject: LSP ID in LSR MIB

From: "Neelesh Dwivedi" <[email-masked]>
Date: Wed, 29 Aug 2001 09:55:16 +0530

Hello,
I have  few doubts related to the MPLS LSR MIB
(draft-ietf-mpls-lsr-mib-07.txt).

The Cross-Connect Table has an entry

       mplsXCLspId                 MplsLSPID

 This MplsLSPID is described in  draft-ietf-mpls-tc-mib-02.txt as

 "An identifier that is assigned to each LSP and is used to uniquely
identify
it.  This is assigned at the head end of the LSP and can be used by all LSRs
to identify this LSP.  This value is piggybacked by the signaling protocol
when this LSP is signaled within the network.  This identifier can then be
used at each LSR to identify which labels are being swapped to other
labels for this LSP.  For IPv4 addresses this results in a 6-octet long
cookie."
SYNTAX        OCTET STRING (SIZE (0..31))

 My questions are:
a)  Is there any standard format for this unique identifier ? If not, then
what can be the possible ways to assign it?

 b) What do we mean by "piggybacking" this value by the signaling protocol?
If it is to be advertised in some control message then where and how do
we do it?

 Regards,
Neelesh.

 Mercury Corporation
New Delhi R&D Centre,
Gurgaon, India.

---

From: abhay <[email-masked]>
Date: Wed, 29 Aug 2001 15:14:47 +0530

Neelesh,

       With regards to your questions

       1)You can have the LSPID as an array of unsigned chars

        for example  192.168.1.10:1  where this is the LSPID

        The 192.168.1.10 is the source address and 1 is the local lspid.

        Similar relevance can be applied to RSVP piggyback.

       2)Piggyback is the Label mapping message for a pending label request message

         here you only update the label value returned by the signaling protocol

         Hope this helps,

         Regards,

         Abhay

---

From: "Neelesh Dwivedi" <[email-masked]>
Date: Wed, 29 Aug 2001 15:38:22 +0530

Abhay,
Thanks for your reply.

But as the description of the MplsLSPID in  draft-ietf-mpls-tc-mib-02.txt
says:
"This is assigned at the head end of the LSP and can be used by all LSRs
to identify this LSP."
Now if we consider Head-End to be the Ingress LSR, then how is it going to
inform the other LSRs about the LSPID? The point is how are we going to
piggyback this
LSPID on any Signaling Protocol control message  ?

Neelesh.
Mercury Corporation
New Delhi R&D Centre,
Gurgaon, India.

----- Original Message -----
From: abhay
To: Neelesh Dwivedi
Cc: [email-masked] ; [email-masked]
Sent: Wednesday, August 29, 2001 3:14 PM
Subject: Re: LSP ID in LSR MIB

Neelesh,
       With regards to your questions
       1)You can have the LSPID as an array of unsigned chars
        for example  192.168.1.10:1  where this is the LSPID
        The 192.168.1.10 is the source address and 1 is the local lspid.
        Similar relevance can be applied to RSVP piggyback.
       2)Piggyback is the Label mapping message for a pending label request
message
         here you only update the label value returned by the signaling
protocol
         Hope this helps,
         Regards,
         Abhay

Neelesh Dwivedi wrote:
Hello,

---

From: "Vijayalakshmi B" <[email-masked]>
Date: Thu, 30 Aug 2001 09:10:30 +0530

Imagination is more important than knowledge..
****************************************
Vijayalakshmi B
Software Engineer
Infosys Technologies LTD.

---

From: abhay <[email-masked]>
Date: Thu, 30 Aug 2001 12:12:11 +0530

Neelesh,

       On the piggyback you have the Ingress (Source Address) and the local lspid

       along all the routers which serviced the LSP request message.

       This is the key.

       Hope this helps.

       Regards,

       Abhay