Subject: RRO Processing

From: Manoj Agiwal <[email-masked]>
Date: Tue, 14 Aug 2001 09:58:01 +0530

Hi ,
      In case of RRO processing ,

"If the newly added subobject causes the RRO to be too big to fit 
in a  Path (or Resv) message, the RRO object SHALL be dropped 
from the  message and message processing continues as normal"

 In this particular case will the RRO object will be dropped for all the
Filter Descriptors  , or for the one which is new .

How the case should be handled in case if RRO was not there and subsequent
adding the RRO object starts giving this error .

Regards ,
Manoj

---

From: "Feng, Mark" <[email-masked]>
Date: Wed, 15 Aug 2001 14:16:29 -0700

In the Path message, there should be only one RRO. So, if it is too big, the
RRO is removed.

In Resv message, IMO, it should be consistent with Path, i.e. the RRO should
be dropped per sender.

I am not sure what you mean by "new". The RRO procedure initiates either by
the ingress or the egress.

-Mark

> -----Original Message-----
> From: Manoj Agiwal [mailto:[email-masked]]
> Sent: Monday, August 13, 2001 9:28 PM
> To: [email-masked]'
> Subject: RRO Processing
> 
> 
> Hi ,

---

From: Manoj Agiwal <[email-masked]>
Date: Thu, 16 Aug 2001 09:58:34 +0530

Hi Feng ,
     One Resv message may contain multiple filter descriptors ,
and each filter descriptor may contain RRO . By "new" I meant
should we drop the RRO for the filter descriptor newly added  in the Resv
Message , for a new sender .
     There is another possibility that initially for the PSB state and the
corresponding RSB  state does not contain RRO object and
down the line Path messages starts including the RRO object, now the
corresponding Resv messages for this sender  also starts including the RRO
object at the egress , in such a scenario 
at any LSR if one gets MTU exceed error, the RRO for which sender should be
removed ( Resv message contains multiple filter descriptor )
Regards ,
Manoj

> ----------
> From: 	Feng, Mark[SMTP:[email-masked]]
> Sent: 	Thursday, August 16, 2001 2:46 AM
> To: 	[email-masked]'
> Subject: 	RE: RRO Processing
>

---

From: "Feng, Mark" <[email-masked]>
Date: Thu, 16 Aug 2001 15:17:38 -0700

Please see comments below. 

-Mark

> Sent: Wednesday, August 15, 2001 9:29 PM
> To: 'Feng, Mark'
> Cc: [email-masked]'

It is more logical to drop the "newly" added sender's RRO.

> removed ( Resv message contains multiple filter descriptor )

In the ResvErr, the sender should be specified. In the transit node, I don't
believe any action is taken, i.e. the transit node is not going to drop any
RRO, as long as that particular node can fit the RRO in the message.

BTW, I know the error code is "RRO too large for MTU". But I believe the
limit of RSVP message is the IP packet size.

> > In the Path message, there should be only one RRO. So, if 
> it is too big,
> > the
> > RRO is removed.
> > 
> > In Resv message, IMO, it should be consistent with Path, 
> i.e. the RRO
> > should
> > be dropped per sender.
> > 
> > I am not sure what you mean by "new". The RRO procedure 
> initiates either
> > by