Subject: reserving

From: Fabris Sergio <[email-masked]>
Date: Wed, 1 Aug 2001 15:39:49 -0300

Hi,

A contsraint-based routing scheme automatically choose 
paths with minimum hop count, largest available bandwidth, etc.
But if I want to find a path and setup tunnel for 10Mbs for example. 
How does the path finder algorithm know that? 
Is it signaled by RSVP?

Thanks.

Sergio

---

From: abhay <[email-masked]>
Date: Thu, 02 Aug 2001 10:04:10 +0530

Fabris,

      If you can see the constraint-based routing schemes,one of the path finder

      algorithm's attribute is

      *)It knows the available bandwidth at each priority

      This information can be got by extensions to routing protocols such as OSPF

      and IS-IS

      Hence you can modify your path finder algorithm in this way:

      1)Let it also take the required bandwidth into account,then the

        algorithm may not return you the path if there is no sufficient bandwidth

        available and it can also tell u which paths can be pre-empted in order

        to satisfy your 10Mbps requriment.

       Once the path is found it can signaled by the signaling protocol.

       Hope this throws some light,

       Regards,

       Abhay