Subject: RE: Time to live

From: [email-masked]
Date: Tue, 21 Aug 2001 17:22:28 +0100

It stays the same. The routers only look at the label value not the IP
header. When the packet leaves MPLS domain then the normal operation would
apply.

Asim

-----Original Message-----
From: David Escobar [mailto:[email-masked]]
Sent: 21 August 2001 17:19
To: [email-masked]
Subject: Time to live

Hi;
What happens to the TTL field in the IP header when a labeled packet goes
through an LSP? Is it decreased at each router or stay the same?

---

From: "Alexander Marhold" <[email-masked]>
Date: Tue, 21 Aug 2001 18:44:07 +0200

Hello
I want to explain the mechanism a little bit more in detail

FRAME based general:
1. normally at the ingress LSR the IP-TTL is copied into the TTL-field of
the label header.
2. the label-TTL is decremented at each hop by 1
3. when it reaches 0 the labelled packet will be dropped and a
TTL-exceeded-ICMP message will be sent if possible
4. at the egress the label-TTL is copied back into the IP-TTL

CELL based general:
1. normally at the ingress LSR the IP-TTL is copied into the TTL-field of
the label header.
1a. the ingress LSR to the ATM-MPLS cloud either decrements the TTL by 1
1b		or by the amount of ATM_MPLS hops of the LSP ( this he knows from the
LSP-setup using downstream on demand label allocation and ordered
lsp-control label setup)
2. then the packet is chopped into cells
3. the egress reassembles the packet and copies the label ttl back into the
IP-TTL

if 1a is used then the ATM-MPLS cloud looks like a 1-hop network

special features:
a) on cisco LSRs there is the possibility to disable the copying of the
IP-TTL to the label-TTL and the label-TTL again starts at 255.
on the egress the smaller of the 2 TTL-values ( label and IP-header) will be
used for the IP-TTL
then for traceroute the MPLS cloud looks like a 1-hop (2-hop with PHP)
network

with best regards

Alexander

__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/
     __/
    __/   Dipl.Ing. Alexander Marhold MBA
   __/   CCIE #3324, CCNP, CCDP, CCSI #20642
  __/   Core & IP Services <Senior Consultant>
 __/   Mobile: ++43-(0)664-16 28 234
__/   PRO IN http://www.proin.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, August 21, 2001 6:22 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: Time to live

Asim

-----Original Message-----
From: David Escobar [mailto:[email-masked]]
Sent: 21 August 2001 17:19
To: [email-masked]
Subject: Time to live

Hi;

---

From: Eric W Gray <[email-masked]>
Date: Tue, 21 Aug 2001 12:47:24 -0400

Sort of.

Yes, the IP header is ignored within the LSP.  But the TTL is
transferred to the label encapsulation where (for Ethernet and
PPP at least) it is decremented at each LSR.  On egress, the
TTL is then transferred back to the IP header.

Where TTL is not included in the label encapsulation (ATM
and FR), TTL is decremented at the LSP ingress (by some
amount between 1 and the number of hops for the LSP - as
determined by 'hop count' in LSP setup, for instance) in the
IP header before encapsulation and forwarding via ATM/FR.

Read RFCs 3031 and 3032.

--
Eric Gray

---

From: Eric W Gray <[email-masked]>
Date: Tue, 21 Aug 2001 12:53:21 -0400

Alexander,

    No cigar.  The distinction is not cell verses frame, but rather
whether or not it is possible to incorporate the label in the L2
encapsulation.  Where this is possible, ATM and FR, there is
no TTL capability in the L2 encapsulation.  Not that Frame
Relay is Frame based...

--
Eric Gray

---

From: Eric W Gray <[email-masked]>
Date: Tue, 21 Aug 2001 13:10:17 -0400

Below, the last sentence was supposed to be "Note that Frame
Relay ..."

--
Eric Gray

---

From: Ray Qiu <[email-masked]>
Date: Tue, 21 Aug 2001 10:26:06 -0700 (PDT)

There is also an option that we don't copy the MPLS TTL back to IP TTL.
It makes IP think the MPLS LSP is only one hop.

Thanks,
Ray

On Tue, 21 Aug 2001, Eric W Gray wrote:

> Date: Tue, 21 Aug 2001 13:10:17 -0400
> From: Eric W Gray <[email-masked]>
> To: Alexander Marhold <[email-masked]>,
>      MultiProtocol Label Switching Mailing List <[email-masked]>
> Subject: Re: Time to live
>

---

From: Eric W Gray <[email-masked]>
Date: Tue, 21 Aug 2001 13:56:11 -0400

Yes, that has been suggested as a logical extension of the 'Pipe'
model in DiffServ.  I don't recall where that effort is at right now
but I don't think the work has been adopted by either the MPLS
or CCAMP working groups.  Do you know?

--
Eric Gray

---

From: Ray Qiu <[email-masked]>
Date: Tue, 21 Aug 2001 11:40:44 -0700 (PDT)

Eric,

I think it is now a proprietary implementation.  Juniper and Riverstone
both support this feature.

Thanks,
Ray

On Tue, 21 Aug 2001, Eric W Gray wrote:

> Date: Tue, 21 Aug 2001 13:56:11 -0400
> To: Ray Qiu <[email-masked]>
> Cc: MultiProtocol Label Switching Mailing List <[email-masked]>