Subject: MPLS Tunnel interface

From: Kiril Shulga <[email-masked]>
Date: Wed, 10 Oct 2001 09:41:15 +0200

Hi!
I've few questions related to MPLS TE-MIB:

In which purpose it's created tunnel that isn't interface
(mplsTunnelIsIf = FALSE)?
How redirect traffic to such tunnel?

Thanks in advance,
Kiril

---

From: "abhay" <[email-masked]>
Date: Wed, 10 Oct 2001 14:15:39 +0530

Kiril,
        You create tunnels which are not interfaces if you are going to have
a router management running with
         various IGP's running and they can attach the tunnel for a
destination at runtime based on decision.
         Tunnels which are interfaces have an extra registration with the
Interfaces MIB.Which implies that they can
         be used in routing calculations,where the tunnel is the next hop.
         Hope this helps
         Regards,
         Abhay

---

From: Kiril Shulga <[email-masked]>
Date: Wed, 10 Oct 2001 11:05:14 +0200

Hi Abhay,

The questions are below:

> destination at runtime based on decision.

Attaching tunnel means defining ifIndex for it? That is non-interface tunnel
turns to tunnel which is interface?

Regards,
Kiril

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 10 Oct 2001 11:07:35 -0400

>(mplsTunnelIsIf = FALSE)?

         Some vendors chose to not implement
the tunnel heads as interfaces. This is why
it is possible to do this in the MIB.

>How redirect traffic to such tunnel?

         Some people have implemented
a device that can control tunnels
on remote LSRs. The creation of a
tunnel as an interface in the MIB doesn't
make sense in this case, but instead
just as a tunnelEntry.

         --Tom

>Kiril

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 10 Oct 2001 11:13:53 -0400

>(mplsTunnelIsIf = FALSE)?

         One other case that I forgot in my last
reply is when examining the MIB at the midpoint
of a tunnel. Some LSRs may choose to not implement
mid-points of tunnels as interfaces, thus
they show up in the table as non-ifIndexes.

         --Tom

---

From: "abhay" <[email-masked]>
Date: Thu, 11 Oct 2001 10:04:52 +0530

Kiril,
       Actually when you create a tunnel as an interface the tunnel id for
the tunnel is the unique combination of source
       address and the interface index provided by the Interfaces MIB(assume
a module).
       Tunnels which are not interfaces have a different way of assigning
the tunnel id which means that when u have a
        tunnel which is not an interface you have a definite outgoing
interface over which u have the connection identifier
        assigned.
        In this case before you transmit the data packet there is a check
which verifies if there is a established tunnel for a
        particular destination by using a lookup table(say at the ingress)
and the packet is put on that outgoing interface attached         to the
tunnel.
        Yes,the contents of the FEC to NHLFE and LSR MIB greatly help in
this mechanism.
         Hope this interpretation helps.
         Regards,
         Abhay.