Subject: RE: LSP Failure/Recovery

From: "David Allan" <[email-masked]>
Date: Tue, 9 Oct 2001 13:39:23 -0400

Sachin/Venkata:
 
You're mixing protection switching, and re-route scenarios. There are
specific behaviors/state requirements depending on the recovery strategy,
    - LSR 16 may tell the ingress (revertive/non-revertive global repair), 
    - LSR 16 may tell no-one (local repair),  
    - LSR 16 may tell EVERYONE (simple re-route) when the link goes
down/comes back up.
 
later
Dave

From: Sachin Kalra [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 1:17 PM
To: Naidu, Venkata; [email-masked]'; [email-masked]
Subject: RE: LSP Failure/Recovery

Venkata:

Thanks for the email.

> Router 16 MAY indicate the ingress LER when the link between
>Router 16 and 17 comes back up. There are no hard and fast rules...

I agree with Mani in this case and suspect that "LSR 16 MAY indicate the
ingress LER when the link between Router 16 and 17 comes back up."

Because
1> Why would LSR16 maintain information about the broken LSP (Which is not
going through LSR16 any more, as may be the case that LSR14/15 or Ingress
LER may have rerouted the LSP bypassing LSR16)

2> And if LSR16 does not maintain any state for broken LSP then it should
not even know that it has to inform any LER (or other LSR) about the link
recovery. 

Please correct me if I am wrong.
Sachin

At 01:00 PM 10/9/01 -0400, Naidu, Venkata wrote:

Mani:

-> If you have a "local repair" support implemented, Router 16 will
-> reroute the LSP from itself (Router16) to the destination. It is not
-> required for the rerouting to be done from the Ingress or the head
-> of the LSP - which is known as "Global repair".

  Strictly speaking, there is no requirement that only the
  affected router (Router 16 here) should do "local repair".
  Any router/LSR which has sufficient information can do 
  local repair (for example router 15 or 14 etc)
 
-> Secondly Router 16 can reroute avoiding Router 17, only when
-> Router 17 is not an explicit Hop to be reached from Router 16 for
-> the rerouted LSP

  Not necessarily true. If one of the links between Router 16 
  and Router 17 fails, the _only_ requirement is to avoid the
  failed "link" and not the complete "node" (Router 17 here).

  So Router 16 can locally route the LSP to another parallel
  link to Router 17 _OR_ another disjoint path to 17. What you
  are trying to achieve here is link disjointness and not
  node disjointness.
   
-> W.r.to your questions, If Router 16, has indicated the ingress
-> and done the reroute (global repair), It will not indicate the
                                           ^^^^^
-> ingress to reroute again when the link between 16 and 17 comes
-> up.

  Router 16 MAY indicate the ingress LER when the link between
  Router 16 and 17 comes back up. There are no hard and fast rules...

--Venkata Naidu

---

From: "Hongwei" <[email-masked]>
Date: Tue, 9 Oct 2001 19:28:27 +0100

Dave,

  If it is intended to implement traffic engineering with mpls, i think it
will be rational to let the ingress router deal with rerouting task because
it is the ingress router that computed the explicit route. if we allow LSR16
to do local rerouting, we may not achieve overall optimised network
performance, that is, the network load may not be balanced the best.

  If we have no concern about traffic engineering, i think all the three
methods you listed are usable, depending on the network administrator or
device vendors.

  To be honest, I have also some other confusions about explicit routing:
  1. how does the ingress routers compute the optimised explicit routes
through the network?
  2. To compute an optimised route, a router need complete information of
the network. but every router including LERs and LSRs, has the complete
information about the whole network or the autonomous system, or just the
LERS have this whole information?
  3. how do the routers get the information about the whole network? it
should be a headache because the load of the network, maybe also the
topology of the network, is in highly dynamic change.

  Thanks for every answer in advance!!!

  -Hongwei

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of David
Allan
    Sent: 09 October 2001 18:39
    To: Sachin Kalra; Naidu, Venkata; [email-masked]'; [email-masked]
    Subject: RE: LSP Failure/Recovery

    Sachin/Venkata:

        - LSR 16 may tell the ingress (revertive/non-revertive global
repair),

    later
    Dave

---

From: Yousuf Hasan <[email-masked]>
Date: Tue, 09 Oct 2001 12:40:27 -0700

At 07:28 PM 10/9/2001 +0100, Hongwei wrote:
>   
>Dave, 
>  
>If it is intended to implement traffic engineering with mpls, i think it will be rational to let the ingress router deal with rerouting task because it is the ingress router that computed the explicit route. if we allow LSR16 to do local rerouting, we may not achieve overall optimised network performance, that is, the network load may not be balanced the best. 

Jumping in, if I understand correct,  if LSR16 is a midpoint node for a TE tunnel, then if it does local rerouting, meaning it has some backup LSP via an alternate path to LSR17, that local re-routing imlies that from the ingress router's (headend) prospective, the TE tunnel is still up. LSR16 just put the traffic on a pre-signaled TE tunnel. That would be Fast re-route as per 
draft-swallow-rsvp-bypass-label

>  
>If we have no concern about traffic engineering, i think all the three methods you listed are usable, depending on the network administrator or device vendors. 
>  

With traffic engineering

>1. how does the ingress routers compute the optimised explicit routes through the network?

ingress router has a TE database which has the SPF view of the whole network + constraints (like Bandwidth, Link/Tunnel affinities). So TE database runs Constraint based SPF with reference to the constraints mentioned

>2. To compute an optimised route, a router need complete information of the network. but every router including LERs and LSRs, has the complete information about the whole network or the autonomous system, or just the LERS have this whole information?

currently the TE database would be limited to an AS or routing area/level

>3. how do the routers get the information about the whole network? it should be a headache because the load of the network, maybe also the topology of the network, is in highly dynamic change.

Constraint info. is distributed via IGP extensions
draft-ietf-isis-traffic
draft-katz-yeung-ospf-traffic

Hope that helps
Thanks

-Yousuf

>From: [email-masked] [mailto:[email-masked]]On Behalf Of David Allan 
>You're mixing protection switching, and re-route scenarios. There are specific behaviors/state requirements depending on the recovery strategy, 
>    - LSR 16 may tell EVERYONE (simple re-route) when the link goes down/comes back up. 
>  
>later 
>Dave 
>