Subject: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

From: "Ashwin C. Prabhu" <[email-masked]>
Date: Mon, 15 Oct 2001 19:21:03 +0530

Hello 

 In the  draft-ietf-mpls-te-mib-07.txt tunnel table 
 the Local protection is defined as

mplsTunnelLocalProtectInUse  OBJECT-TYPE
   SYNTAX        TruthValue
   MAX-ACCESS    read-create
   STATUS        current
   DESCRIPTION
        "Indicates that the local repair mechanism is in use
          to maintain this tunnel (usually in the face of an
          outage of the link it was previously routed over)."
   ::= { mplsTunnelEntry 15 }

 Shouldn't this be read-only variable as the fast reroute is enabled only 
 when the link is failed and the local protection is in use flag will be
set?

Ashwin

---

From: "abhay" <[email-masked]>
Date: Tue, 16 Oct 2001 10:18:28 +0530

Doubt in draft-ietf-mpls-te-mib-07.txt MIBAshwin,
           mplsTunnelLocalProtectInUse,is usually used by the administrator to view if the primary path is protected.

          1) When we enable a primary path to have disjoint local protection path,the primary path has its mplsTunnelLocal
           ProtectInUse filled when we create the path and not when the link in the path fails.

           2)It is also can be a way to telling the MPLS Management(ref the recent draft on MPLS Management) running on the
              router to know that the primary path is fast-reroute enabled and this router if required should participate in setting up
              local repair paths.

          That explains the read-create attribute of the variable.

          Hope this helps,
          Regards,
          Abhay
  ----- Original Message ----- 
  From: Ashwin C. Prabhu 
  To: [email-masked] ; [email-masked] 
  Sent: Monday, October 15, 2001 7:21 PM
  Subject: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

  Hello 

   Shouldn't this be read-only variable as the fast reroute is enabled only 
   when the link is failed and the local protection is in use flag will be set? 

  Ashwin