Subject: some questions!!!

From: "k m a" <[email-masked]>
Date: 17 Oct 2001 02:32:29 -0000

hi all i have the following questions ,if u could help me on these!!!
1) what is Constraint Based Routing in general
i mean how is an MPLS router intelligent enough to perform it. 
 2) how does MPLS perform resource reservation/constraint based routing 
 3) is the MPLS label used in any way to accomplish the above 
 4) what is CR-LDP 
 5)is there some form of load balancing done in case a route becomes 
   unavailable 
    - if so, what is the overhead in terms of control messages etc.. 
    - compare this with resource reservation/overhead etc.. in an 'IP 
      only' network( ie: no MPLS ) 

thanx a lot
k

---

From: Ajay Simha <[email-masked]>
Date: Tue, 16 Oct 2001 23:43:08 -0400 (Eastern Daylight Time)

On 17 Oct 2001, k m a wrote:

kma:
kma:
kma:hi all i have the following questions ,if u could help me on these!!!
kma:1) what is Constraint Based Routing in general

Please read RFC 2702.

kma:i mean how is an MPLS router intelligent enough to perform it.

it performs CSPF (Dikstra that takes bandwidth/affinity into account)

kma: 2) how does MPLS perform resource reservation/constraint based routing

MPLS does not.  The headend could either use RSVP/CR-LDP to signal the
reservation and get labels in exchange if the reservation is honored.

kma: 3) is the MPLS label used in any way to accomplish the above
yes.

kma: 4) what is CR-LDP

Constrain Routing - Label Distribution Protocol

For more details read draft-ietf-mpls-cr-ldp-05.txt

kma: 5)is there some form of load balancing done in case a route becomes
kma:   unavailable
kma:    - if so, what is the overhead in terms of control messages etc..
kma:    - compare this with resource reservation/overhead etc.. in an 'IP
kma:      only' network( ie: no MPLS )

Load balancing is an implementation matter.  If a vendor wishes they can do
this.

Somehow your questions seem like a quiz/homework :-)

Regards,

-ajay
kma:
kma:thanx a lot
kma:k
kma:

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi