Subject: Why do we need CR-LDP Tunnel Resource Table in TE MIB 7?

From: "Ashwin C. Prabhu" <[email-masked]>
Date: Wed, 24 Oct 2001 15:43:19 +0530

Hello All
 
 Why the CR-LDP Tunnel Resource Table is added in the
draft-ietf-mpls-te-mib-07.txt. 
 There is also a mplsTunnelResourceTable which has all the parameters 
 of the mplsTunnelCRLDPResTable. 
 
 And the note specifically says that this is in addition to the Tunnel
Resource Table . 
 
The mplsTunnelCRLDPResTable allows a manager to
          specify which CR-LDP-specific resources are desired
          for an MPLS tunnel if that tunnel is signaled using
          CR-LDP. Note that these attributes are in addition
          to those specified in mplsTunnelResourceTable. This
          table also allows several tunnels to point to a
          single entry in this table, implying that these
          tunnels should share resources.
 
And the parameters of the table are same expect the mplsTunnelCRLDPResFlags.
Can you please tell me what is the differance between these 2 tables and why
is this 
needed ?

Ashwin

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 24 Oct 2001 09:46:01 -0400

> draft-ietf-mpls-te-mib-07.txt.

         It was added to support CD-LDP resources for tunnels. :P

>  of the mplsTunnelCRLDPResTable.

         Yes, I believe that is a typo that needs to be fixed in the next
revision. The duplicated objects that are in the CD-LDP table
will be removed, as they can be gotten from the base resource
table.

         --Tom

>Can you please tell me what is the differance between these 2 tables and 
>why is this
>needed ?
>
>
>Ashwin
>
>
>
>

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: "abhay" <[email-masked]>
Date: Thu, 25 Oct 2001 10:08:44 +0530

RE: Doubt in draft-ietf-mpls-te-mib-07.txtAshwin,
           Sometime ago the CR-LDP sentence in the MIB was not present for resource allocation.
           And during those times,I used my own MIB variables,just to have a little fun and give CR-LDP
           a fair chance.Now u see it,later u wont...again..any extensions to CR-LDP,you will see it again.
           In good humour.
           Regards,
           Abhay
  ----- Original Message ----- 
  From: Ashwin C. Prabhu 
  To: [email-masked] ; [email-masked]' 
  Cc: [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Wednesday, October 24, 2001 3:43 PM
  Subject: Why do we need CR-LDP Tunnel Resource Table in TE MIB 7?

  Hello All
   
   Why the CR-LDP Tunnel Resource Table is added in the draft-ietf-mpls-te-mib-07.txt. 
   There is also a mplsTunnelResourceTable which has all the parameters 
   of the mplsTunnelCRLDPResTable. 
   
   And the note specifically says that this is in addition to the Tunnel Resource Table . 

  And the parameters of the table are same expect the mplsTunnelCRLDPResFlags.
  Can you please tell me what is the differance between these 2 tables and why is this 
  needed ?

  Ashwin