Subject: RE: mplsLdpEntityTable

From: "Tiruveedhula, Kishore" <[email-masked]>
Date: Thu, 11 Oct 2001 17:40:40 -0400

Hi Joan,
      Thanks for your mail. Please see below for my doubt.
> You need to have 2
>distinct
>mplsEntityLdpIds if the label space part is zero, then this means that 
>the LSR IDs need to be different.  Admittedly, this is unlikely (or at
>least in my experience this is unlikely since I have typically seen the
>LSR ID portion == the RouterId), but I suppose if someone wanted 
>to do this so that he/she could support both DOD and DU sessions where 
>each session is using per platform label space on the same router that
>configuration would be an alternative.

     The entry in the entity table is indexed by both mplsEntityLdpIds and
mplsLdpEntityIndex.
       Can't we create two entries with same mplsEntityLdpIds with different
mplsLdpEntityIndex in the Entity Table to support both DOD and DU sessions
using per platform label space on a LSR with same LSR id ?
 mplsLdpEntityIndex  is used to uniquely identify row in the
mplsLdpEntityTable. I think we can have two or more entries with same
mplsEntityLdpIds with different mplsLdpEntityIndex. Is this correct ?
 
Thanks,
Kishore    

>  -Joan

> 
> Thanks,
> Kishore
> 
> >  -Joan
> 
> >
> >> Thanks,
> >> Kishore
> >
> > -----Original Message-----
> > From: Joan Cucchiara [mailto:[email-masked]]
> > Sent: Tuesday, October 09, 2001 5:59 PM
> > To: Srinivas T M
> > Cc: [email-masked]; [email-masked];
> > [email-masked]; [email-masked]
> > Subject: Re: mplsLdpEntityTable
> >
> > Srinivas T M wrote:
> > >
> > > Hi,
> > >    Can anybody clarify my below question.
> > >
> > > How Interface Index relates to entry in the
> > > mplsLdpEntityTable in case of per-platform label space
> > > , generic label type and in case of LDP Identifier is
> > > same for all interfaces ?
> >
> > The entity entry/row is the configuration for a potential
> > session.  The Interface Index is in the label range tables
> > and the mplsLdpEntityLdpId and mplsLdpEntityIndex are used
> > to tie the entity entry with a label range entry.
> >
> > In the case of the per-platform label space, this is also
> > the situation.  I'm not sure if this answers the question
> > you are asking though.
> >
> > >
> > >  Can we use single entry in the entity table for
> > > multiple interfaces? If it is like that, then what
> > > happens if we change label Distribution Method or
> > > LabelRetentionMode  or any field in the entity table,
> > > on interface? draft-ietf-mpls-ldp-mib-08.txt is not
> > > telling how interface relates to entry in the entity
> > > table.
> >
> > The front section of the MIB and the description for
> > mplsLdpEntityAdminStatus does describe that it
> > expects the user to administratively disable the entity
> > (and thus take down the session -- meaning the session
> > is removed) and then change whatever
> > fields and then administratively enable the entity
> > to create new session.
> >
> >   -Joan
> >
> > >
> > >   MplsLdpEntityEntry ::= SEQUENCE {
> > >      mplsLdpEntityLdpId        MplsLdpIdentifier,
> > >      mplsLdpEntityIndex        Unsigned32,
> > >      mplsLdpEntityProtocolVersion  Integer32,
> > >      mplsLdpEntityAdminStatus      INTEGER,
> > >      mplsLdpEntityOperStatus       INTEGER,
> > >      mplsLdpEntityTcpDscPort       Unsigned32,
> > >      mplsLdpEntityUdpDscPort       Unsigned32,
> > >      mplsLdpEntityMaxPduLength     Unsigned32,
> > >      mplsLdpEntityKeepAliveHoldTimer  Integer32,
> > >      mplsLdpEntityHelloHoldTimer      Integer32,
> > >      mplsLdpEntityInitSesThreshold    Integer32,
> > >      mplsLdpEntityLabelDistMethod     INTEGER,
> > >      mplsLdpEntityLabelRetentionMode  INTEGER,
> > >      mplsLdpEntityPVLMisTrapEnable    INTEGER,
> > >      mplsLdpEntityPVL                 Integer32,
> > >      mplsLdpEntityHopCountLimit       Integer32,
> > >      mplsLdpEntityTargPeer            TruthValue,
> > >      mplsLdpEntityTargPeerAddrType
> > > adressFamilyNumbers,
> > >      mplsLdpEntityTargPeerAddr      MplsLdpGenAddr,
> > >      mplsLdpEntityOptionalParameters
> > > MplsLdpLabelTypes,
> > >      mplsLdpEntityDiscontinuityTime   TimeStamp,
> > >      mplsLdpEntityStorType            StorageType,
> > >      mplsLdpEntityRowStatus            RowStatus
> > >      }
> > >
> > > Thanks in Advance,
> > > Srini.
> > >
> > > __________________________________________________
> > > Do You Yahoo!?
> > > NEW from Yahoo! GeoCities - quick and easy web site hosting, just
> > $8.95/month.
> > > http://geocities.yahoo.com/ps/info1

---

From: Joan Cucchiara <[email-masked]>
Date: Mon, 15 Oct 2001 09:34:11 -0400

> mplsEntityLdpIds with different mplsLdpEntityIndex. Is this correct ?

This is not a viable solution to the problem --  you will still have
only
one LSRID and that implies that one session will be capable of both
DOD and DU which is not possible with LDP.

   Thanks, Joan