Subject: label value type

From: "krishnakanth.rao" <[email-masked]>
Date: Tue, 9 Oct 2001 01:42:20 -0400

What is the range of the label values attached to packets in MPLS, is it an integer value or is it a string

Krishnakanth

---

From: "Hongwei" <[email-masked]>
Date: Tue, 9 Oct 2001 12:02:07 +0100

Integer values, and values from 0-16 have been reserved. But I think there
are no standards among the device vendors, you can use anything in your
research. anyway, labels are
only locally significant and are used just for identifying LSPs (or FECs).

I appreciate any correction of my comments ;-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
krishnakanth.rao
Sent: 09 October 2001 06:42
To: [email-masked]
Subject: label value type

What is the range of the label values attached to packets in MPLS, is it an
integer value or is it a string

Krishnakanth

---

From: "Ding Aijun" <[email-masked]>
Date: Tue, 9 Oct 2001 14:29:53 +0800

It should be an integer. Actually, if there is some programming technique
that is good at string processing, then the label may be a string.

regards,
aijun

---

From: Eric Gray <[email-masked]>
Date: Tue, 09 Oct 2001 11:37:09 -0400

Krishnakanth,

    Start here: http://www.ietf.org/html.charters/mpls-charter.html

    Then go to http://www.ietf.org/rfc.html, find and read these:

        RFC 3031
        RFC 3032

    Finally, read various works in progress located at:

        http://www.ietf.org/ids.by.wg/mpls.html

As a general observation, directed at no one in particular, it is a really good
idea to do at least some work on your own...

--
Eric Gray (mailto:[email-masked])
http://www.mindspring.com/~ewgray