Subject: RE: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

From: "Ashwin C. Prabhu" <[email-masked]>
Date: Tue, 16 Oct 2001 10:48:17 +0530

Hello Abhay
 
     Thanks for your reply.
    
     But still i am not clear.
 
    There is one more entry in the tunnel table. fastReroute under the
mplsTunnelSessionAttributes 
    as follows
  
----------------------------------------------------------------------------
-------------------------------------------------------------------
    mplsTunnelSessionAttributes OBJECT-TYPE
   SYNTAX      BITS {
                  fastReroute (0),
                  mergingPermitted (1),
                  isPersistent (2),
                  isPinned (3),
                  recordRoute(4)
                 }
   MAX-ACCESS    read-create
   STATUS        current
   DESCRIPTION
        "This bitmask indicates optional session values for
          this tunnel. The following describes these
          bitfields:
        
        fastRerouteThis flag indicates that the any tunnel
          hop may choose to reroute this tunnel without
          tearing it down.  This flag permits transit routers
          to use a local repair mechanism which may result in
          violation of the explicit routing of this tunnel.
          When a fault is detected on an adjacent downstream
          link or node, a transit router can reroute traffic
          for fast service restoration.
        
   REFERENCE
        "1. RSVP-TE: Extensions to RSVP for LSP Tunnels,
          Awduche et al, Internet Draft <draft-ietf-mpls-rsvp-
          lsp-tunnel-07.txt>, August 2000."
   DEFVAL        { 0 }
   ::= { mplsTunnelEntry 13 }
 
 I think the flag you were talking about is the above one and not the
mplsTunnelLocalProtectInUse. 
 Please tell me if i am wrong. 
 I am still not clear about mplsTunnelLocalProtectInUse flag what it is ment
for ? According to my 
 understanding this flag shold be set only when the local protection is in
use ? And if this is what is 
 the purpose then it should be read-only and not read-create.
 
Best Regds,
Ashwin

-----Original Message-----
From: abhay [mailto:[email-masked]]
Sent: Tuesday, October 16, 2001 9:48 AM
To: Ashwin C. Prabhu; [email-masked]; [email-masked]
Subject: Re: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

Ashwin,
           mplsTunnelLocalProtectInUse,is usually used by the administrator
to view if the primary path is protected.
 
          1) When we enable a primary path to have disjoint local protection
path,the primary path has its mplsTunnelLocal
           ProtectInUse filled when we create the path and not when the link
in the path fails.
 
           2)It is also can be a way to telling the MPLS Management(ref the
recent draft on MPLS Management) running on the
              router to know that the primary path is fast-reroute enabled
and this router if required should participate in setting up
              local repair paths.
 
          That explains the read-create attribute of the variable.
 
          Hope this helps,
          Regards,
          Abhay

----- Original Message ----- 
From: Ashwin C.  <mailto:[email-masked]> Prabhu 
To: [email-masked] <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  
Sent: Monday, October 15, 2001 7:21 PM
Subject: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

Hello 

 In the  draft-ietf-mpls-te-mib-07.txt tunnel table 
 the Local protection is defined as 

mplsTunnelLocalProtectInUse  OBJECT-TYPE 
   SYNTAX        TruthValue 
   MAX-ACCESS    read-create 
   STATUS        current 
   DESCRIPTION 
        "Indicates that the local repair mechanism is in use 
          to maintain this tunnel (usually in the face of an 
          outage of the link it was previously routed over)." 
   ::= { mplsTunnelEntry 15 } 

 Shouldn't this be read-only variable as the fast reroute is enabled only 
 when the link is failed and the local protection is in use flag will be
set? 

Ashwin

---

From: "abhay" <[email-masked]>
Date: Tue, 16 Oct 2001 15:40:47 +0530

Doubt in draft-ietf-mpls-te-mib-07.txt MIBAshwin,
           Yes,I see your point.
            The tunnel session attribute's containing the fast reroute bit is seemingly right.
            The mplsTunnelLocalProtectInUse can be set by the signaling protocol or the link management module
            when either of them,whichever faster(usually the Link Management),detect a link failure or a node failure.
            Hence read-create.
            Regards,
            Abhay      
  ----- Original Message ----- 
  From: Ashwin C. Prabhu 
  To: abhay ; [email-masked] ; [email-masked] 
  Sent: Tuesday, October 16, 2001 10:48 AM
  Subject: RE: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

  Hello Abhay
   
       Thanks for your reply.

      There is one more entry in the tunnel table. fastReroute under the mplsTunnelSessionAttributes 
      as follows
    
  -----------------------------------------------------------------------------------------------------------------------------------------------
      mplsTunnelSessionAttributes OBJECT-TYPE
     SYNTAX      BITS {
                    fastReroute (0),
                    mergingPermitted (1),
                    isPersistent (2),
                    isPinned (3),
                    recordRoute(4)
                   }
     MAX-ACCESS    read-create
     STATUS        current
     DESCRIPTION
          "This bitmask indicates optional session values for
            this tunnel. The following describes these
            bitfields:

     REFERENCE
   
   I think the flag you were talking about is the above one and not the mplsTunnelLocalProtectInUse. 
   Please tell me if i am wrong. 
   I am still not clear about mplsTunnelLocalProtectInUse flag what it is ment for ? According to my 
   understanding this flag shold be set only when the local protection is in use ? And if this is what is 
   the purpose then it should be read-only and not read-create.
   
  Best Regds,
  Ashwin
   
    -----Original Message-----
    From: abhay [mailto:[email-masked]]
    Sent: Tuesday, October 16, 2001 9:48 AM
    To: Ashwin C. Prabhu; [email-masked]; [email-masked]
    Subject: Re: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

    Ashwin,
               mplsTunnelLocalProtectInUse,is usually used by the administrator to view if the primary path is protected.

              1) When we enable a primary path to have disjoint local protection path,the primary path has its mplsTunnelLocal
               ProtectInUse filled when we create the path and not when the link in the path fails.

               2)It is also can be a way to telling the MPLS Management(ref the recent draft on MPLS Management) running on the
                  router to know that the primary path is fast-reroute enabled and this router if required should participate in setting up
                  local repair paths.

              Hope this helps,
              Regards,
              Abhay
      ----- Original Message ----- 
      From: Ashwin C. Prabhu 
      To: [email-masked] ; [email-masked] 
      Sent: Monday, October 15, 2001 7:21 PM
      Subject: Doubt in draft-ietf-mpls-te-mib-07.txt MIB

      Hello 

       Shouldn't this be read-only variable as the fast reroute is enabled only 
       when the link is failed and the local protection is in use flag will be set? 

      Ashwin