Subject: RE: Constraint Based Routing

From: Ajay Simha <[email-masked]>
Date: Tue, 16 Oct 2001 13:22:25 -0400 (Eastern Daylight Time)

On Tue, 16 Oct 2001, Chen, Cheng wrote:

CC>Mr. Simha,
CC>
CC>
CC>What is PCALC? where can i find the detailed description on PCALC?

Sorry for the jargon.  PCALC is short for Path Calculation (Computation) done
at the headend.

7.0 Constraint-Based Routing

of RFC-2702 talks about it some.

-ajay
CC>
CC>Thank you in advance,
CC>
CC>
CC>Best Regards,
CC>
CC>
CC>Cheng C. Chen
CC>
CC>-----Original Message-----
CC>From: Ajay Simha [mailto:[email-masked]]
CC>Sent: Tuesday, October 16, 2001 10:35 AM
CC>To: Rajesh P Jain
CC>Cc: 'MPLS UUNET Mailing List'
CC>Subject: Re: Constraint Based Routing
CC>
CC>
CC>On Tue, 16 Oct 2001, Rajesh P Jain wrote:
CC>
CC>RPJ>"Hi",
CC>RPJ>	Can anyone explain me what exactly is "Constraint-Based Routing"
CC>(CBR) ?
CC>RPJ>
CC>RPJ>	Please correct me if I am wrong. I feel that RSVP-TE, CR-LDP, CSPF
CC>(the
CC>RPJ>protocols like RSVP, LDP and OSPF) having extension for
CC>Traffice-Engineering
CC>RPJ>can synomously used for "CBR" since the constraint are specified while
CC>RPJ>setting up the LSP.
CC>
CC>Rajesh,
CC>
CC>There is the PCALC for which the IGP flooding is used at headends when the
CC>path is computed based on the constraints.  RSVP/CR-LDP comes later to
CC>signal
CC>and reserve the needed bandwidth and get labels for the PATH.
CC>
CC>-ajay
CC>
CC>
CC>RPJ>
CC>RPJ>	Also, please give a list of protocols which needs to be extended for
CC>"CBR".
CC>RPJ>TIA,
CC>RPJ>	Rajesh P Jain
CC>RPJ>
CC>
CC>

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

When in despair I remember that all through
history the way of truth and love has always won;
there have been tyrants and murderers, and for a
time they can seem invincible, but in the end they
always fall.

 - Mahatma Gandhi

---

From: ward <[email-masked]>
Date: Thu, 18 Oct 2001 11:2:24 +0800

Rajesh:

-> 	Can anyone explain me what exactly is "Constraint-Based 
-> Routing" (CBR) ?

   You will find more info if you search the web (or list achieves).
   But in a crude way, if you type source and destination address 
   in www.mapquest.com you get different paths 
       - shortest path
       - fastest path
       - avoid highways etc etc :)
   The same fundamentals work out here in routing/switching IP
   datagrams. You will be given certain link/node/path constraints
   in the topology and you need to optimize and get the "best"
   path to route/switch.
 
-> 	Please correct me if I am wrong. I feel that RSVP-TE, 
-> CR-LDP, CSPF (the
-> protocols like RSVP, LDP and OSPF) having extension for 
-> Traffice-Engineering
-> can synomously used for "CBR" since the constraint are 
-> specified while
-> setting up the LSP.
->
-> 	Also, please give a list of protocols which needs to be 
-> extended for "CBR".

   This is the place where I am little bit inconvenient. As an
   evolving beneficial technology, MPLS didn't extend any of the
   existing routing protocols (OSPF and ISIS) to do CSPF. 
   If a border conversion router running OSPF and ISIS which are 
   distributing topologies and helping signaling protocols to 
   find out "Traffic engineered" paths, Can you think of how 
   many (C)SPF algo's the LSR running? In any case, RFCs 2386 and
   2676 will be some help for you.
   
   Routing protocols, OSPF & ISIS are extended (still extending)
   to include traffic engineering information. Signaling protocols, 
   RSVP-TE and CR-LDP, are used to setup constrained paths.
   Apart from this, you should implement your own topology
   data base and CSPF. (no standards are required for this)
  
   I request Kireeti to include an informational appendix on
   CSPF algo, in the forth coming draft-kompella-te-pathcomp-00
   to the benefit of the community (just like appendix B&C in
   RFC 2676 :) - if he doesn't mind!

--Venkata Naidu