Subject: RE: mplsLdpEntityTable

From: "Tiruveedhula, Kishore" <[email-masked]>
Date: Wed, 10 Oct 2001 10:14:35 -0400

Hi Joan,
  
>The entity table represents configuration for potential sessions, so 
>if some interfaces use Downstream on Demand and some are Downstream
>Unsoliticied, then this means a minimum of 2 sessions (so 2
>mplsLdpEntityLdpId 
>indexes).  RFC3036 describes that a single session could not run both
>in DOD and DU simultaneously.

 In case of per platform label space. one entity can have several peers.
 One entity corresponds to many peers with different peer LDP identifier
(mplsLdpPeerLdpId) in case of platform label space. 
That means one entity can have many sessions based upon peer. Some sessions
can use DOD and some sessions 
can use DU, but both sessions corresponds to one entity. In this case one
session uses one distribution only. 
   
>There could be two label spaces where both
>are considered per platform where some interfaces participate in
>supporting
>one label space, and some interfaces participate in supporting another
>label space, which is how one could possibly configure some interfaces
>for DownStream OnDemand 
>and some interfaces for Downstream Unsolicited (but this would take a
>minimum
>of two label ranges and at least two entities (or sessions)).

 LDP MIB is restricting to use different label space if interfaces uses
different distribution modes in case of platform label space. That means, it
is forcing to use multiple platform label space in one LSR.
 But in case of platform label space, label space id is zero as per RFC 3036
in LDP identifier (<LSR Id> : <label space id>). This contradicts with your
answer.

Thanks,
Kishore

>  -Joan

> 
>> Thanks,
>> Kishore
> 
> -----Original Message-----
> From: Joan Cucchiara [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 5:59 PM
> To: Srinivas T M
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: mplsLdpEntityTable
> 
> Srinivas T M wrote:
> >
> > Hi,
> >    Can anybody clarify my below question.
> >
> > How Interface Index relates to entry in the
> > mplsLdpEntityTable in case of per-platform label space
> > , generic label type and in case of LDP Identifier is
> > same for all interfaces ?
> 
> The entity entry/row is the configuration for a potential
> session.  The Interface Index is in the label range tables
> and the mplsLdpEntityLdpId and mplsLdpEntityIndex are used
> to tie the entity entry with a label range entry.
> 
> In the case of the per-platform label space, this is also
> the situation.  I'm not sure if this answers the question
> you are asking though.
> 
> >
> >  Can we use single entry in the entity table for
> > multiple interfaces? If it is like that, then what
> > happens if we change label Distribution Method or
> > LabelRetentionMode  or any field in the entity table,
> > on interface? draft-ietf-mpls-ldp-mib-08.txt is not
> > telling how interface relates to entry in the entity
> > table.
> 
> The front section of the MIB and the description for
> mplsLdpEntityAdminStatus does describe that it
> expects the user to administratively disable the entity
> (and thus take down the session -- meaning the session
> is removed) and then change whatever
> fields and then administratively enable the entity
> to create new session.
> 
>   -Joan
> 
> >
> >   MplsLdpEntityEntry ::= SEQUENCE {
> >      mplsLdpEntityLdpId        MplsLdpIdentifier,
> >      mplsLdpEntityIndex        Unsigned32,
> >      mplsLdpEntityProtocolVersion  Integer32,
> >      mplsLdpEntityAdminStatus      INTEGER,
> >      mplsLdpEntityOperStatus       INTEGER,
> >      mplsLdpEntityTcpDscPort       Unsigned32,
> >      mplsLdpEntityUdpDscPort       Unsigned32,
> >      mplsLdpEntityMaxPduLength     Unsigned32,
> >      mplsLdpEntityKeepAliveHoldTimer  Integer32,
> >      mplsLdpEntityHelloHoldTimer      Integer32,
> >      mplsLdpEntityInitSesThreshold    Integer32,
> >      mplsLdpEntityLabelDistMethod     INTEGER,
> >      mplsLdpEntityLabelRetentionMode  INTEGER,
> >      mplsLdpEntityPVLMisTrapEnable    INTEGER,
> >      mplsLdpEntityPVL                 Integer32,
> >      mplsLdpEntityHopCountLimit       Integer32,
> >      mplsLdpEntityTargPeer            TruthValue,
> >      mplsLdpEntityTargPeerAddrType
> > adressFamilyNumbers,
> >      mplsLdpEntityTargPeerAddr      MplsLdpGenAddr,
> >      mplsLdpEntityOptionalParameters
> > MplsLdpLabelTypes,
> >      mplsLdpEntityDiscontinuityTime   TimeStamp,
> >      mplsLdpEntityStorType            StorageType,
> >      mplsLdpEntityRowStatus            RowStatus
> >      }
> >
> > Thanks in Advance,
> > Srini.
> >
> > __________________________________________________
> > Do You Yahoo!?
> > NEW from Yahoo! GeoCities - quick and easy web site hosting, just
> $8.95/month.
> > http://geocities.yahoo.com/ps/info1

---

From: Srinivas T M <[email-masked]>
Date: Wed, 10 Oct 2001 07:30:16 -0700 (PDT)

Hi,
    Is LDP supports mutliple platform label space? If
yes, how?

Srini.

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Joan Cucchiara <[email-masked]>
Date: Wed, 10 Oct 2001 20:21:43 -0400

> in LDP identifier (<LSR Id> : <label space id>). This contradicts with your

I don't believe this contradicts my response.  You need to have 2
distinct
mplsEntityLdpIds if the label space part is zero, then this means that 
the LSR IDs need to be different.  Admittedly, this is unlikely (or at
least in my experience this is unlikely since I have typically seen the
LSR ID portion == the RouterId), but I suppose if someone wanted 
to do this so that he/she could support both DOD and DU sessions where 
each session is using per platform label space on the same router that
configuration would be an alternative.
 
  -Joan