Subject: RE: ppvpn some VLAN clarifications

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 23 Oct 2001 11:07:29 -0700

See below for comments.

-----Original Message-----
From: Michael Wu [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 9:01 AM
To: Amir Shatil; [email-masked]; [email-masked]
Subject: RE: ppvpn some VLAN clarifications

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Amir Shatil
Sent: Tuesday, October 23, 2001 8:34 AM
To: [email-masked]; [email-masked]
Subject: ppvpn some VLAN clarifications

Hi
few Questions about draft-martini-l2circuit-encap-mpls-03.txt: 
1. In section 4.3 it is stated (about the VLAN tag) “…and MAY be overwritten
by the egress router.”
What are the cases in which this might happen? 
>> So the SP doesn't need to have same vlan id at both ends. But this will
prevent STP working
   correctly unless the PE can modify the STP message accordingly. 
 
[Anoop Ghanwani]  STP doesn't use the VLAN ID.  In 802.1Q, all VLANs use the
same spanning
tree.  Besides I don't think the draft is trying to support bridging.  It
just provides point-to-point Ethernet link.
In this case, does the VLAN tag lose its original meaning and functions only
as a VC ID (more like a DLCI in F/R)? 
2. Is the reason for carrying the ethernet VLAN L2 encapsulation (section
4.3 "For an Ethernet 802.1q VLAN the entire Ethernet frame without the

   preamble or FCS is transported as a single packet") is only to preserve
the original SA & DA ? 
>> 802.1p will be preserved as well.
Michael 
Thanks
Amir.

---

From: "Michael Wu" <[email-masked]>
Date: Tue, 23 Oct 2001 11:42:45 -0700

-----Original Message-----
  From: Anoop Ghanwani [mailto:[email-masked]]
  Sent: Tuesday, October 23, 2001 11:07 AM
  To: [email-masked]'; Amir Shatil; [email-masked]; [email-masked]
  Subject: RE: ppvpn some VLAN clarifications

  See below for comments.
    -----Original Message-----
    From: Michael Wu [mailto:[email-masked]]
    Sent: Tuesday, October 23, 2001 9:01 AM
    To: Amir Shatil; [email-masked]; [email-masked]
    Subject: RE: ppvpn some VLAN clarifications

      -----Original Message-----

Hi
>> So the SP doesn't need to have same vlan id at both ends. But this will
prevent STP working
   correctly unless the PE can modify the STP message accordingly.  [Anoop
Ghanwani]  STP doesn't use the VLAN ID.  In 802.1Q, all VLANs use the same
spanning
tree.  Besides I don't think the draft is trying to support bridging.  It
just provides point-to-point Ethernet link.
Ooops. Anoop you are right. The STP is not a good example. I should have
said any
application the carried vlan id similar to NAT...
The draft doesn't disallow the PE to support bridging locally. The WAN/MPLS
side
is p2p between two PEs for a given vlan/internet. The PE can setup multiple
p2p with
more than one PE and bridge them locally. The draft focuses on the
transport/encapsulation.
It is up to the application to use the p2p connection.
Michael
In this  case, does the VLAN tag lose its original meaning and functions
only as a VC ID (more like a DLCI in F/R)?
2. Is the reason for carrying the ethernet VLAN L2 encapsulation (section
4.3 "For an Ethernet 802.1q VLAN the entire Ethernet frame without the
   preamble or FCS is transported as a single packet") is only to preserve
the original SA & DA ?
Michael
Thanks
Amir.

---

From: [email-masked] (Eran Man)
Date: Wed, 24 Oct 2001 09:18:27 +0200

> 1. In section 4.3 it is stated (about the VLAN tag) “…and MAY be overwritten by the egress router.”
> 
>>> So the SP doesn't need to have same vlan id at both ends. But this will prevent STP working
> 
> [Anoop Ghanwani]  STP doesn't use the VLAN ID.  In 802.1Q, all VLANs use the same spanning
> 
> tree.  Besides I don't think the draft is trying to support bridging.  It just provides point-to-point Ethernet link. 
> 
> Ooops. Anoop you are right. The STP is not a good example. I should have said any
> 

Actually 802.1s extends 802.1d to support spanning tree per VLAN, and 
many vendors do implement this, so this would of course be broken if 
you change the 802.1q tag on the tunnel egress.
-- 
Eran Mann			[email-masked]
Software Engineer		Tel: +972-4-9936200
Optical Access			Fax: +972-4-9890564
www.opticalaccess.com