Subject: Interworking of CR-LDP with RSVP-TE

From: Adithya Bhat <[email-masked]>
Date: Wed, 10 Oct 2001 14:13:43 +0530

Hi *,

Is there any work in progress on the
draft-wright-mpls-er-interwork-00.txt ?
This version of the draft seemed to have expired on sept 2000.
Is there any new version of this draft ? or is there any other
draft that addresses the issue of Interworking of CR-LDP with RSVP-TE ?

Thanks and Regards,

-Adithya

---

From: Christopher Lewis <[email-masked]>
Date: Wed, 10 Oct 2001 11:02:07 -0500

Syed,

Basically they are two alternatives that approach the problem from 
different perspectives;

Alternative 1
Take a well established, well tested, existing protocol for signaling QoS 
over IP networks (viz., RSVP), and extend it to support both label 
distribution and path setup based on explicit routes.   Use the existing 
and developing IP QoS model, so as to leverage past and ongoing IETF work 
on QoS and on signaling of QoS.

Alternative 2
Extend the newly designed LDP protocol to add explicit route setup and QoS 
signaling, thereby creating CR-LDP.

Both alternatives proceeded by taking a protocol and extending it into 
areas beyond its original intended application.  Both alternatives added 
explicit route support to protocols, which originally did not have it.  The 
real difference is whether to take a QoS signaling protocol and add label 
distribution, or whether to take a label distribution protocol and add QoS 
signaling.

It seems that more vendors vote for alternative 1.

I'll send you a separate e-mail with a PDF from Data Conenctions Ltd. in 
the UK comparing the two protocols.

Chris

At 08:58 AM 10/10/2001, syed ali wrote:
>Guys,
>      Is there a doc that describes the pros and cons
>of each.
>
>thanks
>Syed
>
>=====
>TIME IS A LUXURY YOU CAN'T AFFORD!
>
>__________________________________________________
>Do You Yahoo!?
>Make a great connection at Yahoo! Personals.
>http://personals.yahoo.com
>
>-------
>The MPLS-OPS Mailing List
>Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
>Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Christopher Lewis <[email-masked]>
Date: Wed, 10 Oct 2001 11:02:07 -0500

Syed,

Alternative 1

Alternative 2

Chris