Subject: RE: Constraint Based Routing

From: "Naidu, Venkata" <[email-masked]>
Date: Tue, 16 Oct 2001 11:34:12 -0400

Rajesh:

-> 	Can anyone explain me what exactly is "Constraint-Based 
-> Routing" (CBR) ?

   You will find more info if you search the web (or list achieves).
   But in a crude way, if you type source and destination address 
   in www.mapquest.com you get different paths 
       - shortest path
       - fastest path
       - avoid highways etc etc :)
   The same fundamentals work out here in routing/switching IP
   datagrams. You will be given certain link/node/path constraints
   in the topology and you need to optimize and get the "best"
   path to route/switch.
 
-> 	Please correct me if I am wrong. I feel that RSVP-TE, 
-> CR-LDP, CSPF (the
-> protocols like RSVP, LDP and OSPF) having extension for 
-> Traffice-Engineering
-> can synomously used for "CBR" since the constraint are 
-> specified while
-> setting up the LSP.
->
-> 	Also, please give a list of protocols which needs to be 
-> extended for "CBR".

   This is the place where I am little bit inconvenient. As an
   evolving beneficial technology, MPLS didn't extend any of the
   existing routing protocols (OSPF and ISIS) to do CSPF. 
   If a border conversion router running OSPF and ISIS which are 
   distributing topologies and helping signaling protocols to 
   find out "Traffic engineered" paths, Can you think of how 
   many (C)SPF algo's the LSR running? In any case, RFCs 2386 and
   2676 will be some help for you.
   
   Routing protocols, OSPF & ISIS are extended (still extending)
   to include traffic engineering information. Signaling protocols, 
   RSVP-TE and CR-LDP, are used to setup constrained paths.
   Apart from this, you should implement your own topology
   data base and CSPF. (no standards are required for this)
  
   I request Kireeti to include an informational appendix on
   CSPF algo, in the forth coming draft-kompella-te-pathcomp-00
   to the benefit of the community (just like appendix B&C in
   RFC 2676 :) - if he doesn't mind!

--Venkata Naidu

---

From: "abhay" <[email-masked]>
Date: Wed, 17 Oct 2001 14:24:46 +0530

Hi Naidu,Rajesh and others concerned,
              
            1) The reliability of CSPF of always giving true  Constraint Based Path is less as situations in the network may change
                we cannot always guarantee that a CSPF actual path setup is successful.

                For example a CPSF path for  setup through colored links assures the signaling protocol,that such links exist in the                     domain for which there can be path setup.Hence it can also be used as a guessing tool.
            
            2) We still need to include the constraint parameters in the signaling protocols (especially bandwidth reservation).

            3)CSPF can give out information such as whether a setup of a path it has just output,will pre-empt other paths with 
               lower priority.This being the case in a network full of important paths,this CSPF path may not be setup so as to 
               avoid pre-emption.
          
            Someone agrees CSPF as a guess tool for a routers ?

            Thanks,
            Abhay