Subject: RE: MPLS Support of Diffserv

From: "Abdul Malick" <[email-masked]>
Date: Mon, 15 Oct 2001 10:48:15 +0530

Hello Mrugendra,

When you talk about edge diffserv LSR i assume you are talking about the
ingress LER.
In this case it is this LER that is going to do the MF classification to
find the PHB that a particular flow would be subjected to. There need not be
a mapping from the EXP to PHB in this LER. Only in the subsequent LSRs and
Egress LER would the mapping be required.

When you talk about FEC i assume that you talk about the (Destination
address/prefix) only.But the MF classification is much more than that. So
flows going to the same destination could be classified as different
DiffServ Classes and could be mapped to different LSPs (L-LSP) or the same
LSP(E-LSP) with different EXP values representing different PHBs.

If you did not mean destination address/prefix only as FEC(but also Src
address, port, so on and so forth), then it is natural to say that all the
flows matching an FEC definition should get the same treatment. Then you
cannot differentiate a flow and a FEC IMHO.

Please correct me if i am wrong.

Warm Regards,
Malick

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Mrugendra
Singhai
Sent: Monday, 15 October 2001 9:28 AM
To: [email-masked]
Subject: Re: MPLS Support of Diffserv

But you see this brings up an incompatibility in
integrating diffserv with MPLS.

An edge diffserv enabled LSR will map exp to phb based
solely on FEC. So all flows inside a FEC will get same
treatment inside a MPLS network i.e diffserv will not
be able to exist inside MPLS network and can only
exist outside MPLS network.

Pls correct me if i am wrong

Regards

Mrugendra
Research Assistant
NCSU
--- Scott Bradner <[email-masked]> wrote:
> > I think what you are refering is DSCP(Can only be
> used
> > in behavior aggregate classifier), defined in RFC
> 2597
> > which i agree is surely 6 bits.
>
>
> which is all that difserv is
>
> and all that is seen in the network - and all that
> would be
> sen by a mpls router
>
> Scott

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Mrugendra Singhai <[email-masked]>
Date: Sun, 14 Oct 2001 23:20:53 -0700 (PDT)

Hi,

What I meant from edge diffserv LSR was the LSR which
will be generating Label Mapping Message in response
to a Label Request Message(your scenario talks about
it) i.e. i am refering to egress LSR for a FEC. That
egress LSR is suppose to generate a PHB mappings for
EXP received in Diffserv TLV based on FEC TLV that it
receives. And here the problem comes which i described
in my earlier mails.

Regards

Mrugendra