Subject: the nexthop of RSVP_TE.

From: Marshall Ma Shaowen <[email-masked]>
Date: Tue, 23 Oct 2001 02:06:21 +0530

hi, all
I have a question about the nexthop of RSVP_TE.
as the draft said that we should follow the ERO to forward the packet.
but the rfc2205 says that the destination address is the egress ip address.
so there is some problem about this

RTA     
  |
-+--------------+----------------+----------
                       |                      |
                       |                      |
                   RTB               RTC
                       |                      |
                       |                      |
-----------------+---------------+--------------+--------
                                                                   |
                                                                RTD
if the CSPF caclulate a path next hop by RTB and then RTD.
but if the RTA send out the packet with the destiantion of RTD, 
both the RTB and RTC will forward this packet. so How can ensure the LSP
establish through RTA-RTB-RTD ?

Best Regards.
marshall

---

From: Ajay Simha <[email-masked]>
Date: Mon, 22 Oct 2001 23:21:08 -0400 (Eastern Daylight Time)

On Tue, 23 Oct 2001, Marshall Ma Shaowen wrote:

MMS:hi, all
MMS:I have a question about the nexthop of RSVP_TE.
MMS:as the draft said that we should follow the ERO to forward the packet.
MMS:but the rfc2205 says that the destination address is the egress ip address.
MMS:so there is some problem about this

First of all rfc2205 does not talk about LSPs.

MMS:
MMS:RTA
MMS:  |
MMS:-+--------------+----------------+----------
MMS:                       |                      |
MMS:                       |                      |
MMS:                   RTB               RTC
MMS:                       |                      |
MMS:                       |                      |
MMS:-----------------+---------------+--------------+--------
MMS:                                                                   |
MMS:                                                                RTD
MMS:if the CSPF caclulate a path next hop by RTB and then RTD.
MMS:but if the RTA send out the packet with the destiantion of RTD,
MMS:both the RTB and RTC will forward this packet. so How can ensure the LSP
MMS:establish through RTA-RTB-RTD ?

Ok.  Assuming RTA is the headend of the tunnel, there are a few ways to ensure
that the LSP follows the path RTA-RTB-RTD:

1. Explicit path where you simply specify the next-hops but it is still run
against the TED to ensure the contraints are met

2. You could use something like the affinity bits to control this (although
this is not the cleanest way of acheiving the goal).

3. you could set your igp cost and bandwidth to look most attrictive along
this path.

-ajay
MMS:
MMS:Best Regards.
MMS:marshall
MMS:

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi