Subject: Small question on Resource Affinities in draft-ietf-mpls-te-mib-0 7

From: Edward Harrison <[email-masked]>
Date: Wed, 31 Oct 2001 18:56:47 -0000

Hi,

I've just noticed the following object in TE-MIB:

mplsTunnelExcludeAllAffinity OBJECT-TYPE
   SYNTAX        MplsTunnelAffinity
   MAX-ACCESS    read-create
   STATUS        current
   DESCRIPTION
        "A link satisfies the exclude-all constraint if and
          only if the link contains none of the adminstrative
          groups specifie in the constraint."
        REFERENCE "RSVP-TE: Extensions to RSVP for LSP
          Tunnels, draft-ietf-mpls-rsvp-lsp-tunnel-07.txt"
   ::= { mplsTunnelEntry 29 }

>From the description and the name of the corresponding field in the RSVP
SESSION_ATTRIBUTE (LSP_TUNNEL_RA) object, shouldn't this really be called
mplsTunnelExcludeAnyAffinity?  

Ed

PS There also seem to be a few typos in the description - "adminstrative"
and "specifie".

-----------------
Edward Harrison  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd.
http://www.dataconnection.com/
Tel: +44 20 8366 1177  Fax: +44 20 8363 1468

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 31 Oct 2001 14:58:00 -0500

>mplsTunnelExcludeAnyAffinity?

         Yup, this looks like a typo. The MIB currently contains
the following affinity specifications:

mplsTunnelIncludeAnyAffinity
mplsTunnelIncludeAllAffinity
mplsTunnelExcludeAllAffinity   <===*

         But should have:

mplsTunnelIncludeAnyAffinity
mpslTunnelIncludeAllAffinity
mplsTunnelExcludeAnyAffinity   <===*

         One of us will correct this in the current version, but
please bring it up after the IESG reviewed version is issued if
it is missed.

>PS There also seem to be a few typos in the description - "adminstrative"

         Thanks for catching these.

         --Tom

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.