Subject: Re: Fast Reroute Interoperability

From: "Hemant P. Kelkar" <[email-masked]>
Date: Fri, 5 Oct 2001 11:31:14 -0400 (EDT)

Hi !
Can somebody tell the differences between the fast reroute mechanisms
provided by cisco
and juniper ?

thanks,
Hemant

Date: Fri, 05 Oct 2001 10:28:14 -0300
From: "Gustavo Bellotto (CEA)" <[email-masked]>
To: [email-masked], [email-masked]
Subject: Fast Reroute Interoperability
Resent-Date: Fri, 5 Oct 2001 09:33:21 -0400
Resent-From: [email-masked]

Hello,

In spite of the different way that Juniper and Cisco have taken
to provide fast reroute protection, making them not interoperable,
I'm wondering if there is any way to build a scheme were both can
coexist in a MPLS fault protected network. A valid solution could
consider nested tunnels and statically configured LSPs.
In our particular case Cisco GSR builds up the core and Juniper the
edge of the backbone.

Regards,
Gustavo

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: "Gustavo Bellotto (CEA)" <[email-masked]>
Date: Fri, 05 Oct 2001 13:13:35 -0300

Juniper implemented draft-gan-fast-reroute-00.txt
while Cisco does something like draft-swallow-rsvp-bypass-label-01.txt

Basically, Juniper use new RSVP objects FAST_ROUTE and DETOUR to signal
and build up detours to skip next hop in each LSR on the LSP.

Cisco uses "standard" (draft-ietf-mpls-rsvp-lsp-tunnel-08.txt) RSVP
to signal that, by setting the "Local Protection desired" flag in the
SESSION_ATTRIBUTE object. Then each LSR on the LSP will use a manually
pre configured "backup tunnel" (nested label stack) to reach next hop
in the case of link failure.

Please correct me if I'm wrong.

Regards,
Gustavo

---

From: Henry Cheok <[email-masked]>
Date: Fri, 05 Oct 2001 13:45:32 -0400

The effort in resolving the interop issues has been in place.
For the detail, please see the draft
http URL:draft-atlas-rsvp-local-protect-interop-01.txt

Regards,
Henry

---

From: Vishnu Pavan Kumar Beeram <[email-masked]>
Date: Fri, 5 Oct 2001 11:02:35 -0700 (PDT)

check this out
http://www.ietf.org/internet-drafts/draft-atlas-rsvp-local-protect-interop-01.txt

--- "Gustavo Bellotto (CEA)"
<[email-masked]> wrote:
> Cisco uses "standard"
> (draft-ietf-mpls-rsvp-lsp-tunnel-08.txt) RSVP
> > Archive:
> http://www.mplsrc.com/mpls-ops_archive.shtml
> > 
> > 
> > -------
> > Archive:
> http://www.mplsrc.com/mpls-ops_archive.shtml
> > 
> 
> 
> -------
> Archive:
http://www.mplsrc.com/mpls-ops_archive.shtml

__________________________________________________
Do You Yahoo!?
NEW from Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1