Subject: RE: Doubt in draft-ietf-mpls-te-mib-07.txt

From: "Ashwin C. Prabhu" <[email-masked]>
Date: Wed, 24 Oct 2001 09:59:41 +0530

Hello 

     Thanks for the reply. 
     If i add this table entry then what about the OID for this entry ? 
     Can i assign that OID myself ? If that is the case then how does the 
     NM know about it ? or is it that i have to change the NM according to 
     my need. If i have to change it, then won't it be something like
private 
     NM and a private MIB insted of saying it as standard ? 

Ashwin

-----Original Message-----
From: Cheenu Srinivasan [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 11:51 PM
To: 'Ashwin C. Prabhu'
Cc: [email-masked]'
Subject: RE: Doubt in draft-ietf-mpls-te-mib-07.txt 

> shouldn't there be mplsTunnelInstanceNext ?

This is tricky to add since we cannot have just a single index-next
object but a mechanism to return the next instance index for a given
mplsTunnelIndex. This is like a (read-only) table indexed by 
mplsTunnelIndex.

For example:

mplsTunnelInstanceNextTable ... SEQUENCE OF MplsTunnelInstanceNextEntry

mplsTunnelInstanceNextEntry ... MplsTunnelInstanceEntry
...
INDEX { mplsTunnelIndex }

MplsTunnelInstanceNextEntry ::= SEQUENCE {
  mplsTunnelInstanceNextIndex INTEGER
}

---

From: "Venkata Prasad Piriya" <[email-masked]>
Date: Thu, 25 Oct 2001 10:29:13 +0530

RE: Doubt in draft-ietf-mpls-te-mib-07.txtHello All

In mplsTunnelEntry it is defined that the columnar object mplsTunnelResourcePointer as RowPointer. 
There is some confusion between definition of RowPointer and Example mentioned in the draft-ietf-mpls-te-mib-07.txt 
section  8.
In draft it was assign mplsTunnelResorceIndex.5.

Following same as draft:
mplsTunnelResourcePointer = mplsTunnelResourceIndex.5,

As per SNMPV2_TC the row pointer as defined as follows:

 RowPointer ::= TEXTUAL-CONVENTION
 STATUS       current
 DESCRIPTION
 "Represents a pointer to a conceptual row.  The value is the
 name of the instance of the first accessible columnar object
 in the conceptual row.

 For example, ifIndex.3 would point to the 3rd row in the
 ifTable (note that if ifIndex were not-accessible, then
 ifDescr.3 would be used instead)."

As per RowPointer definition we can't assign a OID which is having permission not_accessible to RowPointer variable so it should be
mplsTunnelResourcePointer  = mplsResourceMaxRate.<Index> Here Index is mplsTunnelResourceIndex.

Please correct me if I am wrong.

Regards
Venkata Prasad P.

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 25 Oct 2001 08:47:37 -0400

Yes, the mplsTunnelResourcePointer needs to contain the OID of
the first accessible columnar object. The example has a typo. It should be
mplsTunnelResourceEntry.mplsTunnelResourceMaxRate.5.

         --Tom

>There is some confusion between definition of RowPointer and Example 
>mentioned in the draft-ietf-mpls-te-mib-07.txt
>section 8.
>As per RowPointer definition we can't assign a OID which is having 
>permission not_accessible to RowPointer variable so it should be

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.