Subject: some VLAN clarifications

From: "Amir Shatil" <[email-masked]>
Date: Tue, 23 Oct 2001 17:33:46 +0200

Hi
few Questions about draft-martini-l2circuit-encap-mpls-03.txt: 
1. In section 4.3 it is stated (about the VLAN tag) “…and MAY be
overwritten by the egress router.”
What are the cases in which this might happen?
In this case, does the VLAN tag lose its original meaning and functions
only as a VC ID (more like a DLCI in F/R)? 
2. Is the reason for carrying the ethernet VLAN L2 encapsulation
(section 4.3 "For an Ethernet 802.1q VLAN the entire Ethernet frame
without the

   preamble or FCS is transported as a single packet") is only to
preserve the original SA & DA ?
Thanks
Amir.

---

From: "Michael Wu" <[email-masked]>
Date: Tue, 23 Oct 2001 09:00:58 -0700

-----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Amir Shatil
  Sent: Tuesday, October 23, 2001 8:34 AM
  To: [email-masked]; [email-masked]
  Subject: ppvpn some VLAN clarifications

Hi
few Questions about draft-martini-l2circuit-encap-mpls-03.txt:
1. In section 4.3 it is stated (about the VLAN tag) “…and MAY be overwritten
by the egress router.”
What are the cases in which this might happen?
>> So the SP doesn't need to have same vlan id at both ends. But this will
prevent STP working
   correctly unless the PE can modify the STP message accordingly.
In this case, does the VLAN tag lose its original meaning and functions only
as a VC ID (more like a DLCI in F/R)?
2. Is the reason for carrying the ethernet VLAN L2 encapsulation (section
4.3 "For an Ethernet 802.1q VLAN the entire Ethernet frame without the
   preamble or FCS is transported as a single packet") is only to preserve
the original SA & DA ?
>> 802.1p will be preserved as well.
Michael
Thanks
Amir.

---

From: "Rajesh Saluja" <[email-masked]>
Date: Tue, 23 Oct 2001 13:42:42 -0400

Amir Shatil wrote:

> 1. In section 4.3 it is stated (about the VLAN tag) ??and MAY be overwritten by the egress router.?
>
> In this case, does the VLAN tag lose its original meaning and functions only as a VC ID (more like a DLCI in F/R)?
>
This will happen when you want to connect two different VLANs through a
VPN.

> 2. Is the reason for carrying the ethernet VLAN L2 encapsulation (section 4.3 "For an Ethernet 802.1q VLAN the entire Ethernet frame without the
>    preamble or FCS is transported as a single packet") is only to preserve the original SA & DA ?
>
You need to recreate the same user frame at the egress and hence you
have to preserve original SA, DA, VLAN Id .

Thanks,
Rajesh

--

-------------------------------------------------------------
Rajesh Saluja
Nortel Networks Inc 600 Technology Park Billerica, MA  01821
Ph: (978) 288-7791      Fax: (978) 670-8760
--------------------------------------------------------------