Subject: RE: New revision of the MPLS ttl draft

From: Shahram Davari <[email-masked]>
Date: Wed, 10 Oct 2001 11:25:25 -0700

Hi Puneet,

But your draft says that any value other than 1 can be subtracted from TTL. So how does a customer router that sits downstream of the egress LSR know how much has been subtracted from the TTL?

Yours,
-Shahram

> -----Original Message-----
> From: Puneet Agarwal [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 11:09 PM
> To: Shahram Davari; [email-masked]
> Subject: RE: New revision of the MPLS ttl draft
> 
> 
> Hi Shahram,
> 
> Thanks for your comments.
> 
> Regarding not storing the TTL decrementing policy of the 
> customer in the
> provider's egress LSR(s), I do not think that the proposed 
> ttl processing
> needs/requires the customers ttl decrement policy to be known 
> to the Egress
> LSRs. From a customers perspective, they send a packet with 
> ttl n and they
> get back a packet with ttl n-2. If the customer wants, they 
> can decrement
> the ttl by any amount they want without the providers egress 
> LSR knowing
> anything about it. TTL processing is different (and easier to 
> determine)
> than PHB determination as the TTL field has the same 
> semantics in either the
> providers network or the customers network - which is not 
> true for the bits
> used for PHB determination.
> 
> Hence I do not see a reason to change the TTL decrementing 
> policy for Pipe
> model LSPs. (There are other valid reasons for our proposal 
> but they are not
> relevant to the points you've raised). 
> 
> Hope this helps.
> 
> Thanks.
> 
> -Puneet  
> 
> >-----Original Message-----
> >From: Shahram Davari [mailto:[email-masked]]
> >Sent: Tuesday, October 09, 2001 1:34 PM
> >To: 'Puneet Agarwal'; [email-masked]
> >Subject: RE: New revision of the MPLS ttl draft
> >
> >
> >Hi Puneet,
> >
> >The reason that Pipe model was introduced was that we didn't 
> >want to store the customer policies in the egress LSR. This 
> >meant from the Diffserv perspective, that we didn't want to 
> >store EXP<=>PHB mapping for each individual customer. The Pipe 
> >model essentially terminates the tunnel on the ingress line 
> >card of the Router downstream of the Egress LSR, rather than 
> >on the egress line-card of the egress LSR.
> >
> >As mentioned in your draft, each domain may have its own 
> >policy (value to be decremented) for decrementing the TTL. 
> >Therefore it seems to me that for the same reason, it is 
> >better not to store TTL decrementing policy and apply it to 
> >the packet in the egress LSR for the Pipe model. 
> >
> >Therefore I suggest that the Pipe model TTL processing be the 
> >same as Short-pipe model with PHP.
> >
> >Yours,
> >-Shahram
> >
> >> -----Original Message-----
> >> From: Puneet Agarwal [mailto:[email-masked]]
> >> Sent: Monday, October 08, 2001 5:18 PM
> >> To: [email-masked]
> >> Subject: New revision of the MPLS ttl draft
> >> 
> >> 
> >> A new revision of the "TTL Processing in MPLS Networks" has 
> >> been submitted.
> >> This updates the -00 version of the draft.
> >> 
> >> Any comments/suggestions would be much appreciated.
> >> 
> >> -Puneet and Bora
> >> 
> >> 
> >> 
> >
>

---

From: Eric Gray <[email-masked]>
Date: Wed, 10 Oct 2001 15:09:47 -0400

Shahram,

    Can you help me to understand this question?  Why would the customer
router dwnstream of the egress LSR want (or need) to know how much TTL
has been decremented by the egress LSR?

--
Eric Gray (mailto:[email-masked])
http://www.mindspring.com/~ewgray