Subject: CE to PE OSPF within MPLS/BGP VPN

From: "Jing Zeng" <[email-masked]>
Date: Mon, 29 Oct 2001 11:52:28 -0800

I have a question about CE to PE ospf within MPLS/BGP VPN:
Suppose the routers connected as following:
CE1--PE1--PE2--CE2.
The link between CE1 and PE1 using OSPF, and belong to area 0. The link
between PE2 and CE2 using ospf and belong to area 1.
(there is a interface inside CE2 belong to ospf area 0)
How to transport the routes between PE1 and PE2? Is any RFC or Draft to
address this issue?

Jing

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: Aamer Akhter <[email-masked]>
Date: Tue, 30 Oct 2001 22:58:56 -0500

Jing,

I'm assuming you're talking about ospf data being caried across bgp as in:

http://search.ietf.org/internet-drafts/draft-rosen-vpns-ospf-bgp-mpls-02.txt

The PE's by defenition are in Area 0. Area 0 needs to be contigious. You'll need to have a virtual link between PE2 
and CE2

hope this helps

-- 
Aamer Akhter / [email-masked]
NSITE - cisco Systems