Subject: RE: Use of L3PID

From: "Feng, Mark" <[email-masked]>
Date: Wed, 10 Oct 2001 17:00:57 -0700

I don't think the PHP needs to do that. The PHP has, in the "lookup table",
the incoming label, and the next hop. What is missing is the outgoing label.
It doesn't need the L3PID to forward the data packets.
 
- Mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 10, 2001 2:48 PM
To: Feng, Mark
Cc: 'Apratim Mukherjee'; [email-masked]
Subject: RE: Use of L3PID

Mark, 

I agree with you. 1 minor addition: If PHP is used, also the penultimate
node should check. 

Best regards, 

        Francis. 

----------------------------- 

To: 	"'Apratim Mukherjee'" <[email-masked]>, [email-masked] 

cc: 	(bcc: Francis ARTS/BE/ALCATEL) 

Subject: 	RE: Use of L3PID

IMO, only the egress node should check. The transit nodes are merely
forwarding the data packets. Whether they support the L3PID protocol does
not seem to be relevant.

- Mark

> -----Original Message-----
> From: Apratim Mukherjee [mailto:[email-masked]]
> Sent: Tuesday, October 09, 2001 11:31 PM
> To: [email-masked]
> Subject: Use of L3PID
>
>
> Hi,
>
> The Label Request Object carries the L3PID expected to be
> supported at the
> 'reciever' .
> draft-ietf-mpls-rsvp-lsp-tunnel-08.txt:
> "If the receiver cannot support the protocol L3PID, it SHOULD
> send a PathErr
> with the error code "Routing problem" and the error value"Unsupported
> L3PID."  This causes the RSVP session to fail."
> But it is not clear to me as to where the check for this
> support is to be
> carried out . Existing documents ( especially the Juniper
> implementation
> white paper ) seem to suggest that this check should be
> carried out at every
> LSR .
> But , lets look at a situation :
> Ingress-->LSR1-->LSR2--->Egress
> IPv6        IPv4       IPv4      IPv6
>
> So , in this case the LSP will be aborted at  LSR1 itself.
> However , if the
> check were to be made only at the egress , the Lsp would have
> been set up
> and data packets also would have gone through , since they do
> not need any
> IPv6 support at either LSR 1 or LSR 2, they need it only at
> the Ingress and
> Egress .
>
> Please tell me if I am missing out on something here,
> Thanks,
> Apratim
>
>

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 10 Oct 2001 17:25:45 -0700 (PDT)

> It doesn't need the L3PID to forward the data packets.

With PHP, there is no outgoing label.  If the label stack is empty after
popping, what L2 encapsulation do you put on the data packet?

> I agree with you. 1 minor addition: If PHP is used, also the penultimate

Slight change: if PHP is used AND the label stack is empty after the pop,
the penultimate LSR should also check.

> forwarding the data packets. Whether they support the L3PID protocol does

Agreed, with Francis's proviso.

Kireeti.