Subject: Re: RSVPTE questions

From: "Hong Liao" <[email-masked]>
Date: Mon, 1 Oct 2001 18:07:07 -0400

Yes,  but the way to generate this error whatever they will have error msg
generated or detected and log locally is the same, right?

Julia

                    David Charlap                                                                                 
                    <David.Charlap@ma        To:     [email-masked]                                                  
                    rconi.com>               cc:     (bcc: Hong Liao/Telcordia)                                   
                                             Subject:     Re: RSVPTE questions                                    
                    10/01/01 04:35 PM                                                                             

Hong Liao wrote:
>
> There is error conditon under error code 23:   Unknown object
> Class-Num(spec 2205 page 96)
> and there is error code for Unknown object Class #13, what is the
> difference between these two?

Please re-read the page more carefully.

The bullet on page 97:

     o  Unknown object Class-Num.

is _NOT_ on a list of conditions that generate an RSVP System error.  It
is a list of conditions that an RSVP implementation may choose to detect
and log locally.  This has nothing to do with whether or not an error is
generated.

-- David

---

From: David Charlap <[email-masked]>
Date: Mon, 01 Oct 2001 18:32:07 -0400

Hong Liao wrote:
> 
> Yes,  but the way to generate this error whatever they will have
> error msg generated or detected and log locally is the same, right?

An unknown class in a Path or Resv message should generate a PathErr or
ResvErr message.  If it appears in another kind of message (like a
PathTear or ResvConf), then no error should be generated, because there
is no appropriate type of error message to send in the first place.

In all cases, however, whether or not an error was generated, the switch
has the option of logging the error condition.

It's not an either-or situation.  pages 96-97 list a lot of conditions
that routers will typically log.  This is _NOT_ an exhaustive list, nor
is it a mandatory list.  Your can choose to log more events than these,
or you can choose to log fewer, or none at all.  You can log events that
result in the generation of error messages as well as those that don't.

-- David