Subject: When to use TE-MIB (tewg) and when to use MPLS-TE-MIB (mplswg)

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Mon, 15 Oct 2001 13:20:54 -0400

Hi! I have a basic question on the difference between the MPLS-TE-MIB 
(MPLS WG) and TE-MIB (TE WG).

Q1. When should one use the TE-MIB, instead of the MPLS-TE-MIB ?
      (or the MPLS-TE-MIB, instead of TE-MIB)

Q2. Specifically on a LSR(/LER) that supports MPLS-TE, is there any
      case, where the TE-MIB, compliments the features exported by the
      MPLS-TE-MIB?

Thanks,
sanjay

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 15 Oct 2001 10:40:51 -0700 (PDT)

> (MPLS WG) and TE-MIB (TE WG).

Here's my simplistic answer:

If you want to configure MPLS tunnels via a MIB, go for the MPLS-TE-MIB.
If you want detailed information (e.g., labels in and out), ditto.

If you want a simple, read-only MIB to figure out what your tunnels
are doing, use the TE-MIB.

The best thing is to read the MIBs and make your own decision.

Kireeti.

---

From: "abhay" <[email-masked]>
Date: Tue, 16 Oct 2001 10:33:08 +0530

Hi All
I have great pleasure in answering this one,

1) The differences are not many first of all

Some the differences are in the perspective of Traffic Engineering features implemented in different ways
but offering some degree of service 

2) The way tunnel id is assigned and maintained in Tom's MIB has more flexibility in terms of maintaining tunnels
however this MIB does not offer concrete mechanism for implementing total primary path protection,however if
one carefully observes that this MIB offers a good mechanism for static configured local protection paths as in Cisco
Routers.

3) Kompella's MIB has a very good way for implementing total path protection,however the way tunnels are managed
are different especially the way tunnels are identified.

In terms of Tom's MIB,the performance of the MIB walkthrough for SNMP queries can have a slower performance mainly
because of the structure assignments and also creation of tunnels can involve in maintaining more state information.(Refer the
MIB for PathInUse and the Path Option Type).

Both I feel are good if we have a union of the best in both.

We can follow one of these MIB's and borrow some fields from the other,ofcourse mainly for implementation performance.

Hope this Helps,
Regards,
Abhay