Subject: MPLS Support of Diffserv

From: mrugendra singhai <[email-masked]>
Date: Sun, 14 Oct 2001 20:20:00 -0700 (PDT)

Hi All,

This is in reference to Draft "MPLS Support of
Differentiated Services"

It says that a label mapping message generated by a
LSR should include EXP/PHB mapping in diffserv for FEC
received in label request message i.e. it is being
suggested that PHB should be supplied based on FEC as
classifier for any destination. But diffserv uses lot
of other fields as classifier. So how can diffserv
treatement be provided for various flow by a LSR
belonging to the same FEC. Is the definition of FEC
not limiting in this case.

Can somebody provide more details on this.

Mrugendra
Research Assistant
NCSU

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Mrugendra Singhai <[email-masked]>
Date: Sun, 14 Oct 2001 20:45:15 -0700 (PDT)

Scott,

With all regards pls refer to RFC 2475 Section
2.3.1(specially sections describing MF type of
classification) on classifiers.

I think what you are refering is DSCP(Can only be used
in behavior aggregate classifier), defined in RFC 2597
which i agree is surely 6 bits. 

But you see the problem is that Diffserv enabled LSR
will be at loss to generate PHB's decision based only
on FEC since FEC definition is very limited(atleast
for supporting diffserv).

Regards

Mrugendra 
Research Assistant
NCSU

--- Scott Bradner <[email-masked]> wrote:
> > But diffserv uses lot
> > of other fields as classifier. 
> 
> maybe you need to look at difserv again - it uses 6
> bits as
> a classifier - all in one field
> 
> Scott

---

From: Mrugendra Singhai <[email-masked]>
Date: Sun, 14 Oct 2001 20:58:14 -0700 (PDT)

But you see this brings up an incompatibility in
integrating diffserv with MPLS.

An edge diffserv enabled LSR will map exp to phb based
solely on FEC. So all flows inside a FEC will get same
treatment inside a MPLS network i.e diffserv will not
be able to exist inside MPLS network and can only
exist outside MPLS network.

Pls correct me if i am wrong

Regards

Mrugendra
Research Assistant
NCSU
--- Scott Bradner <[email-masked]> wrote:
> which is all that difserv is
> 
> and all that is seen in the network - and all that
> would be 
> sen by a mpls router
> 
> Scott

---

From: Mrugendra Singhai <[email-masked]>
Date: Sun, 14 Oct 2001 21:25:24 -0700 (PDT)

From "MPLS Support of Differentiated Services" I infer
that a MPLS LSR which is terminal LSR for a given FEC
receives a Label Request Message with diffserv TLV
containing EXP values only. This TLV is filled up with
PHB values corresponding to FEC that has been received
in Request Message. 

So interworking between diffserv conflicts at this
point so as to how to take a decision so as to what
PHB(DSCP) value to be applied to filled in diffserv
TLV based on just the knowledge of FEC.

Mrugendra
Research Assistant
NCSU

--- Scott Bradner <[email-masked]> wrote:
> > solely on FEC. 
> seems backwards - the difserv phb is an input to
> figuring
> out what FEC to use
> 
> Scott