Subject: RE: the nexthop of RSVP_TE.

From: Marshall Ma Shaowen <[email-masked]>
Date: Tue, 23 Oct 2001 11:39:08 +0530

hi, all
thanks for David Charlap.he give me the solution.
I konw the rfc2205 doesn't talk about the LSPs.but if I follow the rfc2205, 
I will choose the RTD's IP address as the packet's destination address. 
and If I send  the packet with the IP address of RTB . I can not let the 
router that don't know RSVP to forward the packet as the rfc2205 said.
but along the way of LSP. if a router don't know RSVP. I cannot setup a LSP.

So I follow the destination address will be set as RTB's IP address. and I
can update 
my IP stack to let socket send out a packet based on the nexthop.
and I got another question ,
if I choose RTB's IP address,do we need to implement Router Alert option in
IP option ?

Best Redards
marshall

-----Original Message-----
From: Ajay Simha [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 8:51 AM
To: Marshall Ma Shaowen
Cc: [email-masked]; [email-masked]
Subject: Re: the nexthop of RSVP_TE.

On Tue, 23 Oct 2001, Marshall Ma Shaowen wrote:

MMS:hi, all
MMS:I have a question about the nexthop of RSVP_TE.
MMS:as the draft said that we should follow the ERO to forward the packet.
MMS:but the rfc2205 says that the destination address is the egress ip
address.
MMS:so there is some problem about this

First of all rfc2205 does not talk about LSPs.

MMS:
MMS:RTA
MMS:  |
MMS:-+--------------+----------------+----------
MMS:                       |                      |
MMS:                       |                      |
MMS:                   RTB               RTC
MMS:                       |                      |
MMS:                       |                      |
MMS:-----------------+---------------+--------------+--------
MMS:                                                                   |
MMS:                                                                RTD
MMS:if the CSPF caclulate a path next hop by RTB and then RTD.
MMS:but if the RTA send out the packet with the destiantion of RTD,
MMS:both the RTB and RTC will forward this packet. so How can ensure the LSP
MMS:establish through RTA-RTB-RTD ?

Ok.  Assuming RTA is the headend of the tunnel, there are a few ways to
ensure
that the LSP follows the path RTA-RTB-RTD:

1. Explicit path where you simply specify the next-hops but it is still run
against the TED to ensure the contraints are met

2. You could use something like the affinity bits to control this (although
this is not the cleanest way of acheiving the goal).

3. you could set your igp cost and bandwidth to look most attrictive along
this path.

-ajay
MMS:
MMS:Best Regards.
MMS:marshall
MMS:

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi

---

From: David Charlap <[email-masked]>
Date: Tue, 23 Oct 2001 10:19:58 -0400

> thanks for David Charlap.he give me the solution.

Sorry.  I accidentally sent my reply to Marshall and not to the group. 
It's been sent now.

> I konw the rfc2205 doesn't talk about the LSPs.but if I follow the
> rfc2205, I will choose the RTD's IP address as the packet's
> destination address. and If I send  the packet with the IP address
> of RTB . I can not let the router that don't know RSVP to forward
> the packet as the rfc2205 said.

You do not send the packet with RTB's address.  You send it with RTD's
address.  RTB is the next-hop, not the destination.

> but along the way of LSP. if a router don't know RSVP. I cannot
> setup a LSP.  So I follow the destination address will be set as
> RTB's IP address.  and I can update my IP stack to let socket send
> out a packet based on the nexthop. and I got another question ,
> if I choose RTB's IP address,do we need to implement Router Alert
> option in IP option ?

Yes, you must use router-alert.  Without it, RTB will forward a
properly-formed packet, which is incorrect behavior.  RTB must intercept
the packet and process it.

If you actually send the packet to RTB, the packet will get delivered
there, but your behavior will be incorrect.

-- David

> RTA
>  |
> -+--------------+---------------+----------------
>                 |               |
>                 |               |
>                RTB             RTC
>                 |               |
>                 |               |
> ----------------+---------------+--------------+-
>                                                |
>                                               RTD