Subject: Re: resvtear msg

From: "Hong Liao" <[email-masked]>
Date: Tue, 9 Oct 2001 16:22:09 -0400

Adrian,

Thanks,

Julia

                    "Adrian                                                                                  
                    Farrel"              To:     "Hong Liao" <[email-masked]>                           
                    <afarrel@mova        cc:     (bcc: Hong Liao/Telcordia)                                  
                    z.com>               Subject:     Re: resvtear msg                                       
                                                                                                             
                    10/09/01                                                                                 
                    03:48 PM                                                                                 

Hi Julia,

Confirmed.

(However, there is an obvious race where the egress has already sent out
ResvTear and it crosses with the PathTear)

Regards,
Adrian
--
Adrian Farrel
Movaz Networks Inc.
Tel: 703-847-1867
[email-masked]
----- Original Message -----
From: "Hong Liao" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 09, 2001 3:39 PM
Subject: resvtear msg

> Hi,
>
> If Ingress router sends out the pathtear msg to tear down the path and
resv
> state, does the egress suppose to send out the resvtear msg out once it
> receive this pathtear msg?  I read the spec, I think the egress should
not
> send out the resvtear msg.
>
> Can someone help me to confirm this?
>
> Thanks,
>
> Julia
>
>

---

From: David Charlap <[email-masked]>
Date: Thu, 11 Oct 2001 10:47:02 -0400

Adrian Farrel wrote:
> 
> However, there is an obvious race where the egress has already sent
> out ResvTear and it crosses with the PathTear

This isn't really a race condition.  The ResvTear will propagate up to
the point at which it crosses the PathTear.  Beyond there, there will be
no corresponding path state and the Resv will be dropped (silently, I
think - I don't think you generate a ResvErr in response to a ResvTear
that doesn't match established state.)

-- David