Subject: RE: RFC2961 BUNDLE message

From: "Feng, Mark" <[email-masked]>
Date: Thu, 25 Oct 2001 12:07:49 -0700

One thing it saves is the IP header, since multiple RSVP message will be
packed into one.

If the question is, by the Bundle message itself, helps the scaling problem.
IMO, not a whole lot.

- Mark

> -----Original Message-----
> From: Arvind, K [mailto:[email-masked]]
> Sent: Thursday, October 25, 2001 11:47 AM
> To: [email-masked]'
> Cc: Arvind, K
> Subject: RFC2961 BUNDLE message
> 
> 
> Does the BUNDLE message offer any real benefit in terms of 
> reducing control
> overhead? There seems to be no significant change in the 
> overall amount of
> control traffic that is generated or processed as a result of 
> bundling (even
> though the traffic is bunched together resulting in fewer (but larger)
> messages). Does this mechanism really help in scaling RSVP?  
> Could someone
> throw light on this? Thanks.
> 
> Regards,
> Arvind.
>

---

From: Yousuf Hasan <[email-masked]>
Date: Thu, 25 Oct 2001 12:27:07 -0700

>One thing it saves is the IP header, since multiple RSVP message will be

The Summary Refresh helps solve the scaling issue a little more, but it can only be used for messages in steady state.  
Thanks

-Yousuf

---

From: David Charlap <[email-masked]>
Date: Thu, 25 Oct 2001 15:45:42 -0400

Yousuf Hasan wrote:
>
> The Summary Refresh helps solve the scaling issue a little more,
> but it can only be used for messages in steady state.

Which is the point of refresh reduction.  If your state is changing,
then you need to modify state, not refresh it.

All protocols experience high load when things are rapidly changing. 
The only solution to that problem is to not process packets as fast as
you might otherwise be able to.  Which is what happens (among other
things) when damping is used to minimize the effect of rapid route
flapping in routing protocols.

-- David

---

From: Yousuf Hasan <[email-masked]>
Date: Thu, 25 Oct 2001 13:36:53 -0700

>then you need to modify state, not refresh it.

Agreed..

Thanks

---

From: Ping Pan <[email-masked]>
Date: Fri, 26 Oct 2001 15:10:49 -0700

Mark,

I'm not sure that the packet size matters much here. A while ago, I had
measured processing time vs. packet size on 4.4 BSD. It was almost a
flat line. Bundling was designed to improve I/O efficiency, not to save
packet size.

- Ping