Subject: RE: Use of L3PID

From: "Feng, Mark" <[email-masked]>
Date: Wed, 10 Oct 2001 17:35:36 -0700

Following is from RFC 3031
"
   If, on the other hand, penultimate hop popping is used, then when the
   penultimate hop looks up the label, it determines:

      -  that it is the penultimate hop, and

      -  who the next hop is.

   The penultimate node then pops the stack, and forwards the packet
   based on the information gained by looking up the label that was
   previously at the top of the stack.  When the LSP egress receives the
   packet, the label which is now at the top of the stack will be the
   label which it needs to look up in order to make its own forwarding
   decision.  Or, if the packet was only carrying a single label, the
   LSP egress will simply see the network layer packet, which is just
   what it needs to see in order to make its forwarding decision.
"

- Mark

> -----Original Message-----
> From: Kireeti Kompella [mailto:[email-masked]]
> Sent: Wednesday, October 10, 2001 5:26 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: Use of L3PID
> 
> 
> Mark:
> 
> > I don't think the PHP needs to do that. The PHP has, in the 
> "lookup table",
> > the incoming label, and the next hop. What is missing is 
> the outgoing label.
> > It doesn't need the L3PID to forward the data packets.
> 
> With PHP, there is no outgoing label.  If the label stack is 
> empty after
> popping, what L2 encapsulation do you put on the data packet?
>  
> Francis:
> 
> > I agree with you. 1 minor addition: If PHP is used, also 
> the penultimate
> > node should check.
> 
> Slight change: if PHP is used AND the label stack is empty 
> after the pop,
> the penultimate LSR should also check.
> 
> Mark:
> 
> > IMO, only the egress node should check. The transit nodes are merely
> > forwarding the data packets. Whether they support the L3PID 
> protocol does
> > not seem to be relevant.
> 
> Agreed, with Francis's proviso.
> 
> Kireeti.
>

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 10 Oct 2001 17:48:52 -0700 (PDT)

> > If the label stack is empty after

> Following is from RFC 3031

Doesn't answer the question.  All you have done is point out that
the RFC is incomplete in its description.

>    previously at the top of the stack.

If the label that was previously at the top of the stack has the end
of stack bit set, the L3PID (or some other magic) determines what
the layer 2 encap on the outgoing packet should be.  Otherwise, the
outgoing packet is sent as an MPLS packet.

If you do it differently, I'd be interested in your algorithm.

Kireeti.