Subject: RE: New revision of the MPLS ttl draft

From: Shahram Davari <[email-masked]>
Date: Thu, 11 Oct 2001 13:54:15 -0700

Puneet,

>Much 
> like for IP,
> where a node can decrement the TTL by more than 1 (rfc1812), 
> we leave the
> door open for service providers to configure their egress 
> LSRs to decrement
> by more than 1.

When a provider decides to decrement more than 1, it means that the provider is willing to store customers' TTL policy (decrement value). In that case he might store the Diffserv policy (PHB<=>EXP) as well and therefore use the short pipe.

>In (C), the service providers egress LSR *is* doing
> deterministic (customer independent) TTL processing. 

Anything which is configurable can't be deterministic unless either signaled or written in the SLA. The signaling is not desirable, and writing it in SLA, means that it can't be changed quickly, which defeats the purpose of subtracting more than one.

Yours,
-Shahram

---

From: Eric Gray <[email-masked]>
Date: Thu, 11 Oct 2001 17:20:27 -0400

Shahram,

    I think you presuppose an application that suits your argument.

    I can imagine applications that benefit from having an SLA fixed
value of TTL decrement other than one.

--
Eric Gray (mailto:[email-masked])
http://www.mindspring.com/~ewgray

---

From: Bora Akyol <[email-masked]>
Date: 11 Oct 2001 16:08:57 -0700

Shahram

Our draft allows the service provider flexibility in setting what they
want in the egress LSR easily supporting the model you want to see as
well. 

(In fact one can easily configure a default TTL decrement if desired
such that it is the customer router that does the most of the TTL
decrementing on egress)

Regards

Bora