Subject: TTL Processing in RFC 3032

From: "Girish Dandin" <[email-masked]>
Date: Fri, 4 Jan 2002 19:40:46 +0530

Hi

I have doubt in RFC 3032 regarding TTL processing (sec 2.4)

When packet needs to be given(fwd) to IPv4, RFC says, ( in sec 2.4.3, IP Dependent Rules), the value of the IP TTL field must be replaced with the OUT GOING TTL value.
Outgoing TTL value is the maximum of Incoming TTL Value -1 (OR) 0.
Now,  supposing a case of a Proxy Egress ( that is the Egress for the MPLS Domain, but the packet is still forwarded in the IP Domain) :
      Packet that is received by Shim layer would decrement the TTL Value by one, then it gets the Outgoing TTL which it would give to IPLayer. Now, IP Layer would decrement it one more time before forwarding the packet. That is, at the same node, TTL processing is done (decremented) twice, once on a Labelled Packet, other time on the IP Packet !
   I just wanted to know if my understanding is right ?,is the behavior normal?
 if not, how to come over this problem ?

Regards
Girish

---

From: Shahram Davari <[email-masked]>
Date: Fri, 4 Jan 2002 07:06:41 -0800

Hi Girish,
 
Check the following draft, which tries to clarify the TTL processing:
 
http://search.ietf.org/internet-drafts/draft-agarwal-mpls-ttl-01.txt <http://search.ietf.org/internet-drafts/draft-agarwal-mpls-ttl-01.txt> 
 
Yours,
-Shahram

-----Original Message-----
From: Girish Dandin [mailto:[email-masked]]
Sent: Friday, January 04, 2002 9:11 AM
To: [email-masked]
Subject: TTL Processing in RFC 3032

Hi

 
Regards
Girish