Subject: MPLS label value range

From: "Paola Iovanna (ERI)" <[email-masked]>
Date: Mon, 21 Jan 2002 19:03:08 +0100

Hi all!

I'd like to know which are the values that MPLS labels range over.
e.g. the first 4 bits are reserved, from 5 to x bits are used for ATM ( I don't know, it is just an example)...etc

Thank you!!!

Paola

---

From: Ajay Simha <[email-masked]>
Date: Mon, 21 Jan 2002 13:13:52 -0500 (Eastern Standard Time)

On Mon, 21 Jan 2002, Paola Iovanna (ERI) wrote:

PIE>Hi all!
PIE>
PIE>I'd like to know which are the values that MPLS labels range over.
PIE>e.g. the first 4 bits are reserved, from 5 to x bits are used for ATM
PIE>( I don't know, it is just an example)...etc

Paola,

RFC 3032 section:

2.1. Encoding the Label Stack

has only lables 0 through 15 reserved.

-ajay
PIE>
PIE>Thank you!!!
PIE>
PIE>Paola
PIE>

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
Cisco Systems
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi

---

From: "Wayne W. Szeto" <[email-masked]>
Date: Mon, 21 Jan 2002 13:54:42 -0500 (EST)

The range of MPLS labels is from 0 to (2^20 - 1), where label 0-15 are
reserved.

---

From: Eric Osborne <[email-masked]>
Date: Mon, 21 Jan 2002 17:09:18 -0500

> The range of MPLS labels is from 0 to (2^20 - 1), where label 0-15 are

...for frame-based.  For cell-based, the range is mostly size of the
VCI/VPI space; see rfc 3035.

eric