Subject: Question about LMp.21 in RFC3036

From: "Zhun Jonathan Qiu" <[email-masked]>
Date: Tue, 22 Jan 2002 20:25:22 -0800

Hi, there, I guess this may have been discussed before and if that's case please direct me
to the thread.

In RFC3036, A.1.2 (Receive Label Mapping), when we reach LMp.21, we should have failed the
check in LMp.18, i.e. LSR has NOT previously sent a label mapping for FEC to the peer. So
at this point "PrevAdvLabel" should be undefined. Then how can LMp.21 uses it as a
parameter to "Send_Message"?

Do we need to allocate a new label and advertise at this point?

I think I must be missing something obvious. Please help me out then. Thanks a lot!

Regards,
Jonathan Zhun Qiu

---

From: "James R. Leu" <[email-masked]>
Date: Wed, 23 Jan 2002 11:49:31 -0600

> I think I must be missing something obvious. Please help me out then. Thanks a lot!

My interpretation is:

An LSR may have advertised a label for this FEC to another peer.  In which 
case the LSR can advertise the same label or advertise another label and 
merge the two.

In other words the check in LMp.18 has nothing to do with 'PrevAdvLabel'.

Jim

-- 
James R. Leu

---

From: "Zhun Jonathan Qiu" <[email-masked]>
Date: Wed, 23 Jan 2002 10:12:39 -0800

Thank you for your reply James! This helps a lot. However, one more question is, if at
this point the LSR hasn't advertised any label for this FEC to any peer, what would be the
value of "PrevAdvLabel" then?

Regards,
Jonathan Zhun Qiu

-----Original Message-----
From: James R. Leu [mailto:[email-masked]]
Sent: Wednesday, January 23, 2002 9:50 AM
To: Zhun Jonathan Qiu
Cc: [email-masked]
Subject: Re: Question about LMp.21 in RFC3036

My interpretation is:

Jim

--
James R. Leu