Subject: RE: Explicit Loose Path Computation

From: Snigdho Bardalai <[email-masked]>
Date: Wed, 16 Jan 2002 07:24:40 -0800 (PST)

My question may have been a little confusing -
actually the algorithm should generate an explicit
path based on loose route constraint specification.

Snigdho

Snigdho Bardalai wrote:
> 
> I wanted to find out if anybody has come across an
> algorithm to compute an explicit loose path.

IMO, it seems rather pointless.  If you have enough
routing information
available to automatically compute an ERO, why
wouldn't you want to
compute a strict ERO?

IMO, loose EROs are best used only by manual-creation,
where a human
operator can specify certain key nodes, knowing that
the topology of the
intervening nodes may change over time.  But any
software that
auto-generates these EROs should also be capable of
dynamically
recomputing those EROs as the topology changes,
meaning that there is no
real need for loose nodes.

At least this is my opinion.

-- David

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: "abhay" <[email-masked]>
Date: Fri, 18 Jan 2002 10:49:46 +0530

Hi Bardalai,
                All route calculation algorithms if specified with a loose hop will find a explicit route
                The( Constraint or Rule) Being: The Loose Hop should be there in the explicit route.
                Regards,
                Abhay