Subject: mpls lsr mib

From: [email-masked]
Date: Thu, 24 Jan 2002 14:22:28 +0100

Hello Tom et all,

I have a question on the mplsInterfaceConfTable in the mpls lsr mib. 
IAssume that we consider the following:
* Per interface label space used for RSVP signalled LSPs and static LSPs.
* Global label space used for LDP signalled LSPs.

Which value should we then give to the mplsInterfaceLabelMinIn:
* The min label value of the per interface label space (that is, the min 
label value from the RSVP signalled LSPs and the static LSPs)?
* The min label value of the RSVP signalled LSPs.
* The min label value of all LSPs on the interface (=min of all LDP 
signalled, RSVP signalled and static LSPs).

I would appreciate any help you can give me.

Kind regards,

        Francis.

--------------------------------

mplsInterfaceLabelMinIn OBJECT-TYPE
   SYNTAX        MplsLabel
   MAX-ACCESS    read-only
   STATUS        current
   DESCRIPTION
       "This is the minimum value of an MPLS label that this
        LSR is willing to receive on this interface."
   ::= { mplsInterfaceConfEntry 2 }

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 24 Jan 2002 09:29:10 -0500

>* Global label space used for LDP signalled LSPs.

         First, how can you use two different label spaces to advertise over
the same interface?  I have never heard of this behavior before. One
assigns a per-interface label range that is unique for that interface
only, no?

         --Tom

>I would appreciate any help you can give me.

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: Alia Atlas <[email-masked]>
Date: Thu, 24 Jan 2002 09:59:48 -0600

>assigns a per-interface label range that is unique for that interface

Having LDP use global labels while RSVP-TE LSPs use per interface labels is
reasonable; certainly, I've heard of it before.  One can partition the
label range given out, so that one range is for the global labels, while
the other is for per-interface.

Alia

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 24 Jan 2002 10:43:57 -0500

>the other is for per-interface.

         Yes, it is within the realm of possibility to configure your label
ranges that way. However, what you are talking about is per-application
label space configuration, which is not what the MIB variable is getting at.
It is used to represent per-interface label range configuration or per-platform
label range configuration. These values are configured on interfaces, not on
applications. If you want to divide up the range further (i.e.: per 
application),
that is something the MIB was not intended to do.

         --Tom

---

From: "rajneesh mahajan" <[email-masked]>
Date: Thu, 24 Jan 2002 11:01:10 -0500

I had a similar problem while implementing this MIB few months back and I decided that we should give label range for RSVP and statically signalled LSPs (which was per interface as in your case).  LDP label range could be obtained from LDP MIB.  Please correct me if I am wrong.

-Rajneesh
  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Thursday, January 24, 2002 8:22 AM
  Subject: mpls lsr mib

  Hello Tom et all, 

  I have a question on the mplsInterfaceConfTable in the mpls lsr mib. IAssume that we consider the following: 
  * Per interface label space used for RSVP signalled LSPs and static LSPs. 
  * Global label space used for LDP signalled LSPs. 

  Which value should we then give to the mplsInterfaceLabelMinIn: 
  * The min label value of the per interface label space (that is, the min label value from the RSVP signalled LSPs and the static LSPs)? 
  * The min label value of the RSVP signalled LSPs. 
  * The min label value of all LSPs on the interface (=min of all LDP signalled, RSVP signalled and static LSPs). 

  Kind regards, 

          Francis.