Subject: RE: L2 VPN services

From: senthil ayyasamy <[email-masked]>
Date: Mon, 7 Jan 2002 15:17:36 -0800 (PST)

leave alone alll other tunneling methods, what is the exact prons and cons of IPsec and MPLS VPNs ...I feel like IPsec VPN have an edge over MPLS in that it provides more security and also no change to the core network.Also,i dont have to depend too much on the ISP for support....enlighten me more in this aspect
-senthil
  David Kuder <[email-masked]> wrote: Irwin Lazar [[email-masked]] on January 07, 2002 6:46 AM wrote:
> Here's a similar question to the ATM-MPLS debate, but on a
> slightly different track - right now there seems to be a lot
> of interest in using MPLS to provide L2 "VPN" services (e.g.
> frame relay, Ethernet, TDM, ATM) over an IP network. Yet,
> others suggest that using L2TP rather than MPLS is a better
> approach in that it is more scalable and easier to manage.

> My question is what are you folks seeing in the service provider
> space - are SPs moving toward MPLS or are they looking at L2TP.
> Is this an either/or decision or will both technologies have a
> role? Which technology will become the preferred choice for
> providing L2 services of an IP network? Are there any other
> alternatives?

Cisco has a hierarchy of VPNs that I hacked:
Overlay VPN
Layer 2
Frame Relay
ATM
Layer 3
Tunneling
IPSec
GRE
L2TP
P2TP
firewall appliance
Peer to Peer VPN
MPLS
Dedicated Router
real
virtual
Virtual LAN
Bridging Ethernet over 
TDM
DSL
metro fiber

You can probably find a vendor or service provide living in
every one of those categories.

For me, ease of management is not a winner for any tunneling
protocol. I'm not sure about scalability. Obvious losers are
increased bandwidth, increased latency, CPE support, and QOS.

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe: http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

SENTHIL KUMAR
MS(COMPUTER NETWORKING)
UMKC,
MO-64112,USA

---------------------------------
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail.

---

From: "David Kuder" <[email-masked]>
Date: Mon, 7 Jan 2002 15:36:17 -0800

senthil ayyasamy [[email-masked]] on January 07, 2002 3:18 PM wrote:
> leave alone alll other tunneling methods, what is the exact
> prons and cons of IPsec and MPLS VPNs ...I feel like IPsec
> VPN have an edge over MPLS in that it provides more security
> and also no change to the core network.Also,i dont have to
> depend too much on the ISP for support....enlighten me more
> in this aspect 

I am the service provider so already that's different.

IPSec is not as well supported by our default vendor or so
the sales engineer claims.  You may get a different answer
from the same vendor.

IPSec requires many more TLAs (PKI, IKE, MD5, HMAC, ESP).  That's
not entirely a joke.  In terms of configuration and maintenance
there is a big chunk of infrastructure to deal with. 

IPSec does encrypt the payload.  That can be so important as to
make the rest of it part of the cost doing things.

For our application (VOIP), IPSec introduces too much overhead
in bandwidth and latency.

I'm not sure if MPLS is a big winner.  That's why I joined the
list, to learn.  Speaking of which, I see that Senthil cc-ed
[email-masked].  What is the difference between it and mpls-ops?

Every one of the VPN options I've seen is applicable for someone
under some set of assumptions.