Subject: Addition to Deletion Proc for GMPLS RSVP

From: Joe Dumont <[email-masked]>
Date: Wed, 16 Jan 2002 17:39:18 -0600

I posted this comment a few weeks ago and I have not recevied a response yet.  I have attached the original 
posting:

Hello,

Section 7.2.2 of generalized-rsvp-te-06 does not appear cover the case of an Egress initiated deletion where the ingress node does not support admin status. 

I suggest the following additional wording to be added to the end of section 7.2.2 to clarify this additional error procedure:

"In the case of a non-supporting ingress node, a PathTear may not be returned when an egress node sends a Resv with D and R bits set. To support the case of non-supporting ingress node, the egress SHOULD only wait a configurable period of time for the PathTear message to be returned. Once the period of time has elapsed, the egress node sends a ResvTear message or a PathErr message with Path_state_removed flag set, and normal RSVP takes place. By default for this period SHOULD be 30 seconds."

Regards,

Joe

---

From: "Wayne W. Szeto" <[email-masked]>
Date: Thu, 17 Jan 2002 16:30:01 -0500 (EST)

Hi,
Does anyone if there exists any implementation on mpls-router emulator?
I'm aware of two seperate mpls implementations on linux (one at
sourceforge and another one at Cambridge), but I'm looking for a router
emulator (e.g. a unix process acting as a router that accepts and
processes real ip/mpls packets).  I'm also interested to know any ip
router emulators that can be modified to become mpls-enabled. Thanks for
any help.

-ws