Subject: Re: L bit in Unnumbered Interface ID Subobject

From: Yakov Rekhter <[email-masked]>
Date: Fri, 01 Mar 2002 06:16:41 -0800

Ania,

> Hi all,
> 
> Unnumbered Interface ID subobject defined draft-ietf-mpls-rsvp-unnum-04.txt
> has an L bit telling whether it is a strict or loose node.
> Whereas the same subobject draft-ietf-mpls-crldp-unnum-04.txt 
> lacks the bit.
> Is it an error in specification ? If yes, which draft has 
> correct Unnumbered Interface ID definition ?

This is an error in the spec. The revised version of the draft
that I just submitted has this fixed.

Thanks for bringing this up.

Yakov.

---

From: Anna Szymanska <[email-masked]>
Date: Fri, 01 Mar 2002 8:51:56 +200

Robercie,

The problem is that draft-ietf-mpls-crldp-unnum-04.txt says
the Unnumbered Interface ID processing is done accordingly
to the ERO processing algorithm described in section 4.8.1 
of draft-ietf-mpls-cr-ldp-04.txt. The algorithm defines 
different LSR behaviour depending on the value of L bit.
The question is how Unnumbered Interface ID subobject 
should be treated as a strict (i.e. as if L bit is not set)
or as loose node (i.e. as if L bit is set) ?

Regards,

Ania

>Aniu, 
>I don't see any error - as nobody claims inter-exchange ability of ERO's  
>for CRLDP & RSVP-TE. Clearly lack of explicit indication if this is  
>loose or strick ERO sub-object simply makes crldp less capable then  >rsvp-te :).  
>I am sure in the next iteration the flag get's added.  >Rgs,  
>R.  

-- 

Określ Swoje potrzeby - my znajdziemy ofertę za Ciebie!
[ http://oferty.onet.pl ]