Subject: RE: QoS for BGP/MPLS VPNs in 2547bis

From: Shahram Davari <[email-masked]>
Date: Sun, 10 Mar 2002 09:03:06 -0800

Robert,

> -----Original Message-----
> From: Robert Raszuk [mailto:[email-masked]]
> Sent: Saturday, March 09, 2002 9:10 AM
> To: Reddy, Vikram
> Cc: 'Metz, Eduard'; [email-masked]; [email-masked];
> [email-masked]'; [email-masked]'
> Subject: Re: QoS for BGP/MPLS VPNs in 2547bis
> 
> 
> Reddy,
> 
> > My requirement is to be able to apply QoS to an entire VPN and to
> > be able to do it automatically. No manual configuring should be
> > done for each route.
> 
> Per incomming interface EXP bit setting is possible at least in both
> commercial MPLS-VPN implementations I am familiar with. 
> 
> > We must also be able to reserve QoS dynamically when a the 
> first route
> > for the VPN is reserved and must be able to give all the 
> routes learnt later
> > in the VPN the same QoS.
> 
> Giving QoS to the _routes_ is not a new concept. Why don't you use
> regular qos policy propagation with bgp for all VPN routes or a subset
> of those.
> 
> > Since 2547bis does not provide anything to uniquely identify a VPN
> > and to identify traffic belonging to the VPN, there probably should
> > be an extension/draft yo include that.
> 
> Appling different QoS per VPN is a pretty bad idea in itself.

It may not be very scalable, but in fact I think one of the main requirements of VPN is to decouple the QoS of customers. Sonmething that probably requires per-customer queuing.
 
-Shahram 

> 
> Now I am not sure if you are going to use LDP in the core or full mesh
> of PE-PE traffic engineer tunnels. Both ways are possible to achive
> decent diffserv with current 2547bis draft btw.
> 
> > VPN-VR does allow us to uniquely identify a VPN based on VPN-ID.
> > This will give us more control on the policies we want to 
> apply to the
> > VPN.
> 
> Could you be a bit more specific how you are going to use 
> this VPNID, in
> particular how this VPN-ID will help you to identify the vpn data
> belonging to this or different VPN for a selective qos treatment ?
> 
> R.
>

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 10 Mar 2002 18:08:07 +0100

> It may not be very scalable, but in fact I think one of 
> the main requirements of VPN is to decouple the QoS of 
> customers. Sonmething that probably requires per-customer queuing.
> 
> -Shahram

Well in almost all practical scenarios I met SP/ISP will not offer per
customer queuing. Instead it will offer per customer's application
queueing - the difference is very significant. And as an example it
should not matter for customer A if his VoIP packets are transported in
the same diffserv pipe with VoIP packets belonging to different customer
B as long as both of them get what they have paid for.

Rgs,
R.