Subject: RE: traffic eng. req. (2702)

From: "Sundeep Singatwaria"<[email-masked]>
Date: Tue, 5 Mar 2002 10:33:43 -0800

-----Original Message-----
From: Ravi Sankar Mantha [mailto:[email-masked]]
Sent: Monday, March 04, 2002 8:24 PM
To: Singatwaria, Sundeep [SC7:370:EXCH]; [email-masked]
Subject: RE: traffic eng. req. (2702)

 Hi sundeep,
      Only difference is, Resource Class Attribute ( refered in section
6.2); is an attribute of the Resource such as link. Whereas the Resource
Class Affinity Attribute is the attribute of the traffic trunk ( refered in
section 5.6.3). You are right that both are to address the same problem.

-> Yes, I'm aware of it.

     To exemplify, suppose you have 4 links in your topology, and the
corresponding Resource Classes  are : L1 - RED, L2 - GREEN, L3 - RED, L4 -
BLUE.
     Suppose you have a trunk T1 whose Resource Class Affinity is INCLUDE-
RED;
 Now, for path computation for T1, only L1, L3 links can be used.

-> You still are excluding the link which is same as the resource class. 

regards,
Ravi
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Sundeep
Singatwaria
Sent: Tuesday, March 05, 2002 12:06 AM
To: [email-masked]
Subject: traffic eng. req. (2702)

In 2702 ( req. for traffic eng over MPLS) - Section 5.6.3 talks about
Resource Class Affinity Attributes and Section 6.2 talks about the Resource
Class Attribute. It appears to me that they address the same problem of
inclusion/exclusion of some resources from path computation.
Is there some different problems that the authors are addressing w.r.t. to
these sections. Pls. let me know.
Thanks.
Sundeep

---

From: "Ashwin C. Prabhu" <[email-masked]>
Date: Wed, 6 Mar 2002 09:45:56 +0530

-----Original Message-----
From: Sundeep Singatwaria [mailto:[email-masked]]
Sent: Tuesday, March 05, 2002 11:34 PM
To: 'Ravi Sankar Mantha'; [email-masked]
Subject: RE: traffic eng. req. (2702)

-----Original Message----- 
From: Ravi Sankar Mantha [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, March 04, 2002 8:24 PM 
To: Singatwaria, Sundeep [SC7:370:EXCH]; [email-masked] 
Subject: RE: traffic eng. req. (2702) 

 Hi sundeep, 

-> Yes, I'm aware of it. 

[Ashwin C Prabhu] 

Thats exactly the purpose of the two, The Resource class you can say it as 

a color assigned to the link. While establishment of lsp you check the
Resource 

class affinity ( I.e The administrator will configure which all the colors
the lsp 

can traverse ) The combination of the 2 makes the traffic trunk to take the
correct 

path.  

Hope i am right and it helps you.  

regards, 
Ravi 
-----Original Message----- 
From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Sundeep 
Singatwaria 
Sent: Tuesday, March 05, 2002 12:06 AM 
To: [email-masked] 
Subject: traffic eng. req. (2702) 

--------------------------------------------------------------------------------------------------------------------
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom
they are addressed. If you have received this email in error please notify the
originator of the message. 

Any views expressed in this message are those of the individual
sender, except where the sender specifies and with authority,
states them to be the views of Huawei Technologies India Pvt. Ltd.