Subject: RE: Question on draft-ietf-ppvpn-rfc2547bis-01.txt January 2002

From: [email-masked]
Date: Wed, 6 Mar 2002 08:58:27 +0100

Hi Sachin Kalra,

1) The LSPs between PE and PE are established even before any VPNs
   are configured. In general, they are established dynamically,
   using an IGP and LDP.

2) Maybe ask Juniper/Cisco?

Regards,
-----------------------------
Juerg FANKHAUSER
[email-masked]
-----------------------------

-----Original Message-----
From: Sachin Kalra [mailto:[email-masked]]
Sent: Mittwoch, 6. März 2002 01:25
To: [email-masked]
Subject: Question on draft-ietf-ppvpn-rfc2547bis-01.txt January 2002

Hi All:

I had few questions regarding BGP/MPLS VPNs.

1. Are the LSPs from one PE to another PE manually configured or are they 
dynamically created when VPNs are configured?

2. Is there an example available for VRF table used by Juniper and Cisco? 
(Format and Contents)

I would appreciate any help.
Thanks,
Sachin Kalra

---

From: "Reddy, Vikram" <[email-masked]>
Date: Wed, 6 Mar 2002 05:54:13 -0500

For the first part of your question.

The RFC doesn't specify anything about it.

There are multiple options:
1)You can pre-establish the LSPs. In this case one has to
  make sure that an LSP is established between this particular
  PE( on which the new VRF is being configured) and all other PEs which have
  a common VPN to the one being configured.
  This gives flexibiity to the Service Provider 
  to select the Explicit Route, Signalling Protocol (CR-LDP, RSVP-TE), 
  Qos for the LSP, but has the disadvantage of too much configuration 
  requirements and details.

2)A software component on the PE establishes the LSPs  
  dynamically when this PE recieves a VPN-IPV4 route from a 
  remote PE to which there is no existing LSP tunnel.
  
3) Allow a combination of both of the above in which the Service Provider
   is given the option to pre-establish the LSPs he wants to before
configuring 
   the VRF. The rest of the LSPs may be set up dynamically.

Vikram.

-----Original Message-----
From: Sachin Kalra [mailto:[email-masked]]
Sent: Tuesday, March 05, 2002 4:25 PM
To: [email-masked]
Subject: Question on draft-ietf-ppvpn-rfc2547bis-01.txt January 2002

Hi All:

---

From: "Reddy, Vikram" <[email-masked]>
Date: Wed, 6 Mar 2002 23:16:33 -0500

Hi Ravindra,

The statement from the mib draft means MPLS has to
be enabled i.e the interfaces have to be MPLS enabled and
a signalling protocol has to be enabled on the routers
and the interfaces.

It does not say that LSPs have to be pre-established in the network.

Please note that it does not say that LSPs have to be pre-configured.
There is a difference between pre-configuring MPLS in
the network (which means the routers should participate in MPLS. i.e 
they are LSRs) and pre-establishing LSPs in the networks,

Therefore there is no requirement that LSPs have to be 
pre-configured. 

Vikram.

-----Original Message-----
From: Ravindra GPC [mailto:[email-masked]]
Sent: Tuesday, March 05, 2002 9:03 PM
To: [email-masked]
Subject: Re: Question on draft-ietf-ppvpn-rfc2547bis-01.txt January 2002

> dynamically created when VPNs are configured?

Ravindra> You can find some useful info from the draft,
draft-ietf-ppvpn-mpls-vpn-mib-03.txt. It says

   "This configuration is under the assumption that 1) MPLS has been pre-
   configured in the network, through enabling LDP or RSVP-TE. 2) OSPF
   or ISIS has been pre-configured. 3) BGP sessions have been
   established between PEs."

So LSPs will be established prioir to the definition of VPN and I consider
this as a pre requisite. ( Not part of VPN config )

> 2. Is there an example available for VRF table used by Juniper and Cisco?

Ravindra> There is a white paper from Juniper Networks. The name of that is
"RFC2547bis: BGP/VPN Fundamentals". This white paper exaplains the VPNs and
they give one case study. You can have a sample VRF with format there.

Hope these info will be of help to you.

regards
Ravindra