Subject: Backup LSP computation

From: "Charlotte Hullo" <[email-masked]>
Date: Wed, 27 Mar 2002 14:25:14 +0100

Which algorithm is used to compute the backup LSP to do fast rerouting in case of link or router failure?

---

From: Eric Osborne <[email-masked]>
Date: Wed, 27 Mar 2002 09:36:34 -0500

On Wed, Mar 27, 2002 at 02:25:14PM +0100, Charlotte Hullo wrote:
> Which algorithm is used to compute the backup LSP to do fast
> rerouting in case of link or router failure?

That's vendor-specific; there is no standardized algorithm.

eric

---

From: "abhay" <[email-masked]>
Date: Mon, 1 Apr 2002 10:25:02 +0530

Hi,

For backup LSP to do fast re-routing consider the following steps:

1) Store the List of nodes the primary path is traversing

Now you may need complete protection of the primary path or partial protection:

In case of Partial protection:

1) Exclude the set of routers which you may feel as a Network administrator are prone to link failures and apply the input to CSPF algorithm

Signal the protection path from the new ingress to egress,which does not include the excluded routers.

In case of Complete Path protection:

1) Each next hop needs to be excluded,how u are going to do it,is to maintain additional state information along the primary path and also some
interaction with signaling protocols.

2) For the complete path protection,CSPF algorithm may be applied at each alternate router with the constraint to exclude the next hop.

Hope this helps,
Regards,
Abhay

Abhay D.S
Senior Software Engineer,
Multitech Software Systems,
Bangalore-95
India