Subject: RE: Y.1711 requirements from IETF

From: Shahram Davari <[email-masked]>
Date: Tue, 19 Mar 2002 16:09:22 -0800

Thomas,

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 5:41 PM
> To: Shahram Davari
> Cc: [email-masked]'
> Subject: Re: Y.1711 requirements from IETF
> 
> 
> 
> 
> >To put things clear, as one of the authors of Y.1711 I would 
> like to make 
> >some observations regarding
> >the requirements that Y.1711 has from IETF. Off course an official 
> >response will be provided by ITU
> >to IETF in this regard.
> >
> >1) Y.1711 requires only ONE reserved label (=14) for the 
> identification of 
> >OAM packets.
> >2) No more labels is required to implement Y.1711 and no 
> other label is 
> >anticipated to be required for future work.
> >3) The current version of Y.1711 provisions the egress LSRs 
> for continuous 
> >monitoring of the
> >CV (connectivity verification) packets.
> 
>          You should be clear. It specifies that *all* LSPs must be 
> provisioned with this feature
> on and at a specific interval.

Where did you get this " ALL LSPs MUST" statement from? May be you are
reading a different Y.1711 than I have. All I can find are the following
statement:

" ... It is strongly recommended that CV OAM packets be generated on all LSPs 
(in order to detect all defects and potentially provide protection against 
traffic leakage both in and out of LSPs). "

"... CV generation could be enabled on all (or most) of the LSPs"

There is no MUST and in fact you could enable the CV only on ONE LSP.
If the text is not conveying this information, then we would have
to add additional text or appendix in the next version to clarify it.

  I would check with operators 
> on this, but I 
> don't think this it is such a good
> idea to tell operators how to run their networks.

We are not telling them how to run their network. All we are saying is
that in order to detect more defects you need to enable more CVs. This is
a compromise that they have to decide to make not us.

> 
> >However, we thought that it might be beneficial to also
> >be able to signal to the egress LSR whether the CV is running on a 
> >specific LSP or not. There are
> >many ways of doing this (including using NMS) but the ideal 
> way would be 
> >extensions to MPLS signaling protocols.
> 
>          The problem is that the details of this subtle point are not 
> outlined in your current proposal.
> Perhaps you could provide them here?

We have not worked out the details yet. The first version of Y.1711 relies on
provisioning. In future we may or may not introduce new signaling extensions.

> 
> >4) Y.1711 is fully backward compatible with IETF standards 
> and has no 
> >intention of modifying any IETF protocol.
> 
>          How can you have "no intention" if you just stated 
> in #3 that 
> extensions to existing MPLS signaling
> protocols may be needed.

By modifying I meant mandatory extensions not optional extensions. Therefore
we MAY  introduce optional extensions to MPLS signaling for enabling/disabling
the OAM processing of the egress LSR.

> 
> >5) Y.1711 has no intention of adding any extensions to BGP 
> or any other 
> >protocol (except optional
> >extensions to MPLS signaling as mentioned in 3).
> 
>          That is what we are worried about. Again, please 
> provide the details.

I don't understand what is here that is hard to grasp for you.
An optional extension is an optional TLV/object. Why is it important to
know the details of the optional TLV/objects at this point in time?

-Shahram 

> 
>          --Tom
> 
> 
> 
> 
> >Hope this helps.
> >
> >Yours,
> >Shahram Davari
> >Senior Product Research Engineer
> >R&D Research Ottawa
> >PMC-Sierra, Inc.
> >Phone: (613) 271-4018
> >Fax:   (613) 271-6468
> 
> 
> 
> --------------------------------------------------------------
> ----------
> Mathematics is the supreme nostalgia of our time. 
>

---

From: George Swallow <[email-masked]>
Date: Wed, 20 Mar 2002 17:58:45 -0500

> traffic leakage both in and out of LSPs). "

I have one customer providing an IP VPN service who has >1500 PE
routers and probably well over a million LSPs.  Most of the LSPs
represent VPN connectivity can carry very little traffic.

Would you "strongly recommend" that CV OAM packets be generated on all
their LSPs at a rate of 1 per second?  Can you point to *any*
currently deployed network other than those using MPLS solely for
traffic engineering where this would be a good idea?  If I'm carrying
the full internet routing table and using LDP downstream unsolicited
should every router generate 108,000 (the current number of routes) CV
OAM packets per second?

Perhaps you should revisit this "strongly recommended"
recommendation.  Perhaps you should provide for generation of CV OAM
packets at rates other than 1  second.

...George

==================================================================
George Swallow       Cisco Systems                  (978) 497-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824