Subject: RE: question about fast-reroute

From: Sundara Murugan <[email-masked]>
Date: Thu, 7 Mar 2002 14:03:39 -0800

The PLR should switch to bkup/bypass only when it detects the link to T1
fails (link failure) or when PLR detects the Resv message timeou (Node
failure).
 
-sundara.

 ginal Message-----
From: Doug Degan [mailto:[email-masked]]
Sent: Thursday, March 07, 2002 7:55 AM
To: [email-masked]
Subject: question about fast-reroute

0) what is wrong in this story?
   --------------------------------------
 
consider the folowing topology:

 
[I]---[PLR]----[T1]-----[MP]-----[T2]----[E]
        \                    /
         \------------------/
            BYPASS/DETOUR

primary LSP is from I to E,  it is protected at PLR by BYPASS/DETOUR lsp.
(this wasn't configured manually, but was done upon configuring the
protected LSP)
 
now the link between T2 and E fails.
T2 send PATH-ERR upstream cause it can't protect the primary LSP.
same goes to MP and T1 (sending PATH-ERR upstream).
PLR get the PATH_ERR and switch the traffic to the BYPASS/DETOUR.
 
if what I have describes may happen I have other questions except the "0"
question:
1) should PLR know per each possible failure position whether it is
protected against it? (how...)

2) should PLR always select the "farest-merge" bypass? (in this case it
might have prevented traffic loss).
 
thanks in forward.
doug.

---

From: Ping Pan <[email-masked]>
Date: Thu, 07 Mar 2002 15:38:35 -0800

Sundara Murugan wrote:

> 
>     The PLR should switch to bkup/bypass only when ... PLR detects the Resv message
>     timeou (Node failure).
> 

This will be too late.

- Ping