Subject: RE: Y.1711 requirements from IETF

From: Shahram Davari <[email-masked]>
Date: Thu, 21 Mar 2002 09:13:02 -0800

Eric,

I didn't quite catch your question. If you are asking about the 1/s transmission of CV,
then there are 2 choices in general:

1) define one rate and define a globally accepted definition of the availability and unavailability state and the
condition for their transitions. This guarantees interoperability and global SLA measurement.

2) Don't specify any rate or availability and unavailability states and the transition conditions.

Each has its advantage and disadvantage. They are two different approaches. Some like to buy a car with ABS some like to buy a car without ABS which are cheaper.

In fact it would have been much easier for us to not specify any rate, availability and state diagrams in Y.1711 and reduce it to only 2-3 pages.

-Shahram

> -----Original Message-----
> From: Eric Gray [mailto:[email-masked]]
> Sent: Thursday, March 21, 2002 12:01 PM
> To: Shahram Davari
> Cc: 'Thomas D. Nadeau'; 'George Swallow'; [email-masked]'
> Subject: Re: Y.1711 requirements from IETF
> 
> 
> Shahram,
> 
>     Speaking strictly as an individual, I do not understand what your 
> reasons
> are for being quite so immovable on this topic.  Can you 
> explain why it 
> is that
> you feel it is so important to use (or at least not to change) the 
> current words?
> 
> You wrote:
> 
> >Sure, but then what is your fault detection time scale, and 
> how do you measure availability SLA?
> >
> >-Shahram
> >
> >>-----Original Message-----
> >>From: Thomas D. Nadeau [mailto:[email-masked]]
> >>Sent: Thursday, March 21, 2002 11:17 AM
> >>To: Shahram Davari
> >>Cc: 'George Swallow'; [email-masked]'
> >>Subject: RE: Y.1711 requirements from IETF 
> >>
> >>
> >>
> >>         Well, you MAY LSP ping all of those FECs if you wish and at
> >>whatever rate you (i.e.: an operator) feels comfortable with. No one
> >>is "strongly suggesting" that you do so at 1 packet per second.
> >>
> >>         --Tom
> >>
> >>
> >>>But the same is true for MPLS-ping. You also need to ping 
> >>>
> >>all those FECs.
> >>
> >>>-Shahram
> >>>
> >>>>-----Original Message-----
> >>>>From: George Swallow [mailto:[email-masked]]
> >>>>Sent: Wednesday, March 20, 2002 5:59 PM
> >>>>To: Shahram Davari
> >>>>Cc: 'Thomas D. Nadeau'; [email-masked]'; [email-masked]
> >>>>Subject: Re: Y.1711 requirements from IETF
> >>>>
> >>>>
> >>>>>Where did you get this " ALL LSPs MUST" statement from? May
> >>>>>
> >>>>be you are
> >>>>
> >>>>>reading a different Y.1711 than I have. All I can find are
> >>>>>
> >>>>the following
> >>>>
> >>>>>statement:
> >>>>>
> >>>>>" ... It is strongly recommended that CV OAM packets be
> >>>>>
> >>>>generated on all LSPs
> >>>>
> >>>>>(in order to detect all defects and potentially provide
> >>>>>
> >>>>protection against
> >>>>
> >>>>>traffic leakage both in and out of LSPs). "
> >>>>>
> >>>>I have one customer providing an IP VPN service who has >1500 PE
> >>>>routers and probably well over a million LSPs.  Most of the LSPs
> >>>>represent VPN connectivity can carry very little traffic.
> >>>>
> >>>>Would you "strongly recommend" that CV OAM packets be 
> >>>>
> >>generated on all
> >>
> >>>>their LSPs at a rate of 1 per second?  Can you point to *any*
> >>>>currently deployed network other than those using MPLS solely for
> >>>>traffic engineering where this would be a good idea?  If 
> >>>>
> >>I'm carrying
> >>
> >>>>the full internet routing table and using LDP downstream 
> >>>>
> >>unsolicited
> >>
> >>>>should every router generate 108,000 (the current number 
> >>>>
> >>of routes) CV
> >>
> >>>>OAM packets per second?
> >>>>
> >>>>Perhaps you should revisit this "strongly recommended"
> >>>>recommendation.  Perhaps you should provide for 
> >>>>
> >>generation of CV OAM
> >>
> >>>>packets at rates other than 1  second.
> >>>>
> >>>>...George
> >>>>
> >>>>==================================================================
> >>>>George Swallow       Cisco Systems                  (978) 497-8143
> >>>>                     250 Apollo Drive
> >>>>                     Chelmsford, Ma 01824
> >>>>
> >>
> >>
> >>--------------------------------------------------------------
> >>----------
> >>Mathematics is the supreme nostalgia of our time. 
> >>
> >
> >
> 
> 
>

---

From: Eric Gray <[email-masked]>
Date: Thu, 21 Mar 2002 12:19:12 -0500

Shahram,

    Ah!

    I understand that it can be quite frustrating to realize that you
could have done less work.  Might it not be easier in the long
run to revert to the simpler version?