Subject: Tag-switching mtu doubt

From: Rui Francisco Negrão Valente<[email-masked]>
Date: Thu, 14 Mar 2002 16:54:15 -0000

Hi all,
 
Imagine the following VPN scenario:
 
CE----PE---P---P---PE----CE 
 
I have FastEthernet in all the links, and tag-switching mtu 1508 at the PEs
and Ps interfaces.
 
Due to the label stacking(2 labels) we have additional 8 bytes in the MTU
size. So, at the CPE the maximum datagram size I can send is 1500 (What I
did was pings with 1500 and with the DF=1). 
 
My question is:
 
Why pings fail with datagram size of 1504 from PE to PE?
 From what I understand there will be only one label (4 bytes) pushed in the
packet, therefore the mtu size will be 1508...
 
Thanks in advance,
Rui Valente
DRE-SE Vodafone(Portugal)
Tel: +351210914085
Mob: +351919513001
[email-masked] <mailto:[email-masked]> 

---------- 
This message may contain confidential information or privileged material,
and is intended only for the individual(s) named. If you are not in the
named addressee you should not disseminate, distribute or copy this e-mail.
Please notify the sender immediately by e-mail if you have received this
e-mail by mistake and delete this e-mail from your system. 
E-mail transmission cannot be guaranteed to be secure or error-free as
information could be intercepted, corrupted, lost, destroyed, arrive late or
incomplete, or contain viruses.  The sender therefore does not accept
liability for any errors or omissions in the contents of this message which
arise as a result of e-mail transmission. If verification is required please
request a hard-copy version.

---

From: Ajay Simha <[email-masked]>
Date: Thu, 14 Mar 2002 13:10:03 -0500 (Eastern Standard Time)

On Thu, 14 Mar 2002, Rui Francisco Negrão Valente wrote:

This is a Cisco specific question let us take it ofline...

-ajay
RFNV>
RFNV>Hi all,
RFNV>
RFNV>Imagine the following VPN scenario:
RFNV>
RFNV>CE----PE---P---P---PE----CE
RFNV>
RFNV>I have FastEthernet in all the links, and tag-switching mtu 1508 at the PEs
RFNV>and Ps interfaces.
RFNV>
RFNV>Due to the label stacking(2 labels) we have additional 8 bytes in the MTU
RFNV>size. So, at the CPE the maximum datagram size I can send is 1500 (What I
RFNV>did was pings with 1500 and with the DF=1).
RFNV>
RFNV>My question is:
RFNV>
RFNV>Why pings fail with datagram size of 1504 from PE to PE?
RFNV> From what I understand there will be only one label (4 bytes) pushed in the
RFNV>packet, therefore the mtu size will be 1508...
RFNV>
RFNV>Thanks in advance,
RFNV>Rui Valente
RFNV>DRE-SE Vodafone(Portugal)
RFNV>Tel: +351210914085
RFNV>Mob: +351919513001
RFNV>[email-masked] <mailto:[email-masked]>
RFNV>
RFNV>
RFNV>----------
RFNV>This message may contain confidential information or privileged material,
RFNV>and is intended only for the individual(s) named. If you are not in the
RFNV>named addressee you should not disseminate, distribute or copy this e-mail.
RFNV>Please notify the sender immediately by e-mail if you have received this
RFNV>e-mail by mistake and delete this e-mail from your system.
RFNV>E-mail transmission cannot be guaranteed to be secure or error-free as
RFNV>information could be intercepted, corrupted, lost, destroyed, arrive late or
RFNV>incomplete, or contain viruses.  The sender therefore does not accept
RFNV>liability for any errors or omissions in the contents of this message which
RFNV>arise as a result of e-mail transmission. If verification is required please
RFNV>request a hard-copy version.
RFNV>

--