Subject: TE-mib - flags for Local protection available/in use per ARHops

From: "Sandeep B" <[email-masked]>
Date: Thu, 07 Mar 2002 21:53:11 +0000

To the authors of TE-MIB.

I think in ARHops there is a need to add local protection available/in use 
flag per Hop.

Comments??

Sandeep

_________________________________________________________________
Join the world’s largest e-mail service with MSN Hotmail. 
http://www.hotmail.com

---

From: "Arumugamr" <[email-masked]>
Date: Fri, 8 Mar 2002 11:21:20 +0530

One more question on the Session Attribute flags defined in the TE-MIB.

RFC3209- RSVP-TE session attributes carry flags for the following
1. Local protection desired.
2. Label recording desired
3. SE style desired.

Wherein the appropriate mappings are not present in the TE-MIB.

In the te-mib-03 draft the following bits provided mapping as.

ingressMayReroute (0)                                  - maps to SE Style
desired.
This flag indicates that the tunnel
ingress node may choose to reroute this tunnel
without tearing it down

localProtectionAvailable (3)   -                       Local protection
desired.
This flag permits
        transit routers to use a local repair mechanism
        which may result in violation of the explicit
        routing of this tunnel. When a fault is
        det4ected on an adjacent downstream link or
        node, a transit router can reroute traffic for
        fast service restoration.

But from te-mib-04 onwards the two bits mentioned in te-mib-03 has been
merged to

fastReroute This flag indicates that the any tunnel
          hop may choose to reroute this tunnel without
          tearing it down.  This flag permits transit routers
          to use a local repair mechanism which may result in
          violation of the explicit routing of this tunnel.
          When a fault is detected on an adjacent downstream
          link or node, a transit router can reroute traffic
          for fast service restoration.

Can we take it granted that the setting of fastReroute bit directly maps to
the SE style desired
and Local Protection desired. or else extensions will be added.

Also there is no bits value defined for the Label recording desired. Will it
be added.

Comments please.

Regards
Arumugam

----- Original Message -----
From: "Sandeep B" <[email-masked]>
To: <[email-masked]>
Sent: Friday, March 08, 2002 3:23 AM
Subject: TE-mib - flags for Local protection available/in use per ARHops

> Join the world's largest e-mail service with MSN Hotmail.
> http://www.hotmail.com
>