Subject: RE: QoS for BGP/MPLS VPNs in 2547bis

From: Shahram Davari <[email-masked]>
Date: Sun, 10 Mar 2002 10:26:14 -0800

Robert,

Diffserv packets of the same BA share the same FIFO. Also packets from customers may arrive in burst. This means that even though the BW assigned to a BA FIFO could be designed to be less than the aggregate of the BW of all customers for that class, but a number of customers' traffic could potentially cause the packets from other customers to get dropped due to insufficient space in the queue. The only solution is to have very very deep FIFOs at all nodes or to shape at every node, which BTW does not 100% rectify the situation, but it could reduce such incidents. I haven't seen anybody shaping at every node, neither having very deep FIFOs.

Also any misconfiguration or failure of any of customer policers could have adverse effect on all customers. 

If there was per-customer queuing, then such behaviors would be virtually impossible to happen.

-Shahram 

> -----Original Message-----
> From: Robert[mailto:[email-masked]]
> Sent: Sunday, March 10, 2002 12:08 PM
> To: Shahram Davari
> Cc: Reddy, Vikram; 'Metz, Eduard'; [email-masked];
> [email-masked]; [email-masked]'; [email-masked]'
> Subject: Re: QoS for BGP/MPLS VPNs in 2547bis
> 
> 
> 
> > > Appling different QoS per VPN is a pretty bad idea in itself.
> > 
> > It may not be very scalable, but in fact I think one of 
> > the main requirements of VPN is to decouple the QoS of 
> > customers. Sonmething that probably requires per-customer queuing.
> > 
> > -Shahram
> 
> Well in almost all practical scenarios I met SP/ISP will not offer per
> customer queuing. Instead it will offer per customer's application
> queueing - the difference is very significant. And as an example it
> should not matter for customer A if his VoIP packets are 
> transported in
> the same diffserv pipe with VoIP packets belonging to 
> different customer
> B as long as both of them get what they have paid for.
> 
> Rgs,
> R.
>

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 10 Mar 2002 20:27:53 +0100

Well I have not seen VoIP bursting :) but you are right shaping is the
only cure. I guess it remains to be seen if shaping on each not is
really required versus shaping on ingress to the SP network only. 

Rgs,
R.

> Shahram Davari wrote: