Subject: RE: PHP

From: [email-masked]
Date: Thu, 18 Apr 2002 18:22:43 +0100

David, please see below. regards, Neil
> -----Original Message-----
> From: David Charlap [mailto:[email-masked]]
> Sent: 17 April 2002 22:04
> To: [email-masked]
> Subject: Re: PHP
> 
> 
> Sandeep B wrote:
> > 
> > You mention using 0x0800 as L3PID no matter what intermediate L2
> > protocol is carrying this traffic. Lets say we have a LDP session
> > running over another RSVP Session and this session is a VPN for a
> > frame relay circuit carrying IP traffic. Wouldn't we use a L3PID of
> > LDP-MPLS (0x8847) instead of IP for the RSVP session.
> 
> No.  When you tunnel one LSP through another, you should push a new
> label onto the label stack.  The labeled packet's payload is still IP.
NH=> This does not make any sense to me wrt XoverMPLS....where X can be FR,
ATM, ethernet or even SDH.  IMO a given LSP of level N should only care
about the immediate payload it carries.
<snipped to end>

---

From: David Charlap <[email-masked]>
Date: Thu, 18 Apr 2002 13:27:37 -0400

[email-masked] wrote:
> David Charlap wrote:
>>> frame relay circuit carrying IP traffic. Wouldn't we use a L3PID
>>> of LDP-MPLS (0x8847) instead of IP for the RSVP session.
>>
>> No.  When you tunnel one LSP through another, you should push a
>> new label onto the label stack.  The labeled packet's payload is
>> still IP.
>
> This does not make any sense to me wrt XoverMPLS....where X can be
> FR, ATM, ethernet or even SDH.

None of these are MPLS frames, so 0x8847 is still wrong.

-- David