Subject: Fast reroute - problematic scenario

From: "Doug Degan" <[email-masked]>
Date: Mon, 8 Apr 2002 12:14:35 +0300

After a protected primary LSP 'P' was established using bypass tunnel 'B' in a certain PLR -
(and signaling to the Ingress using the RRO that the LSP is protected there)
what will happen when shutting down tunnel X ? (manually or because of topology change/failures)

what about signaling to the Ingress?
what about PLR actions? - like trying to find another bypass.

thanks again 
doug

---

From: "Doug Degan" <[email-masked]>
Date: Mon, 8 Apr 2002 12:57:35 +0300

Ill try.
in the bypass method it is assumed that PLR choose from pre-established bypass enabled tunnels when getting request to establish a protected LSP.
then it signals back to the Ingress of the primary LSP that it is localy protected at this point.

now if the used bypass tunnel become not active (doesn't matter how) what should the PLR do?

1) to signal the Ingress that the primary protected LSP is not protected at this point? or not?
2) to try to choose another tunnel to be used as bypass? or not?
3) to send path error to the ingress for the protected LSP? or not?
4) to ignore the failure of the bypass LSP? 

thanks.
dd.
  ----- Original Message ----- 
  From: Jean Philippe Vasseur 
  To: Doug Degan 
  Cc: [email-masked] 
  Sent: Monday, April 08, 2002 12:24 PM
  Subject: Re: Fast reroute - problematic scenario

  Hi,

  At 12:14 08/04/2002 +0300, Doug Degan wrote:

  your question is not 100% clear. Could you elaborate ?

    thanks again 
    doug

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Mon, 08 Apr 2002 11:24:29 +0200

Hi,

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Mon, 08 Apr 2002 13:15:46 +0200

Hi,

At 12:57 08/04/2002 +0300, Doug Degan wrote:
>Ill try.
>in the bypass method it is assumed that PLR choose from pre-established 
>bypass enabled tunnels when getting request to establish a protected LSP.

correct.

>4) to ignore the failure of the bypass LSP?

Now this is a local decision. The PLR should certainly not ignore the 
failure of the BYPASS. We mentioned in the draft that the PLR mentions in 
the RRO whether the TE LSP is protected or not. Now the PLR behavior will 
depend on the implementation. A possible behavior could be for the PLR to 
look for another BYPASS tunnel and update the RRO appropriately to reflect 
the result.

JP.

>>From: <mailto:[email-masked]>Jean Philippe Vasseur
>>To: <mailto:[email-masked]>Doug Degan
>>Cc: <mailto:[email-masked]>[email-masked]