Subject: Fwd: Re: SE style in optical neyworks

From: Suresh Katukam <[email-masked]>
Date: Fri, 12 Apr 2002 15:03:46 -0700

>
>Tom and all,
>
>I think everyone seemed to pick on my terminology or misinterpreted
>what I said.
>
>Here is an example:
>
>          1+1                        1+1
>A ----------------B --------- C ------------D
>                      \          /
>                        \       /
>                           E
>
>
>A - B & C - D 1+1 line protected
>B - C, C - E, B - E are all unprotected links.
>
>Say, one wants to create a protected LSP from A to D.
>then, you would create one primary LSP from A to D via
>A - B - C - D, and then you would create another LSP
>from A to D using SE style ( to indicate that this is an
>alternate path for same Tunnel ) via A - B - E - C - D.
>This way B - C is protected by B - E - C.
>
>B - C - E is not configured as a UPSR. All unprotected links.
>Virtual UPSR can be created such a way that B has a bridge
>and C has a selector. Ofcourse, for bidirectional LSP, you need
>the same thing in the opposite direction too.
>
>Now, what do you call this kind of protection? Protected LSP?
>But not 1+1 path protected  - since it is not end-to-end path
>protected.
>
>To clarify again, this is when you would use SE style.
>
>Thanks
>Suresh
>
>
>At 01:17 PM 4/12/2002 -0400, Thomas D. Nadeau wrote:
>
>
>>>This can be used to set up Protected circuits which may contain
>>>1+1 lines and 1+1 path protected segments. So on 1+1 line
>>>protected segments, you Share the bandwidth among primary
>>>and alternate paths.
>>
>>         You do not share the bandwidth across 1+1 circuits. You
>>double-book the bandwidth because the same packets are
>>sent twice: once over each LSP.  You only share bandwidth
>>with 1:N.
>>
>>         --Tom
>>
>>
>>>Setting up protected circuits is not considered
>>>in detail so far. Hopefully, P&R design team will consider this..
>>>
>>>Thanks,
>>>Suresh
>>>
>>>At 04:32 PM 4/12/2002 +0530, Khuzema Pithewan wrote:
>>>>Hi,
>>>>
>>>>How does SE style of RSVP signalling fits in the optical nature of network
>>>>i.e. in wavelength, TDM switching etc.
>>>>
>>>>  In other words, How two lsp can share resource in optical networks??
>>>>
>>>>Regards,
>>>>Khuzema.
>>
>>
>>
>>------------------------------------------------------------------------
>>Mathematics is the supreme nostalgia of our time.

---

From: Zhi-Wei Lin <[email-masked]>
Date: Mon, 15 Apr 2002 09:41:18 -0400

Hi Suresh,

Sorry. Wasn't picking on terminology, anyway, some more comments below...

>> B - C, C - E, B - E are all unprotected links.
So this network you drew assumes a single point of interconnect at B and 
C...that's fine

>> This way B - C is protected by B - E - C. 
By creating a new LSP A-B-E-C-D, this circuit is completely separate 
from the original A-B-C-D circuit. There is no sharing at all. It is 
just incidental that they carry the same traffic (i.e., you just happen 
to have set up the A-B-E-C-D to carry the same traffic as in A-B-C-D). 
Again this is not merging (as represented by SE), unless you are 
re-defining what SE means...

>> the same thing in the opposite direction too.
Yes, just as the two LSPs making up the 1+1 from A-B are both 
unprotected LSPs, but taken together provide the 1+1 service. As such, 
if B-E-C is carrying the same traffic as B-C *all the time*, then it's 
still 1+1, but more specifically, it is a 1+1 SNC (sub-network 
connection). 1+1 doesn't necessary only apply to 1+1 path (when you say 
path, I think you mean trail? -- G.805 terminology).

However, if B-E-C is not carrying the same traffic, but may be used to 
support *extra traffic*, then this is a 1:1 type protection.

And if B-E-C LSP is actually supporting multiple LSPs going over B-C, 
then it's 1:N protection. However, note that even in this case it is 
still NOT SE, since the B-E-C LSP at any given time is only ever 
carrying one single traffic.

Hope this clarifies.

Zhi

---

From: Suresh Katukam <[email-masked]>
Date: Mon, 15 Apr 2002 09:54:02 -0700

Zhi, Sudheer and others,

Looks like this was lost in all other mails.. So please take a look
at this..

---

From: Jianwu HE <[email-masked]>
Date: Wed, 17 Apr 2002 00:00:48 -0700 (PDT)

Dr Lin,

In GMPLS architecture, TE Link is defined, and in G.8080(ASON), SNPP Link is defined.
I think TE Link and SNPP link have many same characteristics, all for routing. Can you 
described this problem in detail

Jianwu HE
[email-masked]
Beijing Univ.of Posts and Telecomm.

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/