Subject: 2547 questions . .

From: Vinod Jeyachandran <[email-masked]>
Date: Tue, 23 Apr 2002 09:15:01 -0400

(1) Does the BGP process on a PE maintain separate RIBs for each VRF 
configured? I guess BGP might need to do this even if it is not the PE-CE 
routing protocol

(2) Do any of the other PE-CE routing protocol (e.g., RIP, OSPF) processes 
maintain separate routing tables on the PE?

-Vinod

---

From: "Liu, Chia J (Charlie), ALCNS" <[email-masked]>
Date: Tue, 23 Apr 2002 10:02:47 -0400

> configured? I guess BGP might need to do this even if it is not the PE-CE 
	[Liu, Chia J (Charlie), ALCNS]  My understanding is, in addition to its own IP RIB, each VRF has its own CEF table, in Cisco implementation, to keep routing separate.   However, I am not sure whether there is a separate BGP table in VRF.

> maintain separate routing tables on the PE?
	[Liu, Chia J (Charlie), ALCNS]  In the case of OSPF, it requires separate OSPF process ID, different ID from that used for SP's IGP,  and VRF name, therefore, separate routing table. 

C.J. (Charlie) Liu
AT&T IP Network Architecture & Routing Planning