Subject: AW: initiating a discussion on mpls singaling protocols

From: Hummel Heinrich <[email-masked]>
Date: Tue, 23 Jul 2002 17:57:44 +0200

Eric,
So excuse me. I accept your notes.

But let me repeat my technical point:
Building hierarchical mp2p LSPs, from the egress towards a set of ingress nodes, i.e.
building a sink tree out of LSPs. 
Here downstream unsolicited mode is appropriate. So we need LDP. But because existing LSPs have to be concatenated
(by label switching) we need their LSP-IDs. And this is provided by CR-LDP.

It takes a lot more to create RSVP-TE Downstream Unsolicited mode.

Heinrich

-----Ursprüngliche Nachricht-----
Von: Gray, Eric [mailto:[email-masked]]
Gesendet: Dienstag, 23. Juli 2002 17:27
An: 'Hummel Heinrich'; 'avri'
Cc: MPLS wg
Betreff: RE: initiating a discussion on mpls singaling protocols

Heinrich,

	I don't think this is a fair characterization.

	Several draft authors have participated in work
to develop CR-LDP extensions who have no real interest
in CR-LDP.  This has been done - IMO - out of a sense
of responsible protocol development rather than out of
interest in progressing both signaling protocols.

	Perhaps this is what really needs to change.  If
a specific draft author only wishes to work with one 
signaling protocol, then he or she should be able to
simply do so.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Hummel Heinrich [mailto:[email-masked]] 
Sent: Tuesday, July 23, 2002 11:13 AM
To: 'avri'
Cc: MPLS wg
Subject: AW: initiating a discussion on mpls singaling protocols

Well spoken.
Additionally, all those who do not care for CR-LDP have hardly contributed
in the past nor will they contribute
in the future to extend routing protocols for the sake of CR-LDP. This sweat
is up to the CR-LDP supporters.
It is not honest to complain about the burden carried by the others.
Heinrich 

-----Ursprüngliche Nachricht-----
Von: avri [mailto:[email-masked]]
Gesendet: Dienstag, 23. Juli 2002 15:26
Cc: MPLS wg
Betreff: Re: initiating a discussion on mpls singaling protocols

This seems to me a very strange proposal.  And in fact seems to be
a perversion of the IETF standards process as i understand it.

If things are as argued, then RSVP-TE will progress to draft standard
and then to standard, while CR-LDP remains a proposed standard.  If
it languishes long enough in the proposed state, without significant
deployment or utility, then it would seem appropriate to transition it
to historic at some point in the future.

Taking it to informational at this point seems a fairly blatant political
move without technical merit.  At best it is an administrative sleight
of hand that could strange repercussions as a precedent.  Is the IETF
going to embark next on an effort to define all protocol duplication
out of existence by voting on which alternative to make informational?

I would suggest (as voting is not something I thought the IETF did) that
both protocols remain as ps. If CR-LDP withers on the vine because it has
no utility, so be it.  Voting to change its status seems inappropriate to
me.

a.

---

From: David Charlap <[email-masked]>
Date: Tue, 23 Jul 2002 12:46:04 -0400

> It takes a lot more to create RSVP-TE Downstream Unsolicited mode.

I think you are misunderstanding CR-LDP.  It doesn't support downstream 
unsolicited mode either.

-- David