Subject: RE: LDP Question

From: "Gray, Eric" <[email-masked]>
Date: Mon, 1 Jul 2002 17:25:44 -0400

Chetan,

	You are quite correct in saying that advertisement
and retention modes are not strictly tied to each other.
However, for reasons relating to the amount of overhead
associated with the combination of liberal retention and
DoD - or conservative retention and DU advertisement - 
it may be the case that implementations are optimized for
the combination of DU and liberal retention or DoD and 
conservative retention for practical reasons.

	Ideally, implementations will share this practical
perspective making it unnecessary to have to deal with a
peer that negotiates an impractical combination of modes. 

Eric W. Gray
[email-masked]

-----Original Message-----
From: Chetan Pinto [mailto:[email-masked]] 
Sent: Monday, July 01, 2002 3:52 PM
To: [email-masked]; [email-masked]
Subject: Re: LDP Question

>Hi,
>
>In RFC3036 section 2.6.2.2 says
>     When operating in Downstream on Demand mode with liberal label 
>retention,
>an LSR might choose to request label mappings for all known prefixes from
>all peer LSRs.
>
>   As per my understanding there won't be any restriction when we learn any
>routes from IP and we obtain the mappings by sending Label Request for all
>the learnt FEC's (FEC aggregation/without aggregation) if we find the 
>required
>session/adjacenecy with the peer. So DoD acts as liberal in nature.......

Let us try to keep the "advertisement mode" and the "retention method"
separate. You can have a combination of DoD or DU with
Liberal or Conservative retention. Hence, DoD cannot be liberal by itself.

>
>   Does this mean any filtering is done for achieving conservative in DoD 
>or
>am I missing something........
If u are using DoD on a particular interface:
If using liberal retention, request labels for all FECs even
if the LDP peer is not a next hop for all FECs
If using Conservative retention, request labels for only those
FECs which u deem the LDP peer is the next hop.
This is the kind of filtering you would be talking about
The filter would in fact be the "match" of "LDP peer" for "FEC next hop"

chetan

_________________________________________________________________
Join the world's largest e-mail service with MSN Hotmail. 
http://www.hotmail.com

---

From: "Mahesh kumar S" <[email-masked]>
Date: Tue, 2 Jul 2002 12:27:18 +0530

Hi,

When you are saying that
"If using liberal retention, request labels for all FECs even
if the LDP peer is not a next hop for all FECs"

In DOD case:-

LDP queries the routing table for FECs. The routing table
only has the best route. ( There can't be multiple best routes except
in the case of equal cost multipath). As a result of this only one
request can be sent and hence only one mapping will exist.
So how does liberal come into play for DOD.

Thanks,
Maheshkumar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Gray,
Eric
Sent: Tuesday, July 02, 2002 2:56 AM
To: 'Chetan Pinto'
Cc: [email-masked]; [email-masked]
Subject: RE: LDP Question

Chetan,

Eric W. Gray
[email-masked]

-----Original Message-----
From: Chetan Pinto [mailto:[email-masked]]
Sent: Monday, July 01, 2002 3:52 PM
To: [email-masked]; [email-masked]
Subject: Re: LDP Question

chetan

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************