Subject: Notification process

From: Atul Gupta <[email-masked]>
Date: Tue, 23 Jul 2002 23:58:37 -0700 (PDT)

Hi,
In GMPLS we use Notification Message to avoid the
large propagation delays of the error messages. Can we
use same message in MPLS so that existing Path/Resv
States can be removed quikly and resources are also
preserved.
Atul
Samsung

=====
Atul Gupta
Samsung Software

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 24 Jul 2002 17:19:27 -0400

Atul,

It would not be very efficient to use the Notification message
of GMPLS to remove Path/Resv states in MPLS (or GMPLS).
The primary purpose of the Notification message is to get error
information to the point/node responsible for taking an action
(such as a restoration action) in response to that error/fault.

The removal of the states (even when using GMPLS)
is still handled by normal RSVP processes,
which remove state systematically (hop-by-hop) [and free up resources]
from all of the intermediate nodes on a LSP.

To do the same with a Notification message, you'd probably have to
send a series of Notification messages (since it is a targeted message)
one each to every intermediate node on the LSP, instructing them to
remove state!

-Vishal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Atul
> Gupta
> Sent: Wednesday, July 24, 2002 2:59 AM
> To: [email-masked]
> Subject: Notification process
> 
> 
> Hi,

---

From: Atul Gupta <[email-masked]>
Date: Wed, 24 Jul 2002 23:11:06 -0700 (PDT)

Vishal,

Well sending the Notifications to all upstream nodes
may not help much(If the Idea is not only to remove
the State) because the new PATH request has to come
from Ingress/Initiator.
What if the Notify Message send to the
Ingress/Initiator starts sending the PathTear
downstream and the failure detection point start
tearing the Path State upstream. The two together will
remove the existing PATH and help establishing the new
PATH again quickly.
Although we can use GMPLS over PSC, but the Idea above
is only to modify MPLS for fast convergence, for big
LSP. 

--- Vishal Sharma <[email-masked]> wrote:
> > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Atul
> > Gupta

=====
Atul Gupta
Samsung Software