Subject: RE: initiating a discussion on mpls singaling protocols

From: "Jothilingam, Vasudevan (Vasu)" <[email-masked]>
Date: Wed, 24 Jul 2002 14:22:03 -0400

Going back to the question of making CR-LDP informational RFC.

First, I stronlgy support the thought that ,the Industry should evolve to
One Signaling protocol. At this economy it is costly to develop two
competing protocols. Also, extending the protcols to do other applicatons
will also double the work load on research and implementation.

Having multiple protocols to do single Application will lead us into the
same problem of OSPF or ISIS. 
Now that we are in that trap, that every extension we do, we need to do both
IGPs.

I would like to say, yeah RSVP-TE is the way adn CR-LDP could be
informational RFC.
Being said that, there is lots of work going of L2 Transportation over MPLS,
using LDP.
Well, even though I am not for that approach of using RSVP-TE and LDP ( two
big protocols ??)
for L2 transport, we need to see where that goes..

Thanks
Vasu

Vasu Jothilingam
Lucent Technologies
1 Robbins Rd
Westford, MA-01886
PH:   (978)-952-7533
FAX: (978)-952-7977

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]]
Sent: Wednesday, July 24, 2002 2:00 PM
To: 'David Charlap'; IETF MPLS List
Subject: RE: initiating a discussion on mpls singaling protocols

Hi David,

Actually, SCTP is an alternative that supports message
passing and boundary preservation, plus other features
for reliability and detection of signaling path failure.
It was intended to relieve the application from having to
do continual verification of the signaling path and support
of a backup path.  However, it was being defined at about
the same time as MPLS, so it was never considered as an
alternative for transport of MPLS signaling.  

A reliable UDP was one of the alternatives considered when doing
SCTP, but it still leaves the application to do testing
of the signaling path and message rerouting if that fails, 
and does not have congestion control built in.

Cheers,

Lyndon

-----Original Message-----
From: David Charlap [mailto:[email-masked]]
Sent: Wednesday, July 24, 2002 7:45 AM
To: IETF MPLS List
Subject: Re: initiating a discussion on mpls singaling protocols

As for the rest, TCP is not an appropriate transport for signaling 
protocols in the first place.  RSVP-TE, LDP and CR-LDP all use a 
message-passing mechanism.  They are not designed around streaming data. 
  Use of a streaming protocol means that the protocol has to deal with 
the issue of detecting message boundaries and half-received messages.

Unfortunately, there is no standard for anything resembling reliable UDP 
- that would be ideal.

---

From: Giles Heron <[email-masked]>
Date: 24 Jul 2002 19:48:34 +0000

On Wed, 2002-07-24 at 18:22, Jothilingam, Vasudevan (Vasu) wrote:
[snip]
> Being said that, there is lots of work going of L2 Transportation over MPLS,

LDP != CR-LSP

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================