Subject: Handling of ipv4 packets that are too big

From: "Mayank Kumar" <[email-masked]>
Date: Tue, 9 Jul 2002 18:19:02 +0530

hi

Can any body tell me of the issues involved in providing both the
functionalities of LER and LSR in an MPLS router.
Other than the support required for ILM and there processing , what other
issues are to be dealt with???
Also please somebody tell if there are implementations from mpls vendors of
mpls routers where only the lsr or the ler functionality has been implmented
??

thanks and regds

Mayank

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 9 Jul 2002 09:26:42 -0400

Mayank,

If a router has at least one MPLS interface and at 
least one non MPLS interface which it can route
between, it has LER functionality.  Any non MPLS
interface over which IP packets may be sent (such
as a local drop) qualifies.

The simplest example of a strict LER implementation
is one which has only one MPLS capable interface (it
might be an uplink, for example).  An LER might have 
more than one MPLS capable interface if it is not 
able to route between them.  Otherwise, it is also
an LSR.

If a router has two or more MPLS interfaces which it
can route between, it has LSR functionality. 

The simplest example of a strict LSR is one which has
two MPLS interfaces and no non MPLS interfaces.  Such
a device is of doubtful utility.

Hence, most boxes will incorporate both LER and LSR
functionality, depending on installed interfaces. 

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Mayank Kumar [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2002 8:49 AM
To: Mpls (E-mail)
Subject: Handling of ipv4 packets that are too big

hi

thanks and regds

Mayank