Subject: RE: your mail

From: "Gray, Eric" <[email-masked]>
Date: Tue, 2 Jul 2002 15:36:52 -0400

Eric,

	To answer your final two questions, yes it probably
is stealing.  The fact that you can get away with a crime
does not make it any less a crime.  Who knows, some vendors 
may not check that the protocol over the top of IP is either 
UDP or TCP before using the port numbers.  I think you can 
easily imagine what that might lead to if a set of packets 
carry a higher level protocol where the corresponding fields 
may vary from packet to packet in a single micro-flow.  The
real question is how common is this?

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Eric Osborne [mailto:[email-masked]] 
Sent: Tuesday, July 02, 2002 1:32 PM
To: Hummel Heinrich
Cc: [email-masked]'; Shahram Davari; 'Eric Osborne'; George Sheng;
[email-masked]; [email-masked]
Subject: Re: your mail

On Tue, Jul 02, 2002 at 04:25:37PM +0200, Hummel Heinrich wrote:
> It  gets weirder  and weirder: The MPLS WG invents a label stack, but does
not care at all that any of the
> deeper nested labels may ever be signalled/carried by means of a
Label-TLV/object (no public comments to my
> Hierarchical LSPs, draft-hummel-mpls-hierarchical-lsp-01.txt).
> 
> However it is ok, to "steal" the deepest nested label and call it
"VC-label" for indexing
> some VRF at some remote PE. 

This is not theft; it's using the labels as they were designed.  How
is using the bottommost label as a VC-labe/VPN label/whatever
"stealing"?  You seem to be attacking the very idea of label stacking,
which is a pretty useful concept.

> Furthermore it is ok, to "steal" the very same label for hashing.
> 

What about IP router vendors that do load-balancing based on L4/L5
information like protocol type and port numbers?  Is that stealing?

eric

> Independent from what is clean and what is quick&dirty, I cannot detect
any sense in giving a hash-meaning to the bottom label at all.
> 
> 
> 
> Heinrich Hummel
> Siemens
> 
> -----Ursprüngliche Nachricht-----
> Von: Eric Rosen [mailto:[email-masked]]
> Gesendet: Dienstag, 2. Juli 2002 16:06
> An: Shahram Davari
> Cc: 'Eric Osborne'; George Sheng; [email-masked]; [email-masked]
> Betreff: Re: your mail 
> 
> 
> Shahram> To do ECMP, you need to  assign hashed values to egress ports.
This
> Shahram> assignment is the hash state that I said you need.  
> 
> A hash is  a function that maps  some sequence of octets into  a sequence
of
> integers.  If you want to split  traffic over six paths, while ensuring
that
> all packets  with the  same bottom label  travel the  same path, you  need
a
> function that maps  a 20 bit quantity  into a number from 1-6.   There is
no
> need to maintain state of any kind.

---

From: Eric Osborne <[email-masked]>
Date: Tue, 2 Jul 2002 16:23:41 -0400

On Tue, Jul 02, 2002 at 03:36:52PM -0400, Gray, Eric wrote:
> UDP or TCP before using the port numbers.  

If a vendor checks the offset where the port numbers should be without
checking for the correct protocol type, this is a cruddy
implementation and shouldn't exist.  My question was really along the
lines of "what if we use the values that we *know* are UDP/TCP port
numbers"?  From what you say above, it seems like that might be OK, as
long as we only do this when we're sure?  Or is there some inherent
architectual layer violation thing that you're objecting to?

eric

> I think you can