Subject: AW: initiating a discussion on mpls singaling protocols

From: Hummel Heinrich <[email-masked]>
Date: Mon, 29 Jul 2002 18:16:40 +0200

Note, my mentioning of " the  groups of sites" is just an initial thought. But if you have attended the
elementary classes of the PNNI-school, you will be confident that this goal can be achieved:-)
Heinrich

-----Ursprüngliche Nachricht-----
Von: Shahram Davari [mailto:[email-masked]]
Gesendet: Montag, 29. Juli 2002 18:06
An: 'Hummel Heinrich'; 'Giles Heron'; [email-masked]
Cc: [email-masked]
Betreff: RE: initiating a discussion on mpls singaling protocols

Ok, my mistake.

-Shahram

> -----Original Message-----
> From: Hummel Heinrich [mailto:[email-masked]]
> Sent: Monday, July 29, 2002 12:04 PM
> To: Shahram Davari; 'Giles Heron'; [email-masked]
> Cc: [email-masked]
> Subject: AW: initiating a discussion on mpls singaling protocols
> 
> 
> NO, the savings are much more. They are about 85 % reduction, 
> so that 15 % remains.( I will not talk down these savings)
> However, 0.15  * O(n**2) will still be far too much, if n is 
> big enough.
> 
> Note that method (4) as of 
> draft-hummel-mpls-n-square-investigations-00.txt also uses 
> merging H-LSPs as to reduce the
> costs at the PEs, e.g. down to 0.15 * O(n**2). 
> 
> But I also pointed out that even this is not good enough, if 
> n = 7500 for example. For VPNs of such size, we should even 
> form groups of sites (e.g. all sites within one city form a group)
> and may have:
> a) a partial mesh of elementary LSPs (which form a tree, a 
> ring, a ring of trees, a tree of rings,or a chessboard grit)
> b) a full mesh of hierarchical LSPs between the groups of sites
> c) a full mesh of hierarchical LSPs between the sites of each 
> group of sites
> 
> In order to accomplish effective full mesh connectivity, it 
> may be appropriate to advertise all these LSPs (their ingress
> and their egress, as well as their starting labels, etc.) - 
> roughly spoken.
>  
> Of course it will take more labor, more conceptual thinking. 
> E.g. so that the VC-label handling is integrated rather than
> an "abuse" :-)
> 
> 
> Heinrich
> 
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: Shahram Davari [mailto:[email-masked]]
> Gesendet: Freitag, 26. Juli 2002 17:15
> An: 'Giles Heron'; [email-masked]
> Cc: [email-masked]
> Betreff: RE: initiating a discussion on mpls singaling protocols
> 
> 
> Giles,
> 
> > 
> > I want *both* mp2p LDP and targetted LDP.
> > 
> > I want the former because it:
> > 
> > 1) minimises the number of labels required in the core - O(N) rather
> > than O(N squared).
> > 
> 
> I think Heinrich Hummel demonstrated in the Japan (as 
> predicted by Dave Allan)
> that mp2p (LDP) results only ~15% less states than N^2 mesh. 
> 
> -Shahram 
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 29 Jul 2002 18:41:55 +0200

All,

it seems like this discussion, though related, now has deviated enough
from what was originally intended with this thread, could you please
change the subject line

-- 
     Loa Andersson
     Chief Architect,
     Utfors Research, Architecture and Future Lab (URAX)
     Utfors AB
     Råsundavägen 12
     Box 525, 169 29 Solna
     Office          +46 8 5270 2000
     Office direct   +46 8 5270 5038
     Mobile          +46 70 848 5038
     Email           [email-masked]
     WWW             www.utfors.se