Subject: mplsIngressLsrId in MPLS TE MIB

From: "Szymanski, Pawel" <[email-masked]>
Date: Mon, 22 Jul 2002 15:00:36 +0200

Hi,

I have two questions concerning mplsIngressLsrId in MPLS TE MIB:

1) The mplsTunnelTable vriable is defined as MplsLsrIdentifier.
This type is defined in MPLS TC MIB as 4-octets string.
Description for the variable says that for RSVP-TE it should mimic Extended
Tunnel ID field. 
However if RSVP-TE for IPv6 is used, the field is 16-bytes long. 
It seems to me that the MplsLsrIdentifier definition shall be extended.

2) Is it permissible to set mplsIngressLsrId variable on the ingress router
to value other than local LSR ID or 0 ?

Thanks in advance,

Pawel Szymanski
Software Engineer at Intel Technology Poland
mailto:[email-masked]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 24 Jul 2002 13:19:42 -0400

Dzien dobry Pawel,

>It seems to me that the MplsLsrIdentifier definition shall be extended.

         We are addressing this during the MPLS MIB's MIB Doctor review.

>to value other than local LSR ID or 0 ?

         The values taken by this object should reflect the Extended Tunnel 
Id field in
the RSVP-TE Session object.

         Dziekuja,

         --Tom

>mailto:[email-masked]

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.