Subject: RE: initiating a discussion on mpls singaling protocols

From: "Gray, Eric" <[email-masked]>
Date: Mon, 22 Jul 2002 15:50:18 -0400

Loa,

	An amusing thread.  I'm not sure whether the
topic was actually a typo, or a mental transmission
'slip' resulting in the "MPLS sing-along" it seems
to have inspired.  :-)

	I am not sure that Informational is the right 
way to go.  Perhaps Experimental or Historical is
better.

	I think it is important to understand exactly
what is intended by this proposal.  As I understand 
it, making one of the two proposals informational is 
intended to reduce the effort required to implement 
MPLS and to reduce the work needed to make additional 
signaling extension proposals into standards.  These 
are more concrete 'corollary' effects of the abstract 
goal of having a single 'standard' signaling approach.  

	Reducing effort is good.

	However, changing a Proposed Standard to an 
Informational RFC seems unprecedented.  Does anyone
know of a precedent for this?  Hasn't it previously 
been the case that - once we have decided not to treat 
a proposed standard as a standard any more - we change 
it to an Historical (or Experimental) RFC?  If this has 
been done before, how well did it work that time?

	One reason for choosing to go the Informational
route is because we would like to focus on development 
of standards, implementations and deployment of a single 
MPLS signaling protocol (RSVP-TE) without necessarily 
preventing parallel development (CR-LDP) as non-standard, 
information only, effort.  Will it actually work this 
way, or will we still have to read drafts in the MPLS 
(and/or) CCAMP working groups for these parallel efforts?  

	It seems likely that these efforts will continue.  

	Are we saying - as a working group - we will no 
longer need to concern ourselves with CR-LDP related 
work?  If so, then we should make this intention clear.
We will also have to do some work to make this happen,
since we will have to define how IANA allocates numbers
for CR-LDP extensions without WG participation (currently,
IETF consensus action is required - which generally means
WG participation).

	If the WG continues to need to be involved, then simply 
declaring CR-LDP to be Informational doesn't change anything 
in any useful sort of way.  It won't change who implements it, 
it won't change who deploys it and it won't change who has to 
work on it in the IETF.

	If the real goal is to simply make the intentions of
the IETF clearer, then I believe is accomplished better by
making CR-LDP a (set of) Experimental RFC(s).

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]

P.S. - not responding to Robert - his was just the
last post that seemed to stick to the topic.

-----Original Message-----
From: Robert Raszuk [mailto:[email-masked]] 
Sent: Monday, July 22, 2002 9:08 AM
To: Loa Andersson
Cc: Hummel Heinrich; [email-masked]
Subject: Re: initiating a discussion on mpls singaling protocols

Hi Loa,

You can add my vote:

CRLDP experiment to be declared informational, RSVP-TE proceeds on
standards track. 

R.

> Loa Andersson wrote:
> 
> Heinrich,
> 
> in my opinion the question is very clearly stated - is there support for
> us (the ietf) to move the cr-ldp from standard track to informational.
> We're "speaking for the ietf", it is more a matter of what we say ;)
> 
> All,
> 
> As usual we are trying to reach a rough consensus. Everyone (i.e. the
> mpls wg) can help create this consensus by answering the question
> above.
> 
> Especially it will be helpful if you were involved in specifying the
> mpls protocols, have implemented or deployed (SP) those protocols, and
> take the time to respond.
> 
> I will be ready to give the first extensive tally mid this week.
> Currently the count is
> yes: 30 no: 7,
> if you normalize those e.g. by counting each company once it is
> yes: 21 no: 4
> 
> Disclaimer: Given that I've managed to decipher the sometimes cryptic
> mails correctly :o)
> 
> /Loa
> 
> Hummel Heinrich wrote:
> 
> >  I think, the IETF can only speak for itself. There may be other
standardization
> 
> >bodies (ITU-T, MPLS Forum) which may fill
> > the gap.
> >
> > Heinrich Hummel
> > Siemens AG
> >
> 
> --
>      Loa Andersson
>      Chief Architect,
>      Utfors Research, Architecture and Future Lab (URAX)
>      Utfors AB
>      Råsundavägen 12
>      Box 525, 169 29 Solna
>      Office          +46 8 5270 2000
>      Office direct   +46 8 5270 5038
>      Mobile          +46 70 848 5038
>      Email           [email-masked]
>      WWW             www.utfors.se

---

From: Loa Andersson <[email-masked]>
Date: Mon, 22 Jul 2002 23:58:00 +0200

Eric,

sorry - it would have been funier if it hadn't been a typo,
but when it comes to my spelling it gave my teachers gray
hair already in school, and it has become a lot worse
since ...

/Loa

     Loa Andersson
     Chief Architect,

---

From: "Sumit Garg" <[email-masked]>
Date: Tue, 23 Jul 2002 08:59:53 -0400

Hi

I lean towards not making the CR-LDP spec informational.  My objections
(none really technical, more political i.e. too premature to kill -9
CR-LDP etc.) are summed up by Eric Gray, Stephen Shew, Soumen Sarkar and
others that I miss.

To add to the list of other bodies using CR-LDP - MPLS Forums uses a
CR-LDP derivative for the MPLS UNI spec.

Regards
/Sumit

---

From: Zafar Ali <[email-masked]>
Date: Tue, 23 Jul 2002 10:20:28 -0400

>CR-LDP derivative for the MPLS UNI spec.

Please see my reply to Stephen's email, on the same (non)argument.

Thanks

Regards... Zafar