Subject: RE: your mail

From: "Naidu, Venkata" <[email-masked]>
Date: Tue, 2 Jul 2002 14:49:26 -0400

Vach,

-> For ECMP, you have to look at least one label lower (or more 
-> precisely, one layer higher).

  Why? It is very difficult to look at the payload of MPLS
  packets the way the encapsulations are defined.
 
  So, a router trying to do load balancing have to know
  the X in XoverMPLS (all the PPP exts, LLC encapsulations RFCs etc).
  Very unrealistic...

  Why can't we do something simple like this:

	If I know what the LSP semantics are, then I enable
      load balancing on that LSP - with or with out hashing.
      With out hashing, I do simple round robin 1 to N 
      scheduler (no state, nothing). Even weighted round
      robin also you can do.

	The semantics for that LSP can be:
	- don't worry about out-of-order packets (higher layers
 	  will take care of it)
	- don't worry about X in XoverMPLS - don't even look
	  at it.
      - don't do ECMP if EXP bits are set
	etc etc...

  Why are you thinking that load balancing or ECMP is 
  a router option. You can have it as per LSP option as well.
  Just like ECMP for per destination address/flow.

  When we know what we are doing then the problems will be minimal.

  Do you agree?

--
Venkata.

---

From: Giles Heron <[email-masked]>
Date: 02 Jul 2002 20:24:07 +0000

>   the X in XoverMPLS (all the PPP exts, LLC encapsulations RFCs etc).
[rest snipped]

To a router in the core "one layer higher" means the VC label (for the
XoverMPLS case).  This has MPLS label syntax so the router should be
able to parse it :)

Whilst to a router at the edge (i.e. on ingress) the X will be known.

If there is only one label at the core then it is pretty much a given
that you are doing IP over MPLS (the only exception I know to this only
works with RSVP-TE assigned labels).  In this case you can use standard
IP load balancing techniques.

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================