Subject: RE: AW: your mail

From: "David Allan" <[email-masked]>
Date: Tue, 2 Jul 2002 14:00:23 -0400

Tissa:

I think we need to be a bit stricter. Define mis-ordering...at what
granularity ;-). Similarly any path test tool (e.g. ICMP) must follow the
same path as the traffic.

cheers
Dave

> -----Original Message-----
> From: Tissa Senevirathne [mailto:[email-masked]]
> Sent: Tuesday, July 02, 2002 1:48 PM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: AW: your mail
> 
> 
> Why are we saying ECMP hash is to pick a number between 1 and 
> 6 ? Why not 64 
> ?
> 
> In my opinion ECMP is entirely a local implementation issue. 
> And at WG 
> requirement level one sentence to say
> " Any load balancing policies implemented MUST not mis order packets"
> is adequate
> 
> 
> >From: Hummel Heinrich <[email-masked]>
> >To: "[email-masked]'" <[email-masked]>,        Shahram Davari 
> ><[email-masked]>
> >CC: "'Eric Osborne'" <[email-masked]>,        George Sheng 
> ><[email-masked]>, [email-masked],        [email-masked]
> >Subject: AW: your mail Date: Tue, 2 Jul 2002 16:25:37 +0200
> >
> >It  gets weirder  and weirder: The MPLS WG invents a label 
> stack, but does 
> >not care at all that any of the
> >deeper nested labels may ever be signalled/carried by means of a 
> >Label-TLV/object (no public comments to my
> >Hierarchical LSPs, draft-hummel-mpls-hierarchical-lsp-01.txt).
> >
> >However it is ok, to "steal" the deepest nested label and call it 
> >"VC-label" for indexing
> >some VRF at some remote PE. Furthermore it is ok, to "steal" 
> the very same 
> >label for hashing.
> >
> >Independent from what is clean and what is quick&dirty, I 
> cannot detect any 
> >sense in giving a hash-meaning to the bottom label at all.
> >
> >
> >
> >Heinrich Hummel
> >Siemens
> >
> >-----Ursprüngliche Nachricht-----
> >Von: Eric Rosen [mailto:[email-masked]]
> >Gesendet: Dienstag, 2. Juli 2002 16:06
> >An: Shahram Davari
> >Cc: 'Eric Osborne'; George Sheng; [email-masked]; [email-masked]
> >Betreff: Re: your mail
> >
> >
> >Shahram> To do ECMP, you need to  assign hashed values to 
> egress ports. 
> >This
> >Shahram> assignment is the hash state that I said you need.
> >
> >A hash is  a function that maps  some sequence of octets 
> into  a sequence 
> >of
> >integers.  If you want to split  traffic over six paths, 
> while ensuring 
> >that
> >all packets  with the  same bottom label  travel the  same 
> path, you  need 
> >a
> >function that maps  a 20 bit quantity  into a number from 
> 1-6.   There is 
> >no
> >need to maintain state of any kind.
> 
> 
> 
> 
> _________________________________________________________________
> Chat with friends online, try MSN Messenger: http://messenger.msn.com
> 
>

---

From: Eric Osborne <[email-masked]>
Date: Tue, 2 Jul 2002 14:09:39 -0400

On Tue, Jul 02, 2002 at 02:00:23PM -0400, David Allan wrote:
> granularity ;-). 

"during times of network stability (no link flaps causing rerouting,
etc), any sequence of packets sent from one host to another must
arrive in the order in which they are sent"...or something like that.

eric

> Similarly any path test tool (e.g. ICMP) must follow the