Subject: RE: initiating a discussion on mpls singaling protocols

From: Bala Rajagopalan <[email-masked]>
Date: Tue, 23 Jul 2002 11:48:19 -0400

In response to the comment on OIF tracking CR-LDP:

Life would be simplified for OIF and ITU-T if
there were only a single standard signaling protocol.
But because there are two IETF protocols, the rest of the 
world has to track the two (in addition to other
non-IETF protocols). 

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked] 

> -----Original Message-----
> From: Soumen Sarkar [mailto:[email-masked]]
> Sent: Tuesday, July 23, 2002 3:27 AM
> To: Loa Andersson; [email-masked]
> Subject: Re: initiating a discussion on mpls singaling protocols
> 
> 
> Loa,
> The response so far heavily indicated for RSVP-TE ( obviously 
> not because of the
> merits of RSVP-TE over LDP-CR ). If one has to accept the 
> basic ground-rule, which is,
> how many major players are pushing for RSVP-TE, one would 
> blindly vote for RSVP-TE.
>         The more esoteric view, which is, single signaling 
> protocol would help
> everyone to concentrate better in addressing unresolved  
> problems in MPLS, is also
> appreciably reasonable to accept.
> But looking from holistic perspective, is it not too 
> premature at this time to
> conclude on this issue unilaterally (even if there is 3/4 
> majority in favour if it )
> when this particular issue affects other standard bodies too 
> ? We know for sure, OIF
> is still tracking LDP-CR as an alternative signaling protocol 
> for optical control
> plane. Are we not pushing something without even considering 
> future implication of it
> ? One might say, we are not stopping anyone to use LDP-CR as 
> such. But none would
> disagree that making IETF take a stand itself is deterrant 
> enough and if not that
> much, it is bound to create conflict of interest between IETF 
> and others.
>   Are we really ready for this ? IETF traditionally has been 
> more a forum for vouching
> technical solutions, not imposing it. Are we deviating from 
> that path with full
> understanding ?
> -best regards,
> Soumen
> 
> Loa Andersson wrote:
> 
> > Heinrich,
> >
> > in my opinion the question is very clearly stated - is 
> there support for
> > us (the ietf) to move the cr-ldp from standard track to 
> informational.
> > We're "speaking for the ietf", it is more a matter of what we say ;)
> >
> > All,
> >
> > As usual we are trying to reach a rough consensus. Everyone 
> (i.e. the
> > mpls wg) can help create this consensus by answering the question
> > above.
> >
> > Especially it will be helpful if you were involved in specifying the
> > mpls protocols, have implemented or deployed (SP) those 
> protocols, and
> > take the time to respond.
> >
> > I will be ready to give the first extensive tally mid this week.
> > Currently the count is
> > yes: 30 no: 7,
> > if you normalize those e.g. by counting each company once it is
> > yes: 21 no: 4
> >
> > Disclaimer: Given that I've managed to decipher the 
> sometimes cryptic
> > mails correctly :o)
> >
> > /Loa
> >
> > Hummel Heinrich wrote:
> >
> > >  I think, the IETF can only speak for itself. There may 
> be other standardization
> >
> > >bodies (ITU-T, MPLS Forum) which may fill
> > > the gap.
> > >
> > > Heinrich Hummel
> > > Siemens AG
> > >
> >
> > --
> >      Loa Andersson
> >      Chief Architect,
> >      Utfors Research, Architecture and Future Lab (URAX)
> >      Utfors AB
> >      Råsundavägen 12
> >      Box 525, 169 29 Solna
> >      Office          +46 8 5270 2000
> >      Office direct   +46 8 5270 5038
> >      Mobile          +46 70 848 5038
> >      Email           [email-masked]
> >      WWW             www.utfors.se
>

---

From: Stephen Trowbridge <[email-masked]>
Date: Tue, 23 Jul 2002 10:24:38 -0600

Bala,
There is certainly no issue if both organizations make the same
decision about which protocol(s) is/are standards track. There is
only an issue if they make different decisions.

If a change is to be made in IETF with respect to which protocol(s)
is/are standards track, it would be worth sending a communication to ITU-T
with the proposal and reasoning before this is finalized to see if
an aligned decision could be reached.
Regards,
Steve

---

From: [email-masked]
Date: Tue, 23 Jul 2002 18:26:48 +0200

i concur with you in addition, it will avoid for
these bodies to have to consider at some point in 
time an interworking function... 

- dimitri.

-- 
Papadimitriou Dimitri 
E-mail : [email-masked] 
Website: http://www.rc.bel.alcatel.be/~papadimd/index.html
Address: Alcatel - Optical NA, Fr. Wellesplein, 1 
         B-2018 Antwerpen, Belgium
Phone:   Work: +32 3 2408491 - Home: +32 2 3434361

---

From: Soumen Sarkar <[email-masked]>
Date: Wed, 24 Jul 2002 10:59:24 +0530

So, In effect you are saying that since OIF and ITU-T are not able to decide
which one to pick (based on their requirements), it is benefecial for them
that IETF decide which one they want to promote and others will follow! I
thought ITU-T and OIF work independently and they have their own parameters
to choose the technological alternative.

---

From: Soumen Sarkar <[email-masked]>
Date: Wed, 24 Jul 2002 14:15:53 +0530

Hi Zafar,

My intention was not at
all to pick on Bala's statement. And my  appology if I have hurt anyone
here.

With due respect to all
of you, I just wanted to stress on the fact that, we should not create
a counter-logic based on our inclination on particular choice. From IETF's
perspective, it would only be consistent, if the decision to put some activity
in standard/informational track is taken based on purely technical merits.
Anything else would be a deviation and that deviation is bound to impact
other standard bodies too if they are working on similar thread. And it
would be unfortunate if that impact proves more costly to the industry
at later point of time.

-best regards,

Soumen

Zafar Ali wrote:

At 10:59 AM 7/24/2002 +0530, Soumen
Sarkar wrote:

So, In effect you are saying that
since OIF and ITU-T are not able to decide

which one to pick (based on their requirements), it is
beneficial for them

that IETF decide which one they want to promote and others
will follow!

Hi Soumen,

This would be a very unfair reading of Bala's email. You should read
it in the context that some folks argued that since OIF uses CR-LDP, IETF
should not proceed on this notion.

There is no argument that both  IETF, OIF and ITU-T are independent
bodies. However, it should not surprise anyone that implementation survey
for CR-LDP vs. RSVP-TE for OIF UNI would follow the same sample point.
So, yes, OIF can independently make the same decision; not because of the
IETF influence but using the same rule of wisdom. But this should be separate
discussion at the right mailing alias/ with the right authorities.

Thanks

Regards... Zafar

I

thought ITU-T and OIF work independently and they have
their own parameters

> >         The
more esoteric view, which is, single signaling

> > >      Råsundavägen
12

> > >      Office
+46 8 5270 2000

> > >      Mobile
+46 70 848 5038

> > >      WWW
www.utfors.se

---

From: Zafar Ali <[email-masked]>
Date: Wed, 24 Jul 2002 02:38:18 -0400

At 10:59 AM 7/24/2002 +0530, Soumen Sarkar wrote:
>that IETF decide which one they want to promote and others will follow!

Hi Soumen,

This would be a very unfair reading of Bala's email. You should read it in 
the context that some folks argued that since OIF uses CR-LDP, IETF should 
not proceed on this notion.

There is no argument that both  IETF, OIF and ITU-T are independent bodies. 
However, it should not surprise anyone that implementation survey for 
CR-LDP vs. RSVP-TE for OIF UNI would follow the same sample point. So, yes, 
OIF can independently make the same decision; not because of the IETF 
influence but using the same rule of wisdom. But this should be separate 
discussion at the right mailing alias/ with the right authorities.

Thanks

Regards... Zafar