Subject: RE: Handling of ipv4 packets that are too big

From: "Gray, Eric" <[email-masked]>
Date: Tue, 9 Jul 2002 09:58:36 -0400

Mayank,

	As a further note, I am somewhat guilty of
oversimplifying in my previous message.  Typical
MPLS interfaces are capable of forwarding both
labeled (MPLS) and unlabeled (IP) traffic.  This
is what distinguishes an LSR from what we used to
refer to as an 'MPLS node'.  It is also what an
LSR must be able to do in order to be able to
participate in routing (in anything more than a
lame way).

	This opens the way to a lazy man's LSR - one
which performs no ingress or egress functions but
simply forwards packets as it receives them.  I.e.
labeled packets are forwarded labeled, unlabeled
packets are forwarded unlabeled.  There are many
issues with such an implementation, since it can't
provide or maintain labels for which it does not
have downstream bindings.  I believe such an LSR
would be exceptionally fragile and unlikely to be
of much use as a result - but I mention it mostly
for completeness.  

	While such an LSR might have both MPLS and non 
MPLS interfaces and still not have LER functionality, 
I do not know if such an LSR exists.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Gray, Eric [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2002 9:27 AM
To: [email-masked]'
Cc: Mpls (E-mail)
Subject: RE: Handling of ipv4 packets that are too big

Mayank,

If a router has at least one MPLS interface and at 
least one non MPLS interface which it can route
between, it has LER functionality.  Any non MPLS
interface over which IP packets may be sent (such
as a local drop) qualifies.

The simplest example of a strict LER implementation
is one which has only one MPLS capable interface (it
might be an uplink, for example).  An LER might have 
more than one MPLS capable interface if it is not 
able to route between them.  Otherwise, it is also
an LSR.

If a router has two or more MPLS interfaces which it
can route between, it has LSR functionality. 

The simplest example of a strict LSR is one which has
two MPLS interfaces and no non MPLS interfaces.  Such
a device is of doubtful utility.

Hence, most boxes will incorporate both LER and LSR
functionality, depending on installed interfaces. 

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Mayank Kumar [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2002 8:49 AM
To: Mpls (E-mail)
Subject: Handling of ipv4 packets that are too big

hi

Can any body tell me of the issues involved in providing both the
functionalities of LER and LSR in an MPLS router.
Other than the support required for ILM and there processing , what other
issues are to be dealt with???
Also please somebody tell if there are implementations from mpls vendors of
mpls routers where only the lsr or the ler functionality has been implmented
??

thanks and regds

Mayank

---

From: David Charlap <[email-masked]>
Date: Tue, 09 Jul 2002 11:03:04 -0400

> of much use as a result - but I mention it mostly

Such a device could be stable if it uses RSVP or CR-LDP (or even LDP if 
downstream-on-demand/conservative-retention mode is used).  If all LSPs 
are created using strict EROs, you don't even need routing functionality.

But you're right that such a product would not be useful to most people. 
  Once you've paid enough money to get good forwarding hardware, you're 
going to want routing and LER capabilities.

-- David