Subject: RE: initiating a discussion on mpls singaling protocols

From: "Ong, Lyndon" <[email-masked]>
Date: Tue, 23 Jul 2002 10:00:36 -0700

This might be actually a reasonable solution, to "cap" the
work on CR-LDP.  I'd have the same concern as Avri with
taking an approved standard and "de-standardizing" it,
although it would help to know if this has been done
before.

Cheers,

Lyndon Ong
Ciena

-----Original Message-----
From: Marty Borden [mailto:[email-masked]]
Sent: Tuesday, July 23, 2002 9:38 AM
To: [email-masked]; 'avri'
Cc: [email-masked]
Subject: RE: initiating a discussion on mpls singaling protocols

Eric,
Well that would be good if it were acceptable for a draft
to not have to cover both approaches.  Is that really acceptable?
marty

On 7/23/2002 at 12:09 PM Gray, Eric wrote:

|Avri makes a very good point here.
|
|I think the implementation survey makes it obvious that 
|we should progress RSVP-TE (and related work) to Draft
|Standard.  It seems equally clear that we should not do
|so for CR-LDP at this point.  
|
|Letting CR-LDP die on the vine certainly seems in keeping
|with what the IETF has done in the past.
|
|Eric W. Gray
|Systems Architect
|Celox Networks, Inc.
[email-masked]
|508 305 7214
|
|
|-----Original Message-----
|From: avri [mailto:[email-masked]] 
|Sent: Tuesday, July 23, 2002 9:26 AM
|Cc: MPLS wg
|Subject: Re: initiating a discussion on mpls singaling protocols
|
|
|
|This seems to me a very strange proposal.  And in fact seems to be
|a perversion of the IETF standards process as i understand it.
|
|If things are as argued, then RSVP-TE will progress to draft standard
|and then to standard, while CR-LDP remains a proposed standard.  If
|it languishes long enough in the proposed state, without significant
|deployment or utility, then it would seem appropriate to transition it
|to historic at some point in the future.
|
|Taking it to informational at this point seems a fairly blatant political
|move without technical merit.  At best it is an administrative sleight
|of hand that could strange repercussions as a precedent.  Is the IETF
|going to embark next on an effort to define all protocol duplication
|out of existence by voting on which alternative to make informational?
|
|I would suggest (as voting is not something I thought the IETF did) that
|both protocols remain as ps. If CR-LDP withers on the vine because it has
|no utility, so be it.  Voting to change its status seems inappropriate to
|me.
|
|a.

---

From: Loa Andersson <[email-masked]>
Date: Tue, 23 Jul 2002 19:16:56 +0200

All,

(off list for clarification)
it seems like you are agreeing based on two very different approaches.

1. don't do anyhting about the doc status to cr-ldp, but stop all
    work on it (Lyndon)
2. don't do anything to doc status, but require (encoruage) that id
    authors work only on one singalling protocol at a time (Eric).

1 is very close to what was proposed at the mpls wg meeting, 2 is
actually a decission to continue develop cr-ldp.

/Loa

-- 
     Loa Andersson
     Chief Architect,
     Utfors Research, Architecture and Future Lab (URAX)
     Utfors AB
     Råsundavägen 12
     Box 525, 169 29 Solna
     Office          +46 8 5270 2000
     Office direct   +46 8 5270 5038
     Mobile          +46 70 848 5038
     Email           [email-masked]
     WWW             www.utfors.se

---

From: Soumen Sarkar <[email-masked]>
Date: Wed, 24 Jul 2002 15:34:16 +0530

Loa,
    Thanks for summarizing. I would support the 2nd approach on the ground that
Avri has nicely has put forth.
  2ndly, this approach is very much aligned to IETF's way of working.
-best regards,
Soumen