Subject: MPLS L2VPN Multiple Packet (Broadcast/Multicast/UnkUnicast) Problem

From: Gary Blankenship <[email-masked]>
Date: Sun, 21 Jul 2002 23:07:34 -0700 (PDT)

MPLS WG,

I was wondering what the current direction of the MPLS WG is for solving the duplicate copy over single link problem for L2VPN.

Problem definition:  In a multipoint environment a full mesh of LSP's is required (classic N(N-1)/2).  If the packet is duplicated at the head end it results in multiple copies of the same packet traveling over the same wire (bad thing).

Questions:  

What is the current thinking for solving this problem?  Draft Yasukawa (RSVP Multicast LSPs)?  Hierarchical LSPs?  Can someone please give me a status summary on work to resolve this?  Comments from anyone on the Lasserre-VKompella draft?  Any ideas leading the pack?

Thanks,

Gary

_____________________________________________________________
Powered by a short email address ... http://www.k.st

_____________________________________________________________
Promote your group and strengthen ties to your members with [email-masked] by Everyone.net  http://www.everyone.net/?btn=tag

---

From: fraanro <[email-masked]>
Date: Thu, 25 Jul 2002 06:36:45 GMT

At this moment the existing implementations are based on replication in 
the headend as you say. It is highly important to do that replication 
in hardware, and ASICs usually will have limitations in the number of 
replications they are able to do at the same time. Now the point is, 
considering that scenario what can be considered appropiate for a L2 
VPN, 50 sites? 100? 200? ... 
Obviously because of this, the Hierchical VPLS are being introduced in 
order to support a higher number of sites on a L2 VPN. 
On the other hand I am not sure if an scenario with such a big number 
of sites is appropriate for a L2 VPN and maybe it would be better a L3 
VPN (well, maybe a online gaming L2 VPN where each site is an 
individual user may make sense).

Javier.

----- Mensaje Original -----
Remitente: Gary Blankenship <[email-masked]>
Fecha: Lunes, Julio 22, 2002 8:07 am
Asunto: MPLS L2VPN Multiple Packet (Broadcast/Multicast/UnkUnicast) 
Problem

> MPLS WG,
> 
> I was wondering what the current direction of the MPLS WG is for 
> solving the duplicate copy over single link problem for L2VPN.
> 
> Problem definition:  In a multipoint environment a full mesh of 
> LSP's is required (classic N(N-1)/2).  If the packet is duplicated 
> at the head end it results in multiple copies of the same packet 
> traveling over the same wire (bad thing).
> 
> Questions:  
> 
> What is the current thinking for solving this problem?  Draft 
> Yasukawa (RSVP Multicast LSPs)?  Hierarchical LSPs?  Can someone 
> please give me a status summary on work to resolve this?  Comments 
> from anyone on the Lasserre-VKompella draft?  Any ideas leading 
> the pack?
> 
> Thanks,
> 
> Gary
> 
> Promote your group and strengthen ties to your members with 
> [email-masked] by Everyone.net  http://www.everyone.net/?btn=tag
> 
>