Subject: RE: initiating a discussion on mpls singaling protocols

From: [email-masked]
Date: Fri, 26 Jul 2002 10:30:05 +0100

Giles....my apologies, but I have to correct you here as I feel you are
misrepresenting an important issue....please see below.

regards, Neil

> -----Original Message-----
> From: Giles Heron [mailto:[email-masked]]
> Sent: 26 July 2002 01:44
> To: Jothilingam, Vasudevan " "(Vasu)
> Cc: IETF MPLS List
> Subject: RE: initiating a discussion on mpls singaling protocols
> 
> 
> On Wed, 2002-07-24 at 18:55, Jothilingam, Vasudevan (Vasu) wrote: 
> > Giles
> > 
> > I understand that, I just wanted make sure..
> > So are we suggesting that Just have LDP. Well, I am not 
> sure what will that
> > buy us 
> > without TE.
> 
> No - I am suggesting that we need LDP, and that we also need a TE
> mechanism.  Given that RSVP-TE is so widely deployed I think the
> opportunity for CR-LDP has passed. 
NH=> There is general LDP and targeted LDP....the former creates mp2p
entities, but I believe your requirement is for the latter which creates p2p
entities (though I assume you could use RSVP-TE for this too, so its not
clear to me that LDP is a 'must' in your case.....but please correct me if
this is not the case).
> 
> BTW - LDP actually buys us plenty without TE (only IMO of course - I
> don't want anyone to restart that "we need to kill LDP 
> because it isn't
> compatible with MPLS OAM" thread!)  However some SPs have TE
> requirements, so we need TE as well. 
NH=> This is a misleading slant.  The difficulty of fault-management of
general LDP is simply 1 problem it raises......it is not the only one.  The
discussion/thread you are referring to was based on the question 'what
networking problem does LDP solve that cannot be better solved by IPinIP (if
an any-any mode is required) or p2p LSPs (if hard SLAs are required that are
easily measureable/manageable)?'.  However, I agree we don't want to open
this up again.
<snipped to end NH>

---

From: Giles Heron <[email-masked]>
Date: 26 Jul 2002 11:11:01 +0000

> misrepresenting an important issue....please see below.

no misrepresentation intended.  No correction required ;-)

> clear to me that LDP is a 'must' in your case.....but please correct me if
[snipped to end]

I want *both* mp2p LDP and targetted LDP.

I want the former because it:

1) minimises the number of labels required in the core - O(N) rather
than O(N squared).

2) enables auto-generation of full mesh connectivity (each PE advertises
a single label for itself which reaches all other Ps and PEs).

3) is a good last resort even when RSVP-TE is being used (because of the
above)

I want the latter for L2 over MPLS.

Sure the L2 stuff could be done with RSVP-TE (someone specified this in
a draft at one stage I think?) but LDP seems a to me a much more natural
way to advertise labels over a single hop than RSVP-TE.

Giles
 
-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================