Subject: RE: initiating a discussion on mpls singaling protocols

From: Shahram Davari <[email-masked]>
Date: Thu, 25 Jul 2002 08:04:33 -0700

I think a question to ask is, which one requires less software to implement:

(LDP + CR-LDP) or (LDP + RSVP-TE)?

-Shahram

> -----Original Message-----
> From: David Charlap [mailto:[email-masked]]
> Sent: Thursday, July 25, 2002 10:42 AM
> To: IETF MPLS List
> Subject: Re: initiating a discussion on mpls singaling protocols
> 
> 
> Bisewski, Radoslaw wrote:
> > But CR-LDP is an extension to the LDP protocol. While 
> RSVP-TE has nothing in
> > common with LDP. After "eliminating" CR-LDP you will still 
> have two MPLS
> > signalling protocols MPLS LDP and RSVP-TE.
> 
> So?  These two serve very different purposes and are not redundant.
> 
> LDP automatically generates LSPs based on the routing table.
> 
> RSVP-TE generates traffic-engineered LSPs based on requests from an 
> ingress router.
> 
> -- David
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 25 Jul 2002 18:22:32 +0200

Sharam,

if we have 2 years (well 18 month, and will be a lot more before er
see any cr-ldp deployment) experience of running rsvp-te + ldp, the
SIZE of the software will be a ery minor problem ;)

/Loa

-- 
     Loa Andersson
     Chief Architect,
     Utfors Research, Architecture and Future Lab (URAX)
     Utfors AB
     Råsundavägen 12
     Box 525, 169 29 Solna
     Office          +46 8 5270 2000
     Office direct   +46 8 5270 5038
     Mobile          +46 70 848 5038
     Email           [email-masked]
     WWW             www.utfors.se