Subject: RE: comments on the MPLS OAM discussion

From: "David Allan" <[email-masked]>
Date: Wed, 24 Jul 2002 16:18:25 -0400

Vach:

Isn't defining OAM messaging for every application of MPLS getting into a
bit of a combinatorial problem?

I also got the impression from the presentation in Yokahoma that the HVPLS
OAM was more of a discussion of possibilities, and that MAC layer OAM for
HVPLS also had desirable properties (I cannot remember what the non-MPLS PW
possibilities were which presumably would require a different mechanism...).
IMHO there is not sufficient well elucidated demand for a label for HVPLS
(or anything else) to impact the meeting consensus on the ITU's request.

BTW The discussion in Yokahoma was based around a concern that the ITU would
not repeatedly keep coming back for labels and would make good use of the
the one requested. There was also discussion on hoping that proposed use of
the label was accompanied by informational drafts etc. such that the MPLS
community had the opportunity to comment on how OAM and label use evolved. I
think other folks wanting a "piece" of the label only came up briefly and
was secondary to the original concern....

cheers
Dave
 
> -----Original Message-----
> From: Vach Kompella [mailto:[email-masked]]
> Sent: Wednesday, July 24, 2002 3:50 PM
> To: Loa Andersson; MPLS wg
> Cc: Scott Bradner; George Swallow
> Subject: RE: comments on the MPLS OAM discussion
> 
> 
> I'm all in favor of the OAM label, but I share the concern 
> that "giving away" a
> label to the ITU isn't the best use of the small reserved 
> label space.  I would
> like to see an MPLS OAM label defined.  But the application 
> of the label should
> not be restricted to the Y.1711 proposal.  E.g., HVPLS OAM 
> proposes to use an
> OAM label.  We'd like to be able to use the MPLS OAM label 
> without having to
> exchange OAM FECs as proposed in that draft.
> 
> If we allow the use of a single label for all OAM 
> applications that want to use
> it, we now have the next issue of how do we demux to the 
> different apps that
> want to use this label?
> 
> -Vach
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of Loa
> > Andersson
> > Sent: Thursday, July 18, 2002 1:31 AM
> > To: MPLS wg
> > Cc: Scott Bradner; George Swallow
> > Subject: comments on the MPLS OAM discussion
> >
> >
> > All,
> >
> > at the meeting of the MPLS wg today at the 54th IETF in Yokohama the
> > MPLS OAM and the liasion from ITU-T SG13/Q3 were revisted. 
> There were
> > a very clear consensus in the room supporting the the request in
> > "Use of a reserved label value defined in RFC 3032 for MPLS OAM
> > functions" <draft-ohta-mpls-label-value-01.txt> to assign a label
> > value out of the reserved mpls label value space to support 
> MPLS OAM.
> >
> > There were some concerns raised on the "economy of the 
> reserved label
> > space", i.e. are we using this label space most effectively 
> by accepting
> > the request from ITU-T SG13/Q3. It is the intention of the IESG to
> > address the question of moving the 
> <draft-ohta-mpls-label-value-01.txt>
> > to informational on Thursday next, this is to open up the 
> mpls mailing
> > list for comments on this topic to support the IESG in 
> their decission.
> > Ideally the IESG should be able to take the decission on Thursday,
> > but if we have an active discussion on the list the decission will
> > be taken when the discussion vonverges.
> >
> > /Loa
> >
> > --
> >      Loa Andersson
> >      Chief Architect,
> >      Utfors Research, Architecture and Future Lab (URAX)
> >      Utfors AB
> >      Råsundavägen 12
> >      Box 525, 169 29 Solna
> >      Office          +46 8 5270 2000
> >      Office direct   +46 8 5270 5038
> >      Mobile          +46 70 848 5038
> >      Email           [email-masked]
> >      WWW             www.utfors.se
> >
> >
> 
>

---

From: [email-masked]
Date: Wed, 24 Jul 2002 22:24:26 +0100

Dave....Your 1st observation below misses a key point:  One of the main
requirements of the MPLS OAM work (requirements being defined in Y.1710) is
that solutions must be client or server layer (read technology if you like)
agnostic.  So whether the LSP is carrying IP, ATM, ethernet or anything else
it is the LSP itself that is fault-managed.  This is a desirable goal for
what I think are obvious reasons. 
 
When an OAM pkt is sent the LSP label depth increases by 1 over normal
traffic depth.  So exactly the same 'normal traffic' label stack appears
before an OAM pkt.  Given the semantics of the payload are supposed to be
conveyed from seeing the normal forwarding label then one knows the
application to which this OAM pkt applies.
 
Further, you should not be asking MPLS OAM to proxy for any missing ethernet
OAM.  MPLS OAM looks after LSPs irrespective of the client as I noted above.
If ethernet requires OAM then ethernet should provide it.....in fact I am
puzzled why no one has suggested defining a new ethertype for ethernet OAM
(or maybe they have?), since at least ethernet does have such a field and
this seems an obvious solution here.
 
regards, Neil

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: 24 July 2002 21:18
To: Vach Kompella; Loa Andersson; MPLS wg
Cc: Scott Bradner; George Swallow
Subject: RE: comments on the MPLS OAM discussion

Vach: 

cheers 
Dave 
  
> From: Vach Kompella [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Loa