Subject: RE: on the mpls oam framework

From: [email-masked]
Date: Sat, 15 Nov 2003 17:48:28 -0000

Kireeti Kompella wrote 15 November 2003 06:47
> Hi Dave,
> 
> On Tue, 11 Nov 2003, David Allan wrote:
> 
> > IMHO You are persisting in ignoring what you don't want to see.
> 
> Speaking as a vendor:
> 
> On mp2p: at least 90% of the MPLS deployments I've seen use LDP.
NH=> Does this make it 'right' then?  If the dominant vendor 'does this' then your conclusions are hardly surprising.  Most of the world also uses MS Windows/applications too.....my PC crashes nearly every day....I wish I could sort/change it but I can't.  Market dominance is a very powerful vehicle IMO ;-)
> 
> On ECMP: many providers ask us explicitly for ECMP.  On the other
> hand, no provider that I know (other than BT) of has complained
> about ECMP and asked us to turn it off.
NH=> ECMP is a *consequence* of LDP because one cannot control the routing.
> 
> On PHP: two providers (one being BT) have complained about PHP, out
> of all the providers I've talked to about MPLS (about 3%).
NH=> You live with what you have been given by the dominant vendors....again this does not make it right.  Can you tell me how many operators actually asked for PHP (or even LDP) as a requirement in the 1st place, as I don't know of any network/service problem it solves?

regards, Neil

---

From: Curtis Villamizar <[email-masked]>
Date: Sun, 16 Nov 2003 17:24:25 -0500

In message <[email-masked]
host.net>, [email-masked] writes:
> NH=> Does this make it 'right' then?  If the dominant vendor 'does this' then
>  your conclusions are hardly surprising.  Most of the world also uses MS Wind
> ows/applications too.....my PC crashes nearly every day....I wish I could sor
> t/change it but I can't.  Market dominance is a very powerful vehicle IMO ;-)
> > 
> NH=> You live with what you have been given by the dominant vendors....again 
> this does not make it right.  Can you tell me how many operators actually ask
> ed for PHP (or even LDP) as a requirement in the 1st place, as I don't know o
> f any network/service problem it solves?
> 
> regards, Neil

They are needed for other technical reasons that are out of scope for
the OAM framework.  As far as the OAM framework is concerned, they are
part of the architecture and widely deployed so they must be supported
by OAM tools.  It simply means that working with PHP and ECMP are
requirements for OAM.

You seem to have things backwards.  You have an OAM solution in mind
that doesn't work well with ECMP and PHP and want a OAM framework that
claims these are bad features.

This exercise includes stating requirements - and like it or not ECMP
and PHP are requirements for OAM and so is not requiring changes to
the forwarding plane.  The framework can then discuss a set of
solutions and their tradeoffs.  If a single solution (or set of
solutions) covers all requirements well, then any additional partial
solutions will be redundant.

Curtis

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 17 Nov 2003 08:51:20 -0500

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf 
>Of Curtis Villamizar
>Sent: Sunday, November 16, 2003 5:24 PM
>To: [email-masked]
>Cc: [email-masked]; [email-masked]; [email-masked]
>Subject: Re: on the mpls oam framework 
>
>
>
>In message 
><[email-masked]

	One thing that seems to be out of sight of this
dicussion is that the OAM framework MUST provide a 
framework that works based on the requirements stipulated
in the MPLS OAM Requirements draft; it cannot make new things up.
There are a dozen operators that have officially provided
input into this document (and many more unofficially), so 
I think it is a good idea to listen to these requirements.
Handling of ECMP is definitely specified in the aforementioned 
draft.

>the forwarding plane.  
	
	We already have:  draft-ietf-mpls-oam-requirements-02.txt

	--Tom

> The framework can then discuss a set of