Subject: RE: on the mpls oam framework

From: Shahram Davari <[email-masked]>
Date: Tue, 18 Nov 2003 01:48:00 -0800

>	While I would of course agree that knowing all of the
>algorithms would make things easier, I disagree that we cannot
>move forward with solutions today. I think that solutions can be 
>created to manage what is deployed today. There is clear evidence
>of this already.
>
>	--Tom

How can one create solutions to manage deployed boxes, without knowing how
they behave? for example how can you design the VCCV if you don't know 
which fields in the header are used today to hash ECMP. As an example
the Alert Label (in VCCV) won't work with implementations that hash all label stack.

-Shahram

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 18 Nov 2003 07:53:57 -0500

>-----Original Message-----
>From: Shahram Davari [mailto:[email-masked]] 
>Sent: Tuesday, November 18, 2003 4:48 AM
>To: [email-masked]'; [email-masked]
>Subject: RE: on the mpls oam framework 
>
>
>How can one create solutions to manage deployed boxes, without 
>knowing how they behave? for example how can you design the VCCV if you
don't know 
>the Alert Label (in VCCV) won't work with implementations that 

	Using the example of LSP Ping, you ask the boxes 
what they are going to do. In the case of VCCV,
we don't care because we aren't tracing, just following
whatever path the data takes.

	--Tom