Subject: draft-farrel-mpls-rsvpte-attributes-00.txt for wg document

From: Loa Andersson <[email-masked]>
Date: Mon, 24 Nov 2003 00:11:34 +0100

All,

we been asked to make

draft-farrel-mpls-rsvpte-attributes-00.txt

an mpls working document. The document were discussed in
Minneapolis, the room was undecided if we should go
forward with the document. No opposition, but also no
strongly voiced support.

Therefore we would like both those in favor and those
opposed to making this a working group document to
speak up.

/Loa

-- 

Loa Andersson

mobile +46 739 81 21 64

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 24 Nov 2003 09:16:11 -0800 (PST)

On Mon, 24 Nov 2003, Loa Andersson wrote:

> an mpls working document.

Ja, det ar mycket bra.

Kireeti.
-------

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Mon, 24 Nov 2003 12:53:55 -0500

> > an mpls working document.

merci de ton support Kireeti. A bientot.

JP.

---

From: Lou Berger <[email-masked]>
Date: Mon, 24 Nov 2003 13:58:40 -0500

In favor...

---

From: Arthi Ayyangar <[email-masked]>
Date: Mon, 24 Nov 2003 11:18:30 -0800 (PST)

In favor.

-arthi

---

From: Rahul Aggarwal <[email-masked]>
Date: Mon, 24 Nov 2003 12:08:05 -0800 (PST)

Hi Loa,

In support..

rahul

---

From: "zafar ali" <[email-masked]>
Date: Mon, 24 Nov 2003 15:32:15 -0500

Hi WG chairs, 

I am in favor of this document. 

Thanks
 
Regards... Zafar

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf 
>Of Loa Andersson
>Sent: Sunday, November 23, 2003 6:12 PM
>To: MPLS wg
>Cc: George Swallow; Alex Zinin
>Subject: draft-farrel-mpls-rsvpte-attributes-00.txt for wg document
>
>
>All,
>
>we been asked to make
>
>Minneapolis, the room was undecided if we should go forward 
>with the document. No opposition, but also no strongly voiced support.
>

---

From: "Eric W Gray" <[email-masked]>
Date: Mon, 24 Nov 2003 15:55:38 -0500

I am in favor of making this a working group document.

--
Eric

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa
Andersson

---

From: raymond zhang <[email-masked]>
Date: Mon, 24 Nov 2003 13:59:56 -0800

Hi Loa,

I am in favor of in making this as a wg doc.

Regards,
Raymond

---

From: Markus Jork <[email-masked]>
Date: Mon, 24 Nov 2003 20:06:43 -0500

in favor

Markus

---

From: Reshad Rahman <[email-masked]>
Date: Mon, 24 Nov 2003 20:35:34 -0500

In favour.

Regards,
Reshad.

---

From: "Vishal Sharma" <[email-masked]>
Date: Tue, 25 Nov 2003 15:47:09 -0800

Loa,

I support. There was one question raised by Adrian though that
was not answered at the WG meeting, so it might be useful
for us to consider on the list. It was "do we need a way to support
arbitrary TLVs?"

I believe this is one of the two solutions proposed in the
draft, and it would be good to get WG opinion on that.

-Vishal

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Loa
> Andersson
> Sent: Sunday, November 23, 2003 3:12 PM
> To: MPLS wg

---

From: Seisho Yasukawa <[email-masked]>
Date: Wed, 26 Nov 2003 10:02:51 +0900

Hi Loa, all

I am in favor of making this a WG document.

Regards,
Seisho

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 26 Nov 2003 12:50:22 -0000

Hi Vishal,

> draft, and it would be good to get WG opinion on that.

Actually, it is the only solution proposed in the draft. The 'need' for TLVs is a minor
corroborative reasons used to discard an alternative solution.

In the currently proposed solution, additional TLVs come for free.
We *could* simplify the current solution (by the order of a type and length field) and
dispense with arbitrary TLVs.

The authors felt that not taking the opportunity to add TLVs would be seen as a mistake in
future years.
The similar OSPF solution has TLVs I believe.

Would welcome more opinions.

Cheers,
Adrian

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Wed, 26 Nov 2003 08:34:07 -0500

Hi Adrian,

>The similar OSPF solution has TLVs I believe.

absolutely right; by the way, we already found a few interesting uses of 
them for the IGP.

Cheers

JP.

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 26 Nov 2003 12:34:13 -0800

Hi Adrian,

Thanks for the clarification. I think I misunderstood your
question during the MPLS WG meeting then.

(I think what you mentioned was that with TLVs it is possible
to either (a) define new 32-bit flags, as needed, or (b) define arbitrary
options and parameters that would be carried as TLVs, and you asked,
referring to the entire scheme, whether the WG thought we need
a way to support arbitrary TVLs. 

I misunderstood it to refer to just the second option for encoding 
attributes within the TLVs defined for carrying new attributes.)

I get your point now, and support the overall TLV approach proposed
in the document.

-Vishal

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Adrian
> Farrel
> Sent: Wednesday, November 26, 2003 4:50 AM
> To: Vishal Sharma
> Cc: MPLS wg
> Subject: Arbitrary TLVs in draft-farrel-mpls-rsvpte-attributes-00.txt 
> 
> 
> Hi Vishal,
>

---

From: Dave Cooper <[email-masked]>
Date: Wed, 26 Nov 2003 23:36:34 -0800

in favor

-dave

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 26 Nov 2003 12:34:13 -0800

Hi Adrian,

-Vishal

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 26 Nov 2003 12:50:22 -0000

Hi Vishal,

Cheers,
Adrian

---

From: "Seisho Yasukawa" <[email-masked]>
Date: Wed, 26 Nov 2003 03:40:10 +0900

Hi Loa and all,

I support making this draft a WG doc.

Seisho Yasukawa