Subject: RE: on the mpls oam framework

From: [email-masked]
Date: Mon, 10 Nov 2003 08:22:48 -0000

Loa,

I agree there is a serious disconnect between the 'architecture' and what is being done in some places in IETF, eg PWE3.  Whether some people like them or not, G.805 and G.809 respresent the functional architecture of all technologies.....the former covers the co-cs and co-ps modes and the latter the cnls mode, and all technologies map to one of these modes.

One must respect the architectural principles of the networking mode in question or else problems arise later.....the 'OAM problems' are one symptom of this.  The classic example that springs to mind is a link-connection (ie label) swapping co-ps forwarding mode (eg MPLS) that violates the allowed topological constructs of that mode (which in this case are p2p or p2mp) and terminates the trail 1 hop too soon (ie PHP).  There should also be layer independence in a simple client/server relationship, ie do not modify the client PDU.

Keep the network architecture clean and the problems will not exist.......Dave (Allan's) paper is, in general, simply a survey of what has been 'done'.

So please be very clear when identifying *where* the disconnects exist.....and they are not in Dave's paper.

regards, Neil

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: 10 November 2003 02:27
> To: MPLS wg
> Cc: George Swallow; Alex Zinin
> Subject: on the mpls oam framework
> 
> 
> All,
> 
> I read the mpls oam framework as it has been suggested in
> Dave Allans draft (draft-allan-mpls-oam-frmwrk) and also
> re-read the the mpls architecture document. I've the architecture
> authors to review the oam framework and received some feedback
> from them.
> 
> It is my understanding that there is a serious disconnect
> between the architecture and oam framework, and I therefore
> want to restart the oam framework in a fresh document,
> with the undertanding that this document shall be aligned
> with the architecture.
> 
> I asked David Allan and Tom Nadeau to take on the editorship
> for this new document, and hope to have positive answers from
> both of them before the mpls wg meeting in Minneapolis.
> 
> /Loa
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 10 Nov 2003 16:38:30 +0100

Neil,

I'm glad that you agree on the situation, and surprised on your
attitude towards the guiding documents in MPLS development.

We have the MPLS architecture and it is the starting point all
other mpls documents, and should be so for the mpls om framework
as well. To qoute you "Whether some people like it or not..."

/Loa