Subject: RE: on the mpls oam framework

From: "David Allan" <[email-masked]>
Date: Mon, 17 Nov 2003 10:16:43 -0500

Hi Tom:

<snipped>
> 	Sure, we can keep crying about the past, but I think
> we should just move forward with what we have.

I'm not. I'm sure I'm not the only person who has noted the oxymoron
inherent to the requirement "must support undocumented proprietary feature".
I'm suggesting it MUST be documented in order to proceed.

<snip>
> 	I do not believe that my algorithm(s) are documented 
> anywhere, nor do I think that Kireeti's, Curtis' or 
> otherwise.  I think this 
> is why tools/techniques we produce need to be flexible in 
> this area to support all types.  Throwing away what exists 
> today is not an option.

That's not the suggestion. The suggestion is that we only support what we
can see. Document what exists today so we can all participate in innovation.
We'll otherwise waste a lot of time figuring out what is redundant and what
is not. I'm not interested in wasting my time proposing solutions for some
"star chamber" to pick and choose from....

cheers
Dave

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 17 Nov 2003 10:33:08 -0500

>-----Original Message-----
>From: David Allan [mailto:[email-masked]] 
>Sent: Monday, November 17, 2003 10:17 AM
>To: [email-masked]'; [email-masked]; [email-masked]
>Cc: [email-masked]; [email-masked]
>Subject: RE: on the mpls oam framework 
>
>
>Hi Tom:
>
><snipped>

	I am suggesting that doing so is not a scalable
problem to solve.  Also practically speaking, I doubt
that anyone is going to divulge their exact algorithm.
It might be an interesting informational draft to 
produce such a compendium from anonymous sources, but
this always leaves open the door for one more algorithm.

>That's not the suggestion. The suggestion is that we only 
>support what we can see. 

	That sounds like you want connection-oriented
constructs only too. *)

> Document what exists today so we can all participate 
>in innovation.
>is not. I'm not interested in wasting my time proposing 
>solutions for some "star chamber" to pick and choose from....

	While I would of course agree that knowing all of the
algorithms would make things easier, I disagree that we cannot
move forward with solutions today. I think that solutions can be 
created to manage what is deployed today. There is clear evidence
of this already.

	--Tom