Subject: RE: on the mpls oam framework

From: [email-masked]
Date: Mon, 10 Nov 2003 17:52:15 -0000

Loa....you are misrepresenting my 'agreement on the situation'.   I agree there is a problem.....but has it ever occurred to you that the starting point may be wrong?  The problem is not that Dave's paper fails to line-up with the MPLS arch papers, the problem is that the MPLS arch (sic) stuff is itself architecturally broken......the mere act of 'doing' mp2p and PHP does not bless them with arch validity please note.  You can't expect Dave to fix that.....no doubt you also saw Dave's response.

I don't actually have any problem with all this *providing* people don't try and put a spin on things that are not correct to make them appear correct, ie one can't fix what is wrong/missing in MPLS by asking Dave to redo his paper...as its simply a statement of fact and is therefore 'right'.  One can fix the MPLS arch of course, but this starts with an admission of what is not right now.....and I don't see any strong signs of this happening (at least any time soon), that is the key difference and the real problem here.  

regards, Neil

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: 10 November 2003 15:38
> To: Harrison,N,Neil,IKR2 R
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: on the mpls oam framework
> 
> 
> Neil,
> 
> I'm glad that you agree on the situation, and surprised on your
> attitude towards the guiding documents in MPLS development.
> 
> We have the MPLS architecture and it is the starting point all
> other mpls documents, and should be so for the mpls om framework
> as well. To qoute you "Whether some people like it or not..."
> 
> /Loa
> 
> [email-masked] wrote:
> 
> >Loa,
> >
> >I agree there is a serious disconnect between the 
> 'architecture' and what is being done in some places in IETF, 
> eg PWE3.  Whether some people like them or not, G.805 and 
> G.809 respresent the functional architecture of all 
> technologies.....the former covers the co-cs and co-ps modes 
> and the latter the cnls mode, and all technologies map to one 
> of these modes.
> >
> >One must respect the architectural principles of the 
> networking mode in question or else problems arise 
> later.....the 'OAM problems' are one symptom of this.  The 
> classic example that springs to mind is a link-connection (ie 
> label) swapping co-ps forwarding mode (eg MPLS) that violates 
> the allowed topological constructs of that mode (which in 
> this case are p2p or p2mp) and terminates the trail 1 hop too 
> soon (ie PHP).  There should also be layer independence in a 
> simple client/server relationship, ie do not modify the client PDU.
> >
> >Keep the network architecture clean and the problems will 
> not exist.......Dave (Allan's) paper is, in general, simply a 
> survey of what has been 'done'.
> >
> >So please be very clear when identifying *where* the 
> disconnects exist.....and they are not in Dave's paper.
> >
> >regards, Neil
> >
> >  
> >
> >>-----Original Message-----
> >>From: Loa Andersson [mailto:[email-masked]]
> >>Sent: 10 November 2003 02:27
> >>To: MPLS wg
> >>Cc: George Swallow; Alex Zinin
> >>Subject: on the mpls oam framework
> >>
> >>
> >>All,
> >>
> >>I read the mpls oam framework as it has been suggested in
> >>Dave Allans draft (draft-allan-mpls-oam-frmwrk) and also
> >>re-read the the mpls architecture document. I've the architecture
> >>authors to review the oam framework and received some feedback
> >>from them.
> >>
> >>It is my understanding that there is a serious disconnect
> >>between the architecture and oam framework, and I therefore
> >>want to restart the oam framework in a fresh document,
> >>with the undertanding that this document shall be aligned
> >>with the architecture.
> >>
> >>I asked David Allan and Tom Nadeau to take on the editorship
> >>for this new document, and hope to have positive answers from
> >>both of them before the mpls wg meeting in Minneapolis.
> >>
> >>/Loa
> >>
> >>    
> >>
> >
> >  
> >
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 10 Nov 2003 20:54:31 +0100

Neil,

I don't a need to be right - but it still seems like we agree
that there is a problem, and that problemis that there is a
disconnect between the "oam framework" and the mpls archtecture,
isn't that true.

The rest is jus the pesonal opnions of you and me.

We disagree exactly on how things are broken, I take it that you
want to discard the mpls architecture, my point is that the mpls
architecture is one the guiding doucments for the mpls wg, and as
such served us fine so far, and would like to stay with it.

Though I don't see how we could push forward with an id that
some of the authors and editor agree is not aligned with the
mpls architecture.

/Loa

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 14 Nov 2003 22:14:39 -0800 (PST)

Hi Loa,

On Mon, 10 Nov 2003 [email-masked] wrote:

> ie one can't fix what is wrong/missing in MPLS by
> asking Dave to redo his paper...as its simply a statement of fact
> and is therefore 'right'.

As co-author of the wrong approach, I will be happy to help Tom with
his wrong OAM framework for the wrong MPLS architecture we so wrongly
have.  We would be wrong to make Dave wrong when he is so right.

Kireeti.
-------