Subject: RSVP Fastreroute.

From: Gopalkrishna Panicker <[email-masked]>
Date: Tue, 4 Nov 2003 22:28:52 -0800 (PST)

Hello,

I have question on rsvp-fastreroute(03.txt).

Consider the following network

  A-----B-----C-----E---F
  |           |
  |-----D-----|

I have a protected LSP via ABCEF. A has a detour
via D to protect against the failure of B.

At C, the detour is merged and the path message of
the protected LSP is refreshed.
This path message contains session attributes
and TSPEC of the protected LSP and a Fast Reroute
object.

Now if B fails and C's path state expires, Will
the path message being refreshed downstream from
C, be that of the detour LSP? That is  will
it carry a detour object ?
 
Now if Path Specific Method is being used, E will have
two path messages with same sender template and
incoming interface, but one of them has a FRR the
other Detour. Also, the Session attribute object and
TSPEC will be different.

Is this correct ? 

Thanks in advance,

Regards
Gopal 

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree

---

From: Pavan Beeram <[email-masked]>
Date: Wed, 05 Nov 2003 10:35:10 -0500

>it carry a detour object ?
If B fails, the primary path/resv state on C must not expire as long
as there is atleast one backup merging into C.
E should continue receiving primary path refreshes as if nothing has
happened upstream.

-Pavan