Subject: Re: Fast Reroute - local revertive

From: "Kellermann,Rurick" <[email-masked]>
Date: Mon, 24 Nov 2003 12:03:12 -0500

Atrjoh,

I still think that the interop. statement of section 6.5.2 refers only
to the fact that both PLR and the MP have to agree on supporting local
revertive in order for the MP to respond to the PLR's attempts to
resignal the TE LSP to the restored TE LSP. Note that the draft says
that this signaling will be done through the backup TE LSP.  

IMO, the other interop. issue is whether / how both modes can be
supported by the MP. The draft says the following:

<< It is recommended that one always use the globally revertive mode.
   Note that a link or node "failure" may be due to the facility being
   permanently taken out of service.  Local revertive mode is
   optional.  When used in combination, the global mode may rely
   solely on timers to do the reoptimization.>> 

If i'm reading this correctly, the MP may respond to the head-end LSR of each tunnel wrt. reoptimizing 
the TE LSPs that used the failed resource. But it can also respond to the PLR's initiative to switch 
the backup LSP to the protected TE LSP, if and only if, the MP and PLR support the local revertive.

Authors, could you please provide some input?

Rurick K.  

On Sun, 2003-11-23 at 02:19, [email-masked] wrote:
> I still didn't understand from your answer why if the MP is configured for 
> global revertive, it will reject the LSP if the PLR will try to resignal it over the restored resource.
> 
> "Kellermann,Rurick" <[email-masked]> wrote:
> 
> >IMO, it says that both the PLR and the MP have to agree to support local
> >revertive in order for the PLR to be able to resignal the TELSP over the
> >restored resource.
> >
> >If I compare this to the protection behaviour offered by APS, the
> >behaviour is equivalent to NON revertive APS....
> >
> >Rurick Kellermann
> >
> >
> >On Thu, 2003-11-20 at 12:00, [email-masked] wrote:
> >> I have a question regarding the local revertive behavior (section 6.5.2 fast reroute draft). The draft says: "Interoperability: If a PLR is configured with the local revertive mode but the MP is not, any attempt from the PLR to resignal the TELSP over the restored resource would fail as the MP will not send any Resv message...".
> >> Why the MP won't send the RESV message? 
> >> 
> >> __________________________________________________________________
> >> McAfee VirusScan Online from the Netscape Network.
> >> Comprehensive protection for your entire computer. Get your free trial today!
> >> http://channels.netscape.com/ns/computing/mcafee/index.jsp?promo=393397
> >> 
> >> Get AOL Instant Messenger 5.1 free of charge.  Download Now!
> >> http://aim.aol.com/aimnew/Aim/register.adp?promo=380455
> >> 
> >
> >
> 
> __________________________________________________________________
> McAfee VirusScan Online from the Netscape Network.
> Comprehensive protection for your entire computer. Get your free trial today!
> http://channels.netscape.com/ns/computing/mcafee/index.jsp?promo=393397
> 
> Get AOL Instant Messenger 5.1 free of charge.  Download Now!
> http://aim.aol.com/aimnew/Aim/register.adp?promo=380455

---

From: [email-masked]
Date: Sun, 23 Nov 2003 02:19:27 -0500