Subject: RE: [mpls] New Liaison Statement, "T-MPLS Consented Recommendatio ns"

From: Shahram Davari <[email-masked]>
Date: Tue, 11 Apr 2006 08:07:14 -0700

Hi Scott,

The tabel in G.8112 diesn't show any restriction on label range. It is in-line with RFC-3032. It just repeats which of the 32 reserved labels are already in use, and which are for FFS. It also mentions that all the remaining 2^20-32 labels could be used for T-MPLS. What restriction do you see in that?

-Shahram

> -----Original Message-----
> From: Scott W Brim [mailto:[email-masked]]
> Sent: Tuesday, April 11, 2006 10:55 AM
> To: Shahram Davari
> Cc: [email-masked]; 'Thomas D. Nadeau'
> Subject: Re: [mpls] New Liaison Statement, "T-MPLS Consented
> Recommendatio ns"
> 
> 
> On 04/11/2006 10:16 AM, Shahram Davari allegedly wrote:
> > Hi Tom,
> > 
> > 1) Reading the T-MPLS specs I didn't see any specific label 
> range restriction. Where have you seen this?
> 
> It's in G.8112.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Scott W Brim <[email-masked]>
Date: Tue, 11 Apr 2006 11:43:08 -0400

On 04/11/2006 11:07 AM, Shahram Davari allegedly wrote:
> Hi Scott,
> 
> The tabel in G.8112 diesn't show any restriction on label range. It
> is in-line with RFC-3032. It just repeats which of the 32 reserved
> labels are already in use, and which are for FFS. It also mentions
> that all the remaining 2^20-32 labels could be used for T-MPLS. What
> restriction do you see in that?
> 
> -Shahram

In 3032, labels 0-3 have special use and 4-15 are reserved.  G.8112
(table 6-7) extends this by saying: "16-31 For further study".  Existing
implementations use these labels by default -- some cannot be configured
not to.

Cisco put in a comment suggesting this be modified to "16-31  For
further study in consultation with the IETF".  The editor responded
suggesting "16-31 Not used in T-MPLS" and a note: "Labels 16-31 are, by
convention, not used in T-MPLS. If used in the future, they will be used
in the context of label pop, push or swap as defined in RFC3031 and
RFC3032."  I have trouble seeing the difference.